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Note the following details of the code protection feature on Microchip devices:

. Microchip products meet the specification contained in their particular Microchip Data Sheet.

. Microchip believes that its family of products is one of the most secure families of its kind on the market today, when used in the

intended manner and under normal conditions.

. There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our
knowledge, require using the Microchip products in a manner outside the operating specifications contained in Microchip’s Data
Sheets. Most likely, the person doing so is engaged in theft of intellectual property.

. Microchip is willing to work with the customer who is concerned about the integrity of their code.

. Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not

mean that we are guaranteeing the product as “unbreakable.”

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of our
products. Attempts to break Microchip’s code protection feature may be a violation of the Digital Millennium Copyright Act. If such acts
allow unauthorized access to your software or other copyrighted work, you may have a right to sue for relief under that Act.

Information contained in this publication regarding device
applications and the like is provided only for your convenience
and may be superseded by updates. It is your responsibility to
ensure that your application meets with your specifications.
MICROCHIP MAKES NO REPRESENTATIONS OR
WARRANTIES OF ANY KIND WHETHER EXPRESS OR
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OTHERWISE, RELATED TO THE INFORMATION,
INCLUDING BUT NOT LIMITED TO ITS CONDITION,
QUALITY, PERFORMANCE, MERCHANTABILITY OR
FITNESS FOR PURPOSE. Microchip disclaims all liability
arising from this information and its use. Use of Microchip
devices in life support and/or safety applications is entirely at
the buyer’s risk, and the buyer agrees to defend, indemnify and
hold harmless Microchip from any and all damages, claims,
suits, or expenses resulting from such use. No licenses are
conveyed, implicity or otherwise, under any Microchip
intellectual property rights.
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Preface

NOTICE TO CUSTOMERS

document.

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the

For the most up-to-date information on development tools, see the MPLAB® IDE online help.
Select the Help menu, and then Topics to open a list of available online help files.

INTRODUCTION

This chapter contains general information that will be useful to know before using the
PIC32MX. Items discussed in this chapter include:

Document Layout

Conventions Used in this Guide

Recommended Reading

The Microchip Web Site

Development Systems Customer Change Notification Service
Customer Support

Document Revision History

DOCUMENT LAYOUT

This document describes how to use the PIC32MX Starter Board as a development tool
to emulate and debug firmware on a target board. The user guide is composed of the
following chapters:

Chapter 1. “Introducing the PIC32MX USB Starter Board” provides a brief
overview of the PIC32MX USB Starter Board, highlighting its features and uses.
Chapter 2. “PIC32MX USB Starter Board Tutorial” provides step-by-step
instructions for installing the PIC32MX USB Starter Board and using the Microchip
MPLAB IDE to build and run the tutorial program on the PIC32MX USB Starter Board.
Chapter 3. “Create a New Project” provides step-by-step instructions for creating
a new project using the MPLAB® IDE and loading it onto the PIC32MX USB Starter
Board.

Chapter 4. “PIC32MX USB Starter Board Hardware” provides the hardware
description of the PIC32MX USB Starter Board.

Appendix A. “PIC32MX USB Starter Board Schematics” provides a block
diagram and detailed schematics of the PIC32MX USB Starter Board.

© 2008 Microchip Technology Inc. DS61150A-page 1
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description

Represents

Examples

Arial font:

Italic characters

Referenced books

MPLAB® IDE User’s Guide

Emphasized text

...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer
Quotes A field name in a window or dialog | “Save project before build”
Underlined, italic text with right A menu path File>Save
angle bracket
Bold characters A dialog button Click OK

A tab

Click the Power tab

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier New font:

Plain Courier New

Sample source code

#defi ne START

Filenames aut oexec. bat

File paths c:\nccl8\h

Keywords _asm _endasm static
Command-line options - Opa+, - Opa-

Bit values 0, 1

Constants (in source code) OxFF, ‘A

Italic Courier New

A variable argument

file.o,wherefile canbe any
valid filename

Square brackets [ ]

Optional arguments

nccl8 [options] file
[ opti ons]

Curly brackets and pipe
character: {| }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0]1}

Ellipses...

Replaces repeated text

var_name [, var_nane...]

Represents code supplied by user

void main (void)
{
}

DS61150A-page 2
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RECOMMENDED READING

This user’s guide describes how to use the PIC32MX USB Starter Board.

The following Microchip documents are available and recommended as supplemental
reference resources.

PIC32MX Data Sheet (DS61143)
Consult this document for detailed information on the PIC32MX 32-bit devices.
Reference information found in this data sheet includes:

« Device memory map

 Device pinout and packaging details
 Device electrical specifications

« List of peripherals included on the device

MPLAB® c32 C Compiler User’s Guide (DS51686)

This document details the use of Microchip’s MPLAB C32 C Compiler for PIC32MX
devices to develop an application. MPLAB C32 is a GNU-based language tool, based
on source code from the Free Software Foundation (FSF). For more information about
FSF, see their web site at http://www.fsf.org.

MPLAB® IDE User’s Guide (DS51519)

Consult this document for more information pertaining to the installation and
implementation of the MPLAB IDE software, as well as the MPLAB Editor and MPLAB
SIM Simulator software that are included with it.

Universal Serial Bus Specification and Associated Documents

The Universal Serial Bus is defined by the USB 2.0 specification and its associated
supplements and class-specific documents. These documents are available from the
USB Implementor’s Forum. See their website at http://www.usb.org.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at http://www.microchip.com. This
web site makes files and information easily available to customers. Accessible by most
Internet browsers, the web site contains the following information:

* Product Support — Data sheets and errata, application notes and sample
programs, design resources, user’s guides and hardware support documents,
latest software releases and archived software

« General Technical Support — Frequently Asked Questions (FAQs), technical
support requests, online discussion groups, Microchip consultant program
member listings

« Business of Microchip — Product selector and ordering guides, latest Microchip

press releases, listings of seminars and events; and listings of Microchip sales
offices, distributors and factory representatives

© 2008 Microchip Technology Inc. DS61150A-page 3
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DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip’s customer notification service helps keep customers current on Microchip
products. Subscribers will receive e-mail natification whenever there are changes,
updates, revisions or errata related to a specified product family or development tool of
interest.

To register, access the Microchip web site at http://www.microchip.com, click on Cus-
tomer Change Notification and follow the registration instructions.

The Development Systems product group categories are:

e Compilers — The latest information on Microchip C compilers and other language
tools. These include the MPLAB C18, MPLAB C30, and MPLAB C32 C compilers;
ASM32, MPASM™ and MPLAB ASM30 assemblers; MPLINK™, and MPLAB
LINK30, MPLAB LINK32 object linkers; and MPLIB™ and MPLAB LIB30 object
librarians.

« Emulators — The latest information on Microchip in-circuit emulators. This
includes the MPLAB REAL ICE™ and MPLAB ICE 2000 in-circuit emulators.

« In-Circuit Debuggers — The latest information on the Microchip in-circuit
debuggers. This includes the MPLAB ICD 2 and PICKkit™ 2.

« MPLAB IDE — The latest information on Microchip MPLAB IDE, the Windows®
Integrated Development Environment for development systems tools. This list is
focused on the MPLAB IDE, MPLAB IDE Project Manager, MPLAB Editor and
MPLAB SIM simulator, as well as general editing and debugging features.

* Programmers — The latest information on Microchip programmers. These include
the MPLAB PM3 device programmer and the PICSTART® Plus, PICkit™ 1 and
PICkit 2 development programmers.

CUSTOMER SUPPORT

Several channels are available to assist the users of Microchip products:

« Distributor or Representative

 Local Sales Office

« Field Application Engineer (FAE)

» Technical Support

« Development Systems Information Line

Customers should contact their distributor, representative or FAE for support. Local
sales offices are also available to help customers. A list of sales offices and locations
is included in the back of this document.

Technical support is available through the web site http://support.microchip.com.

DOCUMENT REVISION HISTORY

Revision A (June 2008)
This is the initial release of the PIC32MX USB Starter Board User’s Guide.

DS61150A-page 4 © 2008 Microchip Technology Inc.
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Chapter 1. Introducing the PIC32M X USB Sarter Board

1.1 INTRODUCTION

Thank you for purchasing the Microchip Technology PIC32MX USB Starter Board. This
board provides a low-cost, modular development system for Microchip’s new line of
32-bit microcontrollers.

The starter board comes pre-loaded with demonstration software for the user to
explore the new features of the PIC32MX. It is also expandable through a modular
expansion interface, which allows the user to extend its functionality. The PIC32MX
USB Starter Board also supplies on-board circuitry for full debug and programming
capabilities.

1.2 HIGHLIGHTS

This chapter covers the following topics:

« Kit Contents

* PIC32MX Functionality and Features

The preprogrammed example code on the PIC32MX MCU is available via download.
All project files have been included, so that the code may be used directly to restore
the PIC32MX MCU on the starter board to its original state (i.e., if the sample device
has been reprogrammed with another program) or so you can use the tutorial code as
a platform for further experimentation. Refer to Section 2.4 for download and
installation instructions.

1.3 KIT CONTENTS

The PIC32MX USB Starter Board contains the following items:
e PIC32MX USB Starter Board

« USB Mini-B to full-sized A cable — USB debug cable to debug and power the
board

+ USB Micro-B to full-sized A cable — PIC32 USB cable to communicate with the
PI1C32 USB port

If you are missing any part of the kit, contact a Microchip sales office for assistance. A
list of Microchip offices for sales and service is provided on page 36.

© 2008 Microchip Technology Inc. DS61150A-page 5
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1.4 PIC32MX FUNCTIONALITY AND FEATURES

A representation of the layout of the PIC32MX USB Starter Board is shown in
Figure 1-1. The board includes these key features, as indicated in the diagram:
1. PIC32MX460F512L 32-bit microcontroller

2. Green power-indicator LED

3. Regulated +3.3V power supply for powering the starter board via USB or
expansion board

4. On-board crystal for precision microcontroller clocking (8 MHz)

5. USB connectivity for on-board debugger communications

6. PIC18LF4550 USB microcontroller for on-board debugging

7. Orange Debug indicator LED

8. Three push-button switches for user-defined inputs

9. Three user-defined indicator LEDs

10. Connector for various expansion boards (on the underside of board)

11. USB Type A receptacle connectivity for PIC32MX Host based Applications

12. USB Type Micro-AB receptacle for OTG and USB Device connectivity for
PIC32MX OTG/Device based Applications (on the underside on board)

13. USB Host and OTG power supply for powering PIC32MX USB applications.

Note 1: To power Rev B boards, the USB debug cable must be connected to a
USB port on the host PC.

2. When running USB device applications, open the jumper JP2 to prevent
possibly back-feeding voltage onto VBUS from one port on the host to
another (or from one host to another).

FIGURE 1-1: PIC32MX USB STARTER BOARD LAYOUT
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Chapter 2. PIC32M X USB Sarter Board Tutorial

2.1 INTRODUCTION

This chapter is a self-paced tutorial to get you started using the PIC32MX USB Starter
Board.

2.2  HIGHLIGHTS

Items discussed in this chapter include:

« Host Computer Requirements

« Installing the PIC32MX USB Starter Board Software
 Using the PIC32MX USB Starter Board Out of the Box
« Starting the Tutorial Project

« Building the Project

* Programming the Device

* Running the Program

 Tutorial Program Operation

2.3 HOST COMPUTER REQUIREMENTS

To communicate with and program the starter board, the following hardware and
software requirements must be met:

* PC-compatible system

« Two available USB ports on PC or powered USB hub

« Microsoft Windows XP® or Windows Vista® operating system
(The PIC32MX USB Starter Board has not been tested on Windows NT® and
Windows 2000® operating systems.)

2.4  INSTALLING THE PIC32MX USB STARTER BOARD SOFTWARE

Starter board software and installation instructions are available on the Microchip.com
web site at the following URL.: http://www.microchip.com/PIC32USBboard. The web
page will guide you through installation and setup of MPLAB IDE, MPLAB C32 C
Compiler, and the demo projects. The page also provides links to other technical
documents. After completing the online installation instructions, continue to the next
section in this document.

© 2008 Microchip Technology Inc. DS61150A-page 7
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2.5 USING THE PIC32MX USB STARTER BOARD OUT OF THE BOX

Install software (instructions in section 2.4) before connecting the board to the host PC.
The PIC32MX USB Starter Board may be used directly from the box as a
demonstration board for the PIC32MX device. The PIC32MX is preprogrammed with
the classic “Simon Says” game (si non_says_deno. hex) in the PIC32MX460F512L
device and is ready for immediate use.

25.1 How to Play the Game

When the USB debug cable is plugged into the starter board’s Mini-B (debug) recepta-
cle, the three LEDs start blinking to indicate the start of a new game. Begin the game
by pressing one of the switches, SW1-SW3, to choose the level of game difficulty. SW3
is the easiest, SW1 is the hardest. The goal is to imitate the light patterns as long as
you can, without getting frazzled. Ultimately, you will make a mistake and all of the
LEDs will light up to signal the end of the game. After a brief pause, you can press any
switch to start a new game.

If you launch MPLAB IDE and connect to the starter board while the game is running,
the game will stop. Further, if you perform a debug or program operation from MPLAB
IDE, the demo application will be replaced with the current MPLAB project application.
However, the game can be reloaded onto the starter board by opening the file
si non_says_deno. ncwfrom c: \ Program Fi | es\ M cr ochi p\ pi ¢32_sol uti ons\

si mon_says_deno.

The preprogrammed example code on the PIC32MX has been included in the
PIC32MX USB Starter Board demo-projects download file located at the following URL:
http://www.microchip.com/PIC32USBboard. All project files have been included, so
that the code may be used directly to restore a PIC32MX to its original state (i.e., if the
sample device has been reprogrammed with another program), or so you can use the
tutorial code as a platform for further experimentation.

DS61150A-page 8
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2.6 STARTING THE TUTORIAL PROJECT

FIGURE 2-1:

Connect the starter board to the host PC and click the MPLAB IDE icon on your
computer desktop. Select File>Open Workspace... from the menu bar and browse to
the tutorial project file: c: \ pi ¢c32_sol uti ons\ usb_hi d_nouse_devi ce_deno\

St art er Boar d_Mbusedeno. ntw

(or browse to the file path that you used when you installed the MPLAB IDE).

The pane on the left of the MPLAB IDE interface displays project files, the *. ¢’, *. h’ and
‘.a’ (library) files that are used to build an application. The project files are organized by
type into folders.

Select Debugger>Select Tool>PIC32MX Starter Kit from the menu bar. “Starter Kit
Found” should then be displayed in the “Output” pane of the MPLAB IDE interface. If
not, check the driver installation, as well as the connections between the hardware and
the PC.

MPLAB® IDE WORKSPACE

W usb_hid_mouse_device_demo_starter_board_pic32Zmxz460f5121 - MPLAB IDE v8.02 - [C:'pic32_solutions',Microchip == x|
I File Edit Yiew Project Debugger Programmer Tools Configurs  ‘Window Help 18] x|
DEH|smE(SGA®T? [biw JoSEBO [ cnall @pvannynun| v uwn o]

EID Source Files

db_utils.h

usb_config.h

[ushihidimuuseideviceidemuislaneriboar@ P+++++++4-4-4-4.4-+4-+4-+4-+4-+4-+4-+4-*4-*4-*+++++++++4—+4-+4-+4-+4-+4-+4-+4-+4-+4-+4-++++++++++4—+4—+§

= [ c:4pic32_solutionstusb_hid_mouse_device_t

- \MicrochipilISE\hid_device_driverifid.c This file implements the USE device abstraction.
AMicrochip\USB\usb_device.c

- \MicrochipiUsB|usb_hal.c & Palomermg el @
\MicrochipiUSBiusb_hal_care.c * Dependancies: TED
mouse_demo,c * Processor: TED
mouse_dsc.c * Hardware: TED
mouse_teport.c * Assembler: TED
5-E2 Header Files * Linker: TED
[E) .. \MicrochiptIncludetushihiddesc.h * Company: Microchip Technology, Ine.

\MicrochipiIncludetusbhidreport. b
. \MicrachipiIncludetusbiusb.h Software License Agreement

. \MicrochipiIndudetusbiusb_cha.h
\MicrochipiIncludetusbiush_common. b
\Microchip\Includeusblusb_device.h

. \MicrochipiIndudetusblush_device_hid.h
AMicrochipiIncludetusbiush_hal.h

. \Microchip\USE\hid_device_driver\hidpri.h

HardwareProfile.h user to criminal ssnetions under applicsble lsws, as well as to

USE Human Interface Device [(HID) Function Driver

The software supplied herewith by Microchip Technology Incorporated
[the "Company”) for its PICmicro® Microcontroller is intended and
supplied to you, the Company’s customer, for use solely and
exclusively on Microchip PICmicro Microcontroller products. The
software is owned by the Company and/or its supplier, and is
protected under applicsbhle copyright laws. All rights are reserved.
Any use in wiolation of the foregoing restrictions may subject the

civil liskility for the breach of the terms and conditions of this

[0 Object Files license.
-2 Library Files =
db_utils.a JLI—I :
[ Linker Seript [Output =
0 other Fies Euild I Wersion Controll Find in Files ~ MPLAB PIC3ZMX
[Debugger] Starter Kit Found
KN i
(2] Files IOL: Svmbo|5|
|P1C32M% Starter | [PIC32MR4E0FS12L |pe:0xbfenoong | [tnt, ol 1 NS [wR
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2.7 BUILDING THE PROJECT

From the menu bar of the main MPLAB IDE window, click Project>Make. The build
Output window displays, as shown in Figure 2-2.

Observe the progress of the build. When the “BUILD SUCCEEDED” message displays,
you are ready to program the device.

FIGURE 2-2: BUILD OUTPUT WINDOW

|Output [x]
Build | ersion Control | Firdin Files | MPLAB PIC32h:< |

2MXSK=1.-Map="0hjects - usb_hid_mouse_device_demo_starter_board_pic32mx460{51 2I"-,usb_hid_mouse_device_ded
Executing: "ChiProgram FilesiMicrochiphWMPLAE C32vhinypic3Z-binZhex.exe" "Chpic32_solutionsiushb_hid_mouse_dewvice
Loaded Chpic3Z2_solutionsiusb_hid_mouse_device_demao\Ohbjects - ush_hid_mouse_device_demo_starter_board_pic

Debug build of project "Clpic3Z2_solutionsiush_hid_mouse_device_demoiusb_hid_mouse_device_demo_starter_boan
Preprocessor symbol "__DEBUG' is defined.

Target debug platform is __MFLAB_DEBUGGER_FIC32MXSK=1".

Maon Apr 07 16:25:22 2008

BUILD SUCCEEDED _lJ
»

KT I—
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2.8 PROGRAMMING THE DEVICE

2.8.1 Program the Device

Click on the Program All Memories icon on the Program Device Tool Bar, as shown in
Figure 2-3.

FIGURE 2-3: PROGRAM DEVICE TOOL BAR

R AR R R R R R R A R E A AR T A AR A R AR R A A AR R A AR T AR TR A RAGHST

3TARTER EIT Tutorial README

A Programming Warning window, shown in Figure 2-4, opens to warn you about over-
writing the memory. Click Yes.

FIGURE 2-4: PROGRAMMING WARNING WINDOW

Programming Warning

Are you sure you want to program {overwrite) the
progran, boot, and configuration memaries?

Lwes | [ |

[0 not show this warning again,

The Output window, shown in Figure 2-5 tracks the progress of the output. A “Done
entry indicates that the programming of the device is complete.

FIGURE 2-5: OUTPUT WINDOW

‘Output E”
Build | Version Control | Findin Files MPLAB PIC32MX
[Debugger] Starter Kit Found

All Memaries
Erasing
Program Memory:
Programming
zDone
Boot Mermory and Configuration Memaory:
cProgramrming...
“Dane
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2.9 RUNNING THE PROGRAM
Either click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon

(the turquoise triangle) on the Debug Tool Bar, shown in Figure 2-6, to run the new
program.

FIGURE 2-6: DEBUG WINDOW

WM D oo B G E|| Chek

o e e i e e e O i

2.10 TUTORIAL PROGRAM OPERATION

The USB Human Interface Device (HID) mouse tutorial project demonstrates a simple
USB peripheral device by emulating a mouse. Depending on the revision of your USB
starter board, make the following connections to run the mouse demo.
» For Rev B of the USB starter board, the host PC must have two available USB
ports:
1. Move jumper JP2 to the open position.
2. Use the USB debug cable (Mini-B to A) to attach the board’s debug connector

J1 to the first USB port of the host PC. Rev B boards source power from the
debugger connection.

3. Use the USB Micro-B to full-sized A cable to attach the board’s J5 connector
(type Micro-AB receptacle) to the second USB port of the host PC.
» For a later revision of the USB starter board:
1. Move jumper JP2 to the open position.
2. Use the USB Micro-B to full-sized A USB cable to attach the board’s J5
connector (type Micro-AB receptacle) to an available USB port on the host PC.

Note: For the HID mouse demo (and all other USB device demos), the JP2
jumper should be open to prevent the possibility of back-feeding voltage
onto VBus from one port on the host to another (or from one host to
another).

After a pause, the PIC32MX USB Starter Board will enumerate as a standard mouse
HID, using drivers built into the host’s operating system. The successful completion of
this process is usually accompanied by a “bing-bong” tone from the host PC. The

output window will display a message indicating that the demo is running, as shown in
Figure 2-7.

DS61150A-page 12 © 2008 Microchip Technology Inc.
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FIGURE 2-7: OUTPUT WINDOW

[Output
Build | Wersion Control | Findin Files MPLAB PIC32hx
[Debugger] Starer Kit Found

All Memories:

=Erasing...

Program Mermory:

zProgramming....

z:Dane

Boot Memary and Configuration Memany:

zProgramming....

=:Done

[TargetDUT] *==*FICZ32 USE HID Device Demo ==

[TargetDUT] W1 =Down SW2=Right SW3=Rewverse SWT/SWE Direction

Running. .. (1 [1]]

To move the mouse cursor, press the button switches on the starter board. Table 2-1
shows the action associated with each button.

TABLE 2-1: BUTTONS FOR CURSOR MOVEMENT

Button Pressed Mouse Cursor Action
Swi Moves Cursor Down
SW2 Moves Cursor to Right
SW1 and SW3 Moves Cursor Up
SW2 and SW3 Moves Cursor Left

To disable the HID mouse demo, disconnect the host PC from the Micro-AB receptacle
on the starter board. The host PC usually plays a reverse “bong-bing” tone to indicate
the successful disconnection of the peripheral device.

© 2008 Microchip Technology Inc. DS61150A-page 13
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NOTES:
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Chapter 3. Createa New Project

3.1 INTRODUCTION

This chapter explains how to create a new project.

3.2 HIGHLIGHTS

Items discussed in this chapter include:

« Creating a New Project

« Building the Project

* Programming the Device

* Running the Program

After completing this chapter, you should be able to accomplish the following tasks:
 Create a project using the Project Wizard

« Assemble and link the code, and set the Configuration bits

« Set up the MPLAB IDE to use the PIC32MXUSB Starter Board

« Program the chip and run the program

3.3 CREATING A NEW PROJECT
The first step is to create a project and a workspace in the MPLAB IDE. Typically, there
is a single project per workspace.

A project contains the files needed to build an application (i.e., source code, header
files, library, etc.), and their corresponding build options.

A workspace contains one or more projects, information on the selected device,
debug/programmer tool, and MPLAB IDE configuration settings.

MPLAB IDE contains a Project Wizard to help create a new project.
You will perform the following tasks as you create a new project:

Task 1, Select a DeVICe......ocooieiiiiiiiiiiiieeee e page 16
Task 2, Select the Language Toolsuite .........cccccvveeeeeennn. page 17
Task 3, Name Your Project ......cccceeveiiiiniiiniiiiiiiiieeeeeeen page 18
Task 4, Add Files to Your Project .........oooociiiieieiiennennnnn. page 19
Task 5, Confirm the Configuration Settings .......c............ page 21
Task 6, Build the Project ..., page 22
Task 7, Program the DevViCe .........ccccceeeiiiiiiiiiiiiiieeeeeeee, page 23
Task 8, Run the Program.......ccccccccvvveeeii i, page 24

© 2008 Microchip Technology Inc. DS61150A-page 15
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3.3.1 Task 1, Select a Device
1. Start MPLAB IDE.
2. Click File>Close Workspace on the menu bar, to close any open workspace.
3. Click Project>Project Wizard... to start the wizard.
4. In the Welcome window, click Next. The Project Wizard Step One: window is
displayed, as shown in Figure 3-1.
FIGURE 3-1: SELECTING THE DEVICE
Project Wizard x|
Step One: E
Select & device
/&
Device:
< Back I MHeut » I Cancel Help

5. From the “Device” drop-down list, select “PIC32MX460F512L".
6. Click Next. The Project Wizard Step Two: dialog box opens, see Figure 3-2.

DS61150A-page 16
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FIGURE 3-2:

SELECTING THE TOOLSUITE

Project Wizard gl

Step Two:
Select alanguage toalsuite

Active Toolsuite: | Micrachip PIC32 C-Compiler T oolsuite

Toolzuite Contents

el |
MPLAE C32 C Compiler [pic32-goc.exe]
MPLAE LIME32 Object Linker [pic32-d.exe)
KPP &R 1T IRI2 Mhiact | ikrananfd rehivear (mie 32250 awal

Location

|C:'\F'rogram Filez'\MicrochiphMPLAR C32\binhpicdz-az exe

| [ Browse...

| Helpl My Suite Isn't Listed!

[ 5kow all installed toolsuites

[ ¢ Back “

Mest > ] [ Cancel ] [ Help

3.3.2

Task 2, Select the Language Toolsuite

1. From the “Active Toolsuite” drop-down list, click “Microchip PIC32 C Compiler
Toolsuite”. The toolsuite includes the compiler, assembler and linker that will be
used. If the PIC32 compiler option is not available, check the “Show all installed

toolsuites” box.

2. Click Next to continue. The Project Wizard Step Three: dialog opens, as shown

in Figure 3-3.

© 2008 Microchip Technology Inc.
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FIGURE 3-3: NAMING YOUR PROJECT

Project Wizard

Step Three:
Create a new project, or reconfigure the achive project?

(%) Create Mew Project File
C:\MyProjecthBlinkLED ' Browse.. |

Browse...

¢ Back “ Mest » ][ Cancel ][ Help

3.3.3 Task 3, Name Your Project

1. Inthe “Create New Project File” field, type C:\MyProject\BlinkLED.

2. Click Next and Ok to continue. The Project Wizard Step Four: dialog opens, as
shown in Figure 3-4.
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FIGURE 3-4: ADDING FILES TO THE PROJECT

%]

Project Wizand

Step Four: Eﬁ
£

Add exizting files to pour project

i5:
a2

¢ Back “ Mest > ][ Cancel ][ Help

3.34 Task 4, Add Files to Your Project

This window can be skipped, since no ‘. ¢’ files have been created.

1. Click Next to continue.

2. Click Finish on the summary screen. A project and workspace have been
created in the MPLAB IDE.
Bl i nkLED. ncwis the workspace file and Bl i nkLED. ntp is the project file.

3. Click Eile>New from the menu bar to create a new file. A new file is created.

4. Click Eile>Save As... and save this file as ‘bl i nkLED. ¢’ in the same folder, in this
case, the C:\ MyPr oj ect folder.

5. Now copy the source code provided in Example 3-1 to the bl i nkLED. ¢ file.

© 2008 Microchip Technology Inc. DS61150A-page 19
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EXAMPLE 3-1: PROJECT SOURCE CODE

#i ncl ude <plib. h> /* include PIC32 peripheral library */
int main(void)
{
int i;
/* Setup LED s */
nmPORTDC earBit s(BI T_0); /* Turn off LEDL on startup */
nmPORTDSet Pi nsDi gi tal Qut (BI T_0); /* Make RDO (LEDl1l) as output */
nmPORTDC earBits(BIT_1); /* Turn off LED2 on startup */
mMPORTDSet Pi nsDi gi tal Qut (BI T_1); /* Make RD1 (LED2) as output */
mMPORTDCl ear Bit s(BI T_2); /* Turn off LED3 on startup */
mMPORTDSet Pi nsDi gi tal Qut (BI T_2); /* Make RD2 (LED3) as output */
whi | e(1)
{
for(i=0; i<200000; i++); /* put a delay */
nPORTDToggl eBit s(BI T_0) ; /[* turn ON LED1 */
for(i=0; i<200000; i++); /* put a delay */
nPORTDToggl eBits(BI T_1); /[* turn ON LED2 */
for(i=0; i<200000; i++); /* put a delay */
nmPORTDToggl eBits(BI T_2); /* turn ON LED3 */
b
return O;
}

6. Inthe Project window, right-click on the Source Files folder. Select Add Files and
choose bl i nkLED. ¢ to add the file to the source directory, see Figure 3-5.

FIGURE 3-5: ADDING SOURCE FILES

BlinkLED.mcw X

- [ BlinkLED.mcp
Source Files,
[ Header File:
] Ohject Files|  Filter

] Library Files 1
[ Linker Scripks

[ other Files

Add Files. ..

[2] Files | ¥ Symbols

7. Click Debugger>Select Tool>PIC32MX Starter Kit from the menu bar, for the
Target board.

Note: Make sure that the starter board is connected to your PC.
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3.3.5

Task 5, Confirm the Configuration Settings

Click Configure>Configuration Bits to confirm that the configuration settings are

correct.

Typical configuration settings for the starter board are shown in Figure 3-6.

Note: The configuration settings can also be embedded in the source file. See
the MPLAB C32 C Compiler User’s Guide (DS51686) for information.
FIGURE 3-6: CONFIGURATION BIT SETTINGS
Ml Configuration Bits i [m] ]
™ Configuration Bits set in code.
Address Value Category Setting
Z2FFC 11FFFO0L ey Channel Select ICE EMNU MUDE pins shared with P
Boot Flash Write Protect Boot Flash is writable
Code Protect Protection Disabled
1FCO_ZFF& 00008243 Oscillator Selection Bits Primary Osc w/PLL (XT+, H3+, EC+PLL)
Secondary Oscillator Enable Disshled
Internal/External Switch Cver Disabled
Primarv Oscillator Configuration HZ osc mode
CLED Output Signal Active on the OSCO Pin Dissbled
Peripheral Clock Divisor Pb_Clk is Sys_Clk/1
Clock Switching and Monitor Selection Clock switching disabled; fail safe clock monitor disabled
Watchdog Timer Postscaler 1:1
Watchdog Timer Ensble WDT Disabled (SWDTEN Bit Controls)
1FCO_2FF4 00000101 PLL Input Divider 2x Diwvider
PLL Multiplier 15x Multiplier
USE PLL Input Diwvider 2x Diwvider
U3E PLL Enshle Enabled
System PLL Output Clock Diwvider PLL Diwvide by 1
1| | »
Note: The “Configuration Bits set in code” check box must be unchecked if the

config bits are set via this window and not in the code.

© 2008 Microchip Technology Inc.
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3.3.6 Task 6, Build the Project

1. Click Project>Make from the menu bar of the main MPLAB IDE window. The
build Output window displays (Figure 3-7).

2. Observe the progress of the build. When the “BUILD SUCCEEDED” message
displays, you are ready to program the device.

FIGURE 3-7: BUILD OUTPUT WINDOW

Build | “ersion Control | Find in Files | MPLAE PICI2M3,

Clean: Delsting intermediary and outputfiles, ~
Clean: Deleted file "CA\MyProjectiblinkLED.o".

Clean: Deleted file "CA\yProjectBlinkLED elf".

Clean: Deleted file "CAMyProjectBlinkLED hex".

Clean: Deleted file "CA\MyFrojectBlinkLED mcs".

Clean: Done.

Executing: "CAProgram Files\kMicrochiphtdPLAE C32\hinkmic
Executing: "CAPragram Files\MicrochiphtFLAE C32\ainkaic
Executing: "CAProgram Files\MicrochiphWPLAE C32\inkaic
Loaded CAMyProjectBlinkLED. elf.

BUILD SUCCEEDED: Fri Sep 28 15:39:24 2007

4 *
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3.3.7 Task 7, Program the Device

1. Click the Program All Memories icon on the Program Device Tool Bar, as shown
in Figure 3-8.

FIGURE 3-8: PROGRAM DEVICE WINDOW

cpa| B aesR imuxk|| » me

Ee i ol e e e i e e i i o e e e e

ATARTEER KIT Tutorial README

A Programming Warning window opens to warn you about overwriting the memory, as
shown in Figure 3-9.

2. Click Yes.

FIGURE 3-9: PROGRAMMING WARNING WINDOW

Programming Warning

Are you sure you want to program {overwrite) the
program, boot, and configuration memories?

I Yes ] [ Mo ]

[150 nat show this warning again.;

The Output window, shown in Figure 3-10, tracks the progress of the output. “Done”
signals that the programming of the device is complete.

FIGURE 3-10: OUTPUT WINDOW

Build | Wersion Contral | Find in Files | MPLABR PIC3ZMx

=:Erasing... ~
Frogram temony.

z:Dane

Boot Mermary and Configuration Memany:

2:Dane

All Mermories:

=Erasing...

Program hMemory:

zProgramming....

2:Dane

Boot Memory and Configuration Memaony:

zProgramming....

2:Dane w
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3.3.8 Task 8, Run the Program

Click Debugger>Run from the menu bar of the MPLAB IDE or click the Run icon (the
turquoise triangle) on the Debug Tool Bar, as indicated in Figure 3-11, to run the new
program.

FIGURE 3-11: RUN THE PROGRAM

WM D oo B G E|| Chek

o e e i e e e O i

The starter board LEDs blink to indicate that the program is running successfully.
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Chapter 4. PIC32M X USB Sarter Board Hardware

41 INTRODUCTION
This chapter describes the hardware features of the PIC32MX USB Starter Board.

4.2 HARDWARE FEATURES

The key features of the PIC32MX USB Starter Board are listed below. They are presented
in the order given in Section 1.4 “PIC32MX Functionality and Features”. You can refer
to Figure 1-1 on page 6 for their locations on the board.

42.1 Processor Support

The PIC32MX USB Starter Board is designed with a permanently mounted (i.e.,
soldered) PIC32MX460F512L processor.

4.2.2 Power Supply
There are three ways to supply power to the PIC32MX USB Starter Board:

» USB bus power connected to USB debug connector J1.

« USB bus power connected to PIC32 USB connector J5 — if using Rev C or later
revision of the board.

» An external application board with a regulated DC power supply that provides +5V
can be connected to the J2 application board connector that is provided on the
bottom side of the board.

One green LED (D3) is provided to show that the PIC32 microcontroller is powered up.

4.2.3 Debug USB Connectivity

The PIC32MX USB Starter Board includes a PIC18LF4550 USB microcontroller that
provides debugger connectivity over USB. The PIC18LF4550 is hard-wired to the
PIC32MX device to provide two types of protocol translation:

« 1/0O pins of PIC18LF4550 to ICSP™ pins of PIC32MX

* 1/O pins of PIC18LF4550 to JTAG pins of PIC32MX

The PIC32MX USB Starter Board currently uses the JTAG pins of the PIC32MX device
for programming and debugging.

© 2007 Microchip Technology Inc. DS61150A-page 25
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4.2.4 PIC32MX USB Connectivity

There are three possible ways to connect to the PIC32MX USB microcontroller:
« HOST Mode

Connect the device to the Type A connector J4, located on the top side of the USB
starter board. If using the Debug USB port to power the Host port, install jumper JP2 to
short the back-power prevention diode. Note that a maximum of ~400 mA can be
supplied from the Debug USB port to the Host port using this method. If the full 500 mA
supply is needed, an external supply must be connected to the application board. Also,
remove JP2 to prevent back powering the Debug USB port.

» DEVICE Mode

First, connect the debug Mini-B USB cable to port J1. Next, connect the USB starter
board to the host using a cable with a Type-B Micro plug to the USB starter board’s
Micro A/B port J5, located on the bottom side of the USB starter board. The other end
of the cable must have a Type-A plug. Connect it to a USB host.

« OTG Mode

Connect the USB starter board to the OTG device using an OTG Micro A/B cable to the
Micro A/B port J5, located on the bottom side of the USB starter board. The USB starter
board provides an on board power supply capable of providing 120mA Max. This
supply is controlled by the PIC32MX460 microcontroller.

4.2.5 Switches

Push-button switches provide the following functionality:

* SW1: Active-low switch connected to RD6

* SW2: Active-low switch connected to RD7

* SWa: Active-low switch connected to RD13

The switches do not have any debounce circuitry and require the use of internal pull-up

resistors; this allows you to investigate software debounce techniques. When Idle, the
switches are pulled high (+3.3V). When pressed, they are grounded.

4.2.6 LEDs

The RDO through RD2 LEDs are connected to PORTD of the processor. The PORTD
pins are set high to light the LEDs.

4.2.7 Oscillator Options

The installed microcontroller has an oscillator circuit connected to it. The main oscillator
uses an 8 MHz crystal (Y2) and functions as the controller’s primary oscillator. Use of
an external crystal is required to develop USB applications. USB specification dictates
frequency tolerance of +/- 0.25% for full speed. Non-USB applications can use the
internal oscillators. The USB starter board also has provisions for an external
secondary oscillator (Y3); however, this is not populated.

The PIC18LF4550 is independently clocked and has its own 8 MHz crystal (Y1).
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4.2.8 120-Pin Modular Expansion Connector

The PIC32MX USB Starter Board has been designed with a 120-pin modular
expansion interface, which allows the board to provide basic generic functionality now
and easy extendability to new technologies as they become available.

TABLE 4-1: STARTER BOARD CONNECTOR PART NUMBERS
HIROSE Electric PN

Starter Board Connector FX10A-120P/12-SV1(71)
Application Board Connector FX10A-120S/12-SV(71)
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NOTES:
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Appendix A. PIC32M X USB Sarter Board Schematics

A.1 INTRODUCTION

This section provides detailed technical information about the PIC32MX USB Starter
Board.

A.2 DEVELOPMENT BOARD BLOCK DIAGRAM

FIGURE A-1: HIGH-LEVEL BLOCK DIAGRAM OF THE PIC32MX USB STARTER BOARD
+33V —p|| USB OTG
Device Power )
” «——» Device/lOTG
f;g ?2; Max (Type Micro A/B)
vusB® or VUSB or
e +OV_EXT USB Host Host
— | | Power Supply ¢ —> (Type A)
ICSpP™ —
Debug USB ITAG

+5V EXT ¢—|

<«—»| PIC18LF4550

PIC32MX460F512L

Switches

LEDs <«

€

Application Board Connector

Note 1: From Debugger USB Port

A.3 STARTER BOARD SCHEMATICS

Figure A-2. PIC32MX CPU
Figure A-3. PIC18LF4550 Debug CPU
Figure A-4. Application Board Connector
Figure A-5. Switches and LEDs
Figure A-6. +3.3V Power Supply

USB HOST Power Supply

USB Device/OTG Power Supply
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FIGURE A-4:

PIC32MX SCHEMATIC, SHEET 3 OF 6 (APPLICATION BOARD CONNECTOR)
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FIGURE A-5: PIC32MX SCHEMATIC, SHEET 5 OF 6 (SWITCHES AND LEDS)
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FIGURE A-6:

PIC32MX SCHEMATIC, SHEET 6 OF 6 (POWER SUPPLY)
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