Genie -NX

Instruction Manual
Genie-NX provides the right solution for all your control needs!

Providing excellent performance and functionality, Genie-NX performs simple logic, timing, counting, and real time clock operations. It is an ideal programmable controller for simple control applications such as building construction equipments, HVAC, parking lot lighting and other applications in which cost is a primary design issue. All programming and data adjustments can be done via the on-board keypad and display or with the help of a software.

Programming Genie-NX with the help of G-Soft NX configuration software is quite simple, without particular programming knowledge. It facilitates program generation, project simulation and documentation which are accomplished simply using the pick and place functionality, allowing maximum ease of operation.

Some of its features are:

- Integrated, ready to use, wide range of programmable functions including 16 timers, 16 (retentive selectable) counters, 16 time switches, 16 compare counters, 16 soft text messages, 32 auxiliary relays and 12 analog comparators.
- 8 digital inputs & 4 relay outputs. Two analog inputs (0-10V) in 12-24VDC, model which can be used as digital inputs.
- Ability to add up to three(3) extension modules expanding I/O’s to 32 digital inputs, 16 relay outputs.
- Communication module allows programmable relay to be connected to a Modbus network through RS 485 link
- Backlit LCD screen for display and modification of pre-selected parameters of function blocks, viewing I/O status and programming on the device.
- Ladder programming using software on PC as well on the device with the help of keypad & LCD Display
- Memory back up allowing programs to be transferred or copied into another Genie NX with the help of a memory card.
- Compact size – only 72mm (2-53/64") wide x 90mm(3-35/64") high x 65 mm (2-9/16) deep, reducing panel area requirements for lower installed costs.
- Soft keys for convenient creation and editing of programs on the device.
- Available in both: AC(110 - 240 V AC) & DC(12 - 24 VDC) models.
- Password & Parameter lock facility.

Approvals

EXTENSION MODULE

- Extension Module can be used with base module to increase I/O capacity of Genie-NX.
- Every extension module has 8 digital inputs & 4 digital outputs.
- Connections are made in Daisy chain fashion.
- Genie-NX can be expanded by connecting 3 extension modules, to obtain a maximum configuration of 32 inputs and 16 outputs.

COMMUNICATION MODULE (\textit{\textsuperscript{\textregistered} Comm})

- \textit{\textsuperscript{\textregistered} Comm} (RS 485) provides Modbus communication for Genie NX.
- Possible to connect multiple Genie’s with a SCADA system or a HMI over RS 485.
- Available in both AC (110 - 240 VAC) & DC (12 - 24 VDC) models.

ACCESSORIES

- USB Cable
- Communication Cable
- Serial Cable
- Memory Card
The 8 keys located on the front facia of Genie-NX are used to configure, program and control the application. They perform the following actions:

**DEL**
This key is used to delete a program element or a blank line, if the cursor is located at the extreme column.

**ALT**
This key is used for selecting/exiting a parameter in the edit mode and to show either the Parameters or Program while the program is running. This feature is also useful for debugging.

**OK**
This key is used to insert a program line, when cursor is blinking in the first column of first row. During the parameter entry while editing this key saves the changes and proceeds to next parameter. In RUN mode, this key can be used to select one of the 3 displays. This also selects/deselects links.

**ESC**
This key is used to exit the menu or a selection. During the parameter entry it proceeds to the next parameter without saving the changes.

**ARROW**
On the program editor screen, the arrow keys are used to move up, left, down and right. The position on screen is shown by a cursor or blinking text.

**AUXILIARY or Z-Keys**
Arrow keys are called auxiliary keys in Run mode. They are used as push buttons to get signals from user. If user goes in PAR (parameter mode), then these keys are not available as z-keys. At that time these keys are used as arrow keys.
SUPPLY, INPUT & OUTPUT CONNECTIONS

AC Base Module

Fig. 1

AC Extension Module

DC Base Module

Fig. 2

DC Extension Module

Fig. 3

Connection Between Base Module & Extension Module

Same for both AC & DC

Fig. 4

Connection Between Base Module & Communication Module

Power Supply Wiring

1. Although the Genie has been designed to withstand the negative effects of any electrical noise that might be present in the incoming power supply it may be necessary to insert an isolation transformer between the supply and the line terminals of the Genie.

2. While using the DC Genie-NX, run the 24 VDC Input line away from the 100 V AC and 200 V AC lines.

Wiring of Input/Output

1. Separate the Input lines and output.

2. When the output lines are running close to power supply lines or the Input lines use batch shielded and ground them.

MOUNTING DIMENSIONS (mm)
Programming and other settings in Genie NX can be done using the software as well as on the device itself with the help of the backlit display and keypad.

When the connections are made and the device is powered ON, screen 1 is displayed on the device. By default the cursor will blink on the 'PROGRAM' option. Using the Up, Down keys, user can select between any of the options.

When the cursor is on the PROGRAM option and OK key is pressed, then screen 2 is displayed.

When screen 2 is being displayed, the cursor is on the 'EDIT' option. Press the OK key to enter this option & screen 6 will be displayed. Similarly by pressing down key and OK, one can enter the other functions viz. "DELETE", "TRANSFER", "MODBUS CONF" and screen 7,8 and 9 will be displayed respectively.

EDIT
This function allows the user to enter a new program or edit an existing program. If Password is set, then this function is accessible only with the correct password.

DELETE
This function will clear the entire program stored in the Genie-NX. If Password is set, then this function will work only with correct password.

TRANSFER
This function will transfer the program from device to memory card or vice versa. Program data on memory can also be deleted in this mode.

MODBUS CONFIG
This function will set Mod bus Slave configuration data. The user can set the following communication parameters:

- SLAVE ID , BAUD RATE, PARITY, STOP BIT

When screen 1 is being displayed, press the down key to shift the cursor to the RUN option and press OK key to enter it. Screen 3 will be displayed.

RESET
The RESET Mode resets all the previous states of Inputs/Outputs, clears timer and counter states, starts afresh.

CONTINUE
The CONTINUE Mode does not change the states of the Inputs/Outputs and special functions and continues with the execution of the program.

When the cursor is on PARAMETERS option and OK is pressed then screen 4 will be displayed.

PARAMETERS
This function displays and allows the user to change parameters of special functions like timer, counter, Time switch (clock), compare counters and analog functions used in the program. This may be password protected and may have additional individual lock for each parameter.

When the cursor is on the UTILITIES option and OK key is pressed, then screen 5 is displayed.

When screen 5 is being displayed, the cursor is on the 'SET CLOCK' option. Press the OK key to enter this option & screen 1 will be displayed. Similarly by pressing down key and OK, one can enter the other functions viz. "PASSWORD", "EXT MOD", "BACKLIT CONF" and screen 7,8 and 9 will be displayed respectively.

SET CLOCK
This function is used to set the day and time: Day of the week, Date, Hours-Minutes. This function is available only on Genie-NX unit.

PASSWORD
This function allows setting of password. If password is set, certain functions like Program, Parameters are protected and are accessible only when correct password is entered. The Password can be set or removed; the status is indicated by the open or closed lock symbol.

BACKLIT CONF
This function allows the setting of backlight in either On, Off or Auto mode. In the Auto mode, the backlight comes up only when a key is pressed on the device and remains for 10 seconds. If the ON or OFF modes are selected the backlight will be permanently ON or OFF respectively.
## Ladder Programming Elements / Function Blocks

In ladder programming, the ladder elements / Functional Blocks are connected to create a ladder for any application. The following section gives the description of each element that is used for ladder programming.

### INPUTS

<table>
<thead>
<tr>
<th>Genie-NX provides 2 types of Inputs viz. Digital &amp; Analog</th>
</tr>
</thead>
<tbody>
<tr>
<td>AC Model: Digital Inputs (1 - 8)</td>
</tr>
<tr>
<td>DC Model: Digital Inputs (1 - 6), Analog Inputs (V1, V2)</td>
</tr>
</tbody>
</table>

#### TIMERS

Genie-NX provides 16 Timers which can be configured as:
- I. ON Delay
- ii. OFF Delay
- iii. Single Pulse
- iv. Symmetric/Asymmetric

<table>
<thead>
<tr>
<th>T1, T2, ..... T16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer Coil / Normally Open (NO) Contact</td>
</tr>
<tr>
<td>t1, t2, ..... t16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### OUTPUTS

<table>
<thead>
<tr>
<th>Genie-Nx provides Digital Outputs: Base Module (4), Extension Module (4)</th>
</tr>
</thead>
<tbody>
<tr>
<td>The outputs can be configured as:</td>
</tr>
<tr>
<td>I. State Change (Contactor)</td>
</tr>
<tr>
<td>ii. Level Change (Remote Control)</td>
</tr>
<tr>
<td>iii. Bi-stable (Set Reset)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Q1, Q2, ..... Q8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normally Open (NO) Contact</td>
</tr>
<tr>
<td>U1, U2, ..... U8</td>
</tr>
<tr>
<td>Extension Module 1</td>
</tr>
<tr>
<td>V1, V2, ..... V8</td>
</tr>
<tr>
<td>Extension Module 2</td>
</tr>
<tr>
<td>W1, W2, ..... W8</td>
</tr>
<tr>
<td>Extension Module 3</td>
</tr>
</tbody>
</table>

#### ANALOG COMPARATORS

Genie-NX provides 12 Analog Comparators which can be used for comparison between values of two analog signals or between a one analog signal and any absolute value

<table>
<thead>
<tr>
<th>A1, A2, ..... A16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normally Open (NO) Contact</td>
</tr>
<tr>
<td>a1, a2, ..... a16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### COMPARE COUNTERS

Genie-NX provides 16 Compare Counters which can be used for comparison between values of two counters or between a counter and any absolute value

<table>
<thead>
<tr>
<th>P1, P2, ..... P16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normally Open (NO) Contact</td>
</tr>
<tr>
<td>p1, p2, ..... p16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### COUNTERS

Genie-NX provides 16 Counters which can be configured as:
- I. Up Counter
- ii. Down Counter

<table>
<thead>
<tr>
<th>C1, C2, ..... C16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Counter Coil / Normally Open (NO) Contact</td>
</tr>
<tr>
<td>c1, c2, ..... c16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### SOFT TEXT MESSAGES

Genie-NX provides 16 Soft Text Message blocks which can be used to display text messages, the Preset Value and Current Value of any Special Function Block or the Current Date and time

<table>
<thead>
<tr>
<th>X1, X2, ..... X16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Used for viewing Alarms, HMI Functionality</td>
</tr>
</tbody>
</table>

#### TIME SWITCHES

Genie-NX provides 16 Time Switches which can be used for daily or weekly applications

<table>
<thead>
<tr>
<th>Θ1, Θ2, ..... Θ16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normally Open (NO) Contact</td>
</tr>
<tr>
<td>Θ1, Θ2, ..... Θ16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### AUXILIARY RELAYS

Genie-Nx provides 32 Auxiliary relays which can be used to expand a rung from one line to another line.

<table>
<thead>
<tr>
<th>M1, M2, ..... M16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auxiliary Coil / Normally Open (NO) Contact</td>
</tr>
<tr>
<td>m1, m2, ..... m16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

#### Z-KEYS

Z-Keys are navigation keys provided on device front face. They behave exactly like the physical inputs (Discrete inputs); The only difference is that they do not correspond to smart relay connection terminals, but to the four gray buttons on the front panel.

<table>
<thead>
<tr>
<th>Z1, Z2, ..... Z16</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normally Open (NO) Contact</td>
</tr>
<tr>
<td>z1, z2, ..... z16</td>
</tr>
<tr>
<td>Normally Closed (NC) Contact</td>
</tr>
</tbody>
</table>

Z-Keys can be used as navigation keys for current displayed menu. To use Z-Keys go to RUN Screen or RUN LADDER Screen and Press ALT which will display the Z-Key Screen. Then Press Z1 - Z4.
Setting the Clock
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “SET CLOCKS” option from the Sub Menu and press OK.
3. The cursor will blink on the first digit of the date, press ALT to edit the digit.
4. The digit will now start blinking.
5. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
6. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
7. Now press OK to confirm the changes that have been made.
8. Repeat the same procedure if the other modules are to be selected.
9. Press OK to save the changes and the ‘UTILITIES’ sub menu is displayed.

Extension Module Selection
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “EXT MOD” option from the Sub Menu and press OK.
3. The cursor will blink on ‘A’, press ALT to edit and the ‘A’ will start blinking.
4. Press Up(Z4) or Down(Z2) keys to select or deselect the extension module.
5. A dark square around ‘A’ indicates that the module has been selected.
6. Now press OK to confirm the changes that have been made.
7. Repeat the same procedure if the other modules are to be selected.
8. Press OK to save the changes and the ‘UTILITIES’ sub menu is displayed.

Backlit Configuration
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “BACKLIT CON” option from the Sub Menu and press OK.
3. The ‘Auto’ option will be displayed with the cursor blinking on it.
4. Press ALT to edit and the Auto option will start blinking.
5. Press Up(Z4) or Down(Z2) keys to select other options viz. ON, OFF.
6. Now press OK to confirm the changes that have been made.
7. Press OK to save the changes and the ‘UTILITIES’ sub menu is displayed.

Ladder Program Protection
1. If the password is already enabled and user attempts to gain access using wrong password, then an error message is displayed.
2. If four such consecutive attempts are made then user is presented with options to either delete the entire device data or else revert.
3. If the DELETE ALL option is selected, then all device data including Password and Ladder is erased. The user can then re program the Ladder using G-SOFT NX and secure it with a new password.

Removing the Password
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “PASSWORD” option from the Sub Menu and press OK.
3. The unlock symbol means that the password is not set.
4. The password comprises four numeric digits from 0 to 9. Therefore the password can have any value between 0 and 9999.
5. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
6. The digit will now start blinking.
7. The cursor will blink on the first digit, press ALT to edit the digit.
8. Now press OK to confirm the changes that have been made.
9. Again on pressing OK the password is enabled and the Main Menu is displayed.

PASSWORD
The password secures access to the following main menu options: “PROGRAM”, “PARAMETERS” and “UTILITIES”.
In run mode password protects the run time parameters and ladder viewing. The password comprises four numeric digits from 0 to 9. Therefore the password can have any value between 0 and 9999.

Setting the Password
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “PASSWORD” option from the Sub Menu and press OK.
3. The unlock symbol means that the password is not set.
4. The cursor will blink on the first digit of the date, press ALT to edit the digit.
5. The digit will now start blinking.
6. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
7. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
8. Repeat the same procedure to set all the 4 digits.
9. Now press OK to confirm the changes that have been made.
10. Again on pressing OK the password is enabled and the Main Menu is displayed.

Setting the Clock
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “SET CLOCKS” option from the Sub Menu and press OK.
3. The cursor will blink on the first digit of the date, press ALT to edit the digit.
4. The digit will now start blinking.
5. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
6. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
7. Now press OK to confirm the changes that have been made.
8. Repeat the same procedure to set the month, year, hour and minutes.
9. Once all the parameters have been set, press OK to save the changes and exit.

Backlit Configuration
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “BACKLIT CON” option from the Sub Menu and press OK.
3. The ‘Auto’ option will be displayed with the cursor blinking on it.
4. Press ALT to edit and the Auto option will start blinking.
5. Press Up(Z4) or Down(Z2) keys to select other options viz. ON, OFF.
6. Now press OK to confirm the changes that have been made.
7. Press OK to save the changes and the ‘UTILITIES’ sub menu is displayed.

Ladder Program Protection
1. If the password is already enabled and user attempts to gain access using wrong password, then an error message is displayed.
2. If four such consecutive attempts are made then user is presented with options to either delete the entire device data or else revert.
3. If the DELETE ALL option is selected, then all device data including Password and Ladder is erased. The user can then re program the Ladder using G-SOFT NX and secure it with a new password.

Removing the Password
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “PASSWORD” option from the Sub Menu and press OK.
3. The unlock symbol means that the password is not set.
4. The cursor will blink on the first digit of the date, press ALT to edit the digit.
5. The digit will now start blinking.
6. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
7. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
8. Repeat the same procedure to set all the 4 digits.
9. Now press OK to confirm the changes that have been made.
10. Again on pressing OK the password is enabled and the Main Menu is displayed.

PASSWORD
The password secures access to the following main menu options: “PROGRAM”, “PARAMETERS” and “UTILITIES”.
In run mode password protects the run time parameters and ladder viewing. The password comprises four numeric digits from 0 to 9. Therefore the password can have any value between 0 and 9999.

Setting the Password
1. Select the “UTILITIES” option from the Main Menu and press OK.
2. Select the “PASSWORD” option from the Sub Menu and press OK.
3. The unlock symbol means that the password is not set.
4. The cursor will blink on the first digit of the date, press ALT to edit the digit.
5. The digit will now start blinking.
6. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
7. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
8. Repeat the same procedure to set all the 4 digits.
9. Now press OK to confirm the changes that have been made.
10. Again on pressing OK the password is enabled and the Main Menu is displayed.
Creating or Editing a Ladder
To create a new ladder or edit an existing ladder, select the PROGRAM option from the Main Menu by pressing OK. Select the EDIT option to create or edit a ladder.

Inserting a Contact
1. Place the blinking cursor in the required position.
2. Press ALT.
3. Choose the required element using the Up or Down keys.
4. Use the Right Arrow key to move to the number.
5. Choose the number using up or down keys.
6. Press ALT or Right Arrow to accept and to go to next position.

Inserting a Coil
1. Place the blinking cursor in the required position.
2. Press ALT.
3. Choose the required element using the Up or Down keys.
4. Use the Right Arrow key to call-up the number.
5. Choose the number using Up or Down keys.
6. Use the Left Arrow key to move to the type of coil.
7. Choose the type of coil using Up or Down keys.
8. Press ALT or Right Arrow to accept and to go to next position.

Entering a Link
1. Place the blinking cursor next to the desired location.
2. Press OK to start the link ("Z","","cursor")
3. Move the cursor to the desired location using the arrow keys.
4. As the cursor moves, the link is drawn.
5. Press OK to exit to normal mode.
6. Repeat this action as many times as necessary to link all the elements together as required.

Deleting a Program Line
Move the cursor to the first column of the line, if necessary delete the elements one by one to create a blank line. Press Del. The line is deleted. It is also possible to delete the entire program stored in the Genie-NX. To do this, call up the "DELETE" option in the Program menu and validate the deletion of all program lines.

Replacing a Link with a Contact
To replace a link with a contact, simply place cursor at the required location and press ALT to enter the contact

Changing an Element
To change an element in an existing program, simply move to the element to change, press ALT and follow the same procedure as when entering a new element

Deleting an Element
To delete an element, simply place the cursor on the required element, then press Del. Generally, the deleted element must be replaced by a link

Deleting Links between Elements
To delete a link, simply move the cursor next to the desired position, press the OK key to change the cursor to a and press Del. Key. This may delete some of the required connections, which may be restored by the same method as above

Inserting a Program Line
To insert a program line, simply move cursor to the first column of the line immediately above the one to create and press OK.

TRANSFER
The TRANSFER function allows data to be transferred from Memory Card to Genie-NX or vice-versa. Transferring data to memory card is useful when user wants to load the same program in many Genie-NX units. In this case instead of using PC user can make use of memory card, which is capable of storing one program. This feature is particularly useful on the production line where user is not required to edit and debug the program and a PC is not available.

In this mode of transfer "PASSWORD" and "UTILITIES" such as Backlight configuration & Extension module state will also get transferred with the program ladder.

Devic to Card
1. Insert the Memory card in the connector after removing the serial cable, if present.
2. Select the "TRANSFER" function from the "PROGRAM" menu.
3. Press the OK key to validate.
4. Select the Device > Card function.
5. Press the OK key to validate.

Card to Device
This transfer is used to reload an application into the Genie-NX. It avoids the need to re-enter an existing application.
1. Insert the Memory card in the connector after removing the serial cable, if present.
2. Move cursor to the "TRANSFER" function from the "PROGRAM" menu.
3. Press the OK key to validate.
4. Select the Card > Device function.
5. Press the OK key to validate.

Editing Parameters of Special Function Blocks
Parameters of special Function Blocks can be modified in two modes
1. Run Mode
2. Program Stop Mode

Run Mode
1. Enter the PASSWORD if it has been enabled.
2. Special function block with it’s parameters set will get display.
3. Set parameters & press OK to save the parameters.
4. Press ESC to return Run Mode Menu.
5. If user do not press OK and do press ESC previous settings retains & returns to Run Mode Menu

Program Stop Mode
Enter the PASSWORD if it has been enabled and press OK to save the parameters. If user do press ESC key without pressing OK the screen as shown will appear, so that user can have three options as:
EDIT: Again enter into parameter set mode.
SAVE AND EXIT: Save the parameters & come out of mode.
EXIT: Retain previous settings & come out of set mode.
**RUN MODE**

To enter into RUN mode select the "Run" option in the main menu and press 'OK'.

If the CONTINUE option is selected then Ladder Program execution will proceed & the Run mode display screen will appear as shown.

If the RESET option is selected then all special function block parameters are initialized & the Run mode display screen will appear.

**Run Mode Functions**

During the Run mode the user can enter the Run Mode Functions by pressing the ESC key.

**PAUSE**

If the PAUSE option is selected by pressing OK then program execution is paused.

And user can have two options as:
- Continue: Run with the parameters status it has or
- Reset: Reset the parameters and run the program.

**STOP**

If the STOP option is selected by then the program execution is stopped & Main Menu is displayed on the screen.

**PAR RUN**

- If the PAR RUN option is selected then Parameter edit window of Special Function Block is displayed. The user can edit the parameters by using ALT, UP, DOWN & OK keys.

**PROG RUN**

- If the PROG RUN option is selected then the ladder program is displayed on the screen. The user cannot edit the program and can only try through the program by using UP, Down keys.

If Z-Keys are used in the program then pressing the ALT key will display the Z-Key screen.

**MODBUS SETTINGS**

**Slave ID**

1. Select the “PROGRAM” option from the Main Menu and press OK.
2. Select the “MODBUS CONF” option from the Sub Menu and press OK.
3. The cursor will blink on the first digit of the Slave ID (SLV ID).
4. Press ALT to edit the digit and the digit will now start blinking.
5. Using Up(Z4) and Down(Z2) keys select the appropriate digit.
6. Now press Z3 to edit the other digit and using Up & Down keys select the digit.
7. Now press OK to confirm the changes that have been made.

**Baud Rate**

8. Now press Z3 to select Baud Rate (BAUD) and press ALT to edit.
9. Using Up(Z4) and Down(Z2) keys select the appropriate Baud Rate.
10. Now press OK to confirm the changes that have been made.

**Parity**

11. Now press Z3 to select ‘PARITY’ and press ALT to edit.
12. Using Up(Z4) and Down(Z2) keys select the appropriate parity.
13. Now press OK to confirm the changes that have been made.

**Stop Bits**

15. Using Up(Z4) and Down(Z2) keys select the number of stop bits.
16. Now press OK to confirm the changes that have been made.

17. Once all the changes have been made press OK to save and exit.

**Parameter Lock**

When user edits parameter from text message and if parameter is locked then above screen appears. To change that parameter user has to edit that parameter in edit mode only.
Programming using the G Soft-NX Software

G-Soft NX is the exclusive programming software for the Genie NX using Windows®. It facilitates:

**Entering the Program: Select & Place**
G-SOFT NX provides a user-friendly interface wherein the user has to only select contact type and contact number and place it where it is required. Contacts get connected automatically if they are on the same line. User can enter comments for better readability and for future reference.

**Saving Programs**
G-SOFT NX allows user to save individual programs on the PC.

**Debugging**
G-SOFT NX is very powerful in error handling. It displays any possible errors as the program is being entered to make corrections simultaneously.

**Simulation on PC**
User can simulate the program on PC. User can use buttons provided on the screen to simulate the input connections. Scroll bar can be used to simulate Analog input. The actuation/de-actuation of the relays can be monitored on the screen.

**Simulation on Genie NX**
User can connect Genie-NX unit to PC using a serial Communication cable / USB cable and perform on line program simulation. In this mode the PC acts as a master and the inputs are taken from Genie-NX and outputs are sent to Genie-NX unit (and the extension modules, if connected). This mode is useful in debugging the entire system since the actual I/Os are used.

**Printing**
User can take print outs of programs in two different formats, namely Short format and Detail format. Also, program Parameters and Comments can be printed.

**Transferring Programs**
Programs can be transferred from PC to Genie-NX and vice versa using serial Communication cable / USB cable. This saves the program entering time on Genie-NX.

**Transferring Clock**
With this utility user can set the clock (date and time) on Genie-NX.

Select File -> New from the menu bar to create a new program. A blank screen will appear. Now you can start entering the program. Ensure that you have chosen proper Genie-NX Configuration before starting the program entry.

**Choosing Contact Type**
Position the cursor at the place where you want to insert the contact by a left click with mouse. The position will get highlighted. Choose the required contact type and Contact Number from I/O function selector. Click on the required contact and contact number, which will be highlighted for a few seconds. The selected contact will appear at the position selected in the program. The selected contact number will be shown with a tick mark to indicate that it has been used in the program. You can right click on any of the contact to change its type and properties.

**Connecting Inputs & Outputs**
Each circuit connection runs from left to right. Please remember this when you interconnect contacts and relay coils. User can draw a circuit connection horizontally from left to right and vertically between adjacent circuit connections. An intersection of circuit connections represents an electrical connection.

**Horizontal connection**
To make a horizontal connection, click on the horizontal dotted line in the connection box of the circuit. Or to make connection in contact box, press right button and select “Joining link”. Generally when an output coil is placed in the fourth column, it gets automatically connected.

**Vertical connection**
To make a vertical connection click on the vertical dotted line in the connection box of the circuit. Vertical connection represents OR connection. For deleting a connection just left click on the connection line.
To Set & Remove Password
- Select the Configuration > Device Utilities menu command. Then Device Utilities window will pop up as shown in the adjoining window.
- Click on set password.
- Enter four digits password in the two boxes “New password” and “Confirm New” Password then confirm with OK.
- You can delete your assigned password at any time. To do this, enter the existing password in “Old password” box. Then confirm with OK.
- To change the password, you must first enter the new password in the two boxes “New password” and “Confirm Password” and the existing password in Current password text box. Then confirm with OK.

To Set Backlit Mode
- Select the Configuration > Device Utilities menu command. Then Device Utilities window will pop up as shown in the adjoining window.
- Select the mode Auto, On or Off then click on the set mode button.
- Then “The requested operation will move the device out from the run mode. Do you want to continue?” message will pop up.
- If pressed Yes, then backlight mode will get set in device and "Backlight mode has been set successfully" message will appear on the screen.

To Configure Communication Port
- Select the Options > Comm port menu command. Then COM Port setting window will pop up as shown in the adjoining window showing two option buttons to select the Port.
- Select “Device is connected to USB port” when the device is connected with Serial Communication cable.
- Select “Device is connected to Serial Communication port” when the device is connected with Serial Communication cable.

To Set Communication Parameters
- Select the Options > Comm port menu command. Then COM Port setting window will pop up as shown.
- The user can set the following communication parameters:
  - SLAVE ID: Selectable from 1 to 247.
  - BAUD RATE: Selectable as 1200, 2400, 4800, 9600 baud.
  - PARITY: Selectable as NONE, EVEN and ODD.
  - STOP BIT: Selectable as 1 and 2 stop bits.

Clock Setting
- Select the Transfer > Device Clock menu command. Then Device Clock window will pop up as shown in the Device Clock window.
- To view Date and time of device: Click Read button on the clock setting window. Then the Clock Setting window will show the Date and Time of the device.
- To set Date and time in the device: User can select Date and Time to write into the device. Click Write button on the clock setting window.

DST (Daylight Saving Time) Setting
- Select the Transfer > Device Clock menu command. Then Device Clock window will pop up as shown in the adjoining window.
- To set Enable DST, Follow the following steps: Click Daylight Saving Time check box then the DST setting section becomes visible.
- User can select the following parameters: Begin Week, Begin Day, Begin Month, Begin Time, End Week, End Day, End Month, End Time, Offset Time.
- To set Disable DST, Follow the following steps:
  1. Deselect Daylight Saving Time option then DST window will get disable.
  2. Press Set DST.
- To read DST: Press Read DST, independent of the DST enable or disable.

Transfer Options
PC to Device
- Select the Transfer > Program menu command. Then transfer window will pop up as shown in the Transfer Window.
- Press "PC to Device" button on transfer dialog box. Current program on the screen will get transferred to device.
- Transfer completion message "The Program is downloaded successfully" will appear on the screen.

Device to PC
- Select the Transfer > Program menu command. Then transfer window will pop up as shown in the adjoining window.
- Press "Device to PC" button on transfer dialog box. Current program on the screen will get transferred to device.
- Transfer completion message "The Program is downloaded successfully" will appear on the screen.
- Read program will be shown on main screen.

Extension Module Selection
- Select the Configuration > PLC Model menu command. Then Model Selection window will pop up as shown.
- Selection of Genie-NX model and Extension modules. Maximum three extension modules can be connected to one Genie-NX.
**Sample Programs**

**FACTORY/SCHOOL SCHEDULE**
Opening bell at 8am announces start of work or class (bell to last 10 sec and stop): Bell at 10:30am announces start of coffee break, Bell at 10:45am announces end of coffee break, Bell at 12noon announces lunch, Bell at 12:45 announces end of lunch, Bell at 5pm announces end of work day.

**Programming**
For the 6 time periods 6 Time Switches are required. O₁, O₂, ..., O₆ represent the 6 Time Switches.
Timer T₁ ensures that the duration of the output is 10 seconds only.
Q₁ represents the Output Coil (Alarm/Bell in this case)
Double click on the G SOFT NX icon the launch the G SOFT Software application.
Click on File → New to launch a new Program window.

**Time Switch Selection & Parameter Editing**
1. Click on the Time Switch symbol in the I/O selector window and select Time Switch 1 (O₁)
2. Move the cursor to the ‘Contact 1’ column of the first row and left click on the block to place the Time Switch.
3. Right click on the Time Switch and select properties to open the properties window.
4. In the Weekday settings option select ‘From’ as Monday ans ‘To’ as Saturday.
5. In the Daily Duration option enter the start time as 10:30 and since we want the siren for 10 sec. enter end time as 10:31.
6. Similarly select the other 5 Time Switches and enter the times as described above and place them in the contact 1 column of lines 2, 3, 4, 5 & 6.

**Timer Selection & Parameter Editing**
7. Select Timer T₁ from the I/O selector window and place it in the coil column of line 1 and contact column of line 7.
8. Open the Timer properties window and select the mode as Interval and enter the time duration i.e. SP as 10 sec.
9. Connect the lines from all the Time Switches to the Timer as shown in screen.

**Output Configuration**
10. Select Output Q₁ from the I/O selector window and place it in the coil column.
11. Right click on output Q₁ to and select the option ‘State Change: Contactor’

**LADDER PROGRAM**

<table>
<thead>
<tr>
<th>Contact-1</th>
<th>Connection-1</th>
<th>Contact-2</th>
<th>Connection-2</th>
<th>Contact-3</th>
<th>Connection-3</th>
<th>Coil</th>
</tr>
</thead>
<tbody>
<tr>
<td>O₁</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₁</td>
</tr>
<tr>
<td></td>
<td>Start of class</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>T₁</td>
</tr>
<tr>
<td>O₂</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₂</td>
</tr>
<tr>
<td></td>
<td>Start of Coffee</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₂</td>
</tr>
<tr>
<td>O₃</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₃</td>
</tr>
<tr>
<td></td>
<td>End of Coffee break</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₃</td>
</tr>
<tr>
<td>O₄</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₄</td>
</tr>
<tr>
<td></td>
<td>Start Lunch Break</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₄</td>
</tr>
<tr>
<td>O₅</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₅</td>
</tr>
<tr>
<td></td>
<td>End of Lunch Break</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₅</td>
</tr>
<tr>
<td>O₆</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₆</td>
</tr>
<tr>
<td></td>
<td>End of class</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₆</td>
</tr>
<tr>
<td>O₇</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>O₇</td>
</tr>
<tr>
<td></td>
<td>T₁</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>T₁</td>
</tr>
</tbody>
</table>

O₁, O₂, ..., O₆ represent the 6 Time Switches.
Timer T₁ ensures that the duration of the output is 10 seconds only.
Q₁ represents the Output Coil (Alarm/Bell in this case).
Sample Programs

CAR PARKING
There are 5 parking spots available in a parking area. There are 2 sensors, one at the entry gate and one at the exit gate. When all the parking spots are occupied, there is a lamp outside the entry gate indicating parking is full. When any of the parking spots is available, other lamp is switched ON indicating parking is available.

Programming
Input I1 is the sensor at the Entry gate and Input 2 is the sensor at the exit gate.
Output Q1 indicates that Parking is available, Output 2 indicates that Parking is Full.
Counter C1 is used to count the number of vehicles that have entered or exited the parking.
Compare Counters P1 & P2 are used switch ON outputs Q1 & Q2 respectively by comparing the count of counter C1.

Input Selection
1. Click on the Input symbol in the I/O selector window and select I1.
2. Move the cursor to the Contact 1 column of the first row and left click on the block to place the input.
3. Again click on the Input symbol in the I/O selector window and select I2.
4. Move the cursor to the Contact 1 column of the second row and left click on the block to place the input. Also place it in the Contact 1 column of the third row.

Counter Selection & Parameter Editing
5. Select Counter C1 from the I/O selector window and place it in the coil column of line 1. Right click on the counter and select the option counting input.
6. Again select the same counter C1 and place it in the coil column of line 3. Right click on the counter and select the option direction input.

Compare Counter Selection & Parameter Editing
7. Select Compare Counter P1 from the I/O selector window and place it in the contact column of line 4.
8. Right click on the compare counter and select properties.
10. Select Compare Counter P2 from the I/O selector window and place it in the contact column of line 5.
11. Right click on the compare counter and select properties.

Output Configuration
13. Select Output Q1 from the I/O selector window and place it in the coil column
14. Right click on output Q1 to and select the option ‘State Change: Contactor’

LADDER PROGRAM

<table>
<thead>
<tr>
<th></th>
<th>Contact-1</th>
<th>Connection-1</th>
<th>Contact-2</th>
<th>Connection-2</th>
<th>Contact-3</th>
<th>Connection-3</th>
<th>Coil</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>I1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>C C1</td>
</tr>
<tr>
<td></td>
<td>Entry Sensor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>I2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>C C1</td>
</tr>
<tr>
<td></td>
<td>Exit Sensor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>I2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>C C1</td>
</tr>
<tr>
<td></td>
<td>Exit Sensor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>04</td>
<td>P1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Q1</td>
</tr>
<tr>
<td></td>
<td>Parking Available</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>05</td>
<td>P2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Q2</td>
</tr>
<tr>
<td></td>
<td>Parking Full</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Technical Specifications

<table>
<thead>
<tr>
<th>Supply Voltage</th>
<th>110 - 240 VAC</th>
<th>12 - 24 VDC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supply Variation</td>
<td>-20% to +10%</td>
<td>-20% to +10%</td>
</tr>
<tr>
<td>Frequency</td>
<td>50/60 Hz</td>
<td>50/60 Hz</td>
</tr>
<tr>
<td>Power Consumption</td>
<td>5 VA</td>
<td>5 VA</td>
</tr>
<tr>
<td>Analog Inputs</td>
<td>N.A.</td>
<td>2</td>
</tr>
<tr>
<td>Analog Input Range</td>
<td>N.A.</td>
<td>0 - 10 VDC</td>
</tr>
<tr>
<td>Digital Inputs</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>Digital Input Range</td>
<td>(0 - 40 VAC) OFF, (80 - 264 VAC) ON</td>
<td>(0 - 4 VDC OFF, 8 - 26.4 VDC) ON</td>
</tr>
<tr>
<td>Outputs</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Contact Rating</td>
<td>8A @ 240 VAC / 5A @ 30 VDC</td>
<td>8A @ 240 VAC / 5A @ 30 VDC</td>
</tr>
<tr>
<td>Input / Output Extension (Max)</td>
<td>Yes (3)</td>
<td>Yes (3)</td>
</tr>
<tr>
<td>Power Reserve (For clock only)</td>
<td>150 h</td>
<td>150 h</td>
</tr>
<tr>
<td>Timers</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>Time Switches (Daily/Weekly)</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>Counters (Up/Down, Retentive selectable)</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>Compare Counters</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>Soft Text Messages</td>
<td>16 (Priority Driven)</td>
<td>16 (Priority Driven)</td>
</tr>
<tr>
<td>Analog Functions</td>
<td>N.A.</td>
<td>N.A.</td>
</tr>
<tr>
<td>Auxiliary Relays</td>
<td>32</td>
<td>32</td>
</tr>
<tr>
<td>Lines for Ladder Programming</td>
<td>250</td>
<td>250</td>
</tr>
</tbody>
</table>

## ORDERING INFORMATION

<table>
<thead>
<tr>
<th>Part Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>G7DDT9</td>
<td>110 - 240 VAC, Genie Nx Base Module</td>
</tr>
<tr>
<td>G8DDT9</td>
<td>12 - 24 VDC, Genie Nx Base Module</td>
</tr>
<tr>
<td>GTDDT0E</td>
<td>110 - 240 VAC, Genie Nx Extension Module</td>
</tr>
<tr>
<td>G8DDT0E</td>
<td>12 - 24 VDC, Genie Nx Extension Module</td>
</tr>
<tr>
<td>G7XDT4</td>
<td>110 - 240 VAC, Genie Nx RS 485 Communication Module</td>
</tr>
<tr>
<td>G8XDT4</td>
<td>12 - 24 VDC, Genie Nx RS 485 Communication Module</td>
</tr>
<tr>
<td>GFDN1</td>
<td>Memory Card</td>
</tr>
<tr>
<td>GFDNN2S</td>
<td>RS 232 Serial Communication Cable</td>
</tr>
<tr>
<td>GFDDNP</td>
<td>USB Cable</td>
</tr>
<tr>
<td>GNXNN1</td>
<td>Genie Nx Software supplied on CD-ROM compatible with Windows 98, 2000, XP &amp; Vista</td>
</tr>
</tbody>
</table>

## APPLICATIONS

### HVAC Controls
- Energy management
- Heating Control
- Cooling systems
- Ventilation systems
- Air conditioning systems

### Machine Controls
- Motor, pump and valve controls
- Air compressors
- Exhaust and filtering systems
- Water-treatment plants
- Woodworking machinery
- Etching and purification plants

### Residential and Commercial Building Services
- Interior and exterior lighting control
- Door/gate control
- Shutter, sun blind and awning control
- Irrigation system control

### Transport facilities
- Conveyor systems
- Hoisting platforms
- Elevators
- Silo facilities
- Livestock feed delivery

### Operational Monitoring Systems
- Access control
- Vehicle control monitoring
- Alarm systems
- Level limit monitoring
- Traffic light control systems
- Baggage handling

### Other Applications
- Solar-electric systems
- Marine applications
- Harsh environments
- Display panels and traffic control signs