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Warranty and Disclaimer

The use of the deliverables (e.g. software, application examples, target boards, evaluation boards, starter kits, schematics, 
engineering samples of IC’s etc.) is subject to the conditions of Fujitsu Semiconductor Europe GmbH (“FSEU”) as set out in (i) the 
terms of the License Agreement and/or the Sale and Purchase Agreement under which agreements the Product has been delivered, 
(ii) the technical descriptions and (iii) all accompanying written materials.
Please note that the deliverables are intended for and must only be used for reference in an evaluation laboratory environment.
The software deliverables are provided on an as-is basis without charge and are subject to alterations. It is the user’s obligation to 
fully test the software in its environment and to ensure proper functionality, qualification and compliance with component 
specifications.
Regarding hardware deliverables, FSEU warrants that they will be free from defects in material and workmanship under use and 
service as specified in the accompanying written materials for a duration of 1 year from the date of receipt by the customer.
Should a hardware deliverable turn out to be defect, FSEU’s entire liability and the customer’s exclusive remedy shall be, at FSEU´s
sole discretion, either return of the purchase price and the license fee, or replacement of the hardware deliverable or parts thereof, if 

the deliverable is returned to FSEU in original packing and without further defects resulting from the customer’s use or the transport. 
However, this warranty is excluded if the defect has resulted from an accident not attributable to FSEU, or abuse or 
misapplication attributable to the customer or any other third party not relating to FSEU or to unauthorised decompiling and/or 
reverse engineering and/or disassembling.
FSEU does not warrant that the deliverables do not infringe any third party intellectual property right (IPR). In the event that the 
deliverables infringe a third party IPR it is the sole responsibility of the customer to obtain necessary licenses to continue the usage 
of the deliverable.
In the event the software deliverables include the use of open source components, the provisions of the governing open source 
license agreement shall apply with respect to such software deliverables. 
To the maximum extent permitted by applicable law FSEU disclaims all other warranties, whether express or implied, in particular, 
but not limited to, warranties of merchantability and fitness for a particular purpose for which the deliverables are not designated.
To the maximum extent permitted by applicable law, FSEU’s liability is restricted to intention and gross negligence. FSEU is not liable 
for consequential damages.
Should one of the above stipulations be or become invalid and/or unenforceable, the remaining stipulations shall stay in full effect.
The contents of this document are subject to change without a prior notice, thus contact FSEU about the latest one.

This board and its deliverables must only be used for test applications in 
an evaluation laboratory environment.
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About the SK-FM3-100PMC

The SK-FM3-100PMC is available in two versions:
The SK-FM3-100PMC includes a low-cost evaluation board 
based on the Fujitsu FM3 microcontroller MB9B500 Series
SK-FM3-100PMC-JLINK includes a low-cost evaluation board 
based on the Fujitsu FM3 microcontroller MB9B500 Series and 
the JTAG adapter J-Link 

The MB9B500 Series includes the following features:

Up to 512 KByte Flash Memory
Up to 64 KByte RAM
Up to 2 CAN controller 2.0A/B
Up to 8 LIN-USART-I²C interfaces
USB-Host/-Device interface
Timers (ICUs, OCUs,  PPGs, others)
Up to three 12 Bit ADC
External interrupts

All Rights Reserved.© Fujitsu Limited 2010
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About the SK-FM3-100PMC

Features of the SK-FM3-100PMC board:

Microcontroller MB9BF506N
1x UART-Transceiver (SUB-D9 connector)
1x USB to serial converter (Type-B connector)
1x High-speed CAN-Transceiver (SUB-D9 connector)
1x USB-MiniHost (Type-A connector)
1x USB-Device (Type-B connector)
JTAG- and TRACE-Interface each on a 20 pin-header
TSC-Interface to connect for example the Fujitsu SK-TSC-1127S-SB
2x LED-Display (7-Segment)
2x ‘User’-button
1x ‘Reset’-button, ‘Reset’-LED
All 100 pins routed to pin-header
On-board 5V and 3V voltage regulators, ‘Power’-LED
Power supply via USB (UART’B’), USB-Device, JTAG or external with a 
8V to 12V power connector

5
All Rights Reserved.© Fujitsu Limited 2010



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics

SK-FM3-100PMC content

The SK-FM3-100PMC contains
SK-FM3-100PMC evaluation board with MB9BF506N
USB cable
CD: Documentation, USB driver, Software examples, Programmer

All Rights Reserved.© Fujitsu Limited 2010
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ESD-foam          ESD-box            SK-FM3-100PMC                    USB cable 
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SK-FM3-100PMC-JLINK content

The SK-FM3-100PMC-JLINK contains
SK-FM3-100PMC evaluation board with MB9BF506N
USB cable
CD: Documentation, USB driver, Software examples, Programmer
Segger J-Link JTAG adapter incl. USB cable

All Rights Reserved.© Fujitsu Limited 2010
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ESD-foam          ESD-box            SK-FM3-100PMC                    USB cable 

A B

CD Additional information                       
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Box         Note     Segger J-Link JTAG adapter       USB cable
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Test it

The microcontroller on the SK-FM3-100PMC is already 
preprogrammed with a simple application.

Connect the SK-FM3-100PMC via USB (X5) with the PC 
Install the USB driver from the CD
Press the ‚Reset‘- Button
The SK-FM3-100PMC will automatically start counting
The count direction can be changed by pressing the key buttons

8

INT0

INT1
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Test it

You finished successfully the first test

Now you will get more details about the SK-FM3-100PMC
You will learn more about 

The on-board features
How to program the Flash
How to start with IAR-Embedded-Workbench and KEIL µVision

9
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The Hardware

Main features

10
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The Hardware

The jumpers

11

JP4: UART RX select
R-0: UART0=UART‘A‘ / U-4: UART4=UART‘B‘ (USB)

R-4: UART4=UART‘A‘ / U-0: UART0=UART‘B‘ (USB)

JP5: UART TX select
R-0: UART0=UART‘A‘ / U-4: UART4=UART‘B‘ (USB)

R-4: UART4=UART‘A‘ / U-0: UART0=UART‘B‘ (USB)

JP6: MD0 selection
Close this jumper to control
the MD0 level by the RTS signal
of the USB interface

S1: Mode selection
PROG: Program-mode

RUN: Run-mode

JP10: 5V / 3.3V
1-2: 5V supply is used

2-3: 3.3V supply is used

JP1: DTR-Reset
1-2: DTR-Signal of the UART connector       

is connected to the MCU reset-pin. 

2-3: DTR-Signal of the USB connector 
is connected to the MCU reset-pin.

Some terminal-programs, e.g. Fujitsu‘s 
Skwizard, allow to reset the evaluation 
board by using the DTR-Signal.

JP9: MCU Vcc
This jumper can be used
to measure the current
consumption of the MCU

J5: Power Supply
1-2: USB (UART ‚B‘) supply     3-4: USB Device supply  

5-6: JLINK supply                     7-8: External supply 
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The Hardware

The jumpers 

12

JP67: USB Function                            
HCONX

Open:    D+ is not pulled up
Closed: HCONX controls Pullup of D+

JP17: Port8 (USB use)
1-2: USB in use
2-3: USB not in use
2-4: Use Port 8 as digital I/O

JP16: USB prog 
(for PROG-Mode S1) 

Open:    UART programming enabled
Closed: USB programming enabled 

JP24-JP26: Flow Control UART4
JP24                                          JP25              JP26

1-2: Flow control disabled      1-2: Flow control enabled        open: Flow control disabled
2-3: Flow control enabled       2-3: Flow control disabled       closed: Flow control enabled    

JP2: Pullup resistor TSC
Closed: Pull up SCL3

JP3: Pullup resistor TSC
Closed: Pull up SDA3

JP22,JP23: Flow Conrol CTS4, DTS4
JP22, JP23 1-2: Flow control on UART‘A‘
JP22, JP23 2-3: Flow control on UART‘B‘
JP22, JP23 Open: Flow control disabled

All Rights Reserved.© Fujitsu Limited 2010
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The Hardware

JP4, JP5 : UART selection
UART0 and UART4 of the microcontroller can be used together with a 
typical RS232 SUB-D9 connector and a serial/USB converter
The jumpers JP4 and JP5 routes the channel to the connector

UART0 = USB-connector (X5), UART4 = Sub-D9 (X4) (default)
• Setting of Jumper JP4 and JP5: U-0 / R-4

UART0 = Sub-D9 (X4), UART4 = USB-connector (X5)
• Setting of Jumper JP4 and JP5: U-4 / R-0

13

USBRS232

(default)

USBRS232
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The Hardware

Extension headers X20-X23
Standard 0.1” / 2.54mm grid for use with prototype boards

14
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2x 15 pins
1.4“ / 35.56mm

0.9“/22.86mm
0.7“

0.3“ / 7.62mm

0.3“ / 7.62mm

0.4“
10.16mm 

0.5“ / 12.7mm

2x10 pins     
17.78mm

0.2“
5.08mm
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The Hardware

The microcontroller pins

15

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

1 VCC MCUVCC 11 P32/ZIN0_0/TIOB2_1/SOT6_1/INT05_2/M
DQM0

2 P50/INT00_0/AIN0_2/SIN3_1/RTO10_0/
MDATA0

Key button 
‘INT0’ 12 P33/INT04_0/TIOB3_1/SIN6_1/ADTG_6/M

DQM1

3 P51/INT01_0/BIN0_2/SOT3_1/RTO11_0/
MDATA1

Key button 
‘INT1’ 13 P34/FRCK0_0/TIOB4_1/TX0_1/MAD24 CAN0 TX

4 P52/INT02_0/ZIN0_2/SCK3_1/RTO12_0/
MDATA2

USB current 
limitation‘INT2’ 14 P35/IC03_0/TIOB5_1/RX0_1/INT08_1/MA

D23 CAN0 RX

5 P53/SIN6_0/TIOA1_2/INT07_2/RTO13_0
/MDATA3 15 P36/IC02_0/SIN5_2/INT09_1/MCSX3

6 P54/SOT6_0/TIOB1_2/RTO14_0/MDATA
4 16 P37/IC01_0/SOT5_2/INT10_1/MCSX2

7 P55/SCK6_0/ADTG_1/RTO15_0/MDATA
5 17 P38/IC00_0/SCK5_2/INT11_1 SEG2-A

8 P56/INT08_2/DTTI1X_0/MCSX7 18 P39/DTTI0X_0/ADTG_2 SEG2-B

9 P30/AIN0_0/TIOB0_1/INT03_2/MDATA6 19 P3A/RTO00_0/TIOA0_1 SEG2-C

10 P31/BIN0_0/TIOB1_1/SCK6_1/INT04_2/
MDATA7 20 P3B/RTO01_0/TIOA1_1 SEG2-D
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The Hardware

The microcontroller pins (cont‘d)

16

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

21 P3C/RTO02_0/TIOA2_1 SEG2-E 31 P44/TIOA4_0/RTO14_1/MAD18

22 P3D/RTO03_0/TIOA3_1 SEG2-F 32 P45/TIOA5_0/RTO15_1/MAD17

23 P3E/RTO04_0/TIOA4_1 SEG2-G 33 C ‘C’ capacitor

24 P3F/RTO05_0/TIOA5_1 SEG2-DP 34 VSS GND

25 VSS GND 35 VCC MCUVCC

26 VCC MCUVCC 36 P46/X0A
Subclock
(optional)

27 P40/TIOA0_0/RTO10_1/INT12_1/MAD22 TINT TSC-Con-
nector ‘INT12’ 37 P47/X1A

Subclock
(optional)

28 P41/TIOA1_0/RTO11_1/INT13_1/MAD21 GINT TSC-Con-
nector ‘INT13’ 38 INITX Key button 

‚Reset‘

29 P42/TIOA2_0/RTO12_1/MAD20 39 P48/DTTI1X_1/INT14_1/SIN3_2/MAD16

30 P43/TIOA3_0/RTO13_1/ADTG_7/MAD19 40 P49/TIOB0_0/IC10_1/AIN0_1/SOT3_2/MA
D15

SDA3 TSC-
Connector
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The Hardware

The microcontroller pins (cont‘d)
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Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

41 P4A/TIOB1_0/IC11_1/BIN0_1/SCK3_2/
MAD14

SCL3 TSC-
Connector 51 VCC MCUVCC

42 P4B/TIOB2_0/IC12_1/ZIN0_1/MAD13 52 P10/AN00

43 P4C/TIOB3_0/IC13_1/SCK7_1/AIN1_2/
MAD12 53 P11/AN01/SIN1_1/INT02_1/RX1_2

44 P4D/TIOB4_0/FRCK1_1/SOT7_1/BIN1_
2/MAD11 54 P12/AN02/SOT1_1/TX1_2/MAD09

45 P4E/TIOB5_0/INT06_2/SIN7_1/ZIN1_2/
MAD101 55 P13/AN03/SCK1_1/MAD08

46 MD1 GND 56 P14/AN04/SIN0_1/INT03_1/MCSX1

47 MD0 Mode-Switch S1 57 P15/AN05/SOT0_1/MCSX0

48 X0 4 MHz Crystal 58 P16/AN06/SCK0_1/MOEX

49 X1 4 MHz Crystal 59 P17/AN07/SIN2_2/INT04_1/MWEX

50 VSS GND 60 AVCC MCUVCC
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The Hardware

The microcontroller pins (cont‘d)
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Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

61 AVRH MCUVCC 71 P23/SCK0_0/TIOA7_1/RTO00_1

62 AVSS GND 72 P22/SOT0_0/TIOB7_1/ZIN1_1 UART0 (TXD)

63 P18/AN08/SOT2_2/MDATA8 SEG1-A 73 P21/SIN0_0/INT06_1/BIN1_1 UART0 (RXD)

64 P19/AN09/SCK2_2/MDATA9 SEG1-B 74 P20/INT05_0/CROUT/AIN1_1 Reset TSC-
Connector

65 P1A/AN10/SIN4_1/INT05_1/IC00_1/MDA
TA10 SEG1-C 75 VSS GND

66 P1B/AN11/SOT4_1/IC01_1/MDATA11 SEG1-D 76 VCC MCUVCC

67 P1C/AN12/SCK4_1/IC02_1/MDATA12 SEG1-E 77 P00/TRSTX JTAG TRSTX

68 P1D/AN13/CTS4_1/IC03_1/MDATA13 SEG1-F 78 P01/TCK/SWCLK JTAG/TRACE 
TCK

69 P1E/AN14/RTS4_1/DTTI0X_1/MDATA14 SEG1-G 79 P02/TDI JTAG/TRACE 
TDI

70 P1F/AN15/ADTG_5/FRCK0_1/MDATA15 SEG1-DP 80 P03/TMS/SWDIO JTAG/TRACE 
TMS
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The Hardware

The microcontroller pins (cont‘d)

19

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

Pin Pin-name
Pin-Function on 
SK-FM-100PMC 

81 P04/TDO/SWO JTAG/TRACE 
TDO 91 P0E/CTS4_0/TIOB3_2/IC13_0/MAD03 CTS4 Flow 

control

82 P05/TRACED0/TIOA5_2/SIN4_2/INT00_
1

TRACE 
TRACED0 92 P0F/NMIX/MAD02

83 P06/TRACED1/TIOB5_2/SOT4_2/INT01
_1

TRACE 
TRACED1 93 P63/INT03_0/SIN5_1/RX0_2/MAD01 USB-Switch 

Device/Host

84 P07/TRACED2/ADTG_0/SCK4_2 TRACE 
TRACED2 94 P62/SCK5_0/ADTG_3/TX0_2/MAD00 Current limit-

ation enable

85 P08/TRACED3/TIOA0_2/CTS4_2 TRACE 
TRACED3 95 P61/SOT5_0/TIOB2_2/UHCONX USB UHCONX

86 P09/TRACECLK/TIOB0_2/RTS4_2 TRACE 
TRACECLK 96 P60/SIN5_0/TIOA2_2/INT15_1 Mode-Switch 

S1

87 P0A/SIN4_0/INT00_2/FRCK1_0/MAD07 UART4 (RXD) 97 USBVCC USB-power 
supply

88 P0B/SOT4_0/TIOB6_1/IC10_0/MAD06 UART4 (TXD) 98 P80/UDM0 USB Data-

89 P0C/SCK4_0/TIOA6_1/IC11_0/MAD05 99 P81/UDP0 USB Data+

90 P0D/RTS4_0/TIOA3_2/IC12_0/MAD04 RTS4 Flow 
control 100 VSS GND
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The Software

The SK-FM3-100PMC CD includes the following software:
MCU Flash programming tools

FUJITSU FLASH MCU Programmer for FM3
FLASH USB DIRECT Programmer 

USB driver for on-board USB-to-RS232 converter
The terminal program SKwizard
Software examples for the SK-FM3-100PMC

Please check our dedicated microcontroller website:

for updates of the Flash programmer tool, utilities and examples
for data sheets, hardware manuals, application notes, etc.

20
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Installation of the USB-driver

Connect the SK-FM3-100PMC via USB (X5) to your PC
Windows will ‘Found New Hardware: SK-FM3-100PMC’ and 
the Hardware Wizard should start automatically

• Note: The installation procedure may differ with different operating systems

Do not connect to Windows Update to search for software 
Select ‘Install from a list or specific location (Advanced)’
Within next windows select ‘Search for the best driver’
and browse on the CD to the folder ‘drive:\USB-
Driver\Win2000_WinXP_Vista_Windows7_Fujitsu’

21
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Installation of the USB-driver

‘Continue anyway’ although the Windows Logo test may not be passed
Windows completes the installation 
by copying some files
‘Finish’ will close the window

22
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Installation of the USB-driver

Again Windows will ‘Found New Hardware: USB Serial Port’ and 
the Hardware Wizard should start automatically

• Note: The installation procedure may differ with different operating systems

Do not connect to Windows Update to search for software 
Select ‘Install from a list or specific location (Advanced)’
Within next windows select ‘Search for the best driver’
and browse on the CD to the folder ‘drive:\ USB-
Driver\Win2000_WinXP_Vista_Windows7_Fujitsu’’

23
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Installation of the USB-driver

‘Continue anyway’ although the Windows Logo test may not be passed
Windows completes the installation 
by copying some files

24
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Installation of the USB-driver

Start the Device Manager of the Windows Control Panel
START -> Settings -> Control Panel 
Control Panel -> System -> Hardware -> Device Manager

Check ‘Ports’ for the assigned virtual COM-port number
FUJITSU Microcontroller board (e.g.: COM3)

Ready!

25
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Tools and Software Examples

SKwizard
Free of charge terminal program
Start installation

Following examples are provided with SK-FM3-100PMC for
IAR Embedded Workbench V6 and KEIL µVision4:

mb9bf506n_template
• ‚Empty‘ project as base for user applications

mb9bfxxx_adc_dvm
• Digital Voltage Meter based on the A/D-converter

mb9bfxxx_can_uart_terminal
• Simple CAN example (CAN0)

mb9bfxxx_ioport_counter
• Counts from 0 to 99 on the 7-segment Display

Further examples on CD Examples and on our website

Note: 
Please copy the examples to your local drive!

26
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Flash Programming

There are two options to program the flash:

1. UART Programming (X4, X5)
• Check jumper JP16 is opened
• Connect UART0 of the board to the USB-Port of the PC 

– via USB (JP4,JP5: U-0, R-4)
– via RS232 (JP4,JP5: U-4, R-0)

• Use the FUJITSU FLASH MCU Programmer

2. USB Programming (X3)
• Check jumper JP16 is closed
• Connect the board via USB-Device (X3) to the USB-Port of the PC
• Use the FLASH USB DIRECT Programmer

All Rights Reserved.© Fujitsu Limited 2010
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FUJITSU FLASH MCU Programmer 
for UART Programming

FUJITSU FLASH MCU Programmer
Free of charge, no registration required
Windows based programming tool for FM3 Fujitsu microcontroller
Uses PC serial port COMx (incl. virtual COM port: USB-to-RS232)
Start installation

All Rights Reserved.© Fujitsu Limited 2010
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Program Download

Start the FUJITSU FLASH MCU Programmer
Select the target microcontroller (MB9BF506)
Select the crystal frequency (4 MHz)
Choose the software example from the example ‘exe‘-folder 
(e.g. Examples\mb9bfxxx_ioport_counter-vxx10\example\IAR\output\release\exe\
mb9bfxxx_ioport_counter.srec)

29
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Connect to the PC 
Connect UART0 with RS232 (X4) or
with the USB interface X5
Select COM port (‚Set Environment‘)

Open JP16
Set switch S1 to position ‚PROG‘
Press ‚Reset‘
Start ‚Full Operation‘

Program Download

30

(see JP4, JP5 jumper settings) 

RS232   USB port 

S1: Mode selection
PROG: Set switch to position 
‚PROG‘ in order to select the 
program-mode

Keybutton ‚RESET‘

All Rights Reserved.© Fujitsu Limited 2010



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics

Close the FUJITSU FLASH MCU Programmer
Set switch S1 to position ‚RUN‘
Press ‚Reset‘

Program Download

31

S1: Mode selection
RUN: Set switch to position ‚RUN‘
in order to select the run-mode

Keybutton ‚RESET‘

Close the FUJITSU FLASH 
MCU Programmer 
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FLASH USB DIRECT Programmer
for USB Direct Programming

All Rights Reserved.© Fujitsu Limited 2010
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FLASH USB DIRECT Programmer
Windows based programming tool for FM3 Fujitsu microcontroller
Uses direct USB connection (via X3)
Start installation
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Program Download
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Start the FLASH USB DIRECT Programmer
Select the target microcontroller (MB9BF506)
Choose the software example from the example ‘exe‘-folder 
(e.g. Examples\mb9bfxxx_ioport_counter-v10\example\IAR\output\release\exe\

mb9bfxxx_ioport_counter.srec)

Select the COM port 
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Program Download

Select the MCU power supply (J5)
Close JP16
Set switch S1 to position ‚PROG‘
Connect USB port X3 with the PC 
Install the USB driver

See subfolder ‚driver‘ of installed programmer
E.g.: C:\FUJITSU USB DIRECT Programmer

Press ‚Reset‘
Start ‚Full Operation‘

34
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Keybutton

‚RESET‘

USB port X3 J5

JP16

S1: Mode selection
PROG: Set switch to position 
‚PROG‘ in order to select the 
program-mode



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics

Program Download

Close the FLASH USB DIRECT Programmer
Set switch S1 to position ‚RUN‘
Press ‚Reset‘

All Rights Reserved.© Fujitsu Limited 2010
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Close the FLASH USB 
DIRECT Programmer

S1: Mode selection
RUN: Set switch to position ‚RUN‘
in order to select the run-mode

Keybutton ‚RESET‘
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Debugging via JTAG

The MB9BF506N microcontroller offers a JTAG-Interface
that is supported by SK-FM3-100PMC.

Debug your program with a JTAG-Adapter e.g. Segger J-Link
Connect the J-Link to the JTAG-Interface routed to the 20-Pin-Header 
on X13 and to the USB-Port of your PC
Use IAR-Embedded Workbench to debug your program  
If the JTAG-Adaper allows powering the target, then jumper J5 can be 
set as follows: 

36
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Debugging via TRACE

The MB9BF506N microcontroller offers an ETM (Embedded-
Trace-Macrocell) that is supported by SK-FM3-100PMC

An optional JTAG-Adapter supporting trace features is required e.g. 
ULINKpro from KEIL
The ETM is connected to the 20-Pin-Header X11 (TRACE)
Use e.g. KEIL µVision to trace your program  

All Rights Reserved.© Fujitsu Limited 2010
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IAR-Embedded Workbench /
KEIL µVision IDE and Debugger 

Installation
Getting Started
Open Project
Build Project
Debug Project

All Rights Reserved.© Fujitsu Limited 2010
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IAR Workbench Getting Started

Install EWARM from IAR-CD or download latest version from 
IAR Website

EWARM 30-day Evaluation Version
• http://supp.iar.com/Download/SW/?item=EWARM-EVAL

EWARM 32K Kickstart Version
• http://supp.iar.com/Download/SW/?item=EWARM-KS32

Install J-Link Debugger (SK-FM3-100PMC-JLINK)
Connect J-Link to USB Port and follow installation instructions

• Drivers:
<Installation_Path>\IAR Systems\Embedded Workbench 
x.y\arm\drivers\Jlink\ x64 or x86

Start EWARM Workbench

All Rights Reserved.© Fujitsu Limited 2010
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http://supp.iar.com/Download/SW/?item=EWARM-EVAL
http://supp.iar.com/Download/SW/?item=EWARM-KS32
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IAR Workbench Getting Started
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Choose File → Open → Workspace
Select e.g.\ Examples\mb9bfxxx_ioport_counter-
vxx\example\IAR\ mb9bfxxx_ioport_counter.eww
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IAR Workbench – Main Window
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IAR Workbench
Workspace on left side
of Workbench window

• Choose:
View→Workspace,
if hidden

Source files on right
side of Workbench
window as tabbed
windows

Project can
alternatively be
opened by:
File→Open→
Workspace→*.eww 
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IAR Workbench – Menu Bar

Menu Bar
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File Control 
(new, open, 
save, etc.)

Edit Control
(cut, copy, 

paste, undo, 
redo)

Configuration 
Control

(e.g. RAM or ROM 
debugging)

Navigation Control
(Find, Bookmarks, File 

Navigation, etc.)

Build Control
(compile, make, 

stop build)

Debug Control
(Breakpoint, start 
Debug w/ and w/o 

download)
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IAR Workbench – Workspace

IAR Workspace Window
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Project Name

Sub Folder Modules

Main Modules

Module Includes

Project Description

Project Built Output
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IAR Workbench – Making Project

Making the Project
Use Make-Icon (      ), <F7> or
Menu: Project→Make
Check for no errors in Output window
below

Build errors are indicated by       or
In Output window and Source view

44
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IAR Workbench – Download to 
Target

Download to Target and Start Debugging
Use       Icon, <Ctrl>-D, or Project→Download and Debug
A new menu bar will occur on sucessful connection to target

45
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Reset 
Target

Stop

Step 
Over

Step 
Into

Step 
Out

Next 
Statement

Run to 
Cursor

Run

End 
Debugging

Trace 
Control
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IAR Workbench – Debug (1)

Source Window
The Source windows do not change contents but get additional 
information

• Current line (PC):
• Halted on Breakpoint:
• Halted on Data break (example):  

Disassembly Window
Shows ‘pure‘ disassebly view
Shows mixed mode view

46
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IAR Workbench – Debug (2)

Watch Window
Watch

• Expressions/Variables have to be added by user and are updated 
by Halt/Breakpoint

Quick Watch
• The Quick watch allows the user to calculate and recalculate 

expressions even with variables

• The drop down menu memorizes the last typed contents

All Rights Reserved.© Fujitsu Limited 2010
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IAR Workbench – Simulator

Simulator
Mark Project File in Workspace
Choose Project→Options
Choose Simulator in Debugger Setup
Start Simulator with usual      Icon

48
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KEIL µVision IDE and Debugger 
Getting Started

Install µVision from KEIL-CD or download latest version from 
KEIL Website

Evalualtion Version
• https://www.keil.com/demo/eval/arm.htm
• Registration required

Install ULINK-ME 
Specical installation is not needed, because ULINK-ME acts as a USB 
Human Interface Device (HID) and thus needs no extra USB driver

Install ULINK Pro (optional)
ULINK Pro needs an own dedicated USB driver located in:
<Installation Path>\KEIL\ARM\ULINK

Start µVision

All Rights Reserved.© Fujitsu Limited 2010
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KEIL µVision – Getting Started

Choose Menu: Project→Open Project...
Browse to: Examples\mb9bfxxx_ioport_counter-v10\example\ARM\
Choose mb9bfxxx_ioport_counter.uvproj

All Rights Reserved.© Fujitsu Limited 2010
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KEIL µVision – Main Window

KEIL µVision
Project window on left side of
IDE window

• Choose:
View→Project Window
if hidden

Source files on right side
of IDE window as tabbed
windows
Output window on bottom
side of IDE window

All Rights Reserved.© Fujitsu Limited 2010
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KEIL µVision – Menu Bars (1)

Menu Bar 1
Can be moved in bar window area or set floating
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File Control
(new, open, 
save, etc.)

Edit Control
(cut, copy, paste, etc)

(indention, commenting)

Navigation Control
(Bookmarks + search, etc.)

(Text search, search in files, etc.)

Debug Control
(Start/Stop Debug Session, 

set/remove/disable 
breakpoints, remove/disable 

all breakpoints)

Project 
Window View

IDE 
Configuration
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KEIL µVision – Menu Bars (2)

Menu Bar 2
Can be moved in bar window area or set floating
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Build Control
(Compile [Translate], 
Build, Rebuild, etc.)

Download 
to Target

Configuration 
Control

(e.g. RAM or ROM 
debugging)

Target 
Options

Manage Books, 
File Extensions, 

Environment

Manage 
Multi-

Project 
Workspace
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KEIL µVision – Project Window

µVision Project Window

All Rights Reserved.© Fujitsu Limited 2010
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Project Name

Startup Code Subfolder

Startup Code Source and 
HeaderFiles

Main Project Code Subfolder

Main Project Code Source and 
Header Files

Project Description Subfolder 
and Abstract File
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KEIL µVision – Making Project

Making the Project
Use Rebuild Icon
(      ) or
Project→Rebuild all target
files
Check for no errors in
Output window below

Build errors are shown in Output window.
• Can be double-clicked by showing the source line with a blue arrow
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KEIL µVision – Debug (1)

Start Debugging
Download to target first, when MCU Flash does not contain the current 
application openend and built in the IDE

• Use Download Icon (      ) or Menu: Flash→Download
Start Debug Session

• Use Start/Stop Debug Icon (       ) or Menu: Debug→Start/Stop 
Debug Session

Ending Debug Session
• Use same way as for starting debug session

56
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KEIL µVision – Debug (2)

Debugging Icon Bar
During a Debug Session there will be visible a new icon bar

All Rights Reserved.© Fujitsu Limited 2010
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Reset 
Target

Start/
Stop

Application

Step Control 
(Step in, out, 

etc.)

Show 
Source/Code 
Line of current 

PC

Show Windows 
(Command, Disassembly, 

Symbols, Registers, Call Stack)

Show (multiple) 
Windows

(Watch, Memory, Serial, 
Analysis, Trace, System 

Viewer)

Tool Box 
(can be 

customized)

Debug 
Restore 
Views



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics

KEIL µVision – Debug (3)

Source View
The Source windows do not change contents but get additional 
information
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Active Breakpoint

Disabled Breakpoint

Current Program 
Counter

Current Cursor Line of 
Source Code

Code Lines with 
compiled Instructions 

(dark grey    )
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KEIL µVision – Debug (4)

Disassembly View
Mixed mode is selectable and deselectable
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Active Breakpoint

Disabled Breakpoint

Current Program 
Counter

Current Cursor Line of 
Code highlighted in 

yellow background (   )
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KEIL µVision – Debug (5)

Memory Window
Up to 4 Memory windows can be displayed in tabs
Memory is updated during runtime
Memory window tabs are shared with Watch windows

Register View
Register view is a tab of the Project window
Changes are highlighted in dark blue text
background
Register tree knots can be expanded
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KEIL µVision – Debug (6)

Variable Windows
Watch Windows

• Up to 2 Watch windows are sharing their tabs with e.g. Memory and 
Local views

• Updated during runtime
• Any changes are highlighted in dark blue text backround color
• Displayed values can be changed by user during break

Local View
• The local view shares the tab with e.g. Memory and Watch windows
• Any changes are highlighted in dark blue text backround color
• Displayed values can be changed by user during break
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KEIL µVision – Trace (ULINK ME)

Trace via ITM
Simple Trace views via Instrumentation Trace Macro is supported by 
µLINK ME

• Records
• Exceptions
• Counters

All Rights Reserved.© Fujitsu Limited 2010
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KEIL µVision –
Trace (ULINK Pro) (1)

Trace via ETM
Check settings in menu:
Flash→Configure Flash Tools... Tab:Debug
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enables ETM pins
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KEIL µVision –
Trace (ULINK Pro) (2)

Instruction Trace
Real Time Trace recording
Output can be filtered by several ETM and ITM events
Trace buffer is held in PC memory and transfered to µVision on break
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KEIL µVision – Simulator

Simulator
The Core Simulator can be selected by the menu:
Flash→Configure Flash Tools... and then choosing Use Simulator
Look & feel is like using ULINK debugger
Controlable also with *.ini files

All Rights Reserved.© Fujitsu Limited 2010
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Further Steps

In order to learn more about Fujitsu’s microcontrollers

Visit our microcontroller website
• http://mcu.emea.fujitsu.com
• http://mcu.emea.fujitsu.com/mcu_product/detail/MB9BF506NPMC.htm

See our application notes
• http://mcu.emea.fujitsu.com/mcu_product/mcu_all_appnotes.htm

See our software examples
• http://mcu.emea.fujitsu.com/mcu_product/mcu_all_software.htm

Contact your local distributor …

for individual support
to register for our monthly FM3 seminar  
to order the latest ‘Fujitsu Micros DVD’ containing all information regarding 
Fujitsu’s 8-bit, 16-bit, and 32-bit microcontrollers
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Contacts - Distribution

European distributors

Anatec                                        www.anatec.ch
EBV Elektronik                          www.ebv.com
Farnell                                        www.farnell.com
Glyn                                            www.glyn.de , www.glyn.ch
Ineltek                                         www.ineltek.com
Melchioni Electronica               www.melchioni.it
PN Electronics                           www.pne.fr
Rutronik Elektronische             www.rutronik.com
Bauelemente
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Fujitsu Semiconductor Europe

Germany (Headquarters)
Pittlerstrasse 47, D-63225 Langen
Tel: (0 61 03) 69 00, Fax: (0 61 03) 69 01 22

France
2-12 Chemin des Femmes, F-91300 Massy
Tel: (01) 64 47 97 07, Fax: (01) 64 47 97 01

Italy
Palazzo Pitagora – Milano 3 City, Via Ludovico il Moro 4B, 
I-20080 Basiglio, Milano
Tel: (02) 90 45 02 1, Fax: (02) 90 75 00 87

United Kingdom
Network House, Norreys Drive, Maidenhead, Berkshire SL6 4FJ
Tel: (01628) 50 46 00, Fax: (01628) 50 46 66

World Wide Web
http://emea.fujitsu.com/microelectronics
http://mcu.emea.fujitsu.com
Contact: mcu_ticket.FSEU@de.fujitsu.com
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EU-Konformitätserklärung /
EU declaration of conformity

Hiermit erklären wir, Fujitsu Semiconductor Europe GmbH, Pittlerstrasse 47, 63225 Langen, Germany
dass dieses Board aufgrund seiner Konzipierung und Bauart sowie in den von uns in Verkehr gebrachten 
Ausführung(en) den grundlegenden Anforderungen der EU-Richtlinie 2004/108/EC „Elektromagnetische Verträglichkeit“
entspricht. Durch eine Veränderung des Boards (Hard- und/ oder Software) verliert diese Erklärung ihre Gültigkeit!

We, Fujitsu Semiconductor Europe GmbH, Pittlerstrasse 47, 63225 Langen, Germany 
hereby declare that the design, construction and description circulated by us of this board
complies with the appropriate basic safety and health requirements according to the EU Guideline 2004/108/EC entitled 
’Electro-Magnetic Compatibility’. Any changes to the equipment (hardware and/ or software) will render this declaration 
invalid!

Note:
All data and power supply lines connected to this starter kit should be kept as short as possible, with a maximum 
allowable length of 3m. Shielded cables should be used for data lines. As a rule of thumb, the cable length used when 
connecting external circuitry to the MCU pin header connectors for example should be less than 20cm. Longer cables
may affect EMC performance and cause radio interference.
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Recycling

Gültig für EU-Länder:
Gemäß der Europäischen WEEE-Richtlinie und deren Umsetzung 
in landesspezifische Gesetze nehmen wir dieses Gerät wieder zurück.
Zur Entsorgung schicken Sie das Gerät bitte an die folgende Adresse:

Valid for European Union Countries:
According to the European WEEE-Directive and its implementation 
into national laws we take this device back.
For disposal please send the device to the following address:

Fujitsu Semiconductor Europe GmbH
Warehouse/Disposal 

Monzastraße 4a
D-63225 Langen

This board is compliant with China RoHS
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CD Contents

Software
FUJITSU FLASH MCU Programmer
FLASH USB DIRECT Programmer
SKwizard

Documents
Schematic ‘SK-FM3-100PMC’
Data sheet MB9B500 Series
Peripheral Manual

Errata sheet 
Technical Reference Manual
Flash Programming Manual

Download the latest version from the following website:
http://mcu.emea.fujitsu.com

71

Examples
mb9bf506n_template
Further examples on CD Examples
and on our website

Note: 
Please copy the examples 
to your local drive!
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