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TWR-56F8200 Tower Board 
 

 

1 Overview                                

The MC56F8200 Tower System 32-bit MCU 

module (TWR-56F8200) is an evaluation, 

demonstration and development board.  The 

TWR-56F8200 can operate standalone or as the 

main control board in a Tower system with 

peripheral modules. It can also be used as the 

main control board with an 

APMOTOR56F8000E motor control board. 

 

The following list summarizes the features of 

the TWR-56F8200: 

 32-bit Digital Signal Controller module 

featuring MC56F82748 in a 64-LQFP 

package 

 Tower system compatible 

 Selectable power sources:  

o USB on 56F8200 card 

o Barrel connector on 56F8200 

card 

o Motor control board plug 

direct to 56F8200 card, no 

Tower System connection, 

plug motor control to 9 V.  

o Tower System elevator board 

(USB or Barrel on Primary 

side) 
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 Filtered power for VDDA and VSSA on the 32-bit MC56F82748DSC 

 Optional 8 MHz crystal circuit for the MC56F82748 DSC 

 Nine LEDs controlled by the MC56F82748 DSC 

 Two trimmer potentiometers for user to change analog input voltage 

 Motor Control Board connector for the APMOTOR56F8000E motor control board 

 Auxiliary Signal connector 

 Four thermistors for single-ended or differential analog inputs to the MC56F82748 DSC 

 CAN transceiver, header, and termination 

 Two push-buttons for user input or interrupts to the MC56F82748 DSC 

 Reset push-button for the MC56F82748 DSC 

 JTAG header for the MC56F82748 DSC with header to disconnect from OSBDM/OSJTAG 

 Headers to connect SCI signals to either USB bridge with CDC(one channel) or elevator board 

(two channels) or connect one to each 

 Expansion via Primary Elevator connector 

 MC9S08JM60 MCU with a 4 MHz crystal provides: 

o Open Source Debug (OSBDM/OSJTAG) circuit 

o USB- to-SCI bridge with CDC and other techniques supported by third parties 

o Simultaneous OSBDM/OSJTAG and USB -to-SCI bridge functions with no header 

required to select 

o Header with enabled boot loader allows easy upgrade to latest S08 firmware pushed 

down by CodeWarrior 

o BDM header for the MC9S08JM60 MCU 

o Status and Target Power indicator LEDs 

o Control of semiconductor switch to supply power to board from USB 

o Voltage translators between 5 V MC9S08JM60 MCU chip and 3.3 V MC56F82748 DSC 

chip 

1.1 Block diagram 

The block diagram for the TWR-56F8200 board is shown in this figure. 
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From an engineering perspective, the measuring instrument is controlled by legally relevant and legally 

non-relevant software applications (see Error! Reference source not found.). 
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relevant software
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Communication Keyboard

HAN

RTC

NVM
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billing

  ADC
   Aux.

Software 
separation

 

Legally non-relevant applications perform all remaining software tasks including communicating 

digitally-signed packets to the utilities and providing data to equipment attached to a Home Area  

 
 

 

Figure 2. Kinetis M block diagram 

1.2 Reference documents 

The documents listed below should be referenced for more information on the Freescale Tower system 

and the TWR-56F8200.  See www.freescale.com/MC56F827xx, www.freescale.com/TWR-56F8200, 

and www.freesale.com/Tower for the latest revision of all applicable documentation (if and when 

available).  

1. Freescale Tower Electromechanical Specification 

2. TWR-56F8200 Quick Start Guide 

3. TWR-56F8200  Sample code 

4. MC56F82XXX Reference Manual 

5. MC56F82XXX Data Sheet 

6. MC56F82XXX Chip Errata [if exists] 

7. USB Bootloader for the MC9S08JM60 (document number AN3561) 

8. APMOTOR56F8000e Motor Control Demonstration System User Guide 

9. BLDC Motor Control with Hall Sensors Driven by DSC using TWR-56F8257 and TWR-MC-

LV3PH (document number AN4413) 

2 Hardware features 

This section provides more details about the features and functionality of the TWR-56F8200. 

A schematic drawing of the TWR-56F8200 showing the jack locations is given in Appendix D—TWR-

56F8200 board jack layout (top view). Features are discussed in the following sections. 
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Headers 

5.0V
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Mini-AB 

Voltage 
Translators 
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Header 

 

 LEDs & Buffers (9) 

 IRQ PB & HDRs (2) 

 RESET PB 

 Thermistors & HDRs 

(4) 

 Analog Filters 

 Microphone (optional) 

 

 CAN XCVR & HDR 

Barrel Power Connector 
Power Selection HDRs 
Voltage Regulator 

5V-
9V 

3.3V 

MC56F82748 

Digital Signal 

Controller 

JTAG 
Header 

Boot load HDR 

Figure 1. TWR-56F8200 block diagram 

http://www.freescale.com/MC56F827xx
http://www.freescale.com/TWR-56F8200
http://www.freesale.com/tower
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2.1 Tower system MCU module 

The TWR-56F8200 board is an MCU module designed for standalone use (or with a Freescale Tower 

system) and complies with the electrical and mechanical specification as described in Freescale Tower 

Electromechanical Specification [1]. Connection to the Tower system is through two expansion card-

edge connectors that interface to the Elevator boards in a Tower system: the Primary and Secondary 

Elevator connectors.  The Primary Elevator connector, comprised of sides A and B, is utilized by the 

TWR-56F8200, while the Secondary Elevator connector only makes connections to ground (GND).  On 

sheet 8 of the TWR-56F8200-SCH (See Appendix B—TWR-56F8200 board schematic), the J500A and 

J500B symbols have names assigned to the card edge fingers that correspond with the normal Tower 

system pin assignments.  

Note: On the top and bottom of one edge of the TWR-56F8200 board, there is a WHITE BELT; the 

card-edge connectors next to the WHITE BELT on the TWR-56F8200 board should be connected to the 

Primary Elevator board which uses the WHITE PCI connector.  The card-edge connectors without the 

WHITE BELT on the TWR-56F8200 board should be connected to the secondary Elevator board (or left 

unconnected) using the Black PCI connector. This instruction overrides any silkscreen information that 

may be present, such as the words “Primary” or “Secondary” on the TWR-56F8200, since early 

revisions had this reversed. 

2.2 System power 

The TWR-56F8200 board has three power rails: P5V_USB, P3_3V, and P3_3V/5V. The sources and 

usage of these power rails is described as follows. 

2.2.1 P5V_USB 

The P5V_USB power rail is derived from the mini-B USB connector at J18 and the inductor at L2. It is 

used to power the on board OSBDM/OSJTAG/Serial Bridge circuit. This consists of the 

OSBDM/OSJTAG MCU at U6, several pullup resistors at R13, R14, R15, R527, and R528, the USB 

power switch at U501, and the STATUS and TPWR LEDs at D12 and D13. If there is no USB cable 

connected to J18, there is no power on this rail and all these circuits are powered down. 

2.2.2 P3_3V 

The P3_3V power rail is derived from either of the following sources. 

 the P3_3V_MOTOR power net from the motor control board connector at J501,  

 the P3_3V_ELEV power net from the Tower connector at J500, or  

 the onboard 3.3 V regulator at U1 

The selection of any of these power sources is made with a shunt from J7-2 (jumper J7 pin 2) to another 

pin of J7 or to J6. A shunt from J11-2 (Jumper J11-pin2) to another pin of J11 or to J10, is used to select 

power to the regulator from the following sources:  
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 the P5V_TRG_USB power net out of the USB switch at U501,  

 the P5V_ELEV power net from the elevator connection at J500 pins A1 and B1, or  

 the PWR_IN power net from the 2mm barrel jack at J3 through resettable fuse F1.  

Table 6 shows the operation of the different shunt positions. The barrel jack input is protected from 

reverse voltage inputs by diode D11. The input to the barrel jack may be from a 5-9 V source and needs 

to be center-positive.  

The P3_3V power rail provides power to the majority of the circuits on the board including the 

MC56F82748 (including the analog power pins through L500 and L501), inverters at U500 and U502, a 

buffer at U505, the onboard LEDs at D1-D9, the thermistor divider circuits at RT1-RT4, and the pullup 

resistors at R2, R3, R11, R565, R570, and R562. 

2.2.3 P3_3V/5V 

The P3_3V/5V power rail is derived from the diode OR (using D500 and D501) of:  

 the P5V_ELEV power net from the elevator connection (J500 pins A1 and B1),  

 the P5V output of the USB power switch at U501, or c) the P3_3V power rail from J7.  

When there is a USB cable connected or when the Tower elevator boards are connected, this power rail 

will be a Schottky diode drop (about 0.3V) below the 5 V power nets. When there is no 5 V source, this 

power rail will be a Schottky diode drop below the P3.3V power rail. This allows the inputs of the ICs 

powered by this rail to stay in a high-impedance state instead of loading down the inputs through the 

input protection diodes as would happen if there were no power supplied to the buffers.  

2.2.4 Default power configuration 

The TWR-56F8200 board default power configuration uses the OSBDM/OSJTAG USB port for all 

power. As soon as the OSBDM/OSJTAG firmware has started, it negotiates with the host PC USB port 

for full USB power. Once approved, it enables the 5V USB power switch (U501) which provides 5 V to 

the P3_3V/5 V power rail and to the 3.3 V regulator (U1) through headers J10 and J11. Likewise, the 

onboard voltage regulator provides 3.3 V to the P3_3V power rail through headers J6 and J7. The 3.3 V 

regulator is able to provide up to 700 mA current, subject to the power dissipation and temperature 

limits of the device. 

2.3 MC56F82748 DSC 

The primary circuits on the board are related to the MC56F82748 DSC. This part is supplied in a 

surface-mounted 64-pin LQFP package at U2. Although the board was laid out to allow a ZIF socket at 

U3 in parallel to the chip at U2, the TWR-56F8200 is only available for purchase with the surface-

mounted chip. 
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2.3.1 Clock sources for the MC56F82748 DSC 

Three options are available for clocking the MC56F82748 device: 

 Oscillator internal to the MC56F82748 chip —approximately 8 MHz.  

 8 MHz crystal 

 External clock input from Primary Tower Connector or the AUX Connector. 

The internal oscillator is used to clock the MC56F82748 MCU immediately following reset. This is the 

default operation. In this mode, the 0-ohm resistors at R4 and R10 allow the GPIOC0 and GPIOC1 pins 

of the MC56F82748 MCU to be used as inputs or outputs. 

To use an external crystal with the MC56F82748, 0-ohm resistors R4 and R10 must be removed and 

placed in the R5 and R7 positions. The desired crystal, load capacitors, and parallel resistor (if needed) 

must be soldered to the board at Y1, C5, C6, and R6. (These components are not provided with the 

TWR-56F8200 kit.) Following reset, reconfigure the GPIOC0 and GPIOC1 pins to the XTAL and 

EXTAL functions to allow the use of an external crystal.  

To use an external clock for the MC56F82748, make sure the 0-ohm resistors are installed at R4 and 

R10 and removed from R5 and R7. Provide a clock signal on either the Primary Tower Connector 

J500A - pin B24 (the pin designated as CLOCKIN0), or on the AUX connector J502 - pin 8. Following 

reset, configure the GPIOC0 pin to the CLKIN input function. In this mode, the 0-ohm resistors at R10 

allows the GPIOC1 pin of the MC56F82748 (pin 10) to be used as an input or output. 

2.3.2 Serial I/O source select headers 

The TWR-56F8200 board allows the UART functions of the MC56F82748 DSC to be connected to the 

serial interface of the Primary Tower Connector J500A or through a USB bridge to the host PC using the 

OSBDM/OSJTAG MCU (U6). The selection of the RXD connections is done as shown in Table 1. The 

selection of the TXD connections is done as shown in Table 2. 

Table 1. J8-RXD source select header 

Pin# Connected signal Description 

1 ELEV_RXD0 at J500A pin A41 Shunt pins 1 and 2 together to connect the DSC 

RXD0 pin to the primary Tower Connector 

RXD0 pin. (This is a default position.) 

2 GPIOF8/RXD0/TB1 from the 

56F82748 DSC – pin 6 (RXD0 

function) 

— 
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Pin# Connected signal Description 

3 RXD_SEL from the USB bridge 

function on the OSBDM/OSJTAG 

MCU. 

 Shunt pins 2 and 3 together to connect 

the DSC RXD0 pin to the USB serial 

bridge function. 

 Shunt pins 3 and 4 together to connect 

the DSC RXD1 pin to the USB serial 

bridge function. 

4 GPIOF5/RXD1/XB_OUT5 from the 

56F82748 DSC – pin 42 (RXD1 

function) 

— 

5 ELEV_RXD1 at J500 pin A43 Shunt pins 4 and 5 together to connect the DSC 

RXD1 pin to the primary Tower Connector 

RXD1 pin. (This is a default position.) 

 

Table 2. J9–TXD source select header 

Pin # Connected Signal Description 

1 ELEV_TXD0 at J500A pin A42 Shunt pins 1 and 2 together to connect the DSC 

TXDO pin to the primary Tower Connector 

TXD0 pin. (This is a default position.) 

2 GPIOC2/TXD0/TB0/XB_IN2/CLKO 

from the 56F82748 DSC – pin 5 

(TXD0 function) 

— 

3 TXD_SEL to the USB bridge function 

on the OSBDM/OSJTAG MCU. 
 Shunt pins 2 and 3 together to connect 

the DSC TXD0 pin to the USB serial 

bridge function. 

 Shunt pin 3 and 4 together to connect the 

DSC TXD1 pin to the USB serial bridge 

function. 

4 GPIOF4/TXD1/XB_OUT4 from the 

56F82748 DSC – pin 41 (TXD1 

function) 

— 

5 ELEV_TXD1 at J500 pin A44 Shunt pins 4 and 5 together to connect the DSC 

TXD1 pin to the primary Tower Connector 

TXD1 pin. (This is a default position.) 
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As can be seen in the tables, the 56F82748 DSC serial signals may be connected to either the Tower 

serial signals or to the USB bridge chip; however, only one channel may be connected to the USB 

bridge chip. If the associated 56F82748 DSC serial pins are not being used for the serial functions, the 

shunts should be removed from those pins. For more information on the USB Serial Bridge function, see 

USB serial bridge interface. 

There are some tower boards available, such as TWR-SER that provide serial ports based on these 

elevator connections.  These boards can work with the TWR-56F8200, if configured and installed in the 

same Tower system. 

2.3.3 LEDs controlled by the MC56F82748 DSC 

There are nine LEDs with buffers connected to the MC56F82748 DSC. Inverting buffers (U500A-F and 

U502D-F) isolate the LEDs from the DSC pins by providing high-impedance inputs.  The LEDs are 

powered by the P3_3V rail and each LED draws about 5 mA current. This table shows the DSC pin 

names associated with each LED. 

Table 3. LEDs controlled by the MC56F82748 DSC 

MC56F82748 DSC 

Pin name 

MC56F82748 

Pin number 

LED 

Reference 

LED 

Label 

LED 

Color 

GPIOE0/PWM0B 45 D1 E0 Green 

GPIOE1/PWM0A 46 D2 E1 Yellow 

GPIOE2/PWM1B 47 D3 E2 Green 

GPIOE3/PWM1A 48 D4 E3 Yellow 

GPIOE4/PWM2B/XB_IN2 51 D5 E4 Green 

GPIOE5/PWM2A/XB_IN3 52 D6 E5 Yellow 

GPIOE6/PWM3B/XB_IN4 53 D7 E6 Green 

GPIOE7/PWM3A/XB_IN5 54 D8 E7 Yellow 

GPIOF6/TB2/PWM3X 94 D9 F6 Amber 

2.3.4 Motor control connector 

The TWR-56F8200 board may be connected to a motor control board APMOTOR56F8000E. The motor 

control connector (J501) is at the bottom of the board to provide a convenient connection to the motor 

control board.  
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Some of the MC56F82748 DSC pins are connected to the motor control connector. The pins associated 

with analog inputs have 100 Ω resistors in series to provide some ESD protection for the analog inputs 

of the DSC. The pins providing analog signals from the motor control board have 2200 pF capacitors 

with the 100 Ω resistors to provide a low-pass filter. The connector pinout is shown in Table 4. 

 

Table 4. Motor control connector pinout 

Pin 

# 

MC56F82748 DSC signal Pin 

# 

MC56F82748 DSC signal 

1 P3_3V_MOTOR 2 GPIOB7/ANB7&ANC15&CMPB_IN2 

(With 100 Ω in series) 

3 GND 4 RESETB/ GPIOD4 

(With 0 Ω in series – remove to isolate) 

5 GPIOF4/TXD1/XB_OUT8 6 GPIOA3/ANA3&VREFLA&CMPA_IN2 

(With 100 Ω in series) 

7 GPIOF3/SDA1/XB_OUT7 8 GND 

9 GPIOE1/PWMA_0A 10 GPIOA0/ANA0&CMPA_IN3/CMPC_O 

(With 100 Ω, 2200 pF low-pass filter) 

11 GPIOE0/PWMA_0B 12 GPIOA1/ANA1&CMPA_IN0 

(With 100 Ω, 2200 pF low-pass filter) 

13 GPIOC3/TA0/CMPA_O/RXD0/CLKIN1 14 GPIOA2/ANA2&VREFHA&CMPA_IN1 

(With 100 Ω, 2200 pF low-pass filter) 

15 GPIOC13/TA3/XB_IN6/EWM_OUT_B 16 GND 

17 GPIOC4/TA1/CMPB_O/XB_IN8/EWM_OUT_B 18 GPIOB0/ANB0&CMPB_IN3 

(With 100 Ω, 2200 pF low-pass filter) 

19 GPIOC6/TA2/XB_IN3/CMP_REF 20 GPIOB1/ANB1&CMPB_IN0 

(With 100 Ω, 2200 pF low-pass filter) 

21 GPIOC15/SCL0/XB_OUT5 22 GPIOB2/ANB2&VREFHB&CMPC_IN3 

(With 100 Ω, 2200 pF low-pass filter) 

23 GPIOC14/SDA0/XB_OUT4 24 GND 

25 TDI /GPIOD0 26 GPIOE7/PWMA_3A/XB_IN5/PWMB_2A 

27 TDO/ GPIOD1 28 GPIOE6/PWMA_3B/XB_IN4/PWMB_2B 
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Pin 

# 

MC56F82748 DSC signal Pin 

# 

MC56F82748 DSC signal 

29 TCK/GPIOD2 30 GPIOE3/PWMA_1A 

31 TMS /GPIOD3 32 GPIOE2/PWMA_1B 

33 GPIOB3/ANB3&VREFLB&CMPC_IN0 

(With 100 Ω in series) 

34 GPIOE5/PWMA_2A/XB_IN3 

35 GPIOB4/ANB4&ANC12&CMPC_IN1 

(With 100 Ω in series) 

36 GPIOE4/PWMA_2B/XB_IN2 

37 GPIOB5/ANB5&ANC13&CMPC_IN2 

(With 100 Ω in series) 

38 GPIOA4/ANA4&ANC8&CMPD_IN0 

(With 100 Ω in series) 

39 GPIOB6/ANB6&ANC14&CMPB_IN1 

(With 100 Ω in series)(100K Trimpot in parallel) 

40 GPIOA5/ANA5&ANC9 

(With 100 Ω in series)(100K Trimpot in 

parallel) 

 

2.3.5 Auxiliary connectors 

In addition to the motor control connector, the TWR-56F8200 board also provides two auxiliary 

connectors J502 at the bottom of the board. These connectors provide access to the MC56F82748 DSC 

signals that are not covered by the motor control connector. The pins associated with analog inputs have 

100 Ω resistors in series to provide some ESD protection for the analog inputs of the DSC. The 

connector pinout is shown in this table. 

Table 5. Auxiliary connector J502 pinout 

Pin # MC56F82748 DSC signal Pin # MC56F82748 DSC signal 

J502-1 GPIOF0/XB_IN6/TB2/SCK1 J502-2 GPIOA6/ANA6&ANC10 

(With 100 Ω in series) 

J502-3 GPIOF1/CLKO1/XB_IN7/CMPD_O J502-4 GPIOA7/ANA7&ANC11 

(With 100 Ω in series) 

J502-5 GPIOF2/SCL1/XB_OUT6 J502-6 GND 

J502-7 GPIOF5/RXD1/XB_OUT9 J502-8 GPIOC0/EXTAL/CLKIN0 

J502-9 GPIOF6/TB2/PWMA_3X/PWMB_3X/XB

_IN2 

J502-10 GPIOC1/XTAL 



 

  TWR-56F8200 Tower Board, Rev. 1, 10/2013 

Freescale Semiconductor Inc.  11 

Pin # MC56F82748 DSC signal Pin # MC56F82748 DSC signal 

J502-11 GPIOF7/TB3/CMPC_O/SS1_B/XB_IN3 J502-12 GPIOC2/TXD0/TB0/XB_IN2/CLKO

0 

J502-13 GPIOF8/RXD0/TB1/CMPD_O J502-14 GPIOC5/DACO/XB_IN7 

J502-15 GPIOC11/CANTX/SCL1/TXD1 J502-16 GPIOC7/SS0_B/TXD0 

J502-17 GPIOC12/CANRX/SDA1/RXD1 J502-18 GPIOC8/MISO0/RXD0/XB_IN9 

J502-19 GND J502-20 GPIOC9/SCK0/XB_IN4 

J502-21 No Connection J502-22 GPIOC10/MOSI0/XB_IN5/MISO0 

J502-23 No Connection J502-24 No Connection 

J502-25 No Connection J502-26 No Connection 

 

2.3.6 Tower system elevator connectors 

The TWR-56F8200 board features two expansion card-edge connectors that interface to Elevator boards 

in a Tower System: the Primary and Secondary Elevator connectors. The Primary Elevator connector, 

comprised of sides A and B, is utilized by the TWR-56F8200 board, while the Secondary Elevator 

connector only makes connections to ground (GND). Table 7 lists the pin functions for the Primary 

Elevator Connector. 

2.3.7 Thermistors as analog inputs 

The TWR-56F8200 board provides four thermistors (RT1–RT4) near the corners of the board that can 

be used as single-ended or differential analog inputs to the MC56F82748 DSC as can be seen on sheet 6 

of the schematic (See Appendix B—TWR-56F8200 board schematic). In addition to each thermistor, 

there is a resistor between the thermistor and P3_3V and another resistor between the thermistor and 

ground. All the thermistors are 10 kΩ parts but the associated divider chain uses different resistors. This 

makes the voltage across the thermistor larger or smaller and provides the ability to try the different gain 

settings on the analog channels. All the four thermistor circuits are designed to provide useable 

differential inputs over the temperature range of 90 °C to –20 °C. RT2 and RT4 both give a differential 

voltage of ~1.65 V at 25 °C. RT1 gives a differential voltage of 0.10 V and RT3 gives a differential 

voltage of 0.28 V at 25 °C.  

In addition to the thermistor voltage divider chain, each thermistor has a 0.1 µF capacitor in parallel. 

Each thermistor circuit also has a header that allows the thermistor to be disconnected from the analog 

inputs to the DSC. If a user wishes to apply an external analog value, these headers may be removed and 

the external analog signal attached to the DSC side of the headers. Finally, each analog input to the DSC 

has a 100 Ω series resistor and a 2200 pF capacitor as a low pass filter. This helps protect the DSC from 



 

 

  TWR-56F8200 Tower Board, Rev. 1, 10/2013  

12  Freescale Semiconductor Inc. 

electrostatic discharges and lowers the impedance of the analog signal so that it can be sampled with less 

noise. 

2.3.8 CAN transceiver 

The TWR-56F8200 board has a CAN transceiver circuit that may be connected to the CAN pins of the 

DSC. The CAN transceiver (U503) can be connected to the GPIOC11/CANTX/SCL1/TXD1 and 

GPIOC12/CANRX/SDA1/RXD1 pins of the DSC through the header at J16. Installing a shunt from pin 

1 to pin 2 connects the TXD nets and installing a shunt from pin 3 to pin 4 connects the RXD nets.  

Note: The GPIOC11/CANTX/SCL1/TXD1 and GPIOC12/CANRX/SDA1/RXD1 nets also go to the 

primary elevator edge connector (J500A) pins B41 and B42 and to the auxiliary connector (J502) pins 

15 and 17. When using these nets for CAN communications, care must be taken that these nets are not 

driven from these other connectors. 

The transceiver is capable of running from 3.3 V and is powered by the P3_3V/5V power rail. The 

transceiver output is connected to header J13 with CANH connected to pin 4 and CANL connected to 

pin 3. A 120 Ω parallel termination resistor, R560, may be connected between these nets by installing a 

shunt on header J15. 

2.3.9 IRQ or input push-buttons 

The TWR-56F8200 board has two push-buttons (SW1 and SW2) that can be used to provide inputs or 

interrupts to the DSC. Each has a 10 kΩ pullup resistor to P3_3V and a 0.1 µF capacitor to ground to 

minimize bounce on the output.  

The push-button SW1 is connected to header J4 where the switch output can be connected to either DSC 

pin GPIOC2/TXD0/TB0/XB_IN2/CLKO (default) or GPIOF6/TB2/PWM3X depending on the position 

of the shunt on the header (pin 1 to pin 2 is the default). Similarly, push-button SW2 is connected to 

header J5 where the switch output can be connected to either DSC pin GPIOF8/RXD0/TB1 (default) or 

GPIOF7/TB3 depending on the position of the shunt on the header (pin 1 to pin 2 is the default).  

If the push-button switches are not being used as an interrupt, or other purpose, it is best to 

remove the shunt to the DSC so that the 0.1 µF capacitor is not loading down the DSC pins.  

2.3.10 RESET 

The GPIOD4/RESET_B pin of the DSC is connected to the motor control connector and the Tower 

connector but also to a push-button (SW3) and through buffers to the OSBDM/OSJTAG chip. It is 

pulled to P3_3V by a 10 kΩ resistor. It may be pulled low by the push-button or by Q1 in response to a 

high output from the OSBDM/OSJTAG chip (pin 1) on the TRESET_OUT net. The state of the 

GPIOD4/RESET_B signal is provided to the OSBDM/OSJTAG chip through a voltage translator 

(U504B). This buffer is powered by the P3_3V/5V power rail so that its input will remain high-

impedance when there is no USB cable connected. The buffered RESET signal is provided to pin 33 of 

the OSBDM/OSJTAG chip and is used by the OSBDM/OSJTAG program in that chip. 
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2.3.11 JTAG header and OSBDM/OSJTAG disconnect header 

The TWR-56F8200 board includes an OSBDM/OSJTAG circuit as a debug interface to the C56F82748 

DSC for normal purposes. If the user desires to use a different debugger connection, header J14 provides 

a connection point for an external JTAG hardware debugger. If an external debugger is connected to the 

JTAG header, the shunts at J21 (pins 1 to 2, 3 to 4, 5 to 6, and 7 to 8) which connect the 

SBDM/OSJTAG circuit to the JTAG signals should be removed, allowing the external debugger to 

control the JTAG port, rather than the JM60. 

The TWR-56F8200 board provides a 2.2 kΩ pullup resistor to 3.3 V on the TMS line. If an external 

JTAG hardware debugger also has a pullup on this line, the external debugger may not be able to pull 

the TMS line low. If this happens, remove one of the pull up resistors on the TMS line. 

2.4 OSBDM/OSJTAG 

2.4.1 Debug interface 

An onboard MC9S08JM60 based Open Source BDM (OSBDM/OSJTAG) circuit provides a debug 

interface to the MC56F82748. A standard USB A male to mini-B male cable (supplied with the tower 

card) can be used for debugging via the USB connector, J18.   

2.4.2 USB serial bridge interface 

The onboard MC9S08JM60 can also be used as a USB-to-serial bridge interface for the UART signals 

from the MC56F82748 DSC. This bridge circuit is described in detail in Serial I/O source select headers. 

 

The RXD_SEL signal goes to the MC56F82748 DSC. The USB bridge chip is powered by 5 V; so it has 

a 5 V output. The buffer (U505) is able to accept the 5 V signal from the USB bridge chip (T_TXD1) 

and converts it to the 3.3 V signal (RXD_SEL) for the DSC. The buffer output is enabled by an inverted 

RTS signal (TXD_RXD_EN_B) from the USB bridge chip. If there is no USB connection to the TWR 

board, the RTS signal is not driven and the 3.3 V powered inverter (U502C) input is biased low 

disabling the output of the buffer.  

 

In a similar way, TXD_SEL is a 3.3 V signal from the MC56F82748 DSC. The USB bridge chip is 

expecting a 5 V input on T_RXD1. The buffer between these two signals (U504C) is powered by 

P3_3V/5V. It will accept the 3.3 V input from the DSC and convert it to the 5 V signal needed by the 

USB bridge chip. The buffer output is enabled by the same inverted RTS signal (TXD_RXD_EN_B) 

discussed above. If there is no USB connection to the TWR board, the RTS signal is not driven and the 

5 V powered buffer is disabled; so nothing is driving the powered down USB bridge chip.  

 

The serial interface signals from the MC56F82748 DSC may be routed to the MC9S08JM60 serial 

interface via header and Berg straps. Using the USB serial bridge, the MC9S08JM60 will convert the 

serial interface data into USB packets and send them to the host PC where they may be handled by a PC 

application normally conversant with a serial port. 
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2.4.3 Clocking the OSBDM/OSJTAG MCU (MC9S08JM60) 

The MC9S08JM60 MCU uses an onboard 4 MHz external crystal circuit (Y2, R16, C7, and C9) for its 

clock. There are no user options for clocking the MC9S08JM60 MCU. 

2.4.4 Reserved function select header 

Header J20 selects whether the onboard MC9S08JM60 MCU operates as an OSBDM/OSJTAG debug 

interface or as a USB Serial Bridge interface on older versions of S08 firmware such as may have 

existed on prototypes of the TWR56F8200. Leaving the shunt on the header enables the 

OSBDM/OSJTAG debug interface. Removing the shunt on header J20 enables the USB Serial Bridge 

interface.  The header J20 is subsequently reserved for future use. 

2.4.5 Bootloader enable 

In addition to the OSBDM/OSJTAG Debug interface and the USB Serial Bridge interface, the 

MC9S08JM60 device used in the OSBDM/OSJTAG circuit is preprogrammed with a USB boot loader.  

The USB boot loader will run following a power-on reset if a shunt is installed on header J17.  This 

allows in-circuit reprogramming of the JM60 flash memory via USB. This enables the 

OSBDM/OSJTAG firmware to be upgraded by the user when upgrades become available.  In normal 

OSBDM/OSJTAG or USB Serial Bridge operation, this shunt must be left open. For details on the USB 

boot loader, see USB Bootloader for the MC9S08JM60 (document number AN3561), available on 

freescale.com. 

 

The USB boot loader communicates with a GUI application running on a host PC.  The GUI application 

can be found on freescale.com using the search keyword “JM60 GUI”.  See Section 2.5 “PC Driver and 

PC GUI Tool,” and Section 3.3 “Running PC GUI Tool,” of USB Bootloader for the MC9S08JM60 

(document number AN3561) for details on installing and running the application. 

2.4.6 BDM header 

The BDM header at J22 is used for initial programming of the MC9S08JM60 MCU or if reprogramming 

when the boot loader fails. An external S08 BDM debugger would be connected to J22 and used to 

program the MCU. This is not expected to be a normal user interface; however it is useful if the JM60 

device is inadvertently reprogrammed with firmware that is not functional. 

2.4.7 OSBDM/OSJTAG status LEDs 

The MC9S08JM60 OSBDM/OSJTAG MCU controls two status LEDs at D12 and D13. See the 

OSBDM/OSJTAG instructions for the meaning of the LEDs. 

2.4.8 OSBDM/OSJTAG voltage translation 

Since the OSBDM/OSJTAG MCU runs from 5 V and the 56F82748 DSC runs from 3.3 V, there needs 

to be voltage translation between the two circuits. This is done through U505, U504A, and U502B. 

U505 has 5 V tolerant inputs and provides 3.3 V signals (TCK, TDI, and TMS) to the DSC’s JTAG pins 

through the shunts on header J21. U504A is powered by the P3_3V/5V rail and translates the 3.3 V 

TDO signal from the DSC to a 5 V signal for the OSBDM/OSJTAG MCU. The outputs of both these 

http://www.freescale.com/
http://www.freescale.com/
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translators are high-impedance if the signal OUT_EN_B goes high. This happens if the 

OSBDM/OSJTAG circuit looses power (no power to the USB connector). In that case, the OUT_EN 

signal from the OSBDM/OSJTAG MCU (pin 15) is biased low by R12. The inverter at U502B then 

drives OUT_EN_B high in response. For additional information, see USB serial bridge interface. 

 

3 Jumper table 

There are several headers provided for isolation, configuration, and feature selection.  See Table 6 for 

details.  The default shunt positions are shown in bold. 

 
Table 6. TWR-56F8200 jumper table 

Jumper Function 
Shunts Description 

Power use 
case 

J1 Thermistor RT1 Connect 
1-2, 3-4 

Connect RT1 circuit to the 
MC56F82748 DSC 

 

none 
Disconnect RT1 circuit from the 
MC56F82748 DSC 

 

J2 Thermistor RT2 Connect 
1-2, 3-4 

Connect RT2 circuit to the 
MC56F82748 DSC 

 

none 
Disconnect RT2 circuit from the 
MC56F82748 DSC 

 

J4 IRQ1 Select 

1-2 

Connect SW1 to MC56F82748 
DSC pin 
GPIOC2/TXD0/TB0/XB_IN2/CLKO 

 

2-3 
Connect SW1 to MC56F82748 DSC 
pin GPIOF6/TB2/PWM3X 

 

none 
Disconnect SW1 from the 
MC56F82748 DSC 

 

J5 IRQ0 Select 

1-2 

Connect SW2 to MC56F82748 
DSC pin  
GPIOF8/RXD0/TB1 

 

2-3 

Connect SW2 to MC56F82748 DSC 
pin  
GPIOF7/TB3 

 

none 
Disconnect SW2 from the 
MC56F82748 DSC 

 

J6 and 
J7 

3.3 V Source Select 

J6-1 to 
J7-2 

Connect the on-board voltage 
regulator to the P3_3V power rail 

1, 2, 3a 

J7-1 to 
J7-2 

Connect P3_3V_MOTOR to the 
P3_3V power rail (power the 3.3V 
rail from the motor control 
connector) 

4 

J7-2 to 
J7-3 

Connect P3_3V_ELEV to the P3_3V 
power rail (power the 3.3V rail from 
the Tower connector) 

3 

J7-2 
open 

Disconnect the P3_3V power rail – 
no power 
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Jumper Function 
Shunts Description 

Power use 
case 

J8 
RXD Source Select (note that 
only one connection can be 
made to pin 3 at a time) 

1-2 

Connect ELEV_RXD0 from the 
Tower connector  to MC56F82748 

DSC pin GPIOF8/RXD0/TB1 

 

2-3 

Connect RXD_SEL from the USB 
Serial Bridge to MC56F82748 DSC 

pin GPIOF8/RXD0/TB1 

 

Pin 2 
open 

Disconnect MC56F82748 DSC pin 

GPIOF8/RXD0/TB1 

 

3-4 

Connect RXD_SEL from the USB 
Serial Bridge to MC56F82748 DSC 

pin GPIOF5/RXD1/XB_OUT5 

 

4-5 

Connect ELEV_RXD1 from the 
Tower connector  to MC56F82748 

DSC pin GPIOF5/RXD1/XB_OUT5 

 

Pin 4 
open 

Disconnect MC56F82748 DSC pin 

GPIOF5/RXD1/XB_OUT5 

 

J9 
TXD Source Select (note that 
only one connection can be 
made to pin 3 at a time) 

1-2 

Connect ELEV_TXD0 from the 
Tower connector  to MC56F82748 
DSC pin 

GPIOC2/TXD0/TB0/XB_IN2/CLKO 

 

2-3 

Connect TXD_SEL from the USB 
Serial Bridge to MC56F82748 DSC 
pin 

GPIOC2/TXD0/TB0/XB_IN2/CLKO 

 

Pin 2 
open 

Disconnect MC56F82748 DSC pin 

GPIOC2/TXD0/TB0/XB_IN2/CLKO 

 

3-4 

Connect TXD_SEL from the USB 
Serial Bridge to MC56F82748 DSC 

pin GPIOF4/TXD1/XB_OUT4 

 

4-5 

Connect ELEV_TXD1 from the 
Tower connector  to MC56F82748 

DSC pin GPIOF4/TXD1/XB_OUT4 

 

Pin 4 
open 

Disconnect MC56F82748 DSC pin 

GPIOF4/TXD1/XB_OUT4 

 

J10 and 
J11 

5 V Source Select 

J10-1 to 
J11-2 

Connect the power in barrel 
connector (through fuse F1) to the 
input of the 3.3V voltage regulator 

1 

J11-1 to 
J11-2 

Connect P5V_TRG_USB (the 
switched USB 5V) to the input of 
the 3.3V voltage regulator 

2 

J11-2 to 
J11-3 

Connect P5V_ELEV to the input of 
the 3.3V voltage regulator 

3a 

J11-2 
open 

Disconnect the input of the 3.3V 
voltage regulator 

3, 4 

J12 Unused open Unused  

J15 CAN Termination Enable 
1-2 

Connect the 120 ohm CAN 
termination resistor 
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Jumper Function 
Shunts Description 

Power use 
case 

open No CAN termination  

J16 CAN Enable 
1-2, 3-4 

Connect the CAN transceiver TXD 
and RXD to MC56F82748 DSC 
pins GPIOC11/CANTX/SCL1/TXD1 
GPIOC12/CANRX/SDA1/RXD1 

 

open Disconnect the CAN transceiver  

J17 MC9S08JM60 Bootload Enable 1-2 
Enable USB bootloading of the 
MCU Flash memory 

 

open Disable bootloading  

J19 Thermistor RT3 Connect 
1-2, 3-4 

Connect RT3 circuit to the 
MC56F827 DSC 

 

none 
Disconnect RT3 circuit from the 
MC56F82748 DSC 

 

J20 
RESERVED / 
OSBDM/OSJTAG Enable 

1-2 Reserved-deprecated  

none Reserved-deprecated  

J21 
OSBDM/OSJTAG Connect to 
JTAG 

1-2, 3-4, 
5-6, 7-8 

Connect the OSBDM/OSJTAG 
debug signals (JTAG) to the 
MC56F82748 DSC JTAG pins 

 

none 
Disconnect OSBDM/OSJTAG from 
the MC56F82748 DSC 

 

J23 Thermistor RT4 Connect 
1-2, 3-4 

Connect RT4 circuit to the 
MC56F827 DSC 

 

none 
Disconnect RT4 circuit from the 
MC56F82748 DSC 

 

 

 

Due to the large number of use cases for the TWR-56F8200 board, the following power use cases are 

referred in the table above to ease the configuration of the board with Berg Straps and/or wires for 

power configurations. 

 

The use cases enumerated are: 

 

1. TWR-56F8200 standalone with the barrel power connector and the U-MULTILINK or 

USB-TAP.  Use this mode for initial programming of the board, especially prior to using 

it to control high voltages. 

2. TWR-56F8200 standalone with the USB connector.  Use this for OSJTAG programming 

of the board.  No other hardware is required than the board and cable supplied for 

connection to USB of computer. 

3. TWR-56F8200 in Tower system driving TWR-MC-LV3PH board, also in Tower system, 

or for any other Tower application other than APMOTOR56800E motor driving in 

Tower. (3a is alternative connection.) 

4. TWR-56F8200 in Tower system driving APMOTOR56800E (equipped with three 1 inch 

#4 hardware plastic standoffs (female both ends) with six #4 screws). 

5. TWR-56F8200 driving APMOTOR56800E outside the Tower system. (Same power 

configuration as 4). 
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4 Getting started 

4.1 Introduction 

In this section, you will find details that give step by step instructions on how to set up your Tower 

system for several different scenarios: 

 

 Debugging new application on TWR-56F8200 using MultiLink  

o Set up a new project application interfacing with the Universal Multilink interface 

 

 Debugging new application on TWR-56F8200 using OSJTAG 

o Set up a new project application interfacing with the standard TWR interface, OSJTAG 

 

 Programming TWR board with the Thermistor demo using Universal Multilink 

o Set up the standard out of box demo using the Universal Multilink interface 

 

 Programming TWR board with thermistor demo using OSBDM/OSJTAG 

o Set up the standard out of box demo with the standard TWR interface, OSJTAG 

 

 Programming TWR board with a three-phase motor demo using Universal Multilink 

o Set up the TWR-MC-LV3PH BLDC motor kit to spin the motor, controlled via the 

hardware buttons, interfacing with the Universal Multilink. 

 

 Programming TWR board with a three-phase motor control demo using 

OSBDM/OSJTAG 

o Set up the TWR-MC-LV3PH BLDC motor kit to spin the motor, controlled via the 

hardware buttons, interfacing with OSJTAG. 

 

 Three-phase motor control demo controlled via FreeMASTER using P&E Universal 

Multilink 

o Spin the TWR-MC-LV3PH BLDC motor controlling it from your PC via FreeMASTER, 

interfacing with Universal Multilink. 
 

 Three-phase motor control demo controlled via FreeMASTER using OSBDM/ OSJTAG 

o Spin the TWR-MC-LV3PH BLDC motor, controlled from your PC via FreeMASTER, 

interfacing with OSJTAG. 

 

You can also view a video of how to set up the scenarios at freescale.com/TWR-56F8200.  

4.2 Hardware installation 

The first step to any of the scenarios is to configure the hardware. Set up the hardware as mentioned in 

Table 6 or, the TWR-56F8200 Jumper Table in the Quick Start Guide [2] and your board should look 

like the one shown in this figure. 

http://www.freescale.com/TWR-56F8200
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Figure 3. TWR-56F8200 tower board 

4.3 Software installation 

After the hardware is configured, the software needs to be set up. The first step is for the user to set up 

CodeWarrior. You need to install CodeWarrior to program and debug the TWR-56F8200, and 

FreeMASTER for debugging via GUI.  

The installation software can be found in the following locations, or by following the “Jump Start Your 

Design“ section in the Quick Start Guide available in Tower System box. 

 CodeWarrior Development Tools: www.freescale.com/CodeWarrior 

 FreeMASTER Application and Communication Driver: www.freescale.com/FREEMASTER 

 

http://www.freescale.com/CodeWarrior
http://www.freescale.com/FREEMASTER
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4.4 Procedure for  debugging new  applications on TWR-56F8200 Using 
MultiLink 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Connect all the jumpers on 56F8200 board as 

mentioned in Table 6.  
 

2. Make the connection using U-Multilink and USB cable: Connect one end of the USB cable to 

TWR-56F8200 board and other to the computer for supplying the power to board. Connect the P&E U-

Multilink to the JTAG Connector J14. Make sure the red wire of P&E Multilink ribbon connector 

connects to pin1 of J14. Connect the other end of the multilink to the computer USB port. 

 

3. Create an application for MC56F82748: Launch CodeWarrior and run the program. 

a) From the menu, choose File > New > Bareboard Project. 

b) Assign a project name, such as “ProjDSC” and click Next. 

c) Expand the 56800/E (DSC) drop box, expand 56F827xx, select MC56F82748, and then click 

            Next. 

d) Select all the checkboxes on “Connection to be used,” and click Next twice. 

e) Select Processor Expert, and click Finish. 

 

4. Build your application: Wait for Processor Expert to finish loading. Observe the activity in the lower 

right of the IDE screen, such as progress indications. Once idle, click the project name “ProjDSC” and 

then click the hammer icon to build the project. 

 

5. Load your application using U-MultiLink:  

a) When finished building, right-click the project name.  

b) Choose Debug As > Debug configurations and then select CodeWarrior Download. 

c) Select U-MultiLink and click OK.  

d) Observe the activity in the lower portion of the IDE screen, such as progress indications. Once 

the debugger runs, it will stop in the Main program for you to take control. 

 

6. Debug your application: Set a breakpoint at the “for” instruction from within the C language 

program by right-clicking in the margin to the left of the “for” statement and selecting “toggle 

breakpoint.” Look for a red square at the top of the screen, among the debug controls. Mouse over them 

to the left and find and click Resume to continue.  

4.5 Procedure for debugging new applications on TWR-56F8200 Using 
OSJTAG 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Connect all the jumpers on 56F8200 board as 

mentioned in Table 6. 
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2. Connect USB cable: Connect one end of the USB cable to the TWR-56F8200 board and other to the 

computer. 

 

3. Create an application for MC56F82748: Launch CodeWarrior and run the program. 

a) From the menu, choose File > New > Bareboard Project. 

b) Assign a project name, such as “ProjDSC” and click Next. 

c) Expand the 56800/E (DSC) drop box, expand 56F827xx, select MC56F82748, and then click 

Next. 

d) Select all the checkboxes on “Connection to be used,” and click Next twice. 

e) Select Processor Expert, and click Finish. 

 

4. Build your application: Wait for Processor Expert to finish loading. Observe the activity in the lower 

right of the IDE screen. Once idle, click the project name “ProjDSC” and click the hammer icon to build 

the project. 

 

5. Load your application using OSJTAG:  

a) When finished building, right-click the project name.  

b) Choose Debug As > Debug configurations and then select CodeWarrior Download. 

c) Select OSJTAG and click OK.  

d) Observe the activity in the lower portion of the IDE screen. Once the debugger runs, it will stop 

in the Main program for you to take control. 

 

6. Debug your application: Set a breakpoint at the “for” instruction from within the C language 

program by right-clicking in the margin to the left of the “for” statement and selecting “toggle 

breakpoint.”Look for a red square at the top of the screen, among the debug controls. Mouse over them 

to the left and find and click Resume to continue. 

 

4.6 Programming the Tower system with thermistor demo using Universal 
Multilink 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Make sure the following pins shown in red are 

connected as shown in the following figure. 
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2. Power to TWR-56F8200 TWR card: Power up the TWR-56F8200 board using the USB cable from 

the computer’s USB port.  

 

3. Connect programming /debugging tool: Connect P&E Universal multilink to TWR-56F8200 at 

JTAG connector J14, and make sure the red wire of ribbon connector connects to Pin1 on J14. Connect 

the other end of the P&E Universal Multilink to computer USB port  

 

4. Launch CodeWarrior: Import and run the TWR56F8200_Thermistor_lab_JTAG project from the 

“MC56F827xxCodeExample” directory:  

a) Create a new work area called “ThermistorDemoMultilink” for example.  

b) Choose File > Import, expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

“MC56F827xxCodeExample”.  

d) A list of projects appears. Select MC56F827xxCode Example and click OK.  

e) A list of all the selected projects will appear. Select TWR56F8200_Thermistor_lab_JTAG and 

click “Copy projects into workspace” button and then click Finish.  

f) Clean and build TWR56F8200_Thermistor_lab_JTAG project by using Project > Clean. Click 

the “Clean projects selected below” button and select TWR56F8200_Thermistor_lab_JTAG. 

Select “Start a build immediately” and “Build only selected projects” checkboxes. 

g) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 

h) Select “SDM_PnE U-Multilink” as the choice of hardware for debugging.  

i) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project” and select TWR56F8200_Thermistor_lab_JTAG.elf and click OK.  

j) Click ‘Debug’ on the right bottom of the window to load the program.  

k) After the program loads, it will stop in the main program.  

l) Click the resume icon to resume execution.  

 

5. Run the thermistor demo: Now you should see LEDs E0-E7 flashing in pairs, with a period of 

400 ms. With a finger, touch one of the onboard thermistors (RT1, RT2, RT3, RT4) placed on each 

corner of the board. By touching the thermistor, you will increase its temperature. The change in 

temperature is detected by the DSC and it will update the LED flashing pattern. If you touch RT1, LEDs 
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E0 and E1 will flash in intervals of 200 ms. All other LEDs will be turned off. The thermistors and the 

LEDs are related as shown in this table.  

 

Thermistor LEDs 

RT1 E0, E1 

RT2 E2, E3 

RT3 E4, E5 

RT4 E6, E7 

 

 

If you remove the finger from the thermistor, the LED will return to the default flash pattern. 

 

4.7 Programming the Tower system with thermistor demo using 
OSBDM/OSJTAG 

Prerequisite: Download and Install CodeWarrior Development Tools as mentioned in Software 

installation. 

1. Connect jumpers on TWR-56F8200 module: Make sure following pins shown in red are connected 

as shown in this figure.  

 
 

2. Power to TWR-56F8200 TWR card: Power up the TWR-56F8200 board using the USB cable from 

the computer’s USB port.  

 

3. Launch CodeWarrior: Import and run the TWR56F8200_Thermistor_lab_JTAG project from the 

“MC56F827xxCodeExample” directory:  

a) Create a new work area called “ThermistorDemoMultilink” for example.  

b) Choose File > Import, expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

MC56F827xxCodeExample. 

d) A list of projects appears. Select MC56F827xxCode Example and click OK.  



 

 

  TWR-56F8200 Tower Board, Rev. 1, 10/2013  

24  Freescale Semiconductor Inc. 

e) A list of all the selected projects will appear. Select TWR56F8200_Thermistor_lab_JTAG and 

click “Copy projects into workspace” button and then click Finish.  

f) Choose Project > Clean to clean and build TWR56F8200_Thermistor_lab_JTAG project. Click 

the “Clean projects selected below” button and select TWR56F8200_Thermistor_lab_JTAG. 

Select “Start a build immediately” and “Build only selected projects” checkboxes. 

g) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 

h) Select SDM_OSJTAG as the choice of hardware for debugging.  

i) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project” and select TWR56F8200_Thermistor_lab_JTAG.elf and click OK.  

j) Click ‘Debug’ on the right bottom of the window to load the program.  

k) After the program loads, it will stop in the main program.  

l) Click the resume icon to resume execution.  

 

4. Run the thermistor demo: Now you should see LEDs E0-E7 flashing in pairs, with a period of 400 

ms. With a finger, touch one of the onboard thermistors (RT1, RT2, RT3, RT4) placed on each corner of 

the board. By touching the thermistor, you will increase its temperature. The change in temperature is 

detected by the DSC and it will update the LED flashing pattern. If you touch RT1, LEDs E0 and E1 

will flash in intervals of 200 ms. All other LEDs will be turned off. The thermistors and the LEDs are 

related as shown in this table.  

 

Thermistor LEDs 

RT1 E0, E1 

RT2 E2, E3 

RT3 E4, E5 

RT4 E6, E7 

 

 

If you remove the finger from the thermistor, the LED will return to the default flash pattern. 

4.8 Programming TWR board with LV_Motor demo using Universal Multilink 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Reconfigure the TWR-56F8200 module by 

removing all the jumpers. Reconnect the 10 pins shown in red in the following figure to first program 

the TWR-56F8200 standalone with “MC56F82748_TWR_LV_BLDC” source code. 
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2. Power to TWR-56F8200 TWR card: Connect one end of the USB cable to the TWR-56F8200 

board and the other to the computer for supplying power to the board. 

 

3. Connect programming /debugging tool: Connect P&E Universal multilink to TWR-56F8200 at 

JTAG connector J14, and make sure red wire of ribbon connector connects to Pin1 on J14. Connect 

other end of P&E Universal Multilink to computer USB port. 

 

4. Launch CodeWarrior: Import and run the MC56F82748_TWR_LV_BLDC project from the 

“MC56F827xxCodeExample” directory: 

a) Create a new work area called “WS_8200” for example.  

b) Choose File > Import. Expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

MC56F827xxCodeExample.  

d) A list of projects appears. Select MC56F827xxCode Example and click OK.  

e) A list of all the selected projects will appear. Select MC56F82748_TWR_LV_BLDC and click 

the “Copy projects into workspace” button. Then, click Finish.  

f) Clean and build “MC56F82748_TWR_LV_BLDC” project by choosing Project > Clean. Click 

the "Clean projects selected below" button and select MC56F82748_TWR_LV_BLDC. Select 

"Start a build immediately" and "Build only selected projects" checkboxes. 

g) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 

h) Select SDM_PnE U-Multilink as the choice of hardware for debugging.  

i) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project” and select MC56F82748_TWR_LV_BLDC.elf and click OK.  

j) Click Debug on the right bottom of the window to load the program.  

k) After the program loads, it will stop in the main program.  

l) Click the resume icon to resume execution. 

 

5. Disconnect the computer and power: Remove the USB cable from the TWR-56F8200. 

Remove the P&E U-Multilink from TWR-56F8200. Click OK on the pop-up window which appears 

while disconnecting USB cable. 

 

6. Connect jumpers on TWR-MC-LV3PH module: Reconfigure the TWR-MC-LV3PH module by 

removing all the wires and jumpers. Reconnect the two pins shown in red, as shown in the following 

figure.  
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7. Assemble TWR-MC-LV3PH module: Connect the white edge of the TWR-MC-LV3PH module 

with the white edge of the primary Tower elevator. 

 

8. Assemble TWR-56F8200 module: Connect the white edge of the TWR-56F8200 module with the 

white edge of the primary Tower elevator. 

 

9. Put the modules together: Connect the black edge of the TWR-MC-LV3PH and TWR-56F8200 

modules into the black edge of the secondary Tower elevator using the corresponding connectors. 

 

10. Power to TWR-56F8200 TWR card from TWR-MC-LV3PH: Reconfigure the TWR-56F8200 

power selection module to power from “TWR-MC-LV3PH” by removing jumper from J11 and short 

pins 2 and 3 of connector J7 as shown in this figure. 

 

 
 

11. Connect the motor and the power: Connect the motor three-prong cable to the three-prong 

connection on the TWR-MC-LV3PH. Connect the motor five-prong cable to the five-prong connection 

on the TWR-MC-LV3PH. The green wires of both the cables will be on the inside, facing each other. 

 

12. Power the motor: Plug in the included 24-volt power supply. Apply the resulting 24 volts to the 

barrel connector of the TWR-MC-LV3PH module only. 

 

13. Adjust the motor speed: Use the motor speed buttons S1 and S2 on the TWR-56F8200 to change 

the speed of the motor in either a clockwise or counterclockwise direction. The S3 button resets 

MC56F82748 and will stop the motor. Pressing the two motor speed buttons at the same time will also 

safely stop the motor. 
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4.9 Programming the Tower System with LV_Motor Demo using 
OSBDM/OSJTAG 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Reconfigure the TWR-56F8200 module by removing 

all jumpers. Reconnect the ten pins shown in diagrams below in red to first program the TWR-56F8200 

stand alone with “MC56F82748_TWR_LV_BLDC” source code. 

 

 
 

2. Power to TWR-56F8200 TWR card: Connect one end of the USB cable to TWR-56F8200 board 

and the other to computer for supplying power to the board. 

 

3. Launch CodeWarrior: Import and run the MC56F82748_TWR_LV_BLDC project from the 

“MC56F827xxCodeExample” directory: 

a) Create a new work area called “WS_8200” for example.  

b) Choose File > Import. Expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

“MC56F827xxCodeExample”.  

d) A list of projects appears. Select MC56F827xxCode Example and click OK.  

e) A list of all the selected projects will appear. Select MC56F82748_TWR_LV_BLDC and click 

the “Copy projects into workspace” button. Then, click Finish.  

f) Clean and build MC56F82748_TWR_LV_BLDC project by choosing Project > Clean. Click the 

"Clean projects selected below" button and select MC56F82748_TWR_LV_BLDC. Select "Start 

a build immediately" and "Build only selected projects" checkboxes. 

g) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 

h) Select SDM_OSJTAG as the choice of hardware for debugging.  

i) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project” and select MC56F82748_TWR_LV_BLDC.elf and click OK.  

j) Click Debug on the right bottom of the window to load the program.  

k) After the program loads, it will stop in the main program.  

l) Click the resume icon to resume execution. 

 

4. Disconnect the computer and power: Remove the USB cable from the TWR-56F8200.  

Click OK on the pop-up window which appears while disconnecting USB cable. 
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5. Connect jumpers on TWR-MC-LV3PH module: Reconfigure the TWR-MC-LV3PH module by 

removing all wires and jumpers. Reconnect the two pins shown in red in this figure. 

 

 
6. Assemble TWR-MC-LV3PH module: Connect the white edge of the TWR-MC-LV3PH module 

with the white edge of the primary Tower elevator. 

 

7. Assemble TWR-56F8200 module: Connect the white edge of the TWR-56F8200 module with the 

white edge of the primary Tower elevator. 

 

8. Put the modules together: Connect the black edge of the TWR-MC-LV3PH and TWR-56F8200 

modules into the black edge of the secondary Tower elevator using the corresponding connectors. 

 

9. Power to TWR-56F8200 TWR card from TWR-MC-LV3PH: Reconfigure the TWR-56F8200 

power selection module to power from “TWR-MC-LV3PH” by removing jumper from J11 and short 

pins 2 and 3 of connector J7 as shown in this figure. 

 

 
 

10. Connect the motor and the power: Connect the motor three-prong cable to the three-prong 

connection on the TWR-MC-LV3PH. Connect the motor five-prong cable to the five-prong connection 

on the TWR-MC-LV3PH. The green wires of both cables will be on the inside, facing each other. 

 

11. Power the motor: Plug in the included 24-volt power supply. Apply the resulting 24 volts to the 

barrel connector of the TWR-MC-LV3PH module only. 

 

12. Adjust the motor speed: Use the motor speed buttons S1 and S2 on the TWR-56F8200 to change 

the speed of the motor in either a clockwise or counterclockwise direction. The S3 button resets 

MC56F82748 and will stop the motor. Pressing the two motor speed buttons at the same time will also 

safely stop the motor. 
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4.10   LV_Motor Spin demo controlled via FreeMASTER using Universal Multilink 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Reconfigure the TWR-56F8200 module by removing 

all jumpers. Reconnect the 10 pins shown in red in the following figure to first program the TWR-

56F8200 standalone with “MC56F82748_TWR_LV_BLDC” source code. 

 

 
 

2. Power to TWR-56F8200 TWR card: Connect one end of the USB cable to TWR-56F8200 board 

and other with computer for supplying the power to board. 

 

3. Connect programming /debugging tool: Connect P&E Universal multilink to TWR-56F8200 at 

JTAG connector J14, and make sure red wire of ribbon connector connects to Pin1 on J14. Connect 

other end of P&E Universal Multilink to computer USB port. 

 

4. Launch CodeWarrior: Import and run the MC56F82748_TWR_LV_BLDC project from the 

“MC56F827xxCodeExample” directory: 

a) Create a new work area called “WS_8200” for example.  

b) Choose File > Import. Expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

“MC56F827xxCodeExample”. 

d) A list of project appears. Select MC56F827xxCode Example and click OK.  

e) A list of all the selected projects will appear. Select MC56F82748_TWR_LV_BLDC and click 

the “Copy projects into workspace” button. Then, click Finish.  

f) Clean and build “MC56F82748_TWR_LV_BLDC” project by choosing Project > Clean. Click 

the “Clean projects selected below" button and select MC56F82748_TWR_LV_BLDC. Select 

“Start a build immediately” and “Build only selected projects” checkboxes. 

g) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 

h) Select SDM_PnE U-Multilink as the choice of hardware for debugging.  

i) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project” and select MC56F82748_TWR_LV_BLDC.elf and click OK.  

j) Click Debug on the right bottom of the window to load the program.  

k) After the program loads, it will stop in the main program.  

l) Click the resume icon to resume execution. 
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5. Disconnect the computer and power: Remove the USB cable from the TWR-56F8200. 

Remove the P&E U-Multilink from TWR-56F8200. Click OK on the pop-up window which appears 

while disconnecting USB cable. 

 

6. Connect jumpers on TWR-MC-LV3PH module: Reconfigure the TWR-MC-LV3PH module by 

removing all wires and jumpers. Reconnect the two pins shown in red in the following figure. 

 

 
 

7. Assemble TWR-MC-LV3PH module: Connect the white edge of the TWR-MC-LV3PH module 

with the white edge of the primary Tower elevator. 

 

8. Assemble TWR-56F8200 module: Connect the white edge of the TWR-56F8200 module with the 

white edge of the primary Tower elevator. 

 

9. Put the modules together: Connect the black edge of the TWR-MC-LV3PH and TWR-56F8200 

modules into the black edge of the secondary Tower elevator using the corresponding connectors. 

 

10. Power to TWR-56F8200 TWR card from TWR-MC-LV3PH: Reconfigure the TWR-56F8200 

power selection module to power from “TWR-MC-LV3PH” by removing jumper from J11 and short 

pins 2 and 3 of connector J7 as shown in this figure. 

 

 
 

11. Connect the motor: Connect the motor three-prong cable to the three-prong connection on the 

TWR-MC-LV3PH. Connect the motor five-prong cable to the five-prong connection on the TWR-MC-

LV3PH. The green wires of both cables will be on the inside, facing each other. 

 

12. Connect programming /debugging tool: Connect P&E Universal multilink to TWR-56F8200 at 

JTAG connector J14, and make sure red wire of ribbon connector connects to Pin1 on J14. Connect 

other end of P&E Universal Multilink to computer USB port.  
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13. Power the motor: Plug in the included 24-volt power supply. Apply the resulting 24 volts to the 

barrel connector of the TWR-MC-LV3PH module only.  
 

14. Open FreeMASTER: In CodeWarrior, under MC56F82748_TWR_LV_BLDC, click the 

FreeMASTER folder. Double click the BLDC_HS_demo_TWR56F8400.pmp file. It will open the 

FreeMASTER application. 

 

15. FreeMASTER settings:  
1. In the FreeMASTER application, click "Project select options"; this opens the Options 

window.  

2. In the Communications (Comm) tab, select Plug-in Module and from the dropdown list, 

select “FreeMASTER BDM JTAG/EOnCE Communication Plug-in (56F8xxx)”.  See the 

following figure. 

3. Now, in the MAP Files tab, click the dotted button to locate the 

MC56F82748_TWR_LV_BLDC.elf file. This is located inside the 

MC56F82748_TWR_LV_BLDC project folder.  

4. Click OK. 

 

 
 

16. Make the connection: On the Menu bar of FreeMASTER, click the STOP button. The status of 

FreeMASTER at the rightmost corner changes from NOT CONNECTED to a display showing the 

connection details. 

 

17. Adjust the motor speed  
The motor can now be controlled from the graphical user interface shown on screen. 

1. Change the position of needle to change the speed of the motor in either a clockwise or counter 

clockwise direction, or 
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2. Click the RUN/STOP button to Run position and provide desired speed in “Required Speed” 

column  

3. Click the Demo switch to “on” position. This will run the demo code and the motor will run by 

speed and direction that are predefined in the source code.  

4.11   LV_Motor Spin demo controller via FreeMASTER using OSBDM/ OSJTAG 

Prerequisite: Download and install CodeWarrior Development Tools as mentioned in Software 

installation. 

 

1. Connect jumpers on TWR-56F8200 module: Reconfigure the TWR-56F8200 module by 

removing all the jumpers. Reconnect the ten pins shown in red (in the following figure) to first program 

the TWR-56F8200 standalone with “MC56F82748_TWR_LV_BLDC” source code. 

 

 
 

2. Power to TWR-56F8200 TWR card: Connect one end of the USB cable to TWR-56F8200 board 

and other with computer for supplying power to the board. 

 

3. Launch CodeWarrior: Import and run the MC56F82748_TWR_LV_BLDC project from the 

“MC56F827xxCodeExample” directory: 

a) Create a new work area called “WS_8200” for example.  

b) Choose File > Import. Expand “General”, select “Existing Projects into Workspace” and then 

click Next.  

c) On the “Select Root directory” radio button, click Browse and browse to the 

“MC56F827xxCodeExample”. 

d) A list of projects will appear. Select MC56F827xxCode Example and click OK.  

e) A list of all the selected projects will appear. Select MC56F82748_TWR_LV_BLDC and click 

the “Copy projects into workspace” button. Then, click Finish. 

f) In the CW window, browse to the Project headers folder of the 

“MC56F82748_TWR_LV_BLDC” project directory. Open the freemaster_cfg.h file. In the file, 

modify “#define FMSTR_USE_SCI 0” to “#define FMSTR_USE_SCI 1” (line 23) 

and “#define FMSTR_USE_JTAG 1” to “#define FMSTR_USE_JTAG 0” (line 27). 

Save and close the file. 

g) Clean and build “MC56F82748_TWR_LV_BLDC” project by choosing Project > Clean. Click 

the “Clean projects selected below" button and select MC56F82748_TWR_LV_BLDC. Select 

“Start a build immediately” and “Build only selected projects” checkboxes. 

h) After the build completes, right-click the project and choose Debug As > Debug Configurations, 

and then select CodeWarrior Download. 
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i) Select SDM_OSJTAG as the choice of hardware for debugging.  

j) In the Debug Configuration window, under the ‘main’ tab in the application, click “search 

project”, select MC56F82748_TWR_LV_BLDC.elf and click OK.  

k) Click Debug on the right bottom of the window to load the program.  

l) After the program loads, it will stop in the main program.  

m) Click the resume icon to resume execution. 

 

4. Disconnect the computer and power: Remove the USB cable from the TWR-56F8200. Click “Ok” 

on the pop-up window which appears while disconnecting USB cable. 

 

5. Connect jumpers on TWR-MC-LV3PH module: Reconfigure the TWR-MC-LV3PH module by 

removing all wires and jumpers. Reconnect the two pins shown in red in this figure. 

 

 
 

 

6. Assemble TWR-MC-LV3PH module: Connect the white edge of the TWR-MC-LV3PH module 

with the white edge of the primary Tower elevator. 

 

7. Assemble TWR-56F8200 module: Connect the white edge of the TWR-56F8200 module with the 

white edge of the primary Tower elevator. 

 

8. Put the modules together: Connect the black edge of the TWR-MC-LV3PH and TWR-56F8200 

modules into the black edge of the secondary Tower elevator using the corresponding connectors. 

 

9. Power to TWR-56F8200 TWR card from TWR-MC-LV3PH: Reconfigure the TWR-56F8200 

power selection module to power from “TWR-MC-LV3PH” by removing jumper from J11 and short 

pins 2 and 3 of connector J7 as shown in this figure. 
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10. Connect the motor and the power: Connect the motor three-prong cable to the three-prong 

connection on the TWR-MC-LV3PH. Connect the motor five-prong cable to the five-prong connection 

on the TWR-MC-LV3PH. The green wires of both cables will be on the inside, facing each other. 

 

11. Connect programming /debugging tool: Connect the USB cable to the TWR-56F8200 and 

computer.  

 

12. Power the motor: Plug in the included 24-volt power supply. Apply the resulting 24 volts to the 

barrel connector of the TWR-MC-LV3PH module only. 

 

13. Open FreeMASTER: In CodeWarrior under MC56F82748_TWR_LV_BLDC, click the 

FreeMASTER folder. In this folder, double click the BLDC_HS_demo_TWR56F8200.pmp file. This 

will open FreeMASTER tool.  

 

14. FreeMASTER settings:  
1. In FreeMaster application, choose Project > Options. It will open the Options window.  

2. Click the Communications (Comm) tab, and select Direct RS232.  

3. In the Port section, select the correct COM port (for example, COM2). The appropriate COM 

port can be found as OSBDM/OSJTAG—CDC serial port in the Ports section of Device manager 

(MS Windows utility) of your system.  

4. In the Speed section, select 9600.  

5. In the MAP Files tab, click the dotted button to locate the MC56F82748_TWR_LV_BLDC.elf 

file which is located inside MC56F82748_TWR_LV_BLDC project folder. See the following 

figure. 

6. Press OK.  

 

 



 

  TWR-56F8200 Tower Board, Rev. 1, 10/2013 

Freescale Semiconductor Inc.  35 

15. Make the connection: On the Menu bar of FreeMASTER, click the STOP button. The status of 

FreeMASTER at rightmost corner must change from NOT CONNECTED to a display showing the 

connection details.  

 

16. Adjust the motor speed: The motor can now be controlled via the graphical user interface shown 

on screen. 

a) Change the position of needle to change the speed of the motor in either a clockwise or counter 

clockwise direction, or 

b) Click the RUN/STOP button to Run position and provide desired speed in “Required Speed” 

column 

c) Click the Demo switch to “on” position. This will run the demo code and the motor will run by 

speed and direction that are pre-defined in the source code. 

 

 

5 Revision history 

 

Revision number Date Changes 

1 10/2013 Initial public release 

 

 

6 Appendix A – Tower system elevator connector pin functions 

 

Table 7 provides the pin out for the Primary Elevator Connector.  An “X” in the “Used” column 

indicates that there is a connection from the TWR-56F8200 board to that pin on the Elevator connector.  

An “X” in the “Jmp” column indicates that a jumper is available that can isolate the onboard circuitry 

from the Elevator connector. 

 

The function listed in the “Usage” column is the function(s) that the pin is expected to provide when 

used with the Tower system. All of the MC56F82748 pins (except power) have multiple functions. Not 

all of the possible functions are shown. 

 

Note that all analog pins (ANAn or ANBn) have a low-pass filter to ground consisting of a 100 ohm 

resistor and a 2200 pF capacitor. This is to protect the analog inputs of the DSC from a static discharge 

at one of the connectors. See schematic sheets 6 and 7 in Appendix B—TWR-56F8200 board schematic. 

 
Table 7. TWR-56F8200 Primary Elevator connector pinout 

Primary Elevator Connector 

Pin Name Usage Used Jmp Pin Name Usage Used Jmp 

B1 5V_1 5V Power X  X A1 5V_2 5V Power X X 

B2 GND Ground X   A2 GND_9 Ground X  
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B3 3.3V_1 3.3V Power X X  A3 3.3V_4 3.3V Power X X 

B4 ELE_PS_SENSE_1 

(must not be 

connected) X X  A4 3.3V_5 3.3V Power X X 

B5 GND_2 Ground X   A5 GND_10 Ground X  

B6 GND_3 Ground X   A6 GND_11 Ground X  

B7 SDHC_CLK / SPI1_CLK SCK (see also pin B48) X   A7 I2C0_SCL  SCL0 X  

B8 SDHC_D3 / SPI1_CS1_b    A8 I2C0_SDA SDA0 X  

B9 
SDHC_D3 / SPI1_CS0_b SS_B (see also pin B46) 

X  A9 

GPIO9/UART1_CTS

1 
GPIOA4/ANA4 

X 

X 

B10 SDHC_CMD / SPI1_MOSI MOSI (see also pin B45) X  A10 GPIO8/SDHC_D2 GPIOA5/ANA5 X X 

B11 
SDHC_D0 / SPI1_MISO MISO (see also pin B44) 

X 
 

A11 

GPIO7 / 

SD_WP_DET 
GPIOA6/ANA6 

X 

X 

 

B12 ETH_COL_1     A12 ETH_CRS     

B13 ETH_RXER_1     A13 ETH_MDC_1     

B14 ETH_TXCLK_1     A14 ETH_MDIO_1     

B15 ETH_TXEN_1     A15 ETH_RXCLK_1     

B16 ETH_TXER     A16 ETH_RXDV_1     

B17 ETH_TXD3     A17 ETH_RXD3     

B18 ETH_TXD2     A18 ETH_RXD2     

B19 ETH_TXD1_1     A19 ETH_RXD1_1     

B20 ETH_TXD0_1     A20 ETH_RXD0_1     

B21 GPIO1 / UART1_RTS1 

GPIOB4/ANB4&CMPC_

M1 X 
X 

A21 
I2S0_MCLK 

   
 

B22 GPIO2 / SDHC_D1 

GPIOB5/ANB5&CMPC_

M2 X 

X 
A22 

I2S0_DOUT_SCLK 
   

 

B23 GPIO3 

GPIOB6/ANB6&CMPB_

M1 X 

X 
A23 

I2S0_DOUT_WS 
   

 

B24 CLKIN0 XTAL&CLKIN X X A24 I2S0_DOUT_DIN0     

B25 CLKOUT1    A25 

I2S0_DOUT_DOUT

0    
 

B26 GND_4 Ground X  A26 GND_12 Ground X  

B27 
AN7 ANB3&CMPC_M0 

X 
 

A27 
AN3 

ANA3&CMPA_M

2 X 
X 

B28 
AN6 ANB2&CMPC_P2 

X 
 

A28 
AN2 

ANA2&CMPA_M

1 X 
 

B29 
AN5 

ANB1&VERFLB&CMPB_

M0 X 
 

A29 
AN1 

ANA1&VREFLA

&CMPA_M0 X 
 

B30 

AN4 
ANB0&VERFHB&CMPB

_P2 
X 

 

A30 

AN0 

ANA0&VREFHA

&CMPA_P2/CMP

C_O X 

 

B31 GND_5 Ground X  A31 GND_13 Ground X  

B32 DAC1     A32 DAC0 DAC0 X  

B33 TMR3 TA3 X  A33 TMR1 TA1 X  

B34 TMR2 TA2 X  A34 TMR0 TA0 X  

B35 GPIO4 

GPIOB7/ANB7&CMPB_

M2 X 
X 

A35 GPIO6 GPIOA7/ANA7  X 
X 

B36 3.3V_2 3.3V Power X X A36 3.3V_6 3.3V Power X X 

B37 PWM7 PWM3B X  A37 PWM3 PWM1B X  

B38 PWM6 PWM3A X  A38 PWM2 PWM1A X  

B39 PWM5 PWM2B X  A39 PWM1 PWM0B X  

B40 PWM4 PWM2A X  A40 PWM0 PWM0A X  
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B41 
CAN0_RX0 CANRX 

X 
X 

A41 
UART0_RX 

 ELEV_RXD0 (see 

also pin B61) X 
X 

B42 
CAN0_TX0 CANTX 

X 
X 

A42 
UART0_TX 

 ELEV_TXD0 (see 

also pin B62) X 
X 

B43 1WIRE     A43 UART1_RX  ELEV_RXD1 X X 

B44 SPI0_MISO/IO1 MISO (see also pin B11) X  A44 UART1_TX  ELEV_TXD1 X X 

B45 SPI0_MOSI/IO0 MOSI (see also pin B10) X  A45 VSSA     

B46 SPI0_CS0_b SS_B (see also pin B9) X  A46 VDDA     

B47 SPI0_CS1_b    A47 CAN1_RX     

B48 SPI0_CLK SCK (see also pin B7) X  A48 CAN1_TX     

B49 GND_6 Ground X  A49 GND_14 Ground X  

B50 I1C1_SCL1 SCL1 X  A50 GPIO14     

B51 I2C1_SDA1 SDA1 X  A51 GPIO15     

B52 GPIO5/SPI0_HOLD/IO3 GPIOF0 X  A52 

GPIO16/SPI0_WP/I

O2     

B53 RSRV_B53    A53 GPIO17     

B54 RSRV_B54    A54 USB0_DM     

B55 IRQ_H    A55 USB0_DP     

B56 IRQ_G    A56 USB0_ID     

B57 IRQ_F    A57 USB0_VBUS     

B58 IRQ_E    A58 I2S0_DIN_SCK TB3 X X 

B59 IRQ_D    A59 I2S0_DIN_WS TB2 X X 

B60 IRQ_C    A60 I2S0_DIN1     

B61 IRQ_B TB1 (see also pin A41) X X A61 I2S0_DOUT1     

B62 IRQ_A TB0 (see also pin A42) X X A62 RSTIN_b RESET_B   

B63 EBI_ALE / EBI_CS1_b    A63 RSTOUT_b RESET_B   

B64 EBI_CS0_b    A64 CLKOUT0 CLKO   

B65 GND_7 Ground X  A65 GND_15 Ground   

B66 EBI_AD15    A66 EBI_AD14    

B67 EBI_AD16    A67 EBI_AD13    

B68 EBI_AD17    A68 EBI_AD12    

B69 EBI_AD18    A69 EBI_AD11    

B70 EBI_AD19    A70 EBI_AD10    

B71 EBI_R/ W_b    A71 EBI_AD9    

B72 EBI_OE_b    A72 EBI_AD8    

B73 EBI_D7    A73 EBI_AD7    

B74 EBI_D6    A74 EBI_AD6    

B75 EBI_D5    A75 EBI_AD5    

B76 EBI_D4    A76 EBI_AD4    

B77 EBI_D3    A77 EBI_AD3    

B78 EBI_D2    A78 EBI_AD2    

B79 EBI_D1    A79 EBI_AD1    

B80 EBI_D0    A80 EBI_AD0    

B81 GND_8 Ground X  A81 GND_16 Ground   

B82 3.3V_3 3.3V Power X X A82 3.3V_7 3.3V Power   
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7 Appendix B—TWR-56F8200 board schematic 

 

 

The schematic is available as a standalone pdf at: freescale.com/TWR-56F8200 under the “Downloads” 

tab then within the “Hardware Development Tools” section. 

 

8 Appendix C—TWR-56F8200 board BOM 

 

Qty Reference Description Mfg. name Mfg. part 

number 

7 C1,C2,C506,C516,C520,C54

0,C541 

CAP CER 10UF 16V 10% 

X5R 0805 

AVX 0805YD106KAT

2A 

23 C3,C4,C8,C500,C501,C503,

C505,C509,C510,C513,C514

,C515,C530,C532,C533,C53

5,C536,C537,C538,C539,C5

42,C543,C544 

CAP CER 0.10UF 25V 10% 

X7R 0603 

KEMET C0603C104K3R

AC 

2 C5,C6 CAP CER 22PF 50V 5% C0G 

0805 

KEMET C0805C220J5GA

C 

2 C7,C9 CAP CER 18PF 50V 5% C0G 

0603 

YAGEO 

AMERICA 

CC0603JRNPO9

BN180 

15 C502,C504,C507,C512,C517

,C518,C519,C521,C522,C52

3,C524,C525,C526,C527,C5

28 

CAP CER 2200PF 50V 10%  

X7R 0402 

MURATA GRM155R71H22

2KA01D 

2 C508,C511 CAP CER 2.2UF 10V 10% 

X5R 0603 

TDK C1608X5R1A22

5K 

2 C529,C531 CAP CER 0.47UF 25V 10% 

X7R 0805 

VENKEL 

COMPANY 

C0805X7R250-

474KNE 

1 C534 CAP CER 1000PF 50V 5% 

C0G 0603 

MURATA GRM1885C1H10

2JA01D 

6 D1,D3,D5,D7,D10,D12 LED YEL/GRN SGL 25MA 

SMD 0603 

DIALIGHT 598-8060-107F 

5 D2,D4,D6,D8,D13 LED YEL SGL 30MA SMT 

0603 

KINGBRIGHT AP1608SYCK 

htp://www.freescale.com/TWR-56F8200
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1 D9 LED AMBER SGL 25MA 

0603 

AVAGO 

TECHNOLOG

IES 

HSMA-C190 

1 D11 DIODE ZNR 200W 12V SOD-

123 

ON 

Semiconductor 

SMF12AT1G 

1 D500 DIODE SCH PWR RECT 1A 

30V SOD-123 

ON 

Semiconductor 

MBR130LSFT1

G 

1 D501 DIODE SCH DUAL CC 

200MA 30V SOT23 

Fairchild BAT54C 

1 F1 FUSE PLYSW 1.1A 0.48 

OHM SMT 

TYCO 

ELECTRONIC

S 

SMD100F-2 

5 J1,J2,J16,J19,J23 HDR 2X2 SMT 100MIL CTR 

400H AU 

Samtec TSM-102-01-L-

DV-P-TR 

1 J3 CON 1 PWR PLUG RA TH 

1A -- 430H NI 

SWITCHCRA

FT 

RAPC722X 

4 J4,J5,J7,J11 HDR 1X3 TH 100MIL SP 

339H AU 100L 

SAMTEC TSW-103-07-G-

S 

2 J6,J10 HDR 1X1 TH -- 350H AU 

100L 

Samtec TSW-101-07-L-S 

2 J8,J9 HDR 1X5 SMT 100MIL SP 

380H AU 

Samtec TSM-105-01-L-

SV-P-TR 

1 J12 HDR 1X2 TH 100MIL SP 

339H AU 98L 

SAMTEC TSW-102-07-G-

S 

1 J13 HDR 2X5 SMT 100MIL CTR 

400H AU 

Samtec TSM-105-01-L-

DV-A-P-TR 

1 J14 HDR 2X7 SMT 2.54MM SP 

397H AU 

Samtec TSM-107-01-L-

DV-P-TR 

3 J15,J17,J20 HDR 1X2 TH 100MIL SP 

339H AU 98L 

SAMTEC TSW-102-07-G-

S 

1 J18 CON 1X5 USB_MINI_B 

32MILS AU SMT 

SAMTEC MUSB-05-F-B-

SM-A 

1 J21 HDR 2X4 SMT 100MIL CTR 

400H AU 

Samtec TSM-104-01-L-

DV-A-P-TR 

1 J22 HDR 2X3 SMT 100MIL CTR 

414H AU 

SAMTEC TSM-103-01-L-

DV-P-TR 
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1 J500 CON DUAL 2X82 Edge PCI 

Express SMT 1MM SP 591H 

FOR TOWER SYSTEM NOT 

A PART TO ORDER 

NA EDGE PCI 

EXPRESS 164 

1 J501 CON 2X20 SMT SKT 100MIL 

CTR 307H AU 

SAMTEC SSM-120-L-DV-

BE 

1 J502 CON 2X13 SKT SMT 100MIL 

CTR 300H AU 

SAMTEC SSM-113-L-DV-

TR 

2 L1,L2 IND FER BEAD 

330OHM@100MHZ 2.5A -- 

SMT 

TDK MPZ2012S331A 

2 L500,L501 IND 600 OHM@100MHZ 

0.2A 25% 0603 SMT 

MURATA BLM18BD601S

N1D 

1 Q1 TRAN NPN GEN 200MA 40V 

SOT-23 

ON 

SEMICONDU

CTOR 

MMBT3904LT1

G 

1 Q3 TRAN NPN W/RES 100MA 

50V SOT346 

PHILIPS 

SEMICONDU

CTOR 

PDTC115TK 

4 RT1,RT2,RT3,RT4 THERMISTOR 10K 1/10W 

1% 0603 

MuRata NCP18XH103F0

3RB 

1 R1 RES MF 270 OHM 1/16W 5% 

0402 

VISHAY 

INTERTECH

NOLOGY 

CRCW0402270R

JNED 

15 R2,R3,R8,R9,R11,R12,R13,

R14,R15,R554,R555,R561,R

570,R574,R575 

RES MF 10.0K 1/16W 1% 

0402 

VISHAY 

INTERTECH

NOLOGY 

CRCW040210K0

FKED 

3 R4,R10,R568 RES MF ZERO OHM 1/8W -- 

0805 

YAGEO 

AMERICA 

RC0805JR-

070RL 

4 R5,R7,R18,R19 RES MF ZERO OHM 1/8W -- 

0805 

YAGEO 

AMERICA 

RC0805JR-

070RL 

1 R6 RES MF 1.0M 1/8W 1% 0805 VENKEL 

COMPANY 

CR0805-8W-

1004FSNT 

1 R16 RES MF 10M  1/16W 1% 0402 KOA SPEER RK73H1ETTP10

05F 

2 R17,R20 RES POT 100K 1/4W 10%  5 

TURNS WSH SMT 

BOURNS 3214W-1-104E 
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9 R500,R501,R502,R503,R504

,R507,R556,R558,R559 

RES MF 330 OHM 1/16W 1% 

0402 

VISHAY 

INTERTECH

NOLOGY 

CRCW0402330R

FK 

2 R505,R506 RES MF 158K  1/16W 1% 

0402 

KOA SPEER RK73H1ETTP15

83F 

6 R508,R509,R562,R569,R571

,R576 

RES MF 4.99K  1/16W 1% 

0402 

KOA SPEER RK73H1ETTP49

91F 

40 R510,R511,R512,R513,R514

,R515,R516,R517,R518,R51

9,R520,R521,R522,R523,R5

24,R525,R526,R529,R530,R

531,R532,R533,R534,R535,

R537,R538,R540,R541,R542

,R543,R544,R545,R546,R54

7,R548,R549,R550,R551,R5

52,R553 

RES MF 100 OHM 1/16W 1% 

0402 

THYE MING 

TECH CO 

LTD 

CR-02FL6--100R 

2 R527,R528 RES MF 1.0K 1/16W 1% 0402 KOA SPEER RK73H1ETTP10

01F 

1 R536 RES MF 100 OHM 1/16W 1% 

0402 

THYE MING 

TECH CO 

LTD 

CR-02FL6--100R 

1 R539 RES MF 100OHM 1/8W 1% 

0805 

VENKEL 

COMPANY 

CR0805-8W-

1000FT 

3 R557,R563,R564 RES MF 1.0K 1/16W 1% 0402 KOA SPEER RK73H1ETTP10

01F 

1 R560 RES MF 120 OHM 1/16W 1% 

0402 

VISHAY 

INTERTECH

NOLOGY 

CRCW0402120R

FKED 

1 R565 RES MF 2.2K 1/16W 1% 0402 KOA SPEER RK73H1ETTP22

01F 

2 R566,R567 RES MF 53.6K 1/16W 1% 

0402 

KOA SPEER RK73H1ETTP53

62F 

2 R572,R573 RES MF 33.0 OHM 1/16W 1% 

0402 

THYE MING 

TECH CO 

LTD 

CR-02FL6---33R 

3 SW1,SW2,SW3 SW SMT 4.0MM FMS 0.1A 

MAX 16V MAX ROHS 

COMPLIANT 

BOURNS 7914J-1-000E 
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5 TP1,TP2,TP3,TP5,TP6 TEST POINT BLACK 40 MIL 

DRILL 180 MIL TH 109L 

COMPONENT

S 

CORPORATI

ON 

TP-105-01-00 

1 TP4 TEST POINT BLACK 40 MIL 

DRILL 180 MIL TH 109L 

COMPONENT

S 

CORPORATI

ON 

TP-105-01-00 

1 U1 IC VREG LDO 3.3V 0.7A 4.3-

20V SOT-223 

LINEAR 

TECHNOLOG

Y 

LT1129CST-

3.3#PBF 

1 U2 IC CTLER DSP 32BIT 2.7-

3.3V LQFP64 

FREESCALE 

SEMICONDU

CTOR 

PC56F82748ML

H 

1 U3 SUBASSEMBLY, IC CTLER 

DSP 32BIT 2.7-3.3V LQFP64 

+ SKT 64 QFP TH 0.5MM 

847H AU 87L 

SUBASSEMB

LY 

312-80379,210-

79953 

1 U4 MICROPHONE MINI 

SISONIC 300 OHM 59DB 1.5-

3.6V SMT 

Knowles 

Acoustics 

SPM0408HE5H-

SB 

1 U5 DIODE TVS ARRAY 3CH -- 

5V 0.225W SOT143 

LITTELFUSE SP0503BAHTG 

1 U6 IC MCU 8BIT 60K FLASH 

48MHZ 2.7-5.5V LQFP44 

FREESCALE 

SEMICONDU

CTOR 

MC9S08JM60CL

D 

2 U500,U502 IC GATE HEX INV -- 

TSSOP14 

TEXAS 

INSTRUMEN

TS 

SN74LVC04AP

WE4_ 

1 U501 IC LIN SW PWR ACTIVE 

HIGH DUAL 2.7V-5.5V 0.5A 

SOIC8 

MICREL MIC2026-1YM 

1 U503 IC XCVR CAN 1MBAUD 5V 

S08 

PHILIPS 

SEMICONDU

CTOR 

PCA82C250TD 

1 U504 IC BUF QUAD TS 4.5-5.5V 

SOIC14 

Texas 

Instruments 

SN74HCT125D 
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1 U505 IC BUF QUAD TS 1.65-3.6V 

TSSOP14 

TEXAS 

INSTRUMEN

TS 

SN74LVC125AP

WG4 

1 Y1 XTAL 8.000MHZ SER SMT Citizen HCM49-

8.000MABJ-UT 

1 Y2 XTAL 4MHZ -- 18PF 20PPM 

SMT 

ABRACON 

CORP 

ABLS-

4.000MHZ-B2-T 

 

 

9 Appendix D—TWR-56F8200 board jack layout (top view) 
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10 Appendix E—TWR-56F8200 board jack layout (bottom view) 
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