USER MANUAL

1. Introduction

To all residents of the European Union

Important environmental information about this product

This symbol on the device or the package indicates that disposal of the device after its lifecycle could harm the environment. Do not dispose of the unit (or batteries) as unsorted municipal waste; it should be taken to a specialized company for recycling. This device should be returned to your distributor or to a local recycling service. Respect the local environmental rules.

If in doubt, contact your local waste disposal authorities.

Thank you for choosing Velleman®! Please read the manual thoroughly before bringing this device into service. If the device was damaged in transit, do not install or use it and contact your dealer.

2. Safety Instructions

- This device can be used by children aged from 8 years and above, and persons with reduced physical, sensory or mental capabilities or lack of experience and knowledge if they have been given supervision or instruction concerning the use of the device in a safe way and understand the hazards involved. Children shall not play with the device. Cleaning and user maintenance shall not be made by children without supervision.

- Indoor use only. Keep away from rain, moisture, splashing and dripping liquids.

3. General Guidelines

- Refer to the Velleman® Service and Quality Warranty on the last pages of this manual.
- Familiarise yourself with the functions of the device before actually using it.
- All modifications of the device are forbidden for safety reasons. Damage caused by user modifications to the device is not covered by the warranty.
- Only use the device for its intended purpose. Using the device in an unauthorised way will void the warranty.
- Damage caused by disregard of certain guidelines in this manual is not covered by the warranty and the dealer will not accept responsibility for any ensuing defects or problems.
- Nor Velleman nv nor its dealers can be held responsible for any damage (extraordinary, incidental or indirect) – of any nature (financial, physical…) arising from the possession, use or failure of this product.
- Due to constant product improvements, the actual product appearance might differ from the shown images.
- Product images are for illustrative purposes only.
- Do not switch the device on immediately after it has been exposed to changes in temperature. Protect the device against damage by leaving it switched off until it has reached room temperature.
- Keep this manual for future reference.
4. What is Arduino®

Arduino® is an open-source prototyping platform based in easy-to-use hardware and software. Arduino® boards are able to read inputs – light-on sensor, a finger on a button or a Twitter message – and turn it into an output – activating of a motor, turning on an LED, publishing something online. You can tell your board what to do by sending a set of instructions to the microcontroller on the board. To do so, you use the Arduino programming language (based on Wiring) and the Arduino® software IDE (based on Processing).

Surf to [www.arduino.cc](http://www.arduino.cc) and [www.arduino.org](http://www.arduino.org) for more information.

5. Overview

VMA100

The VMA100 (Arduino® Uno compatible) is a microcontroller board based on the ATmega328. It has 14 digital input/output pins (of which 6 can be used as PWM outputs), 6 analogue inputs, a 16 MHz ceramic resonator, a USB connection, a power jack, an ICSP header and a reset button. It contains everything needed to support the microcontroller. Connect it to a computer with a USB cable or power it with an AC-to-DC adapter or battery to get started.

![Arduino Board Diagram]

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>USB interface</td>
<td>6</td>
</tr>
<tr>
<td>2</td>
<td>reset button</td>
<td>7</td>
</tr>
<tr>
<td>3</td>
<td>digital I/O</td>
<td>8</td>
</tr>
<tr>
<td>4</td>
<td>Atmel mega16U2</td>
<td>9</td>
</tr>
<tr>
<td>5</td>
<td>ICSP</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>microcontroller</td>
<td></td>
</tr>
<tr>
<td></td>
<td>operating voltage</td>
<td></td>
</tr>
<tr>
<td></td>
<td>input voltage (recommended)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>input voltage (limits)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>digital I/O pins</td>
<td></td>
</tr>
<tr>
<td></td>
<td>analogue input pins</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DC current per I/O pin</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DC current for 3.3 V pin</td>
<td></td>
</tr>
<tr>
<td></td>
<td>flash memory</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SRAM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>EEPROM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>clock speed</td>
<td></td>
</tr>
<tr>
<td></td>
<td>dimensions</td>
<td></td>
</tr>
<tr>
<td></td>
<td>length</td>
<td></td>
</tr>
<tr>
<td></td>
<td>width</td>
<td></td>
</tr>
<tr>
<td></td>
<td>weight</td>
<td></td>
</tr>
</tbody>
</table>
VMA101

The VMA101 (Arduino® compatible) Mega 2560 is a microcontroller board based on the ATmega2560. It has 54 digital input/output pins (of which 15 can be used as PWM outputs), 16 analogue inputs, 4 UARTs (hardware serial ports), a 16 MHz crystal oscillator, a USB connection, a power jack, an ICSP header, and a reset button. It contains everything needed to support the microcontroller. Connect it to a computer with a USB cable or power it with an AC-to-DC adapter or battery to get started. The Mega is compatible with most shields designed for the Arduino® Duemilanove or Diecimila.

1 USB interface
2 ICSP for 16U2
3 digital I/O
4 Atmel mega16U2
5 ICSP for mega2560
6 16 MHz clock
7 Atmel mega2560
8 reset button
9 digital I/O
10 7-12 VDC power input
11 power and ground pins
12 analogue input pins

- Microcontroller: ATmega2560
- Operating voltage: 5 VDC
- Input voltage (recommended): 7-12 VDC
- Input voltage (limits): 6-20 VDC
- Digital I/O pins: 54 (of which 15 provide PWM output)
- Analogue input pins: 16
- DC current per I/O pin: 40 mA
- DC current for 3.3 V pin: 50 mA
- Flash memory: 256 kB of which 8 kB used by bootloader
- SRAM: 8 kB
- EEPROM: 4 kB
- Clock speed: 16 MHz
- Dimensions
  - Length: 112 mm
  - Width: 55 mm
  - Weight: 62 g
VMA102

The VMA102 (Arduino® compatible Nano 3.0) is a small, complete, and breadboard-friendly board based on the ATmega328 (Arduino Nano 3.x) or ATmega168 (Arduino® Nano 2.x). It has more or less the same functionality of the Arduino® Duemilanove, but in a different package. It lacks only a DC power jack, and works with a mini-B USB cable instead of a standard one.

<table>
<thead>
<tr>
<th></th>
<th>mini USB interface</th>
<th></th>
<th>reset button</th>
<th></th>
<th>digital I/O</th>
<th></th>
<th>ICSP</th>
<th></th>
<th>serial communication pins</th>
<th></th>
<th>ICSP</th>
<th></th>
<th>analogue input pins</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td>2</td>
<td>digital I/O</td>
<td></td>
<td>serial communication pins</td>
<td></td>
<td>ICSP</td>
<td></td>
<td>analogue input pins</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>digital I/O</td>
<td></td>
<td>serial communication pins</td>
<td></td>
<td>ICSP</td>
<td></td>
<td>analogue input pins</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>digital I/O</td>
<td></td>
<td>serial communication pins</td>
<td></td>
<td>ICSP</td>
<td></td>
<td>analogue input pins</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>digital I/O</td>
<td></td>
<td>serial communication pins</td>
<td></td>
<td>ICSP</td>
<td></td>
<td>analogue input pins</td>
</tr>
</tbody>
</table>

- Atmel mega328p
- Atmel ATmega168 or ATmega328
- operating voltage ................................................................. 5 VDC
- input voltage (recommended) ....................................................... 7-12 VDC
- input voltage (limits) ................................................................. 6-20 VDC
- digital I/O pins ........................................................................ 14 (of which 6 provide PWM output)
- analogue input pins ...................................................................... 8
- DC current per I/O pin ................................................................. 40 mA
- flash memory .................................................................................. 16 kB (ATmega168) or 32 kB (ATmega328)
- SRAM ............................................................................................... 1 kB (ATmega168) or 2 kB (ATmega328)
- EEPROM ........................................................................................... 512 bytes (ATmega168) or 1 kB (ATmega328)
- clock speed .................................................................................... 16 MHz
- dimensions
  - length ......................................................................................... 45 mm
  - width ........................................................................................... 18 mm
  - weight .......................................................................................... 5 g
The VMA103 (Arduino® compatible Leonardo) is a microcontroller board based on the ATmega32u4. It has 20 digital input/output pins (of which 7 can be used as PWM outputs and 12 as analogue inputs), a 16 MHz crystal oscillator, a micro USB connection, a power jack, an ICSP header, and a reset button. It contains everything needed to support the microcontroller. Connect it to a computer with a USB cable or power it with an AC-to-DC adapter or battery to get started.
6. **How to Use**

In the example below, we use the VMA100 to make an LED blink.

First, download the latest Arduino® Integrated Development Environment (IDE) from the Arduino® page.

https://www.arduino.cc/en/Main/Software

Install the software and use a USB cable to connect your VMA board to your computer.

a. LED13 will blink.
Next, launch the Arduino® application and click File > Examples > 01. Basics > Blink.

You will need to select the used board. To do so, click Tools > Board.
Select the serial device of the Arduino board. To do so, click Tools > Serial Port.

The LED should now be blinking.

Use this device with original accessories only. Velleman nv cannot be held responsible in the event of damage or injury resulting from (incorrect) use of this device. For more info concerning this product and the latest version of this manual, please visit our website www.velleman.eu. The information in this manual is subject to change without prior notice.

© COPYRIGHT NOTICE
The copyright to this manual is owned by Velleman nv. All worldwide rights reserved. No part of this manual may be copied, reproduced, translated or reduced to any electronic medium or otherwise without the prior written consent of the copyright holder.
Velleman® Service and Quality Warranty

Since its foundation in 1972, Velleman® acquired extensive experience in the electronics world and currently distributes its products in over 85 countries.

All our products fulfil strict quality requirements and legal stipulations in the EU. In order to ensure the quality, our products regularly go through an extra quality check, both by an internal quality department and by specialized external organisations. If, after all precautionary measures notwithstanding, problems should occur, please make appeal to our warranty (see guarantee conditions).

General Warranty Conditions Concerning Consumer Products (for EU):

• All consumer products are subject to a 24-month warranty on production flaws and defective material as from the original date of purchase.
• Velleman® can decide to replace an article with an equivalent article, or to refund the retail value totally or partially when the complaint is valid and a free repair or replacement of the article is impossible, or if the expenses are out of proportion.

You will be delivered a replacing article or a refund at the value of 100% of the purchase price in case of a flaw occurred in the first year after the date of purchase and delivery, or a replacing article at 50% of the purchase price or a refund at the value of 50% of the retail value in case of a flaw occurred in the second year after the date of purchase and delivery.

• Not covered by warranty:
  - all direct or indirect damage caused after delivery to the article (e.g. by oxidation, shocks, falls, dust, dirt, humidity...), and by the article, as well as its contents (e.g. data loss), compensation for loss of profits;
  - consumable goods, parts or accessories that are subject to an aging process during normal use, such as batteries (rechargeable, non-rechargeable, built-in or replaceable), lamps, rubber parts, drive belts...
    (unlimited list);
  - flaws resulting from fire, water damage, lightning, accident, natural disaster, etc....;
  - flaws caused deliberately, negligently or resulting from improper handling, negligent maintenance, abusive use or use contrary to the manufacturer’s instructions;
  - damage caused by a commercial, professional or collective use of the article (the warranty validity will be reduced to six (6) months when the article is used professionally);
  - damage resulting from an inappropriate packing and shipping of the article;
  - all damage caused by modification, repair or alteration performed by a third party without written permission by Velleman®.
• Articles to be repaired must be delivered to your Velleman® dealer, solidly packed (preferably in the original packaging), and be completed with the original receipt of purchase and a clear flaw description.
• Hint: In order to save on cost and time, please reread the manual and check if the flaw is caused by obvious causes prior to presenting the article for repair. Note that returning a non-defective article can also involve handling costs.
• Repairs occurring after warranty expiration are subject to shipping costs.
• The above conditions are without prejudice to all commercial warranties.

The above enumeration is subject to modification according to the article (see article’s manual).