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1 Overview

The Tower LCD RGB Module (TWR-LCD-RGB) adds a side mounting TFT WQVGA Display to the
Freescale Tower System. It can be used with Tower Processor Modules featuring an RGB interfacing
LCD Controller.

The TWR-LCD-RGB features a 4.3” WQVGA TFT LCD Display with touch sensitive overlay. The LCD
interfaces to the Tower System through a 24-bit RGB interface. The 4-wire resistive touch overlay can
interface directly with a compatible Tower Processor Module using GPIO enabled ADC lines, or can
offload the resistive touch sensing to the on-board Xtrinsic Touch Sensing Platform (CRTouch).
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Figure 1 - TWR-LCD-RGB Block Diagram
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Figure 2 - Tower System with TWR-LCD-RGB

2 Reference Material

The documents listed below should be referenced for more information on the Freescale Tower
system and the TWR-LCD-RGB. Refer to http://www.freescale.com/tower for the latest revision of all
Tower documentation.

e TWR-LCD-RGB Schematics

e TWR-LCD-RGB Quick Start Guide

e Example Binary Application featuring Swell Software

For additional software applications supporting the TWR-LCD-RGB refer to:
e http://freescale.com/eGUI
e http://freescale.com/peg
e http://swellsoftware.com

3 Hardware Features

This section provides more details about the hardware specific features and functionality of the TWR-
LCD-RGB.

3.1 Tower System connection

The TWR-LCD-RGB is designed to interface with the secondary side of the Freescale Tower System.
The TWR-LCD-RGB comes pre-attached to an additional TWR-SELE (Secondary Elevator). The LCD
module can be detached from the included TWR-SELE, but it is recommended that the modules
remain attached to avoid any damage to the LCD glass when attempting to reconnect the modules.
For Tower System assemblies that require use of the TWR-LCD-RGB, use the included pre-assembled
TWR-LCD-RGB + TWR-SELE.

TWR-LCD-RGB User’s Guide Page 4 of 14


http://www.freescale.com/tower
http://freescale.com/eGUI
http://freescale.com/peg
http://swellsoftware.com/

-

Z “freescale"

semiconductor

3.2 Power Supply

The TWR-LCD-RGB is designed to be powered via the Tower System and does not require a direct
power source. The Freescale Tower System is capable of being powered directly over USB using the
TWR-ELEV, the Processor Module, or specific peripheral modules. Depending on the number of
modules in the Tower System and the amount of power required for each module it may be required
to use a power source that can supply more than 500mA. Up to 2A may be required depending on the
Tower System configuration. This can be accomplished by either a USB wall adapter or a 5V power
supply, attached to the screw terminal of the TWR-ELEV.

3.3 LCD Display / Driver

The TWR-LCD features an NEC color LCD module (NL4827HC19-05B), which his composed of an
amorphous silicon thin film transistor liquid crystal display (a-Si TFT LCD) panel structure with driver
LSIs for driving the TFT array, touch panel, and backlight. The display panel a 4.3” a-Si TFT active matrix
with 16,777,216 colors, 480(H) x 272 (V) pixels, 24-bit RGB (8-bit per signal).

3.3.1 Timing parameters

The following “typical” timing parameters are taken from the NL4827HC19-05B specification, for
complete details refer to NEC for the latest data.

Table 1 - NEC TFT Timing Parameters

Parameter Typical Value Unit
Clock Frequency 10.87 MHz
HSYNC Cycle 20.7 kHz
HSYNC Display Period 480 CLK
HSYNC Front porch 2 CLK
HSYNC Pulse width 41 CLK
HSYNC Back porch 2 CLK
VSYNC Cycle 75 Hz
VSYNC Display Period 272 CLK
VSYNC Front porch 1 H
VSYNC Pulse width 2 H
VSYNC Back porch 1 H

3.3.2 Communication Mode

The TWR-LCD-RGB is accessible through the 24-bit RGB interface defined on the Secondary Tower
Elevator Pin out. The integrated 4-wire resistive touch panel is accessible via the CRTouch using the
I2C interface or optionally through the ADC signals.
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The signal specification required to drive the display is as follows:

Table 2 - TWR-LCD-RGB TFT Signals

TWR-SELE Description

LCD_D[23:16] | 8-bit Red data signal: LCD_DJ[23:16] -> R[7:0]

LCD_DJ[15:8] | 8-bit Green data signal: LCD_DJ[15:8] -> G[7:0]

LCD_D[7:0] | 8-bit Blue data signal: LCD_D[7:0] -> B[7:0]

LCD_HSYNC | Horizontal Sync Signal

LCD_VSYNC | Vertical Sync Signal

LCD_CLK Clock

LCD_DE Data Enable

Backlight Enable Signal ON/OFF signal,
requires jumper J9 shunted on pins 2-3
Backlight Dimming Control signal,

requires jumper J9 shunted on pins 1-2

GPIO22

PWM15

Either GPIO22 or PWM15 must be appropriately driven.

3.3.3 Resistive Touch Overlay

The TWR-LCD-RGB display features an integrated analog resistive touch panel. The panel can be
access by either the on-board CRTouch Xtrinsic Touch Sensing Solution or a compatible Tower MCU
module. The CRTouch is the preferred interface, allowing the most compatibility within the Freescale
Tower System. The CRTouch features gesture detection such as slide, two-point zoom, and two-point
rotate.

The signal specification available to interface the 4-wire resistive touch overlay using the on-board
CRTouch Xtrinsic Touch Sensing Solution is as follows:

Table 3 — TWR-LCD-RGB 4-Wire Resistive Overlay Digital Signals

TWR-SELE Description

SDA2 I2C SDA signal from the CRTouch
SCL2 I2C SCL signal from the CRTouch
IRQ_| Optional Touch Pending Interrupt from CRTouch,

Requires jumper J10 shunted on pins 1-2
Optional Touch Pending Interrupt from CRTouch,
Requires jumper J10 shunted on pins 2-3

IRQ_M
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The signal specification available to interface the 4-wire resistive touch overlay directly from the MCU
using GPIO capable ADC signals is as follows:

Table 4 —- TWR-LCD-RGB 4-Wire Resistive Overlay Analog Signals

TWR-SELE Description

X-axis right analog signal (XR) direct access to MCU ADC,
AN11 s .

requires jumper J8 shunted on pins 2-3

Y-axis down analog signal (YD) direct access to MCU ADC,
AN10 o :

requires jumper J5 shunted on pins 2-3

X-axis left analog signal (XL) direct access to MCU ADC,
AN9 S i

requires jumper J3 shunted on pins 2-3

Y-axis up analog signal (YU) direct access to MCU ADC,
AN8 on .

requires jumper J2 shunted on pins 2-3

3.4 4-way Navigation Pad

The TWR-LCD-RGB features a 4-way navigation pad implemented using capacitive electrodes. The
touch enables electrodes are accessible only through the CRTouch Xtrinsic Touch Sensing Solution.
Refer to the CRTouch datasheet for details in reading the capacitive electrode states.

4 Software Features

This section provides more details about the software specific features and enablement of the TWR-
LCD-RGB.

4.1 Swell Software - http://swellsoftware.com

Swell Software provides Graphical User Interface (GUI) Solutions for Embedded Devices. Swell's PEG
Pro, PEG+ and C/PEG product offering includes a Graphical User Interface (GUI) library for embedded
development that works tightly with real-time operating systems. The development tool allows
developers to layout user interface screens and controls using the PEG library and external resources
to generate C/C++ code. The PEG WindowBuilder automatically generates C++ source code that is
ready to be compiled and linked into any application, further accelerating the deployment of the final
product.

The TWR-LCD-RGB is supported in PEG Pro and PEG+ versions of the Swell Software GUI development
suite. Official support is included PEG v2.3.13 and later.

Screen drivers featuring the TWR-LCD-RGB are included for the following Tower Controller Modules:
e TWR-K70F120M
e TWR-PXD10
e TWR-PXD20
e TWR-VF65GS10
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Selection of the TWR-LCD-RGB specific pre-defined Screen Driver is done using the “Screen Driver
Configuration” panel within the Swell Window Builder application. The use of the CRTouch is specified
using the appropriate pre-defined Touch Screen driver from the “Input/Output Configuration” panel
within the Swell Window Builder application.

Deskiop Screen Driver —Iput Dievice:

[wéindaws True Color + Alpha (=] Touch Screen
@ Pre-defined |Freescale T'wRETD with TwR-LCD-RGE [=]

& Custom =
Freescale TWRMCFB2252 with TWR-LCD

R atatian
{@ Mone @& 90Degees @ 270 Degress

Tanget Ervirorment L Include Touge . ole MPCSSAS Customer EVE

@ Pre-defined Freezcale TWRETD with TwWR-LCD-RGE - [ Mouse/Pointing [Freescale MPCEEOE Customer EVE E]
Freezcale TWRE 7D with T\wWR-LCD-RGE

© Custom Freescale TWRMCF225x with TwR-LCD =] Keyboard
Freescale MPCSE45 Customer EVE Arrow-Key Suppart Tab-Key Support
L, L= i kA% 20 Y00 bl BA IR A0 Ty E]

Figure 3 - Window Builder Configuration

Example projects are included with the installation of PEG Pro and PEG+. Additionally example pre-
compiled applications are available for download at from the TWR-LCD-RGB webpage located on
http://freescale.com/tower

4.2 eGUI Software - http://freescale.com/eGUI

The complimentary Freescale embedded graphical user interface (eGUI) allows single chip
microcontroller (MCU) systems to implement a graphical user interface and drive the latest generation
of color graphics LCD panels with integrated display RAM and simple serial peripheral interface (SPI) or
parallel bus interface.

The TWR-LCD-RGB is officially supported in eGUI 3.0 and later releases.

Selection of a low-level driver that utilizes the TWR-LCD-RGB is done through the d4d_user_cfg.h
header file included with the installation of eGUI.

As an reference example, below are the defines required to support the TWR-K70F120M with the
TWR-LCD-RGB

#define D4D _LLD LCD d4dlcd_frame buffer
#define D4D_LLD LCD_HW d4dlcdhw_k70 lcdc
#define D4D _LLD TCH d4dtch_cr_touch
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4.3 Loading Example Pre-Compiled Applications

Several example applications are posted on the TWR-LCD-RGB webpage. The section below provides
details regarding loading these applications on to the Tower System.

These specific instructions detail flashing an example application on the TWR-K70F120M with the
TWR-LCD-RGB.

4.3.1 Setup the Tower System

Install the Tower System with the following Tower System modules:
e TWR-ELEV (Primary Elevator)
e Preassembled TWR-LCD-RGB + TWR-SELE (Secondary Elevator)
e TWR-K70F120M
e TWR-SER

Attach the miniUSB connector between the TWR-K70F120M and the host PC. This will enable
programming the TWR-K70F120M over the Open Source JTAG interface.

Be aware that the example projects include a large amount of graphical assets that are compiled
directly into the application. This results in a fairly large flash file. Using the Open Source JTAG
interface can result in approximately a 5 minute flash process.

4.3.2 Create a New Project for Flashing the TWR-K70F120M

Using CodeWarrior for MCU version 10.x
1. Open CodeWarrior for MCU v10.x

2. If required specify the desired workspace

3. Create a new project: File -> New -> Bareboard Project

4. Project a Project name, select Next

5. Select the following device: Kinetis -> K70 Family -> K70 (120 MHz) Family -> MK70FN1MO,
select Finish

6. Right-click the newly created project and select Run -> Run Configuration

7. From the CodeWarrior Download section, select the

<project_name>_MK70FN1MO_INTERNAL_FLASH_PnE U-Multilink option

8. From the C/C++ application section, select the Browse option associates with the
Application field

9. Navigate to the location of the downloaded .out file and select Open

10. Select Run

TWR-LCD-RGB User’s Guide Page 9 of 14



-

Z “freescale"

semiconductor

Using IAR Embedded Workbench

1. Open IAR Embedded Workbench for ARM 6.40
Create a new workspace: File -> New -> Workspace
Create a new project within blank workspace: Project -> Create New Workspace
Tool chain: ARM, Project Template: Externally built executable
Save the resulting project (.ewp) to a desired location
Right-click the project and select Options
0 General Options: Under Processor variant select Device and choose Freescale -> K70
-> Freescale MK70FN1MOxxx12
0 Debugger: Under the Setup tab, Select the PE Micro Driver
0 Debugger: Under the Download tab, check the Use flash loader(s) option.
7. Add the .out file to the project: Project -> Add Files, navigate to the location of the .out file
and select Open (make sure the File Filter is set to All Files (*.*)
8. Save the resulting workspace (.eww) to a desired location using File -> Save Workspace As
9. Flash the project using Project -> Download and Debug
10. Run the resulting application using Debug -> Go

ouhkwnN

5 Elevator Connections

The TWR-LCD features two 80-pin connectors that interface to the Side Expansion Ports on the
Secondary Elevator board in a Tower System. The Secondary Elevator Side Expansion Port connectors,
comprised of sides C and D, are utilized by the TWR-LCD-RGB. The table below provides the pinout for
the Secondary Elevator Connector. An “X” in the “Used” column indicated that there is a connection
from the TWR-LCD-RGB to that pin on the Elevator connector. An “X” in the “Jmp” column indicates
that a jumper is available that can configure or isolate the connection from the Elevator connector.

Table 5 - TWR-LCD-RGB Secondary Elevator Expansion Pinout

TWR-LCD-RGB Secondary Connector

Pin Name Usage Used Jmp Pin Name Usage Used Jmp ‘

D1 5V 5.0V Power X Cl 5V 5.0V Power X

D2 GND Ground X C2 GND Ground X

D3 3.3V 3.3V Power X C3 3.3V 3.3V Power X

D4 ELE_PS_SENSE Elevator Power Sense C4 3.3V 3.3V Power X

D5 GND Ground X C5 GND Ground X

D6 GND Ground X C6 GND Ground X

D7 SPI2_CLK c7 scL2 CRTOUCH SCL X

D8 SPI2_CS1_b c8 SDA2 CRTOUCH SDA X

D9 SP12_CSO_b c9 GPI1025 RESET_IN_B X

D10 SPI12_MOSI C10 ULPI_STOP

D11 SPI2_MISO c11 c11
I T————

D12 ETH_COL c12 GP1026

D13 ETH_RXER c13 ETH_MDC

TWR-LCD-RGB User’s Guide
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TWR-LCD-RGB Secondary Connector

Used Jmp Pin Name Used Jmp

D14 ETH_TXCLK cl14 ETH_MDIO
D15 ETH_TXEN C15 ETH_RXCLK
D16 GPIO18 Cc16 ETH_RXDV
D17 GPIO19 / SDHC_D4 c17 | GPIO27 /SDHC_D6
D18 GPI020 / SDHC_D5 cis| GPI028/SDHC_D7
D19 ETH_TXD1 c19 ETH_RXD1
D20 ETH_TXDO 20 ETH_RXDO

ULPI_DATAO /
D21 ULPI_NEXT / USB1_DM C21 USB3_DM

ULPI_DATA1/
D22 ULPI_DIR / USB1_DP c22 USB3_DP

ULPI_DATA2 /
D23 | UPLI_DATA5 / USB2_DM C23 USB4_DM

ULPI_DATA3 /
D24 ULPI_DATA6 / USB2_DP C24 USB4_DP
D25 ULPI_DATA7 C25 ULPI_DATA4
D26 GND Ground X C26 GND Ground X
D27 LCD_HSYNC / LCD_P24 RGB_Hsync c27 AN11 Resistive Touch XR X X
D28 LCD_VSYNC / LCD_P25 RGB_Vsync c28 AN10 Resistive Touch YD X X
D29 AN13 Cc29 AN9 Resistive Touch XL X X
D30 AN12 c30 ANS8 Resistive Touch YU X X
D31 GND Ground X C31 GND Ground X
D32 LCD_CLK / LCD_P26 RGB_CLK X c32 GPIO29
D33 TMR11 Cc33 TMR9
D34 TMR10 Cc34 TMR8
D35 GPIO21 C35 GPIO30
D36 3.3V 3.3V Power X C36 3.3V 3.3V Power X
D37 PWM15 LED_PWM X X |c37 PWM11
D38 PWM14 Cc38 PWM10
D39 PWM13 Cc39 PWM9
D40 PWM12 c40 PWM8
D41 CANRX1 ca1 RXD2 / TSIO
D42 CANTX1 ca2 TXD2 / TSI1
D43 GPI022 / Backlight LCD_ENABLE X X | ca3 RTS2 / TSI2
D44 LCD_OE / LCD_P27 RGB_DE X caa CTS2 /TSI3
D45 LCD_DO/ LCD_PO BLUE Data Signal BO (LSB) X ca5 RXD3 / TSI4
D46 LCD_D1/LCD_P1 BLUE Data Signal B1 X c46 TXD3 / TSI5
D47 LCD_D2 /LCD_P2 BLUE Data Signal B2 X ca7 RTS3 / TSI6
D48 LCD_D3/LCD_P3 BLUE Data Signal B3 X c48 CTS3 /TSI7
D49 GND Ground X C49 GND Ground X
D50 GPI023 C50 LCD_D4 / LCD_P4 BLUE Data Signal B4 X
D51 GPl1024 Cc51 LCD_D5/LCD_P5 BLUE Data Signal B5 X
D52 LCD_D12 /LCD_P12 GREEN Data Signal G4 X C52 | LCD_D6/LCD_P6 |BLUE Data Signal B6 X

BLUE Data Signal B7

D53 LCD_D13/LCD_P13 GREEN Data Signal G5 X C53 LCD_D7/LCD_P7 | (MSB) X
D54 LCD_D14 /LCD_P14 GREEN Data Signal G6 X Csq | CD-D8/LCD_PS E_F;E)EN Pata Signal 60 X

TWR-LCD-RGB User’s Guide
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TWR-LCD-RGB Secondary Connector

Used Jmp Pin Name
D55 IRQ_P / SPI2_CS2_b cs55 LCD_D9/LCD_P9 | GREEN Data Signal G1
D56 IRQ_O /SPI2_CS3_b C56 | LCD_D10/LCD_P10 |GREEN Data Signal G2
D57 IRQ_N c57 | LCD_D11/LCD_P11 |GREEN Data Signal G3
D58 IRQ_M C58 TMR16
D59 IRQ_L C59 TMR15
D60 IRQ_K IRQ_B X X | c60 TMR14
D61 IRQ_J c61 TMR13
GREEN Data Signal G7
062 IRQ_I IRQ_A X X | g, | LCD_DIS/LCD_P1S (MSB)
D63 LCD_D18/LCD_P18 RED Data Signal R2 c63 | LCD_D16/LCD_P16 |RED Data Signal RO (LSB)
D64 LCD_D19/LCD_P19 RED Data Signal R3 C64 | LCD_D17/LCD_P17 |RED Data Signal R1
D65 GND Ground X C65 GND Ground
EBI_BE_32 24 b/
D66 EBI_AD20/ LCD_P42 C66 LCD_P28
EBI_BE_23 16 b/
D67 EBI_AD21 /LCD_P43 C67 LCD_P29
EBI_BE_15_8 b/
D68 EBI_AD22 / LCD_P44 C68 LCD_P30
EBI_BE_7. 0 b/
D69 EBI_AD23/LCD_P45 C69 LCD_P31
D70 EBI_AD24 / LCD_P46 C70 | EBI_TSIZEO / LCD_P32
D71 EBI_AD25 / LCD_P47 C71 | EBI_TSIZE1/LCD_P33
D72 EBI_AD26 / LCD_P48 C72 | EBLTS b/LCD_P34
D73 EBI_AD27 / LCD_P49 C73 | EBI_TBST b /LCD_P35
D74 EBI_AD28 / LCD_P50 C74 | EBI_TA b/LCD_P36
D75 EBI_AD29 /LCD_P51 C75 | EBI_CS4 b /LCD_P37
D76 EBI_AD30 /LCD_P52 C76 | EBI_CS3_b/LCD_P38
D77 EBI_AD31/LCD_P53 C77 | EBI_CS2_b/LCD_P39
D78 LCD_D20/LCD_P20 RED Data Signal R4 C78 | EBI_CS1_b/LCD_P40
D79 LCD_D21/LCD_P21 RED Data Signal R5 c79 GPI031 / LCD_P41
D80 LCD_D22 /LCD_P22 RED Data Signal R6 C80 | LCD_D23/LCD_P23 |RED Data Signal R7 (MSB)

TWR-LCD-RGB User’s Guide
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6 Jumper Table

The following configuration switches provided for isolation, configuration, and feature selection.
Refer to the following table for details. The default installed dip switch settings are shown in m

Table 6 - TWR-LCD-RGB Configuration Table

Setting Description
. 1-2 Use the onboard CRTouch
12 Y+ Selection -
Routes the Y+ signal to the AN8 (ELEV C30)
. 1-2 Use the onboard CRTouch
13 X- Selection -
Routes the X- signal to the AN9 (ELEV C29)
. 1-2 Use the onboard CRTouch
J5 Y- Selection -
Routes the Y- signal to the AN10 (ELEV C28)
. 1-2 Use the onboard CRTouch
J8 X+ Selection -
Routes the X+ signal to the AN11 (ELEV C27)
1-2 Uses PWM15 (ELEV D37) to control the LED brightness
J9 LED DIM Control
Uses GPI022 (ELEV D43) to control the LED on/off state
. 1-2 CRTouch IRQ is connected to IRQ_I (ELEV D62)
J10 IRQ Selection -
2-3 CRTouch IRQ is connected to IRQ_K (ELEV D64)

6.1 Mechanical Form Factor

The TWR-LCD-RGB is designed for the Freescale Tower System as a side mounting peripheral and
complies with the electrical and mechanical specification as described in Freescale Tower
Electromechanical Specification. The TWR-LCD-RGB is intended for use on the secondary side only and
come pre-assembled to the TWR-SELE.

7 Revision History

Revision Number Date Substantive changes
1 10/2011 Initial release
2 11/2014 Updated to correct Tower
Elevator connections

TWR-LCD-RGB User’s Guide Page 13 of 14



-

Z “freescale"

semiconductor
How to Reach Us: Information in this document is provided solely to enable system and software
implementers to use Freescale products. There are no express or implied
Home Page: copyright licenses granted hereunder to design or fabricate any integrated

freescale.com circuits based on the information in this document.

Freescale reserves the right to make changes without further notice to any
products herein. Freescale makes no warranty, representation, or guarantee
regarding the suitability of its products for any particular purpose, nor does
Freescale assume any liability arising out of the application or use of any
product or circuit, and specifically disclaims any and all liability, including without
limitation consequential or incidental damages. “Typical” parameters that may
be provided in Freescale data sheets and/or specifications can and do vary in
different applications, and actual performance may vary over time. All operating
parameters, including “typicals,” must be validated for each customer application
by customer’s technical experts. Freescale does not convey any license under
its patent rights nor the rights of others. Freescale sells products pursuant to
standard terms and conditions of sale, which can be found at the following
address: freescale.com/SalesTermsandConditions.

Web Support:
freescale.com/support

Freescale, the Freescale logo, and Kinetis are trademarks of Freescale
Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. Xtrinsic is the trademark of
Freescale Semiconductor, Inc. All other product or service names are the
property of their respective owners. The ARM Powered Logo is a trademark of
ARM Limited. ARMnnn is the trademark of ARM limited.

© 2014 Freescale Semiconductor, Inc.

TWR-LCD-RGB User’s Guide Page 14 of 14



	User’s Guide
	1  Overview
	2 Reference Material
	3 Hardware Features
	3.1 Tower System connection
	3.2 Power Supply
	3.3 LCD Display / Driver
	3.3.1 Timing parameters
	3.3.2 Communication Mode
	3.3.3 Resistive Touch Overlay

	3.4 4-way Navigation Pad

	4 Software Features
	4.1 Swell Software - http://swellsoftware.com
	4.2 eGUI Software - http://freescale.com/eGUI
	4.3 Loading Example Pre-Compiled Applications
	4.3.1 Setup the Tower System
	4.3.2 Create a New Project for Flashing the TWR-K70F120M
	Using CodeWarrior for MCU version 10.x
	Using IAR Embedded Workbench



	5 Elevator Connections
	6  Jumper Table
	6.1 Mechanical Form Factor

	7 Revision History

