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Introduction
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The National Instruments USB-6008/6009 devices provide eight single-ended analog
input (Al) channels, two analog output (AO) channels, 12 DIO channels, and a 32-bit
counter with a full-speed USB interface. This user guide describes how to use these
devices.

For specifications, refer to the NI USB-6008 Device Specifications and the
NI USB-6009 Device Specifications available at ni.com/manuals.

The following table compares the NI USB-6008 and NI USB-6009 devices.

Feature NI USB-6008 NI USB-6009

Al resolution 12 bits differential, 11 14 bits differential, 13 bits single-
bits single-ended ended

Maximum Al sample rate, single 10 kS/s 48 kS/s

channelll]

Maximum Al sample rate, 10 kS/s 48 kS/s

multiple channels (aggregate)[t!

DIO configuration Open collector!?! Each channel individually
programmable as open collector or

active drivel?]

Table 1. NI USB-6008 and NI USB-6009 Comparison

The following figure shows key functional components of the NI USB-6008/6009.
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Figure 1. NI USB-6008/6009 Block Diagram
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2 This document uses NI-DAQmx naming conventions. Open-drain is called open
collector and push-pullis called active drive.

Safety Guidelines

The following section contains important safety information that you must follow
when installing and using the NI USB-6008/6009.

A Caution: Operate the NI USB-6008/6009 only as described in these
operating instructions. Misuse of the device can result in a hazard. You can
compromise the safety protection built into the device if the device is
damaged in any way. If the device is damaged, contact National
Instruments for repair.

© National Instruments 5
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Caution: Do not substitute parts or modify the device except as described
in this user guide. Use the device only with the accessories specified in the
installation instructions.

Caution: Do not operate the device in an explosive atmosphere or where
there may be flammable gases or fumes. If you must operate the device in
such an environment, it must be in a suitably rated enclosure.

Electromagnetic Compatibility Guidelines

This product was tested and complies with the regulatory requirements and limits
for electromagnetic compatibility (EMC) stated in the product specifications. These
requirements and limits provide reasonable protection against harmful interference
when the product is operated in the intended operational electromagnetic
environment.

This product is intended for use in industrial locations. However, harmful
interference may occur in some installations, when the product is connected to a
peripheral device or test object, or if the product is used in residential or
commercial areas. To minimize interference with radio and television reception and
prevent unacceptable performance degradation, install and use this product in strict
accordance with the instructions in the product documentation.

Furthermore, any changes or modifications to the product not expressly approved
by National Instruments could void your authority to operate it under your local
regulatory rules.

Caution: To ensure the specified EMC performance, operate this product
only with shielded cables and accessories.

Caution: This product may become more sensitive to electromagnetic
disturbances in the operational environment when test leads are attached

or when the product is connected to a test object.

ni.com
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Caution: Emissions that exceed the regulatory requirements may occur
when this product is connected to a test object.

A\\‘ Note: Changes or modifications to the product not expressly approved by
National Instruments could void your authority to operate the product
under your local regulatory rules.

Unpacking the Kit

Caution: To prevent electrostatic discharge (ESD) from damaging the
device, ground yourself using a grounding strap or by holding a grounded
object, such as your computer chassis.

1. Touch the antistatic package to a metal part of the computer chassis.

2. Remove the device from the package and inspect the device for loose
components or any other sign of damage.

A Caution: Never touch the exposed pins of connectors.

’\\‘ Note: Do not install a device if it appears damaged in any way.

3. Unpack any other items and documentation from the kit.

Store the device in the antistatic package when the device is not in use.
Setting Up the NI USB-6008/6009

Complete the following steps to get started with the NI USB-6008/6009.

\g . . . .

) Note: For information about non-Windows operating support, refer to the
Getting Started with NI-DAQmx Base document available from ni.com/
manuals.
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1. Install the application software (if applicable), as described in the installation
instructions that accompany your software.

2. Install NI-DAQmx[L.

,\\’ Note: The NI-DAQmx software is included on the disk shipped with
your kit and is available for download at ni.com/support. The
documentation for NI-DAQmx is available after installation from
Start > All Programs > National Instruments > N[I-DAQmx. Other NI
documentation is available from ni.com/manuals.

3. Install the 16-position screw terminal plugs by inserting them into the
connector jacks, as shown in the following figure.

Figure 2. Signal Label Application Diagram

1. Overlay Label with Pin Orientation Guides
2. Screw Terminal Connector Plug
3. Signal Label
4. USB Cable
4. Affix the provided signal labels to the screw terminal connector plugs. You can
choose labels with pin numbers, signal names, or blank labels, as shown in
the following figure. Choose one of the labels, align the correct label with the

terminals printed on the top panel of your device and apply the label, as
shown in the previous figure.
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Figure 3. NI USB-6008/6009 Signal Labels
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Terminal Number Label
Digital I/O Label
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Analog Input Single-Ended Signal Name Label

> Note: After you label the screw terminal connector plugs, you must

only insert them into the matching connector jack, as indicated by
the overlay label on the device.

. Plug one end of the USB cable into the NI USB-6008/6009 and the other end
into an available USB port on the computer.

. Double-click the NI MAX icon on the desktop to open Measurement &
Automation Explorer (MAX).

. Expand My System > Devices and Interfaces and verify that the

NI USB-6008/6009 is listed. If your device does not appear, press <F5> to
refresh the view in MAX. If your device is still not recognized, refer to ni.com/
support/dagmx for troubleshooting information.

. Self-test your device in MAX by right-clicking NI USB-6008 or NI USB-6009

and selecting Self-Test. Self-test performs a brief test to determine successful
device installation. When the self-test finishes, a message indicates successful
verification or if an error occurred. If an error occurs, refer to ni.com/support/
dagmx.

© National Instruments 9
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Caution: To ensure the specified EMC performance, operate this
product only with shielded cables and accessories.

Connect the wires (16 AWG to 28 AWG) of a shielded, multiconductor cable to
screw terminals by stripping 6.35 mm (0.25 in) of insulation, inserting the
wires into the screw terminals, and securely tightening the screws with the
flathead screwdriver to a torque of 0.22N-m to 0.25N-m

(2.0lb-in.t0 2.2 lb-in.). Refer to the Pinout and Signal Descriptions section
for an image of the NI USB-6008/6009 pinout.

If using a shielded cable, connect the cable shield to a nearby GND terminal.

\ Note: For information about sensors, go to ni.com/sensors. For
information about IEEE 1451.4 TEDS smart sensors, go to ni.com/
teds.

Run a Test Panel in MAX by right-clicking NI USB-6008 or NI USB-6009 and
selecting Test Panels.

Click Start to test the device functions, or Help for operating instructions. Click
Close to exit the test panel.

1 NI USB-6008/6009 devices are supported by NI-DAQmx 7.5 and later.

Using the NI USB-6008/6009 in an Application

You can use the DAQ Assistant through many NI application software programs to
configure virtual and measurement channels. The following table lists DAQ Assistant
tutorial locations for NI applications.

NI Application Tutorial Location
LabVIEW Go to Help > LabVIEW Help. Next, go to Getting Started with LabVIEW >

Getting Started with DAQ > Taking an NI-DAQmx Measurement in
LabVIEW.

LabWindows™/CVI™ Go to Help > Contents. Next, go to Using LabWindows/CVI> Data

ni.com

Acquisition > Taking an NI-DAQmx Measurement in LabWindows/CVI.
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NI Application Tutorial Location
Measurement Go to NI Measurement Studio Help > Getting Started with the Measurement
Studio Studio Class Libraries > Measurement Studio Walkthroughs > Walkthrough:

Creating a Measurement Studio NI-DAQmx Application.

LabVIEW Go to Help > Taking an NI-DAQmx Measurement in SignalExpress.
SignalExpress

Table 2. DAQ Assistant Tutorial Locations

Refer to the Where to Go from Here section for information about programming
examples for NI-DAQmx and NI-DAQmx Base.

Features

The NI USB-6008/6009 features a USB connector, USB cable strain relief, two screw
terminal connector plugs for I/O, and an LED indicator, as shown in the following

figure.

Figure 4. NI USB-6008/6009 Top and Back Views
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1. USB Cable Strain Relief

2. Screw Terminal Connector Plug
3. LED Indicator

4. USB Connector

USB Connector and USB Cable Strain Relief

The NI USB-6008/6009 features a USB connector for full-speed USB interface. You
can provide strain relief for the USB cable by threading a zip tie through the USB

© National Instruments 1 1
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cable strain relief ring and tightening around a looped USB cable, as shown in the
following figure.

Figure 5. NI USB-6008/6009 Strain Relief

LED Indicator

The NI USB-6008/6009 device has a green LED indicator that indicates device status,
as listed in the following table. When the device is connected to a USB port, the LED
blinks steadily to indicate that the device is initialized and is receiving power from
the connection.

LED State Device Status
Not lit Device not connected or in suspend

On, not blinking Device connected but not initialized, or the computer is in standby mode. In
order for the device to be recognized, the device must be connected to a
computer that has NI-DAQmx installed on it.

Single-blink Operating normally
Table 3. LED State/Device Status

Screw Terminal Connector Plugs

The NI USB-6008/6009 ships with one detachable screw terminal connector plug for
analog signals and one detachable screw terminal connector plug for digital signals.
These screw terminal connectors provide 16 connections that use 16 AWG to 28 AWG
wire. Refer to step 4 of the Setting Up the NI USB-6008/6009 section for information
about selecting labels for the screw terminal connector plugs. Refer to the Pinout
and Signal Descriptions section for the device pinout and signal descriptions.

ni.com
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You can order additional connectors and labels for your device. Refer to the Cables
and Accessories section for ordering information.

Firmware

The firmware on the NI USB-6008/6009 refreshes whenever the device is connected
to a computer with NI-DAQmx. NI-DAQmx automatically uploads the compatible
firmware version to the device. The firmware version may be upgraded when new
versions of NI-DAQmx release.

Cables and Accessories

The following table contains information about cables and accessories available for
the NI USB-6008/6009. For a complete list of accessories and ordering information,

refer to the pricing section of the NI USB-6008 or NI USB-6009 product page at
ni.com.

Accessory Part Number Description
USB-6008/6009 Accessory 779371-01 Four additional screw-terminal connectors,
Kit connector labels, and a screwdriver
USB-6000 Series 779511-01 Unshielded breadboarding accessory for custom-
Prototyping Accessory defined signal conditioning and prototyping. You
can use up to two accessories per device.

Hi-Speed USB Cable 184125-01, 1mand 2 m lengths

184125-02

Table 4. NI USB-6008/6009 Cables and Accessories

A Caution: For compliance with Electromagnetic Compatibility (EMC)
requirements, this product must be operated with shielded cables and
accessories. If unshielded cables or accessories are used, the EMC
specifications are no longer guaranteed unless all unshielded cables
and/or accessories are installed in a shielded enclosure with properly
designed and shielded input/output ports.

© National Instruments 1 3
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Pinout and Signal Descriptions

The following figure shows the pinout of the NI USB-6008/6009. Analog input signal
names are listed as single-ended analog input name, Al x, and then differential
analog input name, (Al x+/-). Refer to the following table for a detailed description of
each signal.

Figure 6. NI USB-6008/6009 Pinout
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Signal Reference Direction |Description

Name

GND — — Ground—The reference point for the single-ended analog
input measurements, analog output voltages, digital signals,
+5VDC supply, and +2.5VDC at the I/O connector, and the
bias current return point for differential mode
measurements.

Al <0..7>  Varies Input Analog Input Channels 0 to 7—For single-ended

measurements, each signal is an analog input voltage
channel. For differential measurements, Al 0 and Al 4 are the
positive and negative inputs of differential analog input
channel 0. The following signal pairs also form differential
input channels: Al <1, 5>, Al <2, 6>, and Al <3, 7>. Refer to the
Analog Input section for more information.

AO<0,1> GND Output Analog Output Channels 0 and 1—Supplies the voltage
output of AO channel 0 or AO channel 1. Refer to the Analog
Output section for more information.

ni.com



Signal
Name

P0.<0..7>

P1.<0..3>

PFI0

+2.5V

+5V

Reference Direction

GND

GND

GND

GND

GND

Input or
Output

Input or

Output

Input

Output

Output

Table 5. Signal Descriptions

Analog Input

USB-6008/6009 Features

Description

Port 0 Digital I/O Channels 0 to 7—You can individually
configure each signal as an input or output. Refer to the
Digital I/O section for more information.

Port 1 Digital I/O Channels 0 to 3—You can individually
configure each signal as an input or output. Refer to the
Digital I/O section for more information.

PFI 0—This pin is configurable as either a digital trigger or an
event counter input. Refer to the PFI 0 section for more
information.

+2.5 V External Reference—Provides a reference for wrap-
back testing. Refer to the +2.5 V External Reference section for
more information.

+5 V Power Source—Provides +5V power up to 200 mA.
Refer to the +5 V Power Source section for more information.

The NI USB-6008/6009 has eight analog input channels that you can use for four
differential analog input measurements or eight single-ended analog input

measurements.

The following figure shows the analog input circuitry of the NI USB-6008/6009.

Figure 7. NI USB-6008/6009 Analog Input Circuitry

MUX

+2.5 VRer
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PGA ADC — AIFIFO

Input Range
Selection

The main blocks featured in the NI USB-6008/6009 analog input circuitry are as

follows:
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= MUX—The NI USB-6008/6009 has one analog-to-digital converter (ADC). The
multiplexer (MUX) routes one Al channel at a time to the PGA.

= PGA—The programmable-gain amplifier provides input gainsof 1,2, 4,5, 8,
10, 16, or 20 when configured for differential measurements and gain of 1
when configured for single-ended measurements. The PGA gain is
automatically calculated based on the voltage range selected in the
measurement application.

= ADC—The analog-to-digital converter (ADC) digitizes the Al signal by
converting the analog voltage into digital code.

= Al FIFO—The NI USB-6008/6009 can perform both single and multiple
analog-to-digital conversions of a fixed or infinite number of samples. A first-
in-first-out (FIFO) buffer holds data during Al acquisitions to ensure that no
data is lost.

Analog Input Modes and Signal Sources

You can configure the Al channels on the NI USB-6008/6009 to take differential or
referenced single-ended (RSE) measurements. The following table summarizes the
recommended analog input mode(s) for floating signal sources and ground-
references signal sources. Refer to the table in the Pinout and Signal Descriptions
section for more information about 1/0 configurations for single-ended or
differential measurements.

Analog Input Floating Signal Sources (Not Connected Ground-Referenced Signal Sources

Mode to Building Ground)
Examples Plug-in instruments with non-isolated
P = Ungrounded thermocouples 5
outputs

= Signal conditioning with

isolated outputs

= Battery devices
Differential
(DIFF) Signal Source ._N_I EJ_S_B_—EEO_O_BLG_OQS_JI Signal Source NI USB-GOOB/BOOQI

ni.com
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Analog Input Floating Signal Sources (Not Connected Ground-Referenced Signal Sources
Mode to Building Ground)

Referenced

Sin gle— Ended Signal Source [:IL9§I§-5399£§/§QQQ: NOT RECOMMENDED

( RS E) Signal Source NI USB-6008/6009

i 1Al

Ground-loop potential (V5 — Vp) are added
to measured signal.

Table 6. Analog Input Configurations

Floating Signal Sources

A floating signal source is not connected to the building ground system, but has an
isolated ground-reference point. Some examples of floating signal sources are
outputs of transformers, thermocouples, battery-powered devices, optical isolators,
and isolation amplifiers. An instrument or device that has an isolated outputis a
floating signal source.

Refer to Field Wiring and Noise Considerations for Analog Signals for more
information. To access this document, go to ni.com/info and enter the Info Code
rdfwn3.

When to Use Differential Connections with Floating Signal Sources

Use DIFF input connections for any channel that meets any of the following
conditions:

= Your application requires input ranges other than £10 V.
= The inputsignalis low level and requires greater accuracy.

The leads connecting the signal to the device are greater than 3 m (10 ft).

The input signal requires a separate ground-reference point or return signal.

The signal leads travel through noisy environments.

Two analog channels, Al+ and Al-, are available for the signal.

© National Instruments 1 7
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DIFF signal connections reduce noise pickup and increase common-mode noise
rejection. DIFF signal connections also allow input signals to float within the
working voltage of the device.

Refer to the Taking Differential Measurements section for more information about
differential connections.

When to Use Referenced Single-Ended (RSE) Connections with Floating Signal Sources

Only use RSE input connections if the input signal meets all of the following
conditions:

= The input signal can share a common reference point, GND, with other
signals that use RSE.

= Your application permits the use of the £10 V input range.
= The leads connecting the signal to the device are less than 3 m (10 ft).

DIFF input connections are recommended for greater signal integrity for any input
signal that does not meet the preceding conditions.

In the single-ended modes, more electrostatic and magnetic noise couples into the
signal connections than in DIFF configurations. The coupling is the result of
differences in the signal path. Magnetic coupling is proportional to the area between
the two signal conductors. Electrical coupling is a function of how much the electric
field differs between the two conductors.

With this type of connection, the PGA rejects both the common-mode noise in the
signal and the ground potential difference between the signal source and the device
ground.

Refer to the Taking Referenced Single-Ended Measurements section for more
information about RSE connections.

Ground-Referenced Signal Sources

A ground-referenced signal source is a signal source connected to the building
system ground. It is already connected to a common ground point with respect to
the device, assuming that the computer is plugged into the same power system as
the source. Non-isolated outputs of instruments and devices that plug into the
building power system fall into this category.

ni.com
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The difference in ground potential between two instruments connected to the same
building power system is typically between 1 mV and 100 mV, but the difference can
be much higher if power distribution circuits are improperly connected. If a
grounded signal source is incorrectly measured, this difference can appear as
measurement error. Follow the connection instructions for grounded signal sources
to eliminate this ground potential difference from the measured signal.

Refer to Field Wiring and Noise Considerations for Analog Signals for more
information. To access this document, go to ni.com/info and enter the Info Code
rdfwn3.

When to Use Differential Connections with Ground-Reference Signal Sources

Use DIFF input connections for any channel that meets any of the following
conditions:

= Your application requires input ranges other than £10 V.

The input signal is low level and requires greater accuracy.

The leads connecting the signal to the device are greater than 3 m (10 ft).

The input signal requires a separate ground-reference point or return signal.

The signal leads travel through noisy environments.

Two analog channels, Al+ and Al-, are available for the signal.

DIFF signal connections reduce noise pickup and increase common-mode noise
rejection. DIFF signal connections also allow input signals to float within the
working voltage of the device.

Refer to the Taking Differential Measurements section for more information about
differential connections.

When to Use Referenced Single-Ended (RSE) Connections with Ground-Referenced
Signal Sources

Do not use RSE connections with ground-referenced signal sources. Use differential
connections instead.

As shown in the table in the Analog Input Modes and Signal Sources section, there
can be a potential difference between GND and the ground of the sensor. In RSE
mode, this ground loop causes measurement errors.

© National Instruments 1 9
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Taking Differential Measurements

For differential signals, connect the positive lead of the signal to the Al+ terminal,
and the negative lead to the Al- terminal.

Figure 8. Connecting a Differential Voltage Signal

Al+!

<
Voltage C‘) ! NI USB-6008/6009 !
Source \_ _ ' |
A !

The differential input mode can measure +20 V signals in the +20 V range. However,
the maximum voltage on any one pinis £10 V with respect to GND. For example, if Al
lis+10VandAl5is-10V, then the measurement returned from the device is +20 V.

Figure 9. Example of a Differential 20 V Measurement
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Connecting a signal greater than £10 V on either pin results in a clipped output.

Figure 10. Exceeding +10 V on Al Returns Clipped Output
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Taking Referenced Single-Ended Measurements

To connect referenced single-ended (RSE) voltage signals to the NI USB-6008/6009,
connect the positive voltage signal to an Al terminal, and the ground signal to a GND
terminal, as shown in the following figure.

Figure 11. Connecting a Referenced Single-Ended Voltage Signal

Voltage <+> ! NI USB-6008/6009 '
Source\ _ h .

When no signals are connected to the analog input terminal, the internal resistor
divider may cause the terminal to float to approximately 1.4 V when the analog
input terminal is configured as RSE. This behavior is normal and does not affect the
measurement when a signal is connected.

Digital Trigger

You can configure PFI 0 as a digital trigger input for analog input tasks. Refer to the
Using PF1 0 as a Digital Trigger section for more information.

Analog Output

The NI USB-6008/6009 has two independent analog output channels that can
generate outputs from 0V to 5 V. All updates of analog output channels are
software-timed. GND is the ground-reference signal for the analog output channels.

The following figure shows the circuitry of one analog output channel on the
NI USB-6008/6009.

© National Instruments 21
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Figure 12. Circuitry of One Analog Output Channel
+5V

T

REF(+) REF(-) 50 Q
12-Bit o AO
DAC

L

GND
The main block featured in the NI USB-6008/6009 analog output circuitry is the
digital-to-analog converter (DAC), which converts digital codes to analog voltages.

There is one DAC for each analog output line.
Connecting Analog Output Loads

To connect loads to the NI USB-6008/6009, connect the positive lead of the load to
the AO terminal, and connect the ground of the load to a GND terminal, as shown in
the following figure.

Figure 13. Connecting a Load

| NI USB-6008/6009 | Load

+ GND

Minimizing Glitches on the Output Signal

When you use a DAC to generate a waveform, you may observe glitches in the
output signal. These glitches are normal; when a DAC switches from one voltage to
another, it produces glitches due to released charges. The largest glitches occur
when the most significant bit of the DAC code changes. You can build a lowpass
deglitching filter to remove some of these glitches, depending on the frequency and
nature of the output signal. For more information about minimizing glitches, refer to
the KnowledgeBase document, Reducing Glitches on the Analog Output of MIO
DAQ Devices. To access this document, go to ni.com/info and enter the Info Code
exszek.

ni.com
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Digital /0

The NI USB-6008/6009 has 12 digital lines on two ports, Port 0 has eight lines,
P0.<0..7>, and Port 1 has four lines, P1.<0..3>. GND is the ground-reference signal for
the digital 1/O ports. You can individually program all lines as inputs or outputs.

The following figure shows P0.<0..7> connected to example signals configured as
digital inputs and digital outputs. You can configure P1.<0..3> similarly.

Figure 14. Example of Connecting a Load

+5V T
LED //l/l/vv |
é ol P0.0
HED é o PO.1
@/V_K]_WW o« P0.2
o P0.3
o LI ros
T 45V TTL Signal | ° PO.5
o P0.6
v I »P0.7
Switch\g
/’ GND

1/0 Connector T
! NI USB-6008/6009

P0.0 configured as an open collector digital output driving an LED
P0.2 configured as an active drive digital output driving an LED
P0.4 configured as a digital input receiving a TTL signal from a gated invertor

>N

P0.7 configured as a digital input receiving a 0 V or 5V signal from a switch

A Caution: Exceeding the maximum input voltage ratings or maximum
output ratings can damage the device and the computer. National
Instruments is not liable for any damage resulting from such signal
connections. Refer to the NI USB-6008 Device Specifications or
NI USB-6009 Device Specifications for more information.
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Source/Sink Information

The default configuration of the NI USB-6008/6009 digital I/O ports is open collector,
allowing 5V operation, with an onboard 4.7 kQ pull-up resistor. An external user-
provided pull-up resistor can be added to increase the source current drive up to a

8.5 mA limit per line, as shown in the following figure.[]

Figure 15. Example of Connecting an External User-Provided Resistor

External \
Pull-Up Re Rp

Resistor 4.7 kQ Onboard Resistor

E P0.0
- <

Port Pad

RI
Load

® GND

The NI USB-6009 ports can also be configured as active drive using the NI-DAQmx
AP, allowing 3.3 V operation with a source/sink current limit of £8.5 mA. For more
information about how to set the DIO configuration, refer to the KnowledgeBase
document, How Do | Configure My NI Device to be Open-Drain (Open Collector)
or Push-Pull (Active Drive)?. To access this document, go to ni.com/info and enter
the Info Code ex52sp.

1 This document uses NI-DAQmx naming conventions. Open-drain is called open
collector and push-pullis called active drive.

Determining the Value of the User-Provided Pull-Up Resistor

Complete the following steps to determine the value of the user-provided pull-up
resistor:

1. Place an ammeter in series with the load.
2. Place avariable resistor between the digital output line and the +5 V supply.
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3. Set P0.0 to high.

4. Adjust the variable resistor until the ammeter current reads as the intended
current. The intended current must be less than 8.5 mA.

5. Remove the ammeter and variable resistor from your circuit.

6. Measure the resistance of the variable resistor. The measured resistance is the
ideal value of the pull-up resistor.

7. Select a static resistor value for your pull-up resistor that is greater than or
equal to the ideal resistance.

8. Reconnect the load circuit and the pull-up resistor.

|/O Protection

To protect the NI USB-6008/6009 against overvoltage, undervoltage, and
overcurrent conditions, as well as ESD events, you should avoid these fault
conditions by using the following guidelines:

= If you configure a DIO line as an output, do not connect it to any external
signal source, ground signal, or power supply.

= If you configure a DIO line as an output, understand the current
requirements of the load connected to these signals. Do not exceed the
specified current output limits of the DAQ device.

National Instruments has several signal conditioning solutions for digital
applications requiring high current drive.

= If you configure a DIO line as an input, do not drive the line with voltages
outside of its normal operating range. The DIO lines have a smaller operating
range than the Al signals.

= Treat the DAQ device as you would treat any static-sensitive device. Always
properly ground yourself and the equipment when handling the DAQ device
or connecting to it.

Power-On States
At system startup and reset, the hardware sets all DIO lines to high-impedance

inputs. The DAQ device does not drive the signal high or low. Each line has a weak
pull-up resistor connected to it.
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Static DIO

Each of the NI USB-6008/6009 DIO lines can be used as a static DI or DO line. You can
use static DIO lines to monitor or control digital signals. All samples of static DI lines
and updates of DO lines are software-timed.

PFIO

PF10is configurable as either a digital trigger input or an event counter input.
Using PFI 0 as a Digital Trigger

When an analog input task is defined, you can configure PFI 0 as a digital trigger
input. When the digital trigger is enabled, the Al task waits for a rising or falling edge
on PFI 0 before starting the acquisition. To use Al Start Trigger (ai/StartTrigger) with
a digital source, specify PFl 0 as the source and select a rising or falling edge.

Using PFI'0 as an Event Counter

You can configure PFI 0 as a source for counting digital edges. In this mode, falling-
edge events are counted using a 32-bit counter. For more information about event
timing requirements, refer to the NI USB-6008 Device Specifications and

NI USB-6009 Device Specifications documents available on ni.com/manuals.

External Reference and Power Source

The NI USB-6008/6009 creates an external reference and supplies a power source.
All voltages are relative to ground (GND).

+2.5V External Reference

The NI USB-6008/6009 creates a high-purity reference voltage supply for the ADC
using a multi-state regulator, amplifier, and filter circuit. You can use the resulting
+2.5 V reference voltage as a signal for self-test.
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+5V Power Source

The NI USB-6008/6009 supplies a 5V, 200 mA output. You can use this source to
power external components.

,\\’ Note: When the device is in USB suspend, the output is disabled.

Where to Go from Here

This section lists where you can find example programs for the NI USB-6008/6009
and relevant documentation.

Example Programs

NI-DAQmx and NI-DAQmx Base software include example programs to help you get
started programming with the NI USB-6008/6009. Modify example code and save it
in an application, or use examples to develop a new application, or add example
code to an existing application.

NI-DAQmXx

To locate NI software examples, go to ni.com/info and enter the Info Code
dagmxexp.

To run examples without the device installed, use an NI-DAQmx simulated device.
For more information, in Measurement & Automation Explorer (MAX), select Help >

Help Topics > NI-DAQmx > MAX Help for NI-DAQmx and search for simulated
devices.

Related Documentation

Each application software package and driver includes information about writing
applications for taking measurements and controlling measurement devices. The
following references to documents assume you have NI-DAQmx 9.3 or later, and
where applicable, version 8.5 or later of the NI application software.
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NI USB-6008/6009

The NI USB-6008/6009 Quick Start included with the NI USB-6008/6009 describes
how to install NI-DAQmx software, install the device, and confirm that your device is
operating properly.

The NI USB-6008 Device Specifications and NI USB-6009 Device Specifications
contain device specifications and are available at ni.com/manuals.

NI-DAQmMx

The NI-DAQmx Readme is available from the Windows Start menu and lists which
application software, devices, and ADEs are supported by this version of NI-DAQmx.

The NI-DAQmx Help is available from the Windows Start menu and contains API
overviews, general information about measurement concepts, key NI-DAQmx
concepts, and common applications that are applicable to all programming
environments.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW PDA 8.x)

The Getting Started with NI-DAQmx Base document describes how to install the
NI-DAQmx Base software, the NI-DAQmx Base-supported DAQ device, and how to
confirm that the device is operating properly on your Windows, Linux, or Mac
machine. In Windows, select Start > All Programs > National Instruments > NI-
DAQmx Base > Documentation > Getting Started with NI-DAQmx Base.

The NI-DAQmx Base Readme lists devices supported in different versions of
NI-DAQmx Base. In Windows, select Start > All Programs > National Instruments >
NI-DAQmx Base > DAQmx Base Readme.

The NI-DAQmx Base VI Reference Help contains VI reference and general
information about measurement concepts. In LabVIEW, select Help > NI-DAQmx
Base VI Reference Help.

The NI-DAQmx Base C Function Reference Help contains C reference and general

information about measurement concepts. In Windows, select Start > All Programs
> National Instruments > NI-DAQmx Base > Documentation > C Function Reference
Help.
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g Note: All NI-DAQmx Base documentation for Linux is installed at /usr/

local/natinst/nidagmxbase/documentation.

g Note: All NI-DAQmx Base documentation for Mac OS X is installed at /
Applications/National Instruments/NI-DAQmx Base/documentation.

LabVIEW

Refer to ni.com/gettingstarted for more information about LabVIEW.

Use the LabVIEW Help, available by selecting Help > LabVIEW Help in LabVIEW, to
access information about LabVIEW programming concepts, step-by-step
instructions for using LabVIEW, and reference information about LabVIEW Vs,
functions, palettes, menus, and tools. Refer to the following locations on the

Contents tab of the LabVIEW Help for information about NI-DAQmx:

= VI and Function Reference > Measurement I/0 VIs and Functions > DAQmx
— Data Acquisition VIs and Functions—Describes the LabVIEW NI-DAQmx Vs
and functions.

= Property and Method Reference > NI-DAQmx Properties—Contains the
property reference.

= Taking Measurements—Contains the conceptual and how-to information
you need to acquire and analyze measurement data in LabVIEW, including
common measurements, measurement fundamentals, NI-DAQmx key
concepts, and device considerations.

LabWindows/CVI

The Data Acquisition section of the LabWindows/CVI Help contains Taking an
NI-DAQmx Measurement in LabWindows/CVI, which includes step-by-step
instructions for creating a measurement task using the DAQ Assistant. In
LabWindows/CVI, select Help > Contents, and then select Using LabWindows/
CVID»Data Acquisition. This book also contains information about accessing detailed
information through the NI-DAQmx Help.

© National Instruments 29



30

USB-6008/6009 Features

The NI-DAQmx Library section of the LabWindows/CVI Help contains APl overviews
and function reference for NI-DAQmx. Select Library Reference > NI-DAQmx Library
in the LabWindows/CVI Help.

Measurement Studio

If you program your NI-DAQmx-supported device in Measurement Studio using
Visual C# or Visual Basic .NET, you can interactively create channels and tasks by
launching the DAQ Assistant from MAX or from within Visual Studio. You can use
Measurement Studio to generate the configuration code based on your task or
channel. Refer to the DAQ Assistant Help for additional information about
generating code.

The NI Measurement Studio Help is fully integrated with the Microsoft Visual
Studio help. To view this help file in Visual Studio, select Measurement Studio > NI
Measurement Studio Help. For information related to developing with NI-DAQmX,
refer to the following topics within the NI Measurement Studio Help:

= For step-by-step instructions on how to create an NI-DAQmx application
using the Measurement Studio Application Wizard and the DAQ Assistant, refer
to Walkthrough: Creating a Measurement Studio NI-DAQmx Application.

= For help with NI-DAQmx methods and properties, refer to
Nationallnstruments.DAQmx Namespace and
Nationallinstruments.DAQmx.ComponentModel Namespace.

= For conceptual help with NI-DAQmX, refer to Using the Measurement
Studio NI-DAQmx .NET Library and Developing with Measurement Studio
NI-DAQmX.

= For general help with programming in Measurement Studio, refer to
Getting Started with the Measurement Studio Class Libraries.

To create an application in Visual Basic .NET or Visual C#, follow these general steps:

1. InVisual Studio, select File > New > Project to launch the New Project dialog
box.

2. Inthe Project types pane, expand the Visual Basic or Visual C# node,
depending on which language you want to create the project in, and select
Measurement Studio.
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3. Choose a project type. You add DAQ tasks as a part of this step.
ANSI C without NI Application Software

The NI-DAQmx Help contains APl overviews and general information about
measurement concepts. Select Start > All Programs > National Instruments > NI-
DAQmx > NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library functions, which
you can use with National Instruments data acquisition devices to develop
instrumentation, acquisition, and control applications. Select Start > All Programs >
National Instruments > NI-DAQmx > Text—Based Code Support >NI-DAQmx C
Reference Help.

NET Languages without NI Application Software

With the Microsoft .NET Framework, you can use NI-DAQmx to create applications
using Visual C# and Visual Basic .NET without Measurement Studio. Refer to the NI-
DAQmx Readme for specific versions supported.

Training Courses

If you need more help getting started developing an application with NI products, NI
offers training courses. To enroll in a course or obtain a detailed course outline, refer
to ni.com/training.

Technical Support on the Web

For additional support, refer to ni.com/support or ni.com/examples.

\J )
,\\ Note: You can download these documents at ni.com/manuals.

Many DAQ specifications and user guides/manuals are available as PDFs. You must
have Adobe Reader 7.0 or later (PDF 1.6 or later) installed to view the PDFs. Refer to
the Adobe Systems Incorporated website at www.adobe.com to download Adobe
Reader. Refer to the National Instruments Product Manuals Library at ni.com/
manuals for updated documentation resources.
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Worldwide Support and Services

The National Instruments website is your complete resource for technical support.
At ni.com/support, you have access to everything from troubleshooting and
application development self-help resources to email and phone assistance from NI
Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty,
and other services.

Visit ni.com/register to register your National Instruments product. Product
registration facilitates technical support and ensures that you receive important
information updates from NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the
European Communities using the manufacturer’s declaration of conformity. This
system affords the user protection for electromagnetic compatibility (EMC) and
product safety. You can obtain the DoC for your product by visiting ni.com/
certification. If your product supports calibration, you can obtain the calibration
certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504. National Instruments
also has offices located around the world. For telephone support in the United
States, create your service request at ni.com/support or dial 1 866 ASK MYNI

(275 6964). For telephone support outside the United States, visit the Worldwide
Offices section of ni.com/niglobal to access the branch office websites, which
provide up-to-date contact information, support phone numbers, email addresses,
and current events.
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