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2022/06/08 

『MITSUMI Sensor Shield Kit for Arduino』 User’s Guide: 

Instruction Manual 

OUTLINE 

This document is the instruction manual of “MITSUMI Sensor Shield Kit for Arduino”. 

“MITSUMI Sensor Shield Kit for Arduino” is a kit consisting of the Shield for Arduino, which is supposed to be used by 

connecting to Arduino, and the Sensor board equipped with various sensors. You can easily check the operation of the 

sensors by using Sample Sketch for each sensor. 

For details on each sensor, refer to the applicable data sheet. 
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1 Configuration 
“MITSUMI Sensor Shield Kit for Arduino” consists of Shield, Sensor boards, Cables (I2C, SPI), and Sample Sketch. 

Arduino itself is not included in this kit. 

 

Shield  Sensor Board Cable Sample Sketch 

 

 

 

 

 

 

2 Usage form 
This kit is used by connecting the Shield to user’s Arduino. Using Sample Sketch allows you to check operations of each 

sensor.  

 

 

Cable (I2C) 

Cable (SPI) 

Arduino UNO 
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USB Cable 

Cable (I2C) 

PC 
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3 Compatible Arduino models 
This kit is applicable to UNO, LEONARDO, DUE, and MEGA2560. 

 

Model UNO LEONARDO DUE MEGA2560 

View 

 

 

  

System  

Power 

Supply 

5.0 V 5.0 V 3.3 V 5.0 V 

 

4 Block diagram 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PC Arduino Shield  

Sensor Board 

・MMR902-I2C 

・MMR920-I2C 

・MW3827 

USB 

3.3 V 

5.0 V 

I2C 

SPI 

PCA9517DP 

74LVC2T45DC 

Sensor Board 

・MMR902-SPI 

・MMR906 

・MMR920-SPI Level Shifter 

 

Cable (I2C) 

Cable (SPI) 

 

 

I2C Connector 

SPI Connector 

Level Shifter 

5.0 V 

3.3 V 

3.3 V or 5.0 V 3.3 V 3.3 V 

3.3 V 

I2C (5.0V or 3.3V) 

SPI (5.0 V or 3.3 V) SPI (3.3 V) 

I2C (3.3 V) 

3.3 V or 5.0 V 3.3 V 

Jumper 
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5 How to use the Sensor Shield Kit 
An example connection is given below. In this example, the Sensor board of the temperature & humidity sensor 

(MW3827) and Arduino Uno are used. 

 

(1) Connect the Arduino UNO and the Shield. 

(2) Connect the system power switch jumper to 5 V pin. 

(3) Connect I2C connector (CN106) on the Sensor board of MW3827 and I2C connector (CN9) on the Shield using an I2C 

cable. 

(4) Connect the Arduino UNO and the PC using an USB cable. 

 

 

(5) Launch Arduino IDE. 

(6) Recognize the Arduino UNO on the Arduino IDE. 

Select [Tools] -> [Board: ”Arduino Uno”] -> [Arduino Uno]. 

 

   Select [Tools] -> [Port] -> [COMxx (Arduino Uno)]. 

The port number (COMxx) differs depending on the PC. 

PC 

Arduino UNO 

Shield 

Sensor Board (MW3827) 

USB Cable 

Cable (I2C) 

Power switching 

Jumper 
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(7) Open the Sample Sketch on the Arduino IDE. 

Select [File] -> [Open…] -> [Mitsumi_Sensor_Shield_Kit_MW3827_I2C_Sample_Sketch.ino]. 

 

 

(8) Verify the Sample Sketch on the Arduino IDE. 

Click [Verify] button to check whether an error occurs. 

 

 

(9) Upload the Sample Sketch to the Arduino UNO on the Arduino IDE. 

Click [Upload] button to upload the Sample Sketch. 

 

 



MITSUMI Sensor Shield Kit for Arduino_UG-001_Rev.0_English.doc 

User’s Guide Page( 6 / 13 ) 

 

 

(10)  Check the output data on the serial monitor.  

Select [Tools] -> [Serial Monitor]. 

 

The data is output to the serial monitor. 

The data is displayed in the following order: measurement interval [usec], measurement data (temperature [℃], 

relative humidity [%RH]) 

 

6 Shield  

6-1 Description 

The Shield has connectors to connect to Arduino (CN21 to CN25) in its peripheral area and those to connect to the 

Sensor board (I2C connectors: CN1 to CN9, SPI connectors: CN10 to CN11, interrupt connector: CN12) in its center. 

The size of the Shield is 55.88 x 53.34 mm. 

 

 

JP1 

CN1 CN2 CN3 

CN4 

CN5 

CN6 

CN7 

CN8 

CN9 

CN10 CN11 CN12 
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6-2 Connector 

JP1: System power switch jumper 

View Pin Name Function Note 

 

 

1 3.3 V 3.3 V supplied from the Arduino. Sensor power supply 

2 VDD System power supply 

・ During use of UNO, LEONARDO, or MEGA2560 

  -> Connected to 5.0 V pin. 

・ During use of DUE 

  -> Connected to 3.3 V pin. 

3 5.0 V 5.0 V supplied from the Arduino.  

Set the jumper according to the system power supply of the Arduino. For the system power supply, refer to the 

compatible models. If the jumper setting is wrong, the communication between the Arduino and each sensor may fail. 

 

CN1 - CN9： I2C connector 

View Pin Name Function Note 

 

1 SCL 
I2C 

Connected to CN25 SCL pin. 

2 SDA Connected to CN25 SDA pin. 

3 VDD 3.3 V (sensor power supply) － 

4 GND Ground － 

 

CN10, CN11： SPI connector 

View Pin Name Function Note 

 
1 CSB 

SPI 

SPI1: Connected to CN24 D7 pin. 

SPI2: Connected to CN24 D6 pin. 

2 SCLK Connected to CN23 SCLK pin. 

3 MOSI Connected to CN23 MOSI pin. 

4 MISO Connected to CN23 MISO pin. 

5 VDD 3.3 V (sensor power supply) － 

6 GND Ground － 

CSB pin of SPI1 connector and that of SPI2 connector are connected to different pins of the Arduino. 

 

CN12： Interrupt connector 

View Pin Name Function Note 

 

1 INT1 Interrupt or Digital input 

Connected to CN24 D3 pin. 

Connect TH on the Sensor board to use DRDY / 

DRDYB signal of the sensor.  

2 INT2 Interrupt or Digital input 

Connected to CN24 D2 pin. 

Connect TH on the Sensor board to use DRDY / 

DRDYB signal of the sensor. 
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7 Sensor Board 

7-1 Description 

For the Sensor board, the IF depends on the mounted sensor. The size of this board is 20 x 24 mm. 

 

Sensor I2C SPI Note 

MMR902A34A 

 

 

 

 

- Digital output gauge pressure sensor 

- Operating range: 0 to +300 mmHg 

- Operating range: 0 to +50℃ 

- I2C Address: 0xCA(W)/0xCB(R) 

- Data Sheet: MMR902A34A_DATASHEET_Rev.0 

MMR906XAN ― 

 

 

- Digital output gauge pressure sensor 

- Operating range: -40 to +360 mmHg 

- Operating range: 0 to +60℃ 

- Data Sheet: MMR906XAN_DATASHEET_Rev.0 

MMR920C04 

 

 

 

 

- Digital output micro-pressure sensor 

- Operating range: -40 to +40 cmH2O 

- Operating range: 0 to +50℃ 

- I2C Address: 0xCE(W)/0xCF(R) 

- Data Sheet: MMR920C04_DATASHEET_Rev.2 

MW3827ARRE 

 

 

― 

- Digital output temp. & humidity sensor 

- Operating range: 0 to 100%RH 

- Operating range: -40 to +105℃ 

- I2C Address: 0x50(W)/0x51(R) 

- Data Sheet: MW3827ARRE_DATASHEET_Rev.3 

 

7-2 Connector 

CN101, CN104, CN106： I2C connector 

View Pin Name Function Note 

 

1 SCL 
I2C 

Connected to SCL pin of the sensor. 

2 SDA Connected to SDA pin of the sensor. 

3 VDD 3.3 V (sensor power supply) － 

4 GND Ground － 

 

CN102, CN103, CN105： SPI connector 

View Pin Name Function Note 

 1 CSB 

SPI 

Connected to CSB pin of the sensor. 

2 SCLK Connected to SCLK pin of the sensor. 

3 MOSI Connected to SDI pin of the sensor. 

4 MISO Connected to SDO pin of the sensor. 

5 VDD 3.3 V (sensor power supply) － 

6 GND Ground － 

 

CN101 CN102 

CN103 

CN105 CN104 

CN106 

MMR902A34A MMR902A34A 

MMR906XAN 

MMR920C04 MMR920C04 

MW3827ARRE 
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TH： Through-hole 

View Pin Name Function Note 

 

1 
DRDYB 

(DRDY) 

Digital output 

(Data Ready signal) 

Connect to CN12 on the Shield to use DRDYB or 

DRDY signal of the sensor. 

 

8 Schematic Circuit Diagram 

8-1 Shield 
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8-2 Sensor Board 
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9 Sample Sketch 
 

Sensor board Interface File Name 

MMR902_I2C I2C Mitsumi_Sensor_Shield_Kit_MMR902_I2C_Sample_Sketch.ino 

MMR902_SPI SPI Mitsumi_Sensor_Shield_Kit_MMR902_SPI_Sample_Sketch.ino 

MMR906 SPI Mitsumi_Sensor_Shield_Kit_MMR906_SPI_Sample_Sketch.ino 

MMR920_I2C I2C Mitsumi_Sensor_Shield_Kit_MMR920_I2C_Sample_Sketch.ino 

MMR920_SPI SPI Mitsumi_Sensor_Shield_Kit_MMR920_SPI_Sample_Sketch.ino 

MW3827 I2C Mitsumi_Sensor_Shield_Kit_MW3827_I2C_Sample_Sketch.ino 

* Operation check using Arduino IDE 1.8.19. 

9-1 How to change Arduino model 

In the Sample Sketch, the code for UNO is initially set.  

Change the code given below according to the Arduino model to use. 

 

9-2 How to change SPI connector 

In the Sample Sketch, the code for CN10 SPI1 connector is initially set. 

To make the Sample Sketch to be used for CN11 SPI2 connector, change the code given below. 

 

・Arduino UNO 使用時

・Arduino DUE 使用時

・Arduino LEONARDO 使用時

・Arduino MEGA2560 使用時

・CN10 SPI1コネクタ使用時

・CN11 SPI2コネクタ使用時

・For use of Arduino UNO 

・For use of Arduino DUE 

・For use of Arduino LEONARDO 

・For use of Arduino MEGA2560 

・For use of CN10 SPI1 connector 

・For use of CN11 SPI2 connector 
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9-3 How to change the delimiter 

Data output of the Sample Sketch is initially comma-separated. 

To change the delimiter, change the character between double quotations to the desired character as shown below. 

 

 

9-4 Serial Monitor Settings 

The Sample Sketch outputs the measurement data and the measurement intervals by serial communication. 

The measurement data can be confirmed on the serial monitor. 

Setting of the serial communication is as shown below. The data can be confirmed by multi-purpose terminal software 

and others. 

 

Serial communication setting 

Item Setting Value 

Baud rate 115,200 bps 

Data length 8 bits 

Parity None 

Stop bit 1 bit 

Transfer Direction LSB First 

Delimiter LF 

 

9-5 Download of Arduino IDE 

The Arduino IDE is required to upload the Sample Sketch to the Arduino. Download the Arduino IDE from the URL 

below. 

https://www.arduino.cc/en/software 

測定間隔[usec] 測定データ

- Use of comma 

 

- Use of semicolon 

測定間隔[usec] 測定データ

Measurement interval [usec] Measurement data 

https://www.arduino.cc/en/software
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[Contact] 

Mitsumi Electric Co., Ltd.  
Semiconductor Division, Design Engineering Department 
 
1601, Sakai, Atsugi-shi, Kanagawa, 243-8533 JAPAN 
TEL：046-230-3367 
URL：http://www.mitsumi.co.jp/profile/contact.html 

 

Important notice for users of this material 

 

1. This is a reference material for Mitsumi products users. This does not grant users any rights to use 

or practice intellectual property or other rights with regard to engineering information contained in 
this material, owned by Mitsumi Electric Co., Ltd. 

2. We will assume no responsibility for any loss or any infringement of third party's rights, resulting 

from the information provided in this material. 

3. All information provided in this material is as of the issue date of the material. Please note that the 

products and specifications mentioned in this material are subject to change without prior notice. 

Please check the latest information before purchasing Mitsumi's products, and let you keep up to 

date with information posted on our website. 

4. Although the information contained in this material is carefully produced to ensure accuracy, we will 

assume no responsibility for any loss incurred by customers, arisen from any incorrect information 

found in this material. 

5. When you use the engineering information, programs, or algorithms provided in this material for 

your purpose, please fully evaluate an overall system but not individually evaluate product alone, 

engineering information, programs, and algorithms before application. We will assume no 

responsibility for your decision for application. 

6. The design and manufacturing of the product mentioned in this material are not intended for 

applications in devices or systems used under which is harmful to human's life. 

7. Our prior-permission is required for any reprint or reproduction of this material. 

8. Please contact us for further details of this material, and let us know your comments, if any. 

http://www.mitsumi.co.jp/profile/contact.html

