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About this document 

Scope and purpose 

The CY8CKIT-045S PSoC® 4500S Pioneer Kit is a scalable and reconfigurable platform structure of 
programmable embedded system controllers with an Arm® Cortex®-M0+ CPU. 
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Safety Information 

Regulatory Compliance 

The CY8CKIT-045S PSoC 4500S Pioneer Kit is intended for use as a development platform for hardware or 

software in a laboratory environment. The board is an open system design, which does not include a shielded 

enclosure. This may cause interference to other electrical or electronic devices in close proximity. In a 

domestic environment, this product may cause radio interference. In such cases, you may be required to take 

adequate preventive measures.  

This kit is not a finished product and when assembled may not be resold or otherwise marketed unless all 

required authorizations are first obtained. Contact support@cypress.com for details. 

Attaching additional wiring to this product or modifying the product operation from the factory default settings 

may affect its performance and cause interference with other apparatus in the immediate vicinity. If such 

interference is detected, suitable mitigating measures should be taken.  

  

  

 

The PSoC 4500S Pioneer Board contains electrostatic discharge (ESD) sensitive 
devices. Electrostatic charges readily accumulate on the human body and any 

equipment, and can discharge without detection. Permanent damage may 
occur on devices subjected to high-energy discharges. Proper ESD precautions 

are recommended to avoid performance degradation or loss of functionality. 

Store unused PSoC 4500S Pioneer Boards in the protective shipping package. 

  

 

End-of-Life/Product Recycling 

This kit has an end-of life of five years from the date of manufacture mentioned 

on the back of the box. Contact your nearest recycler for discarding the kit. 

 

 

  

mailto:support@cypress.com
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General Safety Instructions 

ESD Protection 

ESD can damage boards and associated components. Cypress recommends that you perform procedures only 

at an ESD workstation. If such a workstation is not available, use appropriate ESD protection by wearing an 

antistatic wrist strap attached to the chassis ground (any unpainted metal surface) on your board when 

handling parts. 

Handling Boards 

PSoC 4500S Pioneer boards are sensitive to ESD. Hold the board only by its edges. After removing the board 

from its box, place it on a grounded, static-free surface. Use a conductive foam pad if available. Do not slide 

board over any surface. 
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1 Introduction 

Thank you for your interest in the CY8CKIT-045S PSoC 4500S Pioneer Kit. The PSoC 4500S Pioneer Kit is a 
scalable and reconfigurable platform structure with a programmable embedded system controller containing 
an Arm Cortex-M0+ CPU. The PSoC 4 is a combination of a microcontroller with standard communication and 

timing peripherals, two motor control accelerator blocks specifically designed for motor control algorithm 
acceleration, a capacitive touch-sensing system (CapSense®) with best-in-class performance, programmable 
general-purpose continuous-time and switched-capacitor analog blocks, and programmable connectivity. 

The PSoC 4500S pioneer kit integrates the Cypress KitProg3 that enables on-board programming, debugging, 
and bridging functionality, such as USB-UART and USB-I2C. KitProg3 is used to program and debug the target 
PSoC 4500S device.  

1.1 Kit Contents 

The CY8CKIT-045S PSoC 4500S Pioneer Kit contains the following, as shown in Figure 1. 

• PSoC 4500S Pioneer board 

• USB Type-A to Micro-B cable  

• Six jumper wires (five inches each) 

• Quick Start Guide 
 

 

Figure 1 CY8CKIT-045S PSoC 4500S Pioneer Kit Contents 
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1.2 PSoC Creator 

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces 
revolutionary hardware and software co-design, powered by a library of pre-verified and pre-characterized 

PSoC Components. With PSoC Creator, you can: 

1. Drag and drop Components to build your hardware system design in the main design workspace 

2. Co-design your application firmware with the PSoC hardware 

3. Configure Components using configuration tools 

4. Explore the library of 100+ Components 

5. Review Component datasheets 
 

 

Figure 2 PSoC Creator Features 

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains and 

production programmers for PSoC devices. 

For more information, visit www.cypress.com/psoccreator. Visit the PSoC Creator Video Training Page for 
video tutorials on learning and using PSoC Creator. 

  

https://www.cypress.com/psoccreator
https://www.cypress.com/go/creatorstart/creatortraining
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1.2.1 PSoC Creator Code Examples 

PSoC Creator includes a large number of code examples. These examples are available from the PSoC Creator 
Start Page, as Figure 3 shows or from the menu under “File > Code Example...”. 

Code examples can speed up your design process by starting you off with a complete design, instead of a 
blank page. The code examples also show how PSoC Creator Components can be used for various 

applications. Code examples and documentation are included, as shown in Figure 4. 

In the Find Code Example dialog shown in Figure 4, you have several options: 

• Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or PSoC 5LP; project name; 
or keyword. 

• Select from the list of examples offered based on the Filter Options. 

• Review the code example’s description on the Documentation tab 

• Review the code from the Sample Code tab. You can copy the code from this window and paste to your 

project, which can help speed up code development. 

• Create a new project (and a new workspace if needed) based on the selection. This can speed up your design 
process by starting you off with a complete, basic design. You can then adapt that design to your application.  

 

 

Figure 3 Code Examples in PSoC Creator 
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Figure 4 Code Example Projects with Sample Code 

1.2.2 Kit Code Examples 

You can download the kit code examples package from the kit webpage. Refer to the Code Examples chapter 

for a list of code examples that are provided with this kit. 

1.2.3 PSoC Creator Help 

Launch PSoC Creator and navigate to the following items: 

• Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you the basics for 
developing PSoC Creator projects. 

• Simple Component Code Examples: Choose File > Code Example. These examples demonstrate how to 
configure and use PSoC Creator Components. To access examples related to a specific Component, right-
click on the Component in the schematic or in the Component Catalog. Select the Find Code Example option 

in the context menu that appears. 

• System Reference Guide: Choose Help > System Reference Guides. This guide lists and describes the 

system functions provided by PSoC Creator. 
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1.2.4 Component Datasheets 

Right-click a Component and select Open Datasheet (see Figure 5).  

 

Figure 5 Opening Component Datasheet 

1.3 Getting Started 

This guide will help you get acquainted with the CY8CKIT-045S PSoC 4500S Pioneer Kit: 

• The Kit Operation chapter describes the major features of the PSoC 4500S Pioneer Kit and functionalities 

such as programming, debugging, the USB-UART and USB-I2C bridges and the method to update the 
KitProg3 firmware. 

• The Code Examples chapter describes multiple code examples that will help you understand how to create 
your own PSoC 4500S projects. 

• The Appendix chapter describes the hardware content of the kit and the hardware operation and also 
provides kit schematics, and the bill of materials (BOM). 
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1.4 Additional Learning Resources 

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device for your 

design, and to help you to quickly and effectively integrate the device into your design. For a comprehensive list 

of resources, see KBA86521 - How to Design with PSoC 3, PSoC 4, and PSoC 5LP. The following is an 

abbreviated list for PSoC 4: 

• Overview: PSoC Portfolio and PSoC Roadmap. 

• Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device selection tool. 

• Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, PSoC 4200,  

PSoC 4100M, PSoC 4200M, PSoC 4200L, PSoC 4000S, PSoC 4100S, PSoC 4100S Plus, PSoC 4100S Plus 

256K and PSoC 4500S device families. 

• CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the PSoC 4 family 
of devices. 

• Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. Many of the 

application notes include code examples. Visit the PSoC 3/4/5 Code Examples web page for a list of all 

available PSoC Creator code examples. To access code examples from within PSoC Creator - see PSoC 
Creator Code Examples. 

• Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and registers in each 
PSoC 4 device family. 

• Development Kits: 

 CY8CKIT-041, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042, CY8CKIT-040 and CY8CKIT-045S are easy-to-

use and inexpensive development platforms. These kits include connectors for Arduino™ compatible 
shields and Digilent Pmod Peripheral Modules. 

 CY8CKIT-043, CY8CKIT-049, CY8CKIT-145, CY8CKIT-146, CY8CKIT-147 and CY8CKIT-149 are very low-
cost prototyping platforms for sampling PSoC 4 devices. 

 CY8CKIT-001 is a common development platform for all PSoC family devices. 

 The MiniProg4 device provides an interface for flash programming and debug.  

• Knowledge Base Articles (KBA): Provide design and application tips from experts on using the device. 

• PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a comprehensive list of 
video training on PSoC Creator. 

• Learning from Peers: Visit www.cypress.com/forums  to meet enthusiastic PSoC developers discussing the next-

generation embedded systems on Cypress Developer Community Forums. 

 

1.5 Technical Support 

For assistance, visit Cypress Support or contact customer support at +1 (800) 541-4736 Ext. 3 (in the USA) or 

+1 (408) 943-2600 Ext. 3 (International). 

You can also use the following support resources if you need quick assistance: 

• Self-help (Technical Documents) 

• Local Sales Office Locations 

 

https://www.cypress.com/
https://community.cypress.com/docs/DOC-9422
https://www.cypress.com/psoc
https://www.cypress.com/product-roadmaps/cypress-platform-psoc-solutions-roadmap
https://www.cypress.com/search/psg/1297
https://www.cypress.com/psoccreator
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4000-family-datasheet-programmable-system-chip-psoc
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100-family-datasheet-programmable-system-chip-psoc
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200-family-datasheet-programmable-system-chip-psoc
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100m-family-datasheet
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200m-family-datasheet
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4200l-family-datasheet
https://www.cypress.com/file/230631/
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100s-family-datasheet-programmable-system-chip-psoc?source=search&keywords=PSoC%204100S%20Plus&cat=technical_documents
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100s-plus-datasheet-programmable-system-chip-psoc?source=search&keywords=PSoC%204100S%20Plus&cat=technical_documents
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100s-plus-256kb-datasheet-programmable-system-chip-psoc?source=search&keywords=PSoC%204100S%20Plus&cat=technical_documents
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4100s-plus-256kb-datasheet-programmable-system-chip-psoc?source=search&keywords=PSoC%204100S%20Plus&cat=technical_documents
https://www.cypress.com/documentation/datasheets/psoc-4-psoc-4500s-datasheet-programmable-system-chip-psoc?source=search&keywords=PSoC%204500S%20datasheet&cat=technical_documents
https://www.cypress.com/documentation/application-notes/an85951-psoc-4-and-psoc-6-mcu-capsense-design-guide
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&amp;f%5B1%5D=resource_meta_type%3A574&amp;f%5B2%5D=field_related_products%3A1297
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Asoftware_tools&amp;f%5B1%5D=field_related_products%3A1297&amp;f%5B2%5D=software_tools_meta_type%3A579
https://www.cypress.com/documentation/code-examples/psoc-345-code-examples
https://www.cypress.com/search/all?f%5B0%5D=meta_type%3Atechnical_documents&f%5B1%5D=field_related_products%3A1297&f%5B2%5D=resource_meta_type%3A583
https://www.cypress.com/?app=search&amp;searchType=advanced&amp;keyword&amp;rtID=110&amp;id=4749&amp;applicationID=0&amp;l=0
https://www.cypress.com/CY8CKIT-041
https://www.cypress.com/CY8CKIT-046
https://www.cypress.com/CY8CKIT-044
https://www.cypress.com/cy8ckit-042
https://www.cypress.com/CY8CKIT-040
https://www.cypress.com/documentation/development-kitsboards/psoc-4500s-pioneer-kit-cy8ckit-045s
https://www.cypress.com/CY8CKIT-043
https://www.cypress.com/documentation/development-kitsboards/psoc-4-cy8ckit-049-4xxx-prototyping-kits
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-145-40xx-psoc-4000s-capsense-prototyping-kit
https://www.cypress.com/documentation/development-kitsboards/psoc-4-cy8ckit-146-4xxx-prototyping-kits
https://www.cypress.com/documentation/development-kitsboards/cy8ckit-147-psoc-4100ps-prototyping-kit
https://www.cypress.com/cy8ckit-149
https://www.cypress.com/go/CY8CKIT-001
https://www.cypress.com/file/452836/download
https://community.cypress.com/community/topics/knowledge-base-articles
https://www.cypress.com/go/creatorstart/creatortraining
https://www.cypress.com/forums
https://www.cypress.com/support
https://www.cypress.com/search/all?f%5b0%5d=meta_type%3Atechnical_documents
https://www.cypress.com/about-us/sales-offices
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1.6 Document Conventions 

Table 1 Document Conventions for Guides 

Convention Usage 

Courier New Displays file locations, user entered text, and source code: 

C:\...cd\icc\ 

Italics Displays file names and reference documentation: 

Read about the sourcefile.hex file in the PSoC Creator User Guide. 

[Bracketed, Bold] Displays keyboard commands in procedures: 

[Enter] or [Ctrl] [C] 

File > Open Represents menu paths: File > Open > New Project 

Bold Displays commands, menu paths, and icon names in procedures: Click 

the File icon and then click Open. 

Times New Roman Displays an equation: 

2 + 2 = 4 

Text in gray boxes Describes Cautions or unique functionality of the product. 
 

 

1.7 Acronyms 

Table 2 Acronyms Used in this Document 

Acronym Description 

ADC Analog-to-Digital Converter 

BOM Bill of Materials 

CE Code Example 

CMOD Modulator Capacitor 

DAC Digital to Analog Converter 

ESD Electrostatic Discharge 

GPIO General Purpose Input/Output 

I2C Inter-Integrated Circuit 

IDE Integrated Design Environment 

KBA Knowledge Based Article 

NTC Negative Thermal Coefficient 

LDO Low Drop Out 

LED Light-Emitting Diode 

PSoC Programmable System-on-Chip 

SAR Successive Approximation Register 

SWD Serial Wire Debug 

UART Universal Asynchronous Receiver Transmitter 

USB Universal Serial Bus 
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2 Kit Operation 

This chapter introduces you to the features of the CY8CKIT-045S PSoC 4500S Pioneer Kit. This primarily 

includes the programming/debugging functionality, KitProg3 USB-UART and USB-I2C bridges, and the method 

to update the KitProg3 firmware. 

2.1 Theory of Operation 

Figure 6 shows the block diagram for the CY8CKIT-045S PSoC 4500S Pioneer Kit.  

 

Figure 6 Block Diagram of CY8CKIT-045S PSoC 4500S Pioneer Kit 

The PSoC 4500S Pioneer Kit is simplistic in design and focuses on providing you with complete access to develop 

applications using the PSoC 4500S device. This kit supports the following features: 

• PSoC 4500S Extended I/O Headers (J10, J11): The PSoC 4500S Pioneer board brings most GPIOs of the 
target PSoC 4500S device to the two expansion headers enabling you to have maximum access to the 

capabilities of the PSoC 4500S device. 

• Arduino UNO R3-compatible Headers (J1, J2, J3, J4): J1 header powers third-party Arduino Shields. This 
header also has a provision to power the PSoC 4500S Pioneer Kit through the VIN input on the header. J2, J3 

and J4 headers are compatible with PSoC 4500S Pioneer Kit and operates flawlessly with third-party 
Arduino Shields. 

• User RGB LED (D8): This on-board RGB LED can be used to display outputs from the PSoC 4500S device. This 
includes modulating the brightness of the LED to notify different states of the device. 

• User Button (SW2): Provides an input to PSoC 4500S device. 
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Note: The button connects the PSoC 4500S pin (P1[2]) to ground when pressed. Therefore, you need to 

configure the PSoC 4500S pin as ‘resistive pull-up’ for detecting the switch press. Also note that when 

configuring the pin as ‘resistive pull-up’, the pin cannot be connected to any other internal peripheral 

through a hardware connection. 

• Reset Button (SW1): Resets the PSoC 4500S device when pressed. 

• Power LED (D1): Indicates power is being supplied to the board. 

• Five Segment CapSense Slider (CSS1): This slider can be used to measure finger position to be used as a 

sliding scale control input. 

• CapSense Button (CSB1): This button can be used as a general purpose on/off input as an alternative to a 

mechanical button. 

• ECO Crystal (Y1): A 24-MHz crystal is loaded onboard for precision clock applications. 

• VIN Header (J8): Connects an external DC power supply input to the onboard regulators. The voltage input 
from the external supply should be between 7 V and 12 V. 

• Thermistor (TH1): The thermistor is used to measure ambient temperature. 

• Ambient Light Sensor (Q1): A general purpose ambient light sensor. 

• Pmod (J9):  This header can be used to connect Digilent Pmod 1 × 6 pin SPI modules. 

• PSoC 4500S Device (U1): Target device (CY8C4548AZI-S485) on the board. 

• 5-pin and 10-pin SWD Program/Debug Headers (J7 and J12): External programming headers that can be 

used to program/debug PSoC 4500S using MiniProg4. Typically, this connection is not required because the 

kit contains an integrated KitProg3. 

• Power Selection Jumper (J6): Selects the PSoC 4500S supply voltage (P4_VDD) between 5 V and 3.3 V. 

• KitProg3 USB Connector (J5): Use the USB cable provided along with the PSoC 4500S Pioneer Board to 

connect the board to the PC to use the KitProg3 onboard programmer and debugger and to provide power 

to the board. 

• KitProg3 (U2): An on-board programmer/debugger that uses a PSoC 5LP (CY8C5868LTI-LP039), which 
enables you to program and debug the target PSoC 4500S device. It can also act as a USB-UART and UART-

I2C bridge. 

When used as a standalone module, it can be used to program devices of the PSoC 3, PSoC 4, or PSoC 5LP 

families through the SWD interface. For more details on the KitProg3 functionality, see the KitProg3 User 

Guide. 

• KitProg3 Mode Selection Button (SW3): This button function is reserved for future use. Note that the 

button connects the PSoC 5LP pin to ground when pressed.  

• KitProg3 Status LED (D5): Shows the programming/mode status of KitProg3. 

Table 3 KitProg3 Mode Switching 

KitProg3 Programming Modes * Status LED (D5) 

CMSIS-DAP/Bulk mode (default) ON 

CMSIS-DAP/HID mode RAMPING at 1Hz 

*Note: Switching between the programming modes can be done through Firmware-loader tool. Refer to the 

chapter 2.2.3 Mode Switching section of the KitProg3 User Guide for details. 

  

https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
https://github.com/cypresssemiconductorco/Firmware-loader
https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
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2.2 Programming and Debugging the PSoC 4500S Target Device 

The target PSoC 4500S device can be programmed and debugged using KitProg3. Before programming the 

device, ensure that PSoC Creator and PSoC Programmer software are installed on the PC.  

2.2.1 Programming Using PSoC Creator 
 

1. Connect the PSoc 4500S pioneer board to the computer through the connector (J5), as shown in  

Figure 7. If you are plugging in the PSoC 4500S Pioneer Kit to your PC for the first time, the kit 

drivers will get installed automatically. KitProg3 can operate either in CMSIS-DAP HID mode or CMSIS-

DAP Bulk mode (default). Programming is faster with the CMSIS-DAP Bulk mode. The status LED (Yellow) 

is always ON in CMSIS-DAP Bulk mode and is ramping (increasing and decreasing brightness) at 1 Hz rate 

in CMSIS-DAP HID mode. see the KitProg3 User Guide for details on the KitProg3 status and 

troubleshooting instructions.  

 

Figure 7 Connecting the CY8CKIT-045S PSoC 4500S Pioneer Kit to a Computer 

2. Open the desired project in PSoC Creator. From inside PSoC Creator, go to File > Open > 

Project/Workspace. This provides the option to browse and open a previously saved project. If you want 

to open one of the code examples provided with the kit, follow the instructions in the Code Examples 

chapter.  

3. Select the option Build > Build <Project_Name> or press [Shift] [F6] to build the project as shown in 

Figure 8.  

 

Figure 8 Build a Code Example 

https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
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4. If there are no errors during build, program the firmware into the kit by choosing Debug > Program or 

press [Ctrl] [F5], as shown in Figure 9. This programs the target PSoC 4500S device on the PSoC 4500S 

Pioneer Kit, and the kit is ready to use. 

 

Figure 9 Programming Device from PSoC Creator 

2.2.2 Debugging Using PSoC Creator 

For debugging the project using PSoC Creator, follow steps 1–3 from Programming Using PSoC Creator and 

then do the following:  

1. Click on the Debug button   , press F5 or select Debug > Debug. 

2. Once the PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your application. 

For more details on using the debug features, refer to the PSoC Creator Help. Select Help > PSoC Creator 
Help Topics in the PSoC Creator menu. In the PSoC Creator Help window, locate Using the Debugger 
section in the Contents tab.  

2.2.3 Programming Using PSoC Programmer 

PSoC Programmer (3.29.0 or later) can be used to program existing .hex files into the PSoC 4500S Pioneer 

Kit. To do this, follow these steps. 

1. Connect the kit to your PC and open PSoC Programmer from Start > All Programs > Cypress > PSoC 
Programmer <version>> PSoC Programmer<version>. 

2. Click the File Load button at the top left corner of the window. Browse to the desired .hex file and click 

Open. For PSoC 4500S devices, the .hex file is located at:  < Project Directory>\< Project 

Name.cydsn>\CortexM0p\< Compiler Name and Version>\< <Debug> or <Release>\< Project Name.hex>. 

3. Click on the KitProg3/<serial number> in the Port Selection list to connect the kit to your computer. 

4. Click on the Program button to start programming the kit with the selected file. 

Note: If the .hex file does not match the selected device, PSoC Programmer will display a device 
mismatch error and terminate programming. Ensure that you have selected the correct .hex file. 

5. When programming is completed successfully, indicated by a PASS message on the status bar, the kit is 
ready for use. Close PSoC Programmer. 
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2.3 USB-UART Bridge 

The KitProg3 on the PSoC 4500S Pioneer Kit can act as a USB-UART bridge. The UART lines between the KitProg3 

and the PSoC 4500S are hard-wired on the board, with KitProg3 UART_RX (P12[7]) and UART_TX (P12[6]) 

connected to P2[5] (TX) and P2[4] (RX) of PSoC 4500S (target) respectively. For more details on the KitProg3 

USB-UART functionality, see the  KitProg3 User Guide.  

 

Figure 10 UART Connection between KitProg3 and PSoC 4500S 

2.4 USB-I2C Bridge 

The KitProg3 can function as a USB-I2C bridge and communicate with the software utility, for example, to 

communicate with CapSense Tuner. The I2C lines on the PSoC 4500S (target) device are P1[1] (SDA) and P1[0] 

(SCL), which are hard-wired on the board to the I2C lines of KitProg3. The USB-I2C bridge supports I2C speeds of 

50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg3 USB-I2C functionality, see the KitProg3 

User Guide.  

 

Figure 11 I2C Connection between KitProg3 and PSoC 4500S 

  

https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
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2.5 Updating the KitProg3 Firmware 

The KitProg3 firmware normally does not require any update. You can use the PSoC Programmer software to 

update the KitProg3 firmware if necessary. Open the PSoC Programmer, then click Utilities > Upgrade Firmware to 

update KitProg3 firmware.  

 

Figure 12 Upgrade KitProg3 Firmware 

 

https://www.cypress.com/products/psoc-programming-solutions
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3 Code Examples 

This chapter explains the code examples provided along with the PSoC 4500S Pioneer Kit. You can access the 
code examples either from the code examples ZIP file available on the kit webpage or from the Find Code 
Example wizard in the PSoC Creator. Each method is described separately below. 

3.1 Using the Kit Code Examples from the kit website 

To access these code examples, download the CY8CKIT-045 PSoC 4500S Pioneer kit package from the kit 

webpage. After extracting the downloaded zip file, select File > Open > Project/Workspace in PSoC Creator and 

then select the code example path to open it. See Figure 13. 

1. Launch PSoC Creator from the Windows Start menu (Start > All Programs > Cypress > PSoC Creator 

<version> > PSoC Creator <version>). 

2. Click File > Open > Project/Workspace, and then select the code example path. See Figure 13. 

3. Click on the desired code example and open it. For the remaining steps, CE230205.cywrk is shown as 

reference.  

 

Figure 13 Open Code Example from PSoC Creator 

4. Build the code example by choosing Build > Build <Project Name>, as shown in Figure 14. A .hex file is 

generated after a successful build process.  

 

Figure 14 Build Code Example from PSoC Creator 

  

https://www.cypress.com/CY8CKIT-045S
https://www.cypress.com/CY8CKIT-045S
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5. Connect the PSoC 4500S Pioneer kit to the PC using the USB cable conncted to KitProg3 USB connector, 

J5 as described in Programming Using PSoC Creator to program the kit with this code example. If this 

is the first time the kit is connected to the PC, you should wait for driver installation to complete before 

proceeding with the next step. 

6. Choose Debug > Program in PSoC Creator as shown in Figure 15.  

 

Figure 15 Programming using PSoC Creator 

7. If the device is already acquired, programming will complete automatically and the result will appear in 

the PSoC Creator status bar at the bottom left side of the screen. If the device is yet to be acquired, the 

Select Debug Target window will appear. Select KitProg3/<serial number> and click the Port Acquire 

button, as shown in Figure 16.  

 

Figure 16 Port Acquire 
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8. After the device is acquired, it is shown in a tree structure below the KitProg3/<serial number>. Click the 

OK / Connect button to exit the window and start programming, as shown in Figure 17.  

 

Figure 17 Connect Device from PSoC Creator and Program 

9. From the workspace explorer in PSoC Creator, open CE230205.pdf as shown in Figure 18 to learn more 

about how to verify the functionality of the code example.  

 

Figure 18 CE230205.pdf 

 

 



  

User Guide 22 of 43 002-31180 Rev. *A  

  <2020-12> 

 

CY8CKIT-045S PSoC 4500S Pioneer Kit Guide 
  

Code Examples 

  

3.2 Using Built-in PSoC Creator Code Examples with the Kit 

The built-in PSoC Creator code examples can be used by following the steps below. 

1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator<version> > PSoC Creator 

<version>. 

2. On the Start Page, click Find Code Example... under Start, or use the menu item “File > Code Example...” 

as shown in Figure 19.  

 

Figure 19 PSoC Creator Find Code Example 

3. In the Find Code Example window, set the Device family to PSoC 4500S as shown in Figure 20.  

 

Figure 20 Selecting PSoC 4500S Device Family in Find Code Example Window 

You can use any project that appears in the list with the kit. As an example, we will select the 

CE230205_CapSense_Slider_and_Button project and see how to use it with the CY8CKIT-045S kit board. 
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4. Select the CE230205_CapSense_Slider_and_Button project and click the Create Project button as 

shown in Figure 21. Save the workspace to a desired location.  

 

Figure 21 CE230205_CapSense_Slider_and_Button Code Example 

5. Open CE230205.pdf from the Workspace Explorer to learn more about the code example and its 

configuration. See Figure 22.  

 

Figure 22 Project Datasheet: CE230205_CapSense_Slider_and_Button 
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4 Appendix 

4.1 Board Details  

The PSoC 4500S Pioneer kit consists of the following blocks: 

1. KitProg3 USB connector (J5) 

2.   Arduino select jumpers (J14, J15) 

3.   KitProg3 (PSoC 5LP) device (CY8C5868LTI-LP039) (U2) 

4.   One push button, SW3 (KitProg3 Mode) 

5.   One yellow LED, D5 (KitProg3 Status) 

6.   5-pin PSoC 4500S SWD Program/Debug header (J7) (footprint only) 

7.   One external power supply connector (J8) (footprint only) 

8.   10-pin PSoC 4500S SWD Program/Debug header (J12) 

9.   Pmod header (J9) (footprint only) 

10. One push button, SW1 (Reset) 

11. Arduino UNO R3-compatible power header (J1) 

12. One RGB LED, D8 (User) 

13. One push button, SW2 (User) 

14. Arduino UNO R3-compatible I/O headers (J2, J3, J4) 

15. One thermistor (TH1) 

16. CapSense button and slider (CSB1 and CSS1) 

17. PSoC 4500S device (CY8C4548AZI-S485) (U1) 

18. One ambient light sensor (Q1) 

19. PSoC 4500S Extended I/O headers (J10, J11) (footprint only) 

20. PSoC 4500S power selection/current measurement jumper (J6) 

21. One yellow LED, D1 (Power) 

 

Figure 23 Cypress Normal Style PSoC 4500S Pioneer Board Details 
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Figure 24 Cypress Normal Style PSoC 4500S Pioneer Board Pinout Details 

4.2 Hardware Details 

4.2.1 PSoC 4500S Pioneer Board 

The target board uses the PSoC 4500S device. PSoC 4500S is a scalable and reconfigurable platform 
architecture for a family of programmable embedded system controllers with an Arm Cortex-M0+ CPU. It 
combines programmable and reconfigurable digital blocks with flexible automatic routing. The PSoC 4500S 

device family, based on this platform architecture, is a combination of a microcontroller with digital 

programmable logic, programmable interconnect, and standard communication and timing peripherals. PSoC 

4500S is the first PSoC 4 device with two SAR blocks. PSoC 4500S products are fully compatible with members  of the  
PSoC 4 pl atform  for new applications  and design needs.  The digi tal  subsystems allow flexibility and 

in-field tuning of the design. For more information, see the PSoC 4500S Pioneer Kit web page and the PSoC 
4500S family datasheet. 

 

https://www.cypress.com/CY8CKIT-045S
https://www.cypress.com/file/495441
https://www.cypress.com/file/495441
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Figure 25 Schematic of PSoC 4500S (Target) 
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4.2.2 KitProg3 

A PSoC 5LP-based KitProg3 is used to program and debug the target PSoC 4500S device. The PSoC 5LP 

device connects to the USB port of the PC through the KitProg3 USB connector and to the SWD interface 

of the target PSoC 4500S device.  

 

 

 

Figure 26 Schematic of PSoC 5LP (KitProg3) 
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4.2.3 Serial Interconnection between PSoC 5LP and PSoC 4500S 

In addition of use as an onboard programmer, the PSoC 5LP device functions as an interface for the USB-UART 

and USB-I2C bridges, as shown in Figure 27. The USB-Serial pins of the PSoC 5LP device are hard-wired to the 

I2C/UART pins of the PSoC 4500S. These pins are also available on the Arduino-compatible I/O headers; 

therefore, the PSoC 5LP device can be used to control Arduino shields with an I2C/UART interface.  

 
 

 
 

 

Figure 27 Schematics of Programming and Serial Interface Connections 

4.2.4 Power Supply System 

The power supply system on this board is versatile, allowing the input supply to come from the following 

sources: 

• 5 V from the onboard KitProg3 USB connector (J5) 

• 7 V to 12 V power from an Arduino shield or from external power supply through VIN header J1.1 or J8 

The power supply system is designed to support 3.3 V or 5 V operation of PSoC 4500S. On the other hand, 5 V is 

provided for the KitProg3 operation.  

The supply rails VIN (7V to 12 V from header J8 or J1.1) and KP_VBUS (5V KitProg USB connector J5) are 

combined into VCC_IN through ORing diodes as Figure 28 shows. An LDO regulator generates the 3.3 V output 

from VCC_IN for PSoC 4500S. The VIN Header (J8) is not populated on the board by default. 
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It is important to understand that the 5 V will not be generated when the kit is powered from the VIN header 

because there is no separate 5 V regulator. 5 V will be present only when the kit is powered through the 

KitProg3 USB connector (J5).  

 
 

 
 

 
 

 
 

Figure 28 Power Supply System 
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4.2.5 PSoC 4500S Power Selection/Current Measurement Jumper 

The operating voltage P4_VDD (3.3V or 5V) for PSoC 4500S can be selected using the jumper J6. It can also be 

used to measure the current consumption of PSoC 4500S using an ammeter without any additional rework 

done. The default position of J6 is 3.3V. 

 

Figure 29 Power Selection/Current Measurement Jumper 

The following method is supported for measuring the current consumption of the PSoC 4500S device. 

• Remove the jumper J6 and connect an ammeter between the terminals 2 and 3, for 3.3V operation or 
connect between the terminals 1 and 2, for 5V operation.  

4.2.6 Expansion Headers 

4.2.6.1 Arduino-compatible Headers (J1, J2, J3, J4) & PSoC 4500S Extended I/O 

Headers (J10, J11) 

The board has four Arduino-compatible headers: J1, J2, J3 and J4. You can connect 3.3 V or 5 V Arduino-

compatible shields to develop applications based on the shield’s hardware. The kit can also be used for motor 

control applications using CY8CKIT-037 by interfacing with these headers. See Board Details for details on 

PSoC 4500S pin mapping to these headers. 

There are two headers J10 and J11 which provide connectivity to PSoC 4500S GPIOs that are not connected to 

the Arduino-compatible headers. The majority of these pins are multiplexed with onboard peripherals and are 

not connected to PSoC 4500S by default. For detailed information on how to rework the kit to access these 

pins, see PSoC 4500S Pioneer Board Rework.  
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Figure 30 Arduino & Extended Headers 

4.2.6.2 Pmod Header (J9) 

The PSoC 4500S Pioneer board supports one Pmod header (J9). The header pins are hard-wired to PSoC 4500S 

GPIOs as shown in the Figure 31. Note that the Pmod header is not populated by default on the board.  

 
 

 

Figure 31 Pmod Header 
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4.2.7 User and Passive Inputs 

4.2.7.1 CapSense Circuit 

One CapSense 5-segment slider and one CapSense button are connected to PSoC 4500S as Figure 32 shows.  

The CapSense slider supports only self-cap (CSD) sensing, while the button supports both self-cap (CSD) and 

mutual cap (CSX) sensing. Four external capacitors - CMOD and CSH for CSD, CINTA and CINTB for CSX are 

present on the PSoC 4500S Pioneer board. Note that the CapSense shield is not connected to PSoC 4500S by 

default. Moreover, the CapSense GPIOs can also be used as external GPIOs which are routed to extended 

headers. For more detailed information on how to rework the kit to access these pins, see PSoC 4500S Pioneer 

Board Rework. For details on using CapSense including design guidelines, see the Getting Started with 

CapSense Design Guide.  

 

 
 

 

Figure 32 CapSense Circuit  

https://www.cypress.com/file/46081/
https://www.cypress.com/file/46081/
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Table 4 CapSense pin assignment 

CapSense element PSoC 4500S GPIO CapSense element PSoC 4500S GPIO 

CS_TX P0[4] CS_SLD_4 P7[1] 

CS_BTN_0 P4[4] CS_CAP_SH* P0[5] 

CS_SLD_0 P4[5] CMOD P4[1] 

CS_SLD_1 P4[6] CINTA P4[2] 

CS_SLD_2 P4[7] CINTB P4[3] 

CS_SLD_3 P7[0] CSH P4[0] 

* Note: Not connected by default. 

4.2.7.2 User Button 

The target PSoC 4500S Pioneer board contains one user button connected to the P1[2] pin on the PSoC 4500S 

device. This button can be used for general user inputs or to control different states in an application.  

 
 

 

Figure 33 User Button on the Board 

4.2.7.3 Reset Switch 

When this button is pressed, the XRES_L line of the PSoC 4500S is pulled to ground, which, in turn, resets the 

target device.  
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Figure 34 Reset switch 

4.2.7.4 Mode Switch 

The PSoC 4500S Pioneer board contains a push button (SW3) connected to P1[2] of PSoC 5LP. This button 

function is reserved for future. Refer to the KitProg3 User Guide for more details.  

 
 

 

Figure 35 Mode switch 

4.2.7.5 LEDs 

The PSoC 4500S Pioneer kit contains three LEDs: 

The yellow Power LED (D1): Indicates that the board is powered from the onboard KitProg3 USB Micro-B 

connector or VIN header. 

The yellow Status LED (D5): Indicates the KitProg3 status (the LED is connected to P1[4] of the KitProg3  
PSoC 5LP device). See Table 3 for a summary of the status LED states. For more details on the KitProg3 status 

LED, see the KitProg3 User Guide. 

The RGB LED (D8): This is the user LED, connected to P1[6], P0[0] and P0[1] of the target PSoC 4500S device. 

The LEDs are active low so the pins must be driven low to turn on the LEDs.      

https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
https://www.cypress.com/documentation/development-kitsboards/kitprog-user-guide?source=search&keywords=KitProg3%20User%20Guide&cat=software_tools
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Figure 36 Power LED 

 

 
 

 

Figure 37 KitProg3 Status LED 
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Figure 38 User LED  

4.2.7.6 Thermistor 

The kit contains one NTC thermistor for temperature sensing. It is capable of sensing in both single-ended and 

differential mode. The single-ended mode is supported by default. P3[4], P3[5], P3[6] and P3[7] are the GPIOs 

which are used for the temperature sensing but only P3[6] is connected by default for single ended sensing. For 
differential sensing, see the PSoC 4500S Pioneer Board Rework.  

 
 

 

Figure 39 Thermistor 
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4.2.7.7 Ambient Light Sensor 

The kit contains one ambient light senor (ALS) which uses the GPIO: P2[7] of PSoC 4500S for ambient light 
sensing.  

 
 

 

Figure 40 Ambient Light Sensor 

4.2.7.8 10-pin and 5-pin SWD Program/Debug Headers 

PSoC 4500S can be programmed alternatively through the 10-pin and 5-pin SWD headers (J12 and J7) using a 
MiniProg4 programmer or any third-party programmer. Note that the 5-pin SWD header (J7) is not loaded by 

default. 

 

 

 

Figure 41 10-pin and 5-pin SWD Program/Debug Headers 
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4.2.8 Crystal Oscillator 

The Pioneer board includes a 24-MHz ECO for PSoC 4500S device.  

 

Figure 42 Schematic of onboard ECO 

4.3 PSoC 4500S Pioneer Board Rework 

4.3.1 Bypassing Reverse Voltage Protection Circuits 

The Reverse Voltage Protection circuit protects the 3.3V LDO (U3) and the onboard PSoC 4500S from getting 
damaged due to overvoltage. This protection circuit cuts-off any voltage greater than the rated max voltages by 

~35mV.  

 

Figure 43 Schematic of Reverse Voltage Protection circuit 

Note that the protection circuits have a voltage drop of maximum ~140 mV. To avoid the voltage drop, bypass 

the protection circuits by populating the bypass zero-ohm resistors R2 and R9.  

Note that this change will compromise the protection circuits when an overvoltage occurs at the respective 
supply connectors and may permanently damage the devices if the voltage exceeds the absolute maximum 

limit of devices. 
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4.3.2 Rework on CapSense and Additional Multiplexed Pins 

CapSense I/Os and the Expansions header GPIOs are multiplexed using the resistor Y-networks as shown in 

Figure 44. These give the provision to use the CapSense I/Os as external GPIOs by connecting to the expansion 

headers J10 and J11.  

The resistor pairs used for multiplexing are: R5, R47; R16, R57; R13, R55; R11, R54; R10, R53; R8, R49; R7, 

R48; R56, R14; R76, R77. To use the alternative GPIOs, you need to remove the mounted resistor and populate 

the other resistor of the mentioned pairs. For example, remove R5 and populate R47 to use the P0.4 as 

extended GPIO at the header J11.1. 

There is also provision of using the pins as extended GPIOs used for the CapSense capacitors CMOD, CINTA and 

CINTB. By populating the resistors: R58, R59, R60 and R61, the respective pins P4.3, P4.2, P4.1 and P4.0 can 
be connected to the extended header J10.  

  

Figure 44 Multiplexed Pins 
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4.3.3 Rework for Thermistor Block 

The onboard thermistor is capable of sensing the temperature both in single-ended and differential mode. The 
single-ended mode is supported by default. To change the sensing mode to differential, populate R74, R78, 

and R65.  

 

Figure 45 Thermistor 

4.3.4 Rework on J14 and J15 for Motor Control Application 

The kit does not support SPI communication for Arduino UNO R3 shields and motor control support using 

CY8CKIT-037 at the same time. The kit does support SPI communication by default. To use the kit for motor 

control application using CY8CKIT-037, change the jumper positions of J14 and J15 to 2-3 position (Jumper 

setting 2). Default position of J14 and J15 is 1-2 (Jumper setting 1). 

  

Figure 46 Arduino Select Headers 
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When using with CY8CKIT-037, by default, both the motor phase current signals gets connected to port 3 (P3_0 
and P3_7) which is the SARMUX port of SAR ADC 1. To make use of both the SAR ADCs of PSoC 4500S, with each 

SAR ADC measuring one of the phase currents, mount R77 and remove R76. This connects one of the phase 
current signal to P2_3 and other to P3_7. 

4.4 PSoC 4500S Pioneer Kit Schematics 

See the schematic file on the kit web page: 

www.cypress.com/CY8CKIT-045S 

4.5 Bill of Materials 

See the BOM file on the kit web page: 

www.cypress.com/CY8CKIT-045S 

 

 

 

https://www.cypress.com/CY8CKIT-045S
https://www.cypress.com/CY8CKIT-045S
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