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CY4500-EPR EZ-PD™ Protocol Analyzer Utility 

user guide 

About this document 

Scope and purpose 

This user guide describes the features of EZ-PD™ Protocol Analyzer Utility. The document also provides 

instructions on the installation and usage of EZ-PD™ Protocol Analyzer Utility. 

Intended audience 

This document is intended for anyone using the CY4500-EPR kit.

http://www.infineon.com/
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The board at a glance 

1 The board at a glance 

The CY4500-EPR EZ-PD™ Protocol Analyzer supports USB-PD protocol analysis and USB Type-C specifications. 

It supports the following power ranges: 

• Standard power range (SPR) – 21 V at 5 A 

• Extended power range (EPR) – 48 V at 5 A 

It performs nonintrusive probing and captures accurate protocol messages on the CC line. This analyzer 

consists of Infineon’s programmable MCU (PSOC™ 5LP), which monitors data on the CC lines and sends this 

data to the host application over a USB interface. The Type-C plug and Type-C receptacle on this analyzer 

provide a pass-through for the Power Delivery (PD) packets transmitted between each Type-C PD connection. 

The MCU processor taps these PD packets without disturbing the system and transfers them over the USB 

interface to a PC running the host application.  

Note: EZ-PD™ Analyzer Utility supports decoding of PD packets per the USB PD Specification Revision 3.2, V1.0. 

1.1 Scope of supply 

The CY4500-EPR EZ-PD™ Protocol Analyzer consists of the following contents: 

• CY4500-EPR EZ-PD™ Protocol Analyzer board enclosed in a transparent casing. 

• USB 2.0 Type-A to Micro-B Cable 

• Six jumper wires  

• Quick Start Guide 

1.2 Block diagram 

The following image shows the block diagram of the CY4500-EPR EZ-PD™ Protocol Analyzer. The  

PSOC™ 5LP controller decodes the USB-PD messages on the CC lines in a nonintrusive manner, and to measure 

the voltage and current flowing through the USB interface. These messages are displayed on the 

EZ PD™ Analyzer Utility application. 

 

Figure 1 Block diagram 

https://www.usb.org/document-library/usb-power-delivery
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1.3 Main features 

• Supports power measurement in the EPR range (48 V at 5 A) 

• Captures protocol message on CC lines 

• Capable of decoding both the SPR/EPR messages 

1.4 Board parameters and technical data 

The board comprises a Type-C plug at one end and a Type-C receptacle at the other, which connects to the 

Type-C device or system under test. The board is powered over the USB micro-B port, which provides 5 V, 

500 mA. The board also consists of one LED to indicate the power status. Besides this, it has connector headers 

brought out for the GPIOs, CC lines, VBUS, and SBU lines from the USB-PD system.  

Figure 2, Figure 3, and Figure 4 show the front view, back view, and side view respectively of the CY4500-EPR 

EZ-PD™ Protocol Analyzer board. Table 1 contains their detailed description. Headers J1 and J8 are located on 

the back side of the board. Ensure that the exposed header pins of J1 and J8 do not get shorted. Shorting these 

exposed pins may result in a functional failure or unexpected behavior of the CY4500-EPR EZ-PD™ Protocol 

Analyzer. 

 

Figure 2 CY4500-EPR EZ-PD™ Protocol Analyzer board (front view) 

 

Figure 3 CY4500-EPR EZ-PD™ Protocol Analyzer board (rear view) 
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Figure 4 CY4500-EPR EZ-PD™ Protocol Analyzer board (side view) 

The following table contains the details about the pinouts and the connector details of the connectors present 

on CY4500-EPR board. Connectors J1 and J8 can be used to probe the Type-C signals and the message trigger 

signals using the provided jumper wires. 

Table 1  Connector details 

Connector Description 

J1 USB Type-C signal header 

Pin 1: CC1 

Pin 2: CC2 

Pin 3: SBU1 

Pin 4: SBU2 

Pin 5: VBUS 

Pin 6: GND 

J2 Type-C receptacle 

J3 Type-C plug 

J7 USB Micro-B connector 

J8 Message trigger header 

Pin 1: SOM 

Pin 2: EOM 

Pin 3: MTR 

 

Note: 1. Header J8 pins are used for triggering. The trigger functionality requires EZ-PD™ Protocol Analyzer 

Utility support. Contact Infineon Sales for more details.  

2. The EZ-PD™ Protocol Analyzer board is protected using a transparent casing. Do not remove the 

board from the casing while using the Analyzer. 

3. If multiple CY4500-EPR devices are connected to the laptop, press the tick icon on the EZ-PD™ Protocol 

Analyzer Utility. This makes the LED on the connected device blink in red color. 
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2 Installation 

2.1 Windows installation 

To install the EZ-PD™ Protocol Analyzer software in Windows, do the following: 

1. Download the latest EZ-PD™ Protocol Analyzer Utility software setup file from EZ-PD™ Protocol Analyzer 

Utility. This package contains the software for running the analyzer and the relevant documentation 

(user guides, Quick Start Guides, and release notes). Double-click on the executable to start the installation. 

Read the license agreement and click the “I accept the agreement” radio button when the screen shown in 

Figure 5 appears. 

 

 

Figure 5 Install the software – Accept the license agreement 

  

https://softwaretools.infineon.com/tools/com.ifx.tb.tool.ezpdprotocolanalyzer
https://softwaretools.infineon.com/tools/com.ifx.tb.tool.ezpdprotocolanalyzer
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2. Select the required installation location and click Next to start the installation. The default location is 

C:\Infineon\Tools\EZ-PD Protocol Analyzer Utility.  

 

 

Figure 6 Install the software – Select the installation folder 
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3. Check the “Create a desktop” shortcut if you want to create a shortcut on the desktop and click Next. 

 

 

Figure 7 Install the software – Create a desktop shortcut 
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4. Figure 8 shows the installation progress. 

 

 

Figure 8 Install the software – Installation in progress 
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5. Check the following buttons if you want to launch the application or view the user guide and click Finish. 

 

 

Figure 9 Install the software – Complete the installation 
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6. After the installation is complete, the contents are available at the following location: 

<Install location>\EZ-PD Protocol Analyzer Utility. 

 

 

Figure 10 EZ-PD™ Protocol Analyzer Utility window 

Note: For EZ-PD™ Protocol Analyzer Utility support on Mac contact Infineon Sales for more details.  
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3 Analyzer operation 

This section describes how to run the CY4500-EPR EZ-PD™ Protocol Analyzer Utility, and how to update the 

firmware of the PSOC™ 5LP device of the analyzer. Complete the installation as explained in the Installation 

section before proceeding. 

3.1 Capturing PD packets using CY4500-EPR EZ-PD™ Protocol Analyzer  

The steps to run the CY4500-EPR EZ-PD™ Protocol Analyzer to capture the PD packets on the CC bus are as 

follows:  

1. Using a USB Micro-B cable, connect the USB Micro-B receptacle (Connector J7) of the CY4500-EPR EZ-PD™ 

Protocol Analyzer board to the host PC. LED1 of the CY4500-EPR EZ-PD™ Protocol Analyzer board blinks in 

white color.  

2. Connect the USB Type-C plug (Connector J3) of the CY4500-EPR EZ-PD™ Protocol Analyzer board to the 

Type-C host device. In this user guide, the CY7113 - EZ-PD™ PMG1-S3 prototyping kit (not provided with this 

analyzer) is used as a Type-C PD sink device as an example.   

3. Verify that the setup looks similar to the image shown in Figure 11.   

 

 

Figure 11 Setup for operating CY4500-EPR EZ-PD™ Protocol Analyzer 

  

https://www.infineon.com/cms/en/product/evaluation-boards/cy7113/
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4. On the host PC, launch the EZ-PD™ Analyzer Utility from  

Start > All Programs > Infineon EZ-PD™ Analyzer Utility. The EZ-PD™ Analyzer Utility’s start-up page looks 

similar to the image shown in Figure 12. 

 

 

Figure 12 EZ-PD™ Analyzer Utility start-up page 

5. Click on the Start Capturing icon  to start the CC packet capturing (USB-PD source and sink must be 

connected after the capture has started or some messages can go missing if we capture after the 

connection is done). 

The Start capturing icon then changes to the Stop Capturing icon  once the capturing starts. 

Alternatively, you can also start capturing data by clicking on Actions > Start Capturing from the menu bar. 

The status bar at the bottom of the utility window shows the message “started capturing” (similar to the 

status bar at the bottom of Figure 12). 

6. Once the capture starts, LED1 on the CY4500-EPR EZ-PD™ Protocol Analyzer will turn green to indicate the 

same. 

7. Connect a USB Type-C power adapter (not provided with the analyzer) to the USB Type-C receptacle 

(Connector J2) of the CY4500-EPR EZ-PD™ Protocol Analyzer board. Verify that the setup looks similar to the 

image shown in Figure 13. The USB Type-C power adapter mentioned here is just an example. Any USB 

Type-C device can be used in its place. 
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Figure 13 Complete setup of CY4500-EPR EZ-PD™ Protocol Analyzer 

8. Upon connecting the USB Type-C power adapter, the utility running on the host PC automatically displays a 

string of messages on the screen. Make sure that the hardware connections are not loose or do not get 

disconnected in the middle of a data capturing event. The EZ-PD™ Analyzer Utility will display messages as 

shown in Figure 14. 
 

 

Figure 14 EZ-PD™ Analyzer Utility showing PD packets captured on the CC line 
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9. The EZ-PD™ Analyzer Utility displays the captured messages (sent and received) between the USB Type-C 

host device and the USB Type-C client device on the CC line. Click on the  icon to stop capturing 

messages. Alternatively, you can stop capturing data by clicking on Actions > Stop Capturing from the 

menu bar. Upon clicking this icon, the status bar at the bottom of the utility window displays 

EZ-PD™ Analyzer is stopped.  

10. Save the captured set of messages by clicking on File > Save. These files can be saved in the .ccgx, .xlsx, 

or .csv formats, but only the file saved in the .ccgx format can be opened using the EZ-PD™ Analyzer Utility 

by clicking File > Open.  

11. To clear a captured group of messages, click either the Clear Data  icon or click Actions > Clear Data 

from the menu bar. This clears all the captured group of messages. If they are not saved prior to clicking 

the Clear Data icon, then these messages are lost.  

12. If the hardware shown in Figure 13 is not stable or gets disconnected at any point, the status bar at the 

bottom of the utility window shows the message EZ-PD™ Analyzer is disconnected.  

13. For more information on how to use the EZ-PD™ Analyzer Utility, see the EZ-PD™ Analyzer Utility User 

Manual by clicking Help > User Manual.  

3.2 Updating PSOC™ 5LP device firmware on the CY4500-EPR EZ-PD™ 

Protocol Analyzer  

The PSOC™ 5LP device firmware, present on the CY4500-EPR EZ-PD™ Protocol Analyzer board, can be updated 

using the Firmware_Update_Tool Utility.  

3.2.1 Updating firmware using EZ-PD™ Analyzer Utility for Windows 

1. Using a USB Micro-B cable, connect the USB Micro-B receptacle (Connector J7) of the CY4500-EPR EZ-PD™ 

Protocol Analyzer board to the host PC. LED1 of the CY4500-EPR EZ-PD™ Protocol Analyzer board blinks in 

white color.  

2. On the host PC, launch the download firmware application from <install location>\EZ-PD Protocol Analyzer 

Utility\Firmware_Update_Tool\ EZPD_Firmware_Update_Tool. The utility’s start-up page looks similar to the 

image shown in Figure 15.  

3. Check the current firmware loaded on the EZ-PD™ Protocol Analyzer hardware by selecting Get Firmware 

Version as shown in Figure 15. A dialog box showing the current firmware version appears. 
 

 

Figure 15 Get the current firmware version and dialog box 
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4. Click OK to return to the main menu. Proceed with the rest of the procedure to download the firmware if a 

new version of the firmware is available.  

5. Upon executing step 4, the Download Firmware window opens as shown in Figure 16. The device enters 

the bootloader mode by default.  

 

 

Figure 16 “Download Firmware” window  

6. Click Load File… as shown in Figure 16 and select the CY4500-EPR firmware file in .cyacd format as shown 

in Figure 17. Click Open. The binary file provided with the analyzer is available at the following location: 
 

CY4500-EPR device firmware:  

<Install location>\ EZ-PD Protocol Analyzer Utility\Firmware_Update_Tool\CY4500_EPR_Firmware 
 

CY4500 device firmware:  

<Install Directory>\ EZ-PD Protocol Analyzer Utility\Firmware_Update_Tool\CY4500_Firmware 

 

 

Figure 17 Selecting the CY4500-EPR firmware file 
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7. Click Program to download the firmware to the device. 

 

 

Figure 18 Programming the CY4500-EPR firmware file 

8. Once the message comes up that the download ended, reset the device by disconnecting the Micro-B cable 

and connecting again. 
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CC 

configuration channel 

 

EoM 

end of message 

 

EPR 

Extended Power Range 

 

GPIO 

general-purpose input output 

 

LED 

light emitting diode 

 

Msg. ID 

message identification 

 

MTR 

message trigger 

 

MCU 

microcontroller unit 

 

Obj. Count 

object count 

 

PD 

Power Delivery 

 

QSG 

Quick Start Guide 

 

SPR 

Standard Power Range 
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SOM 

start of message 

 

SOP 

start of packet 

 

SBU 

sideband use 
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