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Introduction Thistutorial provides all the steps for creating a system for the ADC-DAC
board from the scratch with the DE2 board. Also it shows how to crezate,
compile, debug and run a C/C++ program using the Nios |1 IDE.

Table below shows the Revision history of Designing ADC-DAC System
from Scratch for DE2.

Version Date Description

0.1.1 July 2007 First Publication of Designing ADC-DAC
System from Scratch for DE2 Tutorial.

How to Contact For the most up-to-date information about SL S products, go to the SLS
worldwide website at http://www.slscorp.com. For additional information
SLS about SL S products, consult the source shown below.
Information Type E-mail

Product literature services, SLS liter- | support@slscorp.com
ature services, Non-technical cus-
tomer services, Technical support.
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Typographic Conventions

Typog raph iC Designing ADC-DAC System from Scratch for DE2, Cyclonell Edition uses
. the typographic conventions shown as below.
Conventions
Visual Cue Meaning

Bold Type with Initial Capital Letters

All Headings and Sub Headings Titles in a document are dis-
played in bold type with initial capital letters; Example:
Introduction, Creating a Quartus Il Project.

Bold Type with Italic Letters

All Definitions, Figure and Table Headings are displayed in Italics.
Examples: Figure 2-1. Create a New System Dialog Box,
Figure 2-2. SOPC Builder

1 Numbered steps are used in a list of items, when the sequence of

5 items is important. such as steps listed in procedure.

e N Bullets are used in a list of items when the sequence of items is
not important.

Courier type Anything that must be typed exactly as it appears is shown in
Courier type. For Example cpu
The hand points to information that requires special attention.

=

A

The caution indicates required information that needs special con-
sideration and understanding and should be read prior to starting
or continuing with the procedure or process.

CAUTION
The warning indicates information that should be read prior to
starting or continuing the procedure or processes.
WARNING
The feet direct you to more information on a particular topic.
CL )
add

iv
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1. Introduction

System Level Solutions

Hardware &
Software
Requirements

This tutorial walks you through the hardware & software development flow.
It shows you how to use SOPC Builder and the Quartus Il software to create
and use your own Nios Il system

Thistutorial isbasically for userswho are new to the Nios 11 processor aswell
as users who are new to the concept of using embedded systems in FPGA.
This tutoria guides you through the steps necessary to create and compile a
ADC-DAC System Design, caled sc_adcdac refdes de2. This simple,
single-master ADC-DAC control system consists of a Nios || embedded
processor and associated system peripherals as well as interconnections for
use with the input & output hardware available on the DE2 board.

Thistutorial is divided into the following three sections:

®  ‘Designing & Compiling’ - Teaches you how to use SOPC builder to
create the ADC-DAC modulein block design file (.bdf) and how to
compile the ADC-DAC design using the Quartus || Compiler.

m  ‘Programming - Teaches you how to use the Quartus Il Programmer
and the USB-Blaster cable to configure the FPGA on DE2 board.

B ‘Running the Software on Your Nios|l System’ - Provides the instruc-
tions for running software on your Nios Il system using the Nios 11
Integrated Development Environment (IDE).

The user will require following hardware & software
® A PC running with Win 2000/XP OS

m  Nios |l Embedded Processor

®  The Quartus |l Software, version 6.1

m  DE2 Development Kit

System Level Solutions
July 2007
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2. Designing & Compiling

To use theinstructions in this section, you need to be familiar with the
Quartus Il software interface-specifically tool bars. Refer to Quartus |1 help
for more information about using the Quartus |1 software.

Creating a Here are the steps to create a new Quartus |1 project:
: 1. Openthe Quartusll.
Quartus Il Project pentheQ
Choose File>New Project Wizard.
3. Click Next.
4. Select Working Directory of the Project, Name of the project as
‘sc_adcdac refdes de2’ & top-level entity as
‘sc_adcdac refdes de2'.
5. Click Next.
6. Click Next.
7. Select the family as‘Cyclonell’.
8. We will select the FPGA (which is Cyclone 1l EP2C35F672C6) for
DE2 board, so under Filters / Speed Grade select 6. Then under
Available devices: Select ‘EP2C35F672C6'. Click Next.
9. Click Next.
10. Click Finish.

Start SOPC builder

SOPC builder is a software tool that allows you to create afully functioning,
ADC-DAC system module. A complete ADC-DAC system module contains
aNios |l embedded processor and its associated peripherals.

To start SOPC builder, perform the following steps:

1
2.

Open the Quartus |1 software.

Choose SOPC Builder (Tools menu). SOPC Builder displays the
Create New System dialog box.

System Level Solutions
July 2007
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Designing & Compiling

3. Type'System_Top'. See Figure 2-1.
4. Specify Verilog or VHDL in HDL Language field.

SOPC Builder generates plain text Verilog HDL or VHDL for all of itsnative
components depending on the language you choose.

Figure 2-1. Create New System Dialog Box

I® Create New System @

Swskem MName: System_Tcup|
Targek HOL

i) Yerilog ) YHDL

Cancel O, t

5. Click OK. The Altera SOPC Builder - System Top window appears
and the System Contents tab is displayed.

You are now ready to set the speed and add the Nios || CPU and peripherals
to your system. The components you will be adding are located in the module
pool on the left hand side of the System Content tab. See Figure 2-2.

Specify Target Hardware Settings

The functionality of the SOPC Builder system depends on the hardware on
which it will run. Thus, specifying the target board isthe first step in creating
asystem.
e Choose aboard typein the Target pull-down menu. As DE2 is not
yet added in the menu, keep the ‘ Unspecified Board'.
»  Select the System Clock Frequency as 27M hz.

System Level Solutions
July 2007
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Adding CPU & Peripherals

Figure 2-2. SOPC Builder

t® Altera SOPC Builder - System_Top.

File Modde System Wisw Tooks Help

System Contents | System Generation

£ Aftera SOPC Buider ~
3] Creale New Camponert

= Avalon Cor nt:
8 o

# Bridges

# Communication

# DSP

+ Display

# EP1C20 Hios Developt
# EP1S10 Hios Developr
# EP1540 Hios Developr
£ EP20K200E Hios Devel
# EP2C35 Nios Developt
# EP2SH0 DSP Board Str
# EP2S80 Hios Developr
- El Caming
# Ethernet
- Interfaces and Peript
# Legacy Components
# Math Copracessors
# Memory
i Microcontrollers
i Microtronix
I Other
=-pCl
i Peripherals

< ¥
A1 Buailahio Mamnnnan ™

&n @] &) O

Target

Clack Saurce
Board: |Unspecified Board vl ek External
Device Family: |Cydone II | v

Use | Madule Name Descriptian

A -

MHz Fipeline
S o |
| [
Input cl... | Base End

(%) Done checking for updates.

Next >

Adding CPU &
Peripherals

This section describes adding following modules to the SOPC Builder.

Nios Il 32-bit CPU

JTAG UART

Timer

Tristate Bridge

SRAM Memory

Parallel 1/Osfor

 ADC Output Start Bit
* ADC Output Enable Bit

*  ADC Output Address Latch Enable Bit

* ADC Output Address Bits
* ADC Input End of Character Bit

4
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Designing & Compiling

 ADC Input Data Byte

* DAC Output Data Byte
» LEDs

»  Pushbutton Switches

Nios Il 32-bit CPU

To add the Nios |1 32-bit CPU, named CPU, perform the following steps:
1. Under Avalon Modules, select Nios|1 Processor - Altera Corporation.
2. Click Add. The Nios Il configuration wizard titled Altera Nios Il -
cpu_O displays.
3. Specify the following optionsinthe Nios |1 Coretab.
»  Select the processor core: Niosll/sasin Figure 2-3.
* Instruction Cache Size: 4K bytes

Figure 2-3.Nios Il Configuration Wizard - Nios Il Core Tab

X

I8 Altera Nios Il - cpu_0

Caches & Tightly Coupled Memories | Advanced Features | JTAG Debug Module | Custom Instructions

Select a Mios Il core:

ONios II/e [@Nios 11/s ONios I1/f |
= RISC RISC RISC
NiosII .. 2-bit 2-hit
Selector Guide Instruction Cache [nstruction Cache
Faily: Cyclane IT Branch Prediction Eranch Prediction
Hardware Multiply Hardware Mulkiply
Fsystem: 43 MHz Hardware Divide Hardware Divide
Barrel Shifter
Data Cache
Dynamic Branch Prediction
Performance at 48 MHz Up ko 4 DMIPS Lp to 24 DMIPS Lip to 49 DMIPS
Logic Usage £00-700 LEs 112001400 LEs 1400-1500 LEs
Memory Usage Two MaKs Two Maks + cache Three M4ks + cache
Hardware Multiply: |Embedded Multipliers [ Hardware Civide

Cancel Mext = Finish

4. Click the JTAG Debug M odule tab and choose the selected tab shown
in Figure 2-4.

System Level Solutions 5
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Adding CPU & Peripherals

Figure 2-4.Nios Il Configuration Wizard -JTAG Debug Module

I8 Altera Nios Il - cpu_0 @

Nios I Core | Caches & Tightly Coupled Memories | Advanced Feature:

Select a debugging level:
() No Debugger

Mo LEs
Mo M4ks

(®Level 1

ITAG Target Connection
Download Software
oftware Breakpoints

CiLevel 2 | CiLevel 3

Custom Instructions

| CiLevel 4

NTAG Target Connection

Download Software Download Software

Foftware Breakpoints Software Breakpoints

? Hardware Breakpoints 2 Hardware Ereakpoints

? Data Triggers 2 Daka Triggers
Instruction Trace

JTAG Target Connection

On-Chip Trace

Advanced debug licenses can be purchaszed from FS2.

300-400 LEs B00-900 LEs 2400-2700 LEs
[Two M4ks Mo Maks Faour Maks
hittp: Sy f52 com)
Cancel ] [ < Prev ] [ Mext = ] [ Finish ]

JTAG Target Connection
Download Software
Software Breakpoints

4 Hardware Breakpoints
4 Data Triggers
Instruction Trace

Data Trace

On-Chip Trace

OFff-Chip Trace
3100-3700 LEs

Faour Maks

5. Clicking Finish. You return to the SOPC Builder System Content tab
and an instance of the CPU named cpu_0 now appears in the table of
available components.

6. Right click cpu_0 and select Rename.

7. Typecpu and press Enter.

It is recommended to rename the components for avoiding ambiguity in

further design

process.

JTAG UART

The JTAG UART interface component is added to reduce the number of
connections necessary to ‘talk’ to the Nios 1. To add it

1. Select Communication > JTAG UART and click Add.. The JTAG

UART - jtag_uart_0 wizard displays as shown in Figure 2-5.

6
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Designing & Compiling

Figure 2-5.JTAG UART Configuration Wizard

I8 JTAG UART - jtag uvart 0

Sirmulation

‘Write FIFO { data from Awvalon o ITAG )

Depth: |64 w IR Threshold: ﬂ

[] Construct using registers instead of memary blacks

Read FIFO | data from ITAG to Avalon )

Depth: |64 w IR Threshold: E‘

[] Construct using registers instead of memary blacks

Cancel Mext = | Finish I

Accept the default options by clicking Finish. You return to the SOPC

Builder System Contents tab and an instance of the JTAG UART
named jtag_uart_0 now appears in the table of available components.

Right click jtag_uart_0 and select Rename.

4. Typejtag uart and press Enter.

System Level Solutions
July 2007
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Adding CPU & Peripherals

Timer

The Timer is necessary for some of the default device drivers provided in the
HAL system library, for example, the JTAG UART. To add the timer
perform the following steps:

1. Choose Other > Interval Timer and click Add.

2. Leavethe default settingsin the Avalon Timer - timer_0 window.
Figure 2-6.

Figure 2-6. Timer Configuration Wizard

1™ Avalon Timer - timer_0 g|
Timeout Period
Initial Period: 1| |msec
Input Clock Freguency: 458 MHz
Hardware Options
Preset Configurations: | Full-Featured w
Registers
Witable period
Readable snapshat
Start/Stop contral bits

Cutput Signals
[ Timeaut pulse {1 clock wide)

[] Swstem resst on timeout {(Watchdag)

Cancel | Finish |

3. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the Timer named timer_O now appears in the table of
available components.

4. Right click timer_0 and select Rename.

Type t imer and press Enter.

Tristate Bridge

For the ADC-DAC system to communicate with Tristate memory external to
the FPGA on the DE2, you must add a bridge between the Avalon bus and
external memory controller . To add this:

8 System Level Solutions
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1. Select Bridges > Avalon Tri-State Bridge and click Add. The Avalon
Tri-Sate Bridge- tri_state bridge 0 wizard displays. See Figure 2-7.

Figure 2-7. Avalon Tristate Bridge Configuration Wizard

I™ Avalon Tristate Bridge - tri_state_bridge 0

Incoming Signals

Increazes off-chip Frmax, but alzo increazes latency .
) Mot registered

Otgoing address and control signals are always registered.

=n

2. Click Finish. You return to the SOPC Builder System Content tab and
an instance of the Tri_state bridge named tri_state bridge O now
appears in the table of available components.

3. Rightclicktri_state bridge 0 and select Rename.

4. Typetri state bridge and pressEnter.

SRAM Memory

Depending on which hardware you are using user has to select the externa
SRAM or any memory. We shall be using SRAM aviaable on DE2 board.

SL S has developed a generic SRAM controller which is provided in the
reference design directory.

Therefore, before following the steps mentioned below, copy the contents of
the folder <./SLS ADC-DAC_Board\ADC-DAC_Reference Designs/
Components> to <Quartus installation path>/quartus/sopc_builder/com-
ponents directory. Go to SOPC builder File menu and click Refresh Com-
ponent List.

To add SRAM Memory Controller perform the following steps:

System Level Solutions
July 2007
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Adding CPU & Peripherals

1. Select Memory >SLS 1S61LV6416L 10T _SRAM-sram_0 and
click Add.

2. The SRAM wizard displays. See Figure 2-8.
3. Set Memory Size=512 kB

Figure 2-8. SRAM Memory Configuration Wizard

1M 515 IS61LV6416L 10T SRAM - sram 0 X]

Attribukes
Skatic RAM

Thiz iz & 10 he 16-hit SEAM component, which can alzo be
customized for Address span for other 16-hit 10 ns SRAMsS.

Memmory Size: 512 kg w

18 Word Alighed Address Bits

Generic Mermory Model {Simulation Only)

Include a Functional memory madel in the system testhench.

4. Click Finish. You return to the SOPC Builder System Content tab and
an instance of the SRAM named sram_0 now appears in the table of
available components.

5. Right click sram_0 and select Rename.

6. Typesram and press Enter.

Parallel I/0 for ADC Output Start Bit

To provide aninterface for ADC Output Start Bit on DE2 Board, add the PIO
by performing the following steps:

1. Select Other > PIO (Parallel 10) and click Add.
2. Specify the Options. See Figure 2-9.

10 System Level Solutions
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Designing & Compiling

e Width=1bits
e Direction = Output portsonly.

3. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio_0 now appears in the table of
available components.

4. Rightclick pio_0and select Rename.

5. Typeadc_start and press Enter.

Figure 2-9. PIO Configuration Wizard For ADC Output Start Bit

18 pvalon PIO - pio_0 53
Basic Settings
Width
1] | bits
PIC wicth must he hetween 1 and 32 hits

Direction

() Bidirectional (tri-state) ports

() Input parts only

(O Bath input and autput parts

(T+) Qutput ports only

Cancel | Finish SI

Parallel I/0 for ADC Output Enable Bit

To provide an interface for ADC Output Enable Bit on DE2 Board, add the
PIO by performing the following steps:

1. Select Other > PIO (Parallel 10) and click Add.
2. Specify the Options. See Figure 2-10.

*  Width =1bits

»  Direction = Output ports only.

System Level Solutions 11
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3. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio 0 now appears in the table of
available components.

4. Right click pio_0 and select Rename.

5. Typeadc_oe and press Enter.

Figure 2-10. PIO Configuration Wizard For ADC Output Enable Bit

1% Avalon PIO - pio_0 X

Basic Settings
Width
1] | bits
PIC wicth must he hetween 1 and 32 hits

Direction

() Bidirectional (tri-state) ports

() Input parts only

(O Bath input and autput parts

(%) Qutput parts anly

Cancel | Finish §

Parallel I/0 for ADC Output Address Latch Enable Bit

To provide an interface for ADC Output Address Latch Enable Bit on DE2
Board, add the PIO by performing the following steps:

1. Select Other > PIO (Parallel 10) and click Add.
2. Specify the Options. See Figure 2-11.

e Width =1bits

e Direction = Output ports only.

3. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio_O now appears in the table of
available components.

4. Rightclick pio_0 and select Rename.

12 System Level Solutions
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5. Typeadc_ale and press Enter.

Figure 2-11.PIO Configuration Wizard for ADC Output Address Latch Enable Bit

1% Avalon PIO - pio_0 X

Basic Settings
Width
1] | bits
PIC wicth must he hetween 1 and 32 hits

Direction

() Bidirectional (tri-state) ports

() Input parts only

(O Bath input and autput parts

() Qutput ports only

Cancel | Finish A

Parallel I/O for ADC Output Address Bits

To provide aninterface for ADC Output Address Bits on DE2 Board, add the
PIO by performing the following steps:

1
2.

Select Other > PIO (Parallel 10) and click Add.

Specify the Options. See Figure 2-12.
*  Width =3 bits
»  Direction = Output ports only.

Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio_O now appears in the table of
available components.

Right click pio_0 and select Rename.
Typeadc add and press Enter.

System Level Solutions
July 2007
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Figure 2-12. PIO Configuration Wizard For ADC Output Address Bits

19 Avalon PIO - pio_0 X

Basic Settings

‘Width

|3 |bits

PIC wicth must he hetween 1 and 32 hits
Direction

() Bidirectional (tri-state) ports

() Input parts only

(O Bath input and autput parts

(%) Output parts anly

Cancel Finish
[conesl =

Parallel I/0 for ADC Input End Of Character Bit

To provide an interface for ADC Input End of Character Bit on DE2 Board,
add the PIO by performing the following steps:

1. Select Other > PIO (Parale 10) and click Add.
2. Specify the Options. See Figure 2-13.
e Width =1 bits
e Direction = Input portsonly.
* Accept Input Optionsand Simulation as default.

3. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio_O now appears in the table of
available components.

4. Right click pio_0 and select Rename.

Typeadc eoc and press Enter.

14 System Level Solutions
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Figure 2-13.PIO Configuration Wizard For ADC Input End Of Character Bit

1% Avalon PIO - pio_0 X

Basic Settings | Input Options || Simulation

‘Width
1 | bits

PIC wicth must he hetween 1 and 32 hits
Direction

() Bidirectional (tri-state) ports

(O Bath input and autput parts

() Qutput parts anly

Cancel Mext = ] “ Finish@

Parallel I/0 for ADC Input Data Byte

To provide an interface for ADC Input Data Byte on DE2 Board, add the PIO
by performing the following steps:

1. Select Other > PIO (Paralel 10) and click Add.

2. Specify the Options. See Figure 2-14.
*  Width =8 bits
e Direction = Input portsonly.

»  Keep the default settings under I nput Options and Simulation as
defaullt.

* Click Finish

3. You return to the SOPC Builder System Contents tab and an instance
of the PIO named pio_ O now appears in the table of available
components.

4. Right click pio_0 and select Rename.

5. Typeadc_data and press Enter.

System Level Solutions
July 2007
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I8 Avalon PIO - pio 0

Basic Settings | Input Options || Simulation

Figure 2-14. PIO Configuration Wizard For ADC Input Data Byte

X

‘Width

bits

PIC wicth must he hetween 1 and 32 hits
Direction

() Bidirectional (tri-state) ports

(O Bath input and autput parts

() Qutput parts anly

Cancel Mext = | Finish g
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Parallel I/0 for DAC Output Data Byte

To provide an interface for DAC Output Data Byte on DE2 Board, add the
PIO by performing the following steps:

1
2.

Select Other > PIO (Parallel 10) and click Add.
Specify the Options. See Figure 2-15.

*  Width =8 bits

»  Direction = Output portsonly.

e Click Finish.

You return to the SOPC Builder System Contents tab and an instance
of the PIO named pio_ 0 now appears in the table of available
components.

Right click pio_0 and select Rename.

Typedac_data and press Enter.

Figure 2-15. PIO Configuration Wizard For DAC Output Data Byte

1% Avalon PIO - pio_0 X

Basic Settings

width
8 | bits

PIC wicth must he hetween 1 and 32 hits
Direction

() Bidirectional (tri-state) ports

() Input parts only

(O Bath input and autput parts

Cancel | Finish SI
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Parallel I/O for LEDs

To provide an interface for led’s on DE2 Board, add the PIO by performing

the following steps:

1. Select Other > PIO (Paralel 10) and click Add.

2. Specify the Options. See Figure 2-16.
*  Width =4 bits
»  Direction = Output portsonly.
e Click Finish.

3. You return to the SOPC Builder System Contents tab and an instance
of the PIO named pio_ 0 now appears in the table of available

components.
4. Right click pio_0 and select Rename.
Type led pio and press Enter.

Figure 2-16. PIO Configuration Wizard For LEDs

I8 Avalon PIO - pio 0

Basic Settings
Width

4 | bits

Direction

() Bidirectional (tri-state) ports
() Input parts only

(O Bath input and autput parts

{#) Cutput ports only

Cancel

PIC wicth must he hetween 1 and 32 hits

]

| Finish EI
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Parallel I/O for Pushbutton Switches

To provide an interface for Pushbutton Switches on DE2 Board, add the PIO
by performing the following steps:

1. Select Other > PIO (Paralel 10) and click Add.
2. Specify the Options. See Figure 2-17.

*  Width =4 bits

e Direction=Input portsonly.

Figure 2-17.P10O Configuration Wizard For Pushbutton Switches-Basic Settings

1% Avalon PIO - pio_0 53

Basic Settings | Input Options || Simulation

‘Width

[4 | bits

PIC wicth must he hetween 1 and 32 hits
Direction

() Bidirectional (tri-state) ports

() Input: parts only

(O Bath input and autput parts

() Qutput parts anly

Cancel Mext = ] l Finish&

3. Click Input Options Tab

* Under Edge Capture Register, Check Synchronously Capture.
Under Synchronously capture, select option Either Edge. See
Figure 2-18.

e Under Interrupt, check Generate IRQ. Under Generate IRQ, select
Edge option. See Figure 2-18.

4. Click Finish. You return to the SOPC Builder System Contentstab and
an instance of the PIO named pio 0 now appears in the table of
available components.

5. Right click pio_0 and select Rename.

System Level Solutions 19
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6. Typekey pio andpressEnter.

Figure 2-18.PI0O Configuration Wizard For Pushbutton Switches-Input Options Settings

19 Avalon PIO - pio_0 X

Basic Settings | Input Options | Simulation
Edge Capture Register
Synchronously capture:
() Rising Edge
() Falling Edge
(%) Either Edge

Inkerrupk
Generate IRQ

O Level.

@®

Interrupt CPU when any unmasked hit in
the edge-capture register is logic-true.

Cancel ] [ < Prev ] [ Mext = ] H Finishlﬁl

After adding all components, the complete SOPC builder system looks like
Figure 2-19.
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Figure 2-19.SOPC Builder After Adding All Components

I8 Altera SOPC Builder - System_Top

File Module System View Tools

Help

ywskem Conkent:

Nios II More "cpu” Settings | System Generation

#5) Altera SOPC Buider ”~
b5l Create Mew Component

[=-Avalon Components

: Mioz Il Processar - A

-Bridges

-Communication

-DSP

-Display

-EP1C20 Hios Develom

-EP1510 Hios Developr

-EP15440 Hios Developr

-EP20K200E Hios Devel

-EP2C35 Hios Develom

-EP2560 DSP Board Str

-EP2560 Hios Developr

-El Camino

‘Ethernet

< >
&1 Szl ahla Famnanante

o ®©| %] C

Target

Board: |Unspecified Board

Device Family: | Cyclone IT

Use | Module Mame

cpu
jtag_uart
timer
tri_state_bridge
sram
adc_start
adc_oe
adc_ale
ade_add
adc_eoc
adc_data
dac_data
led_pio
v key_pio

&

v

Description

Mios Il Processar - Altera Corpor...

JTAG UART

Interval timer

Avalon Tristate Bricoe
SLS_ISE1LYE41EL_10T_SRAM
PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

PIC (Parallel 110}

Clock Source hHz P
clk. |External |2?.D |
| |
Input Clock Base Enil IRG
clk 0x00000000|  0:xO00007FF| 6
clk 0x00000800) 0x00000507| [0
clk 20| 0x0000083F|[1
clk
0x00080000) 0x000FFFFF)
clk 0x00000810)  0x0000051F)
clk 0x00000840)  0x0000054F)
clk 0x00000860)  0x0000036F)
clk 0x0000055F )
clk 0x00000870) 0x0000057F)
clk 0x00000880)  0x0000035F)
clk 0x00000890)  O0x0000059F)
clk 0x000008A0| 0x000005AF)
clk 0x000008B0 0x000005EF|[ 2

A Move LUp ]

[ w Mave Down

[7) Done checking For updates.

Exit

. cpu was generated as a time-limited OpenCore Plus module and will time-out unless compiled in Quartus IT with a valid license.
. cpu: The reset address points to volatile memory, Execution of undefined code may occur upon reset,

Mext = ]

l Generatﬁj

Generating the
System

To generate the design logic, perform the following steps.
1. Click the System Generation tab.

2. Specify the following settings from the Options window. Figure 2-20.
* HDL: Check thisbox

e Simulation: Check this box if you have Modelsim installed and
would like to simulate the design.

System Level Solutions
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Figure 2-20.Generating the System

I8 Altera SOPC Builder - System_Top
File Module System WYiew Tools Help

Systemn Contents | Nios IT More "cpu” Settings

Options

I Run nios 11 10E

HOL. jzenerate system module logic in Verilog,
[ simulation| Create simulatar project files.

Info: Quartus II 3hell was successful. 0 errors, 0 warnings M

Info: Allocated 40 megsbytes of wemory during processing
Info: Processing ended: Tue Jul 10 11:05:17 2007
Info: Elapsed time: 00:00:03
# Z0O07.07.10 11:05:17 (%) Completed generation for system: System Top.
# Z0O07.07.10 11:05:17 (*) THE FOLLOWING SYSTEM ITEMS HAVE BEEN GEMNERATED:
SCPC Builder datsbhase : E:/Mrkt Dev/projects/sc_adedac refdes_de2/System Top.ptf
System HDL Model : E:/Mrkt_Dev/projects/sc_adedac refdes_de2/System Top.v
System Generation Script @ E:/Mrkt_Dev/projects/sc_adedac refdes de2/System Top_generation script

# 2007.07.10 11:05:17 (%) ITCCE33: IYITEM GENERATICON COMPLETED.

Press 'Exit' to exit. A
< >

. cpu was generated as a time-limited OpenCore Plus module and will time-out unless compiled in Quartus IT with a valid license.
[7) cpu: defaulting Reset Address, Exception Address to sram

. cpu: The reset address points to volatile memory, Execution of undefined code may occur upon reset,
[7) Done checking For updates.

Exit < Prev Re-Generate %

3. Click Generate. See Figure 2-20.

4.  When generation is complete, the SYSTEM GENERATION
COMPLETED message displays. “DO NOT EXIT SOPC BUILDER
AT THIS POINT.” We will return to this window prior to testing the
system with software.

Addmg the During generation, SOPC Builder creates a symbol of the System_Top, for
using in Quartus I1. To add the symbol perform the following steps.
Quartus I

1. Select File (menu) > New.
SymbOI to the 2. Under Device Design Files, select Block Diagram/Schematic File. See

BDF Figure 2-21.
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Figure 2-21.New Block Design File

MNew

Device Design Files l Other Files ]

AHDL File
Block Diagram/Schematic File
e

SOPC Builder System

Werilog HOL File

WHDL File

Ok

X

Cancel

3. Click OK. You are return to the Quartus |1 software and double click
anywhere inside the BDF window. The Symbol dialog box appears. See

Figure 2-22.
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Figure 2-22.BDF System_Top Symbol

Symbol
Lib[a[ies: PR ................................................ ..
El & Project stem_Tap
EF counter o
reset_n

F B3 d:/toals/alerass1 Aquartuz/librar

out_port_from_the_sclc_add[2.0] f=— - -

out_port_from_the_adc_ale  —

in_port_to_the_adc_data[7..0]

in_port_to_the_adc_eoc

out_port_from_the_adc_oe  |—

out_port_from_the_adc_start |—

out_port_from_the_dac_dstal7 0] e - -

in_port_to_the_key_pial3..0]

out_port_from_the_led_pio[3..0]

< >
M ame:

|S yatem_Top _J

™ Repeat-inzert mode

read_n_to_the_sram
select_n_to_the_sram
tri_state_bridge_address[158..0]
tri_state_hridge_byteenablen[1..0]
tri_state_hridge_data[15..0]
werite_n_to_the_sram

I Insert symbol as block
[ is :

Megaiwizard Plugn Manager... | R R R e

aK h Cancel ‘

4. From Libraries, expand the Project directory by clicking the + sign
nearby.

5. Click System _Top. A large symbol will appear representing the
ADCDAC system module you just created.

6. Click OK. The Symbol dialog box closes and an outline of the
System_Top symbol is attached to the pointer.

7. Place the symbol in the Block Diagram file by clicking the left mouse
button.

8. You can generate the input and output node by selecting the symbol and
right click on it and select Generate Pinsfor Symbol Ports. See
Figure 2-23.
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Figure 2-23.Generate Pins

9. Input, output and bidirectional pinsfor the symbol will be automatically
generated and connected accordingly. See Figure 2-24.

Figure 2-24.Autogenerated Pins for Symbol

&

10. The autogenerated pin names can be changed. Right click the pin name
and select Properties. The Pin Property dialog box appearsas shown in
Figure 2-25.
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Figure 2-25. Pin Properties

Pin Properties

Gerneral l Farmat ]

To create multiple ping, enter a name in AHDL bus natation [for example,
"name[3..0]"], or enter a comma-separated list of names.

Pin nhames):

)

| Ok M Cancel

11. You can give al the name according to Table 2-1 . The names are given

for ease of reference.

Table 2-1. Pin Names in Final BDF

Pin Name of the Symbol

Custom Pin Names

clk clk

reset_n reset_n
in_port_to_the_adc_data[7..0] adc_data[7..0]
in_port_to_the_adc_eoc adc_eoc
in_port_to_the_key pio[3..0] key[3..0]
out_port_from_the_adc_add[2..0] adc_add[2..0]
out_port_from_the_adc_ale adc_ale
out_port_from_the_adc_oe adc_oe
out_port_from_the_adc_start adc_start

out_port_from_the_dac_data[7..0]

dac_data[7..0]
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out_port_from_the_led_pio[3..0] ledg[3..0]
read_n_to_the_sram sram_oe_n
select_n_to_the sram sram_ce_n

tri_state_bridge_address[18..0]

sram_add[18..0]

tri_state_byteenablen[1..0]

sram_be_n[1..0]

tri_state_bridge_data[15..0]

sram_data[15..0]

write_n_to_the_sram

sram_we_n

12. Add the counter by following the steps below:
*  Double click anywhere inside the BDF window.
* It will pops up the Symbol window.

*  Select <dirve path>:/altera/../megafunctions/arithmatic/
Ipm_Counter. See Figure 2-26. Click OK

Figure 2-26.Symbol Window

Libraries:

# 22 Project

B megafunctions
B arithmetic

altfp_div
altfp_rult
altrernmmlt

altrult_add
divide
Ipm_abs
lpm_add_sub
+ lpm_compare

iy parallel_add
FET gates
#HE& 10
FET storage
FHE athers

<

B E d/tools/altera/81 Aquartusdit—

-y altaccumulate
¥y alfp_add_sub

altrult_accum

-

LPW_COUNTER

szt
sload
upcovyn
crt_en

Mame:

|Ipm_c:0unter

I” Repeat-inzert mode
I Insert symbal as block

Megatwizard Plug-In kan.

W Launch Megawizard Plugn

ager.. |

=]

Cancel |
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o Itwill pops up the MegaWizard Plug-In Manager window. See

Figure 2-27.

»  Givethename counter inthe Output file text box. See Figure 2-27.

Figure 2-27.MegaWizard Plug-In Manager [page 2C]

Selected Megafunctions:

—

“wihich type of output file do pou want o create™
& AHDL
© WHDL
" Verilog HDL

What hame do pou want far the autput file?

Brawse:

E:WMikt_Devhprojectshsc_adecdac_refdes de2pm_counter I

Mote: Ta compile 5 project successfully in the Quartus || software, pour
design files must be in the project directory. in the global user ibraries
specified in the Options dialog bax [Taals menu), ar a uger libram specified
inthe User Libraries page of the Settings dialog box [Assignments menu).

“Your current user library directories are:

[ Don't ask me for an output file name or the output file format again.
I future, name output files automatically and use the current output file format.

[Mote: T'ou can bun the Block Editor's auto naming and auto format selection
on and off with the Options command in the Tools menw.]

Selected Megafunctions:

e

‘which tupe of output file do pou want to create?
& AHDL
" WHDL
" Yerlog HOL

“What name do pou want for the output file?

Browse.

|E.\M ikt_Devhprojectshsc_adodac_refdes_deZ\counter

Mote: To compile a project successfully in the Quartus || software, your
design files must be in the project directary, in the global user librariex
specified in the Options dislog box (Tools menw). or a user library specified
in the User Libraries page of the Settings dialog box (Assignments mex).

“T'our cuirent uger library directories are:

™ Don't ask me for an output file name or the output file farmat again,
In future, name output files automatically and wse the curment output file format.

[Mote: Yiou can turn the Black Editar's suto naming and auto format selection
on and off with the Options command in the Tools menu.]

Cancel ‘

‘ est » ‘

Cancsl |

| Nexl>|:| |

*  Click Next. You will go to the next page of MegaWizard.
o Select the output bus width as 6 bits. See Figure 2-28.
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Figure 2-28.MegaWizard Plug-In Manager [page 3]

MegaWizard Plug-In Manager - LPM_COUNTER [page 3 of 7]

,a LPM_COUNTER
Yersion 6.1

Docurnentation

About

Optional Inputs

up countel

Resource Usage
E Iut + 6 reg

I clock o15..0]

Hows wide should the 'q' output bus be? bitz

What should the counter direction be?
! Up anly
) Down only

! Create an 'updown' input port ko allow me to do both
[1 counts up; 0 counts down]

| Cancel ” < Back ” Mext 1\” Einish |

Click Next. You will see the page 4 of MegaWizard.
L eave the default settings as shown in Figure 2-29.
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Figure 2-29.MegaWizard Plug-In Manager [page 4]

MegaWizard Plug-In Manager - LPM_COUNTER [page 4 of 7]

_;a LPM_COUNTER
Yersion 6.1 ,&bT‘

Docurnentation

Optional Inputs

‘which type of counter do you want?
®! Plain binary
1 Madulus, with & count modulus of

up countel

I clock o15..0]

optional additional ports?
[7] Carry-in
["] Count Enable [] Carry-out

Resource Usage
E Iut + 6 reg

| Cancel ” < Back ” Me‘;\&t> ” Einish |

e Click Next.
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Figure 2-30.MegaWizard Plug-In Manager [page 5]

MegaWizard Plug-In Manager - LPM_COUNTER [page 5 of 7]

LPM_COUNTER
Yersion 6.1 ,&bT‘

Docurnentation

Optional Inputs

Do you want any optional inputs?

counter
Up countel

Aspnchronous inputs
[] Clear

[] Load

[ Set

o[5..0]

Resource Usage
E Iut + 6 reg

| Cancel ” < Back ” Mext >NJ Einish |

e Under Synchronousinputs, Check the Clear box. See Figure 2-30.
e Click Next.

e You will see page 6 of MegaWizard. SeeFigure 2-31.
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Figure 2-31.MegaWizard Plug-In Manager [page 6]

MegaWizard Plug-In Manager - LPM_COUNTER [page 6 of 7] -- Simulation Libraries rz|
_,a LPM_COUNTER
Yersion 6.1 About

Simulation

Library

Docurnentation

To properly simulate the generated design files, the Following simulation model
file{s) are needed

counter
Up countel

File | Description

g5.0] lprn LPM megafunction simulation librar

Resource Usage
E Iut + 6 reg

| Cancel ” < Back ” Mext >!\l| Einish |

» Click Next.
*  You will see page 7 of MegaWizard. See Figure 2-32.
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Figure 2-32.MegaWizard Plug-In Manager [page 7]

MegaWizard Plug-In Manager - LPM_COUNTER [page 7 of 7] -- Summary.

counter

LPM_COUNTER
Yersion 6.1 ,&bT‘

Summary

Docurnentation

Turn on the files you wish to generate, & gray checkmark indicates a file that is
automatically generated, and a red checkmark indicates an optional file, Click

Finish to generate the selected files, The state of each checkbox is maintained in

Up countel
subsequent Megawizard Plug-In Manager sessions,

o[5..0]

The MegaWwizard Plug-In Manager creates the selected files in the Following
directory: E:\Mrkk_Deviprojectsisc_adcdac_refdes_de2!

File | Description

[ counter. tdf Yariation file

[ counter.inc AHDL Include file

O counter.cmp WHOL component declaration file
[ counter. bsf Guartuz || symbaol file

O counter_inst. tdf Instantiation template file

Resource Usage

E Iut + 6 reg

| Cancel ” < Back | | Einish [\L

*  Click Finish.

e You will return to BDF window

e Placethe Counter symboal inthe Block Diagram file by clicking the
left mouse button

13. Now theclk input of counter isdirectly connected to the clk input of the
System _Top. The scIr input of the counter is connected to the reset
input of the System_Top using NOT gate.

14. For selection of the NOT gate double click inside the block diagram and
select <drive path>:/.../library/primitives/logic/not. See Figure 2-33.
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Figure 2-33. NOT Gate Selection

Libraries

biord
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nard
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niard

L

oo B P PP
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ard
ard
ard

15. Then by using orthogonal node tool, you can connect the input of NOT
gate to the reset input of the System_Top and the output of the NOT gate
to the sclr input of the counter. See Figure 2-34.
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Figure 2-34. NOT Gate Connection

2 Quartus II - E:/Mrkt_Dew/projectsfsc_adcdac_refdes_de2/sc_adcdac_refdes_de2 - sc_ad

File Edit Yiew Project Processing Tools  Window

stem_Top

clk
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EDg
= P out_part_from_tt
Orthogonal Mode Tool ’ . out_port_fr

in_port_to_the_adc_dsta[7..0]

in_port_to_the_adc_eoc

out_port_f
out_port_fro
#h
out_port_from_th
Fil ¥
= in_port_to_the_key_pio[3..0]
P R R R
out_port_from_
O
rest
@) selec
. tri_state_hrido
tri_state_hbridge_}
™ tri_state_kn
werit

counter
up couriter|

o[5..0]

16. Now you have to expand the line as shown in Figure 2-35. Give the
name cntr_out[5..0].
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Figure 2-35.Counter Output

in_port_to_the_adc_eoc

out_port_from_the_adc_oe

out_port_from_the_adc_start

out_port_from_the_dac_data[7..0]

in_port_to_the_key_pial3..0]

out_port_from_the_led_pio[3..0]

read_n_to_the_sram
zelect_n_to_the_sram
tri_state_hridge_address[15..0]
tri_state_hridge_byteenablen[1..0]
tri_state_hridge_data[15..0]
werite_n_to_the_sram

counter

up counter

o[5..0]

17.

Now for the ADC clock output, add output symbol by selecting it from

the library <drive path>:/.../library/primitives/pin/output.

18.
19.

Givethe output pin name asadc_clk.

Do not connect it with the output of the counter strech its line as shown
in Figure 2-36. Givethe name as cntr_out[5] and press Enter.
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Figure 2-36.Counter Output Connection

in_port_to_the_adc_eoc

out_port_from_the_adc_oe

out_port_from_the_adc_start

out_port_from_the_dac_data[7..0]

in_port_to_the_key_pial3..0]

out_port_from_the_led_pio[3..0]

read_n_to_the_sram
zelect_n_to_the_sram
tri_state_hridge_address[15..0]
tri_state_hridge_byteenablen[1..0]
tri_state_bridge_data[15. 0] je—
werite_n_to_the_sram

=clr

up counter

o5 OF——R

_%_._UILUJ_D ade_clk

21.
22.
23.

24,
25.
26.

27.

After assignment of the 10 pins, select Assignment>Settings. The
Settings Dialog Box pops up as shown in Figure 2-37.

In Device dialog box click the button Device & Pin Options.
Device and Pin options dialog box pops up as shown in Figure 2-38.

Click the Unused pins Tab. Select As Input tri-stated in Reserve all
unused pins combo box.

Click OK. You will return to Device Settings window.
Click OK.

Now select the Processing from the menu bar and click on Sart.and
select the Sart Analysis And Synthesis.

For assignment open the Assignments from menu bar and select the
Assignment Editor. Select the category as pin and then you can see the
list of al pins used in the project. If you do not see the pins then go to
View menu and select Show All Known Pin Names.

System Level Solutions
July 2007

37
Designing ADC-DAC System from Scratch for DE2



Adding the Quartus Il Symbol to the BDF

Figure 2-37.Settings

Settings - sc_adcdac_refdes_de2 rz|
Category:
Files
User Libraries [Current Project] Select the family and device you want ta target for compilation.
Device
+ Dpera.tin.g Conditions ) (Exis |Eyc:lone T j Show in ‘Available devices' list
+/- Compilation Process Settings Package: FRGA
+- EDA Toal Settings AckagE: pd
+- Analyziz & Synthesis Settings Fin count: E7Z -
+|- Fitter Settings Target device
+- Timing Analysiz Settings " Auto device selected by the Fitter Speed giade: |6 hd
Ass?mb'e' . + Specific device selected in ‘Available devices' list Core voltage: 1.2V
Dresign Assistant ~ _
SignalT ap Il Logic Analyzer v Shaw advanced devices
Logic Analyzer Interface r
+- Simulator Settings Ayailable devices:
PowerPlay Power &nalyzer Settings Mame LEs Wermor.. | Embed... | FLL |
EP2C35FET2CE 33218 483840 70 4
EP2CROFETZCE 50528 594432 172 4
EP2CFOFETZCE E841E 1152000 300 4
Migration compatibility
Migration Devices. .. J
0 migration devices selected I
(] 8 | Cancel |
28. Now you have to go to the sc _adcdac refdes de2.csv file at
SLS ADC-DAC_Board/ADC-DAC_Reference Designs folder and
select the pins and copy it. Open the Quartus |l software and paste it in
the assignment editor.
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Figure 2-38. Device & Pin Options

Device & Pin Options E|

Fir Placement ] Error Detection CRC ] Capacitive Loading I Board Trace Model ]
General ] Configuration I Programming Files  Hrused Ping l Dual-Purpoze F'ins] antage]

Specify device-wide optionz for rezerving all unuzed ping on the device, To rezerve
individual dual-purpose configuration ping, ga ta the Dual-Purpoze Pins tab. To
rezerye other ping individually, uge the Assignment Editor.

Resernve all unugzed ping:

Description:

Rezerves all unuzed pins on the target device in one of B gtates: az inputs that are
tri-ztated, az outputs that drive ground. as outputs that drive an unspecified zignal,
az input tri-stated with bus-hold, or as input tri-stated with weak pull-up.

a PT\ Cahicel

29. After adding Inputs/Output, I nouts and pin assignments the final BDF
looks like Figure 2-39. Please refer the provided Reference Design.

30. Choose File>Save.
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Figure 2-39.Final BDF
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instT FRACE System Level Solutions () Pvt. Ltd 3
< >
« [Message [ =
For Help, press F1 ] die NUM

Note: to Figure 2-39.

(2) In this tutorial we are using only one memory (SRAM). In order to disable SDRAM and FLASH
memories, the pins are at Pull up status.

(2) You can assign the pin number using the SLS ADC-DAC_Board/ADC-DAC_Reference Designs/
sc_adcdac _refdes de2.csvfile.
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Compiling the
Design

During compilation, the Compiler locates and processes all design, project
files, generates messages and reports related to the current compilation,
creates the SRAM object file (.sof) as well as any optional programming

files.

To compilethe sc_adcdac refdes de2 design, follow these steps:

1. Choose Sart Compilation (Processing menu), or click the Sart
Compilation toolbar button. If you get amessage asking if you want to
save the changes you made the BDF file, choose Yes.

2. When compilation completes, you can view the results in the ADC-
DAC Compilation Report window. See Figure 2-40.

Figure 2-40.Compilation Report Window
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System Level Solutions

After successful compilation, the Quartus || Compiler generates one or more
programming files that the Programmer uses to program or configure a
device.

To program your design, perform the following steps.

1. Choose Programmer (Tools menu). The Programmer window opens.

2. In the Mode list of the programmer window, make sure JTAG is
selected.

3. Click Hardware Setup.. to configure the programming hardware. The
Hardware Setup dialog box appears.

4. From the Hardware column, select USB Blaster .
Click Close to exit the Hardware Setup window.

6. Inthe Programmer window, turn on Program/Configure. See
Figure 3-1.

7. Click Sart.
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Figure 3-1. Programming Window
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4. Running the Software in
Nios Il IDE

We will be using Nios Il Integrated Development Environment (IDE) to run
our software on top of Nios Il System. To start the Nios Il IDE from the
Quartus |1 software, perform the following steps:

Creating the 1. Click the System Generation tab of the SOPC Builder, then click the
Run Nios|1 IDE button.

Project

2. From the opening window, choose File>New>Nios || C/C++

Application. See Figure 4-1.

3. You will see the New Project Wizard Dialog Box as shown in
Figure 4-2.

Figure 4-1. New Project

. Nios I CC++ - Nios II IDE

F-M Edit Refactor Mavigate Search Project Tools Run Window  Help

Open File...

SN 7 Project...

s 1T CfC++ Application

&h Mios IT System Library
fg‘} Mios IT User-Makefile CfC++ Application
(@} Mios I CfC++ Library
6% Source Folder
¢ Source File
K Header File
(& Class

£ other...

4. The user has been asked to select Blank Project, since SLS has provided
areference C file to access the ADC-DAC on DE2. To import thisC file
into this project do the following steps.

Select the “ Blank Project”
Give aName to the project as ADCDAC_DE2 Board.

Select the SOPC builder system by clicking on Browse and
selecting the System_Top.ptf filein the reference design. See
Figure 4-2.
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Figure 4-2.Creating new Nios Il C/C++ Application

. New Project @

Nios II C/C+ + Application
o
Click Finish to create application with a default system library as
E:iMrkk_Deviprojectsisc_adcdac_refdes_de2software\aDCDAC_DEZ_Eoard
Mame: | ADCDAC_DEZ_Eoard | |
[ Sperify Location
’ |
Select Target Hardware,
SOPC Builder Svstemm: IE:'I.Mrkt_Dev'l.projects'l,sc_adcdac_reFdes_deZ'l,System_Top.ptF v| [Browse... ]
CPL: icpu L |
Select Project Template
%7 Description
0ard Liagnostics Creates a blank project
Counk Binary
Customn Instruction Tutarial Details
Dhrystone T z =
Hello Freestanding Blank Project creates an empty project to which you can add your code, -
Hello LED
H:IIE MicroCj0s-11 This software example runs on the following Nios 1T hardware designs:
Hello World 5 Stindard 4 gl
Hello World Small § Rl hedlis
Host File System * Fast"
Memory Test - Smal w
MicroCOS5-11 Message Box | =
IZ;'._Z:Z' Mext = ] |_ Finish ,\}_J [ Cancel
I
5. Click Next
6. Click Finish.
7. You will observe your project created under the Nios C/C++ Projects

Tab. See Figure 4-3.
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Figure 4-3. Listing of Your Project under Nios Il C/C++ Project Tab

H-==

! Mios IT CfC4++ Projects X

=3 5 [CDAC_DEZ_Board

ADCDAC_DEZ _Board_syslib [System_Top

8. Sdlect the Project (ADCDAC_DE2 Board). Right Click and hit
Import. See Figure 4-4.

Figure 4-4.Importing File System
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= vs

(= Team

@ < Back | Mext = ] Finish

Cancel

9. You will now be asked for the details of the file to be imported.

*  You haveto select the file system as shown in Figure 4-4.
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Figure 4-5.

Click Next. You will see theimport dialog box as shownin

Figure 4-5. Import Dialog Box

. Import

File system

Source must not be emply,

From directary:

| ——
A4 | ! Browsml

Into folder: | ADCDAC_DEZ_Board

| [ Browse. ..
Options
|:| Overwrite existing resources without warning
(O Create complete Folder structure
(®) Create selected Folders anly

System Level Solutions

software. See Figure 4-6.

Browseto SLS ADC-DAC_BoardADCDAC_Reference Designg/

Click OK. You will return back to Import Wizard.
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Figure 4-6. Asking for Details of the files to be imported

Import from directory

Select a directary ba impart Fram.

= [5) 5L5_ADC-DAC_Board
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3

|

Folder: | Software |

[ Make Mew Folder ]

(4 Cancel ]

10. Select the sc_adcdac_app.c file in the template by checking the box.
See Figure 4-7.

11. Click Finish.
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Figure 4-7. Asking for Details of the files to be imported

. Import fgl

File system
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12. Observe the inserted sc_adcdac_app.c file template in the application
list. See Figure 4-8.
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Building the
Project

Figure 4-8. Inserted C file template in the application list

! Mios IT CfC4++ Projects X

=

=125 ADCDAC_DEZ_Board
= sethings
@ st_adcdac app.c
\=| cdtbuild
\=| cdtproject
project
|=| application, skfF
readme. bxt
=% ADCDAC_DEZ_Board_syslib [System_Top

You can browse through the contents of the file by double clicking the file
Namein the list.

After successful creating yourproject, its now time to build your project. To
build your project follow steps below:

1. Rightclick the Name of the Project and select “ Build Project” to build
your project. See Figure 4-9.

50

Designing ADC-DAC System from Scratch for DE2

System Level Solutions



Running the Software in Nios Il IDE

Running the
Project

Figure 4-9. Build Project
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5 ADCD Mew )
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Cpen in New Window

Rebuild Index
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Debug As '

Clean Praojeck

2. You will observe the window. See Figure 4-10.

Figure 4-10. Build Process

Build Project
i ) Operation in progress...

IBuiIding ADCDAC_DEZ Board... |
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After building the project successfully, its now time to run the project on the
hardware. There are two ways to run your project.

1. Select Run > Run.. asshownin Figure 4-11.
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Figure 4-11. Run Option

. Nios Il C/C++ - sc_adcdac_app.c - Nios I IDE
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2. 1t will pops up Run Dialog Box as shown in Figure 4-12.
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Figure 4-12.Run Dialog Box

= E CiC++ Local Application

E Debug hello_world_S.e

; E Debug hello_world_S.e

E Debug hello_world_S.e

E Debug hello_world_S.e

: E Debug hello_world_S.e

= m Mios I Hardware

% blank_project_0 Mios 1T

m hella_world_0 Mios ITH

m hella_world_1 Mios ITH

; m hella_world_2 Mios ITH

ﬁ hella_world_3 Mios ITH

m hella_world_4 Mios ITH

! m hella_world_4 Mios ITH

m hella_world_5 Mios ITH

% hella_world_7 Mios ITH

m jigar Mios IT HW configl

Mios IT Instruckion Set Sirmu

B nios 11 Modelsim

ﬁ Mios IT Multiprocessor Colle

Mame: | blank_praoject_0 Mios IT HW configuration

Target Conneckion fs’r Debugger EV Source | =] Commen |

Project:

|

i[ Browse. .. ]

Target Hardware

Additional nios2-download arguments:
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3. Under Project, select the Nios || C/C++ Porject by browsing your

ADC-DAC Project.

4. Click on Target Connection Tab. You will seethe Figure 4-13.
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Figure 4-13.Run Dialog- Target Connection Settings
. Run

Create, manage, and run configurations @
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|

b &
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5. Select the target Hardware USB-Blaster [USB-0] under JTAG Cable.
Click Refresh.
6. Click Apply.
7. Click Run.
8. Alternatively you can run the project by Right click the Project and
select Run As> Nios || Hardware. Figure 4-14.
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Figure 4-14. Run As-Nios Il Hardware Selection

! Mios IT C/C++ Projects X

B [y

=5 apcn New r
Go Inka
Open in Mew Window

Rebuild Index
Ackive Build Configuration 4

Debug As ¥ | [EL) Mios TT Instructionst Simulator
Build Project ) Nics T Madelsim
Clean Project r

10.

You will observe the console window as shown in Figure 4-15.

The Console Window asks for the selection of choice from the
following options:

1. Andog To Digital Converter

o 2. Digital To Analog Converter

e 3. Auto Test

e 4 Exit

»  Please enter your choice:

Figure 4-15.IDE Console Output

B Consale X

X% | Gb|[B-r3-=0

¥

huto Test
Exit

bW R

blank_project_0 Mios IT HW configuration [Mios 1T Hardware] Mios IT Terminal Window (7/11/07 6:19 PM)

LR A R R R R R R R R R R R R R R R R R R R R R R R R

o o o o o o o o o o o o o o o o ol o o o o o o o o o o o
Please select any option from the following:

Analog To Digital Converter
Digital To Analog Converter

Fleasze enter your choice : 3

*F ~

|
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11. If you select Option 1 and press enter, following message will be
displayed. See Figure 4-16.

Figure 4-16.Analog to Digital Selection Console Window

i E- 5. =0

=R @ ||

¥ ~

£ Analog To Digital Converter
*E

EE
LR R R X R X X R R R R R R R R

o o o o o o o o o o ol o ol ol o o ol ol o ol o o o o o o o
Please read the instructions before driwving ADC.

—-> Please give analog input to the Snap-on Board.

—» Input sample range is in between 0 to 400000.

—» Enter -1 to return to Previous menu.

Please enter the input sample nunbers: I =

B Givetheanalog input at pin INO and connect GND_ADC to ground.
®  Enter analoginput sample number and pressEnter. You shall seethe
sample values displayed.

m  Following figure shows the output window for 5V DC anal og input
at INO and 200 samples as anal og input sample number.
See Figure 4-17.

Here each reading is displayed after 10 samples. It shows the average value
of 10 sample. Therefore only 20 readings are displayed here.
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Figure 4-17.Analog to Digital Output Console Window

B bl || E-r3-=0

blank_project_0 Mios IT HW configuration (1) [Mios IT Hardware] Mios 1T Terminal Window (7/23/07 6:53 PM)
i e e e e

Please enter the input sample numbers:z200
ffolt : 5.000000

Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Wolt @ 5.000000
Volt 5.000000
Volt 5.000000
Volt 5.000000
Volt 5.000000
Volt 5.000000
Volt S5.000000
Volt 5.000000
Volt 5.000000
Volt 5.000000
Volt 5.000000

12. If you select Option 2 and press enter, it will display the following

message. See Figure 4-18.

Figure 4-18.Digital to Analog Selection Console Window

S TR g S
Ex @i |_fiE'i=:' g
blank_project_0 Mios IT HW configuration (1) [Nios IT Hardware] Mios IT Terminal Window (7/23/07 6:53 PM)
T Digital To Analog Converter w* ~
*E *E
o o o o o o o o ol o i i ol ol ol o i o ol o o o o o o o
o o o o o o o o o o o o o o o ol o o o o o o o o o o o
Please read the instructions before driwving DAC.
—>» Input range is in between 0 to 255.
—» Enter -1 to return to Previous menu.
Please enter Input walues: 1 I .

B Givethedigita input signal range between 0 to 255 and press Enter
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®  Theanalog output can be measured at IOUT_n pin and you can see

the display as shown in Figure 4-19.

Figure 4-19.Digital to Analog Output Console Window

B Consale X

S B ] & O
L] Gk pB ||A|B-C35- =0
blank_project_0 Mios IT HW configuration (1) [Mios IT Hardware] Mios 1T Terminal Window (7/23/07 6:53 PM)
”~
Please enter Input wvalues: 1
Command Succesfully Executed.
Tou can measure output from Snap-On Board.
o o o o o o o o o i o o ol o o o o o o o o o o
o o o o o o o o o o o o o o o o o o o
*E *E
s ADC DAC T
T w T E £V

13. If you select Option 3 and press enter, following message will be

displayed. See Figure 4-20.

Figure 4-20.Auto Test Selection Console Window

B Consale X

® Be bl [f]B-r5- =0

Iankroject_ﬂ Mios IT HW configuration (1) [Mios IT Hardware] Mios 1T Terminal Window (7/23/07 6:53 PM)

o o o o o o o o o o o o o o o o o ol o o o o o o o o
o o ol o ol o o ol ol ol o i o o ol o i o ol o i o o o o o o o
Please read the instructions before driving Auto Test.

—-> Prepare Snap-on to LoopBack Before Auto Test.
Press 1 for Auto Test.

—» Enter -1 to return to Previous menu.

Flease Enter choice: I

Thisisan AUTO TEST that requires aloop back connection
make the connections as mentioned bel ow.

m  Connect IOUT _ni.e. output of the DAC to the INOi.e. input of the

ADC. forming aloop.
m  Connect the GND_ADC to ground

Therefore,
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m  After successful connection, you will be able to see the following
window. See Figure 4-21.

Figure 4-21.Auto Test Output Console Window

B Console X & % RO |=}.= B - Fi- =7
Iankroject_ﬂ Mios IT HW configuration (1) [Mios IT Hardware] Mios 1T Terminal Window (7/23/07 6:53 PM)
i Analog Input Digital Cutput 3 L
o o o o o ol ol o o o ol ol o o ol ol o o ol ol o o ol ol o o ol o o o o

0.294118 a

0.196078 I 30

0.274510 &0

0.509304 S0

0.5858235 1z0

0.5490z0 150

0.5858235 1z0

0.509504 a0

0.274510 &0

0.196078 30

0.294118 a =

14. If you select Option 4, it will exit form the procedure of conversion.

- For details on the hardware for ADC-DAC Board refer to the ADC-DAC
Board Reference Manual.
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