Infineon XENSIV™ - Getting Started Box IoT
Quick Start Guide

Veronika Stellwag (IFAG DES TCP EDS)
Julian Eder (IFAG DES TCP EDS)
Tobias Bukowski (IFAG ATV SC M)

May 2019
## Agenda

<table>
<thead>
<tr>
<th></th>
<th>Agenda</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>The Box</td>
</tr>
<tr>
<td>3</td>
<td>Content of the box</td>
</tr>
<tr>
<td>4</td>
<td>XMC™ 2Go and XMC1100 Boot Kit</td>
</tr>
<tr>
<td>5</td>
<td>ESP32 WEMOS D1 MINI</td>
</tr>
<tr>
<td>6</td>
<td>TLV493D 3D Sense Shield2Go</td>
</tr>
<tr>
<td>7</td>
<td>DPS310 Pressure Shield2Go</td>
</tr>
<tr>
<td>8</td>
<td>TLI4970 Current Sense Shield2Go</td>
</tr>
</tbody>
</table>
Agenda

9. IM69D130 Microphone Shield2Go
10. OPTIGA™ Trust E Security Shield2Go
11. Dual-Adapter Trust-X
12. My IoT Adapter for Arduino Uno
13. Arduino: The Arduino IDE
14. „Hello World“ Example with the 3D Magnetic Sensor
Look and feel
Infineon XENSIV™ - Getting Started Box IoT

- DPS310
- TLV493D-A1B6
- IM69D130
- Joystick
- XMC™ 2Go
- OPTIGA™ Trust E
- XMC 1100 Boot Kit
- My IoT Adapter
- Rotate Knob
- Dualadapter equipped with OPTIGA™ Trust X
- MH-ET Live ESP32 Minikit
Hardware ingredients
Overview – what’s inside

› Microcontrollers
  • [XMC 1100 Boot Kit](#) – 32-bit Microcontroller based on ARM® Cortex®-M in Arduino Uno formfactor
  • 2x [XMC™ 2Go](#) – 32-bit Microcontroller based on ARM® Cortex®-M in Shield2Go formfactor
  • [MH-ET Live ESP32 Minikit](#) – Wemos formfactor including BLE and WIFI functionality

› Sensors (XENSIV™) and Security ICs in Shield2Go formfactor
  • [XENSIV™ TLV493D-A1B6](#) – 3D Magnetic Hall Sensor
  • [XENSIV™ DPS310](#) – Barometric Pressure Sensor for consumer
  • [XENSIV™ TLI4970-D050T4](#) – Current Sensor with integrated current rail
  • [XENSIV™ IM69D130](#) – Digital MEMS Silicon Microphone
  • [OPTIGA™ Trust E](#) – Hardware Security Chip
  • [Dualadapter](#) – Adapter with Wemos formfactor for Infineon Shield2Go - equipped with Security IC

› Accessories
  • [My IoT Adapter](#) – Triple Adapter for Infineon Shield2Go with Arduino Uno formfactor
  • USB-Cable
  • Solderless Connectors
  • [Rotate Knob](#) – Add on component for 3D Magnetic Hall Sensor
  • [Joystick](#) - Add on component for 3D Magnetic Hall Sensor
XMC™ 2Go XMC1100 and XMC1100 Boot Kit
Facts and figures

Kit Name: XMC1100 Boot Kit
• ARM® Cortex®-M0, 32 MHz, 64 MHz Timer clock
• 64 kB flash and 16 kB RAM
• USIC with UART, SPI, I2C, I2S, LIN
• 6 Channel 12 Bit ADC, 4x 16 Bit Timer, Real Time Clock
• On-board J-Link Debugger

2GO kit Name: XMC™ 2Go
• Shield2Go formfactor
• ARM® Cortex®-M0, 32 MHz, 64 MHz Timer clock
• 64 kB flash and 16 kB RAM
• USIC with UART, SPI, I2C, I2S, LIN
• 6 Channel 12 Bit ADC, 4x 16 Bit Timer, Real Time Clock
• On-board J-Link Debugger

For more information on the product:
› XMC1100 Boot Kit
› XMC™ 2Go
XMC™ 2Go XMC1100 and XMC1100 Boot Kit Installation instructions

• To add support for the XMC microcontroller series to your Arduino IDE please follow this guide. If you have already installed the XMC package in your Arduino IDE, consider updating it via the Board Manager.

• Full documentation
  • Please refer to the official XMC™ 2Go or XMC1100 Boot Kit repository for a full documentation.

• Important Notes – female pin headers
  • Please note that the female pin headers given in the box do not fit for the XMC™ 2Go!
  • They can be solely used for the XMC1100 Boot Kit and the My IoT Adapter

Example:
Stacked XMC1100 Boot Kit with My IoT Adapter

Example:
XMC™ 2Go stacked with the IM69D MEMS Microphone Shield2Go
**Product Name: MH-ET Live ESP32 Minikit**

- 2.4 GHz Wi-Fi (IEEE 802.11 b/g/n built in)
- Bluetooth (v4.2 BR/EDR and BLE)
- 2*Tensilica Xtensa LX6
- 520kByte SRAM/ 16kByte RTC SRAM
- Frequency 80MHz/160MHz/ 240MHz
- 34 GPIOs + Timers 4*64bit
- Operating voltage 2.5-3.6V
- Compatible with Dual Adapter for WEMOS

**For more information on the product:**
- MH-ET Live ESP32 Minikit

Terms of use

Hyperlinks
The Slide set may contain hyperlinks to web sites of third parties. Infineon shall have no liability for the contents of such web sites and does not make representations about or endorse such web sites or their contents as its own, as Infineon does not control the information on such web sites and is not responsible for the contents and information given thereon. The use of such web sites shall be at the sole risk of the user.
ESP32 WEMOS D1 MINI
Installation instructions

• **Step One:** Paste the following URL into the ‘Additional Boards Manager URLs’ input field under **File > Preferences** to add the ESP32 boards to the Arduino IDE.

  https://dl.espressif.com/dl/package_esp32_index.json

• **Step Two:** To install the boards, please navigate to **Tools > Board > Boards Manager** and search for ESP32.

• **Step Three:** You will find options to install the board files for the microcontrollers. Click “Install” to add the boards to your Arduino IDE.

• **Step Four:** In the boards list **Tools > Board**, the ESP32 microcontroller boards are added and can be used from now on. For the ESP32 WEMOS D1 MINI choose the board **MH ET LIVE ESP32MINIKit**.
Shield2Go Name: TLV493D 3DSense Shield2Go

- TLV493D-A1B6
- 3D magnetic hall sensor
- Bx, By and Bz linear field measurement up to ±130 mT
- Low current consumption: 10 µA in ultra low power mode
- I2C interface
- Add ons: Joystick and rotate knob

For more information on the product:
- [Product page TLV493D 3DSense Shield2Go](#)
- [Product page TLV493D-A1B6](#)
Add ons for TLV493D-A1B6
Facts and figures

Important note

The TLV493D-A1B6 3D magnetic sensor family has so called “add ons”, such as the joystick and the rotate knob. Infineon is thereby offering a unique customer experience. It offers our customers the opportunity of fast prototyping. No need to care about the magnetic design and the mechanical layout of typical 3D magnetic applications such as joysticks. Just plug and play. Both, joystick and rotate knob, can be directly mounted on top of the TLV493D 3DSense Shield2Go

- **Rotate knob** with magnet as used in control elements and push buttons
- Use cases 3D magnetic sensors: rotational and vertical movements of control elements and push buttons
- **Joystick** with magnet
- Use case: 3 dimensional movements of Joysticks

Example:

XMC™ 2Go stacked with the TLV493D 3DSense Shield2Go and rotate knob
Shield2Go Name: TLV493D 3DSense Shield2Go

• Library installation
  • Download the latest release as ZIP archive from here. In your Arduino IDE navigate to Sketch > Include Library > Add .ZIP Library ... And choose the downloaded ZIP archive.

• Examples
  • For example sketches navigate to File > Examples, scroll down to "Examples from Custom Libraries" and choose one of the examples in TLV493D-A1B6.

• Full documentation
  • Please refer to the official TLV493D-A1B6 3D Sense Shield2Go repository for a full documentation.
DPS310 – Digital Barometric Pressure Sensor
Facts and figures

Shield2Go Name: DPS310 Pressure Shield2Go

- Miniaturized digital barometric air pressure sensor
- High precision +/- 0.005 hPa (or +/- 0.05 m)
- Low power consumption: 1.7 µA for pressure measurement, 1.5 µA for temperature measurement
- Typical applications: indoor navigation, health and sports, outdoor navigation, weather station, multicopter
- I2C and SPI interface

› For more information on the product:
  › Product page DPS310 Pressure Shield2Go
  › Product page DPS310
DPS310 – Digital Barometric Pressure Sensor
Installation instructions

Shield2Go Name: DPS310 Pressure Shield2Go

• Automatic library installation via the library
  • In your Arduino IDE navigate to Sketch > Include Library > Manage Libraries and search for DPS310. Install the library.

• Manual library installation
  • Download the latest release as ZIP archive from here. In your Arduino IDE navigate to Sketch > Include Library > Add .ZIP Library and choose the downloaded ZIP archive.

• Examples
  • For example sketches navigate to File > Examples, scroll down to “Examples from Custom Libraries” and choose one of the examples in DPS310.

• Full documentation
  • Please refer to the official DPS310 Pressure Shield2Go repository for a full documentation.
TLI4970-D050T4 Current Sensor
Facts and figures

Shield2Go Name: TLI4970 Current Sense Shield2Go

- Accurate coreless magnetic current sensor
- Differential measurement principle: stray field suppression
- AC & DC measurement range up to +/- 50 A
- Typical applications: current monitoring, chargers, photovoltaic & general purpose inverters, power supplies, electrical drive
- SPI interface

› For more information on the product:
  › Product page TLI4970 Current Sense Shield2Go
  › Product page TLI4970-D050T4
TLI4970-D050T4 Magnetic Current Sensor
Installation instructions

**Shield2Go Name: TLI4970 Current Sense Shield2Go**

- **Library installation**
  - Download the latest release as ZIP archive from [here](#). In your Arduino IDE navigate to **Sketch > Include Library > Add .ZIP Library** and choose the downloaded ZIP archive.
  - **Important note**: Please install the One Wire library from Paul Stoffregen before you install or use the library for the TLI4970-D050T4 Current Sensor. You can find the One Wire library in the **Library Manager** in the Arduino IDE **Sketch > Include Library > Manage Libraries**.

- **Examples**
  - For examples sketches navigate to **File > Examples**, scroll down to “**Examples from Custom Libraries**” and choose one of the examples in TLI4970.

- **Full documentation**
  - Please refer to the official [TLI4970 Current Sense Shield2Go repository](#) for a full documentation.
IM69D130 MEMS Microphone
Facts and figures

**Shield2Go Name: IM69D130 Microphone Shield2Go**

- Dynamic range of 105dB
- Signal to noise ratio of 69dB(A) SNR
- <1% total harmonic distortions up to 128 dBSPL
- Acoustic overload point at 130dBSPL
- Sensitivity (±1dB) and phase(±2° @1kHz) matched
- Flat frequency response with low-frequency roll-off at 28Hz
- Very fast analog to digital conversion speed (6µs latency @1kHz)

› For more information on the product:
  › Product page IM69D130 Microphone Shield2Go
  › Product page IM69D130
IM69D130 MEMS Microphone
Installation instructions

Shield2Go Name: IM69D130 Microphone Shield2Go

• The IM69D is a I2S (Inter-IC-Sound) device and does not need a special library. It works out-of-the-box with the XMC microcontroller series. The ESP32 is not yet natively supported.

• Examples
  • For example sketches navigate to File > Examples, scroll down to “Examples for XMC1100...” (depens on which board you have chosen) and choose one of the examples in I2S.

• Full documentation
  • Please refer to the official IM69D MEMS Microphone Shield2Go repository for a full documentation.
Optiga™ Trust E Security Controller

Facts and figures

Shield2Go Name: OPTIGA™ Trust E Security Shield2Go

- High-end security controller
- Turnkey security solution
- I2C interface
- Cryptographic support: ECC256, SHA-256
- Typical applications: industrial control and automation, consumer electronics, smart home, medical devices, IoT

For more information on the product:
- Product page OPTIGA™ Trust E Security Shield2Go
- Product page OPTIGA TRUST E SLS 32AIA
Shield2Go Name: OPTIGA™ Trust E Security Shield2Go

• Library installation
  • Download the latest release as ZIP archive from here. In your Arduino IDE navigate to Sketch > Include Library > Add .ZIP Library and choose the downloaded ZIP archive.

• Examples
  • For example sketches navigate to File > Examples, scroll down to “Examples from Custom Libraries” and choose one of the examples in OPTIGATrustE.

• Full documentation
  • Please refer to the official Optiga™ Trust E Shield2Go repository for a full documentation.
Important note
The Dual-Adapter Trust-X is an adapter exclusively designed for the Getting started Box Iot. It eases the combination of Infineon Shield2Go boards with WEMOS formfactor microcontroller board. The adapter is equipped with an OPTIGA™ Trust X security controller and pre-soldered female pinheaders.

- Board compatible with MH-ET Live ESP32 Minikit in WEMOS formfactor
- Integrated High-end security controller OPTIGA™ Trust X
- Mutual authentication using DTLS client (IETF standard RFC 6347)
- Compliant with the USB Type-C™ Authentication standard
- I2C interface
- Up to 10 KB user memory
- Cryptographic support: ECC256, AES128, SHA-256, TRNG, DRNG
- Tool to connect your sensor applications with the Internet of Things

For more information on the product:
  - Product page OPTIGA TRUST X SLS 32AIA
Dualadapter for WEMOS with OPTIGA™ Trust X
Installation instructions

• **OPTIGA™ Trust X security controller is designed onto the Dualadapter**
  - Automatic library installation via the Library Manager
    - In your Arduino IDE navigate to Sketch > Include Library > Manage Libraries and search for OptigaTrustX. Install the library.
  - Manual library installation
    - Download the latest release as ZIP archive from [here](#). In your Arduino IDE navigate to Sketch > Include Library > Add .ZIP Library and choose the downloaded ZIP archive.

• **Examples**
  - For example sketches navigate to File > Examples, scroll down to “Examples from Custom Libraries“ and choose one of the examples in OPTIGATrustX.

• **Full documentation**
  - Please refer to the official [Optiga™ Trust X repository](#) for a full documentation.
My IoT Adapter for Arduino Uno
Facts and figures

**Shield2Go Name: My IoT Adapter**

- Board compatible with Arduino Uno formfactor
- 3 available slots for combining Shield2Go boards
- On-board level shifters from 3.3 V to 5 V and vice versa
- On-board voltage converter to support applications with more power demand
- Compatible with all shields for Arduino enabling connectivity, e.g. LTE, Bluetooth, WiFi, etc.
- Tool to connect your sensor applications with the Internet of Things

› **For more information on the product:**
  › [Product page My IoT Adapter](#)
My IoT Adapter for Arduino Uno
Installation instructions

**Shield2Go Name: My IoT Adapter**

- Open one of the examples for the Shield2Go Adapter with **File > Open**... And select the used board - more information can be found [here](#).
  
  - Connect the stacked boards to the PC and press the **Upload** button.
  
- Full documentation

- Please refer to the official **My IoT Adapter repository** for a full documentation.

**Example:**

XMC1100 Boot Kit stacked with the My IoT Adapter, the TLV493D 3D Sense Shield2Go and the TLI4970 Current Sense Shield2Go

Female headers used on XMC 1100 bootkit and My Iot Adapter

Male headers used for connecting the Shield2Go
Please download and install the Arduino IDE from here.

- Installation Details for Windows: Click here
- Installation Details for Mac OS: Click here
- Installation Details for Linux: Click here
- Installation Details for Portable IDE: Click here

Arduino Quick Start

- What is Arduino? Click here
- Extended information about the Arduino environment. Click here
- How to import libraries? Click here
- How to install additional boards? Click here
- Problems related to Arduino? Click here for troubleshooting
TLV493D 3DSense Shield2Go
Application Example

Hardware preparation

• Put the solderless pin headers from the bottom side in the 3DSense Shield2Go. Leave the marked pins free.

• Stack the Shield2Go on a XMC™ 2Go like shown in the picture.

• Mount either the Joystick or the Rotation Knob on top of the 3DSense Shield2Go.

• You are now ready for the software part (next slide)
Library installation

• Please download the latest release of the TLV493D Arduino library as ZIP archive from here.

• Switch to your Arduino IDE and navigate to Sketch > Include Library > Add .ZIP Library and choose the downloaded ZIP archive.
Serial port selection

• Now connect your XMC™ 2Go via USB to your computer and select the corresponding serial port in your Arduino IDE

Tools > Port > COM...

• If you are not sure, which COM port number is the correct one, disconnect the XMC™ 2Go and observe, which COM port disappears from the menu (re-open menu to update port list).
TLV493D 3DSense Shield2Go
Application Example

Flashing an example

• In your Arduino IDE, navigate to 
  File > Examples, scroll down to “Examples from Custom Libraries” and, in TLV493D-A1B6, choose one of the examples (e.g. “Cartesian”).

• Flash the example sketch to the XMC™ 2Go using the Upload button of the Arduino IDE.

• Open the Serial Monitor
  Tools > Serial Monitor to read out your first measurements.

• For full documentation please refer to the official TLV493D-A1B6 3D Sense Shield2Go repository.
Support Material
For XENSIV™ Getting Started Box IoT

Collaterals and Brochures
- Product Briefs
- Selection Guides
- Application Brochures
- Presentations
- Press Releases

Technical Material
- Application Notes
- Technical Articles
- Simulation Models
- Datasheets

- Product page - GET START BOX IOT
- Product page S2GO PRESSURE DPS310
- Product page S2Go Security OPTIGA™ Trust E
- Product page S2Go Security OPTIGA™ Trust X
- Product page S2GO MEMSMIC IM69D
- Product page S2GO_CUR-SENSE_TLI4970
- Product page S2GO_3D-SENSE_TLV493D
- Product page KIT_XMC_2GO_XMC1100_V1
- Product page KIT_XMC11_BOOT_001
- Product page My_IoT Adapter
- Product page Joystick for 3D 2GO kit
- Product page Rotate knob for 3D 2GO kit
- Infineon for Makers – Shield2Go Overview
- Product brochure-Shield2Go
- XENSIV™ – sensing the world - Selection Guide
- XENSIV™ – sensing the world Pocket guide 2018
- XENSIV™ – Sensor 2GO kits and Shield2Go
- OPTIGA™ Trust family – embedded security solutions
- XMC™ microcontroller family

- Whitepaper for Shield2Go boards and My IoT adapter
- Quickstart S2GO PRESSURE DPS310
- Quickstart S2Go Security OPTIGA™ Trust E
- Quickstart S2Go Security OPTIGA™ Trust X
- Quickstart S2GO MEMSMIC IM69D
- Quickstart S2GO_CUR-SENSE_TLI4970
- Quickstart S2GO_3D-SENSE_TLV493D
- XENSIV™ Magnetic Design Tool
- XENSIV™ 3D Magnetic Sensor for Angle Measurement
- How to Make a Magnetic Design for Joysticks
- Whitepaper – securing the smart and connected home
- Roadtest of Shield2Go and My IoT Adapter
Support Material
For XENSIV™ Getting Started Box IoT

Videos
› Technical Videos
› Product Information
› Videos
› Trainings

› Ping-Pong game with XENSIV™ DPS310
› XENSIV™ 3D Magnetic Sensor: 2GO kit vs Shield2Go
› XENSIV™ DPS310 pressure Shield2Go – How to
› XENSIV™ IM69D130 microphone Shield2Go – Get studio recording quality
› Smart Home – Completely built with Shield2Go
Part of your life. Part of tomorrow.