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CHAPTER 1: SPECIFICATIONS

CHAPTER 1:

1.1	 SPECIFICATIONS

TABLE 1-1. SPECIFICATIONS

SPECIFICATION DESCRIPTION

Fiber Optic Switch Connectors

Console Ports: 
   (16 - 160) LC duplex fiber optic ports 
   (2) Network ports 
   (2) Power supply 
   (1) Grounding

Cat-X Switch Connectors

Console Ports: 
   (16 - 160) Cat-X ports 
   (2) Network ports 
   (2) Power supply 
   (1) Grounding

LED interface 1. To show PC port selection status 
2. To show PC port connection status

Storage Temperature -25 to 60 °C (-13 to 140 °F)

Operating Temperature 5 to 45 °C (41 to 113 °F)

Max Operating Humidity Max. 80% non-condensing

Heat Dissipation Corresponds to power consumption in Watt (W)

Power
Input: 100-240 VAC, 3A, 50/60Hz

Output: 12V, 12.5A

Dimensions 1RU chasis 442 x 449 x 44 mm(17.4” x 17.7” x 1.7”)

Dimensions 2RU chasis 442 x 449 x 90 mm (17.4” x 17.7” x 3.5”)

Dimensions 4RU chasis  442 x 449 x 177 mm (17.4” x 17.7” x 7.0”)

Weight 1 RU Chasis 7.7 kg (17 lb)

Weight 2 RU Chasis 11 kg (24.3 lb)

Weight 4 RU Chasis 19 kg (41.9 lb)

Certifications FCC Class A, CE
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CHAPTER 2:

2.1	 INTRODUCTION

The DKM Compact II KVM Matrix Switches come in sizes of 1, 2, and 4 RU with the intended use to establish connections from con-
soles (monitor, keyboard, mouse, and other peripheral devices) to various sources (computer, CPU). These switches support the capa-
bility to facilitate 1G and 3G technology within a single frame, they support modern applications with a combination of HD and 4K 
video resolutions in a very economical way. Their custom-design chassis allows for future field upgradability, so you can scale your 
system from 40 ports to 80 ports or even up to 160 ports to meet your business needs. CATx DKM Switches enable you to extend 
KVM signals up to 140 meters (459 feet) over standard CATx cable. If you’re using CATx 3G, you can extend signals up to 100 meters 
(328 feet). Fiber DKM Switches enable you to extend KVM signals up to 400 meters (1312 feet) over standard multimode fiber or even 
10 kilometers (6.2 miles) over single mode fiber. Hybrid DKM Switches enable you to extend KVM signals up to 10 kilometers (6.2 
miles) over singlemode fiber or 400 meters (1312 feet) over multimode fiber. They also allow you to extend KVM signals up to 140 
meters (459 feet) over standard CATx cable. If you’re using CATx 3G, you can extend signals up to 100 meters (328 feet). If one of 
these standard switches don’t meet your requirements, we can create custom versions specific to your application.

2.2	 FEATURES

 � Choose catx, fiber, or mixed configurations for 1g or 3g

 � Maximum configuration of up to 160 independent ports that can be defined and switched either as a console or cpu

 � Compatible with upcoming 1g/3g, ipv6

 � Modular design is easy to scale and maintain

 � Compatible with all Black Box DKM kvm extenders

 � Has redundant power supply unit and network interface connections

 � Versatility: with only 3 types of chassis and only 5 types of i/o modules, an almost endless number of customer specific Black Box 
matrix switches are possible

2.3	 WHAT’S INCLUDED

Your package should contain the following items. If anything is missing or damaged, contact Black Box Technical Support  
at 877-877-2269 or info@blackbox.com

 � (1) 1,2, or 4 RU DKM Compact II Matrix Switch

 � (2) IEC 320, C13 to 3 Prong, Power Cords w/ Locking mechanism (6.5 feet)

 � (1) Pair of mounting ears

 � (1) 4-Pack of rubber feet (1) DB9-F to RJ45 adapter

CHAPTER 2: OVERVIEW
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2.4	 INSTALLATION EXAMPLES

SingleHead Installation.
 
The following section shows common installation configurations of the DKM.

 
 
 

Figure 2-4.1 Installation Example (example Single-head installation)

TABLE 2-4.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Source (computer, CPU) Source machine examples: computer, CPU 

2 CPU Units CPU Units

3 Interconnected cable Interconnected cable to connect devices to switch

4 DKM Compact II KVM Matrix Switch DKM Compact II KVM Matrix Switch

5 CON Units Console Units

6 Console (monitor, keyboard, mouse) Console units examples: monitor, keyboard, mouse

CHAPTER 2: OVERVIEW
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Single-Head Installation with Multi-Screeen Control

When using Multi-Screen Control, switching control between up to eight connected sources (computers,

CPUs) can be performed at one sink with only one connected mouse or keyboard. In a Single-Head

installation, the sink can consist of up to eight monitors. In a matrix system, Multi-Screen Control can be set

up at multiple sinks. 

Figure 2-4.2 Installation Example (example Single-head installation)

TABLE 2-4.2. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Source (computer, CPU) Source machine examples: computer, CPU 

2 CPU Units CPU Units

3 Interconnected cable Interconnected cable to connect devices to switch

4 DKM Compact II KVM Matrix Switch DKM Compact II KVM Matrix Switch

5 CON Units Console Units

6 Console (monitor, keyboard, mouse) Console units examples: monitor, keyboard, mouse

CHAPTER 2: OVERVIEW
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When using Multi-Screen Control, switching control between up to eight connected sources (computers,
CPUs) can be performed at one sink with only one connected mouse or keyboard. In a Dual-Head
installation, the sink can consist of up to sixteen monitors when operating Dual-Head Sources. In a matrix
system, Multi-Screen Control can be set up at multiple sinks.

Dual-Head Installation with Multi-Screen Control
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 2-4.3 Installation Example (example Single-head installation)

TABLE 2-4.3. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Source (computer, CPU) Source machine examples: computer, CPU 

2 CPU Units CPU Units

3 Interconnected cable Interconnected cable to connect devices to switch

4 DKM Compact II KVM Matrix Switch DKM Compact II KVM Matrix Switch

5 CON Units Console Units

6 Console (monitor, keyboard, mouse) Console units examples: monitor, keyboard, mouse

Keep in mind that any signal source can be switched to any number of monitors that will show the video signal at 
the same time. If required, audio can be switched as well.

CHAPTER 2: OVERVIEW
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2.5	 PRODUCT RANGE - STANDARD SYSTEM

2.5.1	 DKM COMPACT II KVM MATRIX FLEX FIBER 1G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-1G DKM COMPACT II SWITCH  16-PORT, FIBER 1G 1 RU

ACXC24F-1G DKM COMPACT II SWITCH  24-PORT, FIBER 1G 1 RU

ACXC32F-1G DKM COMPACT II SWITCH  32-PORT, FIBER 1G 1 RU

ACXC40F-1G DKM COMPACT II SWITCH  40-PORT, FIBER 1G 1 RU

ACXC48F-1G DKM COMPACT II SWITCH  48-PORT, FIBER 1G 2 RU

ACXC64F-1G DKM COMPACT II SWITCH  64-PORT, FIBER 1G 2 RU

ACXC80F-1G DKM COMPACT II SWITCH  80-PORT, FIBER 1G 2 RU

ACXC120F-1G DKM COMPACT II SWITCH  120-PORT, FIBER 1G 4 RU

ACXC128F-1G DKM COMPACT II SWITCH  128-PORT, FIBER 1G 4 RU

ACXC144F-1G DKM COMPACT II SWITCH  144-PORT, FIBER 1G 4 RU

ACXC160F-1G DKM COMPACT II SWITCH  160-PORT, FIBER 1G 4 RU

2.5.2	 DKM COMPACT II KVM MATRIX FLEX FIBER 3G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-3G DKM COMPACT II SWITCH  16-PORT, FIBER 3G 1 RU

ACXC24F-3G DKM COMPACT II SWITCH  24-PORT, FIBER 3G 1 RU

ACXC32F-3G DKM COMPACT II SWITCH  32-PORT, FIBER 3G 1 RU

ACXC40F-3G DKM COMPACT II SWITCH  40-PORT, FIBER 3G 1 RU

ACXC48F-3G DKM COMPACT II SWITCH  48-PORT, FIBER 3G 2 RU

ACXC64F-3G DKM COMPACT II SWITCH  64-PORT, FIBER 3G 2 RU

ACXC80F-3G DKM COMPACT II SWITCH  80-PORT, FIBER 3G 2 RU

ACXC120F-3G DKM COMPACT II SWITCH  120-PORT, FIBER 3G 4 RU

ACXC128F-3G DKM COMPACT II SWITCH  128-PORT, FIBER 3G 4 RU

ACXC144F-3G DKM COMPACT II SWITCH  144-PORT, FIBER 3G 4 RU

ACXC160F-3G DKM COMPACT II SWITCH  160-PORT, FIBER 3G 4 RU

CHAPTER 2: OVERVIEW
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2.5.3	 DKM COMPACT II KVM MATRIX FLEX HYBRID 1G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-1G DKM COMPACT II SWITCH  40-PORT, HYBRID 1G 1 RU

ACXC24FH40-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH24-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH40-1G DKM COMPACT II SWITCH  80-PORT, HYBRID 1G 2 RU

ACXC80FH40-1G DKM COMPACT II SWITCH  120-PORT, HYBRID 1G 2 RU

ACXC80FH80-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

ACXC120FH40-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

2.5.4	 DKM COMPACT II KVM MATRIX FLEX HYBRID 3G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-3G KVM Matrix 40-Port, Hybrid 3G 1 RU

ACXC24FH40-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH24-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH40-3G KVM Matrix 80-Port, Hybrid 3G 2 RU

ACXC80FH40-3G KVM Matrix 120-Port, Hybrid 3G 2 RU

ACXC80FH80-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

ACXC120FH40-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

2.5.5	 DKM COMPACT II KVM MATRIX FLEX GRID CAT X 1G AND FIBER 1G

PART NO. DESCRIPTION RACK UNIT

ACXC40-1G-2RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 2 RU 2 RU

ACXC40-1G-4RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 4 RU 4 RU

ACXC40F-1G-2RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 2 RU 2 RU

ACXC40F-1G-4RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 4 RU 4 RU

ACXC24F16-1G-2RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 2 RU 2 RU

ACXC24F16-1G-4RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 4 RU 4 RU

CHAPTER 2: OVERVIEW
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2.5.6	 DKM COMPACT II KVM MATRIX FLEX HYBRID 1G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-1G DKM COMPACT II SWITCH  40-PORT, HYBRID 1G 1 RU

ACXC24FH40-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH24-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH40-1G DKM COMPACT II SWITCH  80-PORT, HYBRID 1G 2 RU

ACXC80FH40-1G DKM COMPACT II SWITCH  120-PORT, HYBRID 1G 2 RU

ACXC80FH80-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

ACXC120FH40-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

2.5.7	 DKM COMPACT II KVM MATRIX FLEX HYBRID 3G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-3G KVM Matrix 40-Port, Hybrid 3G 1 RU

ACXC24FH40-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH24-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH40-3G KVM Matrix 80-Port, Hybrid 3G 2 RU

ACXC80FH40-3G KVM Matrix 120-Port, Hybrid 3G 2 RU

ACXC80FH80-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

ACXC120FH40-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

2.5.8	 DKM COMPACT II KVM MATRIX FLEX HYBRID 3G

PART NO. DESCRIPTION RACK UNIT

ACXC40-1G-2RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 2 RU

ACXC40-1G-4RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 4 RU

ACXC40F-1G-2RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 2 RU

ACXC40F-1G-4RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 4 RU

ACXC24F16-1G-2RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 2 RU

ACXC24F16-1G-4RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 4 RU

CHAPTER 2: OVERVIEW
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2.5.9	 DKM COMPACT II KVM MATRIX FLEX FIBER 1G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC24F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC32F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC40F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC48F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC64F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC80F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC120F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC128F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC144F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC160F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

2.5.10	 DKM COMPACT II KVM MATRIX FLEX FIBER 3G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-3G KVM Matrix 16-Port, Cat X 1G 1 RU

ACXC24F-3G KVM Matrix 24-Port, Cat X 1G 1 RU

ACXC32F-3G KVM Matrix 32-Port, Cat X 1G 1 RU

ACXC40F-3G KVM Matrix 40-Port, Cat X 1G 1 RU

ACXC48F-3G KVM Matrix 48-Port, Cat X 1G 2 RU

ACXC64F-3G KVM Matrix 64-Port, Cat X 1G 2 RU

ACXC80F-3G KVM Matrix 80-Port, Cat X 1G 2 RU

ACXC120F-3G KVM Matrix 120-Port, Cat X 1G 4 RU

ACXC128F-3G KVM Matrix 128-Port, Cat X 1G 4 RU

ACXC144F-3G KVM Matrix 144-Port, Cat X 1G 4 RU

ACXC160F-3G KVM Matrix 160-Port, Cat X 1G 4 RU

CHAPTER 2: OVERVIEW
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2.5.11	 2.5.1 DKM COMPACT II KVM MATRIX FLEX HYBRID 1G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-1G DKM COMPACT II SWITCH  40-PORT, HYBRID 1G 1 RU

ACXC24FH40-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH24-1G DKM COMPACT II SWITCH  64-PORT, HYBRID 1G 2 RU

ACXC40FH40-1G DKM COMPACT II SWITCH  80-PORT, HYBRID 1G 2 RU

ACXC80FH40-1G DKM COMPACT II SWITCH  120-PORT, HYBRID 1G 2 RU

ACXC80FH80-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

ACXC120FH40-1G DKM COMPACT II SWITCH  160-PORT, HYBRID 1G 4 RU

2.5.12	 2.5.2 DKM COMPACT II KVM MATRIX FLEX HYBRID 3G

PART NO. DESCRIPTION RACK UNIT

ACXC24FH16-3G KVM Matrix 40-Port, Hybrid 3G 1 RU

ACXC24FH40-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH24-3G KVM Matrix 64-Port, Hybrid 3G 2 RU

ACXC40FH40-3G KVM Matrix 80-Port, Hybrid 3G 2 RU

ACXC80FH40-3G KVM Matrix 120-Port, Hybrid 3G 2 RU

ACXC80FH80-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

ACXC120FH40-3G KVM Matrix 160-Port, Hybrid 3G 4 RU

2.5.13	 2.5.2 DKM COMPACT II KVM MATRIX FLEX HYBRID 3G

PART NO. DESCRIPTION RACK UNIT

ACXC40-1G-2RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 2 RU

ACXC40-1G-4RU DKM COMPACT II SWITCH  40-PORT, CAT X 1G, CUSTOM DESIGN, 4 RU

ACXC40F-1G-2RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 2 RU

ACXC40F-1G-4RU DKM COMPACT II SWITCH  40-PORT, FIBER 1G, CUSTOM DESIGN, 4 RU

ACXC24F16-1G-2RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 2 RU

ACXC24F16-1G-4RU DKM COMPACT II SWITCH  40-PORT, HYBRID 1G, CUSTOM DESIGN 4 RU

CHAPTER 2: OVERVIEW
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2.5.14	 DKM COMPACT II KVM MATRIX FLEX FIBER 1G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC24F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC32F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC40F-1G KVM Matrix 16-Port, Fiber 1G 1 RU

ACXC48F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC64F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC80F-1G KVM Matrix 16-Port, Fiber 1G 2 RU

ACXC120F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC128F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC144F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

ACXC160F-1G KVM Matrix 16-Port, Fiber 1G 4 RU

2.5.15	 DKM COMPACT II KVM MATRIX FLEX FIBER 3G

PART NO. DESCRIPTION RACK UNIT

ACXC16F-3G KVM Matrix 16-Port, Cat X 1G 1 RU

ACXC24F-3G KVM Matrix 24-Port, Cat X 1G 1 RU

ACXC32F-3G KVM Matrix 32-Port, Cat X 1G 1 RU

ACXC40F-3G KVM Matrix 40-Port, Cat X 1G 1 RU

ACXC48F-3G KVM Matrix 48-Port, Cat X 1G 2 RU

ACXC64F-3G KVM Matrix 64-Port, Cat X 1G 2 RU

ACXC80F-3G KVM Matrix 80-Port, Cat X 1G 2 RU

ACXC120F-3G KVM Matrix 120-Port, Cat X 1G 4 RU

ACXC128F-3G KVM Matrix 128-Port, Cat X 1G 4 RU

ACXC144F-3G KVM Matrix 144-Port, Cat X 1G 4 RU

ACXC160F-3G KVM Matrix 160-Port, Cat X 1G 4 RU
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FIGURE 2-6.1. FRONT PANEL - ACXC16-1G & ACXC16-3G

FIGURE 2-6.1.1. FRONT PANEL - ACXC16F-1G & ACXC16F-3G

2.6	 DEVICE VIEWS

2.6.1	 OVERVIEW 16-PORT DKM COMPACT MATRIX SWITCH

Figure 2-6.1 shows the front panel of the 1RU 16-Port DKM Compact Matrix Switch supporting fiber optic. Figure 2-6.1.1 shows 

the front panel of the 1RU 16-Port DKM Compact Matrix Switch supporting Cat-X connection. Figure 2-6.1.2 shows the back panel. 
Tables 2-6.1 and 2-6.1.1 describe the components. 
 

TABLE 2-6.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

3 (1) Network port 1 (RJ45) Network port

4 (1) Network port 2 (RJ45) Network port

5 (1) Reset button Switch Reset
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FIGURE 2-6.1.2. BACK PANEL 16-PORT 

 

TABLE 2-6.1.1. BACK PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

2.6.2	 OVERVIEW 24-PORT DKM COMPACT MATRIX SWITCH

Figure 2-6.2 shows the front panel of the 1RU 24-Port DKM Compact Matrix Switch supporting fiber optic. Figure 2-6.2.1 shows 

the front panel of the 1RU 24-Port DKM Compact Matrix Switch supporting Cat-X connection. Figure 2-6.2.2 shows the back panel. 
Tables 2-6.2 and 2-6.2.1 describe the components.
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FIGURE 2-6.2. FRONT PANEL - ACXC24-1G & ACXC24-3G

FIGURE 2-6.2.1. FRONT PANEL - ACXC24F-1G & ACXC24F-3G

TABLE 2-6.2. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

3 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

4 (1) Network port 1 (RJ45) Network port

5 (1) Network port 2 (RJ45) Network port

6 (1) Reset button Switch Reset
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TABLE 2-6.2.1. BACK PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.2.2 BACK PANEL 24-PORT
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2.6.3	 OVERVIEW 32-PORT DKM COMPACT MATRIX SWITCH

Figure 2-6.3 shows the front panel of the 1RU 32-Port DKM Compact Matrix Switch supporting fiber optic. Figure 2-6.3.1 shows 
the front panel of the 1RU 32-Port DKM Compact Matrix Switch supporting Cat-X connection. Figure 2-6.3.2 shows the back panel. 
Tables 2-6.3 and 2-6.3.1 describe the components. 

 

TABLE 2-6.3. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

3 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

4 (1) Network port 1 (RJ45) Network port

5 (1) Network port (RJ45) Network port

6 (1) Reset button Switch Reset

7 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

FIGURE 2-6.3. FRONT PANEL - ACXC32-1G & ACXC32-3G

FIGURE 2-6.3.1. FRONT PANEL - ACXC32F-1G & ACXC32F-3G
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TABLE 2-6.3.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.3.2 BACK PANEL 32-PORT
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2.6.4	 OVERVIEW 32-PORT DKM COMPACT MATRIX SWITCH WITH GRID

Figure 2-6.4 shows the front panel of the 1RU 32-Port DKM Compact Matrix Switch supporting fiber optic with grid. Figure 2-6.4.1 
shows the front panel of the 1RU 32-Port DKM Compact Matrix Switch supporting Cat-X connection with grid. Figure 2-6.4.2 
shows the back panel. Tables 2-6.4 and 2-6.4.1 describe the components. 
 

TABLE 2-6.4. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

3 (1) Grid port 1 Grid port 1

4 (1) Network port 1 (RJ45) Network port

5 (1) Network port 2 (RJ45) Network port

6 (1) Reset button Switch Reset

7 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

8 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

FIGURE 2-6.4. FRONT PANEL - ACXC32-1G-GRID 

FIGURE 2-6.4.1. FRONT PANEL - ACXC32F-1G-GRID 
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TABLE 2-6.4.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.4.2 BACK PANEL 32-PORT WITH GRID
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2.6.5	 OVERVIEW 40-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-5 shows the front panel of the 1RU 40-Port DKM Compact Matrix Switch supporting fiber optic. Figure 2-6.5.1 
shows the front panel of the 1RU 40-Port DKM Compact Matrix Switch supporting Cat-X connection. Figure 2-6.5.2 
shows the front panel of the 1RU 40-Port DKM Compact Matrix Switch supporting mixed fiber optic and Cat-X connec-
tion ports. Figure 2-6.5.3 shows the back panel. Tables 2-6.5 and 2-6.5.1 describe the components.

TABLE 2-6.5. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

3 (1) Grid port 17 to 24 Grid port 1

4 (1) Network port 1 (RJ45) Network port

5 (1) Network port 2 (RJ45) Network port

6 (1) Reset button Switch Reset

7 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

8 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

 
 

FIGURE 2-6.5. FRONT PANEL - ACXC40-1G & ACXC40-3G

FIGURE 2-6.5.1. FRONT PANEL - ACXC40F-1G & ACXC40F-3G 
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TABLE 2-6.5.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.5.2. FRONT PANEL - ACXC24F16-1G

FIGURE 2-6.5.3 BACK PANEL 40-PORT
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2.6.6	 OVERVIEW 48-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-6.6 shows the front panel of the 2RU 48-Port DKM Compact Matrix Switch supporting fiber optic. Figure 
2-6.6.1 shows the front panel of the 2RU 48-Port DKM Compact Matrix Switch supporting Cat-X connection. Figure 
2-6.6.2 shows the back panel. Tables 2-6.6 and 2-6.6.1 describe the components.

TABLE 2-6.6. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) Grid port 9 to 16 I/O-Ports for connecting devices

4 (1) Grid port 49 to 56 I/O-Ports for connecting devices

5 (1) Grid port 17 to 24 I/O-Ports for connecting devices

6 (1) Grid port 57 to 64 I/O-Ports for connecting devices

7 (1) Network port 1 (RJ45) Network port

8 (1) Network port 2 (RJ45) Network port

9 (1) Reset button Switch Reset

FIGURE 2-6.6. FRONT PANEL - ACXC48-1G & ACXC48-3G 

FIGURE 2-6.6.1. FRONT PANEL - ACXC48F-1G & ACXC48F-3G 
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TABLE 2-6.6.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.6.2 BACK PANEL 48-PORT
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2.6.7	 OVERVIEW 64-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-6.7 shows the front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting fiber optic ports. 
Figure 2-6.7.1 shows the front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting Cat-X connection 
ports. Figure 2-6.7.2 and 2-6.7.3 show the front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting 
mixed fiber optic and Cat-X connection ports. Figure 2-7.4 shows the back panel. Tables 2-6.7 and 2-6.7.1 describe the 
components.

FIGURE 2-6.7 FRONT PANEL - ACXC64-1G & ACXC64-3G 

FIGURE 2-6.7.1. FRONT PANEL - ACXC64F-1G & ACXC64F-3G 
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FIGURE 2-6.7.2. FRONT PANEL - ACXC24F40-1G & ACXC24F40-3G 

FIGURE 2-6.7.3. FRONT PANEL - CXC40F24-1G & CXC40F24-3G
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TABLE 2-6.7. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 1 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

TABLE 2-6.7.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.7.4 BACK PANEL 64-PORT
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2.6.8	 OVERVIEW 80-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-8 shows the front panel of the 2RU 80-Port DKM Compact Matrix Switch supporting fiber optic ports. Figure 
2-8.1 shows the front panel of the 2RU 80-Port DKM Compact Matrix Switch supporting Cat-X connection ports. Figure 
2-8.2 shows the front panel of the 2RU 80-Port DKM Compact Matrix Switch supporting mixed fiber optic and Cat-X 
connection ports. Figure 2-8.3 shows the back panel. Tables 2-8 and 2-8.1 describe the components.

FIGURE 2-6.8. FRONT PANEL -ACXC80-1G & ACXC80-3G 

FIGURE 2-6.8.1. FRONT PANEL -ACXCF80-1G & ACXCF80-3G 
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FIGURE 2-6.8.2. FRONT PANEL -ACXC40F40-1G & ACXC40F40-3G

TABLE 2-6.8. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 2 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

12 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

13 (1) I/O-Ports 73 to 80 I/O-Ports for connecting devices
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TABLE 2-6.8.1 FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.8.3 BACK PANEL 80-PORT
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2.6.9	 OVERVIEW 120-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-6.9 shows the front panel of the 2RU 120-Port DKM Compact Matrix Switch supporting fiber optic ports. Figure 2-9.1 
shows the front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting Cat-X connection ports. Figure 2-9.2 show the 
front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting mixed fiber optic and Cat-X connection ports. Figure 2-9.3 
shows the back panel. Tables 2-9 and 2-9.1 describe the components.

FIGURE 2-6.9. FRONT PANEL -ACXC40F40-1G & ACXC40F40-3G

FIGURE 2-6..9.1. FRONT PANEL -ACXC40F40-1G & ACXC40F40-3G
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FIGURE 2-9.2. FRONT PANEL -ACXC40F40-1G & ACXC40F40-3G

TABLE 2-6.9. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 2 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

12 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

13 (1) I/O-Ports 73 to 80 I/O-Ports for connecting devices

14 (1) I/O-Ports 81 to 88 I/O-Ports for connecting devices

15 (1) I/O-Ports 89 to 96 I/O-Ports for connecting devices

16 (1) I/O-Ports 97 to 104 I/O-Ports for connecting devices

17 (1) I/O-Ports 105 to 112 I/O-Ports for connecting devices

18 (1) I/O-Ports 113 to 120 I/O-Ports for connecting devices
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TABLE 2-6.9.1 FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.9.3 BACK PANEL 120-PORT
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FIGURE 2-6.10 FRONT PANEL - ACXC128-1G & ACXC128-3G

2.6.10	 OVERVIEW 128-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-10 shows the front panel of the 2RU 128-Port DKM Compact Matrix Switch supporting fiber optic ports. Figure 2-10.1 
shows the front panel of the 2RU 64-Port DKM Compact Matrix Switch supporting Cat-X connection ports. Figure 2-10.2 shows 
the back panel. Tables 2-10 and 2-10.1 describe the components.
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FIGURE 2-6.10.1 FRONT PANEL - ACXC128-1G & ACXC128-3G
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TABLE 2-6.10. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 2 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

12 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

13 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

14 (1) I/O-Ports 81 to 88 I/O-Ports for connecting devices

15 (1) I/O-Ports 121 to 128 I/O-Ports for connecting devices

16 (1) I/O-Ports 89 to 96 I/O-Ports for connecting devices

17 (1) I/O-Ports 129 to 136 I/O-Ports for connecting devices

18 (1) I/O-Ports 97 to 104 I/O-Ports for connecting devices

19 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices
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TABLE 2-6.10.1. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.10.2 BACK PANEL 128-PORT
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FIGURE 2-6.11. FRONT PANEL - ACXC80F80-1G & ACXC80F80-3G

2.6.11	 OVERVIEW 144-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-6.11 shows the front panel of the 4RU 144-Port DKM Compact Matrix Switch supporting fiber optic ports. Figure 2-6.11.1 
shows the front panel of the 4RU 144-Port DKM Compact Matrix Switch supporting Cat-X connection ports. Figure 2-6.11.2 shows 
the back panel. Tables 2-6.11 and 2-6.11.1 describe the component.
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FIGURE 2-6.11.1. FRONT PANEL - ACXC144F-1G & ACXC144F-3G
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TABLE 2-6.11. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 1 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

12 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

13 (1) I/O-Ports 73 to 80 I/O-Ports for connecting devices

14 (1) I/O-Ports 81 to 88 I/O-Ports for connecting devices

15 (1) I/O-Ports 121 to 128 I/O-Ports for connecting devices

16 (1) I/O-Ports 89 to 96 I/O-Ports for connecting devices

17 (1) I/O-Ports 129 to 136 I/O-Ports for connecting devices

18 (1) I/O-Ports 97 to 104 I/O-Ports for connecting devices

19 (1) I/O-Ports 137 to 144 I/O-Ports for connecting devices

20 (1) I/O-Ports 105 to 112 I/O-Ports for connecting devices

21 (1) I/O-Ports 113 to 120 I/O-Ports for connecting devices
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FIGURE 2-6.11.2 BACK PANEL 144-PORT
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2.6.12	 OVERVIEW 160-PORT DKM COMPACT MATRIX SWITCH 

Figure 2-6.12 shows the front panel of the 4RU 160-Port DKM Compact Matrix Switch supporting fiber optic ports. Figure 2-6.12.1 
shows the front panel of the 4RU 64-Port DKM Compact Matrix Switch supporting Cat-X connection ports. Figure 2-6.12.2 and 
2-6.12.3 show the front panel of the 4RU 64-Port DKM Compact Matrix Switch supporting mixed fiber optic and Cat-X connection 
ports. Figure 2-6.12.4 shows the back panel. Tables 2-6.12 and 2-6.12.1 describe the components.

FIGURE 2-6.12. FRONT PANEL - ACXC160-1G & ACXC160-3G

FIGURE 2-6.12.1. FRONT PANEL - ACXC160F-1G & ACXC160F-3G
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FIGURE 2-6.12.3 FRONT PANEL - ACXC80F80-1G & ACXC80F80-3G

FIGURE 2-6.12.2 FRONT PANEL - ACXC120F40-1G & ACXC120F40-3G
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TABLE 2-6.12. FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 (1) I/O-Ports 1 to 8 I/O-Ports for connecting devices

2 (1) I/O-Ports 41 to 48 I/O-Ports for connecting devices

3 (1) I/O-Ports 9 to 16 I/O-Ports for connecting devices

4 (1) I/O-Ports 49 to 56 I/O-Ports for connecting devices

5 (1) I/O-Ports 17 to 24 I/O-Ports for connecting devices

6 (1) I/O-Ports 57 to 64 I/O-Ports for connecting devices

7 (1)  Network port 1 (RJ45) Network port

8 (1)  Network port 2 (RJ45) Network port

9 (1) Reset button Switch Reset

10 (1) I/O-Ports 25 to 32 I/O-Ports for connecting devices

11 (1) I/O-Ports 65 to 72 I/O-Ports for connecting devices

12 (1) I/O-Ports 33 to 40 I/O-Ports for connecting devices

13 (1) I/O-Ports 73 to 80 I/O-Ports for connecting devices

14 (1) I/O-Ports 81 to 88 I/O-Ports for connecting devices

15 (1) I/O-Ports 121 to 128 I/O-Ports for connecting devices

16 (1) I/O-Ports 89 to 96 I/O-Ports for connecting devices

17 (1) I/O-Ports 129 to 136 I/O-Ports for connecting devices

18 (1) I/O-Ports 97 to 104 I/O-Ports for connecting devices

19 (1) I/O-Ports 137 to 144 I/O-Ports for connecting devices

20 (1) I/O-Ports 105 to 112 I/O-Ports for connecting devices

21 (1) I/O-Ports 145 to 152 I/O-Ports for connecting devices

22 (1) I/O-Ports 113 to 120 I/O-Ports for connecting devices

23 (1) I/O-Ports 153 to 160 I/O-Ports for connecting devices
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TABLE 2-6.12.1 FRONT PANEL SWITCH COMPONENTS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 Power supply (standard) Power supply

2 Power supply (redundancy) Power supply

3 Grounding Power grounding

FIGURE 2-6.12.4 BACK PANEL 160-PORT
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2.7	 STATUS INDICATIONS AT THE DEVICE

2.7.1	 STATUS LEDS FOR DEVICE STATUS 

TABLE 2-7.1 FRONT PANEL LEDS FOR DEVICE STATUS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Power Supply 1 Status

2 LED 2 LPower Supply 2 Status

FIGURE 2-7.1 FRONT SIDE LEDS FOR DEVICE STATUS
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2.7.2	 STATUS LEDS FOR LINK CONNECTION, 1G CAT X

 
	

TABLE 2-7.2 FRONT PANEL LEDS FOR DEVICE STATUS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Link status LED for upper port

2 LED 2 Link status LED for upper port

Status LEDs at the I/O Ports, 1G Cat XDevice Status (CPU Module) 

When an interconnection is established, the LEDs light up in the following sequence: 
LED 1 / 2 DESCRIPTION

Off No connection detectecd

Orange Connection via interconnection cable ok, extender detection is running

Red Invalid device / Error detecting device

Green / None The extender is having issues being detected or a non compatible device is connected

 
*An interconnection failure is indicate as follows:

LED 1 / 2 DESCRIPTION

Flashing Orange Extender is not detected

FIGURE 2-7.2 FRONT SIDE LEDS FOR DEVICE STATUS
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2.7.3	 STATUS LEDS FOR LINK CONNECTION, 3G CAT X

 
	  
	

TABLE 2-7.1 FRONT PANEL LEDS FOR DEVICE STATUS

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Link status LED 1 for lower port

2 LED 2 Link status LED 2 for lower port

3 LED 3 Link status LED 1 for upper port

4 LED 4 Link status LED 2 for upper port

Status LEDs at the I/O Ports, 3G Cat X

When an interconnection is established, the LEDs light up in the following sequence: 
LED 1 / 3 LED 2 / 4 DESCRIPTION

Off Green No connection detectecd

Orange Green Connection via interconnection cable ok, extender detection is running

Red Green Invalid device / Error detecting device

Green / None Green The extender is having issues being detected or a non compatible device is connected

 
*An interconnection failure is indicate as follows:

LED 1 / 2 LED 1 / 2 DESCRIPTION

Flashing Orange Off Extender is not detected

FIGURE 2-7.3 FRONT SIDE LEDS FOR DEVICE STATUS
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2.7.4	 STATUS LEDS FOR LINK CONNECTION, FIBER

TABLE 2-7.4. FRONT SIDE - STATUS LEDS FOR NETWORK CONNECTION

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Link status LED 1 for lower port

2 LED 2 Link status LED 2 for lower port

3 LED 3 Link status LED 1 for upper port

4 LED 4 Link status LED 2 for upper port

Status LEDs at the I/O Ports. Fiber 

When an interconnection is established, the LEDs light up in the following sequence:
LED 1 / 3 LED 2 / 4 DESCRIPTION

Off Green No connection detectecd

Orange Green Connection via interconnection cable ok, extender detection is running

Red Green Invalid device / Error detecting device

Green / None Green The extender is having issues being detected or a non compatible device is connected

 
*An interconnection failure is indicate as follows:

LED 1 / 2 DESCRIPTION

Flashing Orange Extender is not detected

FIGURE 2-7.4 FRONT SIDE LEDS FOR DEVICE STATUS
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2.7.5	 STATUS LEDS FOR NETWORK CONNECTION

TABLE 2-7.5. FRONT SIDE - STATUS LEDS FOR NETWORK CONNECTION

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Activity status LED network connection 2

2 LED 2 Link status LED network connection 2

3 LED 3 Activity status LED network connection 1

4 LED 4 Link status LED network connection 1

Status LEDs at the I/O Ports, 1G Cat XDevice Status (CPU Module) 

When an interconnection is established, the LEDs light up in the following sequence: 
POS. LED LED 1 / 2 DESCRIPTION

1/3
Activity  
Status 

(orange)

Off No network connection available or data traffic not active

On Network connection available, data traffic active

2/4
Link 

Status 
(green)

Off No network connection available

On network connection available

 

FIGURE 2-7.5 FRONT SIDE LEDS FOR DEVICE STATUS
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2.7.6	 STATUS LEDS FOR POWER SUPPLY

TABLE 2-7.1. FRONT SIDE - STATUS LEDS FOR NETWORK CONNECTION

NUMBER IN FIGURE 2-2 COMPONENT DESCRIPTION

1 LED 1 Power Supply 1 is deted and getting power

2 LED 2 Power Supply 2 is deted and getting power

LEDs for Power Supply

POS. LED LED 1 / 2 DESCRIPTION

1 AC Input 1
On Power supply available

Off No power supply available

2 AC Input 1
On Power supply available

Off No power supply available

FIGURE 2-7.6 FRONT SIDE LEDS FOR DEVICE STATUS
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CHAPTER 3:

3.1	 ACCESS OPTIONS

 
The following options are available to configure and operate the DKM Compact Matrix Switch: 

 

ACCESS OPTIONS DESCRIPTION

OSD
Via OSD (On-Screen-Display) you can configure the basic settings of the matrix

operating system, query several states, and control several functions by
keyboard commands during normal use.

On

The DKM Java Utility (below referred to as “management software”) is available as a
single executable program file (desktop) does not require installation. The

management software can be downloaded from the link
http://www.blackbox.com

Advanced settings can be configured on the DKM operating system using
the management software:
• Advanced configuration

• Extended monitoring options
• System update (firmware update)

• Local backup option
• Documentation
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3.2	 ACCESS OPTIONS

3.2.1	 COMMAND MODE

The extender modules include a command mode that allows access to the matrix and to control several
functions by keyboard commands during normal use.

To access the command mode, use a keyboard sequence (Hot Key) at the keyboard of a CON Unit
plugged in the matrix.

To quit the command mode, press the <Esc> key to exit the command mode.

NOTICE

While in command mode,
 the Caps Lock and Scroll Lock LEDs on the keyboard are flashing,

the USB-HID devices are not operable, mouse and keyboard functions are deactivated,
only selected keyboard commands are available.

The command mode will be deactivated automatically if there is no keyboard command executed within 10 seconds

The following spellings are used for keyboard commands:

ACCESS OPTIONS DESCRIPTION

<key> Description of a key on the keyboard

<key> + <key> Press keys simultaneously

<key>, <key> Press keys successively

2x <key> Press key quickly, twice in a row (like a mouse double-click)
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To enter and exit the command mode and additionally change the hot key, the following keyboard commands are available.

ACCESS OPTIONS DESCRIPTION

Enter command mode
(default) 2x <Left Shift> (Hot Key)

Exit command mode <Esc>

Change Hot Key , , <0>, ,  <c>, <new Hot Key code>, <Enter>

The Hot Key to enter the command mode can be changed. The following table lists the Hot Key codes for
the available Hot Keys.

HOT KEY CODE HOT KEY

0 Freely Selectable

2 2x <Scroll>

3 2x <Left Shift>

4 2x <Left Ctrl>

5 2x <Left Alt>

6 2x <Right Shift>

7 2x <Right Ctrl>

8 2x <Right Alt>
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NOTICE

In a combined KVM matrix/TC Switch (ACX1004 / ACX1008...) configuration, select different Hot Keys for extender modules
connected to the KVM matrix (e.g., 2x <Left Shift>) and the U-Switch (e.g., 2x <Right

Shift>).

Set freely selectable Hot Key (exemplary)
To set a freely selectable Hot Key (e.g., 2x <Space>), use the following keyboard sequence:
<current Hot Key>, <c>, <0>, <Space>, <Enter>

Set Hot Key for direct OSD access
Next to the Hot Key for standard functions, a second Hot Key can be exclusively set for opening the OSD
directly.
To select a Hot Key from the Hot Key table for a direct opening of the OSD, use the following keyboard
sequence:
<current Hot Key>, <f>, <Hot Key Code>, <Enter>
To select a freely selectable Hot Key (e.g., <Space>) for opening OSD directly, use the following keyboard
sequence:
<current Hot Key>, <f>, <0>, <Space>, <Enter>

Delete Hot Key for direct OSD access
To delete the Hot Key for direct OSD access, use the following keyboard sequence.
<current Hot Key>, <f>, <0>, <Del>, <Enter>

Reset Hot Key
To set a Hot Key back to default settings, press the key combination <Right Shift> + <Del> within
5 s after plugging in a keyboard.

3.2.2	 OSD KEYBOARD CONTROL

Via OSD (On-Screen-Display) you set the basic configuration of the matrix operating system, query several
states, and control several functions by keyboard commands during normal use.
To enter the OSD of the matrix, connect a keyboard to a CON Unit of an extender.

ACCESS OPTIONS DESCRIPTION

<Hot Key>, <o> Open OSD

<ESC> Exit OSD (in the main menu)

<Left Shift> +
<ESC> Exit Sub OSD (within the menus)
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NOTICE

If the OSD is closed with one of the keyboard commands mentioned above, possible changes are not
saved. For information on saving changes, see configuration descriptions from chapter 7.10, from

page 129.

Entering the OSD and the Main Menu
1. Start the command mode with the Hot Key (see chapter 3.2.4, page 60).

2. Press the <o> key to open the OSD. You will see a list of all available CPUs as a start menu.

3. Press the <Esc> key to enter the main menu.

*If the Enable CPU Selection option is enabled in the Configuration menu, the selection list for switching
CPU devices will be opened initially. This list can be skipped by pressing the <F7> key. 

Leaving the OSD
Press the <Esc> key in the main menu or simultaneously <Left Shift> + <Esc> anywhere within
the OSD.

The OSD will be closed without any further changes and the currently active CPU connection will be
displayed.

3.2.3	 OSD KEYBOARD CONTROL

The following keyboard commands are available for the navigation and configuration within the menus:

KEYBOARD COMMANDS FUNCTION

<Cursor Left>
Input field: cursor left

In menus: next input field

<Cursor Right>
Input field: cursor right

In menus: previous input field

<Cursor Up>
In input fields: line up (with wrap around)

In menus: line up (without wrap around)

<Cursor Down>
In input fields: line down (with wrap around)

In menus: line down (without wrap around)

<Page Up>
Previous page in menus with more than one page

Next page in menus with more than one page
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KEYBOARD COMMANDS FUNCTION

<Page Down> Next page in menus with more than one page

<Tab> In menus with input fields: next input field

<Left Shift> +
<Tab> In menus with input fields: previous input field

<+>
Next option in selection fields

In the CPU selection list with cursor on a CPU Group: expand members of a
group

<->
Previous option in selection fields

In the CPU selection list with cursor on a CPU Group: collapse members of a
group

<Cursor Down>

Switching in selection fields between two conditions, e.g., between ON / OFF or

Y (Yes) / N (No)

In menus: line down (without wrap around)

<Space>
Switching in selection fields between two conditions, e.g., between ON / OFF or

Y (Yes) / N (No)

<Enter>

In menus with input fields: save data

In menus: select menu item

With buttons: confirm selected button

<Esc>
In menus with input fields: cancel data input without saving

In menus with selection fields: go back to the superior menu

3.2.4	 OSD MENU STRUCTURE

The general layout of the OSD is structured into three areas:

• upper status area (topmost two text lines)

• working area

• lower status area (lowest two text lines)
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FIGURE 3-2.4. OSD MAIN MENU

The following functions are available in most of the menus:

BUTTON FUNCTION

Cancel Reject changes

Okay
Apply changes (temporary storage of the active configuration in the volatile

memory of the matrix).

NOTICE

Possible loss of configuration changes
By clicking the Okay button, changes are applied to the active configuration and saved in the volatile

memory of the matrix. In the event of a sudden power failure, these changes are lost. To save changes
permanently:

Save the configuration changes into the active configuration (Save, see chapter 5.10.1, page 134),
save a predefined configuration (Save as..., from chapter 5.10.1 page 135, or perform a restart (see

chapter 7.10 page 315).
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3.2.5	 OSD SORT FUNCTION

Lists and tables in the OSD offer a sorting function for fast and smooth search.
The following sorting functions are available:

KEYBOARD COMMANDS FUNCTION

<F1>
Sort ID numbers in descending order by pressing the keyboard command once.
Sort ID numbers in ascending order by pressing the keyboard command twice

(ID).

<F2>
Sort ID names in descending order by pressing the keyboard command once.
Sort ID names in ascending order by pressing the keyboard command twice

(Name).

<F3> Go to the next result in the list of results of the search field (Next).

<F4> Go to the previous result in the list of results of the search field (Previous).

<F5> Refresh the currently shown list (Refresh).

<F6> Jump between the search field and the list of results (Find).

<F8> Show unavailable CPUs

<F9> Activate search function from the beginning of the name (Compare).

3.3	 CONTROL OPTIONS VIA MANAGEMENT SOFTWARE

3.3.1	 MANAGEMENT SOFTWARE TOOLBAR

The menu structure of the management software is subdivided into various sections:

FIGURE 3-3.1 MANAGEMENT SOFTWARE MENU STRUCTURE
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TABLE 2-14. FRONT SIDE - STATUS LEDS FOR NETWORK CONNECTION

NUMBER IN FIGURE 2-2 DESCRIPTION

1 Menu Bar (top line)

2 Toolbar (second line)

3 Tab bar ( third line)

4 Task area (left menu section)

5 Working area (right menu section)

6 Status bar (bottom line)

BUTTON FUNCTION

Apply
Confirm changes (temporary storage of the active configuration in the volatile

memory of the matrix)

Cancel Reject changes

NOTICE

Possible loss of configuration changes
By clicking the Apply button changes are applied to the active configuration and saved in the volatile

memory of the matrix. In the event of a sudden power failure, these changes are lost. To save changes
permanently:

Save the configuration changes into the active configuration (Remote Save, see chapter 5.10.1
page 135), save a predefined configuration (Save as...) (see from chapter 5.10.1, page 136), or

perform a restart (see from chapter 7.10 page 315).

Information for Operating and for Support Functions
The operation of the management software is intuitive and corresponds to the user interface of common operating sys-
tems.

• Help texts:
The management software contains its own support function. The integrated help texts in the working area of the manage-
ment software can be activated or deactivated by clicking the checkbox in the upper right corner. Auxiliary names (tooltips) 
for the menu items can be activated in the options.

• Online help:
After calling up a function from the task area, a menu opens in the work area of the management
software, sometimes with several sub-pages (tabs). An online help is available for these functions,
which can be called up by pressing the F1 key on the keyboard. An internet connection and a browser
are required for opening the online help (PDF file).
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3.3.2	 MANAGEMENT SOFTWARE MENU STRUCTURE

The menu structure of the management software is subdivided into various sections:

TABLE 2-14. FRONT SIDE - STATUS LEDS FOR NETWORK CONNECTION

NUMBER IN FIGURE 2-2 DESCRIPTION

1 Load locally saved configuration

2 Save configuration locally

3 Update configuration

4 Connect to the matrix

5 Disconnect from the matrix

6 Activate/deactivate the edit mode

7 Save active configuration (online mode)

8
Show predefined configuration saved on the

matrix (online mode)

9
Save predefined configuration on the matrix

(online mode)

10 Monitoring (online)

11 Flash update for single devices

12 Overview of devices in the subnet (online mode)

13 System check

14 Save status locally

FIGURE 3-3.2. MANAGEMENT SOFTWARE TOOLBAR
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3.3.3	 MANAGEMENT SOFTWARE MOUSE CONTROL

The following mouse commands are selectable for menu functions:

MOUSE CONTROL FUNCTION

Priliminary mouse click Menu selection, marking

Double-click priliminary 
mouse button Open function specific selection menus

Secondary mouse button Open context specific selection menus

3.3.4	 MANAGEMENT SOFTWARE KEYBOARD CONTROL

The following keyboard commands are available for the navigation and configuration within the menus:

KEYBOARD COMMANDS FUNCTION

<Cursor Left> Cursor to the left

<Cursor Right> Cursor to the right

<Cursor Up> Line up

<Cursor Down> Line down

<Cursor Up> In input or status menus with more than one page: previous page

<Page Down> In input or status menus with more than one page: next page

<Page Tab> In input menus: next field

<Left Shift> +
<Tab> In input menus: previous field

<Space>
• Switch in selection fields between two conditions (checkmark or not).

• Open already highlighted fields with editing or selecting possibility.

<Enter>
• Select menu item

• In menus: Save data

<Ctrl> + <Tab>
• Leave tables

• Jump from tables into the next field

<Ctrl> + <Left
Shift> + <Tab>

• Leave tables
• Jump from tables into the previous field

*Various functions within the menus in the menu bar can be executed with the provided keyboard
commands (e.g., press <Ctrl> + <S> to execute Save) that are listed to the right of the respective menu
item.
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3.3.5	 MANAGEMENT SOFTWARE RELOAD OPTIONS

The information shown in the management software can be reloaded in different ways:

• Press the <F5> key on the used keyboard.

• Click the Reload menu item in the toolbar.

• Click Edit >Reload in the drop-down menu of the menu bar.

• Activate the Automatic Reload option by clicking the Automatic Reload checkbox in the right panel of
the View >Matrix menu under Options.

3.3.6	 MANAGEMENT SOFTWARE CONTECT FUNCTION

The management software offers several context functions that support user-friendly and effective
operation. The context functions are described in the respective chapters.

CONTEXT FUNCTION ACTION RESULTS

Execute context
function

Click with the right mouse 
button on a

field.

A context menu opens and displays
functions available for the

corresponding filed (if existing).

Click with the left mouse 
button on the

desired function.
The desired function is executed.

3.3.7	 MANAGEMENT SOFTWARE SORT FUNCTION

Lists and tables in the management software offer a sorting function for fast and smooth search. An active
filter is indicated by an arrow in the header.

SORT FUNCTION ACTION RESULTS

Ascending sort
Click with the left mouse button once

on the header of the column to be
sorted.

• The column is sorted in ascending
order.

• The sort of status is indicated by an
arrow pointing upwards.

Decending sort
Click with the left mouse button twice

on the header of the column to be
sorted.

• The column is sorted in descending
order.

• The sort is displayed by an arrow
that points downwards.

Cancel sort Click with the left mouse button once or
twice on the head of the sorted column. The arrow displayed disappears.
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3.3.8	 MANAGEMENT SOFTWARE FILTER FUNCTION

Lists and tables in the management software offer a filter function that supports a fast and smooth search.
The filter entry field is located above the header. An active filter is indicated by a green filter symbol in the
filter entry field.

FILTER FUNCTION ACTION RESULTS

Active filter
Click with the left mouse button in the

filter entry field above the header.
Write the word or part of a word to be

filtered.

• The filter results are shown
immediately.

• The filter symbol is displayed in
green.

Cancel filter Delete the text in the filter entry field.
• The list or table shows the complete

content.
• The filter symbol is displayed in

gray.

3.3.9	 MANAGEMENT SOFTWARE FILTER FUNCTION

The management software is equipped with a report function that shows the current switching status and all
relevant parts of the matrix configuration in a PDF file.

* The report function can be used in both online and offline mode of the management software. 

To create a report, proceed as follows:
1. Select File > Report... in the menu bar.

1. A selection dialog appears.

2. Select contents that should be included in the report (Matrix View, EXT Units, CPU Devices, CON
Devices and Users).

3. Click the Next > button to confirm the selection.
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4. Navigate to the preferred location for storage of the report.

5. Click the Finish button to confirm the report.
The report will be created as a PDF file.

FIGURE 3-3.9. MANAGEMENT SOFTWARE FILE - REPORT - DEFINE CONTENT
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CHAPTER 4:

4.1	 INSTALLATION

 
NOTICE

Please verify that interconnect cables, interfaces, and handling of the devices comply with the
requirements (see chapter 10, page 314).

* First-time users are recommended to set up the system in a test environment that is limited to a single
room. This makes it easier to identify and solve any cabling problems, and experiment with your system
more conveniently.

FIGURE 3-3.10. MANAGEMENT SOFTWARE FILE - REPORT -SAVE REPORT
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4.2	 PREPARING THE MATRIX FOR RACK MOUNTING

NOTICE

Due to the construction of a matrix with 16, 32 and 40 ports into a 19’’ rack, it is recommended to use an
additional subfloor below the matrix. It should be used in addition to the provided mounting brackets.

The supplied mounting brackets are required for mounting the KVM matrix switch.

1. For front rack mounting, remove the front and middle screws on both sides of the cover.

2. For rear rack mount, remove the rear and middle screws on both sides of the cover.

3. Mount the mounting bracket in the desired position using the screws on the cover/chassis.

CHAPTER 4: INSTALLATION
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4.3	 SETTING UP THE MATRIX

4.3.1	 PREREQUISITES FOR FAILURE-FREE INSTALLATION OF A MATRIX SETUP

* To achieve the best possible performance and results with the matrix system, we recommend using the
supplied cables. If you need a replacement, please use the spare parts specified for this device, which can
be requested from the manufacturer if required. 

*To achieve a failure-free installation of a matrix system, we recommend to first establish a point-to-point
connection between a CPU Unit and a CON Unit before connecting to the matrix as follows:
Source (computer, CPU) - CPU Unit - Link - CON Unit - console (monitor, keyboard, mouse)
Ensure that this most simplistic setup works.
Then continue as follows. 

1. First connect the CPU Unit to the source (computer, CPU) by using the provided connection cables.

2. Connect the CPU Unit to the CON Unit by using the interconnect cables (Cat X or fiber).

3. Connect the monitor, keyboard, and mouse to the CON Unit.

4. Connect the power supply units to the CPU Unit and CON Unit.

5. Power up the CPU Unit and CON Unit.

6. Boot the source (computer, CPU) and check that everything works correctly.
 

4.3.2	 INITIAL COMMISSIONING OF THE MATRIX

1. Connect the monitor, keyboard, and mouse to a functionally tested CON Unit.

2. Connect the CON Unit to an I/O port of the matrix by using the interconnect cables (Cat X or fiber).

3. Connect the matrix and the CON Unit to the power supply.

4. Power up the matrix and wait until the boot process is finished (status LED flashes green).

5. Open the OSD via keyboard command 2x <Left Shift>, <o>. The Caps Lock and Scroll Lock LEDs on the keyboard are 
flashing, and the OSD is opened on the display showing the KVM List view.

6. Press the <ESC> key to enter the advanced menus. The OSD can be operated via keyboard and mouse.

7. Select Configuration in the main menu.

8. Login with administrator rights (see chapter 5.5, page 98).

9. Configure initially as requested (see from chapter 5.5, from page 99).

Optional: Establish a network connection between the matrix and the management software to set an
extended configuration (from chapter 5.6, page 106).

The default IP address is 192.168.100.99 and DHCP is deactivated. 

*After the configuration of the system it is recommended to save the configuration by selecting
Configuration > Save (see chapter 7.10.1, page 129) and restart the matrix by selecting Restart Matrix
(see chapter 7.10 page 315). 

*When installing several matrices at the same time, it is strongly recommended to install them in sequence
and to assign unique IP addresses to avoid IP address conflicts

CHAPTER 4: INSTALLATION
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4.4	 CONNECTING THE MATRIX TO THE SINK (CONSOLE) AND THE SOURCES (COMPUTER, CPUS)

4.4.1	 CONNECTING THE SINK (CONSOLE) TO THE MATRIX

1. Connect the monitor, keyboard, and mouse to the CON Unit.

2. Connect the CON Unit to an I/O port of the matrix by using the interconnect cables (Cat X or fiber).

3. Connect the matrix and the CON Unit to the power supply.

4. Connect the power supply units to the CON Unit.

5. Establish the power supply to the CON Unit.

6. Check the basic function of the CON Unit by opening the OSD via keyboard command <Hot Key>,
<o>. 

4.4.2	 CONNECTING THE SOURCES (COMPUTER, CPU) TO THE MATRIX

1. Connect the source (computer, CPU) to the CPU Unit by using the provided connection cables.

2. Connect the CPU Unit to the matrix using the interconnect cables (Cat X or fiber).

3. Connect the power supply units to the CPU Unit.

4. Establish the power supply to the CPU Unit. 

4.5	 CONNECTING THE MATRIX VIA MANAGEMENT SOFTWARE

NOTICE

Connection to the matrix blocked
Synchronization directories or offline directories require special attention regarding the firewall settings,

e.g., Windows: roaming directories. If blocked by the firewall, no connection to the matrix can be
established.

Save the management software in a locally available directory.

The management software is available as a single executable program file (desktop) that does not require
installation.
Save the management software in a locally available directory.

CHAPTER 4: INSTALLATION
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Requirements
If you want to use the management software on Windows operating systems with integrated Java Runtime,
the following requirements must be fulfilled:

COMPUTER / SOFTWARE / NETWORK RESULTS

Free memory RAM Recommended: 512 MB

Operating system Microsoft Windows 8, Windows 8.1, Windows 10

Management software
with integrated Java

Runtime
DKM Java Utility Downloaded from http://www.blackbox.com 

Network connection - Available between computer and matrix

If you want to use the management software without integrated Java Runtime, the following requirements
must be fulfilled:

COMPUTER / SOFTWARE / NETWORK RESULTS

Free memory RAM Recommended: 512 MB

Operating system
Microsoft Windows 8, Windows 8.1, Windows 10

DKM Java Utility Downloaded from http://www.blackbox.com 

Specification Java
Installed: Oracle Java Runtime Environment (JRE) 1.8.x or

higher
Strongly recommended: Oracle Java 1.8 update 152, or higher.

(https://adoptopenjdk.net, https://github.com/ojdkbuild/ojdkbuild

Management software DKM Java Utility Downloaded from http://www.blackbox.com 

Network connection - Available between computer and matrix

* Contact your system administrator concerning JRE and network connection.

CHAPTER 4: INSTALLATION
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4.5.1	 SETTING UP NETWORK AND FIREWALL RELEASES

Releasing Netowkr Ports
The following ports are used by the matrix depending on the configuration and have to be released at the
security gateway if necessary. The ports will only have to be released if you want to use the respective
function. 

FUNCTION PORT

FTP 21 / TCP

DNS 53

SNTP 123 / UDP

SNMP 161/162 / both UDP

LDAP 389 (636 for SSL)

Syslog 514 / UDP

API 5555 / TCP (5565 for SSL)

Broadcast 5556 / UDP (5566 for SSL)

Matrix Grid 5557 / TCP (5576 for SSL)

Releasing Java Application in the Firewall
If using the management software, the Java application (file javaw.exe) has to be released in the firewall
settings to use the management software. Contact your administrator to configure the firewall settings
accordingly.
Using the management software with integrated Java Runtime, no firewall modification is necessary. 

4.5.2	 CONNECTING THE COMPUTER TO THE MATRIX

NOTICE

For a connection between computer and matrix via switch or hub, parallelly assembled network cables
are required.

Only use a network connection between computer and the matrix that is not primarily used for
streaming audio or video data.

Connect the network cable to the RJ45 ports of computer and matrix.

CHAPTER 4: INSTALLATION
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4.5.3	 STARTING THE MANAGEMENT SOFTWARE

Open the management software by a double-click on the program icon on the desktop or the file in the
directory.
The management software starts in offline mode.

There are two options to connect to a matrix.

• Via a known IP address

• Via Device Finder

FIGURE 4-5.3 MANAGEMENT SOFTWARE OFFLINE MODE

CHAPTER 4: INSTALLATION
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4.5.4	 CONNECTING TO THE MATRIX WITH KNOWN IP ADDRESS

Open the management software by a double-click on the program icon on the desktop or the file in the
directory.
The management software starts in offline mode.

* At least FTP rights are required. 

*Up to twelve connections between the matrix and the management software can be established at the
same time due to a limitation of available sockets.

To connect to a matrix when the IP address is known, proceed as follows:

1. Open the management software.

2. Click the Connect menu item in the tool bar. An access window appears.

3. Enter the IP address according to the network configuration of the matrix (see chapter 6.4.6, page 163).
By default, the IP address of the matrix is 192.168.100.99 and DHCP is deactivated. 

4. Enter the username and password of the administrator (see chapter 6.5, page 177). By default, the username is admin, 
and the password of the administrator is admin.

5. Click the Login button to confirm your entries.

*The data must be entered each time the network connection is re-established.
Alternately, the data can be entered and stored in the management software under Extras > Options
(see chapter 6.3.1, page 150).

FIGURE 4-5.4.1 MANAGEMENT SOFTWARE DIALOG CONNECT
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4.5.5	 CONNECTING TO THE MATRIX VIA DEVICE FINDER

* At least FTP rights are required. 

*Up to twelve connections between the matrix and the management software can be established at the
same time due to a limitation of available sockets.

The Device Finder offers the possibility to find all matrices that are in the same subnet. This is useful, for
example if the IP address of a specific matrix is unknown and should be accessed via IP.

The following device information is shown in the Device Finder:

INFORMATION DESCRIPTION

Broadcast/Multicast
Search parameters for finding devices.

Search via broadcast: 255.255.255.255 (default).
Input for search within a multicast group: multicast address (chapter 6.4.6,

page 163)

Device Name of the device

Name Name of the active configuration

IP Address Current IP address of the device

MAC Address MAC address of the device

Type Type of the device

FIGURE 4-5.5.1 MANAGEMENT SOFTWARE MENU DEVICE FINDER
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* The last column of the Device Finder can be used to access the respective matrix directly clicking the
Connect button.

*Up to twelve connections between the matrix and the management software can be established at the
same time due to a limitation of available sockets.

To find and access a device, proceed as follows:

1. Click the menu item Device Finder in the tool bar.

2. For searching within a multicast group, enter the multicast address. By default, the search is set via
broadcast: 255.255.255.255.

3. Click the Connect button in the last column of the Device Finder to establish direct access to the
respective device within the same subnet.

4. Enter the username and password of the administrator (see chapter 6.5, page 177). By default, the username is admin, 
and the password of the administrator is admin. 

5. Click the Login button to confirm your entries.

CHAPTER 5:

5.1	 CONFIGURATION VIA OSD

NOTICE

Possible loss of configuration changes
By clicking the Okay button, changes are applied to the active configuration and saved in the volatile

memory of the matrix. In the event of a sudden power failure, these changes are lost. To save changes
permanently:

 save the configuration changes into the active configuration (Save, see chapter 5.10.1, page 134),
save a predefined configuration (Save as..., from chapter 5.10.2, page 135), or perform a restart (see

chapter 7.10.1, page 315).
 

NOTICE

A change in system-relevant parameters (e.g., change of the IP address) is immediately displayed in the
OSD. To initialize system-relevant configuration changes on the matrix, the matrix must be restarted. The

restart of the matrix may take several minutes, and the matrix is not available during the restart.
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5.2	 PASSWORD RESET

All configuration or assignment settings can only be configured with administrator rights. The following login
data is saved in the factory settings:

FILED ENTRY

User admin

Password admin
 
 

To access the configuration menu, proceed as follows:

1. Press the <F10> key in the main menu of the OSD. The login mask appears.

2. Enter the login data of the administrator* To log out a user, press the <F10> key again.
When leaving the configuration or assignment menu, the administrator is logged out automatically. 

5.3	 OVERVIEW CONFIGURATION MENU

Various system functions and options are available in the configuration menu. In addition, the following
functions can be called up here: save (as active or predefined configuration) and shutdown, restart, or reset
to factory settings.

NOTICE

For security reasons, please change the administrator password as soon as possible (see chapter 5.4.1,
page 80).

 

FIGURE 5-2.1.1 MANAGEMENT SOFTWARE MENU DEVICE FINDER
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5.4	 SYSTEM SETTINGS

5.4.1	 SETTING SYSTEM CONFIGURATION

The parameters for the system configuration are set in this menu:

FIGURE 5-3.1.1 OSD MENU CONFIGURATION

FIGURE 5-4.1.1. OSD MENU CONFIGURATION - SYSTEM
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COMPUTER / SOFTWARE / NETWORK RESULTS

Device Text Enter the device name of the matrix (default: SWITCH_01)

Name Text
Enter the name of the configuration that is used to save the

current settings (default: Standard)

Info Text
Additional text field to describe the configuration (default:

Factory settings)

Sub Matrix
Y

If the matrix is defined as a sub matrix in the OSD, the user will
lose control. Control can be recovered by using the keyboard
command <Hot Key>, <s>, <o>. The OSD for the matrix that

has been defined as sub matrix will be reopened.

N Function not active (default)

Load Default

Y
Starting the matrix after a restart or a switch-on with the default

configuration.

N
Starting the matrix after a restart or a switch-on with the last

saved configuration (default).

Auto Save
Y

Save the current configuration of the matrix in the flash memory

periodically.
Note: During the save operation, the matrix will not react to

commands. Saving takes place every 600 seconds if changes of
the configuration or switching operations have been executed in

the meantime.

N Function not active (default)

Enable COM Echo
Y

Send all switching commands performed in the matrix as an

echo via serial interface.
Note: This function should be enabled when using a media

controller via serial interface.

N Function not active (default)

Enable LAN Echo
Y

Send all switching commands performed in the matrix as an

echo via LAN connection.
Note: This function should be enabled when using a media

controller via LAN connection or when using stacking with two or
more matrices.

N Function not active (default)

Enable Redudancy
Y

Automatically switch to the second link of a connected
redundant CON Unit when losing the primary link of a CPU Unit

(default).
Note: This function will have to be activated:

• for a single matrix when using redundant link connections,
• for both matrices in a fully redundant setup.

N Function not active

Synchronize
Y

Synchronize the sub matrix to the switch status of the master

matrix.

N Function not active (default)

FIGURE 5-2.1. OSD MENU CONFIGURATION
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COMPUTER / SOFTWARE / NETWORK RESULTS

Echo Only
Y

Synchronize the matrix according to the echo of a second matrix.
Note: This is a bidirectional synchronization where both

matrices have to be configured as Synchronize with the Master IP of the respective other matrix.

N Function not active (default)

Master IP Address Y Set the network address of the master matrix (default:
000.000.000.000)

Invalid IO-Boards
Y

Keep I/O boards with incorrect or invalid firmware online in the matrix.
Note: To keep an I/O board with wrong or damaged firmware

online in the matrix, the maintenance mode of the matrix will be activated.

N Shut down I/O boards with incorrect or invalid firmware automatically (default).

Enable old Echos
Y

Translate current switching command (implemented since
V02.09) internally into the old, already known switching

commands and send them as echo.

N Function not active (default)

Remove IO-Boards Y
Note: Only for DKM enterprise 576:

Shut down of I/O boards if the second controller board is not
available. Connection will be disconnected.

Keep Gridlines
Y Function not available in the firmware described in this manual

N Function not active

OSD Data CPU
COMPUTER / SOFTWARE / NETWORK RESULTS

Horizontal Mouse
Speed [1/x] 1 to 9 Adjust the horizontal mouse speed, 1 = slow, 9 = fast (default: 4)

Vertical Mouse Speed
[1/x] 1 to 9 Adjust the vertical mouse speed, 1 = slow, 9 = fast (default: 5)

Double-click Time
[ms] Text Adjust the time slot for a double-click (default: 200)

Keyboard Layout 100 to 800 Set the OSD keyboard layout according to the keyboard used (default: German (DE))

Hot Key Region Set the OSD keyboard layout according to the keyboard used (default: German (DE))

Load Default Keyboard
command Call the command mode via keyboard sequence (default: 00)

Fast Key Keyboard
command

Open the OSD via direct access (default: 00) How often the shortcut key has to be pressed depends 
on the

specified key: 1x for function keys or print key, 2x for all other keys

CHAPTER 5: OSD CONFIGURATION
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FIGURE 5-3.1. OSD MENU CONFIGURATION

Settings for Global Hot Key and Fast Key

FIELD ENTRY DESCRIPTION

Hot Key / Fast Key

00 No global Hot Key / Fast Key defined, no modification of the
extender module.

01 to FE Overwrite the Hot Key / Fast Key of the extender module with
the entered value of the global Hot Key / Fast Key.

FF Deactivate the Hot Key / Fast Key of the extender module

Valid values for the Hot Key and the Fast Key are USB-HID keyboard scan codes according to
US keyboard layout.
To set modifier keys for the Hot Key and the Fast Key use the following values:

ENTRY MODIFIER KEY

F0 Left CTRL

F1 Left SHIFT

F2 Left ALT

F4 Right CTRL

F5 Right SHIFT

F6 Right ALT

Hot Key or Fast Key set in the CON EXT Units have priority over the global settings.

To set the parameters for the system configuration, proceed as follows:

1. Select Configuration > System in the main menu.

2. Modify the desired settings.

3. Click the Okay button to confirm your entries

CHAPTER 5: OSD CONFIGURATION
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5.4.2	 ENABLING AUTOMATIC CREATION OF CPU AND CON DEVICES

Settings for automatic creation of CPU and CON Devices when a new CON extender module or CPU
extender module is connected are set in this menu.

The following parameters can be configured:

COMPUTER / SOFTWARE / NETWORK RESULTS

Enable Auto Config

 
Y

Automatic creation of a new CPU or CON Device if new

extender modules are connected (default)

 N Function not active

ID Real CPU Device Text Initial value of the automatic ID for real CPUs (default: 1000)

ID Virtual CPU Device 100 to 800 Initial value of the automatic ID for virtual CPUs (default: 2000)

ID Real CON Device Region Initial value of the automatic ID for real CONs (default: 3000)

ID Virtual CON Device Numerical Initial value of the automatic ID for virtual CONs (default: 4000)

FIGURE 5-4.2.1 OSD MENU CONFIGURATION -SYSTEM - AUTOMATIC ID
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To set the parameters for the system configuration, proceed as follows:

1. Select Configuration > System in the main menu.

2. Modify the desired settings.

3. Click the Okay button to confirm your entries.

5.4.3	 SETTING ACCESS CONFIGURATION

The access configuration is set in this menu.

FIGURE 5-4.3.1 OSD MENU CONFIGURATION - ACCESS
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The following parameters can be configured:

COMPUTER / SOFTWARE / NETWORK RESULTS

Force User Login

 
Y

The user has to login with a username and a password once to
enter OSD. Thereafter the user remains logged in until he

explicitly logs out or an auto logout is affected.
Note: When the Force User Login function is activated and a

user is logged in, only the user favorites are available. The CON
favorites are not accessible.

 N Function not active (default)

Enable User ACL
Y

CPU Device access is restricted according to the permissions in the ACL (Access Control List).
• User login is required.

• Switching by keyboard Hot Keys requires a prior login.

N Function not active (default)

Enable CON ACL
Y

CPU Device access is restricted according to the permissions in
the respective CON Device ACL (Access Control List). No login

required

N Function not active (default)

OR User/CON ACL
Y

The user obtains the sum of access rights from the CON Device
and his personal access rights after logging in (extended

access)

N Function not active (default)

AND User/CON ACL
Y

The user obtains the common divisor of access rights from the
CON Device and his personal access rights after logging in

(reduced access)

N Function not active (default)

Enable new User
Y Newly created users automatically receive access to all CPUs

N Function not active (default)

Enable new CON
Y

Newly created CON Devices automatically receive access to all

CPU Devices

N Function not active (default)

Auto Disconnect
Y

Upon opening the OSD, the console will be automatically

disconnected from the current CPU Device.

N Function not active (default)

OSD Timeout [sec] 0 to 999
seconds

Period of inactivity after which OSD will be closed automatically.
• Select 0 seconds for no timeout

• (default: 0 seconds)

Auto Logout [min] 0 to 999
seconds

Period of inactivity of a logged-in user at a CON Device after
which he will be automatically logged out.

In addition to the logout process, a complete disconnection from
the connected CPU Device occurs under Full Access and

Private Mode.
• Select 0 minutes for an automatic user logout when leaving

OSD.
• Using the setting -1 allows the user to be logged in

permanently, until a manual logout is executed.
• The timer is not active as long as the OSD is open

(default: 0 minutes).
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COMPUTER / SOFTWARE / NETWORK RESULTS

Keep CPU

 
Y

Keep the connection to the CPU Device active in the
background after Auto Logout. After a new login there is no

need to re-connect to the CPU Device.

 N Function not active (default)

Show CPU
Y

Permanently show the name of the currently connected CPU

Device in the Connection Info box.

N Function not active (default)

To set the parameters for the system configuration, proceed as follows:

1. Select Configuration > System in the main menu.

2. Modify the desired settings.

3. Click the Okay button to confirm your entries. 

5.4.4	 SETTING SWITCH CONFIGURATION

This menu enables shared operation of a CPU Device by two or more CON Devices. A CPU Device can be
controlled by only one CON Device at a time but can be taken over successively by other CON Devices.
Control of a CPU Unit by a CON Unit is relinquished after the expiration of an inactivity timer associated
with the controlling CON Device. The mouse or keyboard may also be used to take over control. 
 
* To allow a smooth and accurate function of the shared operation, you should use identical mice and
keyboards. They should be connected to the same USB-HID ports of each CON Unit.
The alternative is using the USB-HID Ghosting (see chapter 6.8.1, page 204).
When taking over control within 10 s, any assigned USB 2.0 extender modules if available, will not be
switched due to security and stability aspects.
The shared operation will be deactivated between CON Devices with a different priority as well as the
Release Time. 

The switching parameters are set in this menu.

CHAPTER 5: OSD CONFIGURATION
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The switching parameters are set in this menu.

The following parameters can be configured:

COMPUTER / SOFTWARE / NETWORK RESULTS

Enable Video Sharing

 
Y

The user can switch to any CPU Device as an observer,
including ones that are already assigned to another user

(observer without keyboard/mouse access).
Note: Switching with the <Space> key, not with the <Enter>

key.
The operator only will be informed if further users connect as an

observer to the CPU Device that is connected to his CON
Device, if the option Update Connection Info is activated for

his CON EXT Unit.

 N Function not active (default)

Force Connect
Y

Extension of Force Connect: If the user connects as an
operator to a CPU Device already related to another user, the

previous user will be disconnected.
Note: To share K/M control Force Disconnect has to be

deactivated and Enable Video Sharing has to be activated.

N Function not active (default)

Force Disconnect
Y

If a CON Device is not connected to a CPU Device, you can
establish an automatic connection to the next available CPU

Device by hitting any key or mouse button.

N Function not active (default)

FIGURE 5-4.4.1. OSD MENU CONFIGURATION - SWITCH
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COMPUTER / SOFTWARE / NETWORK RESULTS

CPU Auto Connect

 
Y

If a CON Device is not connected to a CPU Device, you can
establish an automatic connection to the next available CPU

Device by hitting any key or mouse button.

 N Function not active (default)

CPU Timeout [min] 0 to 999
minutes

Period of inactivity after which a CON Device will be
automatically disconnected from its current CPU Device

(default: 0 minutes)

Keyboard Connect
Y

Activate request of K/M control by keyboard event (key will be

lost)

N Function not active (default)

Mouse Connect
Y Activate request of K/M control by mouse event

N Function not active (default)

Release Time [sec] 0 to 999
seconds

Period of inactivity of a connected console after which K/M
control can be requested by other consoles connected to the

CPU Device.
Note: Set 0 for an immediate transfer in real-time.

Only one console can have keyboard and mouse control at a
time. The other consoles that are connected to the same CPU

Device have a Video Only status (default: 10 seconds)

Macro Single Step

Y Execute macro commands sequentially

N Function not active (default)

To configure shared operation, proceed as follows:

1. Select Configuration > Switch in the main menu.

2. Activate the Enable Video Sharing function.

3. Activate the Force Connect function.

4. Activate the Keyboard Connect function if taking over control by a keyboard event should be possible.

5. Activate the Mouse Connect function if taking over control by a mouse movement should be possible.

6. Define a Release Time of inactivity (0 to 999 seconds) after which KVM control can be taken over.

7. Click the Okay button to confirm your settings.

Keyboard Connect and / or Mouse Connect are only effective if Force Connect and / or CPU Auto
Connect are activated.
If the Keyboard Connect and / or Mouse Connect options are enabled, the Keyboard Connect and/or
Mouse Connect will not take effect until the time interval entered in the Release Time has elapsed.
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5.4.5	 SETTING NETWORK CONFIGURATION

To configure shared operation, proceed as follows:

NOTICE

To initialize system-relevant configuration changes, the matrix must be restarted. Restarting the matrix
can take several minutes and the matrix is not available during the restart.

NOTICE

Consult your system administrator before modifying the network parameters. Otherwise, unexpected
results and failures can occur in combination with the network.

NOTICE

The Syslog function starts logging after the matrix or controller card is restarted if the Syslog function has
been activated in this menu.

FIGURE 5-4.5. OSD MENU CONFIGURATION - NETWORK
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The following parameters can be configured: 
 
Network Interface #1

COMPUTER / SOFTWARE / NETWORK RESULTS

Dual Interface

 
Y Redundant network connection is deactivated

 N Redundant network connection is activated (default)

CPU Timeout [min]
Y

The network settings are automatically supplied by a DHCP

server.
Note: If DHCP is activated and there is no physical network

connection available, the boot times might increase.

N Function not active (default)

IP Address Byte
Input of the IP address if DHCP is not active (default:

192.168.100.99)

Subnet Mask Byte
Input of the subnet mask in the form “255.255.255.0” if DHCP is

not active (default: 255.255.255.0)

Gateway Byte
Input of the subnet mask in the form “192.168.1.1” if DHCP is

not active

MAC Address Byte Cannot be changed, is retrieved automatically

Multicast Byte Input of the Multicast address if there is a Matrix Grid in use
within a Multicast group (default: 255.255.255.255)

Network Services

COMPUTER / SOFTWARE / NETWORK RESULTS

API Service #1

 
Y

LAN interface at the matrix activated for access via
management software (default, API service port 5555/5565)

 N Function not active

Grid Service #1
Y

Activate Grid interface at the matrix for access via management

software (Grid Service Port 5557/5567).

N Function not active (default)

SSL Services #1
Y

Activate SSL encryption for API, management software (API),

and Matrix Grid communication.

N Function not active (default)
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The following parameters can be configured: 
 
Network Interface #1

COMPUTER / SOFTWARE / NETWORK RESULTS

Syslog #1/#2

 
Y Syslog server for status request is active

 N Function not active (default)

Syslog Server #1/#2 Byte Input of the IP address of the Syslog servers in the form
“192.168.1.1” and of the Syslog port (default: 514)

* The LDAP settings are explained in the chapter 7.3.6, page 79. 

Log Levels

COMPUTER / SOFTWARE / NETWORK RESULTS

Trace

 
DEB

LAN interface at the matrix activated for access via
management software (default, API service port 5555/5565)

INF Function not active

NOT Activate Grid interface at the matrix for access via management
software (Grid Service Port 5557/5567).

WAR Function not active (default)

ERR Activate SSL encryption for API, management software (API),
and Matrix Grid communication.

Syslog #1/#2

DEB

Activate debug messages in Syslog (default: N)
Note: The debug messages are exclusively for matrix

diagnostics. They only should be activated after consultation
with the manufacturer. Otherwise, an increased traffic of data

might limit the performance of the controller board.

INF Activate information messages in Syslog (default: N)

NOT Activate notification messages in Syslog (default: Y)

WAR Activate warning messages in Syslog (default: Y)

ERR Activate error messages in Syslog (default: Y)

To set parameters for the network configuration, proceed as follows:

1. Select Configuration > Network in the task area.

2. Modify the desired settings.

3. Click the Okay button to confirm your entries.
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5.4.6	 SETTING SNMP FUNCTION

The SNMP function allows all function-critical and safety-critical elements of the matrix to be monitored and
queried. This function complies with the RFC 1157 conformal standard. Two SNMP servers can be used at
the same time. Enabling the SNMP function, the unencrypted SNMP monitoring (SNMPv2) is activated. 

An SNMPv3 User for encrypted SNMP monitoring (SNMPv3) can be set in the user settings (see
chapter 6.4.8 page 167) and the login data for an SNMPv3 User at the SNMP server can be set in the
default settings.

The settings for the SNMP monitoring are set in this menu:

FIGURE 5-4.6.1 OSD MENU CONFIGURATION - SNMP

NOTICE

When using SNMP monitoring, for reasons of access security, the use of a dedicated network according
to the IT-Grundschutz catalog is recommended. The read only community for the MIB file is DKM.

 
NOTICE

For an activation of the SNMP agent function or the SNMP server function, a restart of the matrix or the
CPU board is necessary. Restarting the matrix or the CPU board can take several minutes, and the

matrix is not available during the restart.
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The following parameters can be configured: 

SNMP Agent

COMPUTER / SOFTWARE / NETWORK RESULTS

Enable  
Y

Permission for an active query of the SNMP agent for traps is granted.

This activation is a prerequisite for using the SNMP server.

Read Community N The read only community for the MIB file is DKM.

SNMP Server

* A matrix configuration should only include one LDAP user and one LDAP

TRAPS DESCRIPTION

Enable Traps
Activates the active sending of trap messages from the SNMP agent to the

SNMP server

Server Address
Input of the IP address of the SNMP server in the form “192.168.1.1” and of the

SNMP port (default: 162)

Status Notification about matrix status

Temperature Notification about temperature within the matrix

Insert Board* Notification about insertion of a new I/O board into a slot

Remove Board* Notification about removal of an I/O board out of a slot

Invalid Board* Notification about a faulty I/O board

Insert Extender
• Notification about a newly connected extender to the matrix, notification

about a switched-on extender
• Notification about a newly established link between extender and matrix

Remove Extender
• Notification about a removed extender from the matrix

• Notification about a switched off extender

• Notification about an interrupted link between extender and matrix

Fan Tray #1 Notification about the fan status on the left side of the matrix (interface view)

Fan Tray #2 Notification about the fan status on the right side of the matrix (interface view)

Power Supply #1 Notification about the status of power supply unit #1

Power Supply #2 Notification about the status of power supply unit #2

Power Supply #3* Notification about the status of power supply unit #3

Power Supply #4* Notification about the status of power supply unit #4
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5.4.7	 SETTING SNMP FUNCTION

Activating the SNMP Agent

To activate the SNMP agent, proceed as follows:

1. Select Configuration > SNMP in the main menu.

2. Set the Enable option to Y (Yes) within SNMP Agent. By activating this option, the permission for an active query of the SNMP 
agent is granted.

3. Click the Okay button to confirm your changes. 

Activate SNMP Traps

To activate active reporting of the SNMP traps, proceed as follows:

1. Select Configuration > SNMP in the main menu.

	 This function allows an active transmission of trap messages from the SNMP agent to the SNMP
	 server.

2. Set the IP address of the SNMP server within Server Address.

3. Activate the requested traps by enabling them to Y (Yes).

4. Click the Okay button to confirm your changes.

FIGURE 5-3.6. OSD MENU CONFIGURATION - NETWORK
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5.4.8	 DATE AND TIME

The parameters for the system configuration are set in this menu, based on Simple Network Time Protocol
(SNTP):

The following parameters can be configured: 

TRAPS DESCRIPTION

SNTP Client

Y Enable network time server synchronization

N Function not active (default)

SNTP Server Byte Input of the SNTP server IP address (default: 000.000.000.000)

Time Zone Region Set your specific time zone

FIGURE 5-4.8.1 OSD MENU CONFIGURATION - DATE + TIME
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FIELD ENTRY DESCRIPTION

Date*

MM 1 to 12 Enter month

DD 1 to 12 Enter Date

YY 1 to 12 Enter Year

Day 1 to 7 Enter day of the week

Time

hh 0 to 23 Enter hour

mm 0 to 59 Enter minute

dd 0 to 59 enter second

* Date format according to the English notation.

Configuring the Time Server

To configure a time server, proceed as follows:

1. Select Configuration > Date+Time in the main menu.

2. Set the SNTP Client option to Y (Yes).

3. Enter the IP address of your SNTP server into the SNTP Server field.

4. Select your time zone in the Time Zone field.

5. Click the Okay button to confirm your settings.

6. Restart the matrix.

The system time will now be provided by the SNTP server.

Configuring the Real Time Clock without Time Server

To set the real time clock without using SNTP, proceed as follows:

1. Select Configuration > Date+Time in the main menu.

2. Set the current date in the Date field.

3. Set the current Day in the Day field.

4. Set the current time in the Time field.

5. Click the RTC button to confirm your settings.

The real time clock is now provided.

FIGURE 5-3.7 OSD MENU CONFIGURATION - SNMP
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5.5	 USER SETTINGS

You have the option to configure the following user settings: 

5.5.1	 USER SETTINGS

New users and their user settings and permissions are set in this menu.

FIGURE 5-5.5.1 OSD MENU CONFIGURATION - USER DATA
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The following functions are available:  
 
 
 

The following keyboard commands are available:

DESCRIPTION

New U. Create a new user

Edit Edit an existing user

Delete Delete an existing user

Cancel Reject changes

Okay Confirm the changes of an existing user or the creation of a new user account

DESCRIPTION

<F> Add highlighted CPU to list Full Access

<V> Add highlighted CPU to list Video Access

<N> Add highlighted CPU to list No Access
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The following parameters can be configured:

DESCRIPTION

ID/ Priority Numerical User ID / User priority

Name Text Username (case sensitive)
Note: A username can consist of up to 32 characters.

Full Name Text Optional: personal username (case sensitive, up to 32
characters)

Password Text User password (case sensitive, input of minimum 8 characters
up to 16 characters)

Repeat Password Text Repeat user password (case sensitive)

Member of Group Selection Define the assignment to a user group

Administrator
Y

• Permission for system configuration and all switching

operations
• User has administrator rights

N Function not active

Super User
Y

Permission to switch any CON Device to any CPU Device in

Extended Switching

N Function not active

Power User
Y

• User has user rights

• Permission to switch CON Devices to CPU Devices s in
Extended Switching according to the CON or User ACL,

but not in Private Mode.

N Function not active

SNMP User
Y Permission to use SNMPv3 (encrypted)

N Function not active

Auto Connect
Y Re-establish the previous user connection after login

N Function not active

AD group locked
Y

Lock synchronization of group attribute for an Active Directory
user. This setting is required for a manual change of user

groups for a specific Active Directory user.

N Function not active (default)

1. Select Configuration > User Data in the main menu.

2. Modify the desired settings.

3. Click the Okay button to confirm your entries. 
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5.5.2	 USER FAVORITE LIST

Individual favorite lists of CPUs that will be switched frequently can be created for different users in this
menu. A favorite list can contain up to 32 different CPU Devices (from firmware V3.05).
The switching of the favorites is done via keyboard commands (see chapter 7.2.1, page 274). 

To create a favorites list for your own user, proceed as follows:

1. Select Assignments > User Favorites in the main menu.

2. Select a CPU Device to be moved to the favorites list on the User Favorites list.

3. Press the <a> key to move a CPU Device to the favorites list.

To remove a CPU Device from the favorite list, press the <r> key.

4. Optional: press the <+> or <-> key to change the order of the CPU Devices within the favorites list.

5. Click the Okay button to confirm the settings.

FIGURE 5-5.2.1 OSD MENU CONFIGURATION - USER FAVORITES
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5.5.3	 USER MACROS

In this menu macro commands for switching, disconnection or user administration can be created. Macro
commands are created for each user separately.
A macro can execute up to 16 switching commands successively.

The execution of the macros is done via Hot Key and the <F1> to <F16> function keys (see chapter 7.2.2,
page 275).

* To execute user macros the user has to be logged in to the matrix.

FIGURE 5-5.2.1 OSD MENU CONFIGURATION - USER MACROS
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The following parameters can be configured:

FIELD SELECTION DESCRIPTION

Function
(01 to 16)

Connect
(P1=CON, P2=CPU)

Set a bidirectional connection from CON Device P1 to CPU
Device P2

Connect Video
(P1=CON, P2=CPU)

Set a Video Only connection from CON Device P1 to CPU
Device P2

Disconnect
(P1=CON) Disconnect the CON Device P1

Logout User Logout the current user

Assign CPU
(P1=VCPU, 
P2=RCPU)

Assign a Virtual CPU Device to a Real CPU Device

Assign CON
(P1=RCON, 
P2=VCON)

Assign a Real CON Device to a Virtual CON Device

Push (P1=CON)
The user’s Full Access connection is forwarded to CON Device

P1 and is changed into a Video Only connection.

Push Video 
(P1=CON)

The video signal of the current connection (Full Access or Video
Only) is forwarded to CON Device P1. The user’s connection

remains unchanged (Full Access or Video Only).

Get (P1=CON)
The user’s CON Device gets a Full Access connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 is changed into a Video Only

connection.

Get Video (P1=CON)
The user’s CON Device gets a Video Only connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 remains unchanged (Full Access

or Video Only).

Login User console 
P2 Login a certain user P1 at CON Device P2

P1 CON or CPU Device Name of CON Device or CPU Device

P2 CON or CON Device Name of CON Device or CPU Device

* The macros can also be used to switch to CPU groups.

 
To create a macro for the selected user, proceed as follows:

1. Select via Configuration > User Macros in the main menu the user for which a user macro has to be
created.

2. Select in the Key field the function key for which a macro has to be created.

3. Select the position in the Key list where a macro command is to be inserted.

4. Select a macro command in the Macro Data field.

5. Set the necessary parameters P1 and P2 (e.g., CON Devices or CPU Devices) for the selected macro
command.

6. Click the Okay button to confirm your selection.

7. Repeat the process for further macro commands if necessary.
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5.5.4	 USER GROUPS

The KVM matrix allows to bundle the users of a configuration into User Groups. The groups can be used to
subdivide the users logically or thematically. As an application example you can group all power users
together. The configuration of User Groups at the same times increases the clarity of the configuration.

* To execute user macros the user has to be logged in to the matrix.

FIGURE 5-4.4.1 OSD MENU ASSIGNMENTS - USER DATA
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To create and configure a User Group, proceed as follows:

1. Select Configuration > User Data in the main menu.

2. Click the New G. button.

3. Enter a group name into the field Name.

4. Click the Okay button to confirm the group creation.

To assign a user to a group, proceed as follows:

1. Select Configuration > User Data in the main menu.

2. Select the user to be assign to a User Group.

3. Select the User Group for the assignment in the field Member of Group using the cursor up and down
     keys.

4. Click the Okay button to confirm the group creation.

BUTTON DESCRIPTION

New G. Create a new group

Edit Edit an existing user

Delete Delete an existing user

Cancel Reject changes

Okay Apply changes

BUTTON DESCRIPTION

<F> Add highlighted CPU to list Full Access

<V> Add highlighted CPU to list Video Access

<N> Add highlighted CPU to list No Access
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5.6	 EXTENDER SETTINGS

The matrix automatically recognizes every extender module, physically connected to the matrix with a direct
cable connection, reads out its serial number and creates EXT Units automatically. This is the Flex Port
function of the matrix. Dual-Head extender modules will be recognized as two independent EXT Units.

Add-on modules are not created as independent EXT Units. The data of add-on modules is included in one
EXT Unit together with the associated extender module.
All EXT Units are managed in this menu. This includes the creation of new EXT Units and the deletion of
existing EXT Units.

 
 
 

FIGURE 5-6.1. OSD MENU CONFIGURATION - EXT UNITS
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The following functions are available

*The settings for the General OSD Data are described in chapter 5.8.2, page 111.

BUTTON FUNCTION

New Create a new EXT Unit

Edit Edit an existing EXT Unit

Delete Delete an existing EXT Unit

Cancel Reject changes

Okay Apply changes

BUTTON FUNCTION

ID -
Numerical value of the KVM extender module ID.

The ID is provided by the extender module (serial number) and
cannot be changed.

Name Text Name of the EXT Unit

Fixed
Y Create an EXT Unit with a fixed port assignment (default)

N Function not active (default)

Port 1/2
1 to 160

(depending on
the matrix)

• Port 1: port number of the matrix the extender module is
currently connected

• Port 2: redundant port number of the matrix the extender
module is currently connected
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5.7	 CONFIGURING AN USB 2.0 EXTENDER

This chapter helps you to configure and use your USB 2.0 EXT Units. USB 2.0 EXT Units can be
configured for independent switching or can be assigned to already existing CON Devices or CPU Devices

 

NOTICE

The connection of a fixed port extender module (e.g., USB 2.0) to a Flex Port can cause unintended
results. EXT Units for USB 2.0 extender modules have to be created manually (see chapter 5.6,

page 106).

 

FIGURE 5-7.1. OSD MENU CONFIGURATION -CPU DEVICES
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To configure a USB 2.0 EXT Unit, proceed as follows:

1. Select Configuration > EXT Units in the main menu.

2. Click the New button.

	 An EXT Unit with an eight-digit ID will be created, starting with digit 9.

3. Enter an appropriate name for the EXT Unit in the Name field.

4. Enter the port number of the matrix the USB 2.0 extender module is currently connected into the Port
     field.

5. To configure the created extender as a CON Unit:

	 5.1. Set the USB-CON (standalone) option to Y (C#1 in the Input Signals column).

	 5.2. Click the Okay button to confirm the setting.

6. To configure the created extender as a CPU Unit:

	 6.1. Set the USB-CPU (standalone) option to Y (C#1 in the Output Signals column).

	 6.2. Click the Okay button to confirm the setting.

7. Click the Okay button to confirm the settings.

8. Restart the I/O board to activate the USB fixed port for the new EXT Unit.

	 After restart of the I/O board, the parameters and settings of the USB 2.0 extender module are shown
	 in the respective EXT Unit.

9. The USB 2.0 CPU/CON EXT Unit has to now be either assigned to an existing CPU/CON Device or a
       new CPU/CON Device has to be created for the assignment:

	 • for a CPU Device see chapter 5.8.1, page 111,

	 • for a CON Device see chapter 5.9.3, page 122

10. If you use parallel operation within the matrix, set the Release Time in the System Settings > Switch
       menu to 10 s or more (see chapter 6.4.5, page 162).

11. Restart all I/O boards on which USB 2.0 EXT Units have been configured or alternatively restart the
      matrix.

	 The USB 2.0 EXT Units are now configured and can be used. 

*Manually created EXT Units are always set as fixed port EXT Units. This configuration is necessary if you
want to switch, e.g., USB 2.0 connections via the matrix.
To make a fixed port available again for Flex Port EXT Units after deleting a fixed port EXT Unit, a restart of
the I/O board is necessary.
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5.8	 CONFIGURING CPU SETTINGS

5.8.1	 SETTING CPU DEVICES

New CPU Devices are configured in this menu including their assignment to EXT Units.
The assignment helps to describe and switch more complex computer configurations (e.g., Quad-Head with
USB 2.0) in the matrix.

FIGURE 5-8.1.1 OSD MENU CONFIGURATION - CPU DEVICES
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The following parameters can be configured:

FIELD ENTRY FUNCTION

ID Text Create a new real CPU Device

Name Text Edit an existing CPU Device

Member of Group Selection Assign the CPU Device to a group

Member of Switch Selection Assign the CPU input to the respective CPU Switch

Remote CPU Selection Assign an IP CPU Device to the respective IP CPU extender unit

CPU assigned - ID and name of the assigned Virtual CPU Device, cannot be
changed, is retrieved automatically

Group
Y Automatically set if the CPU Device is assigned to a CPU Group

N Function not active (default)

Remote CPU
CPU assigned

Y Automatically set for a CPU Switch (484 Series)

N Function not active (default)

Remote Access
Y Automatically set for an IP CPU Device

N Function not active (default)

Virtual Device
Y Automatically set for a Virtual CPU Device

N Function not active (default)

Allow Private
Y Allow switching to the respective CPU Device in Private Mode

N Function not active (default)

Force Private
Y Force switching to the respective CPU only in Private Mode

N Function not active (default)

Fix Color Y Force showing a colored frame when switching to the respective
CPU. You can select between 7 colors.

Reference
Y

Activate a reference CPU Device that inherits both Device and
extender settings to any CPU Unit that is connected to the

matrix for the first time.
Note: It is recommended to activate the reference setting for

one single CPU Device only.

N Function not active (default)

2 Step Access
Y

Open a pop-up window after switching to the particular CPU
Device. In the background a Video Only connection will be

established. A confirmation in the pop-up window is required to
establish a Full Access connection to the CPU Device.

N Function not active (default)
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To create a CPU Device, proceed as follows:

1. Select Configuration > CPU Devices in the main menu.

2. Click the New R. button to create a new real CPU Device or click the New V. button to create a new
virtual CPU Device.

3. Enter a CPU Device name into the field Name.

4. Click the Okay button.

The CPU Device is created now.

To assign an extender unit to a CPU Device, proceed as follows:

1. Select Configuration > CPU Devices in the main menu.

2. Select the CPU Device you want to assign an extender unit.

3. Select the extender unit for the assignment in the EXT available list.

4. Click the Okay button.

The CPU Device is assigned to the CPU Device now.

BUTTON FUNCTION

New R Create a new real CPU Device

Edit Edit an existing CPU Device

Delete Delete an existing CPU Device

Cancel Reject changes

FIELD ENTRY FUNCTION

Exclusive Access
Y

Activate an access limitation for the case that a CPU Device is
already connected via Full Access connection. When having the

same priorities, any additional access to the CPU Device can
only be established with a Video Only connection. Having a

lower priority any additional connection is not possible. Only
when having a higher priority, an additional Full Access

connection can be established, and K/M control can be taken
over.

N Function not active (default)

MSC disabled
Y Assign the CPU Device to a group

N Activate Multi-Screen Control function

CPU Colors Selection list
The CPU Device name will be highlighted according to the color

setting for text and background. You can select between 16
colors.
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5.8.2	 SETTING CPU GROUPS

The KVM matrix allows to bundle the CPU Devices of a configuration into CPU groups. The groups can be
used to subdivide the CPU Devices logically or thematically. As an application example you can group all
CPU Devices together that are connected to a specific matrix in a matrix grid. The configuration of CPU
groups at the same times increases the clarity of the configuration. 

 
 
 
 
 
 

FIGURE 5-8.2.1 OSD MENU CONFIGURATION - CPU DEVICES
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The following functions are available:

 

 
To create a CPU Group, proceed as follows:

1. Select Configuration > CPU Devices in the main menu.

2. Click the New G. button.

3. Enter a CPU Group name into the field Name.

4. Click the Okay button.

The CPU Group is created now.

To assign a CPU Device to a group, proceed as follows:

1. Select Configuration > CPU Devices in the main menu.

2. Select the CPU Device you want to assign to a CPU group.

3. Select the CPU Group for the assignment in the field Member of Group using the cursor up and down
    keys.

4. Click the Okay button.
     The CPU Device is assigned to the CPU Group now.

BUTTON DESCRIPTION

New G. Create a new CPU group

Edit Edit an existing CPU Group

Delete Delete an existing CPU Group

Cancel Reject changes

Okay Apply changes

BUTTON FUNCTION

ID Text Ident number of the CPU Group

Name Text Name of the CPU Groupt

Member of Group Selection Assign the CPU Device to a group

Group

Y Function not active (default)

N
• Port 1: port number of the matrix the extender module is

currently connected
• Port 2: redundant port number of the matrix the extender

module is currently connected
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5.8.3	 CONFIGURATION CPU SWITCH

The CPU Switch (484 Series) is an 8:1 port concentrator for up to eight sources (computer, CPU) attached
via VGA and USB-HID (K/M).
This CPU Switch can be specifically configured for a use with a KVM matrix. The configuration allows to
individually switch the up to eight input signals via OSD. 

BUTTON DESCRIPTION

New S. Create a new CPU Switch (484 series)

New SP. Create a CPU extender unit for a CPU Switch

Edit Edit an existing CPU Device

Delete Delete an existing CPU Group

Cancel Reject changes

Okay Apply changes

FIGURE 5-8.3.1 OSD MENU CONFIGURATION - CPU DEVICES

CHAPTER 5: OSD CONFIGURATION



1161.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

The following parameters can be configured:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
Further parameters are described in chapter 5.8.1, page 110.

To create a CPU Group, proceed as follows:

1. Select Configuration > CPU Devices in the main menu.

2. Click the New S. button.

	 A new CPU Switch will be created.

3. Enter a CPU Switch name into the field Name.

4. Assign an extender unit to the CPU Switch into the field EXT assigned.

5. Click the New SP. button.

A new CPU (input) for a CPU Switch will be created (Port 1).

6. Assign the created CPU input to a CPU switch in the field Member of Switch.

7. Repeat the steps 5. and 6. for each input port in use at the CPU Switch.

8. Click the Okay button.

The CPU Switch is now configured and can be individually switched via OSD.

FIELD ENTRY DESCRIPTION

ID Text
Numerical value of the KVM extender module ID.

The ID is provided by the extender module (serial number) and
cannot be changed.

Name Text Name of the EXT Unit

Member of Switch Selection Assign the CPU input to the respective CPU Switch

Switch
Y Automatically set for a CPU Switch (484 Series)

N Function not active (default)
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5.8.4	 VIRTUAL CPU DEVICE

In this menu, either one or more Virtual CPU Devices can be assigned to a Real CPU Device.
With a Virtual CPU Device, the effort of switching several CON Devices to the same CPU Device can be
reduced. 

If several CON Devices are connected to a Virtual CPU Device that is assigned to a Real CPU
Device, you only have to change the Real CPU Device once and all consoles will receive the video signal of
the new Real CPU Device.

*One Real CPU Device can be assigned to several Virtual CPU Devices.

FIGURE 5-8.4.1 OSD MENU CONFIGURATION - VIRTUAL CPU DEVICES
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The following functions are available: 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

For an assignment of Virtual CPU Devices to Real CPU Devices, proceed as follows:

1. Select Assignments > Virtual CPU Devices in the main menu.

2. Select the Virtual CPU Device in the Virtual Devices list that has to be assigned to a Real CPU
Device.

3. Click the Edit button.

4. Select the Real CPU Device in the Real Devices list that has to be assigned to the selected Virtual
CPU Device.

5. Click the Okay button to confirm the assignment.

The selected Virtual CPU Device is assigned to the Real CPU Device. 

BUTTON DESCRIPTION

New V. Create a new virtual CPU Device

Edit Edit an existing CPU Device

Delete Edit an existing CPU Device

Cancel Reject changes

Okay Apply changes
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5.9	 CONFIGURING CONSOLE SETTINGS

Connecting a CON Unit to the matrix creates an EXT Unit in the matrix, reading the serial number of the
CON Unit. An Ext Unit has to be assigned to a CON Device. 

Switching operation is only possible between
CON Device and CPU Device. All steps to create switchable CON Devices are described in this chapter.
Several Real CON Devices can be assigned to a Virtual CON Device to reduce operation efforts (see
chapter 5.8.6, page 106).

5.9.1	 OSD CONFIGURATION FOR MOUSE AND KEYBOARD

The OSD configuration for mouse and keyboard is made in this menu. The settings for mouse and
keyboard are console-specific and can be set separately for each console.

 
 
 

 

 

FIGURE 5-9.1.1 OSD MENU CONFIGURATION - EXT UNITS
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The following parameters can be configured:  
 
 
 
 
 
 
 

 

To change the settings for mouse and keyboard, proceed as follows:

1. Select Configuration > EXT Units in the main menu.

2. Select the console extender in the EXT Units list whose Extender OSD settings has to be adjusted.

3. Click the Edit button or press the <Enter> key to confirm the selection.

4. Modify the desired settings.

5. Click the Okay button to confirm your changes. 
 

5.9.2	 SETTING EXTENDER OSD

In this menu the parameters for the Extender OSD can be set. The settings for mouse and keyboard are
console-specific and can be set separately for each console. 
 
*When setting the horizontal OSD position, a prefixed minus describes the orientation to the right edge of
the monitor, e.g., -2 means 2 x 10 = 20 pixels to this edge. When setting a vertical position, a prefixed
minus describes the orientation to the bottom edge of the monitor.
If the Update connection info function is deactivated, the Extender OSD only appears when switching via
OSD.

 

FIELD ENTRY FUNCTION

Hor. Speed 1/x 1 to 9 Adjustment of the horizontal mouse speed, 1 = slow, 9 = fast
(default: 4)

Ver. Speed 1/x 1 to 9 Adjustment of the vertical mouse speed, 1 = slow, 9 = fast
(default: 5)

Double-click 100 to 800 Adjustment of the time slot for a double-click (default: 200 ms)

Keyboard layout Region Set the OSD keyboard layout according to the used keyboard
(default: German (DE))

Video Mode
Variable or

specific
resolution

Resolution that is used when opening OSD
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The following parameters can be configured:

FIELD ENTRY FUNCTION

Enable CPU 
selection

Y
When executing the key sequence for opening the OSD, a

selection list for switching CPU Devices will be displayed in the
center of the monitor. Pressing the <F7> key within the

selection list opens the standard OSD.

N Function not active (default)

Enable connection
Y Enable Extender OSD (default: Y)

N Function not active

Update connection
info

Y Update connection changes during fade-in of Extender OSD
(default: Y)

N Function not active

Display Time [sec] 0 to 999
seconds Automatically set if the CPU Device is assigned to a CPU Group

Horizontal position 10 Pixels Horizontal OSD position (default: -2)

Vertical position 10 Pixels Vertical OSD position (default: 2)

FIGURE 5-9.2.1 OSD MENU CONFIGURATION - EXT UNITS
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To change the Extender OSD settings, proceed as follows:

1. Select Configuration > EXT Units in the main menu.

2. Select the console extender in the EXT Units list whose Extender OSD settings has to be adjusted.

3. Click the Edit button or press the <Enter> key to confirm the selection.

4. Modify the desired settings.

5. Click the Okay button to confirm your changes.

5.9.3	 SETTING CON DEVICES

New CON Devices are created in this menu including access rights and assignment to extenders.

FIGURE 5-9.3.1 OSD MENU CONFIGURATION - CON DEVICES
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The following functions are available:

The following parameters can be configured:

BUTTON DESCRIPTION

New R. Create a real console

New V. Create a virtual console

Edit Edit an existing console

Delete Delete an existing console

Cancel Reject changes

Okay Apply changes

FIELD ENTRY FUNCTION

ID Text ID of the CON extender unit

Priority 0 to 999

Priority of the CON Device

Note: There is no K/M sharing between CON Devices with a
different priority and the release time does not come into

account. CON Devices only have Video Only access to a CPU
Device if a CON Device with a higher priority is already switched

to it.

Name Text Name of the CON Device

Show Macro List
Y Show the macro list instead of the CPU selection list

N Function not active (default)

Allow User ACL
Y Allow activation of the User ACL at the local console

N Function not active (default)

LOS Frame
Y

• When the video signal between source (computer, CPU) and
the CPU Unit or the connection between matrix and the

CON Unit is lost, an orange frame will be displayed.
• When switching to a CPU without video signal, a blank

screen will appear surrounded by an orange frame.

N Function not active (default)

Disable OSD
Y Automatically set for a CPU Switch (484 Series)

N Function not active (default)

CPU Colors
Y Automatically set for an IP CPU Device

N Function not active (default)
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The following parameters can be configured: 

FIELD ENTRY FUNCTION

Allow CPU Scan
Y Allow switching to the respective CPU Device in Private Mode

N Function not active (default)

Force CPU Scan
Y Force switching to the respective CPU only in Private Mode

N Function not active (default)

Scan Time 0 to 99
seconds Retention period until switching to the next CPU Device

Port Mode
Y

The favorite list will be replaced by a port list where the ports
from 1-999 can be directly selected at each matrix or Matrix

Grid.
Note: The selection only works for CPU Devices and has to be made according to the 

switching of favorites. When using the Port Mode, CON and User favorites will be
deactivated.

N Function not active (default)

Redundancy Off

Y Function is not active

N
Automatically switch to the second link of a connected

redundant CON Unit when losing the primary link of a CPU Unit
(default).

Reference
Y

Activate a reference CON Device that inherits both Device and
extender settings to any CON Unit that is connected to the matrix for the first time.

Note: It is recommended to activate the reference setting for
one single CON Device only.

N Function not active (default)

Fix Color Selection list
Show a colored frame at the CPU Device. You can select

between 7 colors. The colored frame of the CPU device is
displayed with priority.
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To create a CON Device, proceed as follows:

1. Select Configuration > CON Devices in the main menu.

2. Click the New R. button to create a new Real CON Device or click the New V. button to create a new
Virtual CON Device.

3. Enter a CON Device name into the field Name.

4. Click the Okay button.

The CON Device is created now.

To assign an extender unit to a CON Device, proceed as follows:

1. Select Configuration > CON Devices in the main menu.

2. Select the CON Device you want to assign an extender unit.

3. Select the extender unit for the assignment in the EXT available list.

4. Click the Okay button.
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5.9.4	 SETTING CON DEVICE FAVORITES

Individual favorite lists of CPUs to be switched frequently can be created for all consoles in this menu. A
favorite list can contain up to 32 different CPU Devices (from firmware V3.05).
The switching of the favorites is done via Hot Key using the keyboard (see chapter 7.2.1, page 274).

FIGURE 5-9.4.1 OSD MENU CONFIGURATION - CON FAVORITES
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FIGURE 5-9.5.1 OSD MENU ASSIGNMENTS - CON MACROS

5.9.5	 SETTING CON DEVICE MACROS

In this menu macro commands for switching, disconnection or user administration can be created. The
macro commands are created for each console separately. Up to 32 macros can be configured per each
CON Device.

A macro can execute up to 16 switching commands successively.
The execution of the macros is done via Hot Key and the function keys <F1> to <F16> (see chapter 7.2.2,
page 273).

* The macros can also be used to switch to CPU groups.
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FIELD SELECTION DESCRIPTION

Function
(01 to 16)

Connect
(P1=CON, P2=CPU)

Set a bidirectional connection from CON Device P1 to CPU
Device P2

Connect Video
(P1=CON, P2=CPU) Set video connection from CON Device P1 to CPU Device P2

Disconnect
(P1=CON) Disconnect the CON Device P1

Logout User Logout the current user

Set Real CPU
(P1=VCPU, 
P2=RCPU)

Assign a Virtual CPU Device to a Real CPU Device

Assign CON
(P1=RCON, 
P2=VCON)

Assign a Real CON Device to a Virtual CON Device

Push (P1=CON)
The user’s Full Access connection is forwarded to CON Device

P1 and is changed into a Video Only connection.

Push Video 
(P1=CON)

The video signal of the current connection (Full Access or Video
Only) is forwarded to CON Device P1. The user’s connection

remains unchanged (Full Access or Video Only).

Get (P1=CON)
The user’s CON Device gets a Full Access connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 is changed into a Video Only

connection.

Get Video (P1=CON)
The user’s CON Device gets a Video Only connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 remains unchanged (Full Access

or Video Only).

Login User console 
P2 Login a certain user P1 at CON Device P2

P1 CON or CPU Device Name of CON Device or CPU Device

P2 CPU or CPU Device Name of CON Device or CPU Device

 
To create a macro for the selected console, proceed as follows:

1. Select Configuration > CON Macros in the main menu.

1. Select the CON Device for which a console macro is to be created.

2. Select in the Key field the function key (<F1> to <F32>) for which a macro should be created.

3. Select the respective place on the list (1 to 16) for the key that should be set with a macro key.

4. Select for the highlighted position on the list a macro command in the Macro Data field.

5. Set the necessary parameters P1 and P2 (e.g., CON Devices or CPU Devices) for the selected macro

	 command.

6. Confirm your inputs by pressing <Enter> and repeat the process for further macro commands if necessary.
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5.9.6	 CREATING AND ASSIGNING VIRTUAL CON DEVICES

In this menu, several Real CON Devices can be assigned to a Virtual CON Device.

This function reflects changes in permission made to Virtual CON Devices onto Real CON Devices. Virtual CON Devices 
can be switched in the same way as Real CON Devices. 

Real CON Devices that are assigned to a Virtual CON Devices that is connected to a CPU Device will receive the video sig-
nal. The last-assigned CON Device will also have control of the keyboard and mouse.

* A Virtual CON Device can be assigned to more than one Real CON Devices.

For an assignment, proceed as follows:

1. Select Assignments > Virtual CON Devices in the main menu.

2. Select the Real CON Device in the Real Devices list that has to be assigned to a Virtual CON Device.

3. Click the Edit button.

4. Select the virtual console in the Virtual Devices list that has to be assigned to the selected Real CON
     Device.

5. Click the Okay button to confirm the assignment
     The selected Virtual CON Device is assigned to the Real CON Device.

FIGURE 5-9.6.1 OSD MENU ASSIGNMENTS - VIRTUAL CON DEVICES
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5.9.7	 ENABLING MULTI-SCREEN CONTROL

*Due to limited options via OSD, we recommend configuring the Multi-Screen Control only via management
software to carry out the extended configuration options (from firmware V03.08), see chapter 6.9.8, page 238.

When using Multi-Screen Control, switching up to eight connected sources (computers, CPUs) can be
performed at one sink with only one connected mouse and/or keyboard. The sink can consist of up to eight
CON Units and accordingly up to eight monitors, or up to sixteen monitors when using Dual-Head
extenders modules. In a matrix system, Multi-Screen Control can be set up at multiple sinks. The
CON Units of a sink with Multi-Screen Control must all be physically connected to the same block of 8 ports
on the I/O board.

One of the CON Devices is designated for USB-HID control of the connected sources, below referred to as
“Control CON Device”. Control CON Devices are referred to the extender modules/Ext Units within the
Multi-Screen Control that are connected to keyboard and mouse for operation. If the control has to be
performed via several USB-HID devices, several CON Devices have to be defined as Control CON Device.

Smooth switching of sources with the mouse is performed by dragging the mouse pointer beyond the
respective display to an adjacent display in an arrangement of displays. The displays can be arranged side
by side, in a grid layout, or completely freely. Alternatively, switching can be performed via keyboard
commands according to the ID number in the Multi-Screen Control setup.
 
 
 
 
 
 
 
 
 
 
*When configuring Multi-Screen Control via OSD, the number of supported displays is limited to four.
To configure more than four displays (up to eight with Single-Head and up to sixteen with Dual-Head
installation), you have to configure the Multi-Screen Control only via management software.

*The connected sources (computer, PC) need to support absolute mouse mode. Else a specific mouse
driver needs to be installed.

*CON Units that have been already configured for Multi-Screen Control can be connected all together to
other blocks of 8 ports. In this case any further configuration is not necessary, their functionality will remain
as set previously.

NOTICE

When using CON Units with the possibility to connect a local source (computer, CPU) in a Multi-Screen
Control environment, the local switching will be disabled.

CHAPTER 5: OSD CONFIGURATION



131 1.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

The following parameters can be configured:

FIELD SELECTION DESCRIPTION

Enable
Y Activate the respective display for Multi-Screen Control

N Function not active (default)

Control
Y

Enable the CON Device for USB-HID control of other CON

Devices if access is permitted

N Function not active (default)

Owner Selection

• Shared (default) permits the access from a Control CON
Device to all other CON Devices except to another Control

CON Device
• Name of the own Control CON Device to restrict access to

other CON Devices

Frame 0 to 999
seconds

Time for fade in a red frame at the display with current
mouse/keyboard control

 
*Configure the Multi-Screen Control at a CON Device that should be used to control USB-HID in the setup.
To change or delete a Multi-Screen Control setup, you have to open the OSD of the defined Control CON
Device.

FIGURE5-9.7.1 OSD MENU ASSIGNMENTS - MULTI-SCREEN CONTROL
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Configuring Multi-Screen Control

To configure the Multi-Screen Control, proceed as follows:

1. Open the OSD of a CON Unit connected to an I/O board for which the connected CON Units are to be

     configured for Multi-Screen Control.

2. Select Assignments > Multi-Screen Control in the main menu.

     Only the CON Ext Units connected to the selected I/O board are visible.

3. In the Arrangement field, select the layout for the CON Device you want to configure (1 x 4 or 2 x 2).

     The fields for the configuration of the individual displays will be arranged accordingly.

4. Activate Manual option if the USB-HID switching is to be restricted to keyboard commands (see

     chapter 7.2.6, page 276). Manual switching allows the use of multi-head consoles.

5. Set the Enable option to Y on all CON Devices to activate the respective display for Multi-Screen Control.

6. Set the Control function to Y on one or more CON Devices to be enabled as Control CON Device.

7. Use the Frame function to configure a red frame, that shows the display with current mouse control, for  the 
     duration of a specified time by flashing briefly. The frame can be activated individually for each screen by using   
     a timer > 0 seconds.

*All Control CON Devices are enabled to control USB-HID of all other CON Devices in the setup except of another Control 
CON Device. To restrict the access to other CON Devices, see following section.

* To configure Multi-Screen Control for further I/O boards via OSD, connect to the I/O board at a CON Device that should be used 
to control USB-HID in the setup.

Access restriction when using multiple Control CON Devices

Dragging the mouse pointer over the display boundary is only permitted for those displays whose CON Device is enabled 
for access by the owner of the respective Control CON Device.

To enable access to a display for only one Control CON Device, proceed as follows:

1. Click in the Owner field of a Control CON Device and select the name of the Control CON Device.

2. Click in the Owner field of all Control CON Device whose display should be accessible and select the name of the respec-
tive Control CON Device.

The mouse can now be used to access those displays whose CON Device is permitted for access by the enabled Control 
CON Device.

No simultaneous USB HID sharing of multiple Control CON devices.

Example: In a setup of 4 CON Devices, if CON Device 1 and 2 are each Control CON Devices and two other “non-Control 
CON Devices” are configured, both Control CON Devices can access the displays of CON Device 3 to 4 if they are config-
ured with Owner = Sharing.

However, Control CON Device 1 and 2 cannot access the display of a “non-Control CON Device” at the same time. The Con-
trol CON Device that first had USB-HID control is reset to its “own” display when the second Control CON Device take over.
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Changing Multi-Screen Control

To change the Multi-Screen Control for a setup of a specific I/O board, proceed as follows:

1. Open the OSD of a Control CON Device of the specific I/O board.

2. Select Assignments > Multi-Screen Control in the main menu.

    Only the CON Ext Units connected to the selected I/O board are visible.

3. Make any edits at the configuration.

4. Click the Okay button to confirm the changes.

 
Deleting Multi-Screen Control

    To delete the Multi-Screen Control for a setup of a specific I/O board, proceed as follows:

1. Open the OSD of a Control CON Device of the specific I/O board.

2. Select Assignments > Multi-Screen Control in the main menu.

     Only the CON Ext Units connected to the selected I/O board are visible.

3. Set the Enable option to N on all CON Devices.

     The Multi-Screen Control is disabled for all CON Devices of the selected I/O board.

4. Click the Okay button to confirm the changes.

5.10	 SAVING AND ACTIVATING A CONFIGURATION

First starting the DKM, the factory configuration will be copied into the current configuration. You have

2 possibilities to save configuration changes:

     • saving the current configuration permanently in the DKM memory (Save) or

     • saving the configuration in up to 8 predefined storage locations, as well as the default configuration in

the memory of the DKM (Save as...)

NOTICE

By default, the last configuration that has been saved in the permanent DKM memory will be
restored after a restart of the DKM.
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5.10.1	 SAVING THE ACTIVE CONFIGURATION

 
 
 
 
 
 
 
 
 
* If you select Auto Save within the system settings an additional automatic saving of the configuration will
be periodically performed (see chapter 5.4.1, page 81).

To save the current configuration permanently in the DKM storage, proceed as follows:

Select Configuration > Save in the main menu.

The current configuration of the DKM is permanently saved to the DKM memory.

NOTICE

Changing or saving configurations blocks the DKM memory and leads to a freeze of all OSD menus
for a few seconds. The switching connections are not affected by this freeze.

FIGURE5-10.1.1 OSD MENU CONFIGURATION - SAVE
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SAVING POSITION NAME AND DETAILED INFORMATION

Active Name and detailed information of the current configuration are shown. This
configuration can be saved (function Save, see chapter 5.9.1, page 110).

Default Name and detailed information of the respective saved configuration are shown.
This storage location can be overwritten.

File #1 to File #8 Name and detailed information of the respective saved configuration are shown.
These storage locations can be overwritten.

5.10.2	 SAVING A PREDEFINED CONFIGURATION

In this menu the current matrix configuration is saved to predefined storage locations in the permanent
memory of the matrix. 

You have the possibility to save the created configuration within eight storage
locations in the matrix (File #1 to File #8). Additionally, a default configuration can be saved that can be
loaded as default configuration for each start of the matrix (see chapter 5.4.1, page 81). However, it does
not replace the buffering of configuration.

The storage location to be overwritten by the current configuration must be selected explicitly.
The current configuration will be saved to this storage location and will be shown immediately in the menu.
The previously saved configuration saved to this storage location is overwritten. 
 
 
 
 

FIGURE5-9.10.2.1 OSD MENU ASSIGNMENTS - SAVE AS..
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To save the created configuration to a specific memory location, proceed as follows:

1. Select Configuration > Save As... in the main menu.

2. Select the required storage location (File #1 to File #8) or Default.

The current configuration is saved to this storage location and is shown immediately in the menu. The
previously saved configuration saved to this storage location is deleted.

5.10.3	 ACTIVATING A PREDEFINED CONFIGURATION

Previously saved configurations are displayed in this menu. In Active, the currently loaded configuration is
displayed. To replace the current configuration by another configuration, in addition to the default
configuration (Default), one out of eight further, customized configurations (File #1 to File #8) can be
activated. 

To activate a previously saved configuration, proceed as follows:

1. Select Configuration > Open in the main menu.

2. Select the desired configuration.

3. Click the Okay button to activate the selected configuration.

The selected configuration is immediately loaded and displayed in the menu as Active. The previously
active configuration is overwritten.

FIGURE5-9.10.3.1 OSD MENU ASSIGNMENTS - OPEN..
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5.11	  ACTIVE DIRECTORY

The KVM matrix can be synchronized with the directory service Active Directory with regard to user authentication. This al-
lows the user to login at the KVM matrix using login information from the Active Directory service and to contact the Active 
Directory Server for each authentication that does in fact the proper authentication.

The connection between KVM matrix and the Active Directory server is established via OpenLDAP and
periodically synchronized every 5 minutes.

The search of users to be synchronized and automatically added to the KVM matrix configuration can either
be based on a group or organizational unit (OU). In both cases a user requires to be at least assigned to one group:

	 • In case of the group, all users belonging to a previously defined group on the active directory server are
	   added to the KVM matrix and synchronized. In this alternative, the organizational structure of the
	   organizational units (OUs) is added as matrix user group to the KVM matrix configuration. This means
	   that the organizational unit (OU) that includes the user can be found as a matrix user group in the KVM
	   matrix configuration after the synchronization. A user can be member of up to 8 groups.

	 • In case of the organizational unit, all users belonging to groups that are located directly under this
	   organizational unit are added and synchronized. The groups can also include subgroups. The structure
	   of the groups is added to the KVM matrix configuration as user group. Each group will be represented in
	   the KVM matrix as a user group after the synchronization. Groups that are located in sub organizational
	   units will be ignored. 
 
 
 

FIGURE5-9.11.1.1 OSD CONFIGURATION - NETWORK
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NOTICE

Activating a configuration will immediately disconnect and restart the matrix. The selected configuration is
loaded on restart and is shown in the menu as active configuration under Active. The previously active

configuration is overwritten.
The restart of the matrix may take several minutes, and the matrix is not available during the restart.

*A matrix configuration should only include one LDAP user and one LDAP group at the same time. The
LDAP user and the LDAP group can be created, changed, or deleted during ongoing operation: No restart
of the matrix is required. 

To configure the synchronization to the Active Directory server, proceed as follows:

1. Select Configuration > Network in the main menu of the KVM matrix.

2. Activate at least the function LDAP and optionally LDAP TLS/SSL.

3. Enter the appropriate IP address and the port number in the field LDAP Server (default port number:
     389).

4. Enter the LDAP Base DN into the appropriate field (e.g., dc=example, dc=com).

*Changes done in step 2 to 4 only come into effect after a restart of the KVM matrix.

5. Select Configuration > User Data in the main menu of the KVM matrix.

FIGURE5-9.11.1.1 OSD CONFIGURATION - USER
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6. Click the New LU button to create a new LDAP user. This user functions as a bind user.

7. Enter a name into the field name Name.

8. Enter the Common Name (CN) of the bind user into the field Login Name. 
 
9. Enter the password of the bind user from the Active Directory into the fields Password and Repeat
     Password.

10. Click the Okay button to confirm the creation of the user.

11. Stay in the menu Configuration > User Data.

12. Click the New LG button to create a new LDAP group. The group determines which users of the Active
       Directory server should be synchronized.
  
13. Enter a name into the field Name.

14. Enter either the Common Name (CN) of a group or the Common Name (CN) of an organizational unit

into the field LDAP OU=/CN= as shown below:

	 • OU= name of the organizational unit

	 • CN= name of the group

Note: The field entry must include either OU= or CN=.

15. Click the Okay button to confirm the creation of the group.

The Active Directory synchronization can be used now.

5.12	 MATRIX CASCADING

This simple method of cascading allows a switchable connection between two matrices via so called Tie
Lines. The Matrix Cascading does not require Bundle 4.

This kind of configuration may become necessary if the number of ports in the entire system has to be
increased or if certain important connections should be distributed to several matrices due to reasons of
redundancy.

The Tie Lines are unidirectional and can only be used in one direction according to their configuration. For
a bidirectional use of the cascading, you have to configure opposite Tie Lines.
To connect Tie Lines to the matrices, you have to create intended Cascade CON Devices and Cascade
CPU Devices that have to be switched within the cascaded environment.

*Define a Master Matrix. All further matrices will be configured as Sub Matrices in the configuration process.
Ensure that the Tie Lines will only be connected after finishing the configuration.

5.12.1	 DIRECTING A TIE LINE FROM THE SUB TO THE MASTER

To configure settings for using Matrix Cascading and to direct the Tie Line from the Sub to the Master,
proceed as follows:

1. Open the OSD of the Master Matrix.

2. Select Configuration > EXT Units in the main menu of the Master Matrix.

	 2.1. Click the New button.

A new Extender Unit will be created.

FIGURE 2-14. BACK PANEL
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	 2.2. Enter an appropriate name for the Cascading CPU Unit into the Name field.

	 2.3. Enter a port number into the Port field according to the required connection of the Tie Line.

	 2.4. Set the Cascade-CPU option to Y (C#1) in the Output Signals column.

	 2.5. Click the Okay button to confirm the creation of a Cascading CPU Unit.

3. Select Configuration > CPU Devices in the main menu of the Master Matrix.

	 3.1. Click the New R. button.

	 A switchable CPU Device will be created.

	  
 

FIGURE5-9.12.1.1 OSD CONFIGURATION - EXT UNITS
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3.1. Enter an appropriate Cascading CPU Device into the Name field.

3.2. Select the previously configured Cascading CPU Unit in the Extender available list.

3.3. Press the <a> key to move the Cascading CPU Unit to the EXT assigned list.

The assignment is displayed in the Extender assigned list.

	 3.4. Click the Okay button to confirm the assignment.

4. Open the OSD of the Sub Matrix.

5. Select Configuration > EXT Units in the main menu of the Sub Matrix.

	 5.1. Click the New button.
	
A new Extender Unit will be created.

FIGURE5-9.12.1.2 OSD CONFIGURATION - CPU DEVICES
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	 5.2. Enter an appropriate name for the Cascading CON Unit into the Name field.

	 5.3. Enter a port number into the Port field according to the required connection of the Tie Line.

	 5.4. Set the Cascade-CON option to Y (C#1) in the Input Signals column.

	 5.5. Click the Okay button to confirm the creation of a Cascading CON Unit.

	 6. Select Configuration > CON Devices in the main menu of the Sub Matrix.
		
		  6.1. Click the New R. button.
			 
		  A switchable CON Device will be created.
	

 

FIGURE 2-14. BACK PANEL

FIGURE5-9.12.1.3 OSD CONFIGURATION - EXT UNITS
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	 6.2. Enter an appropriate name for the Cascading CON Device into the Name field.

	 6.3. Press the <a> key to move the Cascading CON Unit to the EXT assigned list.

 	      The assignment is displayed in the Extender assigned list.

	 6.4. Click the Okay button to confirm the assignment.

7. Select Configuration > System in the main menu of the Sub Matrix.

	 7.1. Set the Sub Matrix option to Y.
	
	 7.2. Click the Okay button to confirm the Sub Matrix option.

*The OSD of the Sub Matrix will immediately freeze and will be only accessible by using the keyboard
command <Hot Key>, <s>, <o>.

8. Restart all I/O boards (see chapter 7.11.3, page 321) on which any Master/Sub CON Units or CPU Units
    have been configured or alternatively restart the matrix (see chapter 7.11.1, page 320).

FIGURE5-9.12.1.2 OSD CONFIGURATION - EXT UNITS
FIGURE5-9.12.1.4 OSD CONFIGURATION - CON DEVICES
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9. Connect the Tie Lines to the matrices. Ensure that each Cascade CON Device on one matrix is connected to    	     
Cascade CPU Device on the other matrix to achieve switchability between two matrices.

The Matrix Cascading is now configured and can be used.
Additional Tie Lines are configured accordingly. The use of cascading is described in chapter 6.11,
page 247.

5.12.2	 DIRECTING A TIE LINE FROM THE MASTER TO THE SUB

To configure settings for using Matrix Cascading and to direct the Tie Line from the Sub to the Master,
proceed as follows:

1. Open the OSD of the Master Matrix.

2. Select Configuration > EXT Units in the main menu of the Master Matrix.

	 2.1. Click the New button.

A new Extender Unit will be created. 

FIGURE5-9.12.1.5 OSD CONFIGURATION - SYSTEM
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2.2. Enter an appropriate name for the Cascading CON Unit into the Name field.

2.3. Enter a port number into the Port field according to the required connection of the Tie Line.

2.4. Set the Cascade-CON option to Y (C#1) in the Input Signals column.

2.5. Click the Okay button to confirm the creation of a Cascading CON Unit. 

3. Select Configuration > CON Devices in the main menu of the Master Matrix.

	 3.1. Click the New R. button.
	 A switchable CON Device will be created.

FIGURE5-9.12.2.1 OSD CONFIGURATION - EXT UNITS
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	 3.2. Enter an appropriate name for the Cascading CON Device into the Name field.

	 3.3. Select the previously configured Cascading CON Unit in the Extender available list.
	
	 3.4. Press the <a> key to move the Cascading CON Unit to the EXT assigned list.

	 The assignment is displayed in the Extender assigned list.

	 3.5. Click the Okay button to confirm the assignment.

FIGURE5-9.12.2.2 OSD CONFIGURATION - CON DEVICES
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4. Open the OSD of the Sub Matrix.

5. Select Configuration > EXT Units in the main menu of the Sub Matrix.

	 5.1. Click the New button.

		  A new Extender Unit will be created.

	 5.2. Enter an appropriate name for the Cascading CPU Unit into the Name field.

	 5.3. Enter a port number into the Port field according to the required connection of the Tie Line.

	 5.4. Set the Cascade-CPU option to Y (C#1) in the Output Signals column.

	 5.5. Click the Okay button to confirm the creation of a Cascading CPU Unit.

	 6.1. Enter an appropriate name for the Cascading CPU Device into the Name field.

	 6.2. Press the <a> key to move the Cascading CPU Unit to the EXT assigned list.

		  The assignment is displayed in the Extender assigned list.

	 6.3. Click the Okay button to confirm the assignment.

FIGURE5-9.12.2.3 OSD CONFIGURATION - CPU DEVICES
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7. Select Configuration > System in the main menu of the Sub Matrix.

	 7.1. Set the Sub Matrix option to Y.

	 7.2. Click the Okay button to confirm the Sub Matrix option.

*Define a Master Matrix. All further matrices will be configured as Sub Matrices in the configuration process.
Ensure that the Tie Lines will only be connected after finishing the configuration

 
 
 
 
 
 

8. Restart all I/O boards (see chapter 7.11.3, page 321) on which any Master/Sub CON Units or CPU Units
have been configured or alternatively restart the matrix (see chapter 7.11.2, page 320).

9. Connect the Tie Lines to the matrices. Ensure that each Cascade CON Device on one matrix is
connected to Cascade CPU Device on the other matrix to achieve switching ability between two
matrices.

The Matrix Cascading is now configured and can be used.

Additional Tie Lines are configured accordingly. The use of cascading is described in chapter 6.11,
page 247.

FIGURE5-9.12.2.3 OSD CONFIGURATION - CPU DEVICES

FIGURE5-9.12.2.4 OSD CONFIGURATION - SYSTEM
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CHAPTER 6:

6.1	 CONFIGURING IN ONLINE MODE

Configurations and system settings can be edited via management software in online mode with an active
connection between matrix and management software. Hereby, the following steps are necessary:

1. Connect the management software with the matrix.

The manufacturer-specific configuration (Factory Setting) saved on the matrix is loaded into
management software.

2. Click the Activate Edit Mode menu item in the toolbar.

The edit mode is active. A symbol is shown in the status bar.

3. Make any edits at the configuration and system settings.

4. Click the Apply button to confirm the changes.

The changes apply immediately as current configuration in the volatile memory of the matrix.

5. Click the Deactivate Edit Mode menu item in the toolbar.

6. Click the Remote Save button to save the configuration into the active configuration to the matrix.

7. Restart the system (depending on the settings made).

6.2	 CONFIGURING IN OFFLINE MODE

Configuration and system settings via management software can be changed in offline mode without a
direct connection between matrix and management software. Afterwards, the configuration must be
uploaded to the matrix. Hereby, the following steps are necessary:

1. Connect the management software to the matrix.

The manufacturer-specific configuration (Factory Settings) saved on the matrix is loaded into
management software.

NOTICE

Possible loss of configuration changes
By clicking the Apply button changes are applied to the active configuration and saved in the volatile

memory of the matrix. In the event of a sudden power failure, these changes are lost. To save changes
permanently:

Save the configuration changes into the active configuration (Save, see chapter 5.10.1, page 134),
save a predefined configuration (Save as..., from chapter 5.10.1 page 135, or perform a restart (see

chapter 7.10 page 315).

NOTICE

A change in system-relevant parameters (e.g., change in the IP address) is immediately displayed in the
management software. To initialize system-relevant configuration changes on the matrix, the matrix must
be restarted. The restart of the matrix may take several minutes, and the matrix is not available during the

restart.

CHAPTER 5: OSD CONFIGURATION



1501.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

2. Download the configuration.

3. Close the connection from the management software to the matrix.

4. Click the Activate Edit Mode menu item in the toolbar.

	 The edit mode is active. A symbol is shown in the status bar.

5. Make any edits at the configuration and system settings.

6. Click the Apply button to confirm the changes.

	 The changes apply immediately as current configuration in the volatile memory of the matrix.

7. Click the Deactivate Edit Mode menu item in the toolbar.

8. Upload the configuration to the matrix and activate immediately (optional) or later.

9. Optionally: restart the system.

6.3	 SETTING MANAGEMENT SOFTWARE OPTIONS

The settings of the management software can be customized and optimized to support you configure your
matrix. The settings can be set in the offline mode.

*A restart of the management software is required to activate changes in the options menu.

6.3.1	 SETTING PROGRAM DEFAULT SETTINGS

To avoid the repeated entry of data in the management software, this data can be saved in the default
settings.

 

FIGURE 6-3.1 MANAGEMENT SOFTWARE MENU EXTRAS - OPTIONS - DEFAULT SETTINGS
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FIELD DESCRIPTION

IP / Hostname Default IP address or host name of the matrix for establishing a connection

User Default username for establishing a connection

Configuration
Directory Default directory for configuration files

Firmware Directory Default directory for firmware files

Status Directory Default directory for status files

Import / Export 
Directory Default directory for import and export files

Presets Directory Default directory for macro files

 
To activate or set the default settings, proceed as follows:

1. Select Extras > Options in the menu bar.

The Options menu opens and shows the Default Settings tab.

2. Enter the appropriate data.

3. Click the Ok button to confirm your entries.

4. Close the management software and restart it.

6.3.2	 SETTING FONT SIZE, TOOLTIP, AND THEME

The font size can be set in this menu and the display of tooltips for the toolbar can be activated.

1. Select Extras > Options in the menu bar and open the Style tab.

2. Select the desired font size (Normal or Large).

3. Click the Show Toolbar Button Text checkbox.

A tooltip is displayed when hovering over a menu item in the toolbar.

4. Select the color theme for the management software (Dark (default) or Gray).

5. Click the Ok button to confirm your changes.

6. Close the management software and restart it..

FIGURE 2-14. BACK PANEL
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6.3.3	 SETTING LANGUAGE OF THE MANAGEMENT SOFTWARE

The font size can be set in this menu and the display of tooltips for the toolbar can be activated.

The language within the management software is set in this menu. The charset must match the selected
language to ensure correct representation.

1. Select Extras > Options in the menu bar and open the Language tab.

2. Select the desired language within the management software and the corresponding charset.

3. Click the Ok button to confirm your changes.

4. Close the management software and restart it.

FIGURE 6-3.2.1 MANAGEMENT SOFTWARE MENU EXTRAS - OPTIONS - STYLE

FIGURE 6-3.3.1 MANAGEMENT SOFTWARE MENU EXTRAS - OPTIONS - LANGUAGE
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6.3.4	 SETTING AUTOSTART OF THE DEVICE FINDER

Additional options for the matrix can be enabled in this menu.

OPTION DESCRIPTION

Device Finder on
startup Start the Device Finder automatically when starting the management software

Name adoption Entered name for a device is also applied to the extender and vice versa

Show Super Grid
View Show the Super Grid option in the task area

Show power
backplane and fan

firmware
Show the firmware of the fans and the power backplane in the menu Status &

Updates > Status- Matrix Firmware

Enable single I/O
board on compact

switch
Option available only for KXM compact:

Enable splitted
firmware update

(matrix and 
extender)

for master and sub
part of the 576 

matrix

Option available only for DKM enterprise 576:

FIGURE 6-3.4.1 MANAGEMENT SOFTWARE MENU EXTRAS - OPTIONS - MISCELLANEOUS
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To start the Device Finder automatically when starting the management software, proceed as follows:

1. Select Extras > Options in the menu bar and open the Miscellaneous tab.

2. Activate the Device Finder on startup checkbox. 

3. Click the Ok button to confirm your changes.

4. Close the management software and restart it.

     After restarting the management software, the Device Finder appears.

6.4	 SYSTEM SETTING

6.4.1	 SETTING SYSTEM CONFIGURATION

The system configuration is set in this menu.

FIGURE 6-4.1.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - GENERAL
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OPTION DESCRIPTION

Device Text Enter the device name of the matrix (default: SWITCH_01)
The device name is used as the host name in the network.

Name Text
Enter the name of the configuration that is used to save the

current settings (default: Standard)

Info Text Additional text field to describe the configuration (default:
Factory settings)

Sub Matrix
Activated

If the matrix is defined as a sub matrix in the OSD, the user will
lose control. Control can be recovered by using the keyboard
command <Hot Key>, <s>, <o>. The OSD for the matrix that

has been defined as sub matrix will be reopened.

Deactivated Function not active (default)

Load Default
Activated Starting the matrix after a restart or a switch-on with the default

configuration.

Deactivated Starting the matrix after a restart or a switch-on with the last
saved configuration (default).

Auto Save
Activated

Save the current configuration of the matrix in the flash memory
periodically.

Note: During the save operation, the matrix will not be
operational. Saving takes place every 600 seconds if changes of
the configuration or switching operations have been executed in

the meantime.

Deactivated Function not active (default)

Enable COM Echo
Activated

Send all switching commands performed in the matrix as an

echo via LAN connection.
Note: This function should be enabled when using a media

control via LAN connection or when using stacking with two or
more matrices.

Deactivated Function not active (default)

Enable LAN Echo
Activated

Automatically switch to the second link of a connected
redundant CON Unit when losing the primary link of a CPU Unit

(default)
Note: This function will have to be activated for both matrices in

a fully redundant setup

Deactivated Function not active (default)

Enable Redundancy
Activated

Automatically switch to the second link of a connected
redundant CON Unit when losing the primary link of a CPU Unit

(default)
Note: This function will have to be activated for both matrices in

a fully redundant setup

Deactivated Function not active

Synchronize
Activated Synchronize the sub matrix to the switch status of the master

matrix.

Deactivated Function not active (default)
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OPTION DESCRIPTION

Echo Only
Activated

Synchronize the matrix according to the echo of a second

matrix.
Note: This is a bidirectional synchronization where both

matrices have to be configured as Synchronize with the Master
IP of the respective other matrix.

Deactivated Function not active (default)

Master IP Address Byte Set the network address of the master matrix (default:
000.000.000.000)

Invalid IO-Boards
Activated

Keep I/O boards with incorrect or invalid firmware online in the
matrix.

Note: To keep an I/O board with wrong or damaged firmware
online in the matrix, the maintenance mode of the matrix will be

activated.

Deactivated Function not active (default)

Enable old Echo
Activated

Translate current switching command (implemented since
V02.09) internally into the old, already known switching

commands and send them as echo.

Deactivated Function not active (default)

Remove IO-Boards
Activated

Note: Only for DKM 576:

Shut down of I/O boards if the second CPU board is not
available. Connection will be disconnected.

Deactivated Function not active (default)

To set parameters for the system configuration, proceed as follows:

1. Select System Settings > System in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Modify the desired settings.

4. Click the Apply button to confirm your entries.

5. Click the Deactivate Edit Mode menu item in the toolbar. 
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6.4.2	 ENABLING AUTOMATIC CREATION OF CPU AND CON DEVICES

Settings for automatic creation of CPU and CON Devices when a new extender unit is connected are set in
this menu.
 
To set up the automatic creation of CPU Devices or CON Devices, proceed as follows:

1. Select System Settings > System in the task area.

2. Select the Automatic ID tab in the working area.

3. Click the Activate Edit Mode menu item in the toolbar.

4. Modify the desired settings.

5. Click the Apply button to confirm your entries.

6. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-4.2.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM -AUTOMATIC ID
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6.4.3	 CONFIGURING OSD

The Hot Key for accessing the command mode and the Fast Key to open the OSD are configured in this
menu. 

OPTION DESCRIPTION

Hot Key Keyboard
command Calling the command mode via keyboard sequence

Fast Key Keyboard
command Calling the command mode with only one key

To configure global OSD settings, proceed as follows:

1. Select System Settings > System in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the Global OSD Settings tab in the working area.

4. Modify the desired settings.

5. Click the Apply button to confirm your entries.

6. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-4.1.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - GLOBAL OSD SETTINGS
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6.4.4	 SETTING ACCESS CONFIGURATION

The Hot Key for accessing the command mode and the Fast Key to open the OSD are configured in this
menu.

OPTION DESCRIPTION

Force User Login
Activated

The user has to login with a username and a password once to
enter OSD. Thereafter the user remains logged in until he

explicitly logs out or an auto logout is affected.
Note: When using the Force User Login function, both console

favorites and console macros still remain active.

Deactivated Function not active (default)

Enable User ACL
Activated

CPU access is restricted according to the permissions in the

ACL (Access Control List).
• User login is required.

• Switching by keyboard Hot Keys requires a prior login.

Deactivated Function not active (default)

FIGURE 6-4.4.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - ACCESS
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OPTION DESCRIPTION

Enable CON ACL
Activated CPU access is restricted according to the permissions in the

respective Console ACL (Access Control List). No login required

Deactivated Function not active (default)

OR User/CON ACL
Activated The user obtains the sum of access rights from the console and

his personal access rights after logging in (extended access)

Deactivated Function not active (default)

And User/CON ACL
Activated

The user obtains the common divisor of access rights from the
console and his personal access rights after logging in (reduced

access)

Deactivated Function not active (default)

Enable new User
Activated Newly created users automatically receive access to all CPUs

Deactivated Function not active (default)

Enable new CON
Activated Newly created CON Devices automatically receive access to all CPUs

Deactivated Function not active (default)

Auto Disconnect
Activated Upon opening the OSD, the console will be automatically

disconnected from the current CPU.

Deactivated Function not active

OSD Timeout [sec] 0 to 999
seconds

Period of inactivity after which OSD will be closed automatically.
• Select 0 seconds for no timeout

• (default: 0 seconds)

Auto Logout [min] 0 to 999
minutes

Period of inactivity of a logged-in user at a console after which
he will be automatically logged out.

In addition to the logout process, a complete disconnection from
the connected CPU occurs under Full Access and Private

Mode.
• Select 0 minutes for an automatic user logout when leaving

OSD.
• Using the setting -1 allows the user to be logged in

permanently, until a manual logout is executed.
• The timer is not active as long as the OSD is open

(default: 0 minutes).

Keep CPU
Activated Permanently show the name of the currently connected CPU

Device in the Connection Info box.

Deactivated Function not active (default)

 
To set the access configuration, proceed as follows:

1. Select System Settings > Access in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Modify the desired settings.

4. Click the Apply button to confirm your entries.

5. Click the Deactivate Edit Mode menu item in the toolbar.
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6.4.5	 SETTING SWITCH CONFIGURATION

The switching parameters are set in this menu.

The following parameters can be configured:

OPTION DESCRIPTION

Enable Video 
Sharing

Activated

The user can switch to any CPU Device as an observer,
including ones that are already assigned to another user

(observer without keyboard/mouse access).
Note: Switching with the <Space> key, not with the <Enter>

key.
The operator will not be informed if further users connect as an

observer to the CPU Device that is connected to his CPU
Device.

Deactivated Function not active (default)

Force Connect
Activated

The user can connect to every single CPU Device as an
operator, including ones that are related to another user.

Note: The previous user is set to Video Only status.
To share K/M control, Force Connect has to be activated.

Deactivated Function not active (default)

FIGURE 6-4.5.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - SWITCH
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OPTION DESCRIPTION

Force Disconnect
Activated

Extension of Force Connect: If the user connects as an
operator to a CPU Device already related to another user, the

previous user will be disconnected.
Note: To share K/M control Force Disconnect has to be

deactivated.

Deactivated Function not active (default)

CPU Auto Connect
Activated

If a CON Device is not connected to a CPU Device, you can
establish an automatic connection to the next available CPU

Device by hitting any key or mouse button.

Deactivated Function not active (default)

CPU Timeout [min] Activated Period of inactivity after which a console will be automatically
disconnected from its current CPU Device (default: 0 minutes)

Keyboard Connect
Activated Activate request of K/M control by keyboard event (key will be

lost)

Deactivated Function not active (default)

Mouse Connect
Activated Activate request of K/M control by mouse event

Deactivated Function not active (default)

Release Time [sec] 0 to 999
seconds

Period of inactivity of a connected CON Device after which K/M
control can be requested by other CON Devices connected to

the CPU Device.
Note: Set “0” for an immediate transfer in real-time.

Only one CON Device can have keyboard and mouse control at
the same time. The other consoles that are connected to the

same CPU Device have a Video Only status (default:
10 seconds)

Macro Single Step
Activated Execute macro commands sequentially

Deactivated Function not active (default)

 
To set the access configuration, proceed as follows:

1. Select System Settings > Switch in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Modify the desired settings.

4. Click the Apply button to confirm your entries.

5. Click the Deactivate Edit Mode menu item in the toolbar.

* Keyboard Connect and / or Mouse Connect are only effective if Force Connect and / or CPU Auto
Connect are activated.
If the Keyboard Connect and / or Mouse Connect options are enabled, the Keyboard Connect and/or
Mouse Connect will not take effect until the time interval entered in the Release Time has elapsed.
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6.4.6	 SETTING NETWORK CONFIGURATION

The parameters for the network configuration are set in this menu.

 

NOTICE

To initialize system-relevant configuration changes, the matrix must be restarted. Restarting the matrix
can take several minutes and the matrix is not available during the restart.

NOTICE

Consult your system administrator before modifying the network parameters. Otherwise, unexpected
results and failures can occur in combination with the network.

FIGURE 6-4.6.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - NETWORK - GENERAL

CHAPTER 6: CONFIGURATION VIA MGMT. SOFTWARE



164 1.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

The following parameters can be configured: 

FIELD ENTRY DESCRIPTION

Dual Interface
Activated Redundant network connection is deactivated

Deactivated Function not active (default)

Network Settings - Controller Board

FIELD ENTRY DESCRIPTION

DHCP
Activated

The network settings are automatically supplied by a DNS
server.

Note: If DHCP is activated and there is no physical network
connection available, the boot times might increase.

Deactivated Function not active (default)

IP Address Byte Input of the IP address if DHCP is not active (default:
192.168.100.95)

Subnet Mask Byte Input of the subnet mask in the form “255.255.255.0” if DHCP is
not active (default: 255.255.255.0)

Gateway Byte Input of the subnet mask in the form “192.168.1.1” if DHCP is
not active

MAC Address Byte Cannot be changed, is retrieved automatically

Multicast

FIELD ENTRY DESCRIPTION

Multicast Byte Input of the Multicast address if there is a Matrix Grid in use
within a Multicast group (default is broadcast: 255.255.255.255)

Network Services

FIELD ENTRY DESCRIPTION

API Service
Activated LAN interface at the DKM activated for access via

management software (API service port 5555)

Deactivated Function not active (default)

SSL Support
Activated Activate SSL encryption for API, management software API,

management software and Matrix Grid communication

Deactivated Function not active (default)

Grid Service
Activated

Activate Grid interface at the matrix for access via management

software (Grid Service Port 5557)

Deactivated Function not active (default)
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6.4.7	 SETTING SYSLOG FUNCTION

The parameters for the syslog function are set in this menu:

The following parameters can be configured:

FIELD ENTRY DESCRIPTION

Enable Syslog
Activated Syslog server to query status is active

Deactivated Function not active (default)

Syslog Server Byte Input of the IP address of the syslog servers in the form
“192.168.1.1”

Port Byte Input of the syslog ports (default: 514)

Log Level

Debug
Activate debug messages in syslog (default: deactivated)

Note: The debug messages are exclusively for matrix
diagnostics. Use this function only for concrete debug cases as

it is not intended for normal operation.

Info Activate information messages in syslog (default: deactivated)

Notice Activate notification messages in syslog (default: activated)

Warning Activate warning messages in syslog (default: activated)

Error Activate error messages in syslog (default: activated)

FIGURE 6-4.7.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - NETWORK - SYSLOG
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To set parameters for the syslog function, proceed as follows:

1. Select System Settings > Network in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the Syslog tab in the working area.

4. Modify the desired settings.

5. Click the Apply button to confirm your entries.

6. Click the Deactivate Edit Mode menu item in the toolbar.

Setting the syslog options

To set or activate the presetting, proceed as follows:

1. Select Extras > Options in the menu bar and open the Syslog tab.
2. Enter the appropriate data.

3. Click the Ok button to confirm your entries.

4. Close the management software and restart it. 

 

FIGURE 6-4.7.2 MANAGEMENT SYSTEM SETTINGS - SYSTEM - NETWORK - GENERAL
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OPTION DESCRIPTION

Log File Directory Default directory to store the log files

Log File Name Default name of the log file

Log File Extension Default extension for the log file

Daily Log Files Log files are stored every 24 hours (daily)

Maximum Log File
Size [KB] Allowed maximum size of log file

Maximum Number 
of

Log Files
Allowed maximum number of log files

Acoustic 
Notification Enables acoustic notification for errors

Autostart When starting the management software, the syslog function will be started in
the background

Open Monitoring 
Tab When starting the management software, the monitoring tab will be opened

*When reaching the maximum log file size, a new log file will be created. When reaching the maximum
number of log files, the oldest logfile will be overwritten with the new information.

6.4.8	 SETTING SNMP FUNCTION

The SNMP function allows all function-critical and safety-critical elements of the matrix to be monitored and
queried. This function complies with the RFC 1157 conformal standard. Two SNMP servers can be used at
the same time.

NOTICE

For an activation of the SNMP agent function or the SNMP server function, a restart of the matrix is
necessary.
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The settings for the SNMP monitoring are set in this menu:

 
 
 
 
 
 

FIGURE 6-4.8.1 MANAGEMENT SYSTEM SETTINGS - SYSTEM - NETWORK - GENERAL
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The following parameters can be configured: 

SNMP Agent

TRAPS DESCRIPTION

SNMP Agent
Permission for an active query of the SNMP agent for traps is granted.

This activation is a prerequisite for using the SNMP server.

Port The SNMP port is called up automatically (default: 161).

Configured 
SNMPv3

User
Name of the SNMP user (default: snmp)

Read-Only
Community String The read-only community string for the MIB file is DKM.

TRAPS DESCRIPTION

Enable Traps Activates the active sending of trap messages from the SNMP agent to the
SNMP server

SNMP Server Input of the IP address of the SNMP server in the form “192.168.1.1”

Port Input of the SNMP port (default: 162)

Select All Select all traps

Status Notification about matrix status

Temperature Notification about temperature within the matrix

Insert I/O Board Not available*

Remove I/O Board Not available*

Invalid I/O Board Notification about a wrong firmware of the I/O board

Insert Extender
• Notification about a newly connected extender to the matrix, notification

about a switched-on extender
• Notification about a newly established link between extender and matrix
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SNMP Trap 
 
*The SNMP agent must be activated to activate the SNMP traps.

Remove Extender
• Notification about a removed extender from the matrix

• Notification about a switched off extender
• Notification about an interrupted link between extender and matrix

Switch Command Notification about a performed switching operation at the matrix

Fan Tray #1 Notification about the fan status on the left side of the matrix (interface view)

Fan Tray #2 Notification about the fan status on the right side of the matrix (interface view)

Power Supply #1 Notification about the status of power supply unit #1

Power Supply #2 Notification about the status of power supply unit #2

Power Supply #3 Not available*

Power Supply #4 Not available*
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Activating the SNMP agent

To activate the SNMP agent, proceed as follows:

1. Select System Settings > Network in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the SNMP tab in the working area.

4. Click the SNMP Agent checkbox within the SNMP Agent area.

By activating this option, the permission for an active query of the SNMP agent is granted.

5. Click the Apply button to confirm your changes.

6. Click the Deactivate Edit Mode menu item in the toolbar.

Activating SNMP traps

To activate active reporting of the SNMP traps, proceed as follows:

1. Select System Settings > Network in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the SNMP tab in the working area.

4. Click the Enable Traps checkbox within the SNMP Trap area.

5. Enter the IP address of the SNMP server under SNMP Server.

6. Click the checkboxes of the desired traps to activate them.

7. Click the Apply button to confirm your changes.

8. Click the Deactivate Edit Mode menu item in the toolbar.

Setting up SNMP options

Presets for an SNMPv3 user can be set up for the computer on which the management software is
operated are set in this menu.

To set or activate the presetting, proceed as follows:

1. Select Extras > Options in the menu bar and open the SNMP tab.

2. Enter the appropriate data.

3. Click the Ok button to confirm your entries.

4. Close the management software and restart it.
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To activate the SNMP agent, proceed as follows:

TRAPS DESCRIPTION

Port Activates the active sending of trap messages from the SNMP agent to the
SNMP server

Log File Directory Input of the IP address of the SNMP server in the form “192.168.1.1”

Log File Name Input of the SNMP port (default: 162)

Log File Extension Select all traps

Daily Log Files Notification about matrix status

Maximum Log File
Size [KB] Notification about temperature within the matrix

Maximum Number 
of

Log Files
Not available*

Autostart When starting the management software, the SNMP function will be started in
the background

Open Monitoring 
Tab When starting the management software, the monitoring tab will be opened

Creating an SNMPv3 User for the SNMP Server

In the following menu, the login data for an SNMPv3 user can be set up for the computer on which the
management software is operated (SNMP server). The SNMP server authenticates itself with the agent
using this login data. 

 

FIGURE 6-4.8.2 MANAGEMENT SYSTEM SETTINGS - SYSTEM - NETWORK - SNMP

CHAPTER 6: CONFIGURATION VIA MGMT. SOFTWARE



1731.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

NOTICE

Failed SNMP logging
If the login data differs between the matrix (set up in the User menu) and the SNMP server, no SNMP

traps are transmitted.
Ensure the login data (username and password) in both settings are identical (see chapter 5.2

page 79).

To configure the login data for an SNMPv3 User at the SNMP server, proceed as follows:

1. Select Extras > Options in the menu bar and open the SNMP tab.

1. Click the Manage SNMPv3 Users button.

A list appears with already created SNMPv3 users.

2. Click the Add User button.

A dialog window appears.

3. Enter the required data and click the Ok button to confirm your entries.

4. Click the Close button to close the users list.

5. Click the Ok button in the SNMP tab to confirm your settings.

6. Close the management software and restart it.

FIGURE 6-4.8.3 MANAGEMENT SOFTWARE MENU - EXTRAS- SNMP - MANAGE SNMPV3 USERS - ADD USER
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TRAPS DESCRIPTION

Username Activates the active sending of trap messages from the SNMP agent to the
SNMP server

Authentication 
Protocol Input of the IP address of the SNMP server in the form “192.168.1.1”

Authentication 
Password Input of the SNMP port (default: 162)

Privacy Protocol Select all traps

Privacy Password Notification about matrix status

6.4.9	 SETTING LDAP CONFIGURATION

The general LDAP settings are set in this menu.

FIGURE 6-4.9.1 MANAGEMENT SOFTWARE MENU - SYSTEM SETTINGS - NETWORK - LDAP
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The following parameters can be configured:

FIELD ENTRY DESCRIPTION

LDAP
Activated LDAP for the request of information from a user administration is

active

Deactivated Function not active (default)

User TLS/SSL
Activated Enable a secured transmission (transport layer security) for the

Active Directory access.

Deactivated Function not active (default)

LDAP Server Byte Input of the IP address for the LDAP-Servers in the form
“192.168.1.1” and the LDAP port (Default: 389)

Configured LDAP
User Text Input of the LDAP Base DN according to the existing structure of

the user directory

LDAP Base DN Text Input of the LDAP Base DN according to the existing structure of
the user directory

6.4.10	 SETTING DATE AND TIME

The parameters for the system configuration are set in this menu, based on Simple Network Time Protocol
(SNTP)

The following parameters are required to create a new SNMPv3 user on the SNMP server:

FIGURE 6-4.10.1 MANAGEMENT SOFTWARE MENU - 	SYSTEM SETTINGS -  DATE AND TIME
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The following parameters can be configured:

SNTP

Real Time Clock

Configuring the time server

To configure a time server, proceed as follows:

1. Select System Settings > Date and Time in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the SNTP checkbox to enable the SNTP option.

4. Enter the IP address of your SNTP server into the SNTP Server field.

5. Select your time zone in the Time Zone field.

6. Click the Apply button to confirm your settings.

7. Restart the matrix.

The system time is now provided by the SNTP server.

8. Click the Deactivate Edit Mode menu item in the toolbar.

Configuring the real time clock without time server

To set the real time clock without using SNTP, proceed as follows:

1. Select System Settings > Date and Time in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Set the current date in the Date and Time section.

4. Set the current time in the Date and Time section.

The entered time is set immediately in the settings.

5. Option: If you want to receive the time from your currently used computer, click the Get Local Time
button.

6. Click the Deactivate Edit Mode menu item in the toolbar.
FIGURE 2-14. BACK PANEL

FIELD DESCRIPTION

Date* Date and time of real time clock

Get Local Time Get local time of this computer

FIELD DESCRIPTION

Date* Date and time of real time clock

Get Local Time Get local time of this computer
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6.5	 USER SETTINGS

6.5.1	 SETTING USER ACCESS

New users and their user settings and permissions are set in this menu.

The following functions are available:

FIELD DESCRIPTION

New User Open a new user configuration

Delete User Delete an existing user

Apply Confirm the changes of an existing user or the creation of a new user account

Cancel Reject changes

FIGURE 6-5.1.1 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USERS & GROUPS - USERS
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The following keyboard commands are available:

SNTP
FIELD DESCRIPTION

<F> Add CPU to list Full Access

<V> IAdd CPU to list Video Access

<N> Add CPU to list No Access

The following parameters can be configured:

OPTION ENTRY DESCRIPTION

ID Numerical Ident number of the user

Name Text Username (case sensitive)
Note: A username can consist of up to 32 characters.

AD CN= Text Common name of a right group of the Active Directory

Password Text User password (case sensitive, input of minimum 8 characters
up to 16 characters)

Priority Value Priority of the user

Administrator
Activated

• User has administrator rights
• Permission for system configuration and all switching

operations

Deactivated Function not active (default)

Super User
Activated Permission to switch any console to any CPU in Extended

Switching

Deactivated Function not active (default)

Power User
Activated

• User has user rights
• Permission to switch consoles to CPUs in Extended

Switching according to the CON or User ACL, but not in
Private Mode

Deactivated Function not active (default)

SNMPv3 User
Activated Permission to use SNMPv3 (encrypted)

Deactivated SNMPv3 is not enabled

LDAP Logic
Activated LDAP User for accessing the Active Directory

Deactivated Function not active (default)
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Auto Connect
Activated Re-establish the previous user connection after login

Deactivated Function not active 

AD Synchronized
Activated

Enable synchronization with the Active Directory
Note: LDAP Login has to be activated to use the

synchronization

Deactivated Function not active (default)

AD Group Locked
Activated

Lock synchronization of group attribute for an Active Directory
user. This setting is required for a manual change of user

groups for a specific Active Directory user.

Deactivated Function not active (default)

Creating a new User Account

To create a new user, proceed as follows:

1. Select User Settings > Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the New User button.

4. Select a template of an existing user if applicable (Choose template).

5. Click the Apply button.

6. Set a username.

7. Set a password.

8. Set general access permissions.

9. Set user permissions for CPU access (paste function).

10. Set user favorites for OSD access.

11. Click the Apply button to confirm the new user settings.

12. Click the Deactivate Edit Mode menu item in the toolbar.

NOTICE

Failed SNMP logging
If the login data of the SNMPv3 user differs between the matrix and the SNMP server, no SNMP loggings

are transmitted.
Ensure the login data (username and password) in both settings are identical (see section on

page 79).
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Configuring User Access Rights

To configure a user access rights for CPUs, proceed as follows:

1. Select User Settings > Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select a user in the Users list.

4. By clicking with the secondary mouse button once on a CPU in one of the respective access lists (Full

Access, Video Access and No Access) a context menu for selection will appear in which the

respective CPU can be moved, and the access rights can be changed. Alternatively, you can type the

key commands <F>, <V> or <N> to set the respective access rights.

5. Click the Apply button to confirm the changes.

6. Click the Deactivate Edit Mode menu item in the toolbar.

6.5.2	 SETTING USER FAVORITES

Individual favorite lists of CPU Devices that will be switched frequently can be created for different users in

this menu. A favorite list can contain up to 32 different CPU Devices (from firmware V3.05).

The switching of the favorites is done via keyboard command (see chapter 7.2.1, page 274).

FIGURE 6-5.2.1 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USER & GROUPS - USERS FAVORITES
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Creating a Favorites List for Users

To create a favorites list for any user, proceed as follows:

1. Select User Settings> Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the respective user for the favorites list in the Users list.

4. Click the Favorites tab in the working area.

5. Select the CPU Devices in the CPU Device available list that should be added to the favorites list
(Favorite CPU Devices). By pressing and holding down the <Ctrl> key at the same time, more than
one CPU Device can be highlighted.

6. Click the button to move the highlighted CPU Devices to the favorites list. By clicking the button, all
CPU Devices from the CPU Device available list will be moved to the favorites list (Favorite CPU
Devices).

7. To remove highlighted CPU Devices from the favorites list, click the button. If you click the button,
all CPU Devices will be removed from the favorites list.

8. Click the or button to change the order of the CPU Devices within the favorites list.
Or press the <+> or <-> key to change the order of the CPU Devices within the favorites list.

9. Click the Apply button to confirm the changes.

10. Click the Deactivate Edit Mode menu item in the toolbar.

Assigning Settings to other Users

To assign settings of a user to other users, proceed as follows:

1. Select User Settings> Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the Favorites tab in the working area.

4. Select the user whose settings are to be assign to another user.

5. Click the Assign Settings to button below the user list.

A query to select the settings appears.

6. Click the checkboxes for the desired settings.

7. Click the Next button.

FIGURE 2-14. BACK PANEL
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A query to start the assignment appears.

8. Select the user in the Available to assign settings to list to which the settings are to be assigned. 

By pressing and holding down the <Ctrl> key at the same time, more than one user can be highlighted.

9. Click the button to move the highlighted user to the Assign settings to list. By clicking the button,
all users will be moved to the Assign settings to list.

10. To remove highlighted user from the Assign settings to list, click the button. If you click the

button, all users will be removed from the Assign settings to list.

11. Click the Finish button.

The settings are immediately assigned to the selected users.

12. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-5.2.2 MANAGEMENT SOFTWARE MENU - USERS & GROUPS - USERS - SELECT SETTINGS
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Copying Settings from another User

To copy settings from a user to another user, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the user to which the settings are to be copied. By pressing and holding down the <Ctrl> key

     at the same time, more than one user can be highlighted.

4. Click the Copy Settings from button below the user list.

     A query to select the settings appears.

5. Click the checkboxes for the desired settings.

6. Click the Next button.

FIGURE 6-5.2.3 MANAGEMENT SOFTWARE MENU - USERS & GROUPS - USERS - ASSIGN SETTINGS
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    A query to start the assignment appears.

7. Select the user in the selection list from which the settings are to be copied.

8. Click the Finish button.

    The settings are immediately copied to the selected user.

FIGURE 6-5.2.4 MANAGEMENT SOFTWARE MENU - USERS & GROUPS - USERS - SELECT SETTINGS

FIGURE 6-5.2.5 MANAGEMENT SOFTWARE MENU - USERS & GROUPS - USERS - COPY SETTINGS
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6.5.3	 SETTING USER MACROS

In this menu macro commands for switching, disconnection or user administration can be created. Macro
commands are created for each user separately. A macro can execute up to 16 commands successively.
The execution of the macros is done via Hot Key and the <F1> to <F16> function keys (see chapter 7.2.2,
page 273). 

*To execute user macros the user has to be logged in to the matrix.

 
 
 
 

FIGURE 6-5.3.1 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USERS - MACROS
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FIELD SELECTION DESCRIPTION

Function
(01 to 16)

Connect
(P1=CON, P2=CPU)

Set a bidirectional connection from CON Device P1 to CPU
Device P2

Connect Video
(P1=CON, P2=CPU)

Set a Video Only connection from CON Device P1 to CPU
Device P2

Disconnect
(P1=CON) Disconnect the CON Device P1

Logout User Logout the current user

Set Real CPU
(P1=VCPU, 
P2=RCPU)

Assign a Virtual CPU Device to a Real CPU Device

Logout User Assign a Real CON Device to a Virtual CON Device

Set Real CPU
(P1=VCPU, 
P2=RCPU)

Assign a Virtual CPU Device to a Real CPU Device

Set Virtual CON
(P1=RCON, 
P2=VCON)

Assign a Real CON Device to a Virtual CON Device

Push (P1=CON) The user’s KVM connection is forwarded to CON Device P1 and
is changed to a Video Only connection.

Push Video 
(P1=CON)

The video signal of the current connection (KVM or Video Only)
is forwarded to CON Device P1. The user’s connection remains

unchanged (KVM or Video Only).

Get (P1=CON)
The user’s CON Device gets a KVM connection to the CPU
Device that is currently connected to CON Device P1. The

connection of CON Device P1 is changed into a Video Only
connection.

Get Video (P1=CON)
The user’s CON Device gets a Video Only connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 remains unchanged (KVM or

Video Only).

Login User console 
P2 Login a certain user P1 at CON Device P2

P1 CON or CPU Device Name of CON Device or CPU Device

P2 CON or CON Device Name of CON Device or CPU Device

.
 
To create a macro for the selected user, proceed as follows:

1. Select User Settings > Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the user for which macros are to be created.

4. Open the Macros tab.

5. Select in the Key field the function key for which a macro has to be created.

6. Double-click in the Function column to display a list of all available commands that should be part of

     the macro.
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7. Select the desired command in the selection list.

8. Select in the P1 and P2 columns the respective parameters for the macro functions (e.g.,
corresponding CON Devices and CPU Devices).

9. Click the Apply button to confirm the changes.

10. Click the Deactivate Edit Mode menu item in the toolbar.

For an efficient macro configuration, the following context functions are available:

When clicking on the Macros tab, macros can be assigned to other users by using the Assign
Settings to... function (see description on page 218) and can be copied from other users by using the
Copy Settings from... function (see description on page 219).

When clicking on the macro list, macros of the selected key can be copied into the cache by using the
Copy Key Macros function. You can paste the macros from the cache into a key by using the Paste
Key Macros function and you can reset all macros of the selected key by using the Delete Key
Macros function.

6.5.4	 SETTING USER GROUPS

The KVM matrix allows to bundle the users of a configuration into User Groups. The groups can be used to
subdivide the users logically or thematically. As an application example you can group all power users
together. The configuration of User Groups at the same times increases the clarity of the configuration.

 

FIGURE 6-5.4.1 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USERS -& GROUPS - GROUPS
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FIELD DESCRIPTION

New Group Create a new group

Delete User Delete an existing group

Apply Apply changes

Cancel Reject changes

BUTTON FUNCTION

New Group Assign selected user to a user group

Delete User Assign all available users to a user group

Apply Remove selected user from a user group

Cancel Remove all users from a user group

Creating a User Group

To create and configure a User Group, proceed as follows:

1. Select User Settings > Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the Groups tab in the working area.

4. Click the New Group button.

     A selection dialog appears.

     Select Create a standard Group in the selection box.

5. Click the Apply button.

6. Enter a group name into the field Name.

7. Click the Apply button to confirm the group creation.

8. Click the Deactivate Edit Mode menu item in the toolbar.
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Assigning a User Group

To assign a user to a group, proceed as follows:

1. Select User Settings > Users & Groups in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the Groups tab in the working area.

4. Select the User Group to be assigned with a user.

5. Select a user in the list User/Group available that should be assigned to the User Group. By pressing

     and holding down the <Ctrl> key at the same time, more than one User can be highlighted.

6. Click the button to move the highlighted user to the User Group list (User/Group assigned). By
clicking the button, all users from the list User/Group available will be moved to the list User/Group
assigned.

7. To remove highlighted users from the User Group list, click the button. If you click the button, all
Users will be removed from the User Group list.

8. Click the Apply button to confirm the group creation.

9. Click the Deactivate Edit Mode menu item in the toolbar.
     The user is assigned to the User Group now.

6.6	 MAIN EXTENDER SETTINGS

6.6.1	  EXTENDER SETTINGS

The matrix automatically recognizes every physical extender module with a direct cable connection to the
matrix, reads their serial number and creates Ext Units automatically. This is the Flex Port function of the
matrix. Dual-Head KVM extenders will be recognized as two independent Ext Units.

Add-on modules are not created as independent Ext Units. The data of add-on modules is included in one
extender unit together with the associated KVM extender.
All Ext Units are managed in this menu. This includes the creation of new Ext Units and the deletion of
existing Ext Units.

NOTICE

The connection of a fixed port extender unit (e.g., USB 2.0) to a Flex Port can cause unintended results.
Ext Units for USB 2.0 extender modules have to be created manually (see chapter 6.6.5, page 174).
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The following parameters are recognized automatically:

FIELD ENTRY DESCRIPTION

ID Text
Numerical value of the extender unit ID (KVM extenders: ID is

provided by the extender module (serial number) and cannot be
changed)

Name Text Name of the extender unit

Port
1 to 160

(depending on
the matrix)

Port number of the extender unit

 

FIGURE 6-5.4.2 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USERS -& GROUPS - GROUPS
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FIELD ENTRY DESCRIPTION

Fixed
Activated

Numerical value of the extender unit ID (KVM extenders: ID is
provided by the extender module (serial number) and cannot be

changed)

Deactivated Function not active

CPU/CON Assigned - Assigned CPU Device or CON Device

Redundant Port
1 to 160

(depending on
the matrix)

Port number of the extender unit

6.6.2	 EXTENDER TYPE

To display extender types, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Select the extender unit to be displayed.

     The extender type is displayed on the right side of the working area.

	 − The Basic column stands for the extender of the selected extender unit.

	 − The Part A or Part B column stand for the add-on module of the selected extender unit.

 

FIGURE 6-6.2.1 MANAGEMENT SOFTWARE MENU - EXT UNITS - EXPERT VIEW - EXTENDER TYPE
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6.6.3	 EXTENDER FIRMWARE VERSION

To display extender unit information or to modify settings, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Select the extender unit to be displayed.

3. Click the Firmware Version tab on the right side of the working area.

     The Firmware Version overview is displayed on the right side of the working area.

*Add-on modules are shown together with the associated KVM extender in one extender unit. 
 
 

FIGURE 6-6.3.1 MANAGEMENT SOFTWARE MENU -  EXTENDER & DEVICES - EXT UNITS - FIRMWARE VERSION
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6.7	 CREATING AN USB 2.0 EXTENDER

This chapter helps you to configure and use your USB 2.0 Ext Units. USB 2.0 Ext Units can be configured
for independent switching or can be assigned to already existing KVM extenders.

To configure a USB 2.0 extender unit, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the New Unit button.

A selection dialog appears.

4. Select Choose template in the selection box if you want to use a template for a USB 2.0 CON Unit or  a USB 2.0 CPU 
Unit.

An extender with an eight-digit ID will be created, starting with digit 9.

5. Enter an appropriate name to the extender in the Name field.

6. Enter the port number of the matrix physically connected to the USB 2.0 extender unit into the Port field.

7. Click the Apply button to confirm the settings.

A dialog appears to restart the I/O board.

8. Click the Yes button to restart the I/O board to activate the USB fixed port for the new unit.
FIGURE 6-7.1 MANAGEMENT SOFTWARE MENU -  EXTENDER & DEVICES - EXT UNITS -EXTENDER TYPE - USB 2.0
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After restart of the I/O board, the parameters and settings of the USB 2.0 extender module are shown

in the working area of the respective extender unit.

9. The USB 2.0 CPU/CON extender unit now has to be either assigned to an existing CPU/CON Device or

     a new CPU/CON Device has to be created for the assignment:

	 • for a CPU Device see chapter 5.8.1, page 111,

	 • for a CON Device see chapter 5.9.3, page 122

10. If you use parallel operation within the matrix, set the Release Time in the System Settings > Switch

      menu to 10 s or more (see chapter 6.4.5, page 162).

11. Restart all I/O boards on which USB 2.0 extenders have been configured or alternatively restart the matrix.

The USB 2.0 Ext Units are now configured and can be used.

*Manually created Ext Units are always set as fixed port extenders. This configuration is necessary if you
want to switch, e.g., USB 2.0 connections via the matrix.
To make a fixed port available again for Flex Port Ext Units after deleting a fixed port extender unit, a
restart of the I/O board is necessary.

6.7.1	 SETTING CPU DEVICES

New CPU Devices are configured in this menu including their assignment to Ext Units.

The assignment helps to describe and switch more complex computer configurations (e.g., Quad-Head with
USB 2.0) in the matrix.
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FIELD DESCRIPTION

New Device Create a new CPU Device

Delete Delete a new CPU Device

Apply Confirm a created CPU Device

Cancel Reject changes

Assign selected Ext Units to a CPU Device

Assign all available Ext Units to a CPU Device

Remove selected Ext Units from a CPU Device

Change assignment number of extender unit upwards

Change assignment number of extender unit downwards

Deactivate Change assignment number of extender unit to first position

Reset Change assignment number of extender unit to last position

Change assignment number of extender unit upwards

Change assignment number of extender unit downwards

FIGURE 2-14. BACK PANEL

FIGURE 6-8.1.6 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - ASSIGNMENT FINISHED
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The following parameters can be configured:

OPTION ENTRY DESCRIPTION

ID Text Ident number of the user

Name Text Username (case sensitive)
Note: A username can consist of up to 32 characters.

Virtual Device
allow Private

Activated Allow switching to the respective CPU Device in Private Mode

Deactivated User password (case sensitive, input of minimum 8 characters
up to 16 characters)

Force
Private

Activated Force switching to the respective CPU Device only in Private
Mode

Deactivated Function not active (default)

Fix Frame Color Selection list  Force showing a colored frame when switching to the respective

Reference
Activated

Activate a reference CPU Device that inherits both CPU Device
and extender unit settings to any CPU Unit that is connected to

the matrix for the first time.
Note: It is recommended to activate the reference setting for

one single CPU Device only.

Deactivated Function not active (default)

2 Step Access
Activated

Open a pop-up window after switching to the particular CPU
Device. In the background a Video Only connection will be

established. A confirmation in the pop-up window is required to
establish a Full Access connection to the CPU Device.

Deactivated Function not active (default)

CPU Assigned - ID and name of the assigned Virtual CPU Device, cannot be
changed, is retrieved automatically

CON Connected - ID and name of the connected CON Device, cannot be
changed, is retrieved automatically

CPU Colors Selection list
The CPU Device name will be highlighted according to the color

setting for text and background. You can select between 16
colors.

Exclusive Access
Activated

Activate an access limitation for the case that a CPU Device is
already connected via Full Access connection. When having the

same priorities, any additional access to the CPU Device can
only be established with a Video Only connection. Having a

lower priority any additional connection is not possible. Only
when having a higher priority, an additional Full Access

connection can be established, and K/M control can be taken
over.

Deactivated Function not active (default)

MSC disabled
Activated Multi-Screen Control function deactivated

Deactivated Multi-Screen Control function activated
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Creating a new CPU Device

To create a new CPU Device, proceed as follows:

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the New Device button.

     A selection dialog appears.

4. Select a real CPU (Create a standard CPU) or a virtual CPU (Create a virtual CPU) or a template of

     an existing CPU (Choose template) in the Choose template selection box.

     Note: A template is only available if there is at least one existing CPU Device.

5. Click the OK button.

A new CPU Unit will be created.

6. Determine all parameters that are relevant for the CPU Device.

7. Click the Apply button to confirm the creation of the CPU Device.

8. Click the Deactivate Edit Mode menu item in the toolbar.

Accessing a new CPU via Matrix

To access a new CPU Device via matrix, an assignment of one or more CPU Ext Units is required. Proceed

as follows:

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the new CPU Device in the CPU Devices list.

4. Select an extender unit in the Extender available list that you want to assign to the CPU Group. 

     By pressing and holding down the <Ctrl> key at the same time, more than one extender unit can be

     highlighted.

5. Click the button to move the highlighted Ext Units to the Extender assigned list. By clicking the

button, all available Ext Units from the Extender available list will be moved to the Extender assigned

list.

The assignments are displayed in the Extender assigned list.

6. Click the or button to change the order of the Ext Units within the Extender assigned list.

Or press the <+> or <-> key to change the order of the Ext Units within the Extender assigned list.

7. Click the Apply button to confirm the assignment.

8. Click the Deactivate Edit Mode menu item in the toolbar.

Removing an Extender Unit Assignment
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To remove an extender unit assignment, proceed as follows:

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select a CPU Device in the CPU Devices list.

4. Select one or more Ext Units in the Extender assigned list.

5. To remove highlighted Ext Units from the Extender assigned list, click the button. If you click the

button, all CPU Devices will be removed from the Extender assigned list.

6. Click the Apply button to confirm the removal.

7. Click the Deactivate Edit Mode menu item in the toolbar.

6.7.2	 SETTING CPU GROUPS

The KVM matrix allows to bundle the CPU Devices of a configuration into CPU groups. The groups can be
used to subdivide the CPU Devices logically or thematically. As an application example you can group all
CPU Devices together that are connected to a specific matrix in a matrix grid. The configuration of CPU
groups at the same times increases the clarity of the configuration.

 

FIGURE 6-8.3.1 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - CPU DEVICES - CPU GROUPS
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Creating a new CPU Group

To create a CPU Group, proceed as follows:

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CPU Groups tab in the working area.

4. Click the New Group button.

     A selection dialog appears.

5. Select a standard Group (Create a standard Group) or a LDAP Group (Create a LDAP Group) or a

     template of an existing Group (Choose template) in the Choose template selection box.

     Note: A template is only available if there is at least one existing Group.

6. Click the OK button.

7. Enter a group name into the field Name.

8. Click the Apply button to confirm the creation of the group.

9. Click the Deactivate Edit Mode menu item in the toolbar.

Assigning a CPU Group

To assign a CPU Device to a CPU Group, proceed as follows:

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CPU Groups tab in the working area.

4. Select the CPU Group to be assigned with a CPU Device.

5. Select a CPU Device in the list CPU/Group available that you want to assign to the CPU Group. By

pressing and holding down the <Ctrl> key at the same time, more than one CPU Device can be

highlighted.

6. Click the button to move the highlighted CPU Devices to the CPU/Group assigned list. By clicking

the button, all CPU Devices from the CPU Device available list will be moved to the CPU/Group

assigned list.

7. To remove highlighted CPU Devices from the CPU/Group assigned list, click the button. If you click

the button, all CPU Devices will be removed from the CPU/Group assigned list.

8. Click the Apply button to assign the CPU Device to the CPU Group.

9. Click the Deactivate Edit Mode menu item in the toolbar.

 

6.7.3	  
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6.8.4 ASSIGNING VIRTUAL CPU DEVICES

In this menu, either one or more Virtual CPU Devices can be assigned to a Real CPU Device.
With a Virtual CPU Device, the effort of switching several CON Devices to the same CPU Device can be
reduced. If several CON Devices are connected to a Virtual CPU Device that is assigned to a Real CPU
Device, you only have to change the Real CPU Device once and all consoles will receive the video signal of
the new Real CPU Device. 

*One Real CPU Device can be assigned to several Virtual CPU Device.

 

NOTICE

When the Auto Send function in the left lower corner of the work area is ticked, switching operations will
be completed immediately without user confirmation by means of the Send button.

FIGURE 6-8.4.1 MANAGEMENT SOFTWARE MENU - ASSIGNMENT - VIRTUAL CON DEVICES
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FIELD DESCRIPTION

Send Send assignments to the matrix

Reload Reload changes

For an assignment, proceed as follows:

1. Select Assignment > Virtual CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select a Virtual CPU Device in the Virtual CPU list.

4. Double-click in the Real CPU column to display a list of all available Real CPU Devices.

5. Select a Real CPU Device in the selection list.

6. Click the Send button to send the assignment to the matrix.

7. Click the Deactivate Edit Mode menu item in the toolbar.

The selection boxes in the Real CPU column contain a filter function for an easy selection of a single CPU

Device from a larger pool of CPU Devices.

The management software offers the option to switch directly from the Assignment menu to the definition

menu to check specific settings for the respective Real CPU Device or Virtual CPU Device.

Click with the secondary mouse button on the respective Real CPU Device or Virtual CPU Device and

select Open CPU Device in the context menu.

The definition menu for the CPU Device settings is opened (see chapter 6.8.2, page 208).
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6.8	 CONFIGURE CONSOLE SETTINGS

Connecting a CON Unit to the matrix creates an extender unit in the matrix, reading the serial number of
the CON Unit. An extender unit has to be assigned to a CON Device. Switching operation is only possible
between CON Device and CPU Device. All steps to create switchable CON Devices are described in this
chapter. Several Real CON Devices can be assigned to a Virtual CON Device to reduce operation efforts
(see chapter 6.9.6, page 235).

6.8.1	 CONFIGURING FOR MOUSE AND KEYBOARD USED IN THE EXTENDER OSD

The OSD configuration for mouse and keyboard is made in this menu. 
 
 
 

 

FIGURE 6-9.1.1 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - GENERAL OSD DATA
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The following parameters can be configured:

OPTION ENTRY DESCRIPTION

Horizontal Mouse
Speed [1/x] 1 to 9 Adjustment of the horizontal mouse speed, 1 = slow, 9 = fast

(default: 4)

Vertical Mouse 
Speed
[1/x]

1 to 9 Adjustment of the vertical mouse speed, 1 = slow, 9 = fast
(default: 5)

Double Click Time
[sec] 100 to 800 Adjustment of the time slot for a double-click (default: 200 ms)

Keyboard Layout Region Set the OSD keyboard layout according to the used keyboard
(default: German (DE))

Video Mode
Variable or

specific
resolution

Resolution that is used when opening OSD

Hot Key Keyboard
command Calling the command mode via keyboard sequence

Fast Key Keyboard
command Calling the command mode with only one key

*The OSD configuration for mouse and keyboard is made in this menu.

Changing Settings for Mouse and Keyboard

To change the settings for mouse and keyboard, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON extender unit in the EXT Units list whose extender OSD settings has to be adjusted.

4. Select the General OSD Data tab.

5. Modify the desired settings.

6. Click the Apply button to confirm your entries.

7. Click the Deactivate Edit Mode menu item in the toolbar.

Assigning Settings to other Ext Units

To assign settings of an extender unit to other Ext Units, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON extender unit whose settings are to be assign to another extender unit.

4. Click the Assign Settings to button below the Ext Units list.

A query to select the settings appears.

5. Click the checkboxes for the desired settings.

6. Click the Next button.
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A query to start the assignment appears.

7. Select the Ext Units in the Available to assign settings to list to which the settings are to be assigned.

By pressing and holding down the <Ctrl> key at the same time, more than one extender unit can be

highlighted.

8. Click the button to move the highlighted Ext Units to the Assign settings to list. By clicking the

button, all Ext Units will be moved to the Assign settings to list.

9. To remove highlighted Ext Units from the Assign settings to list, click the button. If you click the

button, all Ext Units will be removed from the Assign settings to list.

10. Click the Finish button.

The settings are immediately assigned to the selected Ext Units.

11. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-9.1.2 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - SELECT SETTINGS
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The following parameters can be configured:

Copying Settings from another Extender

To copy settings from an extender unit to another extender unit, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON extender unit to which the settings are to be copied. By pressing and holding down the

<Ctrl> key at the same time, more than one extender unit can be highlighted.

4. Click the Copy Settings from button below the Ext Units list.

A query to select the settings appears.

5. Click the checkboxes for the desired settings.

6. Click the Next button.

FIGURE 6-9.1.3 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - ASSIGN SETTINGS TO
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A query to start the assignment appears.

7. Select the extender unit in the selection list from which the settings are to be copied.

8. Click the Finish button.

The settings are immediately copied to the selected Ext Units.

 
 
 
 
 
 

FIGURE 6-9.1.4 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - SELECT SETTINGS

FIGURE 6-9.1.5 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - COPY SETTINGS
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6.8.2	 SETTING EXTENDER OSD

In this menu the parameters for the Extender OSD can be set. These are local settings that can be made
individually for each console.

When setting the horizontal OSD position, a prefixed minus describes the orientation to the right edge of
the monitor, e.g., -2 means 2 x 10 = 20 pixels to this edge. When setting a vertical position, a prefixed
minus describes the orientation to the bottom edge of the monitor.
If the Update connection info function is deactivated, the Extender OSD only appears when switching via
OSD.

FIGURE 6-9.2.1 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - EXTENDER OSD DATA
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The following parameters can be configured:
 

OPTION DESCRIPTION

Enable CPU 
Selection

List

Activated
When executing the key sequence for opening the OSD, a

selection list for switching CPU Devices will be displayed in the
center of the monitor. Pressing the <F7> key within the

selection list opens the standard OSD.

Deactivated Function not active (default)

Enable Connection
Info

Activated Enable Extender OSD (default)

Deactivated Function not active (default)

Update Connection
Info Activated

Update connection changes during fade-in of Extender OSD

(default)

Display Time 0-999
seconds Duration of OSD fade-in (default: 10)

Horizontal Position 10 pixels Horizontal OSD position (default: -2)

Vertical Position 10 pixels Vertical OSD position (default: 2)

 
Changing the Extender OSD Settings

To change the extender OSD settings, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON extender unit in the EXT Units list whose extender OSD settings has to be adjusted.

4. Select the Extender OSD Data tab.

5. Modify the desired settings.

6. Click the Apply button to confirm your entries.

7. Click the Deactivate Edit Mode menu item in the toolbar.

*For an efficient extender OSD configuration, OSD settings can be assigned to EXT Units (see description
on page 120) or can be copied from an EXT Unit (see description on page 121).
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6.8.3	 SETTING CON DEVICES

New CON Devices are created in this menu including access rights and assignment to Ext Units.

BUTTON FUNCTION

New Device Open a new CON Device

Delete Device Delete a new CON Device

Apply Confirm a created CON Device

Cancel Reject changes

KEYBOARD COMMAND FUNCTION

<F> Add CPU to list Full Access

<V> Add CPU to list Video Access

<N> Add CPU to list No Access

FIGURE 6-9.3.1 MANAGEMENT SOFTWARE MENU - CON DEVICE - CON DEVICES
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OPTION ENTRY DESCRIPTION

ID Text Ident number of the CON Device

Name Text Name of the CON Device

Priority 0 to 999

Priority of the CON Device

Note: There is no K/M sharing between CON Devices with a
different priority and the release time does not come into

account. CON Devices only have Video Only access to a CPU
Device if a CON Device with a higher priority is already switched

to it.

Virtual Device
Activated Create a new CON Device as a Virtual CON Device

Deactivated Function not active (default)

Allow User ACL
Activated Allow activation of the User ACL at the local console

Deactivated Function not active (default)

Force Login Selection list  Force user login at this CON Device

LOS Frame
Activated

• When the video signal between source (computer, CPU) and
the CPU Unit or the connection between matrix and the

CON Unit is lost, an orange frame will be displayed.
• When switching to a CPU Unit without video signal, a blank

screen will appear surrounded by an orange frame.

Deactivated Function not active (default)

Show Macro List
Activated Show the macro list instead of the CPU Device selection list

Deactivated Function not active (default)

OSD Disabled
Activated Disable OSD access for the respective CON Device

Deactivated Function not active (default)

CON Assigned - ID and name of the assigned Virtual CPU Device, cannot be
changed, is retrieved automatically

CPU Connected -
ID and name of the connected CON Device, cannot be

changed, is retrieved automatically

Allow CPU Scan
Activated 

Allow a scan mode with an automatic change of the video signal
for the favorite list (CPU Devices) of the respective console or a

logged in user.

Deactivated Function not active (default)

Force CPU Scan
Activated 

Force a scan mode with an automatic change of the video signal
for the favorite list (CPU Devices) of the respective console or a

logged in user.
Note: An active scanner can be stopped by a mouse or

keyboard event. You gain Full Access for the currently switched
CPU Device if Force Connect is activated.

Deactivated Function not active (default)

Scan Time [sec] 0 to 99
seconds Retention period until switching to the next CPU Device
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OPTION ENTRY DESCRIPTION

Port Mode
Activated

The favorite list will be replaced by a port list where the ports
from 1 to 999 can be directly selected at each matrix or Matrix

Grid.
Note: The selection only works for CPU Devices and has to be

made according to the switching of favorites.
When using the Port Mode, CON and User favorites will be

deactivated.

Deactivated Function not active (default)

Redundancy Off

Activated Function is not active

Deactivated
Automatically switch to the second link of a connected

redundant CON Unit when losing the primary link of a CPU Unit
(default).

CPU Colors Selection list
The CPU Device name will be highlighted according to the color

setting for text and background. You can select between 16
colors.

Fix Frame Color Selection list
Show a colored frame at the CPU Device. You can select

between 7 colors. The colored frame of the CPU device is
displayed with priority.

Creating a new Console

To create a new console, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the New Device button.

A selection dialog appears.

4. Select a real CPU (Create a standard CPU) or a virtual CPU (Create a virtual CPU) or a template of

an existing CPU (Choose template) in the Choose template selection box.

Note: A template can only be used if there is at least on existing CON Device.

5. Click the OK button.

A new CON Device will be created.

6. Determine all parameters that are relevant for the CON Device.

7. Click the Apply button to confirm the creation.

8. Click the Deactivate Edit Mode menu item in the toolbar.
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Assigning Settings to other CON Devices

To assign settings of a CON Devices to other CON Devices, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device whose settings are to be assign to another CON Devices.

4. Click the Assign Settings to button below the CON Device list.

A query to select the settings appears.

5. Click the checkboxes for the desired settings.

6. Click the Next button. 

 
 
 

 
FIGURE 6-9.3.2 MANAGEMENT SOFTWARE MENU - CON SETTINGS - SELECT SETTINGS
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    A query to start the assignment appears.
  
7. Select the CON Device in the Available to assign settings to list to which the settings are to be

    assigned. By pressing and holding down the <Ctrl> key at the same time, more than one CON

    Device can be highlighted.

8. Click the button to move the highlighted CON Device to the Assign settings to list. By clicking the

     button, all CON Devices will be moved to the Assign settings to list.

9. To remove highlighted CON Devices from the Assign settings to list, click the button. If you click the

     button, CON Devices will be removed from the Assign settings to list.

10. Click the Finish button. 

       The settings are immediately assigned to the selected CON Devices.

11. Click the Deactivate Edit Mode menu item in the toolbar.

 
 
 
 
 
 

 

FIGURE 6-9.3.3 MANAGEMENT SOFTWARE MENU - CON SETTINGS - ASSIGN SETTINGS
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Copying Settings from another CON Device

To copy settings from a CON Device to another CON Device, proceed as follows:

1. Select Extender & Devices > EXT Units in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device to which the settings are to be copied. By pressing and holding down the

<Ctrl> key at the same time, more than one CON Device can be highlighted.

4. Click the Copy Settings from button below the CON Device list.

A query to select the settings appears.

5. Click the checkboxes for the desired settings.

6. Click the Next button.

FIGURE 6-9.3.4 MANAGEMENT SOFTWARE MENU -CON SETTINGS - SELECT SETTINGS
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A query to start the assignment appears.

7. Select the CON Device in the selection list from which the settings are to be copied.

8. Click the Finish button.

The settings are immediately copied to the selected CON Devices. 

Configuring Extender Unit Assignments

To run a CPU Device via a matrix, one or more CON Ext Units must be assigned. To place an assignment,

proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device in the CON Devices list that has to be assigned to an extender unit.

4. Select the extender unit in the Extender available list that should be assigned to the CON Device.

5. By clicking with the secondary mouse button once on a CON Device in one of the respective access

lists (Full Access, Video Access and No Access) a context menu for selection will appear in which

the respective CON Device can be moved, and the access rights can be changed. Alternatively, you

can type the key commands <F>, <V> or <N> to set the respective access rights.

6. Click the Apply button to confirm the assignment.

7. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-9.3.5 MANAGEMENT SOFTWARE MENU -CON SETTINGS - COPY SETTINGS
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Removing an Extender Unit Assignment

To remove an extender unit assignment, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device in the CON Devices list to be modified.

4. Select the extender unit(s) in the Extender assigned list to be removed.

5. By clicking with the secondary mouse button once on a CON Device in one of the respective access

     lists (Full Access or Video Access) a context menu for selection will appear in which the respective

     CON Device can be moved to the No Access list. Alternatively, you can enter the <N> key command

     to remove the access rights.

6. Click the Apply button to confirm the changes.

7. Click the Deactivate Edit Mode menu item in the toolbar.

Configuring CPU Access Rights of CON Devices

To configure CPU access rights of CON Devices, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select a CON Device in the CON Devices list.

4. Select the CPU Access Control tab.

5. Click with the secondary mouse button once on a CON Device to or the respective keyboard

     commands (cf. below) to assign new access rights. Type the key commands <F>, <V> or <N>

6. Click the Apply button to confirm the configuration.

7. Click the Activate Edit Mode menu item in the toolbar.
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6.8.4	 SETTING CON DEVICE FAVORITES

Individual favorite lists of CPUs to be switched frequently can be created for all consoles in this menu. A
favorite list can contain up to 32 different CPU Devices (from firmware V3.05).
The switching of the favorites is done via keyboard commands (see chapter 7.2.1, page 274).

To create a favorite list for any console, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device for which a favorites list is to be created.

4. Select the Favorites tab.

FIGURE 6-9.4.1 MANAGEMENT SOFTWARE MENU - CON SETTINGS - CON DEVICES - FAVORITES
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5. Select the CPU Devices in the CPU Device available list that should be added to the favorites list

    (Favorite CPU Devices). By pressing and holding down the <Ctrl> key at the same time, more than

    one CPU Device can be highlighted.

6. Click the button to move the highlighted CPU Devices to the favorites list. By clicking the button, all

    CPU Devices from the CPU Device available list will be moved to the favorites list (Favorite CPU

     Devices).

7. To remove highlighted CPU Devices from the favorites list, click the button. If you click the button,

all CPU Devices will be removed from the favorites list.

8. Optional: Click the or button to change the order of the CPU Devices within the favorites list.

Or press the <+> or <-> key to change the order of the CPU Devices within the favorites list.

9. Click the Apply button to confirm the changes.

10. Click the Deactivate Edit Mode menu item in the toolbar.

*For an efficient favorite configuration, favorite settings can be assigned to CON Devices (see description on
page 127) or can be copied from a CON Device (see description on page 129).

6.8.5	 SETTING CON DEVICE MACROS

In this menu macro commands for switching, disconnection or user administration can be created. The

macro commands are created for each console separately.

A macro can execute up to 16 switching commands successively.

The execution of the macros is done via Hot Key and the function keys <F1> to <F16> (see chapter 7.2.2,
page 273). 

*The macros can also be used to switch to CPU groups.

 
 
 
 
 
 

CHAPTER 6: CONFIGURATION VIA MGMT. SOFTWARE



219 1.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

FIELD SELECTION DESCRIPTION

Function
(01 to 16)

Connect
(P1=CON, P2=CPU)

Set a bidirectional connection from CON Device P1 to CPU
Device P2

Connect Video
(P1=CON, P2=CPU)

Set a Video connection from CON Device P1 to CPU
Device P2

Disconnect
(P1=CON) Disconnect the CON Device P1

Logout User Logout the current user

Set Real CPU
(P1=VCPU, 
P2=RCPU)

Assign a Virtual CPU Device to a Real CPU Device

Set Virtual CON
(P1=RCON, 
P2=VCON)

Assign a Real CON Device to a Virtual CON Device

Push (P1=CON) The user’s KVM connection is forwarded to CON Device P1 and
is changed to a Video Only connection.

Push Video 
(P1=CON)

The video signal of the current connection (KVM or Video Only)
is forwarded to CON Device P1. The user’s connection remains

unchanged (KVM or Video Only).

FIGURE 6-9.4.2 MANAGEMENT SOFTWARE MENU - CON SETTINGS - CON DEVICES - MACROS
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FIELD SELECTION DESCRIPTION

Function
(01 to 16)

Get (P1=CON)
The user’s CON Device gets a KVM connection to the CPU
Device that is currently connected to CON Device P1. The

connection of CON Device P1 is changed into a Video Only
connection.

Get Video (P1=CON)
The user’s CON Device gets a Video Only connection to the

CPU Device that is currently connected to CON Device P1. The
connection of CON Device P1 remains unchanged (KVM or

Video Only).

Login User console 
P2 Login a certain user P1 at CON Device P2

P1 CON or CPU Device Logout the current user

P2 CPU or CPU Device Assign a Virtual CPU Device to a Real CPU Device

To create a macro for the selected console, proceed as follows:

1. Select Extender & Devices > CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CON Device for which a console macro is to be created.

4. Select the Macros tab.

5. Select in the Key field the function key (<F1> to <F32>) for which a macro should be created.

6. Select in the Function column the commands that should be part of the macro. The selection list will be

opened by a double-click on the empty fields.

7. Select the respective parameters for the macro functions (e.g., corresponding CON Devices or CPU

Devices) in the P1 and P2 columns.

8. Click the Apply button to confirm your entries.

9. Click the Deactivate Edit Mode menu item in the toolbar.

For an efficient macro configuration, the following context functions are available:

When clicking on the Macros tab, macros can be assigned to other CON Devices by using the Assign

Settings to... function (see description on page 218) and can be copied from other CON Devices by

using the Copy Settings from... function (see description on page 219).

When clicking on the macro list, macros of the selected key can be copied into the cache by using the

Copy Key Macros function. You can paste the macros from the cache into a key by using the Paste

Key Macros function and you can reset all macros of the selected key by using the Delete Key

Macros function.
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6.8.6	 ASSIGNING VIRTUAL CON DEVICES

In this menu, several Real CON Devices can be assigned to a Virtual CON Device.

This function reflects changes in permission made to Virtual CON Devices onto Real CON Devices. Virtual
CON Devices can be switched in the same way as Real CON Devices. Real CON Devices that are
assigned to a Virtual CON Devices that is connected to a CPU Device will receive the video signal. The
last-assigned CON Device will also have control of the keyboard and mouse.

*A Virtual CON Device can be assigned to more than one Real CON Devices.

FIGURE 6-9.6.1 MANAGEMENT SOFTWARE MENU - ASSIGNMENT - VIRTUAL DEVICES
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BUTTON FUNCTION

Send Send assignments to the matrix

Reload Reload changes

To place an assignment, proceed as follows:

1. Select Assignment > Virtual CON Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the required Real CON Device in the Real Console list.

4. Double-click in the Virtual Console column to display a list of all available Virtual CON 

Devices.

5. Select the required Virtual CON Device in the selection list.

6. Click the Send button to send the assignment to the matrix.

7. Click the Deactivate Edit Mode menu item in the toolbar.

The selection boxes in the Virtual Console column contain a filter function for an easy selec

tion of a single

CPU from a larger pool of CPUs.

The management software offers the option to switch directly from the Assignment menu to 
the definition

menu to check specific settings for the respective Real CON Device or Virtual CON Device.

Click with the secondary mouse button on the respective Real CON Device or Virtual CON 

Device and

     select Open CON Device in the context menu.

     The definition menu for the CON Device settings is opened (see chapter 6.9.1, page 191).

6.8.7	 ENABLING SHARED OPERATION

This menu enables shared operation of a CPU Device by two or more CON Devices. A CPU Device can be
controlled by only one CON Device at a time but can be taken over successively by other CON Devices.
Control of a CPU Unit by a CON Unit is relinquished after the expiration of an inactivity timer associated
with the controlling CON Device. The mouse or keyboard may also be used to take control. 

*To allow a smooth and accurate function of the shared operation, you should use identical mice and
keyboards. They should be connected to the same USB-HID ports of each CON Unit. The alternative is
using the USB-HID Ghosting (see chapter 6.8.1, page 204).
When taking over control within 10 s, any assigned USB 2.0 extender unit if available, will not be switched
due to security and stability aspects. The shared operation will be deactivated between CON Devices with a
different priority as well as the Release Time.
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To configure shared operation, proceed as follows:

1. Select System Settings > Switch in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Activate the Enable Video Sharing function.

4. Activate the Force Connect function.

5. Activate the Keyboard Connect function if taking over control by a keyboard event is to be permitted.

6. Activate the Mouse Connect function if taking over control by a keyboard movement should be possible.

7. Define a Release Time of inactivity (0 to 999 seconds) after which control can be taken over.

8. Click the Apply button to confirm the changes.

9. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-9.6.2 MANAGEMENT SOFTWARE MENU - SYSTEM SETTINGS - SWITCH
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6.8.8	 ENABLING MULTI-SCREEN CONTROL
When using Multi-Screen Control, switching up to eight connected sources (computers, CPUs) can be performed at one sink with 
only one connected mouse or keyboard. The sink can consist of up to eight CON Units and accordingly up to eight monitors, or up 
to sixteen monitors when using Dual-Head extenders modules. In a matrix system, Multi-Screen Control can be set up at multiple 
sinks. 

The CON Units of a sink with Multi-Screen Control must all be physically connected to the same block of 8 ports
on the I/O board. One of the CON Devices is designated for USB-HID control of the connected sources, below referred to as “Con-
trol CON Device”. Control CON Devices are referred to the extender modules/Ext Units within the Multi-Screen Control that are 
connected to keyboard and mouse for operation. 

If the control has to be performed via several USB-HID devices, several CON Devices have to be defined as Control CON Device. 
Smooth switching of sources with the mouse is performed by dragging the mouse pointer beyond the
respective display to an adjacent display in an arrangement of displays. The displays can be arranged side by side, in a grid 
layout, or completely freely. Alternatively, switching can be performed via keyboard commands according to the ID number in the 
Multi-Screen Control setup.

NOTICE

When using CON Units with the possibility to connect a local source (computer, CPU) in a Multi-Screen
Control environment, the local switching will be disabled.

*CON Units that have been already configured for Multi-Screen Control can be connected all together to
other blocks of 8 ports at another I/O board. In this case any further configuration is not necessary, their
functionality will remain as set previously.

 
 
 
 
 
 

FIGURE 6-9.8.1 MANAGEMENT SOFTWARE MENU - ASSIGNMENT - MULTI-SCREEN CONTROL
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FIELD ENTRY DESCRIPTION

Dual-Head Extender
Name

Y Enable configuring two displays for the Dual-Head extender

N Function not active (default)

Enable
Password

Y Activate the respective display for Multi-Screen Control

N Function not active (default)

Control
Administrator

Y Enable the CON Device for USB-HID control of other CON
Devices if access is permitted

N Function not active (default)

Deactivated Function not active (default)

Super User Selection

• Shared (default) permits the access from a Control CON
Device to all other CON Devices except to another Control

CON Device
• Name of the own Control CON Device to restrict access to

other CON Devices

0 to 999
seconds

Time for fade in a red frame at the display with current
mouse/keyboard control

Configuring Multi-Screen Control

To configure the Multi-Screen Control, proceed as follows:

1. Select Assignment > Multi-Screen Control in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the block of 4 or 8 ports in the list of the working area that should be configured for Multi-Screen

Control.

Only blocks of 4 or 8 ports that contain at least one CON Unit are shown.

4. Activate Manual option if the USB-HID switching is to be restricted to keyboard commands (see

chapter 7.2.6, page 276). Manual switching allows the use of multi-head consoles.

5. In the Arrangement field, select the layout for the CON Devices you want to configure. Select as

follows:

• Horizontal: horizontal arrangement

• Block: block arrangement

• Free: free arrangement (The free arrangement allows a flexible positioning of the screens for diverse

applications.) Move the screens from the Available Screens field to the arrangement field.

The fields for the configuration of the individual displays will be arranged accordingly.

6. If the CON Unit to be configured is a Dual-Head extender, click the Dual-Head Extender checkbox to

activate the option.

An additional display appears in the Available Screen field.
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7. Click the Enable checkbox for all CON Devices to be enabled for Multi-Screen Control.

8. Click the Control checkbox for one or more CON Devices to be enabled as Control CON Device.

Enabled Control CON Devices are shown as dark blue screens in the arrangement field.

9. Use the Frame function to configure a red frame, that shows the display with current mouse control, for

the duration of a specified time by flashing briefly. The frame can be activated individually for each

screen by using a timer > 0 seconds.

9.1. Double-click in the respective CON Device in the Frame column.

9.2. Select the time, the red frame should be faded in.

10. Click the Deactivate Edit Mode menu item in the toolbar. 

*All Control CON Devices are enabled to control USB-HID of all other CON Devices in the setup except of
another Control CON Device. To restrict the access to other CON Devices, see following section. 

Access Restriction when using Multiple Control CON Devices

Dragging the mouse pointer over the display boundary is only permitted for those displays whose CON

Device is enabled for access by the owner of the respective Control CON Device.

To enable access to a display for only one Control CON Device, proceed as follows:

1. To enable a Control CON Device for access for a CON Device, double-click on the corresponding

     selection box within the Owner column and select the name of the respective Control CON Device.

2. Double-click on the corresponding selection box within the Owner column of all Control CON Device

     whose display should be accessible and select the name of the respective Control CON Device.

     The mouse can now be used to access those displays whose CON Device is enabled for access by the

     assigned Control CON Device. 

No simultaneous USB HID sharing of multiple Control CON devices

Example: In a setup of 8 CON Devices, if CON Device 1 and 2 are each Control CON Devices and six
other “non-Control CON Devices” are configured, both Control CON Devices can access the displays of
CON Device 3 to 8 if they are configured with Owner = Sharing.

However, Control CON Device 1 and 2 cannot access the display of a “non-Control CON Device” at the
same time. The Control CON Device that first had USB-HID control is reset to its “own” display when the
second Control CON Device takes over.
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Changing Multi-Screen Control

To change the Multi-Screen Control for a setup, proceed as follows:

1. Select Assignment > Multi-Screen Control in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the setup in the list of the working area the Multi-Screen Control should be changed.

4. Make any edits at the configuration and system settings.

5. Click the Apply button to confirm the changes.

6. Click the Deactivate Edit Mode menu item in the toolbar.

Deleting Multi-Screen Control

To delete the Multi-Screen Control for a setup, proceed as follows:

1. Select Assignment > Multi-Screen Control in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the setup in the list of the working area the Multi-Screen Control should be deleted.

4. Click the Enable checkbox for all CON Devices to remove the checkmarks.

     The disabled Control CON Devices are shown as gray screens in the arrangement field and the Multi-
     Screen Control is disabled.

5. Click the Control checkbox for all CON Devices to remove the checkmarks.

6. Click the Deactivate Edit Mode menu item in the toolbar.

Configuring Multi-Head sources for Multi-Screen Control

NOTICE

A Multi-Head configuration for Apple Mac sources is not supported due to limitations of the macOS.

For the use of Multi-Head sources (computer, CPU), an additional configuration of the CPU Devices is
mandatory. The configuration of CPU Devices, which are connected to Single-Head sources (computer,
CPU) is not mandatory. 
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For an additional configuration of the CPU Devices for the use of Multi-Head sources (computer, CPU),
proceed as follows.

1. Select Extender & Devices > CPU Devices in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the CPU Device to be configured.

4. Select the Monitor Arrangement tab.

5. Enter the resolution of the total desktop area into the fields Total Desktop Resolution. For instance, if

there are 4 graphic card outputs with a resolution of 1920x1080 each, you have to enter 7680 under

Width and 1080 under Height.

FIGURE 2-14. BACK PANEL

FIGURE 6-9.8.2 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - CPU DEVICES - MONITOR ARRAGEMENT
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6. Select the individual resolution of the graphic card output from the selection list in the field

     Resolution 1 (e.g., 1920x1080). This is the graphic card output the CPU Device is connected to.

7. Enter the respective pixel coordinates of the CPU Device in the Multi-Screen Control arrangement into

     the fields Offset X and Offset Y. For instance, you have to enter 1920 for a shift of 1920 pixels to the

     right into the field Offset X. DKM flex Configuration via Management Software 215

8. If the CPU Device to be configured is a Dual-Head extender, click the Dual-Head Extender checkbox

    to activate the option. Enter the resolution of the 2nd graphic card output and the offset information in

    the field Resolution 2.

9. For some operating systems it is necessary to activate the option Multiplier. This is mandatory if you

    cannot reach all areas of the desktop with your mouse cursor.

10. Click the Apply button to confirm the settings.

       A dialog appears to restart the extender module.

11. Click the Yes button to restart the extender module to with the new configuration.

       The CPU Device is now configured for the Multi-Head operation. 

12. Click the Deactivate Edit Mode menu item in the toolbar.

6.9	 ACTIVE DIRECTORY

The KVM matrix can be synchronized with the directory service Active Directory regarding user
authentication. This allows the user to login at the KVM matrix using login information from the Active
Directory service and to contact the Active Directory Server for each authentication that does in fact the
proper authentication.

FIGURE 6-9.8.3 MANAGEMENT SOFTWARE DIALOG - MONITOR ARRANGEMENT - RESTART EXTENDER
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The connection between KVM matrix and the Active Directory server is established via OpenLDAP and
periodically synchronized every 5 minutes.
The search of users to be synchronized and automatically added to the KVM matrix configuration can either
be based on a group or organizational unit (OU). In both cases a user requires to be at least assigned to
one group:

	 • In case of the group, all users belonging to a previously defined group on the active directory server are
	   added to the KVM matrix and synchronized. In this alternative, the organizational structure of the
	   organizational units (OUs) is added as matrix user group to the KVM matrix configuration. This means
	   that the organizational unit (OU) that includes the user can be found as a matrix user group in the KVM
	   matrix configuration after the synchronization. A user can be member of up to 8 groups.

	 • In case of the organizational unit, all users belonging to groups that are located directly under this
	   organizational unit are added and synchronized. The groups can also include subgroups. The structure
	   of the groups is added to the KVM matrix configuration as user group. Each group will be represented in
	   the KVM matrix as a user group after the synchronization. Groups that are located in sub organizational
	   units will be ignored.

To configure the synchronization to the Active Directory server, proceed as follows:

1. Select System Settings > Network in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the LDAP tab in the working area.

FIGURE 6-10.1 MANAGEMENT SOFTWARE MENU - SYSTEM SETTINGS - NETWORK - LDAP
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4. Click the LDAP checkbox and optionally the Use TLS/SSL checkbox to activate these functions.

5. Enter the respective IP address and port number into the field LDAP Server (default port number: 389).

6. Enter the LDAP Base DN into the respective field (e.g., dc=example, dc=com).

7. Click the Apply button to confirm the settings.

*Changes done in step 4 to 7 only come into effect after a restart of the KVM matrix.

8. Select User Settings > Users & Groups in the task area. 

9. Click the New User button to create a new LDAP user (bind user).

    A selection dialog appears.

10. Select Create a LDAP User in the selection box.

11. Enter a username into the field Name.

12. Enter the Common Name (CN) of the bind user from the Active Directory into the field Login Name.

13. Enter the password of the bind user from the Active Directory into the field Password.

14. Click the Apply button to confirm the creation of the user. 

15. Stay in the menu and open the Groups tab.

FIGURE 6-10.1.1 MANAGEMENT SOFTWARE MENU - USER SETTINGS -USER & GROUP - USERS
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16. Click the New Group button to create a new LDAP group.

A popup window will appear.

17. Select Create a LDAP Group in the popup window.

The group determines which users of the Active Directory server should be synchronized.

18. Enter a name into the field Name.

19. Enter either the Common Name (CN) of a right group or the Common Name (OU) of an organizational

unit into the field LDAP OU=/CN= as shown below:

	 • OU= name of the organizational unit

	 • CN= name of the right group

20. Click the Apply button to confirm the creation of the group.

       The Active Directory synchronization can be used now.

21. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-10.1.2 MANAGEMENT SOFTWARE MENU - USER SETTINGS - USERS & GROUPS - USER ASSIGNMENT
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6.10	 MATRIX CASCADING

This simple method of cascading allows a switchable connection between two matrices via so called Tie
Lines. The Matrix Cascading does not require Bundle 4.

This kind of configuration may become necessary if the number of ports in the entire system has to be
increased or if certain important connections should be distributed to several matrices due to reasons of
redundancy.

The Tie Lines are unidirectional and can only be used in one direction according to their configuration. For
a bidirectional use of the cascading, you have to configure opposite Tie Lines.
To connect Tie Lines to the matrices, you first have to create intended Cascade CON Devices and
Cascade CPU Devices that have to be switched within the cascaded environment.

*Ensure that the Tie Lines will only be connected after finishing the configuration.

Activating the Sub Matrix Option

1. Connect to the defined Sub Matrix and click the Activate Edit Mode menu item in the toolbar.

2. Select System Settings > System in the task area of the Sub Matrix.

3. Activate the Sub Matrix option in the working area.

4. Click the Apply button to confirm the Sub Matrix option.

*The OSD of the Sub Matrix will immediately freeze and will be only accessible by using the keyboard
command <Hot Key>, <s>, <o>.

5. Click the Deactivate Edit Mode menu item in the toolbar.
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6.10.1	 DIRECTING A TIE LINE FROM THE SUB TO THE MASTER

To configure settings for using Matrix Cascading and to direct the Tie Line from the Sub to the Master,

proceed as follows:

1. Connect to the Master Matrix.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the menu Extender & Devices > EXT Units in the task area.

	 3.1. Click the New Unit button.

	         A selection dialog appears.

	 3.2. Select Cascading CPU Unit in the Choose template selection box.

	 3.3. Click the OK button.

A new Cascading CPU Unit will be created.

FIGURE 6-11.1 MANAGEMENT SOFTWARE MENU - SYSTEM SETTINGS > SYSTEM
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5. Connect to the Sub Matrix.

6. Click the Activate Edit Mode menu item in the toolbar.

7. Select the menu Extender & Devices > EXT Units in the task area.

	 7.1. Click the New Unit button.

	        A selection dialog appears.

	 7.2. Select Cascading CPU Unit in the Choose template selection box.

	 7.3. Click the OK button.

A new Cascading CPU Unit will be created.

FIGURE 6-11.1.1 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - CASCADING CPU UNIT
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7.4. Enter an appropriate name for the Cascading CON Unit into the Name field.

	 7.5. Enter a port number into the Port field according to the required connection of the Tie Line.

	 7.6. Click the Apply button to confirm the creation of a Cascading CON Unit. 

8. Select Extender & Devices > CON Devices in the task area of the Sub Matrix.

	 8.1. Click the New Device button.
	         
	         A switchable CON Device will be created.

	 8.2. Enter an appropriate name for the Cascading CON Device into the Name field. 

FIGURE 6-11.1.2 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - CASCADING CPU DEVICES
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	 8.1. Select the previously configured Cascading CON Unit in the Extender available list.

	 8.2. Click the button to move the highlighted Cascading CON Unit to the Extender assigned list.

	         The assignment is displayed in the Extender assigned list.

	 8.3. Click the Apply button to confirm the assignment.

9. Click the Deactivate Edit Mode menu item in the toolbar.

The OSD of the Sub Matrix will immediately freeze and will be only accessible by using the keyboard
command <Hot Key>, <s>, <o>.

10. Restart all I/O boards on which any Master/Sub CON Units or CPU Units have been configured (see
chapter 7.10.3, page 295) or alternatively restart the matrix (see chapter 7.10.1, page 293).

11. Connect the Tie Lines to the matrices. Ensure that each Cascade CON Device on one matrix is
connected to Cascade CPU Device on the other matrix to achieve switching ability between two
matrices.

The Matrix Cascading is now configured and can be used.
Additional Tie Lines are configured accordingly. The use of cascading is described in chapter 6.11,
page 247.

FIGURE 6-11.1.3 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - CASCADING CON UNITS
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6.10.2	 DIRECTING A TIE LINE FROM THE MASTER TO THE SUB

To configure settings for using Matrix Cascading and to direct the Tie Line from the Master to the Sub,
proceed as follows:

1. Connect to the Master Matrix.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the menu Extender & Devices > EXT Units in the task area.

	 3.1. Click the New Unit button.
	      
	        A selection dialog appears.
	
	 3.2. Select Cascading CON Unit in the Choose template selection box.
	
	 3.3. Click the OK button.

A new Cascading CON Unit will be created.

 

FIGURE 6-11.2.1 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - CASCADING CON UNITS
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	 3.4. Enter an appropriate name for the Cascading CON Unit into the Name field.

	 3.5. Enter a port number into the Port field according to the required connection of the Tie Line.

	 3.6. Click the Apply button to confirm the creation of a Cascading CON Unit. 

4. Select Extender & Devices > CON Devices in the task area of the Master Matrix.

	 4.1. Click the New Device button.

	         A switchable CON Device will be created.

	 4.2. Enter an appropriate name for the Cascading CON Device into the Name field.

	 4.1. Select the previously configured Cascading CON Unit in the Extender available list.

	 4.2. Click the button to move the highlighted Cascading CON Unit to the Extender assigned list.

		  The assignment is displayed in the Extender assigned list.

	 4.3. Click the Apply button to confirm the assignment.

FIGURE 6-11.2.2 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES > CON DEVICES - CASCADING CON DEVICE
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5. Connect to the Sub Matrix.

6. Click the Activate Edit Mode menu item in the toolbar.

7. Select the menu Extender & Devices > EXT Units in the task area.

	 7.1. Click the New Unit button.

	 A selection dialog appears.
	
	 7.2. Select Cascading CPU Unit in the Choose template selection box.

	 7.3. Click the OK button.

	 A new Cascading CPU Unit will be created.

	 7.4. Enter an appropriate name for the Cascading CPU Unit into the Name field.

	 7.5. Enter a port number into the Port field according to the required connection of the Tie Line.

	 7.6. Click the Apply button to confirm the creation of a Cascading CPU Unit. 

FIGURE 6-11.2.3 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES - EXT UNITS - CASCADING CON UNIT
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9. Click the Deactivate Edit Mode menu item in the toolbar.

10. Restart all I/O boards (see chapter 7.10.3, page 295) on which any Master/Sub CON Units or

CPU Units have been configured or alternatively restart the matrix (see chapter 7.10.1, page 293).

11. Connect the Tie Lines to the matrices. Ensure that each Cascade CON Device on one matrix is
connected to Cascade CPU Device on the other matrix to achieve switching ability between two
matrices.

The Matrix Cascading is now configured and can be used.
Additional Tie Lines are configured accordingly. The use of cascading is described in chapter 6.11
page 247.

8. Select Extender & Devices > CPU Devices in the task area of the Sub Matrix.
	
	 8.1. Click the New Device button.

	         A switchable CPU Device will be created.

	 8.2. Enter an appropriate name for the Cascading CPU Device into the Name field.

	 8.1. Select the previously configured Cascading CPU Unit in the Extender available list.

	 8.2. Click the button to move the highlighted Cascading CPU Unit to the Extender assigned list.

	          The assignment is displayed in the Extender assigned list.
	
	 8.3. Click the Apply button to confirm the assignment.

FIGURE 6-11.2.4 MANAGEMENT SOFTWARE MENU - EXTENDER & DEVICES > CON DEVICES - CASCADING CON DEVICE
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6.11	 SAVING AND ACTIVATING CONFIGURATIONS

First starting the matrix, the factory configuration will be copied into the current configuration. You have 3
possibilities to save configuration changes:

	 • saving the current configuration permanently in the matrix memory (Remote Save)

	 • saving configuration on a local memory (Save or Save as)

	 • uploading the configuration in up to 8 predefined storage locations, as well as the default configuration

in the memory of the matrix (Upload)

6.11.1	 SAVING THE CURRENT CONFIGURATION TO THE MATRIX

*By default, the last configuration that has been saved in this way will be restored after a restart of the
matrix.

To save the current configuration permanently in the matrix memory, proceed as follows:

1. Click the Remote Save menu item in the toolbar.

    A query to save the configuration appears.

2. Click the Yes button to confirm the saving.

     The previously active configuration is overwritten and saved in the permanent memory of the matrix.

NOTICE

By default, the last configuration that has been saved in the permanent matrix memory will be restored
after a restart of the matrix.

FIGURE 6-12.1.1 MANAGEMENT SOFTWARE DIALOG SAVE REMOTE CHANGES
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6.11.2	 SAVING OF CONFIGURATIONS LOCALLY

Configurations can be saved as a file that can be stored independent of the matrix.

To save a configuration file locally, proceed as follows:

1. Select File > Save or File > Save As in the menu bar.

2. Enter a name for the configuration.

3. Select the directory of the configuration on your storage medium where the configuration is to be saved.

*Configurations are always saved with the file extension .dtc. 

FIGURE 6-12.2.2 MANAGEMENT SOFTWARE MENU FILE - SAVE AS..
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6.11.3	 OPENING A LOCALLY SAVED CONFIGURATION

To open a locally saved configuration, proceed as follows:

1. Click the Open... menu item in the toolbar.

2. Navigate to the location of the configuration file to be opened.

3. Click the configuration file to be opened.

4. Click the Open button, to open the configuration file.

*The configuration can also be opened via drag & drop. To do this, click on the configuration file, hold down
the primary mouse button and drag the configuration file into the management software.

FIGURE 6-12.3.1 MANAGEMENT SOFTWARE MENU OPEN
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6.11.4	 UPLOADING A PREDEFINED CONFIGURATION TO THE MATRIX

Using the function Upload, the created configuration can be saved within eight storage locations in the
matrix (File#1 to File#8). However, it does not replace the buffering of configuration (see chapter 6.12.1,
page 228).

Additionally, a configuration can also be saved as default configuration that can be automatically loaded
with each start.
To upload an opened configuration to the matrix, proceed as follows:

1. Click the Upload menu item in the toolbar.

An access window appears.

2. Enter the IP address of the matrix .

3. Enter the username and password of the administrator.

4. Click the Next button to display the selection of storage slots. 

5. Under Select Configuration Slot, select the storage slot for the configuration (default or config01 to
config08).

6. Option: To activate the uploaded configuration immediately, click the Activate configuration after
upload check box.

NOTICE

If you click the Activate configuration after upload option, the matrix will be restarted immediately after
the save process has been completed. The restart of the matrix may take several minutes, and the matrix

is not available during the restart.

FIGURE 6-12.4.1 MANAGEMENT SOFTWARE MENU UPLOAD - CONNECT
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7. Click the Finish button to save the configuration to the selected storage location.

    A message appears to inform about successful upload.

6.11.5	 ACTIVATING A PREDEFINED CONFIGURATION

Previously saved configurations are loaded in this menu. In Active Configuration, the name and detailed
information of the currently loaded configuration is displayed. The selection of the configuration to be
loaded can be made between eight customizable configurations and the default settings.

To activate an uploaded configuration, proceed as follows:

1. Select Status & Updates > Activate Configuration during online-mode in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the configuration to be activated.

NOTICE

Activating a configuration will disconnect and restart the matrix. The selected configuration is loaded on
restart and is shown in the menu as active configuration under Active Configuration in the working area.

The previously active configuration is overwritten.
The restart of the matrix may take several minutes, and the matrix is not available during the restart.

FIGURE 6-12.4.2 MANAGEMENT SOFTWARE MENU UPLOAD - SELECT CONFIGURATION SLOT
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4. Click the Activate button to activate the selected configuration.

     A query to restart the matrix appears.

5. Click the Yes button to confirm the activation of the selected configuration.

    The connection is disconnected, and the matrix is restarted. The selected configuration is loaded on

    restart and is shown in the menu as active configuration under Active Configuration in the working

    area. The previously active configuration is overwritten.

6. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-12.4.3 MANAGEMENT SOFTWARE STATUS & UPDATES - ACTIVATED CONFIGURATION
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6.11.6	 DOWNLOADING A PREDEFINED CONFIGURATION FROM THE MATRIX

Configurations saved in the matrix can be downloaded for offline editing in this menu.

To download a configuration from the matrix, proceed as follows:

1. Click the Download menu item in the toolbar.

     An access window appears.
  
2. Enter the IP address of the matrix .

3. Enter the username and password of the administrator.

4. Click the Next button to display the selection of storage location.

5. Under Select Configuration, select the storage location of the desired configuration (default or
     config01 to config08).

6. Click the Finish button to download the desired configuration to management software.

FIGURE 6-12.6.1 MANAGEMENT SOFTWARE MENU - CONNECT
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6.12	 EXPORT AND IMPORT OPTIONS

The KVM Matrix offers the ability to read out available configuration lists (extenders, CPUs, consoles and
users) for export and import again via management software.

*Exported configuration lists are always saved in .csv format that allows offline editing with common
spreadsheet applications.

6.12.1	 EXPORT / IMPORT OPTIONS

Configuration lists are exported in this menu.

FIGURE 6-12.6.2 MANAGEMENT SOFTWARE MENU -DOWNLOAD - SELECT CONFIGURATION
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To export, proceed as follows:

1. Select File > Import / Export in the menu bar.

2. After opening the menu, select the list to import / export.

3. Click the Next button.

4. Navigate to the location of the configuration file to be exported.

5. Enter the name for the configuration file to be exported.

6. Click the Finish button to confirm the export.

FIGURE 6-13.1.1 MANAGEMENT SOFTWARE MENU - FILE EXPORT - SELECT TYPE
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6.13	 UPDATING THE FIRMWARE

6.13.1	 UPDATING THE MATRIX FIRMWARE

*For Linux-based systems, the firmware update of MATLOS has to be performed version by version. E.g., if
the current firmware version is F01.04 should be updated to F01.08, first update with F01.05, then F01.06
and so on. After each firmware update, the matrix has to be restarted.

NOTICE

To process successful firmware updates and avoid failures:
Only use computers to update the matrix that are not integrated into the matrix setup.

Ensure that the computer used for the update is not set into standby mode or sleep mode during the
update.

Save your configuration locally before starting the update.
 Proceed an update via direct LAN connection for reasons of network stability.

NOTICE

Ensure that all USB 2.0 extenders are only connected to the provided ports (fixed ports) before you start
the matrix update. Non-compliance may affect the stability of the update.

FIGURE 6-13.1.2 MANAGEMENT SOFTWARE MENU - FILE EXPORT - EXPORT CONFIGURATION TO CSV FILE
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The firmware of the matrix can be updated in this menu.

The firmware of the matrix can be updated in this menu.

Preparation

*If the syslog function has not been set yet, we recommend activating the syslog function (see chapter 6.4.7,
page 165) before updating the firmware to log the update in case of update errors.

OPTION DESCRIPTION

Name Module name

Type Type number

Current Version Installed firmware version

Update Version Current firmware version

FIGURE 6-14.1.1 MANAGEMENT SOFTWARE MENU - STATUS & UPDATES - UPDATE MATRIX FIRMWARE
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To be prepared for a firmware update, proceed as follows:

1. Save the matrix configuration locally (see chapter 6.12.2, page 257).

2. If the options settings for the management software have not yet been set:

	 2.1. Open Extras > Options in the menu bar.

	 2.2. Under Firmware Directory insert in the directory from which the update files should be standardly

	         sourced.

3. Save the update files in the Firmware Directory.

     Performing the Update

     To update the matrix firmware, proceed as follows:

1. Select Status & Updates > Update - Matrix Firmware in the task area.

     All updateable components of the matrix will be automatically selected and highlighted in green.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click the Update button in the lower part of the working area to start the update.

     A query to save the matrix status appears.

4. Click the Save Matrix Status button to save the matrix status locally or click the Skip button, if the

     status is already saved.

5. The progress of the update is displayed in the working area.

     After the update, a query to restart the matrix appears.

6. Click the Yes button to restart the matrix. 

     The updated firmware is displayed in the working area.

7. Click the Deactivate Edit Mode menu item in the toolbar.

FIGURE 6-14.1.2 MANAGEMENT SOFTWARE DIALOG SAVE MATRIX STATUS
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6.13.2	 EXTENDER UPDATE

The firmware of the extenders connected to the matrix can be updated in this menu, except the firmware
type MSD. 

There are two possibilities to update the extenders:

• Parallel Mode: By default, used for parallel updates of several extenders.

• Sequential Mode: Option the update an extender after the update of another extender is finished.

Preparation

If the syslog function has not been set yet, we recommend activating the syslog function (see chapter 6.4.7,
page 165) before updating the firmware to log the update in case of update errors.

To be prepared for a firmware update, proceed as follows:

1. Save the matrix configuration locally (see chapter 6.12.2, page 229).

2. If the options settings for the management software have not yet been set:

	 2.1. Open Extras > Options in the menu bar.

	 2.2. Under Firmware Directory insert in the directory from which the update files should be standardly

	         sourced.

3. Save the update files in the Firmware Directory.

NOTICE

Possible failures when updating the firmware

When updating individual firmware files, there may be dependencies on the new content of the files
HUSWMSD.pfw or HUSWITCH.pfw if they are changed. Installing in the wrong sequence could lead to

failed updates.
To process successful firmware updates and avoid failures:

First check if there is an update available for the HUSWMSD or HUSWITCH firmware (comparison with
the status displayed in the management software.

If there is an update available, update the firmware files via service port of the extender modules.
Afterwards proceed the update using the function in the management software.
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Performing the Update in Parallel Mode (Standard Update)

To update the extender firmware via standard update, proceed as follows:

1. Select Status & Updates > Update - Extender Firmware in the task area.
    The Parallel Mode for the standard update will be selected by default and the Upload Firmware tab
    will be opened.

2. Before the actual update process, all firmware files have to be uploaded to the respective I/O boards on
    which the extenders are to be updated. If a newer firmware is available, appropriate I/O boards will be
    automatically selected for the upload in the Selected column and highlighted in green.

3. Click the Upload button to start the upload and distribution of the update files. 

*By performing the upload process, no update files will be installed. The update process can be performed
later. If there are not selected all I/O cards, the upload of the update files will be performed in sequence.

A query to update the extender firmware appears finishing the upload process successful.

4. Click the Yes button if you want to directly start the actual update process.
The Update Firmware tab will open immediately.

FIGURE 6-14.2.1 MANAGEMENT SOFTWARE MENU STATUS & UPDATES -  
UPDATE EXTENDER FIRMWARE - PARALLEL MODE - UPLOAD
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*When updating an identical or an older firmware version than the version currently installed, the Enable
Downgrade option in the upper part of the working area must be enabled.

5. Click the Update button to start the update.

*Just before the update process, all affected I/O boards will be set into the Service Mode and retrieved
gradually after finishing the respective updates. During Service Mode, all matrix functions are disabled on
the I/O boards on which an update is currently performed. An OSD picture indicates the activation of the
Service Mode and is displayed on all monitors that are connected to the matrix via a CON device.

6. The progress of the update is displayed in the working area.

7. Check the update messages in the message field after the update if the updates for all extenders have
     been installed correctly.

FIGURE 6-14.2.2 MANAGEMENT SOFTWARE DIALOG STATUS & UPDATES - UPDATE EXTENDER 
FIRMWARE PARALLEL MODE - UPDATE

FIGURE 6-14.1.3 MANAGEMENT SOFTWARE DIALOG STATUS & UPDATES - UPDATE EXTENDER 
FIRMWARE PARALLEL MODE - UPDATE
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Performing the Update in Sequential Mode (Expert Update)

To update the extender firmware via sequential update, proceed as follows:

1. Select Status & Updates > Update - Extender Firmware in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the Sequential Mode option in the upper part of the working area.

    All updateable extenders will be automatically selected and highlighted in green.

4. Click the Update button in the lower part of the working area to start the update.

Just before the update process, all affected I/O boards will be set into the Service Mode and retrieved
gradually after finishing the respective updates. During Service Mode, all matrix functions are disabled on
the I/O boards on which an update is currently performed. An OSD picture indicates the activation of the
Service Mode and is displayed on all monitors that are connected to the matrix via a CON device.

     After update completion the Service Mode will be quit.

5. Check the update messages in the message field after the update if the updates for all extenders have
     been installed correctly.

FIGURE 6-14.1.4 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - UPDATE EXTENDER 
FIRMWARE - SEQUENTIAL MODE
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6. Click the Deactivate Edit Mode menu item in the toolbar.

6.14	 LICENSE MANAGEMENT

In this menu the matrix can be upgraded with new function bundles by installation of license keys.

To obtain license keys to upgrade matrix functions, contact Black Box tech suppert.

FIGURE 6-14.1.5 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - UPDATE EXTENDER 
FIRMWARE - SEQUENTIAL MODE
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To activate a function bundle, proceed as follows:

1. Select Status & Updates > Miscellaneous in the task area.

2. Select the Miscellaneous tab.

3. Enter your license key in the working area under Activate License in the License Key field.

4. To activate the license key, click the Activate button.
    The new functions will be immediately enabled, a restart of the matrix will not be necessary.

 

FIGURE 6-15.1 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - MISCELLANEOUS - LICENSE 
MANAGEMENT
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CHAPTER 7:

7.1	 OPERATION

The matrix can be operated in three different ways:

1. Direct Switching

	 • via a keyboard connected to a CON port and the favorites

	 • by a macro keyboard connected to a console port

2. OSD

	 • via keyboard/mouse directly connected to the CPU board of the matrix

	 • via keyboard/mouse connected to a CON Unit and the OSD

3. External Switching Commands

	 • via an external computer via management software (network connection required)

	 • via a media control (network connection required)

7.2	 SWITCHING OPERATION VIA KEYBOARD

7.2.1	 DIRECT SWITCHING

The direct switching by favorites on a keyboard is the fastest possibility for a user to switch at his console
between different CPUs. This offers the option to switch video, keyboard and mouse or Video Only.

Direct Switching of Video, Keyboard and Mouse

1. Start the command mode with the Hot Key.
    The Caps Lock and Scroll Lock LEDs on the keyboard are flashing.

2. Enter the index number of the new CPU from the list of favorites.

3. Press the <Enter> key to confirm.
    At the same time the command mode is closed, and the console is connected to the new CPU which
    takes over complete control.

    Example: Switching to favorite CPU 7 with video, keyboard, and mouse

    <left Shift>, <left Shift>, <7>, <Enter>

*Fastest switching time can be achieved by using identical mice, keyboards, and monitors. This contributes
to a smooth and seamless direct switching of the matrix.

Switching in Private Mode

1. Start the command mode by entering the Hot Key.
    The Caps Lock and Scroll Lock LEDs on the keyboard are flashing.
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2. Enter the index number of the new CPU from the list of favorites.
3. Press the <left Shift>, <Enter> keys at the same time to confirm.
    At the same time the command mode is closed, and the console is connected to the new CPU with
    complete control in Private Mode.

    Example: Switching to favorite CPU 3 in Private Mode
    <left Shift>, <left Shift>, <3>, <left Shift>, <Enter>

Direct Switching of Video

1. Start the command mode by entering the Hot Key.
    The Caps Lock and Scroll Lock LEDs on the keyboard are flashing.

2. Enter the index number of the new CPU from the list of favorites.

3. Press the <Space> key to confirm.
    At the same time command mode is closed, and the console is connected to the new CPU with Video
    Only.

    Example: Switching to favorite CPU 1 with Video Only
    <left Shift>, <left Shift>, <1>, <Space>

Switching to previous CPU

*If you switch to a CPU that was previously connected with Video Access only, you will be connected to this
CPU with full KVM access.

*You can only switch to valid, unused CPUs using Hot Keys. The options Force Connect and Force
Disconnect as well as the restrictions of the User ACL and CON ACL are taken into account.
Hot Keys are only supported if neither Enable User Login nor the Enable User ACL is selected, and the
user is logged in the OSD.

1. Start the command mode by entering the Hot Key.
    The Caps Lock and Scroll Lock LEDs on the keyboard are flashing.

2. Press the <p> key of your keyboard.
     At the same time command mode is closed, and the console is connected to the previous CPU with
     complete control.
     Disconnecting current connection

1. Start the command mode by entering the Hot Key.
     The Caps Lock and Scroll Lock LEDs on the keyboard are flashing.

2. Press the <Backspace> key of your keyboard.
     The command mode is closed, and the console is disconnected from the previous connected CPU.

*Optimal results can be achieved by using identical resolutions as far as possible. This contributes to a
smooth and seamless function of the scan mode.

7.2.2	 FUNCTION KEYS <F1> TO <F16>

In the command mode you can retrieve the macros 1 to 32 with the <F1> to <F16> function keys on the
connected standard keyboard instead of the special macro keyboard.

Executing macros 17 to 32 is realized by the simultaneous use of the <left Shift> key.
The stored command sequence for the appropriate function key is executed and the command mode is left
immediately.

It is not necessary to press <Enter> to confirm the selection of macros.
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7.2.3	 SWITCHING A CON UNIT TO A LOCAL SOURCE

KVM extender CON Units connected to a local source (computer, CPU) can be locally switched via the
matrix. Switching is performed between the local source and the KVM connection and can be executed via
keyboard commands or OSD (see chapter 7.2.4, page 254).
If you switch to the local source, the KVM connection will be automatically disconnected.

*When using CON Units with the possibility to connect a local source (computer, CPU) in a Multi-Screen
Control environment, the local switching will be disabled.

The following keyboard commands are available to switch to the local source:

KEYBOARD COMMANDS DESCRIPTION

<Hot Key>, <k>, <1>,
<Enter> Switching to extender connection

Type <Hot Key>, <k>, <2>,
<Enter> Switching to extender connection 2 (only with redundant CON Units)

<Hot Key>, <l>,
<Enter> Switching to the local source (computer, CPU)

7.2.4	 MULTI-SCREEN CONTROL SWITCHING VIA KEYBOARD

The Multi-Screen function contains a switching of the USB-HID signal between different statically
connected sources (computer, CPU) within a CON Device and can be performed via keyboard
(configuration see chapter 7.12, page 327) or mouse (see chapter 7.3, page 277).

To perform a switching operation via keyboard command, proceed as follows:

1. Enter the <Hot Key> to start the command mode.

2. Press the respective key on the numeric pad of the keyboard to select the target display.
     The switching operation will be performed, and the USB-HID signal will be available at the target
      display. 

The following keyboard commands are available for switching operations:

KEYBOARD COMMANDS DESCRIPTION

<current Hot Key>,
<Num 0>

Switching of the USB-HID signal to the own display (CON Unit with keyboard
and mouse)

<current Hot Key>,
<Num 1> Switching of the USB-HID signals to display #1

<current Hot Key>,
<Num 2> Switching of the USB-HID signals to display #2)

<current Hot Key>,
<Num 3> Switching of the USB-HID signals to display #3

<current Hot Key>,
<Num 4> Switching of the USB-HID signals to display #4
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7.3	 SWITCHING VIA OSD

7.3.1	 KVM SWITCHING

To switch the console to any available CPU, proceed as follows:

1. Select Switch in the main menu.

2. Select in the CPU Devices list on the left-hand side that CPU that should be connected to the CON
    Device.

3. Press the appropriate keyboard command to confirm desired connection type.

*Switching operations from the own CON Device can only be performed on CPU Devices that are available
in the CPU Devices list.

*Listed CPU Devices highlighted in red color are currently connected in Private Mode and are blocked by the
connected CON Device.

Press the <F8> key to expand the current view to show inactive CPU devices. 

.

FIGURE 7-3.1.1 OSD MENU SWITCH
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Switching via Selection List for CPU Devices

The matrix offers the ability to execute KVM switching operations by means of a selection list for CPU
Devices next to the OSD in full screen.

To use the selection list for CPU Devices, proceed as follows:

1. Activate the Enable CPU Selection List option in the Configuration > EXT Units menu for those
    consoles where the selection list for CPU Devices should be available.

2. Start the command mode by entering the Hot Key and press <o> to open OSD.
     The selection list immediately appears in the preset position of the extender OSD. 

*Press the <F8> key to hides inactive CPU Devices to provide a clearer overview. 

3. Press the respective key (see chapter 7.2.1, page 250) to execute the desired switching operation.
     To prevent a switching operation and access OSD, press <F7> key.
     To close the selection list, press <Esc> key. 

Activating the automatic Scan Mode for CPU Devices
The matrix offers the ability to use a scan mode based on the favorite list of each console or user. Scan
mode allows the matrix to switch in sequence between the CPU Devices in the favorite list within a
predefined time. All scans are performed in Video Only mode.

To configure the scan mode, refer to chapter 5.8.3, page 100.

To activate the scan mode, proceed as follows:
1. Define a favorite list for the respective CON Device or users 

2. Start the command mode by entering the Hot Key and press <o> to open OSD.

3. Select one of the CPU Devices in the CPU selection list that are defined in your favorite list.

4. Confirm your selection by pressing the CPU Scanner button. The scan will automatically start.

*If you have enabled the Force CPU Scan option, the scan will automatically
start after switching the respective CON Device to any CPU Device from the favorite list without the need to
press the CPU Scanner button.

FIGURE 7-3.1.2 EXAMPLE VIEW SELECTION LIST CPU DEVICES
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7.3.2	 EXTENDED SWITCHING

The following information is shown in this menu:

FIELD DESCRIPTION

CON device Real CON Device with assigned CON EXT Unit

CON assigned Virtual CON Device that is assigned to the Real CON Device

CPU connected Currently connected CPU Device

CON status Current connection status (CON Device)

EXT list List of all available physical Ext Units (CON Units)

CPU device Assigned physical EXT Unit (CPU Unit)

CPU assigned Real CPU Device that is assigned to a Virtual CPU Device

FIGURE 7-3.2.1 OSD MENU EXTENDER SWITCH

CHAPTER 7: OPERATION



2661.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

The following keyboard commands are available for switching operations:

To switch any console to any available CPU, proceed as follows:

1. Select Switch in the main menu.

2. Select in the CON Devices list on the left-hand side that one that should be switched to a CPU Device.

3. Press the <Enter> key.
    The connection types and their corresponding keyboard commands are listed in the lower working
    area.

4. Press the appropriate keyboard command to confirm the desired connection type.

*Switching operations from the user’s CON Device can only be performed on CPU Devices that are
available in the CPU Devices list.

*Press the <F8> key to expand the current view to show inactive CPU devices.

7.3.3	 USB 2.0 SWITCHING

Switching of USB 2.0 extender basically works like switching of KVM extenders. The following scenarios to
switch USB 2.0 extenders are possible.

1. An extender unit with USB 2.0 will be created and assigned to an already existing device with existing
    KVM Ext Units (see chapter 5.6.1, page 106).

2. A separate device for the extender unit with USB 2.0 will be created without assigning a KVM extender
    unit to that device. This possibility offers a separate switching of the USB 2.0 signal (see chapter 5.6.1,
       page 106).

FIELD DESCRIPTION

CON connected Currently connected CON Device

CPU status Current connection status (CPU Device)

EXT list List of all available physical Ext Units (CPU Units)

KEYBOARD COMMAND FUNCTION

<Space> Currently connected CON Device

<Enter> Current connection status (CPU Device)

<Shift> + <Enter> List of all available physical Ext Units (CPU Units)

<Backspace> Disconnect own CON Device from CPU Device.
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*Switching of USB 2.0 signals uses Extended Switching functionality (see chapter 7.2.2, page 252).
When using parallel operation within the matrix, set the Release Time in the System Settings > Switch
menu to 10 s or more (see chapter 6.4.5, page 162). Otherwise, the connection of the USB 2.0 extender will

not be established due to security and stability reasons.

7.3.4	 SWITCHING A CON UNIT TO A LOCAL SOURCE

CON Units connected to a local source (computer, CPU) can be locally switched via the matrix. Switching is
performed between the local source and the KVM connection and can be executed via OSD or keyboard
command (see chapter 7.1.2, page 327).

If you switch to the local source, the KVM connection will be automatically disconnected.

*When using CON Units with the possibility to connect a local source (computer, CPU) in a Multi-Screen
Control environment, the local switching will be disabled.

FIGURE 7-3.4.1 OSD MENU SWITCH
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To switch to a local source, proceed as follows:

1. Select Switch in the main menu.

2. If you are not in the Switch menu of the OSD, enter the <Hot Key> to start the command mode.

3. Press the <o> key to open OSD. You will see a list of all available CPUs as a start menu.

4. Switch to the CPU in the Local CPU list.
    The switching operation to the local source will be performed immediately. 

*The local source (computer, CPU) will be only shown in the OSD if the connected CON Unit includes the
option for a local connection.

7.3.5	 SWITCHING VIA MACRO LIST

Next to executing macros via function keys <F1> to <F16>, they can also be executed via Macro List in
the OSD. At the same time this specific list offers the possibility to see the content of the various macros
including the single commands before executing them. There are displayed 16 of the total 32 macros per
page.

FIGURE 7-3.5.1 OSD MACRO LIST
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1. Select Macro List in the main menu.

2. Make sure that you have already configured CON or user macros.

3. Select the respective macro in the list that you want to execute.

4. If you want to execute a macro 17-32 (<Shift> + <F1> to <F16>), press the <Page Down> key and select the macro after-
wards. 

5. Press the <Enter> key to execute the macro The macro will be immediately executed. 

If the Macro List should be directly displayed upon opening OSD, activate the option Show Macro List in
the menu Configuration > CON Devices for the respective CON Devices.

7.3.6	 SWITCHING OF SINGLE EXTENDERS WITHIN DEVICES

You can independently switch single extenders within configurations consisting of CON and CPU Devices
with multiple extenders.

To switch a single extender to a device with multiple extenders, proceed as follows:

1. Select Switch in the main menu.

2. Select the respective CPU Device in the CPU Devices list containing the extender you want to have access to.

3. Press the <F7> function key on the keyboard. The standard will change into the switching mode for single extenders.

FIGURE 7-3.6.1 OSD MACRO LIST

CHAPTER 7: OPERATION



2701.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

4. Select the extender you want to switch within your CON Device.

5. Press the <Tab> key to access the extender list of the selected CPU Device.

6. Select the CPU extender you want to switch to.

7. Press the <Space> key to execute the switching operation. 

Switching of single extenders from a Device is only possible in Video Only mode. Single extenders of a Device that are already 
switched will be highlighted with “!”. 

7.3.7	 ADDRESSING OF MASTER AND SUB MATRICES

The matrix can be cascaded over two levels. You can either send the commands (including opening the
OSD) to the master or the sub matrix.

When in the command mode, you can select whether commands should be handled in the master or the sub matrix.

OSD Access

	 • OSD access to the master matrix: <Hot Key>, <o>

	 • OSD access to the sub matrix <Hot Key>, <s>, <o>

To do a cross-matrix switching, proceed as follows:

1. Open the OSD of the master matrix with the following keyboard sequence: <Hot Key>, <o>

2. Select the CPU device configured as Tie Line in the CPU selection list and press the <Enter> key to switch onto.

3. Open the OSD of the sub matrix with the following keyboard command:    <Hot Key>, <s>, <o>

4. Select your target CPU in the CPU selection list of the sub matrix. 

*The selected master matrix / sub matrix mode is permanently activated until the other mode will be
manually activated. This means that if you press the <s> key, all prospective commands will be sent to the
sub matrix, but not if the command mode is left in the meantime.

7.4	 SWITCHING OPERATION VIA MANAGEMENT SOFTWARE

7.4.1	 EXTENDED SWITCHING

*Switching operations can only be performed in online mode. That means an active network connection is
required between the matrix and the management software. 

You have two options to perform switching operations for the matrix via management software:

Possibility 1:
All connected consoles and the associated CPU connections are shown in columns in the working area in this menu.

1. Select Control > Extended Switch in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.
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The following functions are available to perform a switching operation: 

BUTTON FUNCTION

Send Send effected switching operations to the matrix

Reset Disconnect all existing connections within the matrix

Reload Reload switching status

To perform a switching operation, proceed as follows:

To set a KVM connection between a CON Device and a CPU Device, double-click on the
corresponding selection box within the Full Access column and select the requested CPU Device. 

To set a video connection between a CON Device and a CPU Device, double-click on the
corresponding selection box within the Video Access column and select the requested CPU Device.

To set a Private Mode connection between a CON Device and a CPU Device, double-click on the
corresponding selection box within the Private Access column and select the requested CPU Device.

FIGURE 7-4.1.1 MANAGEMENT SOFTWARE MENU CONTROL - EXTENDER SWITCH
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*If a CPU Device does not have access rights, it will not appear in the list.

*When the Auto Send function in the left lower corner of the work area is ticked, switching operations will be
completed immediately without user confirmation by means of the Send button.
When the Hide Devices w/o Extender Assignment function in the left lower corner of the work area is
ticked, only CON Devices and CPU Devices that are assigned to extenders are shown.

Possibility 2:

The following symbols may be shown in the connection overview:
BUTTON FUNCTION

CON Device is connected via Shared Access with at least one further CON
Device to the same CPU Device. The CON Device has Full Access at the

moment.

CON Device is connected via Shared Access with at least one further CON
Device to the same CPU Device. The CON Device has a Video Access

connection at the moment.

Reload Reload switching status

FIGURE 7-4.1.2 MANAGEMENT SOFTWARE MENU VIEW - MATRIX
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To perform switching operations between CON and CPU Devices proceed as follows:
1. Select View > Matrix in the task area or select View > Port when using a Matrix Grid.
2. Move the mouse cursor to the port that has to be switched.
3. Hold down the primary mouse button and move the cursor to the port that has to be connected to the
initial port. The current cursor movement will be displayed by a black auxiliary line.
4. Release the primary mouse button. A popup to select the available switching type (Full Access, Video
Access or Private Mode) will be opened.
5. Select the desired switching type. The switching operation will be immediately executed. At the same
time all Ext Units that are assigned to the involved devices will be switched.

*If a port is shown with a red cross on Matrix View, the console does not have access rights to the CPU
connected to that port.

To disconnect existing connection between CON and CPU Devices proceed as follows:
1. Click with the secondary mouse button on the port that is to be disconnected.
2. Select the Disconnect function in the popup that appears.
     The connected ports will be immediately disconnected. At the same time all further connections of the
      extenders assigned to the involved devices will be disconnected.

7.4.2	 USB 2.0 SWITCHING

Switching of USB 2.0 extender basically works like switching of KVM extenders. The following scenarios to switch USB 2.0 
extenders are possible.

1. An extender unit with USB 2.0 will be created and assigned to an already existing device with existing
KVM Ext Units (see chapter 6.8.2, page 184 or chapter 6.9.3, page 197).

2. A separate device for the extender unit with USB 2.0 will be created without assigning a KVM extender
unit to that device. This possibility offers a separate switching of the USB 2.0 signal (see chapter 6.8.2,
page 184 or chapter 6.9.3, page 197). 

Switching of USB 2.0 signals uses Extended Switching functionality (see chapter 7.3.1, page 258).
When using parallel operation within the matrix, set the Release Time in the System Settings > Switch
menu to 10 s or more (see chapter 6.4.5, page 162). Otherwise, the connection of the USB 2.0 extender
will not be established due to security and stability reasons.
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7.4.3	 PREDEFINING MACROS

Predefined macros to switch the matrix without loading a new configuration can be created and activated in
this menu.

Creating a new Switch Macro

To create a new switch macro, proceed as follows:

1. Select Control > Presets in the task area.
2. Click the Activate Edit Mode menu item in the toolbar.
3. Click on the (New) symbol in the right column of the working area to open a new switch macro.
You are asked if the existing connections should be taken over for the new switch macro. 
4. Click on a device in the corresponding columns (Full Access, Video Only or Private Mode) to drop
    down the appropriate selection to set the desired switching operations or use the function for a
    disconnect (Disconnect CPU).
5. Click the (Save) symbol in the right column of the working area to save the created switch macro.
    A save dialog will appear.
6. Enter a name for the new switch macro.
7. Click the Ok button in the save dialog to confirm the new preset.
    The new switch macro is listed in the right column.
8. Click the Activate Edit Mode menu item in the toolbar.

FIGURE 7-4.3.1 MANAGEMENT SOFTWARE MENU CONTROL - PRESETS
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Copying a Switch Macro

To copy a switch macro, proceed as follows:

1. Select Control > Presets in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Click with the secondary mouse button on a selected switch macro in the right column to copy the

    current switch macro when using the Save as... option.

4. Click the Activate Edit Mode menu item in the toolbar.

Deleting a Switch Macro

To delete a switch macro, proceed as follows:

1. Select Control > Presets in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

1. Select a switch macro to be deleted.

2. Click the (Delete) symbol in the right column of the working area to delete the current switch macro

    or click with the secondary mouse button on a selected switch macro using the Delete... option.

3. Click the Activate Edit Mode menu item in the toolbar.

Loading a Switch Macro

To load a predefined switching, proceed as follows:

1. Select Control > Presets in the task area.

2. Click the Activate Edit Mode menu item in the toolbar.

3. Select the switch macro in the right column of the working area that has to be loaded.

4. Press the Send button on the bottom right of the working area to activate the selected switch macro.

5. Click the Activate Edit Mode menu item in the toolbar. 

*A predefined switch macro can only be activated in online mode.
When loading presets, only those switching operations that are compliant with the hardware and the
configuration of the currently used matrix are taken into account.

7.5	 MULTI-SCREEN CONTROL SWITCHING VIA MOUSE (PANNING)

The Multi-Screen function contains a switching of the USB-HID signal between different statically connected sources 
(computer, CPU) within a CON Device. The switching of the USB-HID signal can be made by a movement of the mouse 
pointer beyond the edge of the current display to a neighboring display.

To perform a switching operation by movement of the mouse pointer, proceed as follows:

1. Move the mouse pointer to that edge of the display which borders vertically or horizontally to the neighboring 
display.

2. Move the mouse pointer beyond the edge of the display.
    The mouse pointer will appear on the adjacent display. The switching operation has been performed
    and the USB-HID signal will be now available at the target display.

*The switching operation can also be performed via keyboard (see chapter 7.2.6, page 276).
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7.6	 QUERYING A STATUS FOR DIAGNOSIS VIA OSD

Various statuses can be queried for diagnosis:

7.6.1	 NETWORK STATUS

The current network configuration is displayed in this menu.
Select Status > Network in the main menu to query the network configuration.

7.6.2	 SNMP STATUS

FIGURE 7-6.1 OSD MENU STATUS

FIGURE 7-6.1.1 OSD MENU NETWORK
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The current SNMP status is displayed in this menu.
 Select Status > SNMP in the main menu to query the SNMP status. 

*The procedure for activating the SNMP agent or configuring an SNMP server is described in chapter 5.4.6, page 94.

7.6.3	 FIRMWARE STATUS

The current firmware status is displayed in this menu.
Select Status > Firmware in the main menu to query the firmware status.

FIGURE 7-6.2.1 OSD MENU STATUS - SNMP
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FIGURE 7-6.3.1 OSD MENU STATUS - FIRMWARE
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7.6.4	 TRACE

 
The trace function is used for diagnostic purposes. All recorded events for activities and switching
operations of the matrix are displayed in this menu.

Select Status > Trace in the main menu of the I/O board, the user’s console is connected to display the
recorded events of the selected I/O board.

The following information is shown in this menu: 

*The procedure for activating the SNMP agent or configuring an SNMP server is described in chapter 5.3.6, page 75.

FIELD DESCRIPTION

Date Date stamp

Time Time stamp

Message Detailed description of the event

FIGURE 7-6.4.1 OSD MENU STATUS -TRACE

CHAPTER 7: OPERATION



2801.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

7.6.5	 REDUNDANCY FUNCTION

 
The current firmware status is displayed in this menu.
Select Status > Firmware in the main menu to query the firmware status. 

KVM extenders with redundant connectors for interconnect cables can be simultaneously operated with
both connectors at a single Matrix or a Matrix Grid (from firmware version V04.00).

The connector labeled with Link 1 at the KVM extender is meant for the primary connection. If the
connection on CON or CPU Unit side is interrupted due to any problem, the connection will be automatically
re-established through the second connector labeled with Link 2.
For this kind of redundancy function, there is no need for any configuration of the KVM matrix or the KVM
extenders.

FIGURE 7-6.5.1 OSD MENU STATUS -SWITCH
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Select Switch in the main menu.

When using redundant KVM extenders, the respectively active connector is shown in this view under EXT
list in the field CON/CPU Data. If the first connector (Link 1) is active, it will be highlighted with :1 behind
the respective extender. If the second connector (Link 2) is active, this will be highlighted with :2.

7.7	 QUERYING A STATUS VIA MANAGEMENT SOFTWARE

7.7.1	 DEVICE STATUS
The connections to the matrix are displayed in this menu.
 Select View > Matrix in the task area to display the current connections.

NETWORK PORT COLOR DESCRIPTION

Green Port is connected

Red Port is not connected or not available

FIGURE 7-7.1.1 OSD MENU VIEW - MATRIX
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7.7.2	 NETWORK STATUS

 
The current network configuration is displayed in this menu.
Select System Settings > Network in the task area to query the network configuration.

FIGURE 7-7.2.1 MANAGEMENT SOFTWARE MENU SYSTEM SETTINGS - NETWORK - GENERAL
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7.7.3	 MATRIX FIRMWARE STATUS
The firmware status of the extenders is displayed in this menu.
Select Status & Updates > Status - Matrix Firmware in the task area to query the current firmware
status of the extenders.

COLUMN DESCRIPTION

Slot Slot number of the I/O module or CPU module

Name
• Name of the I/O module or CPU module

• Name of the I/O module firmware or CPU module firmware

Type Firmware type

Port Number of ports

Serial Number Serial number of the I/O module or CPU module

Version Installed firmware version

Status Status of the I/O module or CPU module

FIGURE 7-7.3.1 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - STATUS - MATRIX FIRMWARE
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The different modules can be expanded and collapsed by left-clicking on the “plus” and “minus” symbols in
the Name column.
By clicking on the “plus” and “minus” symbol in the upper right corner of the working area, you can expand
and collapse all module information with a click of the primary mouse button.

7.7.4	 EXTENDER FIRMWARE STATUS
The firmware status of the extenders is displayed in this menu.
     Select Status & Updates > Status - Extender Firmware in the task area to query the current firmware
     status of the extenders.

	

COLUMN DESCRIPTION

ID Ident number of the extender

Name Name of the extender and the extender firmware

Port Number of ports

Type Extender type

Device Device to which the extender is assigned

Version Installed firmware version

FIGURE 7-7.4.1 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - STATUS EXTENDER FIRMWARE - FIRMWARE
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Firmware types to be updated or firmware conflicts are highlighted in color:
Extender firmware version conflict
Manual update of EXTMSD / EXTIMSD recommended
Wrong module (CPU/CON mismatch)
Undefined type

The different modules can be expanded and collapsed by left-clicking on the “plus” and “minus” symbols in the Name 
column. By clicking on the “plus” and “minus” symbol in the upper right corner of the working
area, you can expand and collapse all module information with a click of the primary mouse button.

7.7.5	 EXTENDER FIRMWARE STATUS ON I/O BOARD

The extender firmware status of the I/O boards is displayed in this menu.
1. Select Status & Updates > Status - Extender Firmware in the task area to query the current firmware
    status of the extenders.
2. Select the Extender Firmware Status on I&O Board tab in the working area.

The following information is displayed in the working area:

FIGURE 7-7.5.1 MANAGEMENT SOFTWARE MENU STATUS & UPDATES - STATUS MATRIX FIRMWARE  
- EXTENDER FIRMWARE ON IO BOARD
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The different modules can be expanded and collapsed by left-clicking on the “plus” and “minus” symbols in
the Name column.
By clicking on the “plus” and “minus” symbol in the upper right corner of the working area, you can expand
and collapse all module information with a click of the primary mouse button.

7.7.6	 SYSLOG MONITORING

The syslog function offers a complete logging of the matrix activities and switching operations in this menu.
During logging the activities are written continuously into log files and stored locally. 

The procedure for activating the syslog function is described in chapter 6.4.7, page 165.

COLUMN DESCRIPTION

Slot Ident number of the extender

Name Name of the extender and the extender firmware

Type Extender type

Mem Usage / Version • Free memory on the I/O module (in MB)
• Firmware version of the I/O module

NOTICE

Syslog messages are transmitted via UDP. Therefore, port 514 within the used network should not be
blocked, e.g., by a firewall.
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To open the  monitoring, proceed as follows:
Click the Monitoring menu item in the toolbar.
The logged syslog messages are displayed in the working area.

Filter function
To filter relevant messages from the multitude of logged activities of the SNMP module, the extenders and
the chassis, the syslog monitoring offers various filter options.
To set and activate a filter, proceed as follows:

1. Activate the respective checkbox(es) to activate the desired filter option(s).
2. Click the Filter button to activate the filter settings.
3. Click the Clear button to deactivate an activated filter setting.

The following filter options are available:

FIGURE 7-7.5.2 MANAGEMENT SOFTWARE MENU MONITORING 
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Filter options are not valid within the locally stored log files. 

Recording function
Various options are available for the messages displayed in the SNMP log.
To save the displayed messages (filtered or unfiltered), click the Save trace button.
The messages are saved in a SNMP file (extension .csv).

To clear the view with the displayed messages, click the Clear trace button.
The recorded messages will be kept.

To pause the display of messages, click the Pause button.
During the pause, the messages will be recorded continuously.

To display the messages recorded in the background during the pause, click the Pause button again.
 All messages recorded in the background will be displayed immediately.

OPTION DESCRIPTION

Date Messages for a defined date range will be filtered

Facility Messages for a defined facility will be filtered

Severity Messages for a defined severity will be filtered

Host Messages for a defined host will be filtered

Message Messages with defined text parts will be filtered
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Search function
The search function can be used to search for specific Syslog messages from a variety of logged activities
and relevant messages from the SNMP module, extenders, and chassis. 

To find specific syslog messages, proceed as follows:
1. Click the monitoring menu item in the toolbar.
2. Click the Find tab in the working area.
     The recorded SNMP messages are displayed in the working area.
3. Enter a search term in the Find Message search field.
4. Click the Find Next button.
     The first message with the entered search term is highlighted.
5. Click the Find Next button again to find another message with this search term.
     The next message with the entered search term is highlighted.

Possible search terms would be, e.g., the port ID (e.g., MOD=10), the firmware (e.g., EXTCON), link status
(e.g., link).
To go back to the previous search result, click the Find Previous button.

FIGURE 7-7.5.3 MANAGEMENT SOFTWARE MENU MONITORING - SYSLOG - EXAMPLE FOR SEARCH RESULT
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Filter function
To filter relevant messages from the multitude of logged activities of the SNMP module, the extenders and
the chassis, the SNMP monitoring offers various filter options.

To set and activate a filter, proceed as follows:
1. Activate the respective checkbox(es) to activate the desired filter option(s).
2. Click the Filter button to activate the filter settings.
3. Click the Clear button to deactivate an activated filter setting.

The following filter options are available: 

*Filter options are not valid within the locally stored log files. 

Recording function
Various options are available for the messages displayed in the SNMP log.
To save the displayed messages (filtered or unfiltered), click the Save trace button.
The messages are saved in a SNMP file (extension .csv).

To clear the view with the displayed messages, click the Clear trace button.
The recorded messages will be kept.

To pause the display of messages, click the Pause button.
During the pause, the messages will be recorded continuously.

To display the messages recorded in the background during the pause, click the Pause button again.
 All messages recorded in the background will be displayed immediately.

OPTION DESCRIPTION

Date Messages for a defined date range will be filtered

Facility Messages for a defined facility will be filtered

Severity Messages for a defined severity will be filtered

Host Messages for a defined host will be filtered

Message Messages with defined text parts will be filtered
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7.7.7	 SNMP MONITORING

The SNMP function allows all function-critical and safety-critical elements of the SNMP module, the
extenders, and the chassis to be monitored and queried. This function complies with the RFC 1157
conformal standard. 

The procedure for activating the SNMP agent or configuring an SNMP server is described in chapter 6.4.7,
page 143.

To open the SNMP monitoring, proceed as follows:
1. Click the Monitoring menu item in the toolbar.
2. Click the SNMP button in the task area.
The logged SNMP messages are displayed in the working area.

FIGURE 7-7.7.1 MANAGEMENT SOFTWARE MENU MONITORING SNMP
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Filter function
To filter relevant messages from the multitude of logged activities of the SNMP module, the extenders and
the chassis, the SNMP monitoring offers various filter options.

To set and activate a filter, proceed as follows:
1. Activate the respective checkbox(es) to activate the desired filter option(s).
2. Click the Filter button to activate the filter settings.
3. Click the Clear button to deactivate an activated filter setting.

The following filter options are available: 

*Filter options are not valid within the locally stored log files. 

Recording function
Various options are available for the messages displayed in the SNMP log.
To save the displayed messages (filtered or unfiltered), click the Save trace button.
The messages are saved in a SNMP file (extension .csv).

To clear the view with the displayed messages, click the Clear trace button.
The recorded messages will be kept.

To pause the display of messages, click the Pause button.
During the pause, the messages will be recorded continuously.

To display the messages recorded in the background during the pause, click the Pause button again.
 All messages recorded in the background will be displayed immediately.

OPTION DESCRIPTION

Date Messages for a defined date range will be filtered

Facility Messages for a defined facility will be filtered

Severity Messages for a defined severity will be filtered

Host Messages for a defined host will be filtered

Message Messages with defined text parts will be filtered
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Search function
The search function can be used to search for specific SNMP messages from a variety of logged activities
and relevant messages from the SNMP module, extenders, and chassis. 

To find specific syslog messages, proceed as follows:
1. Click the monitoring menu item in the toolbar.
2. Click the Find tab in the working area.
     The recorded SNMP messages are displayed in the working area.
3. Enter a search term in the Find Message search field.
4. Click the Find Next button.
    The first message with the entered search term is highlighted.
5. Click the Find Next button again to find another message with this search term.
    The next message with the entered search term is highlighted. 

*Possible search terms would be, e.g., temperature, fan, or the serial number of an extender (e.g., 40131237).
To go back to the previous search result, click the Find Previous button.

FIGURE 7-7.7.2 MANAGEMENT SOFTWARE MENU MONITORING SNMP 
EXAMPLE FOR SEARCH RESULT
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7.7.8	 REDUNDANCY FUNCTION

KVM extenders with redundant connectors for interconnect cables can be simultaneously operated with
both connectors at a single Matrix or a Matrix Grid (from firmware version V04.00).

The connector labeled with Link 1 at the KVM extender is meant for the primary connection. If the
connection on CON or CPU Unit side is interrupted due to any problem, the connection will be automatically
re-established through the second connector labeled with Link 2.

For this kind of redundancy function, there is no need for any configuration of the KVM matrix or the KVM
extenders.

To check the connection status of the redundant KVM extenders, proceed as follows:
1. Select View > Matrix in the task area.
2. Activate the checkbox Show Redundant Links (L1/L2) under Routing Information on the right side of
     the working area.
3. Open the menu Redundancy on the right side of the working area to receive the respective legend
     information.
4. Redundant connectors are highlighted in the matrix view with L1 and L2. The respectively active link is
     highlighted with a light green label.

FIGURE 7-7.8.1 MANAGEMENT SOFTWARE VIEW - MATRIX
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7.7.9	 SYSTEM CHECK

Users have access to a diagnostic function through system check for checking the device configuration. The feature indi-
cates non-optimal as well as incorrect settings and displays issues instructions. The system check is only used to
check plausibility and does not make any active configuration changes.

The following configuration parts are checked:

• Matrix Firmware

• Extender Firmware

• Multi-Screen Control

• Ext Units

• CPU Devices

• CON Devices

• Users

• Macros

• System Configuration

• Matrix Grid

The following notification levels can be shown: 

LEVEL DESCRIPTION

OK (green) System checks completed without any abnormalities.

WARNING (yellow)
System checks revealed abnormalities in the configuration that point to

incomplete parts of the configuration, firmware differences, duplications, or
unconnected extenders, but without being system critical.

ERROR (red)
System checks revealed errors in the configuration that can have both functional

and system critical influences on the system.

NOTICE

If the messages “WARNING” or “ERROR” are generated by the system check function, the respective
problem will be described, and an issue instruction will be provided.

NOTICE

The system check of the matrix may take several minutes, and the matrix is not available during this time.
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To start the system check, proceed as follows:

1. Click the menu item System Check in the tool bar.

A query appears to check the system.

2. Click the Yes button to start the system check.

A report is displayed after the system check.

FIGURE 7-7.9.1 MANAGEMENT SOFTWARE DIALOG - VALIDATE SYSTEM

FIGURE 7-7.9.2 MANAGEMENT SOFTWARE REPORT SYSTEM CHECK
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7.7.10	 NETWORK CHECK

The network check checks the firewall settings for the ports available in the network. 

To start the network check, proceed as follows:

1. Select Extras > Network Check in the menu bar.

A query appears with an input field for the IP address of the SNMP module to be queried.

2. Enter the IP address of the SNMP module.

3. Click the Start network check button to start the network check.

The availability of the ports is shown after a short moment.

NOTICE

Available ports are shown in green. If a port is not available, the corresponding entry appears in red and
instructions are displayed.

FIGURE 7-7.10.1 MANAGEMENT SOFTWARE REPORT NETWORK CHECK - AVAILABLE PORTS
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7.8	 SAVING A STATUS VIA MANAGEMENT SOFTWARE

1. Click the Save Status menu item in the toolbar to read out the overall status of the device and store it
    locally (file extension .zip).
    A dialog appears.
2. Choose the status option.
3. Click the Next button.

4. Navigate to the directory you want to save the status file.
5. Click the Next button. 
6. Click the Anonymize checkbox to anonymize your personal data when saving the status file if
necessary (not recommended for trouble shooting).
If you want to use the status file as a backup, do not click the Anonymize checkbox.
7. Click the Next button.

FIGURE 7-8.1.1 MANAGEMENT SOFTWARE MENU SAVE STATUS - SAVING OPTIONS

CHAPTER 7: OPERATION



299 1.877.877.2269 BLACKBOX.COM

NEED HELP?
LEAVE THE TECH TO US

LIVE 24/7
TECHNICAL
SUPPORT
1.877.877.2269

8. Click the Save EXT Units Settings checkbox to save your extender settings.

9. Click the Next button.

FIGURE 7-8.1.2 MANAGEMENT SOFTWARE MENU SAVE STATUS - ANONYMIZATION

FIGURE 7-8.1.3 MANAGEMENT SOFTWARE MENU SAVE STATUS - SAVE EXT UNIT SETTINGS
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10. Wait until all steps show green checkmarks and the “Saving status successful” message is
displayed.
11. Click the Finish button to finish the saving.

7.9	 OPENING A LOCALLY SAVED STATUS VIA MANAGEMENT SOFTWARE

To load a locally saved status, proceed as follows:
1. Select Device > Load Status... in the menu bar.
2. Navigate to the storage location of the status file to be opened.
3. Click the status file to be opened.
4. Click the Open button to open the status file.

FIGURE 7-8.1.4 MANAGEMENT SOFTWARE MENU SAVE STATUS - SAVE STATUS
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The status can also be opened via drag & drop. To do so, open the file browser, navigate to the storage
location of the status file, click on the status file, hold down the primary mouse button and drag and drop
the status file into the management software.

7.10	 RESTARTING, RESETTING, AND POWERING DOWN FUNCTIONS VIA OSD

7.10.1	 RESTARTING THE MATRIX

To perform a restart of the matrix, proceed as follows:

Select Configuration > Restart Matrix in the main menu.

The current configuration is saved in the permanent memory of the matrix and matrix will be restarted

with the current configuration.. 

FIGURE 7-9.1.1 MANAGEMENT SOFTWARE MENU DEVICE - LOAD STATUS

FIGURE 7-10.1.1 OSD MENU CONFIGURATION - RESTART MATRIX
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7.10.2	 RESTARTING THE I/O BOARD

To perform a restart of the I/O board, the user’s console is connected, proceed as follows:

Select Configuration > Restart IO Board in the main menu.

The I/O board will be restarted. 

*To restart I/O boards with CPU extenders, use the restart option of the management software (see

chapter 7.10.3, page 295)

7.10.3	 RESTARTING THE CPU BOARD

To perform a restart of the CPU board, proceed as follows:

Select Configuration > Restart CPU Board in the main menu.

The current configuration of the CPU board is saved in the permanent memory of the matrix and the

CPU boards will be restarted with the current configuration.

FIGURE 7-10.2.1 OSD MENU CONFIGURATION - RESTART I/O BOARD
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7.10.4	 RESTARTING THE MATRIX

To perform a restart of the CPU board, proceed as follows:

Select Configuration > Restart CPU Board in the main menu.

The current configuration of the CPU board is saved in the permanent memory of the matrix and the

CPU boards will be restarted with the current configuration. 

7.10.5	 RESETTING THE MATRIX TO THE FACTORY SETTINGS

If a firmware update has been installed since the delivery, the matrix will be set to the state defined there

7.10.6	 POWERING DOWN THE MATRIX

To shut down the system, proceed as follows:
1. Select Configuration > Shut down Matrix in the main menu.
2. Click the Okay button to confirm the selection.
     The current configuration of the matrix is saved in the permanent memory of the matrix and the matrix
     will be shut down.

*The fans will be switched to maximum speed after the shutdown. Then the matrix can be disconnected from

the power supply.

NOTICE

If you perform a (factory) reset, all current settings and all configurations stored in the matrix will be lost.
This also applies to the network parameters (reset to default IP-address) and the admin password.

FIGURE 7-10.4.1 OSD MENU CONFIGURATION -RESTARTING CPU BOARD
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7.10.7	 POWERING DOWN THE I/O BOARD

To shut down the I/O board, proceed as follows:

1. Select Configuration > Shut down IO Board in the main menu.

2. Click the Okay button to confirm the selection.

The current configuration of the I/O boards is saved in the permanent memory of the matrix and the I/O board will be shut 

down.

FIGURE 7-10.6.1 OSD MENU FACTORY RESET

FIGURE 7-10.7.1 OSD MENU CONFIGURATION - SHUT DOWN MATRIX
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7.11	 RESTARTING, RESETTING, AND POWERING DOWN FUNCTIONS VIA MANAGEMENT 
SOFTWARE

7.11.1	 RESTARTING THE MATRIX

To perform a restart of the matrix, proceed as follows:
1. Select Device > Advanced Service > Restart Device in the menu bar.
An access window appears.
2. Enter the username and password of the administrator.
3. Click the Ok button.

A query to restart the matrix appears.
4. Click the Yes button to restart the matrix.

The current configuration is saved in the permanent memory of the matrix and the matrix will be

restarted.

NOTICE

When restarting the matrix, the current configuration is saved in the permanent memory of the matrix and
the matrix will be restarted with the active configuration.

FIGURE 7-11.1.1 MANAGEMENT SOFTWARE DIALOG LOG IN ADMINISTRATOR

FIGURE 7-11.1.2 MANAGEMENT SOFTWARE DIALOG RESTART MATRIX
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7.11.2	 RESTARTING THE CPU BOARD

To perform a restart of the CPU board, proceed as follows:

1. Select View > Matrix in the task area.

2. Click with the secondary mouse button on the symbol of a network port of the CPU board to be

    restarted.

A context menu appears.

3. Select the Restart CPU Board function in the context menu.

    Note: The CPU board will be restarted immediately without user confirmation. The symbols of the

    network ports are red for a short time in the overview. When the symbols of the network ports are green

    again, the restart of the CPU board was successful.

FIGURE 7-11.2.1 MANAGEMENT SOFTWARE VIEW - MATRIX - RESTART I/O BOARD
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7.11.3	 RESTARTING AN I/O BOARD

To perform a restart of the I/O board, proceed as follows:
1. Select View > Matrix in the task area.
2. Click with the secondary mouse button on the symbol of the extender of the I/O board to be restarted.
    A context menu appears.
3. Select the Restart I/O Board function in the context menu.
    Note: The I/O board will be restarted immediately without user confirmation. The I/O board will
    disappear for a short time in the overview. When the I/O board is visible again, the restart of the I/O
    board was successful.

FIGURE 7-11.3.1 MANAGEMENT SOFTWARE VIEW - MATRIX - RESTART I/O BOARD
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7.11.4	 RESTARTING AN EXTENDER MODULE

To perform a restart of an extender module, proceed as follows:

1. Select View > Matrix in the task area.

2. Click with the secondary mouse button on the symbol of the extender to be restarted.

     A context menu appears.

3. Select the Restart Extender function in the context menu.

    Note: The extender module will be restarted immediately without user confirmation. The extender

    symbol will disappear for a short time in the overview. When the symbol is visible again, the restart of

    the extender module was successful.

FIGURE 7-11.4.1 MANAGEMENT SOFTWARE VIEW - MATRIX - RESTART EXTENDER
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7.11.5	 POWERING DOWN THE MATRIX

To shut down the matrix, proceed as follows:
1. Select Device > Advanced Service > Shut down Matrix in the menu bar.
An access window appears.
2. Enter the username and password of the administrator.
3. Click the Ok button. 

A query to shut down the matrix appears.
4. Click the Yes button to start the shutdown.

NOTICE

When restarting the matrix, the current configuration is saved in the permanent memory of the matrix and
the matrix will be restarted with the active configuration.

FIGURE 7-11.5.1 MANAGEMENT SOFTWARE DIALOG LOG IN ADMINISTRATOR

FIGURE 7-11.5.2 MANAGEMENT SOFTWARE DIALOG LOG SHUT DOWN MATRIX
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The current configuration is saved in the permanent memory of the matrix and the matrix will be shut

down.

After shutting down, a notification to power off the matrix appears. 

7.11.6	 RESETTING THE MATRIX TO THE FACTORY SETTINGS

*If a firmware update has been installed since the delivery, the matrix will be set to the state defined there. 

To perform a reset of the matrix, proceed as follows:

1. Select Device > Advanced Service > Factory Reset > Factory Reset in the menu bar.

An access window appears.

2. Enter the username and password of the administrator.

3. Click the Ok button to confirm your entries.

NOTICE

If you perform a (factory) reset, all current settings and all configurations stored in the matrix will be lost.
This also applies to the network parameters (reset to default IP-address) and the admin password.

FIGURE 7-11.5.3 MANAGEMENT SOFTWARE DIALOG LOG SWITCH OFF MATRIX

FIGURE 7-11.6.1 MANAGEMENT SOFTWARE DIALOG LOG IN ADMINSTRATOR
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A query to reset the matrix appears.
4. Click the Yes button to reset the device.

The matrix is reset to factory settings.

FIGURE 7-11.6.2 MANAGEMENT SOFTWARE DIALOG FACTORY RESET
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7.11.7	 RESETTING AN I/O BOARD TO THE FACTORY SETTINGS

If a firmware update has been installed since the delivery, the I/O boards will be set to the state defined
there. 

To perform a reset of an I/O board, proceed as follows:
1. Select View > Matrix in the task area.
2. Click with the secondary mouse button on the symbol of an extender of the I/O board to be reset.
A context menu appears.
3. Select the Factory Reset I/O Board function in the context menu.
Note: The I/O board will be restarted immediately without user confirmation. The I/O board will
disappear for a short time in the overview. When the I/O board and the extenders are visible again, the
reset of the I/O board was successful.

 

NOTICE

If you perform a (factory) reset, all current settings and all configurations of the I/O board will be lost.

FIGURE 7-11.7.1 MANAGEMENT SOFTWARE VIEW - MATRIX - CONTEXT VIEW
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7.12	 SUMMARY OF KEYBOARD COMMANDS

In the following you find a summary of keyboard commands that can activate extender and matrix functions
after executing the Hot Key.

Extender

Matrix

BUTTON DESCRIPTION

<Hot Key>, <a> Download of DDC information for the monitor connected to the CON Unit into
the CPU Unit

<Hot Key>, <k>, <1>,
<Enter>

Switch to the KVM connection 1 (only with HDMI CON Units with available
connection for a local source)

<Hot Key>, <k>, <2>,
<Enter>

Switch to the KVM connection 2 (only with HDMI CON Units with available
connection for a local source and a redundant interconnection)

<Hot Key>, <l>,
<Enter>

Switch to local source (computer, CPU) (only with HDMI CON Units with
available connection for a local source)

<Hot Key>, <h>, <w>,
<Enter>

USB-HID Ghosting: Write device descriptions of the input devices connected to
the CON Unit into the CPU Unit. Activate the emulation in the CPU Unit.

<Hot Key>, <h>, <e>,
<Enter> Activate the emulation of already stored device descriptions in the CPU Unit

<Hot Key>, <h>, <d>,
<Enter>

Deactivate the emulation of active device descriptions in the CPU Unit. The
input devices connected to the CON Unit will be passed transparently to the

source (computer, CPU).

<Hot Key>, <h>, <r>,
<Enter>

Deactivate the emulation of active device descriptions in the CPU Unit. Delete
the descriptions out of the CPU Unit. The input devices connected to the

CON Unit will be passed transparently to the source (computer, CPU).

<Hot Key>, <d>, <1>,
<Enter> Switch to video channel 1 of the Dual-Head CPU Unit (482 series only)

<Hot Key>, <d>, <2>,
<Enter> Switch to video channel 2 of the Dual-Head CPU Unit (482 series only)

BUTTON DESCRIPTION

<Hot Key>, <o> Open OSD

<Hot Key>, <s>, <o> Open OSD of the sub matrix in a cascaded environment

<Hot Key>,
<Backspace> Close the current connection of the own console

<Hot Key>, <p> Switch back to the previous connected source (computer, CPU) with a KVM
connection)

<Hot Key>, <1> ...
<16>, <Enter>

(<Space> or <Left
Shift> + <Enter>)

Switch to a source (computer, CPU) stored in the favorite list with a KVM
connection (Video Only or Private Mode connection)
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CHAPTER 8: 

8.1	 INTERFACES

8.1.1	 RJ45 (NETWORK)

The network communication of the devices requires a 100BASE-T connection.
The cabling has to be done according to EIA/TIA-568-B (100BASE-T) with RJ45 connectors at both ends.
All four wire pairs are used in both directions. The cabling is suitable for a full duplex operation. For the
cable connection to a source (computer, CPU), a crossed network cable (cross cable) has to be used.

8.1.2	 8.1.2 RJ45 (INTERCONNECT)

The communication between Cat X devices requires a 1000BASE-T connection.
Connector wiring must comply with EIA/TIA-568-B (1000BASE-T), with RJ45 connectors at both ends. All
four cable wire pairs are used.

BUTTON DESCRIPTION

<Hot Key>, <F1> ...
<F16> Open OSD

<Hot Key>, <Left 
Shift>

+ <F17> ... <F32>
Open OSD of the sub matrix in a cascaded environment

<Hot Key>, <c>, 
<new

Hot Key Code>,
<Enter>

Close the current connection of the own console

<Hot Key>, <c>, <0>,
<new Hot Key>,

<Enter>
Switch back to the previous connected source (computer, CPU) with a KVM

connection)

<<Hot Key>, <f>, 
<new

Hot Key Code>,
<Enter>)

Switch to a source (computer, CPU) stored in the favorite list with a KVM
connection (Video Only or Private Mode connection)

<Hot Key>, <f>, <0>,
<new Hot Key key>,

<Enter>
Define freely selectable Hot Key for direct OSD access

<Hot Key>, <Num 0> Switch the USB-HID signal to the user’s display (CON Unit with keyboard and
mouse)

<Hot Key>, <Num 1> Switching of the USB-HID signals to display #1

<Hot Key>, <Num 2> Switching of the USB-HID signals to display #2

<Hot Key>, <Num 3> Switching of the USB-HID signals to display #3

<Hot Key>, <Num 4> Switching of the USB-HID signals to display #4
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8.1.3	 FIBER SFP TYPE LC (INTERCONNECT)
The communication of fiber devices is performed via Gigabit SFPs that are connected to suitable fibers
fitted with connectors type LC.

8.2	 INTERCONNECT CABLE

8.2.1	 CAT X

NOTICE

If you perform a (factory) reset, all current settings and all configurations of the I/O board will be lost.

NOTICE

SFP modules can be damaged by electrostatic discharge (ESD).
 � Please consider ESD handling specifications.

NOTICE

Transmission problems
Routing over an active network component, such as an Ethernet Hub, Router or Matrix, is not allowed.

Operation with several patch fields is possible.
Establish a point-to-point connection.

Avoid routing Cat X cables along power cables.

NOTICE

Exceeding the limit of the device class
The use of unshielded Cat X cables with higher electromagnetic emissions / radiation can exceed the limit

values for the specified device class.
Correctly install shielded Cat X cable throughout interconnection, to maintain regulatory EMC

compliance.

NOTICE

Exceeding limit values for electromagnetic radiation
The limit values for the electromagnetic radiation of the device are complied with if ferrites are mounted

on both sides of all Cat X cables near the device. With installed ferrites, the devices meet the EU
guidelines for electromagnetic compatibility. The operation of the devices without mounted ferrites leads

to a loss of conformity with the EU directives.
 Mount ferrites on both sides of all Cat X cables near the device to maintain regulatory EMC

compliance.
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Type of Interconnect Cable
The KVM-Extender requires interconnect cabling specified for Gigabit Ethernet (1000BASE-T). The use of
solid core (AWG24), shielded, Cat 5e (or better) is recommended.

*The use of flexible cables (patch cables) type AWG26/8 is possible; however, the maximum possible
extension distance is halved.

Maximum acceptable cable length

8.2.2	 FIBER

FIGURE 2-14. BACK PANEL

TYPE OF CABLE SPECIFICATION

Cat X installation 
cable

AWG24
S/UTP (Cat 5e) cable according to EIA/TIA-568-B. Four pairs of wires AWG24.

Connection according to EIA/TIA-568-B (1000BASE-T).

Cat X patch cable
AWG26/8

S/UTP (Cat 5e) cable according to EIA/TIA-568-B. Four pairs of wires AWG26/8.
Connection according to EIA/TIA-568-B (1000BASE-T).

TYPE OF CABLE SPECIFICATION

Cat X installation 
cable

AWG24
140 m (460 ft)

Cat X patch cable
AWG26/8 70 m (230 ft)

NOTICE

Transmission problems
Routing over an active network component, such as an Ethernet Hub, Router or Matrix, is not allowed.

Operation with several patch fields is possible.
 Establish a point-to-point connection.

Avoid routing Cat X cables along power cables.
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NOTICE

Transmission problems
Routing over an active network component, such as an Ethernet Hub, Router or Matrix, is not allowed.

Operation with several patch fields is possible.
 Establish a point-to-point connection.

 Avoid routing Cat X cables along power cables.

Type of Interconnect Cable*

Maximum acceptable cable length

*Using single-mode SFPs with multi-mode fibers, the ranges can be increased. 

Maximum acceptable cable length

TYPE OF CABLE SPECIFICATION

Single-mode 9 μm

• Two fibers 9 μm
• I-V(ZN)H 2E9 (in-house patch cable)

• I-V(ZN)HH 2E9 (in-house breakout cable)
• I/AD(ZN)H 4E9 (in-house or outdoor breakout cable, resistant)

• A/DQ(ZN)B2Y 4G9 (outdoor cable, with protection against rodents)

Multi-mode 50 μm
• Two fibers 50 μm

• I-V(ZN)H 2G50 (in-house patch cable)
• I/AD(ZN)H 4G50 (in-house or outdoor breakout cable, resistant)

* Cable notations according to VDE

TYPE OF CABLE SPECIFICATION

Single-mode 9 μm 10,000 m (32,808 ft)

Single-mode 9 μm 
XV 5,000 m (16,404 ft)

Multi-mode 50 μm 
(OM3) 1,000 m (3,280 ft)

Multi-mode 50 μm 400 m (1,312 ft)

CONNECTOR TYPE

Plug-in connector LC-Connector
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8.3	 CONNECTOR PINOUTS

8.3.1	 RJ45 (NETWORK)

8.3.2	 RJ45 (INTERCONNECT)

 

8.3.3	 FIBER SFP TYPE LC
 

TYPE OF 
CABLE

SIGNAL PIN SIGNAL

1 D1+ 5 Not connected

2 D1- 6 D2-

3 D2+ 7 Not connected

4 Not connected 8 Not connected

CONNECTOR TYPE OF 
CABLE

SIGNAL

1 Data OUT

2 Data IN

TYPE OF 
CABLE

SIGNAL PIN SIGNAL

1 D1+ 5 D3-

2 D1- 6 D2-

3 D2+ 7 D4+

4 D3+ 8 D4-
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8.4	 POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION

8.4.1	  POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION FLEX CAT X 1G
 

8.4.2	 POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION CAT X 3G
 
 
 
 
 
 
 
 
 
 
 
 
 
 

PRODUCT TYPE MAX CURRENT MAX VOLTAGE (AC) FREQUENCY POWER CONSUMPTION

ACXC16F-1G 3,918 mA 100 to 240 V 50/60 Hz 53.7 W

ACXC24F-1G 5,057 mA 100 to 240 V 50/60 Hz 69.3 W

ACXC32F-1G 6,196 mA 100 to 240 V 50/60 Hz 85.0 W

ACXC40F-1G 7,334 mA 100 to 240 V 50/60 Hz 100.6 W

ACXC48F-1G 9,600 mA 100 to 240 V 50/60 Hz 126.6 W

ACXC64F-1G 11,933 mA 100 to 240 V 50/60 Hz 157.4 W

ACXC80F-1G 14,267 mA 100 to 240 V 50/60 Hz 188.1 W

ACXC120F-1G 21,900 mA 100 to 240 V 50/60 Hz 279.6 W

ACXC128F-1G 23,067 mA 100 to 240 V 50/60 Hz 294.5 W

ACXC144F-1G 25,400 mA 100 to 240 V 50/60 Hz 324.3 W

ACXC160F-1G 27,733 mA 100 to 240 V 50/60 Hz 354.0 W

PRODUCT TYPE MAX CURRENT MAX VOLTAGE (AC) FREQUENCY POWER CONSUMPTION

ACXC16F-1G 5,318 mA 100 to 240 V 50/60 Hz 72.9 W

ACXC24F-1G 7,157 mA 100 to 240 V 50/60 Hz 98.1 W

ACXC32F-1G 8,996 mA 100 to 240 V 50/60 Hz 123.4 W

ACXC40F-1G 10,834 mA 100 to 240 V 50/60 Hz 148.6 W

ACXC48F-1G 13,800 mA 100 to 240 V 50/60 Hz 182.0 W

ACXC64F-1G 17,533 mA 100 to 240 V 50/60 Hz 231.2 W

ACXC80F-1G 21,267 mA 100 to 240 V 50/60 Hz 280.4 W

ACXC120F-1G 32,400 mA 100 to 240 V 50/60 Hz 413.6 W

ACXC128F-1G 34,267 mA 100 to 240 V 50/60 Hz 437.4 W

ACXC144F-1G 38,000 mA 100 to 240 V 50/60 Hz 485.1 W

ACXC160F-1G 41,733 mA 100 to 240 V 50/60 Hz 532.8 W
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8.5	 CONNECTOR PINOUTS

8.5.1	 POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION FIBER 1G & 3G

8.5.2	 POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION HYBRID 1G

FIGURE 2-14. BACK PANEL

PRODUCT TYPE MAX CURRENT MAX VOLTAGE (AC) FREQUENCY POWER CONSUMPTION

ACXC16F-1G/3G 3,918 mA 100 to 240 V 50/60 Hz 53.7 W

ACXC24F-1G/3G 5,057 mA 100 to 240 V 50/60 Hz 69.3 W

ACXC32F-1G/3G 6,196 mA 100 to 240 V 50/60 Hz 85.0 W

ACXC40F-1G/3G 7,334 mA 100 to 240 V 50/60 Hz 100.6 W

ACXC48F-1G/3G 9,600 mA 100 to 240 V 50/60 Hz 126.6 W

ACXC64F-1G/3G 11,933 mA 100 to 240 V 50/60 Hz 157.4 W

ACXC80F-1G/3G 14,267 mA 100 to 240 V 50/60 Hz 188.1 W

ACXC120F-1G/3G 21,900 mA 100 to 240 V 50/60 Hz 279.6 W

ACXC128F-1G/3G 23,067 mA 100 to 240 V 50/60 Hz 294.5 W

ACXC144F-1G/3G 25,400 mA 100 to 240 V 50/60 Hz 324.3 W

ACXC160F-1G/3G 27,733 mA 100 to 240 V 50/60 Hz 354.0 W

PRODUCT TYPE MAX CURRENT MAX VOLTAGE (AC) FREQUENCY POWER CONSUMPTION

ACXC24FH16-1G 7,334 mA 100 to 240 V 50/60 Hz 100.6 W

ACXC24FH40-1G 11,933 mA 100 to 240 V 50/60 Hz 157.4 W

ACXC40FH24-1G 11,933 mA 100 to 240 V 50/60 Hz 157.4 W

ACXC40FH40-1G 14,267 mA 100 to 240 V 50/60 Hz 188.1 W

ACXC80FH40-1G 21,900 mA 100 to 240 V 50/60 Hz 279.6 W

ACXC80FH80-1G 27,733 mA 100 to 240 V 50/60 Hz 354.0 W

ACXC120FH40-1G 27,733 mA 100 to 240 V 50/60 Hz 354.0 W
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8.5.3	 POWER SUPPLY, CURRENT DRAW AND POWER CONSUMPTION HYBRID 3G
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8.6	 OPEN_ENVIRONMENTAL CONDITIONS AND EMISSIONS

PRODUCT TYPE MAX CURRENT MAX VOLTAGE (AC) FREQUENCY POWER CONSUMPTION

ACXC40-1G-2RU 9,434 mA 100 to 240 V 50/60 Hz 53.7 W

ACXC40-1G-4RU 14,033 mA 100 to 240 V 50/60 Hz 69.3 W

ACXC40F-1G-2RU 17,433 mA 100 to 240 V 50/60 Hz 85.0 W

ACXC40F-1G-4RU 17,7677 mA 100 to 240 V 50/60 Hz 100.6 W

ACXC24F16-1G-2RU 28,067 mA 100 to 240 V 50/60 Hz 126.6 W

ACXC24F16-1G-4RU 33,067 mA 100 to 240 V 50/60 Hz 157.4 W

PARAMETER VALUE

Operating Temperature 5 to 45 °C (41 to 113 °F)

Storage Temperature -25 to 60 °C (-13 to 140 °F)

Relative Humidity Max. 80% non-condensing

Operating Altitude Max. 2.500 m (7,500 ft)

Heat Dissipation Corresponds to power consumption in Watt (W)
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8.7	 DIMENSIONS

8.8	 8.7 OPEN_WEIGHT

8.9	 8.8 MTBF

The following table contains the mean time between failure (MTBF) in power-on hours (POH). The estimate
is based on the FIT rates of the parts included. FIT rates are based on normalized environmental conditions
of T = 60°C and activation energy (Ea) of 0.7 eV. Calculations are based on 90% confidence limit.
We estimate that inside the housing, temperature will be 15°C higher than the ambient temperature.
Therefore, the MTBF calculation refers to an ambient temperature of 45°C. The humidity is limited to 60%.

Under these standard conditions, the MTBF for the components of the DKM flex KVM matrices are
estimated as follows:

PRODUCT/ PACKAGING DIMENSION DIMENSION INCL. SHIPPING BOX

DKM flex 1RU
chassis

442 x 449 x 44 mm
(17.4” x 17.7” x 1.7”)

602 x 526 x 154 mm
(23.7” x 20.7” x 6.1”)

DKM flex 2RU
chassis

442 x 449 x 90 mm
(17.4” x 17.7” x 3.5”)

602 x 526 x 208 mm
(23.7” x 20.7” x 7.9”)

DKM flex 4RU
chassis

442 x 449 x 177 mm
(17.4” x 17.7” x 7.0”)

640 x 570 x 360 mm
(25.2” x 22.4” x 14.2”)

PRODUCT WEIGHT (INCL. FANS AND PSUS)

DKM flex 1RU
chassis 7.7 kg (17 lb)

DKM flex 2RU
chassis 11 kg (24.3 lb)

DKM flex 4RU
chassis 19 kg (41.9 lb)

COMPONENT MTBF IN POH

DKM flex 1RU chassis (incl. fans and PSUs) 71,900

DKM flex 2RU chassis (incl. fans and PSUs) 74,300

DKM flex 4RU chassis (incl. fans and PSUs) 65,400

I/O card Cat X 1G 899,200

I/O card Cat X 3G 474,800

I/O card fiber 1G & 3G (without SFP modules) 878,700
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CHAPTER 9:

9.1	 MAINTENANCE
 
 
The device contains no user serviceable parts inside.
 Do not attempt to open or repair the device.
 Please contact your dealer or manufacturer if there is a fault. 

CHAPTER 10: 

10.1	  TROUBLESHOOTING
 
 
The following chapters provide help in case of problems with the DKM unit. The content of this help is
based on an already functioning extender section. Before operating your extenders with the matrix, please
make sure that the extenders work via a direct point-to-point connection. A Cat X or fiber optic coupler can
be used to support this. In case of problems in this regard, the manuals of the respective extenders offer
assistance if necessary.

10.2	 EXTERNAL FAILURE

10.3	 VIDEO INTERFERENCE

10.4	 MALFUNCTION OF FANS

 
DIAGNOSIS POSSIBLE REASON MEASURE

Matrix cannot be
started anymore

Fuse at the standard
appliance outlet. Check the fuse.

 
DIAGNOSIS POSSIBLE REASON MEASURE

Opening the OSD not
possible No OSD jumper set Set jumper 11 on the CON Unit.

Incorrect video display Cable connection disturbed Check the connection, length, and quality of
the interconnect cable to the units.

 
DIAGNOSIS POSSIBLE REASON MEASURE

Fans do not run Fans defective Contact your dealer.t.
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10.5	 MALFUNCTION OF POWER SUPPLY UNITS

10.6	 NETWORK ERROR

10.7	 FAILURE AT THE MATRIX

 
DIAGNOSIS POSSIBLE REASON MEASURE

Matrix cannot be
started

No power supply available.
Check if power supply cables are connected

correctly.

Power supply units are not
switched on Check switch on the power supply units.

 
DIAGNOSIS POSSIBLE REASON MEASURE

Network settings are
not assumed after

editing.
Restart of the matrix not yet

completed. Restart the matrix.

 
DIAGNOSIS POSSIBLE REASON MEASURE

Port definitions as
USB 2.0 invalid.

Restart of the matrix not yet
completed. Restart the matrix.

No OSD access
possible. Wrong Hot Key Reset Hot Key if necessary (see

chapter 3.9.1, from page 43).
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10.8	 FAILURE AT THE INTERCONNECTION PORT

10.8.1	 ERROR INDICATION AT THE 1G CAT X PORT

10.8.2	 ERROR INDICATION AT THE 3G CAT X PORT

 
DIAGNOSIS POSSIBLE REASON MEASURE

LED 1 or LED 2
flashing orange

Connections CON Unit, matrix
and CPU Unit.

 Check connecting cables and connectors.
(cable break, CPU/CON Unit offline).

 Connect a 3G extender to a 3G port.
 Contact dealer if necessary.

 
DIAGNOSIS POSSIBLE REASON MEASURE

LED 1 or LED 2
flashing orange

Connections CON Unit, matrix
and CPU Unit.

 Check connecting cables and connectors.
(cable break, CPU/CON Unit offline).

 Connect a 3G extender to a 3G port.
 Contact dealer if necessary.

  
*For further measures see user manual of the respective extender series.

FIGURE 10-8.1.1 LEDS OF I/O MODULE 1G CAT X

FIGURE 10-8.1.2 LEDS OF I/O MODULE 3G CAT X
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10.8.3	 ERROR INDICATION AT THE FIBER PORT

10.9	 BLANK SCREEN

*For further measures see user manual of the respective extender series.

 
DIAGNOSIS POSSIBLE REASON MEASURE

LED 1 and LED 2 off Power supply Check the connection to the power network.

Monitors remains dark
after switching

operation

Switching to a port without
connected source (computer,

CPU).
Switch to a Port with a connected source

(computer, CPU).

Connections CON Unit,
matrix, and CPU Unit.

Check connecting cables and connectors (no
cable, cable break, CPU/CON Unit offline,

CPU/CON Unit connected to the wrong port)
see chapter 10.7, from page 310)).

FIGURE 10-9.1.1 LEDS FOR POWER FUPPLY

FIGURE 10-8.1.3 LEDS OF I/O MODULE FIBER PORT
 

DIAGNOSIS POSSIBLE REASON MEASURE

LED 1 or LED 2
flashing RED

Connections CON Unit, matrix
and CPU Unit.

 Check connecting cables and connectors.
(cable break, CPU/CON Unit offline).

 Connect a 3G extender to a 3G port.
 Contact dealer if necessary.

  
*For further measures see user manual of the respective extender series.
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CHAPTER 11:

11.1	 TECHNICAL SUPPORT

Prior to contacting support, please ensure you have read this manual, and then installed and set-up your
DKM flex as recommended.

11.1.1	 11.1 SUPPORT CHECKLIST
To efficiently handle your request, it is necessary that you complete a support request checklist
(Download). Please ensure that you have the following information available before you call:

	 • Company, name, phone number and email,
	 • Type and serial number of the device (see bottom of the device),
	 • Date and number of sales receipt and name of dealer if necessary,
	 • Issue date of the existing manual,
	 • Nature, circumstances, and duration of the problem,

	 • Components included in the system (such as graphic source/CPU, OS, graphic card, monitor, USB-
	    HID/USB 2.0 devices, interconnect cable) including manufacturer and model number,

	 • Results from any testing you have done.

11.1.2	 11.2 SHIPPING CHECKLIST

1. To return your device, you need an RMA number (Return-Material-Authorization). Therefore, please
     contact your dealer.

2. Package your devices carefully. Add all pieces which you received originally. Preferably use the original
     box.

3. Note your RMA number visibly on your shipment.

*Devices that are sent in without an RMA number will not be accepted. The shipment will be sent back
without being opened; postage unpaid.

CHAPTER 12:

12.1	 CERTIFICATES/DIRECTIVES

12.1.1	 12.1 NORTH AMERICAN REGULATORY COMPLIANCE

This equipment has been found to comply with the limits for a Class A digital device, pursuant to Part 15 of
the FCC Rules. These limits are designed to provide reasonable protection against harmful interference
when the equipment is operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and if not installed and used in accordance with the instruction manual, may
cause harmful interference to radio communications. Operation of this equipment in a residential area is
likely to cause harmful interference in which case the user will be required to correct the interference at his
own expense.
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Changes or modifications not expressly approved by the party responsible for compliance could void the
user’s authority to operate the equipment.
Shielded cables must be used with this equipment to maintain compliance with radio frequency energy
emission regulations and ensure a suitably high level of immunity to electromagnetic disturbances.
All power supplies are certified to the relevant major international safety standards.

12.1.2	 12.2 WEEE

The manufacturer complies with the EU Directive 2012/19/EU on the prevention of waste electrical and
electronic equipment (WEEE).
The device labels carry a respective marking.

12.1.3	 12.3 ROHS

This device complies with the Directive 2011/65/EU of the European Parliament and of the council of
8 June 2011 on the restriction of the use of certain hazardous substances in electrical and electronic
equipment (including the Commission Delegated Directive (EU) 2015/853 of 31 March 2015 amending
Annex II to Directive 2011/65/EU).
The device labels carry a respective marking.
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CHAPTER 13:

13.1	 GLOSSARY

The following terms are commonly used in this manual or in video and KVM technology.

TERM DESCRIPTION

Auto Disconnect Matrix function that allows an automatic disconnect between a console and a
CPU, if OSD is opened via this console.

Auto Logout Matrix function that describes the duration of inactivity after the user has been
logged out from the OSD at this console.

Cat X Any Cat 5e (Cat 6, Cat 7) cable

CON Device Logical term that summarizes several physical extenders to switch more
complex console systems via matrix.

CON Timeout Matrix function that allows an automatic disconnect of the own console from the
connected CPU after a predefined time.

CON Unit Component of a KVM Extender or Media Extender to connect to the console
(monitor(s), keyboard, and mouse; optionally also with USB 2.0 devices)

Console Keyboard, video, and mouse

Console ACL Console Access Control List is a list that shows the respective switching rights
for the various consoles.

CPU Auto Connect Matrix function that allows an automatic connection establishment between the
own console and a random CPU that is available.

CPU Device Logical term that summarizes several physical extenders to switch more
complex CPU systems via matrix.

CPU Timeout Matrix function that allows the user to disconnect after a predefined period of
inactivity from the respective CPU.

Dual Access A system to operate a source (computer, CPU) from two consoles

Dual-Head A system with two video connections

EXT Unit Part or extender board of a CON or CPU unit with a connection to the matrix. A
CON or CPU unit can consist of several EXT devices.

Fiber Single-mode or multi-mode fiber cables

Force Connect
Matrix function that allows to switch with the own console to a CPU that is

already used and in doing so to take keyboard and mouse control. The
connected console so far loses K/M control but keeps video control.

Force Disconnect
Matrix function that allows to switch with the own console to a CPU that is

already used and in doing so to take KVM control. The connected console so far
loses complete KVM control.

KVM Keyboard, video, and mouse

Keyboard Connect Matrix function that allows taking over the keyboard control of an inactive
console.

Macro Keys Programmable keys that can execute a stringing together of commands to the
matrix.
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TERM DESCRIPTION

Mouse Connect Matrix function that allows taking the mouse control of an inactive console.

MTBF Mean Time Between Failure (MTBF) is measured in power-on hours..

Multi-mode 50 μm multi-mode fiber cable

Multi-Screen Control
Control of USB-HID of up to eight sources (computer, CPU) at one sink with only
one connected mouse or keyboard. The sink can consist of up to eight monitors,

or up to sixteen monitors when operating Dual-Head Sources. In a matrix
system, Multi-Screen Control can be set up at multiple sinks.

Non-Blocking Access Matrix configuration where no user can be disturbed by an activity of another
user.

OSD The On-Screen-Display is used to display information or to operate a device.

OSD Timeout Matrix function that closes the OSD automatically after a predefined period of
inactivity.

POH Power-on hours corresponds to the average operating time

Quad-Head A system with four video connections.

Release Time Matrix function that allows a console that is connected with the same CPU to
release the K/M control after a predefined time.

Service Mode Defined maintenance condition that allows updating of extenders that are
connected to the matrix.

SFP
SFPs (Small Form Factor Pluggable) are pluggable interface modules for

Gigabit connections. SFP modules are available for Cat X and fiber interconnect
cables.

Single-Head A system with one video connection

Single-mode 9 μm single-mode fiber cable.

Tie Line Communication connection to and between extension modules in a network
environment.

USB-HID

USB-HID devices (Human Interface Device) allow for data input. There is no
need for a special driver during installation; “New USB-HID device found” is

reported.
Typical USB-HID devices include keyboards, mice, graphics tablets and touch

screens. Storage, video, and audio devices are not HID.

User ACL User Access Control List is a list that shows the respective switching rights for
the various users.

Video Sharing Matrix function that allows switching from the user’s console to any CPU with
video.
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