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About This Manual
The manual NI DIAdem: Data Mining, Analysis, and Report Generation describe the structure
of DIAdem as well as how to use the DIAdem functions to find data, to run analyses, to generate
reports, and to compile all the functions into a script.
The first chapter provides an overview of the DIAdem structure. The subsequent chapters
describe the functions of the individual DIAdem panels.

Related Documentation
For more information on DIAdem, refer to the following documentation:
•

Getting Started with DIAdem
You can use the getting started guide to familiarize yourself with DIAdem functions and
how to use them. This manual contains exercises for finding, analyzing, and presenting
data, for combining all work steps in one script, and for executing a simple measurement.

•

NI DIAdem: Acquiring and Displaying Data
This DIAdem manual describes how to use DIAdem to acquire data, to control sequences,
to operate plants, and to visualize processes.

•

You can open the DIAdem Help in every dialog box with the Help button, on the toolbar
with Help»Contents, or with <F1>.
The DIAdem Help offers procedures and dialog box help for each panel, as well as
references for programmers.
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1

DIAdem is the interactive National Instruments software for finding and managing technical
data, mathematically and graphically analyzing the data, and presenting the data in reports. You
search for data on your computer drives or on the network, and navigate in data files and
databases to load data into DIAdem. You view the loaded data to decide on which data to run
mathematical analyses. You present calculation results together with the raw data in a report. If
you frequently use the same method to evaluate data, you create a script that automates
evaluations.

DIAdem Panels
DIAdem consists of several panels. Use the panel bar on the left side of the DIAdem screen, to
switch panels. Each panel deals with a particular type of task. You use DIAdem NAVIGATOR
to mine and load data in different file formats. You use DIAdem VIEW to view data, to
graphically analyze curve sections, and to edit data, for example, to correct errors. You use
DIAdem ANALYSIS to evaluate data mathematically with standard functions or with your own
formulas. You use DIAdem REPORT to create multi-page reports that document data and
present results. DIAdem SCRIPT combines all the panel functions in scripts. You use scripts to
create your own applications that process tasks automatically.
Figure 1-1. Panel Bar (Section)
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All the panels work with the data that you load into the Data Portal. DIAdem VIEW, DIAdem
ANALYSIS, and DIAdem SCRIPT can modify data and store the result data as data channels in
the Data Portal. You can display and edit the contents of the data channels in channel tables in
DIAdem VIEW.

DIAdem User Interface
When you switch DIAdem panels, the user interface changes so that you can quickly access the
functions you want. Each DIAdem panel has its own group bar to the right of the panel bar. Click
a button on the group bar and select a function from the function group that opens. The
workspace also changes with the DIAdem panel and displays, for example, a folder and file
overview or a worksheet. Each panel has its own toolbar, menus, and context menus, which
contain frequently-used functions.
To create a report, select DIAdem REPORT on the panel bar. Click the 2D Axis Systems group
bar to open the function group with the predefined 2D axis systems. Click 2D Axis System with
Frame in this function group. The function group disappears and a small rectangle appears next
to the cursor.
Figure 1-2. Predefined Function: 2D Axis System with a Frame

Click and drag open a frame at the position you want to insert the 2D axis system in the
worksheet. Select the channels to be displayed in the Data Portal, and drag and drop the selected
channels into the axis system. DIAdem displays the channels as curves. Double-click the axis
system to open the dialog box for the axis system and define the display. The settings are grouped
into subject areas on several tabs.
You can use the context menu to change the predefined settings for the functions in the function
group. If you frequently calculate the arithmetic mean and the standard deviation, for example,
change the predefined settings for the Descriptive Statistics function. Select the DIAdem
ANALYSIS panel and click Statistics on the group bar to open the function group. Now
right-click the Descriptive Statistics button. Select Predefined Setting from the context menu.
Click All Off in the dialog box and select the two characteristic values Arithmetic mean and
Standard deviation. Click Change. If you now click the Descriptive Statistics button, the
arithmetic mean and the standard deviation are already enabled in the dialog box.

1-2
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The bottom function group is the same in all the panels. You can assign your own scripts to the
buttons of this function group and then call the scripts in all panels. You can also use the
keyboard to call these scripts. For example, press <Shift–F1> to call the script assigned to the
first button.
You can drag and drop one or more files from other programs, such as the Windows Explorer to
DIAdem, in order to load these files in DIAdem. If you drag and drop files to the workspace of
the active DIAdem panel, they must be file types that the panel can process. For example, you
can load only TDV layout files in DIAdem VIEW and only TDR layout files in DIAdem
REPORT. If you drag and drop files outside of the workspace onto the title bar, the menu bar,
the toolbar, or the status bar, you can load any file type. DIAdem automatically opens the panel
that matches the file type. If you drop a file onto the button of a DIAdem panel while keeping
the mouse button pressed, DIAdem opens the panel and you can drop the file into the workspace.

DIAdem Introduction Screen
When you launch DIAdem, the DIAdem introduction screen appears. The introduction dialog
box contains tutorials, executable examples, and DIAdem manuals. It also lists new features of
the current version and contains links to further information.
If the introduction screen does not appear when DIAdem launches, select Help»Introduction
to open the introduction screen. Use the Don't show this screen again checkbox to specify
whether DIAdem displays the introduction screen the next time DIAdem starts.
•

Tutorials: Open the website with the DIAdem tutorials and learn how to work with
DIAdem. The videos show you how to work with the individual DIAdem panels.

•

Examples: Click the preview pictures in the Example Gallery in order to open examples
of DIAdem REPORT or DIAdem VIEW. Press <Ctrl> and click the preview picture to open
the description of the example. The contents tree of the ExampleFinder contains simple
solutions and also more complex applications on data analysis, report generation, script
creation, and data acquisition. Copy the respective files to DIAdem to use these files as
templates for your solutions.

•

Manuals: Use the DIAdem manuals to familiarize yourself with DIAdem features and how
to use them. You need a PDF reader such as Adobe Reader to open the PDF files.

•

Additional Resources: Under this heading you find the DIAdem Help which helps you
use functions and automate processes. You also can find the website for National
Instruments DIAdem Training Courses and the website with the DataPlugins.
DataPlugins are file filters for loading or saving file formats in DIAdem.

© National Instruments Ireland Resources Limited
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NI License Manager
The NI License Manager helps you manage your NI software product licenses. To work with
DIAdem after your evaluation version expires, select Start»All Programs»National
Instruments»NI License Manager and enter your serial number. To add new DIAdem
components, select Help»Activate License in DIAdem and extend your license.
The NI License Manager only enables functionality that is included in your license. For
example, you cannot use the 3D functions from DIAdem ANALYSIS in the DIAdem Base
Edition. Then the buttons of this function are dimmed. To use the 3D functions, you must obtain
at least a license for the DIAdem Advanced Edition.
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2

Use DIAdem NAVIGATOR to find, to load, and to manage data. You use the DataFinder to
browse data files in different file formats on your computer and on the network. You use the file
browser to navigate through external data in data files and in databases. You load the data you
need into the Data Portal, which manages all internal data. The data in the Data Portal is arranged
in channels, each representing a data series. All DIAdem panels work with the channels in the
Data Portal.
Figure 2-1. DIAdem NAVIGATOR

Mining External Data
In DIAdem NAVIGATOR you use the DataFinder to browse data files on your computer and
on the network. In the search results, DIAdem lists the files, channel groups, or channels it finds.
You can drag and drop this data into the Data Portal or navigate in the files with the file browser.
To find data from a series of tests or data relating to a specific subject, enter an appropriate search
term in the search input area. If you search for meteorological data, for example, enter
Precipitation in the search input area if the data set you want contains the term
Precipitation as a channel name or in the comments. DIAdem browses through all the data
files for the text Precipitation and lists the data files it finds on the Search Results tab.
Refer to Configuring DataFinders in this chapter for information on specifying the folders that
the DataFinder searches.
The properties display below the search results displays the properties of a selected file, selected
channel group, or selected channel. Click one of the files to view the file properties. In the
properties display, DIAdem displays file properties such as the filename, path, creation date,
name, and author. Drag up the top edge of the properties display to view the entire properties list.
To browse in the files, right-click the file in the search results and select Display in File
Browser. DIAdem opens the file browser and selects the file. The file browser offers a tree view
of the folders which you searched. You can navigate down to channel level in the folders that
have the appropriate file formats.
If you navigate in a file down to channel level, DIAdem displays the channel data as a curve in
the channel preview. For example, select a channel in a TDM file to display the channel values
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as a curve in the channel preview on the right edge of the properties display. Drag the right edge
of the properties display to the left to enlarge the channel preview.

Extending the Search
To define a detailed search, click Advanced Search. You can enter several search conditions in
the search input area. You can search for files, channel groups, and channels, because the
Advanced Search is based on the TDM data model. For example, if you search for
meteorological data that includes a channel called Precipitation and that is more than
one month old, specify two search conditions in the search input area. As soon as you specify a
search condition in one line, DIAdem automatically creates a second line. To view all the search
conditions, drag the bottom edge of the search input area down.
Click in the first line of the entry field under Level and select Channel. Click <Enter a
property> in the Property column and select Name. Click the third column and select
the = operator. Click the button with the three dots at the end of the first line. DIAdem lists the
names of all the indexed channels. Enter the letter P under Search in list and select
Precipitation. DIAdem enters the channel name Precipitation in the Value column.
In the second line, select File in the Level column and select Creation date in the
Property column. In the third column, select Date before <= as the operator. In the Value
column, first click the displayed date and then click the button with the arrowhead to open
the calendar. Select a date that dates back at least one month. If you click the button with the
three dots at the end of the second line, DIAdem displays the time range of the creation date for
all the indexed files.
Click Search to find files that match both search conditions. DIAdem lists the files it finds on
the Search Results tab. You can also search for channel groups and channels. If you want to find
channel groups that match the specified search conditions, click the little triangle on the Search
button and select Search Groups. On the Search Results tab, DIAdem lists channel groups
containing a channel called Precipitation and files with the specified creation date. If you
want to view the corresponding channels in the results, select Search Channels.
The search results display the names of the located files, channel groups, or channels, and also
the path and the properties used in the search, for example, the creation date. To display more
information, drag another property, for example, the channel minimum, from the properties
display into the search results of the found channels. DIAdem adds a column with the channel
minimum values to the search results. Click Channel.Minimum to move the column in the
search results list. Click the two triangles on the right side of the column title to sort the channels
in ascending or descending order according to the channel minimum values. Select Configure
Results List from the context menu to edit the display of the properties.
The logical operations line below the search conditions displays the logical connectives of the
individual search conditions. DIAdem numbers the search results from the top down with C1 to
Cn and connects the search conditions with the AND operator. If you search for two values of one
property, use the OR operator to link the values. If you enter several channel names in the Value
column, DIAdem automatically uses OR to link the names. You can use the logical operations
2-2
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line to search simultaneously for files that contain the channel Name1 (search condition C1) or
Name2 (search condition C2), and which are not older than one day (search condition C3):
(C1 OR C2) AND C3

Entering Search Conditions
If you enter text in the search input area of the Quick Search or in the Value column of the
Advanced Search, DIAdem automatically displays a list of the previous entries that start with
the same letters. You can enter the search text in uppercase or lowercase because the DIAdem
search is not case-sensitive.
In the Quick Search, you can also search for fragments if you do not know the complete
filename or if the filenames all start with the name of a test series. For example, enter the
fragment tr_m17_qt for a test series in which the test program automatically generates
the filenames of the measurement results from the test series identification. DIAdem finds all the
data sets that have the fragment tr_m17_qt at the beginning of a name or at the beginning of
another property.
In the Advanced Search, you must use wildcards to search for fragments. Use a question mark
(?) as a wildcard for one character, and an asterisk (*) as a wildcard for any number of
characters. For example, to search for the fragment m17, enter *m17*. DIAdem finds all the data
sets that have the fragment m17 at the beginning, in the middle, or at the end of a property. If you
search for files with a specific filename extension, enter *.TDMS, for example, for the filename.
In the Advanced Search, depending on the type of property you search for, you can use the
various operators listed in the following table. For text properties, such as Name, you use
the = operator, and for numeric properties, such as Maximum values you use the usual
comparative operators. For date properties, such as Creation date, you can use the #
operator with Relative range, where you can select today, yesterday, the last 7 days, the last
14 days, or the last 30 days.
Table 2-1. Where to Use the Operators in an Advanced Search
Operator

Meaning

Numeric

Date

Text

=

Equal to

✔

✔

✔

<>

Not equal to

✔

>

Greater than

✔

>=

Greater than or
equal to

✔

<

Less than

✔

<=

Less than or equal to

✔

#

Relative range

✔

✔

✔
✔
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If you load data from a test series into the Data Portal and you want to find and compare more
data sets from the same test series, you can drag and drop a file, a group, or a channel from the
Data Portal into the search input area. DIAdem enters the name of the file, of the group, or of the
channel as a search condition. You can also drag and drop properties from the properties display
of the Data Portal or of the file browser into the search input area.
If you select several channels in the Data Portal and drag these channels into the search input
area, DIAdem combines the channel names with the OR operator and creates a search condition.
If you then drag a property such as the maximum value from the properties display of the Data
Portal into the search input area, DIAdem combines the maximum values of these channels with
OR to a second search condition. If you look for channels of a test series with a maximum value
of, for example, between 4 and 12, you must define two search conditions. Combine the search
conditions Maximum>4 and Maximum<12 in the logical operations line with AND.
If you define a query you want to use later, you can save the entries of the current search with
Save Query As. DIAdem saves the parameters of the current query together with the
configuration of the search results list in a file with the filename extension .tdq. Use Load
Query to load saved queries or the configuration of the search results list, or both. Click Delete
Query on the toolbar to specify a new query in the search input area. Click Previous Query or
Next Query on the toolbar if you want to reuse a previous query. To delete individual search
conditions from a query, select the search condition and press <Del>. The next time you start
DIAdem, the search input area contains the query you entered last. If you want to change this
setting, click Settings»Current Data Provider»Default Settings and specify that DIAdem
does not show a query, or that DIAdem reads the query from a file when the program opens.

Configuring DataFinders
You execute the searches described above with the local DataFinder My DataFinder, which is
located on your computer. You install the local DataFinder with DIAdem. The DataFinder
function group contains My DataFinder and three more buttons to which you can assign
DataFinder servers if you use the Predefine Setting in the context menu.

Configuring the Local DataFinder
Use My DataFinder to search folders on your computer with the local DataFinder. You cannot
delete the local DataFinder and you cannot create additional local DataFinders. To edit the
settings of the local DataFinder, select Settings»My DataFinder»Configure. In the
configuration of the local DataFinder you specify the search areas and the indexing of the data
files. You can also see which file formats the DataFinder includes in the search.
Search areas are the file system folders in which the DataFinder searches for files. Select these
folders on the Search Areas tab. You can add and delete folders, exclude subfolders from the
search, and change the order in which DIAdem displays the search areas in the file browser. You
can also use the context menu of the file browser to create and to limit search areas. For example,
if LabVIEW is installed on your computer, the LabVIEW Data folder is in the default search
area My Files or My documents. However, the folders My Pictures, My Music, and My
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Videos are not included in the search area because these folders do not usually contain data
relevant for the DataFinder.

The DataFinder only can search files in the search area if the DataFinder indexes the files first.
Click the Indexer tab in the DataFinder configuration dialog box to specify when and how often
the DataFinder indexes the search areas. In the file browser, DIAdem displays an hourglass next
to files and search areas that the DataFinder has not yet indexed.
The File Extensions tab has two lists that contain all the filename extensions that the local
DataFinder recognizes. The Indexable extensions list shows all the indexable file types
that correspond to the TDM data model. In indexable files the DataFinder can search for
properties of data sets, groups, and channels. If the data is indexed, DIAdem can navigate to
channel level. Click a filename extension to see which DataPlugins My DataFinder uses to
index these files. If several DataPlugins are available for one data format, you specify the
sequence of the DataPlugins. The Non-indexable extensions list shows all the
non-indexable file types. These file types do not correspond to the TDM data model. In
non-indexable files, the DataFinder cannot search for properties of groups or channels. The
DataFinder only can search for properties that the file system provides, such as the filename and
the creation date. Specify which DataPlugins the DataFinder uses on the DataPlugins tab.
You can search for properties in data files, as well as in documents and in graphics. You can
search for basic properties such as filename, description, title, author, and storage date, and also
for custom properties. If you want to search for a custom property, for example, the name of a
test sequence, it must be created first when exporting a report. If you drag one of the documents
you found onto the root in the Data Portal, the properties display lists all document properties.
If DIAdem is not able to search in documents and graphics, check under Settings»
Extensions»DataPlugins whether a DataPlugin for documents is registered.
You can optimize the search for custom properties for the local DataFinder. Custom properties
are user-defined properties that you can create for data sets, groups, and channels of the data that
is saved in the TDM data model. Open Settings»My DataFinder»Optimize Custom
Properties and select the custom properties to be optimized on the tabs File, Group, and
Channel. DIAdem lists these custom properties in the selectable properties of the Advanced
Search. If you select an optimized custom property, click the button with the three dots at the
end of the entry field to include a suggested value in the search. You only can search for Date
type custom properties if these custom properties have been optimized.
Generally, you should not change the index location in which My DataFinder saves the index,
and which is set up during installation. However, if the drive with the index has less than 20 MB
free memory space, the DataFinder server stops indexing and displays an error message. You
must then either delete files to make more space available, or change the index location as
follows. Open Settings»My DataFinder»Configure»Advanced and change the Index
location. If you change the index location, the DataFinder reindexes the search areas.
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If you delete large search areas or if the DataFinder can no longer access its index, the
DataFinder must create a new index. To do so, select Settings»My DataFinder»Reset and
delete the previous index. Indexing the search areas may take some time.
In the bottom right corner in the information area of the Windows task bar, you can open the
context menu of the registered My DataFinder. At this point you can configure or close every
My DataFinder, stop or restart indexing, and also reset the index. Select About My DataFinder
to see when the last complete indexing was executed and how many files, groups, and channels
are indexed.

DataFinder Server
Use TDM Server to install DataFinder servers on a network server in order to index files in the
network. DIAdem communicates as a client with DataFinder servers in order to search the index
and to load the files it finds. In TDM Server you can specify several DataFinder servers in order
to separately index the data areas of different work groups. You cannot do this with My
DataFinder. DataFinder servers index faster because of the parallel processes and manage larger
volumes of data because of the more powerful database connections.
Use TDM Server to find and to analyze data on other computers and central servers in the
network. To register a DataFinder Server in DIAdem, copy the client configuration created by
TDM Server onto your computer. TDM Server saves the connection parameters in a file with the
filename extension .urf. Double-click this URF file to register the connection parameters and
the DataPlugins on your computer. Use Settings»DataFinder Server to import, configure and
delete further DataFinder servers.
Use the context menu to assign one of the free buttons in the DataFinder function group to this
DataFinder server in order to access the DataFinder server quickly. If you click this button,
DIAdem opens the search areas of the DataFinder server in the file browser. In the search areas
of the DataFinder server, you can search, navigate, and drag and drop the data into the Data
Portal. You can test the connection to the DataFinder server in DIAdem in Settings»DataFinder
Server and, if necessary, change the connection parameters.
If several work groups access the central data areas of a network server, you can use the
Windows user accounts to manage the access rights of clients to the DataFinder server and data.
TDM Server uses Windows access rights so that members of a work group can search for and
load data only in the shared folders.
You can use DataFinder servers as an ASAM ODS Server in order to read the data through the
Corba interface of ASAM ODS. The ASAM ODS interface makes it possible to connect ASAM
conform programs as clients with this server. If you register the connection settings on a
DIAdem computer, DIAdem can either access the data from the DataFinder server directly or
can open the data as ASAM ODS data in the file browser in DIAdem NAVIGATOR. Register
the DataFinder server under Settings»Data Stores as a data store in order to use the DataFinder
server as an ASAM ODS server in DIAdem. The data browser in DIAdem NAVIGATOR uses a
model hierarchy configured on TDM Server to display the data.
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Navigating in Data Stores
DIAdem NAVIGATOR displays external data stores as a hierarchical structure. You can
navigate in data stores on your computer, on connected drives in the network, and in every
registered database, in order to drag and drop individual channels and channel groups into the
Data Portal. In the Data Stores function group in DIAdem NAVIGATOR, you can register
file-based data stores and server-based data stores.
To load an example for ASAM data, click ASAM Pass Fail Analysis Example. DIAdem
NAVIGATOR opens the ASAM example database in which you can browse in tests,
measurements, matrices, and submatrices and drag and drop data into the Data Portal. A level
which you can load into the Data Portal has a colored symbol in the file browser and, when it is
selected, is highlighted in color. The ASAM model allows the definition of further levels such
as engine, test condition, or operator, the display of which you can define and save in the file
browser by clicking Settings»Current Data Provider»Browse Settings.
When an ASAM data store is open in the file browser, you can search in the data. You specify
the level, such as TestRun, the property, such as Name, the operator, and the value searched for,
such as TR_M17_QT_33*. You can search for TestRun, Measurement, and Meaquantity and
configure the search results list in order to, for example, show a test description.

Adding Data Stores
Settings»Data Stores lists all data stores available in DIAdem. Double-click a data store in
order to open it in DIAdem NAVIGATOR Select Create Data Store to access further data
stores in DIAdem and then, for example, the data store type AOP to register an ASAM database.
Enter your user name and password, and the server for the ASAM database. Assign this database
and further data stores to buttons in the Data Stores function group in order to have fast access
to frequently used data stores.

Loading Data from Files and Data Stores
You drag and drop files, channel groups, or channels from the file browser and from the search
results into the Data Portal. If you drag a file, a channel group, or channels onto the root element
of the Data Portal, DIAdem deletes the internal data and loads the new data. If you drag a file or
a channel group to another position in the Data Portal, DIAdem generates new groups with the
loaded channels. If you drag single channels into the Data Portal, DIAdem adds the channels to
the group you worked with last.
When you drag and drop data into the Data Portal, DIAdem automatically uses the loader
associated with the file type. If DIAdem cannot automatically load a file, a dialog box opens in
which you specify the loader. Click Open With to see which file formats your DIAdem
installation can load. To do so, disable the setting Display only Plugins with same extension.
Select, for example, Import Wizard Text to load a specfic text format with this wizard.
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Click Search to find and load a loader on the NI DataPlugin website if DIAdem does not have
a loader for a specific file format. If DIAdem does not have an appropriate loader on the
DataPlugin website, you can create a DataPlugin for the specific file format. Click Wizard to
open the DataPlugin wizard. A DataPlugin is based on a VBS script that analyzes files of a
specific type and provides the data for DIAdem.
To refresh the DataPlugins available in DIAdem and to add further DataPlugins, open
Settings»Extensions»DataPlugins and click Update. This dialog box contains all DataPlugins
registered in DIAdem. You can import DataPlugins, export them encrypted to a different
computer, and also create new DataPlugins, for example, for your documents. For more
information about DataPlugins, refer to the section on Creating DataPlugins in Chapter 6,
Automating Sequences.
In earlier versions, DIAdem loaded all the data from a file to an internal storage area. Files with
numerous and long channels took some time for this. Now DIAdem does not load the bulk data
of a channel until you write to it for the first time. You can change the loading behavior by
clicking Settings»DIAdem Settings»NAVIGATOR. For faster processing of large files, only
register the channels in DIAdem or execute reduced loading on data from long term
measurements.
To register data in DIAdem, right-click the file in the file browser and select Register Data from
the context menu. DIAdem creates write-protected channels in the Data Portal that refer to the
data without loading the data into the internal memory. To edit a registered channel you must
load the data later with the function Expand Channel from the Data Portal context menu.
For reducing loading of large files in which the consecutive values differ only slightly, select
Data Reduction from the context menu in the file browser. You specify the width of the interval
that DIAdem applies to each data channel in order to load one value from each interval. You can
load the first value from each interval or you can calculate the mean, the maximum, or the
minimum for each interval. If you use several reduction methods simultaneously on one channel,
DIAdem creates a new data channel for each reduction method.
Use, for example, the Bus Log Converter to convert logfiles from CAN, LIN, and FlexRay buses
into the TDM format and to load them into the Data Portal. The CAN bus (Controller Area
Network), LIN bus (Local Interconnect Network), and FlexRay bus are used for the
communication of intelligent sensors and actuators in vehicles. The data packages transported
in the bus are saved in bus logfiles. In order to interpret the data packages, the converter also
needs the descriptive information from a database file, such as NI-CAN (.ncd) or LIN signal
description (.ldf). Use the buttons in the Bus Log Converter function group to simplify the
conversion of logfiles with specific database files. To convert into the TDM format, connect the
logfile with at least one database file. You save the settings necessary for the conversion of a
logfile in a user file with the filename extension .tcc, which you assign in the Predefine
Setting context menu of a button.
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Managing Internal Data in the Data Portal
The Data Portal manages the data that you load in DIAdem NAVIGATOR. All panels in
DIAdem work with the internal data from the Data Portal. The Data Portal contains numeric
channels, waveform channels, time channels, and text channels. The Data Portal organizes the
channels in groups and displays the properties. The channel preview in the Data Portal displays
the channel data as a curve and can play acoustic data saved in waveform channels on the
computer loudspeakers. DIAdem only temporarily loads internal data from the Data Portal into
the workspace. DIAdem does not store the changes you make to the internal data until you save
the data to a file or to a database.

Working with Channels
DIAdem organizes data in channels: a numeric channel contains measurement values from a
sensor, and a time channel contains the associated time values. All DIAdem panels work with
channels. In DIAdem ANALYSIS you can calculate, for example, an FFT from two channels
with time and amplitude values, and in DIAdem REPORT you display a channel as a curve
above the channel index.
Create channel groups to organize channels in the Data Portal. When you drag and drop a data
file from DIAdem NAVIGATOR into the Data Portal, DIAdem creates new channel groups.
Channel groups help you prepare and describe data for evaluation and presentation. For
example, a Results channel group can contain all the calculated result channels.
DIAdem designates the last channel group that you load into the Data Portal as the default group.
DIAdem stores result channels for which you do not specify a channel group, such as the
channels calculated in DIAdem ANALYSIS, in the default group. DIAdem displays the group
name of the default group in bold in the Data Portal. For example, use the context menu to
designate the channel group Results as the default group, and smooth the channel
SensorData. DIAdem saves the result channel Smoothed in the Results default group.
Use the context menu in the Data Portal to edit the internal data. You can generate and delete
channel groups and channels, change the names of channel groups and channels, and move or
copy channel groups and channels. The structure view of the Data Portal orders channels in
channel groups, whereas the list view lists all channels in tables according to a selected property.
If you want to delete all data from the Data Portal, click Delete Internal Data on the toolbar or
select Delete from the context menu of the Data Portal root.
Use filtering and pinning to display only specific groups or channels in the Data Portal. Click
Filter to open the filter area. If, for example, you only want to display the acoustic measurement
channels, enter NOISE as a filter condition. While you enter the letters, the Data Portal already
displays those channels with names starting with these letters. To filter channels that contain a
certain character sequence in the name, use the question mark (?) for one, and the asterisk (*)
for several optional characters. You can define group filters and channel filters, which must both
be fulfilled, and you can link several filter conditions with OR. The filters are not case sensitive
and are not effective when the filter area is closed. To exclude groups and channels from
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filtering, use the context menu to pin groups and channels. Groups and channels that are pinned
are always displayed. In the context menu you can select the pinned channels or show the pinned
channels and groups only.
When DIAdem accesses channels in an axis system or in a calculation, the channel is normally
referenced by the group index combined with the channel name. Select Settings»DIAdem
Settings»General to specify the channel reference as another combination of the group name or
the group index and the channel name or the channel index. The group index is the position of
the group in the Data Portal and the channel index is the position of the channel in the group.
Refer to the section on Calculating with Channels in Chapter 4, Analyzing Data with
Mathematical Functions for more information about channel references.

Creating New Channels
The DIAdem panels create new channels for different actions. DIAdem NAVIGATOR creates
new channels when you load data. In DIAdem ANALYSIS, calculations store results in new
channels. In DIAdem SCRIPT you create new channels with script commands.
In DIAdem VIEW you can also create channels manually. Select Create New Channel from the
context menu of a channel table. You can enter single channel data in the channel table or you
can use the Generate function to create data series. To create a channel group, select New»
Group from the context menu of the Data Portal. You cannot use the same name twice for
channel groups or for channels of one channel group. If you enter a name which is already used,
DIAdem automatically adds an index and a separator to this name in order to ensure the
uniqueness of the name. You can change this behavior in Settings»DIAdem Settings»General.

Numeric Channels, Waveform Channels, Time Channels, and
Text Channels
DIAdem works with different channel types: numeric channels, waveform channels, time
channels, and text channels. The symbol that DIAdem displays before the channel in the Data
Portal identifies the channel type.
Numeric channels contain acquired values, calculation results, input values, or values loaded
from files. DIAdem can use any numeric channel from the Data Portal for calculations and
displays.
Waveform channels contain the x-part and the y-part of a curve in a channel. The x-part is often
the time information that LabVIEW, for example, saves as a linear generation specification with
a start value and a step width. The y-part can include measured values, calculation results, or
input values. If you use waveform channels as the y-channel in calculations and curve displays,
you do not need to specify an x-channel.
Time channels contain absolute time values of a measurement. In a time channel, DIAdem saves
the seconds that have elapsed since the year zero up to the current time. Use the Generate Time
Channel function in DIAdem ANALYSIS, for example, to create time channels. A time channel
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is often the x-channel for calculations and for displays of the associated measurement values.
DIAdem saves relative time values, such as the duration of a test in seconds, in numeric
channels.
Text channels contain text, for example, observations and comments. DIAdem saves text
channels in Unicode. Unicode characters include Chinese, Japanese, and Arabic characters. Use
text channels in tables and in 2D axis systems in DIAdem VIEW and DIAdem REPORT. You
can edit text channels in DIAdem VIEW channel tables.

Organizing 2D Data and 3D Data
DIAdem works with single channels. To display curves in DIAdem VIEW and in DIAdem
REPORT, use one or more channels. If you drag and drop one channel into a 2D axis system,
DIAdem uses the index to display a numeric channel and uses the x-part to display a waveform
channel. If you drag and drop several channels into a 2D axis system, the first channel selected
in the Data Portal is the x-channel of the curves. Even if an axis system already displays a curve,
you can still select one or more channels in the Data Portal and add more curves to the axis
system.
DIAdem REPORT and DIAdem ANALYSIS read data as a matrix or as a triplet to display
three-dimensional data. DIAdem uses three channels that are the same length to make a value
triplet: one channel for the x-values, one channel for the y-values, and one channel for the
z-values. A DIAdem matrix consists of an x-channel, a y-channel, and several z-channels.
The number of z-channels corresponds with the length of the y-channel and the length of the
z-channels corresponds with the length of the x-channel.

Editing and Creating Data Properties
In the TDM file format, DIAdem saves properties and comments with the bulk data. For
example, the data set properties in DIAdem contain the name of the author and the storage date,
the channel group properties contain the name of the measurement and comments, and the
channel properties contain the data type and the unit for the channels. DIAdem uses the data
properties to manage the data. The DataFinder indexes the properties, which enables you to
search for data efficiently.
In the structure view, DIAdem displays the properties of the data in the bottom area of the Data
Portal. If the properties do not appear in the Data Portal, click the bottom edge of the Data Portal
and drag open the properties window. If you click the root of the tree view in the structure view,
you see the data set properties. If you click the name of a channel group, you see the properties
of the channel group. If you click a channel name, you see the channel properties.
The Data Portal organizes the properties in groups. A data set, a channel group, and each channel
has base properties. But channels also have extended properties. Click the plus sign before the
Base Properties to show the individual properties. Double-click a property field to edit the
property. Properties you cannot change, such as maximum and monotony, are dimmed.
Properties that you can change, such as name and unit, are in black font.
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In the Data Portal you can add additional properties to channels, channel groups, and the data
set. Use custom properties to provide data with additional characteristics not included in the
standard data model, and which the DataFinder can search for. Right-click a channel and select
New»Custom Property from the context menu to create a new property for this channel. Enter
a name and select the data type. The property appears in the structure view and in the properties
display of the Data Portal. Click the entry field in the property display and enter a value for the
new channel property.
To ensure that every new channel or every new channel group always receives specific custom
properties, such as the sensor type or the component part number, you can create a template for
the custom properties. Select Settings»DIAdem Settings»General to create a template for the
custom properties of channels. Select the checkbox Data Portal»Template for custom
properties and click Edit. Select the Channel tab and click New Entry to specify the name for
a custom property and to select the data type and the initial value. The Data Portal creates the
new group Custom Properties in the structure view.
By default, DIAdem only reads the properties of the elements that you load into the Data Portal
from a file or a data store. When loading channels, DIAdem only accepts the associated channel
properties. You can change this loading behavior by clicking Settings»DIAdem Settings»
NAVIGATOR, so that the element loaded into the Data Portal inherits properties from
superordinate elements. When loading channels, DIAdem can, for example, add channel group
properties or data set properties to the loaded channels.

Using the Units Catalog
If you click the input field of the channel unit in the Data Portal, you can select a different unit
when you click the button with the three dots at the end of the input field. For example, select
the unit miles per hour [mi/h] to change a velocity that was saved in the unit kilometer
[km/h]. If you click Convert, DIAdem converts the channel values to the new unit. If you click
Replace, you use the new unit without DIAdem having to recalculate the channel values.
DIAdem manages the channel unit in the units catalog. The units catalog assigns a physical
quantity and a unit to measurement values, for example, the quantity speed and the unit
kilometers per hour. Other physical quantities are length, volume, mass, or frequency. Usually
every quantity has several units, for example, to specify the length in meter, centimeter, foot, or
inch. Every unit has a symbol such as [cm] for centimeter. DIAdem groups quantities into unit
sets. By default, DIAdem uses the SI unit set (SI: Système international d’unités). However, you
can also select a different unit set, for example, the unit set with the country specific units.
Select Settings»Units to open the DIAdem units catalog. The Unit Sets tab lists the available
unit sets. If you want to view and to extend the SI unit set, select this line and click the
Quantities tab. This tab lists all the quantities that are defined in the unit set with the respective
basic units, for example, length in meters, time in seconds, or temperature in Kelvin. Every
quantity is followed by the dimension, which refers each quantity to the seven basic quantities
length, mass, time, electric charge, thermodynamic temperature, amount of substance, and
luminous intensity. Use multiplication and division of the basic quantities to create new
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quantities. Enter integer exponents such as 2,0,0,0,0,0,0 for a surface as the product of
two lengths or 1,0,-1,0,0,0,0 for a speed as the quotient of length divided by time.
Select the quantity Length and open the Units tab. This tab lists all the units that are defined for
the quantity length. Select a default unit such as meter, in the Default column. If you create a
new unit, enter the name, the symbol, and the scaling function for the conversion to the basic
unit, for example, Ell with the symbol E and the conversion factor 1/3. This makes three ell as
long as one meter. Use the factor, the offset, linear scaling, or logarithmic scaling to specify how
DIAdem converts the new unit to the basic unit.
Save the units you changed. DIAdem saves the units catalog in a file with the filename extension
.tuc. You can import units from other units catalogs or import the other units catalog

completely.

Saving Internal Data
To save the internal data from the Data Portal, click Save TDM File As in the Data Portal
toolbar, or drag the data to be saved into the file browser. To save all internal data, click the root
in the structure view and drag and drop the data set into the file browser. To save selected
channels, select the channels and channel groups you want to save, and drop the selected
channels into the file browser. DIAdem saves the data in the folder into which you drop your
internal data in the file browser. If you drop data into a data file, DIAdem suggests this filename
for the new data file in the Save As dialog box. DIAdem does not create the new data file until
you click Save.
Remove the write protection from a file because you cannot overwrite a protected file. To do so,
select File Operations»Write Protected from the context menu of the target file in the file
browser. The file operations in the file browser also include copy, move, rename, and delete.
By default DIAdem saves data in TDM file format. The TDM file format saves the properties
and the binary data in different files with the same name. DIAdem saves the data properties in a
text file with the filename extension .tdm, and the numeric data in a binary file with the
filename extension .tdx. When you save TDM files under Settings»DIAdem Settings»
NAVIGATOR, you can specify that DIAdem automatically specifies the storage format of the
numeric data to save memory space. For example, DIAdem saves the loaded integer data as
integer values if they have not changed.
In addition to the TDM format, the Save As dialog box also offers file formats that save the data
for which a DataPlugin with write functions is registered in DIAdem. Select the TDMS file
format to save binary data with the respective properties in one file for LabVIEW. LabVIEW can
append measured data to an existing TDMS file. If you want to evaluate TDM data and TDMS
data with Microsoft Office, use the NI TDM Excel Add-In, which converts the data of the Data
Portal into the structure of the Excel spread sheets.
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Use DIAdem VIEW to inspect the data in the Data Portal, to graphically analyze curve sections,
and to edit data. You inspect curves in axis systems, zoom curve sections, and delete or replace
curve points. In channel tables, you edit and delete single values or entire channels. If you
modify curves or edit channels, DIAdem saves the changes in the Data Portal.
If you record test videos or the route of a test drive simultaneously with the data, you can
synchronize the curves with the videos and the geographical data. If you inspect a component,
you can project the signals measured at various positions or simulated data, onto a model of the
component as color shading or as deformation. You can display characteristic diagrams as color
shading and with isolines.
Figure 3-1. DIAdem VIEW

Worksheet Design
You can combine various axis systems, channel tables, videos, maps, 3D models, contour
displays, dialog boxes, text, and graphics in one worksheet in DIAdem VIEW. To do this, you
partition the worksheet. The function groups contain predefined worksheet partitions with
different numbers and area arrangements.
For example, if you want to display data as a curve in a 2D axis system and list the associated
numeric values in a channel table, divide the worksheet into two areas. Open the Assigned
Worksheet Partitions function group and click the 2D Axis System/Horizontal Channel
Table button. DIAdem inserts an axis system in the top area and a channel table in the bottom
area.
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Figure 3-2. Assigned worksheet partitions

To display a curve, select a channel in the Data Portal and drag and drop the channel onto the 2D
axis system. DIAdem VIEW displays numeric channels over the index and displays waveform
channels over the x-part.
To display one or more curves over one x-channel click the x-channel first in the Data Portal, for
example, Time. Then press Ctrl and click the numeric y-channels, for example, Pressure and
Temperature. Drag and drop these channels onto the 2D axis system. DIAdem VIEW displays
the pressure and the temperature as curves over time. If you drop a channel group onto an axis
system, DIAdem selects the first channel in the channel group as the x-channel. If you drag and
drop several waveform channels onto an axis system, DIAdem displays each waveform channel
over its x-part.
To list data in channel tables, select the channels, a channel group, or the data set in the Data
Portal, and drag and drop the data into the channel table. DIAdem VIEW lists each channel in a
column, with the channel name as the heading.

Editing Layouts
You can load a prepared layout as a template. The layout file contains the description of all the
areas and references to the channels, videos, or graphics to be displayed. Layout files can contain
several worksheets and have the filename extension .tdv.
You can drag the separating bars to resize any area in a worksheet. However, you cannot move
areas to another position in the worksheet. To add new areas, use the context menu to split an
area, or select different worksheet partitions with more areas. If you select worksheet partitions
with fewer areas, the contents of the surplus areas are deleted. If you select one of the worksheet
templates in the Assigned Worksheet Partitions function group, DIAdem creates a new
worksheet that contains areas with specific display types.
Use the context menu to specify and to change the display type of the area. To define an area as
an axis system, right-click the area and select Display Type»2D Axis System from the context
menu. If you select the display type Channel Table for an axis system, DIAdem lists the values
of the channels that are displayed as curves in a channel table.
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Which options the DIAdem VIEW context menu contains, depends on where you right-click.
For example, to insert another worksheet right-click the name of a worksheet on the tab bar and
select New from the context menu. Select Manage to change the order of the worksheets or to
rename the tabs. To insert worksheets from an existing layout, select File»Append Layout.
To document the current view of your data in a report, you can transfer your worksheet to
DIAdem REPORT. Click the Transfer to REPORT button on the DIAdem VIEW toolbar.
DIAdem REPORT creates a new worksheet with 2D axis systems, tables, video frames, 3D
models, map sections, and dialog boxes in the same layout as in the DIAdem VIEW worksheet.
DIAdem REPORT offers extensive functions for the final presentation and documentation of
your results.

Entering and Editing Data in Channel Tables
Use the Channel Table display type to edit and to display the contents of numeric channels,
waveform channels, text channels, and time channels, and to enter new values. The channel table
displays channels columnwise. The table heading includes the channel properties, such as the
channel name and the channel length. Use the mouse wheel to scroll vertically through the
displayed table columns. Press <Shift> at the same time to scroll horizontally through several
table columns or press <Ctrl> to zoom the channel table.
To move channels in the table or to remove channels from the table, select a column in the table
by clicking above the first channel property. Click a cell in the channel table to delete or to
overwrite the contents. Double-click a cell to edit the contents. If you select several cells in one
column or in neighboring columns, you can select the Block Operations from the context menu
to edit the data block.
In the channel table you can create new channels and fill the channels with values. Select Create
New Channel from the context menu. Enter a channel name and specify the display format, for
example, Numeric. DIAdem creates the new numeric channel in the default group of the Data
Portal and inserts the channel into the channel table at the same time. You can now enter channel
values or use the Generate function in the context menu to generate data series.
Select Display from the context menu to specify which channels from the Data Portal DIAdem
VIEW displays and refreshes automatically, for example, after a calculation. The channel table
can display all the channels of the Data Portal, a specific channel group, or only the selected
channels. To display other channel properties, such as the maximum value or user-defined
custom properties, in the table heading, select Select Properties from the context menu. You can
select a property, such as Maximum in the properties display of the Data Portal and drag and
drop the property into the channel table.
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Viewing Data as Curves
Use axis systems to display data as curves. If the x-channel and the y-channel in a 2D axis system
are not the same length, the shorter channel determines the curve length. Double-click the axis
system to open the 2D Axis System Display dialog box, where you add, copy, modify, or delete
curves. You can highlight curve points with markers and label them with text or values.
You change the x-axis scaling and the y-axis scaling individually on the toolbar of the axis
system. You can use logarithmic or linear scaling for the axes. In order to compare curves with
different y-value ranges in an axis system, you can select a common y-axis with a percentage
scaling or select a separate y-axis for each curve.
Use the mouse to drag open the legend on the right side of the axis system. The legend displays
the y-channel name for each curve and two checkboxes. The checkbox that has the same color
as the curve specifies the leading curve, which you analyze later. The second checkbox
determines which curve DIAdem displays in the axis system. The legend can display other
channel properties, such as extreme values or the cursor coordinates. To configure the legend,
select Legend from the axis system context menu.
To copy curves to another axis system, click next to the checkbox of the curve and drag and drop
the selected checkbox to the other axis system. Press <Del> to delete the selected curves.
DIAdem also displays these checkboxes when you load a layout with curve definitions that
contain channels that are not in the Data Portal. To delete all the curve definitions that cannot be
displayed in the axis system, select Delete Invalid Curves from the context menu.

Zooming Curve Sections
To enlarge and inspect curves in an axis system, select the band zoom or the frame zoom on the
toolbar of the axis system. Click Zoom In to increase the zoom stepwise and Zoom Out to undo
the zoom steps. Click Zoom Off, to see the whole curve again. Use the Move function to move
the enlarged section horizontally and to move the frame zoom vertically in the axis system.
To view and to enlarge curves in several axis systems, select the band cursor or the frame cursor
on the DIAdem VIEW toolbar. All the axis systems in a worksheet have the same band cursor
or frame cursor and display the cursor in the same value ranges. The zoom you specify with the
band cursor or the frame cursor applies for all axis systems. The narrower the band cursor, the
more the section is enlarged. You enable and disable zooming and scrolling on the toolbar of the
individual axis systems.
If you examine a section of a curve and you want to see the entire curve at the same time, you
define two 2D axis systems with the same curve definition. One of the axis systems displays the
entire curve and the other axis system zooms a section of the same curve. Click Band Cursor
on the DIAdem VIEW toolbar, and click Scroll in Cursor Range on the toolbar of the second
axis system. If you now move the band cursor in the overall axis system, the zoomed axis system
displays the section of the curve that is inside the band cursor.
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Analyzing Curves
Each axis system has a cursor, which you move along the curve manually with the mouse or with
the arrow keys, or which you move automatically with the toolbar functions. Use the Cursor
Parameters button to vary the speed of the cursor along the curves after you click Play on the
toolbar.
If one axis system has several curves, the cursor moves along the leading curve. To specify the
leading curve, click the checkbox in the legend that is the same color as the curve. If the
individual curves have different x-values, DIAdem interpolates the x-values of the other curves
according to the x-values of the leading curve. The cursor position on the leading curve also
determines the display in the other areas of the worksheet if the displays use the same reference
axis for cursor synchronization. If the worksheet contains several axis systems, the cursors move
along the other axis systems. If you play a video of the test, DIAdem displays the video frame
that matches the current measurement value. If you project the data onto a 3D model, DIAdem
displays the projection at the time of the current cursor position. Select Go To»Cursor Position
from the context menu of the channel table to find the current value in the channel table.
The standard cursor is a crosshair cursor which can either move freely, follow the curve, or jump
to the minimum or maximum values of the curve. To examine the maximum values on a curve,
select Maximum Values Cursor on the toolbar. If you move the cursor along the curve, the
crosshair jumps from one maximum value to the next. DIAdem displays the x-values and the
y-values of the data points on the status bar and in a tooltip that moves along with the crosshair
cursor. To view the x-values and the y-values of the individual maximum values in the
coordinates display, click Coordinates on the DIAdem VIEW toolbar.
In the 2D axis system you can use additional cursor lines at the cursor for the analysis. Select the
Harmonic Cursor on the toolbar of a 2D axis system to measure intervals of the same width.
The harmonic cursor displays several cursor lines to the right of the main cursor. Their distance
to each other corresponds to the distance of the main cursor to the axis origin. The distances
increase when the distance of the main cursor to the axis origin increases. Select the Sideband
Cursor to inspect fixed intervals on the left and on the right side of the main cursor. The
additional cursor lines are equidistant. The distance remains the same when the sideband cursor
moves. Specify the number of cursor lines in Settings»Cursor Parameters»Number.

Editing Curves
You also can edit curves in the axis systems. For example, if a curve has erroneous sections or
outliers, you can replace the erroneous curve points. The functions Flags: Remove Data Points,
Flags: Copy Data Points, and Flags: Interpolate NoValues edit the curve points that you
marked previously with flags.
Click the Band Cursor on the DIAdem VIEW toolbar to select a curve section. Set the band
cursor to a width that encloses the vertical lines of the wanted curve section. In the axis system
toolbar, click the Set Flags button to mark all the curve points in this section of the leading curve.
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If you want to mark the curve points of all the curves in this curve section, <Shift>-click Set
Flags. Use the crosshair cursor and click Set Data Point and Flag in the axis system toolbar to
mark single points.
You delete selected curve points or curve sections with Flags: Remove all Data Points on the
toolbar of the axis system. Select Settings»DIAdem Settings»VIEW to specify whether
DIAdem deletes the curve points from the channels or replaces the curve points with NoValues.
To copy selected curve points or curve sections, click Flags: Copy Data Points on the toolbar
of the axis system. DIAdem creates a new channel for each selected curve, in the default group
of the Data Portal.
To replace sections that you delete and to replace them with NoValues, click Flags: Interpolate
NoValues on the axis system toolbar. Select Settings»DIAdem Settings»VIEW to specify
whether DIAdem applies linear interpolation or interpolates with a spline function.
You can also select several sections to delete, to copy, or to interpolate all the selected curve
points. To remove flags from all curves, click Remove Flags from All Data on the DIAdem
VIEW toolbar.

Selecting an Axis System
Use axis systems in DIAdem VIEW for an overall view of your data. 2D axis systems display
data in the x/y plane and polar axis systems display data in a full circle. Bode axis systems
display the phase and the amplitude on top of each other. The orbit and shaft centerline axis
systems analyze rotating shafts.

2D Axis Systems
In 2D axis systems you can display curves as lines, spikes, and stairs and also define constants
parallel to the x-axis and the y-axis. In 2D axis systems you can color background sections in
order, for example, to display changed test conditions. To do so, double-click the axis system
and select Background Segments in the dialog box. Select two channels from which DIAdem
reads the state and the position of the segments and specify the background color and the
direction of the segments parallel to the x-axis or the y-axis. If you specify several segments,
specify the transparency of the color in such a way that all colors are visible if the segments
overlap.
If you load acoustic data saved in waveform channels into a 2D axis system, DIAdem VIEW can
play the acoustic data. For example, if you load the waveform channel Noise_1, DIAdem
enables the loudspeaker symbol on the toolbar of the axis system. Click Play or Repeat Play to
output the signal on the computer loudspeaker. If a 2D axis system contains several curves, use
the colored curve symbol to specify which channel to play. DIAdem plays the waveform channel
synchronous to the cursor. Specify the play speed with the Cursor Parameters. If you enable
the minimum or the maximum cursor, there is no sound.
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Polar Axis Systems
Use the Polar display type to display data over the angle as curves in a full circle. You need one
or two channels in order to define a polar curve. In channel pairs, the x-channel contains the
angle and the y-channel contains the amounts, and thus the distances from the axis origin. You
can change the angle direction and also the position of the zero-point for the polar axis system.

Bode Axis System
Select the Bode display type to display the phase shift and the amplitude amplification of a
complex transfer function as super-imposed curves. To define a curve, you must specify two or
three channels. You can scale the y-axis of the amplitude display and the joint x-axis linearly or
logarithmically.

Orbit and Shaft Centerline Axis Systems
Use the display types Orbit and Shaft Centerline to analyze rotating shafts. Select the Orbit
display type to display the movement of a rotating shaft as concentric curves. Use the Shaft
Centerline display type to display the deflection of the rotating shaft from its idle position as a
curve. To define a curve, you must specify two channels. Both axis systems are quadratic and
have the same scaled axes because the values of the two sensors on the rotating shaft always have
the same unit. In the axis system DIAdem displays the rotation direction of the shaft and also the
position of the two sensors. If you specify a maximum bearing clearance, DIAdem shows this
limit as a curve or an ellipse in the axis systems.
Figure 3-3. Vibration Analysis in 2D-, Bode, and Shaft Centerline Axis Systems

© National Instruments Ireland Resources Limited

|

3-7

Chapter 3

Analyzing and Editing Data Graphically

Synchronizing Curves with Videos and Maps
In DIAdem VIEW you can simultaneously contrast different measurement data as curves and
also synchronize test data recorded on video and the recorded route of a test drive.

Evaluating Videos and Curves
Use the Video display type to evaluate data and videos which were recorded simultaneously.
DIAdem opens the dialog box for the selection of a video file. DIAdem supports the video
formats that have the filename extensions .avi, .mpg, .mpeg, and .wmv. If you want the video
to ignore the page ratio and fill the complete area, disable the setting Keep Aspect Ratio in the
context menu or when you load the video. To load a different video, select Select Video from
the context menu.
To view a complete video, use the operating functions on the DIAdem VIEW toolbar. DIAdem
does not enable the operating functions until you click a video area or a 2D axis system. To
inspect specific points or a period of time more closely, use the curve cursor in the axis system.
For example, if an unexpected event occurs in the test, move the curve cursor to the respective
curve points. DIAdem VIEW shows the video and the curve synchronized over time. Use the
plus and minus buttons or the mouse wheel to zoom in and out of the video view. If the video
has an audio track, you can also play the sound. To do so, select Sound On from the context
menu.

Synchronizing Videos and Data
DIAdem VIEW uses the time channel of the 2D axis system and the frame rate of the video to
synchronize videos and curves. When DIAdem loads the video file, DIAdem reads the frame
frequency and sets 0 as the start time. The start time specifies in seconds the time of the
measurement value in the first video frame. In most cases, for example, if you record the video
with a camcorder, you can apply these settings. Depending on the data acquisition rate, DIAdem
displays the same video frame for several measured values. For example, if the data acquisition
rate is 100 kHz and the frame rate is 1,000 frames per second (1 kHz), the video frame changes
at every 100th data point on a curve.
To change the start time and the frame rate, double-click the video area and open the
synchronization settings. If the time channel of the axis system returns an absolute time range
with the date and time, and not the measurement time of the test in seconds, you must convert
the start time into the internal DIAdem time format, which is the number of seconds that have
elapsed since the year zero. To do this, use the TTR command in the Calculator. If you run the
video or move the cursor in the axis system after you synchronize the video, DIAdem moves the
cursor synchronously to the video.
If the video time range is not the same as the time range of the measurement data, you must
specify the play range in which the measurement data overlaps with the video. To specify the
beginning and the end of the play range, position the band cursor on the time range, during which
the video was recorded, in the 2D axis system. Then click the Cursor Parameters button on the
toolbar and clear the Specify play range automatically checkbox. Click Apply below the
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cursor position to apply the positions of the band cursor for the beginning and the end of the play
range. If you now use the operating functions, the cursor moves in the axis system and only plays
the video within the play range.

Evaluating Maps and Curves
Use the Map display type to evaluate measurement data and geographical data simultaneously
recorded with a GPS receiver of, for example, a test drive. If your computer is online, DIAdem
loads the maps from OpenStreetMap. Right-click the map and select Display from the context
menu. Connect the map display with the recorded longitudes and latitudes, and the time channel.
During the evaluation, DIAdem moves the map so that the position marker is always visible in
the map section. In addition, you can show the route as a track.
You cannot move the position marker in the map section directly with the mouse. You can move
it only indirectly, for example, with the cursor in a 2D axis system. To synchronize the cursor,
enter the same channels in the axis system that you entered in the map section under cursor
synchronization. If the curve displays speed over time in the axis system, you synchronize over
the time channel. If the curve in the axis system displays the driven route, you synchronize over
the longitude or the latitude. You need only one channel for the synchronization of the curve
cursor, the maximum value cursor, and the minimum value cursor. For the free cursor you need
two channels.
You can enlarge, reduce, and move the displayed map section. To resize a map section, use the
scale displayed in the map or use the mouse wheel. Double-click the map display to enlarge the
map section around the clicked position, which DIAdem simultaneously positions in the middle
of the map section.
If you want to use a map display when your computer is offline, select the setting Save map data
in cache. DIAdem saves all map displays as graphics files on the computer. To display these
files, select the map type Cache in the offline mode. You can also use this map type to speed up
the map display because DIAdem can load the graphics directly from the computer.

3D Data Display
In DIAdem VIEW you can project data onto 3D models, display 3D data two-dimensionally
with colored isolines in contour displays, or as a waterfall with 3D curves. For example, use the
projection onto 3D models to display temperatures that occur on a component with color
changes. Use the contour area to display and to analyze characteristic diagrams of the engine
power over the rpm and the compression. Use a cascade display to, for example, display the
vibration amplitude over the frequency as a waterfall.
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Contour Display with Isolines
Use the Contour display type to display 3D data two-dimensionally by using the third
dimension of the data as color values and isolines. Use the contour display, for example, to map
data from engine test stands as characteristic diagrams and to analyze the data with the cursor.
To display a characteristic diagram, drag the channels Revs, Torque, and Nitric oxide
from the Data Portal and drop them in a free area of the layout. Select the display type Contour.
DIAdem displays the concentration of nitric oxide in relation to rpm and torque as a color
shading. The color legend below the contour indicates that the blue color hues represent a low
concentration and red color hues a high concentration. You can zoom in and out of a contour
display, move it and view sections in more detail with the frame cursor. The contour display
supports the triple structure used here and also the matrix structure of 3D data.
Refer to Organizing 2D Data and 3D Data in Chapter 2, Finding and Managing Data for more
information about 3D data.
Click the Display Dynamic Isoline button on the toolbar of the contour display to analyze how
the concentration of nitric oxides is distributed in the contour. If you move the cursor over the
contour, DIAdem displays the isolines dynamically for the concentration at the current cursor
position. To create an isoline permanently, click Create Isoline at Cursor Position on the
toolbar of the contour. DIAdem calculates the isoline for the current z-value of the cursor, saves
the result channels in the Data Portal default group, and then displays the respective isoline.
To highlight the concentration of the nitric oxide in the color shading, you can insert isolines into
the contour. To do so, you create a contour table. Double-click the contour and click the curve
type Contour. Select the curve parameters Isolines from contour table»Display and open the
Contour Table tab. Click Generate Isolines and enter the start value, the end value, and the
step width. To label the isolines with the concentration values, enable the curve parameter
Isolines from Contour Table»Label on the Surface tab. The contour displays gray isolines
with the concentration steps in the color shading.
Use Create and Refresh Channels for Intersection Curves on the toolbar of the contour to
place a horizontal and vertical intersection through the contour. DIAdem calculates the
intersections parallel to the x-axis and parallel to the y-axis for the current cursor position and
saves the four result channels in a separate channel group in the Data Portal. You can display the
calculated sections in 2D axis systems and synchronize them with the contour. If you move the
cursor in the contour or in one of the two axis systems, the two other cursors move
synchronously.
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Figure 3-4. Contour of the Nitric Oxide in PPM over RPM and Torque
with Vertical and Horizontal Intersection Curve

Cascade with Order Lines
Use the Cascade display type to display 3D data as a waterfall. DIAdem displays amplitudes as
consecutive curves and can also show order lines in order to highlight rotation speed-dependent
vibrations in the cascade.
You create order lines based on a channel. Double-click the cascade to select an order channel.
Afterwards, you create the order lines directly in the dialog box or use the functions on the
toolbar of the cascade display. Click Additional Order Lines in the dialog box and create one
or more static order lines by defining the orders. Click Display dynamic order lines on the
cascade display toolbar to show the order lines at the current cursor position. If you click
Generate order line at cursor line, a static order line displays in the cascade. DIAdem
calculates the order line for the current z-value of the cursor, saves the result channels in the Data
Portal default group, and enters the new order line into the curve list of the cascade.
Use Generate and refresh dynamic orderlines to show the order line curve in a dynamic
display in a 2D axis system. DIAdem stores the x-channel and the y-channel of the order line in
the Data Portal. Use these channels to define the curve in the 2D axis system. If you move the
cursor over the cascade, DIAdem displays the current order line in the cascade. At the same time,
DIAdem recalculates the values of the two channels and displays the refreshed order line curve
in the 2D axis system.
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Figure 3-5. Vibration Progress and Amplitudes over the Frequency and over the Order

Projecting Data onto 3D Models
Use the 3D Model display type to project measured data or data created with a simulation, as
color shading or as deformation onto a model of the test object. For example, 3D models display
the temperatures in a car as color shading on a temperature dummy or display strain as
deformation of a bridge support. You connect the data of each sensor to the associated model
point on the basis of the three-dimensional model of the test object. For model points with no
sensor, DIAdem interpolates the values from the data of neighboring model points. You also can
define several model windows with the same model in one view, to compare different
perspectives or test results.
For example, to inspect the temperature profile on a beam, select the display type 3D Model
from the area context menu. DIAdem VIEW opens the dialog box for the selection of a 3D
model. Load the model beam.wrl. Drag the Temperature1 channel from the Data Portal to
a model point. Select the display type Coloring. Repeat this process for other model points.
If you want to display deformations of the model surface, use the display mode Deformation.
Select on which coordinate axis DIAdem moves the model point.
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Use the operating functions on the DIAdem VIEW toolbar to gain an overall view of the
complete test. If you want to inspect time sections in more detail, create a 2D axis system with
the temperature channels and use the curve cursor in this axis system. For example, if extreme
temperatures occur in the test, move the curve cursor to the respective period of time. DIAdem
displays the temperatures on the beam in color. The red colors indicate warm areas and the blue
colors indicate cool areas.
If you assign a data channel to the incorrect model point, press <Shift> and drag and drop the
definition to the correct model point. Press <Ctrl-Shift> to copy a definition. The tooltip for a
point shows which display type and which data channel you used to define the point.
You can move and zoom the model to view it from all sides. To rotate a model, click and drag
the mouse. To zoom a model in or out, move the mouse wheel or right-click and drag
horizontally. To move the model along a coordinate axis, right-click, move the mouse up and
down, and press <x>, <y>, or <z> at the same time to choose the coordinate axis you want.
DIAdem supports VRML models with the filename extensions .wrl and .stl (Surface
Tesselation Language), which can export CAD/CAE programs.

Editing the Display
You can combine different display types for one model point in the model settings. For example,
you can display temperature simultaneously as color shading and as deformation. Double-click
the model to open the settings. Select the Sensor List tab to enable the coloring or the
deformation of the x-axis, the y-axis, and the z-axis for each model point. You can delete or copy
existing definitions and create new definitions.
Select the Display tab to modify the display of the base model and also the settings for the
surface coloring and the deformation. Use points, grids, and grid surfaces to specify the display
of the base model. Select the checkboxes Points»Channel values to show the current numeric
value at each defined sensor point. Specify the value range to which DIAdem applies the color
shading. By default DIAdem uses the highest and the lowest value of all assigned channels for
scaling. You also can scale the model manually, for example, to limit the coloring to the main
range, which eliminates outliers. You can also specify the color palette under user-defined
coloring.
If you enable deformation, DIAdem shows an offset copy of the model. During an evaluation
you can compare this deformation model directly with the unchanged base model. The offset
specifies the distance between the two models. If you only want to view the deformation model,
disable the settings for the base model. If you also want to show the coloring of, for example,
the temperature channels you defined in the sensor list, on the deformation model, select the
Color surfaces checkbox for the deformation model. To display even slight deformations, you
can use the scaling factor to enlarge the deformation.
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Interactively Evaluating with Dialog Boxes
Use the Dialog Box display type to influence the displays in the other areas of the layout during
an evaluation by entering values, requesting settings, or executing functions. Scripts process the
entries, transfer the values to the other areas in the worksheet, and refresh the display in DIAdem
VIEW.
You can include every user dialog box which you created in the dialog editor of DIAdem and to
which you added the invisible control VIEWConnector. Select the display type Dialog Box to
include a dialog box in an area. Load a dialog box file with the filename extension .sud and
enter the name of the dialog box because one SUD file can contain several dialog boxes.
DIAdem fills the entire area with the dialog box. To edit the dialog box, select Edit Dialog Box
from the context menu. DIAdem opens the dialog editor with this SUD file. Enter properties and
events, which influence other controls or call scripts, for every control. For example, you can
create scripts to move curve points in axis systems or to create new curves. After saving dialog
box changes, open DIAdem VIEW and select Reload Dialog Box from the context menu to
refresh the display.
Use the Flex property so that a dialog box dynamically adapts to the current size of the area.
You can assign different flex properties to the individual controls so that the position of the
controls change respectively when the area or the DIAdem window is scaled.

Using Text and Graphics for Design
Select the Textbox display type to add headings or comments to a worksheet. After
double-clicking the textbox, you can enter text and variable information, for example, the
current date with @@CurrDate@@. You can also select a property, such as the name of the data
set, in the Property Display of the Data Portal, and drag and drop the property to the textbox. Use
the context menu to refresh the variable contents at any time. Select Display from the context
menu to modify the text display and use the button with the three dots at the end of the input field
to insert variables and expressions. Refer to the section on Variable Formatting in Chapter 5,
Creating Reports, for more information about variables.
Use the Graphic display type to include a diagram of a test stand or to insert a company logo
into your worksheet. Double-click the image area to load a new image. DIAdem supports the
current image formats.
When you insert graphics, DIAdem generates a link to the graphics file. DIAdem saves the link
with the path in the layout. When you load a layout, DIAdem only can display the image if the
image file is in this folder. To use a layout on different computers, use DIAdem path variables,
such as @@LayoutReadPath@@ImageFile.jpg.
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You can use DIAdem ANALYSIS to analyze data from the Data Portal with mathematical
functions. The dialog boxes for the standard mathematical functions guide you through the
calculation so that you do not have to enter a formula. You select the input data and the settings.
Use the DIAdem Calculator to define and calculate your own formulas. For complex, recurring
calculations, you can write scripts. In the calculation manager you define complex analysis
sequences which can be standard functions, user-defined formulas, and calculation scripts. Save
the calculation results in channels or in variables.
Figure 4-1. DIAdem ANALYSIS

Using Standard Functions
DIAdem ANALYSIS has extensive libraries with standard mathematical functions in several
function groups. For example, the basic mathematical function group contains the differentiation
function, the signal analysis function group contains the FFT function, or the 3D analysis
function group contains contour line calculation.
To use a standard function, click the associated button. You select the calculation settings in the
dialog box that opens. The preview shows the result curve with the settings in contrast to the
curve with the unchanged input data. For example, if you want to smooth data, select the Curve
Fitting function group and click the Smooth function. Drag and drop the Channel that you want
to smooth from the Data Portal into the channel selection field in the dialog box. Specify Max.
smoothing width on one side (no. of points) and the smoothing procedure. If you have already
used the smoothing function in your current work session, the last calculation settings appear in
the dialog box. Click Calculate if you want to execute more smoothing functions. Click OK to
execute the calculation and to close the dialog box.
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Figure 4-2. Curve Fitting Function Group

DIAdem stores the calculation result in new channels of the default group. You specify the
default group in the context menu of the Data Portal structure view. If you select Store result in
original channel in the dialog box of a standard function, DIAdem overwrites the values of the
input channels with the result data. Do not select this setting if you want to use the input channels
again. Some standard functions, such as descriptive statistics or approximation store the
calculated characteristic values as custom properties in the result or input channels.
If you call another standard function, DIAdem prompts you to apply the function to the result
channels of the last calculation. You can use all the numeric channels, waveform channels, and
time channels in the Data Portal to execute calculations. The DIAdem ANALYSIS workspace
shows you which calculations you have run with which channels. Click Export ANALYSIS
Log on the toolbar to save the work log.
If a standard function, for example, the average channels function processes several channels,
the channel selection field has a button with three dots. Click this button and select all input
channels in the channel selection dialog box or select the input channels in the Data Portal and
drag and drop these channels into the channel selection field. If the channels are different
lengths, the result channel is the same length as the shortest input channel.
If you execute calculations with waveform channels, you do not need to specify an x-channel,
because the waveform channel contains the x-part. If a standard function uses several channels,
only one channel must be a waveform channel for DIAdem to create waveform channels as the
result. If you do specify an x-channel, the results of the calculation are numeric channels. If you
use several waveform input channels, the x-parts of the waveform channels must correspond.
Which functions libraries you can use depends on which options your DIAdem license has.
Functions not included or enabled in your license are dimmed on the DIAdem interface. You can
obtain additional function libraries from NI. For further information on the available function
libraries, refer to Function Libraries in this chapter.

4-2

|

ni.com

NI DIAdem: Data Mining, Analysis, and Report Generation

Calculating Formulas in the Calculator
Use the Calculator to calculate data with your own formulas. In formulas you can combine
numeric channels, waveform channels, and time channels and generate new channels. You use
the text operations for calculating with text channels. You can calculate single values, save
values in variables, and request variable contents.
Open the Calculator on the toolbar in DIAdem ANALYSIS. The Calculator can stay open while
you execute other calculations in DIAdem. You can hide the configurable function keys and only
use the basic functions.

Entering Formulas
Use the keyboard and the Calculator keys to enter a formula in the Formula field. The result
field displays the formula expression of your entry. If there is an error such as a missing closing
parenthesis in your entry, DIAdem identifies this with a red frame in the formula expression. If
the formula entry is correct, click Calculate. The Calculator displays the calculation result.
A formula consists of the assignment target, the assignment operator, and the calculation
statement:
Assignment target = Calculation statement

You usually enter a channel as the assignment target. However, you can also calculate a single
value and assign the single value to a variable. In the calculation statement you use operations
on channels or variables. The standard functions contain operations such as exponential or
comparison operations and the extended functions contain operations such as sine function or
the maximum value of two numbers.
For example, click the sin button in the extended mode, to calculate the sine values of a channel.
The cursor in the Formula field is automatically positioned in the argument section of the sine
function, so that you can drag and drop a channel from the Data Portal correctly into the formula.
In the Calculator, always use a decimal point as the decimal separator and enclose strings in
quotation marks ("...").

Calculating with Channels
For example, to divide the Input channel by the Reference channel from the first channel
group, enter the following formula in the Calculator Formula field:
Ch("[1]/Result") = Ch("[1]/Input")/Ch("[1]/Reference")

DIAdem divides each value of the Input channel by the corresponding value of the
Reference channel. If the channels are different lengths, the result channel is the same length
as the shorter channel.
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DIAdem stores the result in the Result channel in the first channel group. If the Result
channel already exists in the first channel group, DIAdem overwrites the values. If you enter
only the channel name without the group index, DIAdem stores the result channel in the default
group of the Data Portal.
In order to calculate with channels in the Calculator, the channels must have a unique reference.
If you drag and drop channels from the Data Portal into the Calculator, DIAdem uses the Ch
variable and sets the channel name in quotation marks. DIAdem uses the group index and the
channel name to create a unique channel reference. However, a channel reference can also
consist of the group name or the group index combined with the channel name or the channel
index. The group index is the position of the group in the Data Portal and the channel index is
the position of the channel in the group.
If you know the names of the channel groups and of the channels of the data set, and if the name
of the first group is Group1, enter the following formula:
Ch("Group1/Result") = Ch("Group1/Input")/Ch("Group1/Reference")

If you know the structure of a data set, you can combine the group index and the channel index.
Then enter the formula as follows:
Ch("[1]/[5]") = Ch("[1]/[1]")/Ch("[1]/[2]")
Note You can also use only the channel name for the channel reference. This
channel reference is ambiguous if several channels in different groups of the Data
Portal have the same name. DIAdem calculates with the first channel it finds with the
specified name in the Data Portal.

Calculating with Variables and Single Values
In the Calculator, you can store values in variables, use variables in calculation statements, and
request variable values. The following examples show how you enter these three alternatives,
for example, for the auxiliary variable R1 in the Formula field:
You assign the result of the square root of 8.391 to the variable R1:
R1 = sqrt(8.391)

Use the variable name to request the value of a variable. The Calculator displays the value in the
result box:
R1

You multiply each value of the Input channel from the first channel group by the R1 variable.
DIAdem stores the result values in the Result channel of the default group:
Ch("Result") = Ch("[1]/Input")*R1
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Assigning Buttons and Exporting Formulas
In the Calculator you can assign the buttons in the extended mode with the functions you need
regularly for your formula calculations. Click Configure Function Buttons in the Calculator to
view all configurable function buttons. In this dialog box, you select an operation, edit the button
label, and describe the function in a tooltip. The Calculator functions are described in the
DIAdem Help.
Use the Calculator to test formula expressions for the Calculation Manager and for scripts. In the
preview you can check whether the syntax of the formula expression is correct. The success or
failure of the calculation also shows whether the channel references, for example, are correct. If
your formula is correct and returns the right result, you can export the formula. Click Formula
Transfer to Calculation Manager to open the Calculation Manager, which will contain your
formula as a new calculation. Click Prepare for SCRIPT and Copy to Clipboard to insert the
formula as a code line in a script.

Calculating in Scripts
Use scripts to automate complex, recurring calculations. In scripts, you can call standard
functions or create your own formulas. A script is a VBS file that DIAdem processes line by line.
To enter the following examples, create a new script in DIAdem SCRIPT and enter the sample
lines. Refer to Calculating Formulas in Chapter 6, Automating Sequences, for more information
on scripts.

Calling Standard Functions
In scripts, you can use all the standard mathematical functions available in DIAdem. Use the
Call command to call standard functions. For example, to smooth the numeric channel Input
with a smoothing width of 12, and to store the result in the Result channel in the first channel
group, enter the following line in a script:
Call ChnSmooth("[1]/Input","[1]/Result",12,"maxNumber")

Calculating Your Own Formulas
In scripts, you can also calculate your own formulas. For example, to divide the Input1 channel
by the Reference channel from the first channel group, enter the following statement in a line
of the script:
Call Calculate("Ch(""[1]/Result"") =_
Ch(""[1]/Input"")/Ch(""[1]/Reference"")")

Use Call to call the Calculator function Calculate. The formula is in single quotation marks
and the individual channel assignments are in double quotation marks. The formula has the same
syntax as in the Calculator.
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Assigning Single Values
In scripts, you can assign values to variables like in the Calculator. For example, to assign the
square root of 8.931 to the auxiliary variable R1, enter the following line in a script:
Call Calculate("R1=sqrt(8.931)")

Using Variables
DIAdem offers program variables, auxiliary variables, and user variables. You can use VBS
variables as well as DIAdem variables. Refer to the section on Using Variables in Chapter 6,
Automating Sequences, for more information about variables.
Use program variables to configure the command of a standard function in a script. You set the
parameters in the same way as you make settings in the dialog box for the standard function. The
SmoothWidth program variable specifies the smoothing width for the ChnSmooth command
of the standard function Smooth.
Use VBS variables in scripts if you need variables that are not linked to a command. Unlike
DIAdem, VBS does not provide predefined variables or data types. VBS variables are always a
variant data type, which uses different data types depending on what you use the variable for. A
VBS variable reacts like a number when you use the variable in a calculation and like a string
when you assign text to the variable.
Declare VBS variables with the Dim statement. The following example shows the declaration
for the array variable MyArray, for the text variable MyChannels, and for the count variable
iCount. This example generates a matrix with the 100 x-values and the y-values of the sine
function and converts the matrix into channels:
Dim MyArray(1,99), MyChannels(1), iCount
For iCount = 0 to 99
MyArray(0,iCount) = 2*Pi*iCount/99
MyArray(1,iCount) = Sin(2*Pi*iCount/99)
Next
MyChannels(0) = "X Channel"
MyChannels(1) = "Sine Channel"
Call ArrayToChannels(MyArray,MyChannels)

Quantity-Based Calculations
Since the introduction of the units catalog, you can choose whether DIAdem includes the
physical quantities and units of the channels in a calculation or not. In non-quantity based
calculations, DIAdem uses only numeric values in the calculation, so that you can add a length
and an electric voltage. When executing quantity-based calculations, DIAdem checks whether
the selected physical quantities can be processed together. For example, you can divide a time
by a length but you cannot add these quantities. If DIAdem cannot calculate the physical
quantities with each other, DIAdem aborts the calculation with an error message.

4-6

|

ni.com

NI DIAdem: Data Mining, Analysis, and Report Generation

If two units to be calculated with each other belong to the same physical quantity, for example,
centimeter and inch, DIAdem converts the units to the joint base unit. For example, if you add
1 cm (centimeter) and 1 in (inch), the result is 1.39 in. If you do not execute the calculation
quantity-based, the result is the numeric value 2.
Click Calculate Quantity-Based on the DIAdem ANALYSIS toolbar or assign in scripts the
value TRUE to the CalcQuantityBased variable to calculate quantity-based with the units
catalog.
To calculate quantity-based in DIAdem, all input data must have units and unit symbols defined
in the units catalog. In operations, such as addition, subtraction, or average, DIAdem does not
change the physical quantities but transfers these to the result data. These functions cannot
calculate different physical quantities with each other, such as length and electrical voltage. In
operations such as multiplication, differentiation, integration, exponential functions, or root
functions, DIAdem determines the result quantity from the physical input quantity. For example,
if you multiply a force by a length, the result quantity is energy.
When calculating a quantity, DIAdem follows certain rules. The dimension of the result quantity
must have integer exponents. For example, you can extract the square root of a surface and gain
a length. However, you cannot calculate the square root of a volume, because this calculation
results in a non-integer exponent in the dimension. DIAdem specifies the unit of a physical
quantity in such a way that a minimum of conversions is required. If the units used are non-linear
or have an offset, DIAdem always converts these units into a linear unit. For example, the units
°C (degrees Celsius) and °F (degrees Fahrenheit) have an offset. Therefore, DIAdem uses the
base unit K (Kelvin) when these temperatures are included in a calculation. Refer to Using the
Units Catalog in Chapter 2, Finding and Managing Data, for further information about the units
catalog.

Calculating with the Calculation Manager
In the calculation manager, you define calculations to execute recurring analysis sequences with
a mouse click. A calculation can contain simple formulas, standard functions, or scripts. An
analysis sequence can connect calculations if a calculation step accesses the result of a different
calculation step.
Open the Calculation Manager on the DIAdem ANALYSIS toolbar. Click Add Calculation to
create a new calculation, or click the button with the three dots to edit an existing calculation.
A calculation connects inputs and saves the result in outputs. Inputs and outputs might be single
values and variables, or one or several channels. The inputs and outputs are connected in the
Calculation through their names, which might be just letters. The following formula squares and
adds the inputs a and b and transfers the square root to the output c:
c=sqrt(a^2+b^2)

You use standard functions the same way as you do in a script. Click Extended to switch to the
script input. Call a command with Call and use the names of the inputs and outputs as
© National Instruments Ireland Resources Limited
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parameters. The following instruction calculates the smoothing function for input a and returns
the results to output c:
Call ChnSmooth(a,c,15,"MaxNumber")

If you calculate functions, such as averaging over more than one channel, use a channel list. A
channel list contains the names or indexes of the input channels. In the Data Portal, you can
select individual input channels as well as several input channels that are one below the other,
which DIAdem enters into the channel list.
You can execute a calculation multiple times. If you want to analyze a test series of engine
cylinders, you do not have to define a calculation for each cylinder but just one calculation with
variable inputs and outputs. In an input you write Cylinder_@@CCR@@ and enter the number
of cycles. DIAdem replaces the expression @@CCR@@ with the current cycle number every time
a cycle executes. DIAdem evaluates the channels Cylinder_1, Cylinder_2, and
Cylinder_3 in three cycles.
Before you use a calculation, click Validate to check whether the definition is correct. DIAdem
checks the syntax of the calculation instruction and the connection with other calculations if you
set these as the input or output. In the validation script, you can specify further conditions for the
execution of the calculation. Click OK to return to the calculation manager dialog box. Create
calculation groups to group dependent calculations or to sort calculations according to their
tasks.
You can save selected calculation groups or calculations, or all calculations defined in the
Calculation manager in a calculation set with the filename extension .tca. If you want to make
a formula collection available to other users without revealing any know-how, save the
calculations encrypted. Other users can only execute encrypted calculation templates but not
view or change them.
Select Settings»DIAdem Settings»ANALYSIS in DIAdem ANALYSIS to specify the
calculation set that DIAdem loads when the program launches.

Calculating with Invalid Values
Measurement devices have a valid range for the measured values, for example, from 0 to 10
volts. During measurements, disturbances sometimes occur in the sensors, causing incorrect
values. In DIAdem you can declare these outliers as invalid values. In DIAdem, invalid values
are called NoValues. To identify a value manually as a NoValue, overwrite the value in the
channel table of DIAdem VIEW with NoValue or with NV for short. Standard functions exclude
NoValues from calculations and a report does not display NoValues. The following figure shows
the measurement signal on the left and the result of a classification of the measurement signal
on the right. The top diagrams contain the distortion, whereas the bottom diagrams have been
adjusted with NoValues.
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Figure 4-3. Left the Measurement Signal, and Right the Result of the Classification,
Top with Distortion and Bottom Adjusted with NoValues

You can use NoValues to eliminate entire ranges, not just single values, from a numeric channel,
a waveform channel, or a time channel. If you know that a sensor does not return values greater
than 10, enter the following formula into the Formula field of the Calculator in order to replace
incorrect values with NoValues:
Ch("Group1/Sensor") = Ch("Group1/Sensor")+ _
CTNV(Ch("Group1/Sensor")>10)

The Boolean request Ch("Group1/Sensor")>10 checks whether a channel value exceeds
the specified limit value 10. If a channel value exceeds the limit, the result is True, otherwise
the result is False. The CTNV function checks the results and returns NoValue for True,
otherwise it returns 0. The result of the addition with a channel is either the original channel
value or NoValue. This replaces all values greater than 10 with NoValues.
If you calculate with NoValues, a calculation operation results in NoValue
when one of the terms has the value NoValue.
Note

Tip You can use the Process NoValues function in the Channel Functions
function group to delete NoValues in channels, to replace NoValues by a value, or to
replace NoValues through linear interpolation of the neighboring values.
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Function Libraries
DIAdem includes an extensive library of standard mathematical functions for analyzing data.
These functions are arranged by category in the DIAdem ANALYSIS function groups:
•

Basic Mathematical Functions

•

Channel Calculation Functions

•

Curve Fitting Functions

•

Signal Analysis Functions

•

Statistics and Classification Functions

•

3D Analysis Functions

•

Crash Analysis Functions

Basic Mathematical Functions
The Basic Mathematics function group contains the functions Add, Subtract, Multiply, and
Divide, for calculating two or more channels rowwise. If the channels are different lengths, the
result channel is the same length as the shortest channel. Use the Rounding function to reduce
the number of decimal places of the channel values. Use the Remove Duplicates function to
reduce the sections with successive identical channel values to the first value. The Scale function
uses the linear equation ax+b to convert channels. If you need the reciprocal of each channel
value, use the Calculate Reciprocal function. Use the Offset Correction function to subtract a
constant from the channel values or to add a constant to the channel values.
Use the Normalize function to normalize a channel to the value 1. To do this, DIAdem divides
each channel value by the highest absolute value in the channel. The Relativize function
calculates for each channel value the percentage of the total sum of all channel values. The
Calculate Differences function calculates the distances between the values of a channel so that
the result channel is one value shorter than the input channel. You use the Summation function
to calculate the consecutive sum of the single values of a channel.
The Differentiate function calculates the difference quotient from two successive value pairs of
two channels. Use the Integrate function to integrate a channel on the basis of the trapezoidal
rule or the Simpson rule. The Calculate RMS function calculates the root mean square.

Channel Calculation Functions
The Channel Functions function group contains the function Generate Numeric Channel,
which generates new equidistant or geometric channels, or new channels from the x-part of a
waveform channel. You can use this function to partition existing channels more finely. DIAdem
partitions the intervals of successive values into equidistant intervals. The Generate Time
Channel function calculates an equidistant time channel.
Use the Numeric Channels <-> Waveform Channels function to convert numeric channels
and waveform channels. If you convert numeric channels to waveform channels, you must
specify an equidistant x-channel. If you convert waveform channels into numeric channels,
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DIAdem creates an x-channel and a y-channel from every waveform channel. If waveform
channels are located consecutively in a group in the Data Portal, and if they have the same x-part,
DIAdem creates one common x-channel for these channels.
Use the function Numeric Channels <-> Assignment Channels to create or to delete
assignments in channels. Assignments are texts which are assigned to a value range of a channel,
for example, Valve open for the value range 5...10 [bar]. Click the button with the three
dots to open the Assignments property of an assignment channel in order to edit and to extend
the assignments.
The Convert Channel Unit function converts a channel into a different unit of the same
quantity, for example, kilometers per hour [km/h] into miles per hour [mi/h]. The Convert
to Unit Set function assigns a different unit set to multiple channels and converts the channels
to the units of the new unit set. If you load a European unit set, DIAdem only needs a unit set
with American units to convert the lengths, the surfaces, and the velocities of a data set into
American units.
The Average Channels function calculates rowwise the arithmetic mean of two or more
channels. The Sort Channel Values function sorts the values of a channel in ascending order.
You can also specify other channels, such as text channels, to move the values of these associated
channels accordingly. DIAdem offers two functions to determine the peaks in a channel. Use the
Find Peaks function to find channel peaks which match the channel values. Use the Calculate
Peaks function to calculate, for example, peaks for a noisy signal by interpolating the channel
values. Both functions provide two result channels. One result channel contains the x-values and
one the y-values of the peaks.
There are two functions for the event search. Use the Event Search function to check channels
for window, slope, or comparison conditions. You can connect several conditions with AND and
OR, and negate the condition with NOT. Use the Event Search (Free Formula) function with
a free formula, and check channels for specific events. You can use comparison operators such
as < and >, and Boolean operations such as AND and OR in formulas. DIAdem stores the search
result in a two-dimensional array variable.
The Process NoValues function deletes NoValues in channels or replaces NoValues with a given
value or with a linear interpolation of the neighboring values. NoValues are invalid values which
DIAdem does not use for calculations and does not display in a report. Use NoValues to
eliminate corrupt measurement values from channels. Refer to Calculating with Invalid Values
in this chapter for further information about NoValues.
The Optimize Data Type function rounds the channel values to reduce the necessary storage
space when saving the data. DIAdem saves the relative rounding error and the storage saving in
the custom properties of the result channels. Use the Quantize function to divide the value range
of channels into intervals of equal width in order to map the channel values on these intervals by
rounding. Usually the number of steps corresponds with the integer data types 8-bit, 16-bit, or
32-bit.
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Use the Phase Unwrap / Wrap function for displays in the Bode diagram in order to handle
jumps in the phase. You can create or delete phases within a value range of -π ... +π or of
-180° ... +180°.
Use the following functions to create a joint time base for signals of different measurements. The
Resampling function specifies the new x-value range through an interpolation channel or a
sampling rate. Use the Synchronize Data from Different Files function to resample or to delete
an offset. The Linear Mapping function maps a signal onto a different x-channel through
interpolation and extrapolation.

Curve Fitting Functions
The Curve Fitting function group contains the Smooth function for smoothing a signal. To
smooth a signal, DIAdem calculates the floating arithmetic mean or median for each value from
the channel value and from a specified number of neighboring values. The Savitzky-Golay
Filter smoothes a signal by adjusting a polynomial function sectionwise to the signal with the
least squares method. This method retains the characteristics of the signal better than the Smooth
function.
Use the functions Regression and Approximation to calculate a curve with the closest
resemblance to the original set of points according to specific criteria. The preview in the dialog
box displays for each setup function how well the result approximates the channel values. For
the result curve, you can specify a channel with evaluation points or you can generate the
evaluation points. DIAdem saves the calculated coefficients in program variables and as custom
properties in the result channels.
Use Non-Linear Curve Fitting to fit a set of points with a function. DIAdem uses the
Levenberg-Marquardt algorithm to calculate the coefficients. Use the Gaussian Curve Fitting
function to fit a set of points with a Gaussian curve. DIAdem uses the least square method, the
least absolute residual method, or the bisquare method to calculate the center, the amplitude, and
the standard deviation of the Gaussian curve. Use General LS Linear Fitting to calculate a
k-dimensional curve by minimizing the error squares. DIAdem offers various methods, such as
SVD, Givens, Cholesky, or Householder to solve the over-determined system of equations.
DIAdem uses Non-Parametrical Splines, Parametrical Splines, or Akima Subsplines for
spline calculations. Use non-parametrical splines for function type curves that have strictly
monotonic interpolation points. Use parametrical splines for not strictly monotonic interpolation
points, for example, for closed curves. An Akima subspline calculation results in not
continuously differentiable curves, which are especially suited for stair functions. You can use
splines to interpolate or to approximate interpolation points.
Use the Calculate Circle Approximation function to calculate the regression circle, the
incircle, and the circumcircle of a set of points in a Cartesian coordinates system. The maximum
incircle, also called the fitting-in circle, is the largest circle within the set of points that does not
contain a measured point. The minimum circumcircle, which is also called the envelope circle,
is the smallest outer circle around the set of points that contains all the measured points. The
centers of these extreme ideal circles do not have to be the same. They are independent of the
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center of the regression circle. However, the concentric incircle and circumcircle have the same
center and constitute an annulus with the least possible width that still contains all measurement
points.
The Calculate Envelope Curves function specifies the upper and lower envelope of a set of
points. The minimum and maximum values in the specified intervals determine the points of the
envelope. The Calculate Corridor function calculates the tolerance band with a specified
distance to the original curve and the Check Corridor function checks whether a curve is within
a corridor.

Signal Analysis Functions
The Signal Analysis function group contains functions such as the fast Fourier transform, digital
filters, frequency-weighted acceleration, shock response spectrum, and order analysis with
which you examine the frequency parts of oscillations.

Fast Fourier Transform (FFT)
Use FFT to transfer signals from the time domain to the frequency domain and back. For
example, each button you press on a telephone makes a different sound, each of which consists
of two sine oscillations. The exchange receives this sound and can detect which number you
dialed. In the time domain, the sound you create when you press the number nine is difficult to
distinguish from the number five. The exchange runs an FFT on the received sound, because the
sounds can be clearly distinguished in the frequency domain.
In DIAdem you can calculate the FFT with One Time Signal, the Inverse FFT for
retransformation from the frequency domain into the time domain, and the FFT with Two Time
Signals for the cross spectra and the transfer function. DIAdem calculates an FFT for the entire
length of the specified channels, even if the channel length is not a power of two. The Full
Spectrum FFT function executes various separate FFT analyses for the channels of the two
vibration sensors, and a rotating shaft then connects the spectra to a complex FFT.
Use the Third/Octave Analysis as part of a FFT (One Time Signal) to examine the volume in
frequency intervals, not the exact frequency distribution in the signal. The third/octave analysis
sums up the amplitude values in the FFT for a time signal in standardized logarithmic frequency
intervals, similar to the following figure.
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Figure 4-4. Third/Octave Analysis of a Signal

Correlations and Shock Response Spectrum
The Auto Correlation moves a signal copy on the time axis to monitor whether a signal has
periodic parts. The Cross Correlation uses the same method to check two different signals for
similarities. The Shock Response Spectrum (SRS) function describes the reaction of a system
to a shock by calculating the acceleration from an acceleration signal over time, the relative
velocity, or the relative displacement of the system over the frequency. The function includes
the damping degree of the component. For example, if you let a cell phone fall to the ground, the
degree of destruction is different for different cell phones. Use the shock response spectrum to
evaluate the damage to the cell phones.

Vibration Characteristics and SINAD Analysis
The Characterize Oscillation function specifies the single frequency of the greatest amplitude
in the complete or in the limited frequency domain of the signal. The function displays the
frequency, the amplitude, and the associated phase as the result.
The SINAD Analysis (Signal to Noise and Distortion) function calculates the ratio of the total
signal power to the distortion signal power and returns a measurement for the transmission
quality of a signal. The total signal power at the receiver input results from the wanted signal,
noise, and distortion. The higher the value, the better the transmission quality is. The SINAD
analysis is used, for example, in radio systems (AM and FM).
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Digital Filters and Frequency Weightings
With the Digital Filter function, you can attenuate or amplify selected frequency ranges of a
time-dependent signal. You can choose from various filter types, such as lowpass, bandpass, and
bandstop, which transfer only certain frequency ranges of the signal. The allpass filter, which
lets through all the frequencies, is for signal delay and correcting phase distortion. You can use
the various filters as IIR filters and FIR filters.
If, for example, a high-frequency distortion signal interferes with the actual measurement signal,
you can filter out the distortion. To do this, enter the highest frequency in the useful part of the
signal as the limit frequency for the Lowpass filtering mode. The lowpass filters out all the
distortion frequencies above this limit.
The Frequency Weighting (A-, B-, C-Filtering) function executes digital filtering of a
time-related signal in relation to frequency weighting curves. The frequency weightings A, B,
and C describe the frequency-related sensitivity of the human ear to different acoustic pressures.
The Frequency-Weighted Acceleration functions calculate the extent to which measured
vibrations affect the human body, in vehicles and at the workplace. For example, to test the
extent to which vehicle vibrations affect drivers, you can mount various vibration sensors on the
seat and use the Frequency-Weighted Acceleration function to analyze the measured
acceleration signals.

Order Analyses
Use Order Analysis to analyze noises and vibrations that are measured on engines and engine
components. In engine run-up tests, the relation between vibration and RPM is more important
than the relation between vibration and time.
The Order Analysis functions compare the frequencies in a signal to a reference frequency. The
calculated order specifies the multiple from the measured signal to the reference frequency. For
example, the second order means that the analyzed frequency is double the reference frequency.
As shown in the following figure, you can run order analysis in the time domain or in the
frequency domain.
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Figure 4-5. Results of Order Analysis as FFT Spectrum and Order Spectrum

The Order Analysis for Bode Display calculates the amplitude and the phase position of the
shaft vibrations, which you display over RPM in a Bode diagram in DIAdem VIEW.

Vibration Analyses of Rotating Shafts
The AC/DC Coupling determines the unbalance of a shaft by correcting the shaft movement of
the orbit by the changes of the shaft position. The Shaft Centerline function calculates the
movement of the shaft center in the bearing box and provides the data to identify whether the
bearing clearance is critical. The Pulse Detection function analyzes the tachometer signal
measured on the shaft and returns the corrected time points of the pulse. This function and the
functions Full Spectrum FFT and Order Analysis for Bode Display are used for analyzing
rotating shafts or for starting and stopping a turbine in order to recognize changes early and to
thereby prevent damage. To do so, two vibration sensors offset by 90° measure the vibrations of
the engine shaft.
Analyze the results interactively in DIAdem VIEW, as shown in the figure in section Orbit and
Shaft Centerline Axis Systems.
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Statistics Functions
The Statistics function group contains the Descriptive Statistics function for calculating the
characteristic statistical values, such as the mean, the quantile, and the dispersion values. You
can calculate the statistical characteristic values rowwise for several channels, for one entire
channel, and for channel sections.
For example, you can test the pressure resistance of concrete. You run pressure tests on 25 blocks
and measure the pressure under which the blocks crush. From the test results, you calculate the
arithmetic mean, the standard deviation, and the lowest and highest pressure. DIAdem saves the
calculated characteristic values in the custom properties of the input channels. You can drag and
drop these custom properties into DIAdem REPORT in order to document the current statistical
values in the report. In the dialog box, you can also enable the storage of results for each
characteristic value in separate channels.
Use the Process Capability function to specify the process capability indexes Cp, Cpk, CpL,
and CpU. You also can calculate the mean values and the standard deviations from the process,
and various approximations for the number of incorrect parts. DIAdem stores the calculated
characteristic process values in the appropriate variables and in custom properties of the input
channels.

Classification Functions
The Statistics function group contains classification functions for determining frequency
distributions for measured values. DIAdem divides the value range into classes, and counts how
many measured values each class contains. DIAdem calculates histogram classification, single
classification, reducing classification, compound classification, and Rainflow classification.
For example, you want to compare a series of engine tests on test rigs and in road trials. You
select the required oil changes as the criterion. You count the oil changes per thousand
kilometers and classify your results. The following figure presents the counts as a curve and the
classification results as a histogram.
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Figure 4-6. Classifying Two Test Series
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In a Histogram Classification you select the method with which DIAdem determines the
classes to classify a channel. In Single Classification you also select the one-parameter
classification method with which DIAdem classifies random oscillations. You can use the
sample count, peak value count, time-at-level count, range count, or range pair count.
If you want to classify one or more channels that depend on the signal, but not the signal itself,
you can use Reducing Classification. Compound Classification classifies two related
channels simultaneously, not just one channel. The result of a compound classification is a
3D matrix.

Rainflow Classification
Rainflow Classification tests signals, in particular strain-time functions, for special events, such
as overshooting strain levels, or strain changes.
If you test the duration of a spring, for example, you prepare a test schedule that subjects one
hundred springs to oscillations ranging from 10 Hz to 10 kHz. You count the number of strain
runs until the spring breaks. In the rainflow matrix, you enter the strain runs in relation to the
oscillations.
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3D Analysis Functions
The function groups 3D Basic Functions, 3D Arithmetic, and Surfaces contain 3D analysis
functions for processing measurement data for a 3D display. DIAdem calculates the contours
and the boundary curve from engine data for a characteristic diagram of an engine, as displayed
in the following figure.
You can organize 3D data as triplets or as matrices in DIAdem. DIAdem executes the Calculate
Contour Lines function with data in matrices or in triplets. DIAdem requires a matrix structure
for 3D displays such as 2D matrix, contour lines, or waterfall displays. To display a 3D curve,
DIAdem requires a triplet structure.
Figure 4-7. Characteristic Diagram with Isolines for Engine Performance and Fuel
Consumption over RPM and Compression

The 3D Basic Functions include functions for converting the triplet structure into the matrix
structure and vice versa (Convert Matrix). Use the functions Create Submatrix, Append
Matrix, or Sort Matrix to process matrices. The Transpose Matrix function interchanges the
rows and columns of a matrix.
The 3D Arithmetic function group contains functions for calculating matrices. Use
Matrix-Matrix Operations to add, to subtract, to multiply, or to divide matrices. Use the
Matrix-Vector Operations to multiply a matrix by a vector algebraically or componentwise.
Use Matrix-Scalar Operations to add a constant to a matrix or to multiply a constant by a
matrix. The Normalize function normalizes elements of a matrix to the range [-1,1]. DIAdem
divides all matrix values by the highest absolute value in the matrix. Use the Relativize function
© National Instruments Ireland Resources Limited |
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to calculate what part of the total sum of all matrix elements each element in a matrix is, as a
percentage. Use the Summation function to summate the values in a matrix in rows and
columns.
The Integrate function calculates the volume under a surface that is given by a matrix. DIAdem
calculates the integral by adding up the volumes of all the partial rectangles in the xy-grid. The
Calculate Extreme Values function calculates the minimum values and the maximum values
in a matrix.
The Surfaces function group contains the Interpolate function that approximates
three-dimensional data with an interpolated surface, and the Approximate function which
approximates a surface for three-dimensional data with the error square method using a setup
function. The interpolated surface runs exactly through the points of the three-dimensional data.
The approximation function minimizes the distance between the surface and these data points to
create a smoothed surface.
The Calculate Contour Lines function connects the points with the same height on a surface.
If the three-dimensional data is in a matrix structure, DIAdem creates a grid of rectangles. If the
three-dimensional data is in a triplet structure, DIAdem uses a triangulation as the basis to
calculate a surface for the contour lines. You can calculate contours for the entire grid or for a
subsection.
Use the Calculate Convex Hull function to calculate a convex or a non-convex hull for a set of
points. The convex hull encloses the points as a closed polygon. The non-convex hull also
encloses the set of points, but is indented.

Crash Analysis Functions
The Crash Analysis function group contains functions for analyzing measurement data from
vehicle safety tests. You can use the functions to calculate standardized injury criteria. For
example, use the Head Injury Criterion to assess head injuries, the Neck Injury Criterion for the
neck area, the Viscous Criterion for the chest area, and the Tibia Index for the leg area.
The calculations are executed according to the current SAE, ISO, and NHTSA specifications.
For digital phaseless filtering, you can choose from CFC60, CFC180, CFC600, CFC1000, and
FIR100.
The example Crash Evaluation Based on the MME Standard shows an analysis of test data
for vehicle safety, in a report. You can start this application example in the DIAdem help. This
example uses a script to guide you through the analysis of a front or side impact, in three steps.
The following figure shows the report for head acceleration in frontal impact.
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Figure 4-8. Crash Analysis of the Head Acceleration in a Frontal Crash for the Head
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You use DIAdem REPORT to create multi-page reports of data and events. You can use
two-dimensional and three-dimensional axis systems, polar axis systems, tables, text, variables,
formulas, and graphics to document and to present data.
Figure 5-1. DIAdem REPORT

Worksheet Design
Report worksheets can have various displays and changing page orientation. You save the
design of all the worksheets of a report and the links to the report data, in the layout file. You
can reuse stored layouts as templates for similar reports.
To display data as curves in a 2D axis system, for example, open the 2D Axis Systems function
group and click the Simple 2D Axis System button. A small rectangle appears next to the cursor.
Click and drag open a frame at the position where you want to insert in the 2D axis system in the
worksheet.
Figure 5-2. 2D Axis Systems

To display a curve, drag and drop a channel from the Data Portal into the axis system. DIAdem
REPORT displays numeric channels with the index and waveform channels with the x-part.
Click the x-channel Time in the Data Portal to display the temperature over time and then the
y-channel Temperature. Drag and drop these channels into the axis system.
To display one or more channels with the same x-channel, first click the x-channel Time in the
Data Portal. Then press Ctrl and click the numeric y-channels, for example, Pressure,
© National Instruments Ireland Resources Limited
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Temperature, and Revolution. Drag and drop these four channels into the axis system.
DIAdem REPORT displays the pressure, the temperature, and the rpm as curves over time. If
you drop a channel group onto an axis system, DIAdem selects the first channel in the channel
group as the x-channel. If you drag and drop several waveform channels onto an axis system,
DIAdem displays each waveform channel over its x-part.

If you want to display a curve over a text channel, select from the Data Portal a text channel that
contains, for example, the names of the months and a numeric channel that contains, for
example, the monthly precipitation and drag and drop these channels onto the axis system.
DIAdem REPORT displays the precipitation over the months and labels the x-axis with the
names of the months that the channel contains.
To create another worksheet, double-click the tab on the right side of the name of the last
worksheet. To create a new worksheet with the layout of the current worksheet, right-click the
tab with the name of the worksheet and select Copy from the context menu. Use Manage from
the context menu to change the order of the worksheets and to rename and delete worksheets.
To insert worksheets from an existing layout, select File»Append Layout. In the Manage
Worksheets menu, you can select several worksheets and delete them from the report. Use the
filter function to find and display a specific worksheet.
You can print reports, or you can export a report as a graphic file, an HTML file, a PDF file, an
XPS file, or a PowerPoint file. To save the current worksheet as a graphic in one of the common
formats, click Export on the toolbar and select Graphics Export. To save the entire report as
an HTML file, select HTML Export. DIAdem creates an HTML file with the names of the
graphics files created in each worksheet. To save the report as a multipage PDF file, DIAdem
uses the PDF printer driver. With MS Windows 10, you can use the Windows PDF printer if you
enable the setting Create PDF files with Microsoft printer under Settings»DIAdem
Settings»REPORT. From Windows version 7, you can save the report as an XPS file. PDF and
XPS files are formats that are independent of platforms and therefore retain the fonts, graphics,
and formats on every operating system. If you want to save the report as a PowerPoint
presentation, MS Office with PowerPoint must be installed on your computer. Under
Settings»Layout Setup»Layout Parameters you can add custom properties to a report, for
example, the name of a test sequence, in order to search for this property with the DataFinder.

Using the Chart Wizard
Use the Chart Wizard to display data in 2D axis systems or in polar axis systems. In three steps
you select the type of diagram, specify the channels with the data to be displayed, and specify
the display.
If you enable the preview, DIAdem shows how each setting you make in the Chart Wizard
affects the worksheet. If you click Finish, DIAdem applies the settings to create a new
worksheet or a new axis system. If you click Cancel, DIAdem restores the original status.
You can open the Chart Wizard at several points in DIAdem REPORT. If you want to create a
new worksheet, open the Chart Wizard from the DIAdem REPORT toolbar. If you want to
display the channels selected in the Data Portal, open the Chart Wizard from the context menu
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of the Data Portal. If you want to insert a 2D axis system or a polar axis system in a worksheet,
open the Chart Wizard in the 2D Axis Systems function group or the Polar Axis Systems
function group. If you want to edit a 2D axis system or a polar axis system, open the Chart
Wizard from the context menu of these axis systems.

Editing Objects
You can position and resize objects such as axis systems, tables, text, graphics, and lines
anywhere in the worksheet. As soon as the cursor idles on an object, DIAdem displays a blue
frame for you to identify which object you select when you click. To resize an object, click the
object. DIAdem selects the object and frames the object with a dashed line that has small squares
in the corners and at the sides. Drag the squares at the sides to change the width or the height.
Drag the squares at the corners to resize the object while maintaining the proportions. Press
<Ctrl> at the same time to change the size but keep the center.
You can select several objects and move and resize them together. You can align selected objects
to each other and align the size of the objects. The dashed frame around the object group is the
reference point for DIAdem. To make an axis system and a table the same width, click the
Alignment button on the toolbar and select Width. If the table is below and to the right of the
axis system, the axis system provides the left edge and the table provides the right edge for the
joint width.
Most objects consist of several subobjects, such as axes, axis text, and curves. You can select
and edit each subobject. You can move a selected axis text, format the text with the format bar,
or double-click the text to open the dialog box where you can change the text.
You can edit the common properties of several selected objects. If you select an axis text and a
heading, you can change the font for both texts on the format bar simultaneously. However, if
you select an axis system and a text, for example, you cannot configure the objects because the
objects do not have any common properties.

Displaying Objects
You can superimpose axis systems, tables, text, and graphics in a worksheet. The superimposed
objects are visible because the backgrounds are transparent. To highlight a text in an axis system,
select White for the text background.
DIAdem displays objects in the order that you insert the objects into the worksheet. The new
objects are in the foreground. You can change the order for each object. To position a new
graphic behind an existing axis system, for example, right-click the graphic and select Move to
Background from the context menu.
Use the Preview in the dialog boxes to view the settings directly in the worksheet. To do so,
move the dialog box on the monitor or hide it altogether except for the title bar. To do so, click
the arrow in the title bar next to Close.
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Numeric Formatting
Use format definitions to specify the display of numbers on axes and in tables. You select the
numbers you want to format in the worksheet and select the type of numeric display in the dialog
box. To format the numbers in a table, double-click the numbers in a column. DIAdem opens
the table definition on the Column Properties tab. To use a format definition, click the button
with the three dots, which is next to the format entry field. Select, for example, Number as the
category and set 2 as the number of decimal places. DIAdem displays the numbers in this
column as decimals with two places after the decimal point. You can also display the numbers
as exponential, binary, or hexadecimal numbers, or as a percentage,
To format time data, use the categories Date, Time, or Date/Time. Select a Region to specify
whether the date and the separators are displayed according to the European, Japanese, or to the
North American standards. To adapt a format, complete the following two steps. Select the
format definition closest to the format you want, for example, June 01 in the Date category.
Stay in the dialog box and select the category User-defined. Change the format #ttt YY to
#ttt YYYY and check the Preview to see whether DIAdem displays the date with a four-digit
year.

Variable Formatting
Use the Str function to display formatted numeric variable contents. For example, to display
the current median value with four decimal places, enter the following line in a report:
@@Str(StatMedian,"d.dddd")@@
The Str function converts the numeric contents of the StatMedian variable into text. The
format definition d.dddd rounds off to the fourth decimal place. For DIAdem, the @@ characters
indicate a variable expression.

Formatting with User Commands
Use user commands, for example, to display data in a special format unknown to DIAdem. You
define user commands in DIAdem SCRIPT. Refer to the section on Defining User Commands
in Chapter 6, Automating Sequences for more information about user commands.
The following figure displays the same data in two axis systems that have x-axes in different
formats. The top axis system displays the time in hours, and the bottom axis system displays the
time in days after 5,000 hours. The user command CalcTime from the UserCmdReport.vbs
script creates the second formatting. The format specification for the x-axis in the
bottom axis system contains the following command call with CFV (abbreviation of
CurrentFormatValue) for the value to be formatted:
@@CalcTime(CFV,CAxN)@@
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Figure 5-3. User Commands Format the Time Axis

To execute user commands when the report refreshes, select Settings»Layout Setup»Layout
Parameters»Events and enter user commands as Commands to be executed. User commands
can format axis systems and tables, and can also read information from databases and execute
calculations.

Editing Layouts
You save the descriptions of all the worksheets of a report in a layout file with the filename
extension .tdr. The layout file contains descriptions of all objects, such as axis systems, tables,
or text, and the data links. You can change or delete data assignments in the dialog boxes for the
axis systems and tables.
By default, DIAdem uses the channel name and the group index to assign the data channels in
the report. This works well if the channels in the evaluated data files always have the same name
and are always in the same channel group. If the channel group is not always at the same position
in the data files, but the group always has the same name, the channel assignment can also
consist of the group name and the channel name. A report can also include channel references
that consist of the group name or the group index and the channel index. Specify the
name-oriented channel assignment under Settings»DIAdem Settings»General.
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If you enable curve expansion in the layout parameters, DIAdem displays the curve of the first
matching channel pair in a channel group and also the curves of all channel pairs with the same
name in all channel groups with an entry in the curve definition. After you define the channel
assignment for an axis system, DIAdem searches the Data Portal for the first channel that has
the specified x-channel name, such as Time. When DIAdem finds the x-channel, DIAdem
searches for the associated y-channel Speed in the same channel group. In the expansion mode,
DIAdem searches to the end of the Data Portal for other Time and Speed channel pairs in the
other channel groups. Select Settings»Layout Setup»Layout Parameters»Display»Curve
Expansion to specify the attributes for each curve display.

Creating Templates
Specify the layout on the various tabs in the layout setup. Specify the size and orientation of the
worksheets and also the outer frame and a background color on the Worksheet tab. If you add
further worksheets to the report, DIAdem uses these global settings for the new worksheets. You
can change, for example, the orientation of a worksheet under Settings»Layout Setup»
Worksheet Parameters. Use the portrait format for tables, but keep the landscape format for
diagrams in the other worksheets.
Create a master layout to match the appearance of reports to your corporate design. While you
create your report, the master layout remains in the background and cannot be modified. To
create a master layout, select File»Master Layout»New. A master layout consists of a
Landscape Master and a Portrait Master. Design a master layout with graphics such as logos
and sketches, with frames and lines, and with text such as the author, date, or test number. These
details all appear on each sheet of a report. You can also use variables to automatically include
the current date or the name of the data set. Select File»Master Layout»Save As to save the
master layout with the filename extension .tdrm. Go to Settings»Layout Setup»Layout
Parameters and select Master Layout to add a master layout to a report. Click Select Master
Layout to load a master layout. Click Refresh Master Layout to apply the modified master
layout settings. Click Remove Master Layout to remove the master layout from the report.
You can use the layout file as a template for other reports that have data in the same structure. If
you select Settings»DIAdem Settings»REPORT, you can specify a template file in addition to
the start file that DIAdem REPORT displays when launching. DIAdem uses the template when
you select File»New to create a new report. The template can contain standard objects such as
axis systems and also a master layout.

Page Format
In DIAdem REPORT, you specify the page format as relative or as scaled. A relative page
format specifies the worksheet size as the height of the worksheet in relation to the width. Enter
the width of the printout in relation to the selected paper format in the print dialog box. The
DIAdem REPORT default settings specify a ratio of 0.7 for A4 landscape format or 0.77 for
letter landscape. Select User-defined as the page size if you want to change the ratio. If you
change the ratio, you move the objects in the report because you specify the position of the object
as the distance from the edge as a percentage of the width and the height of the worksheet.
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For scaled page format, select Settings»Layout Setup»Layout Parameters»Worksheet and
enter a fixed height and a fixed width for the worksheets. DIAdem always prints the worksheets
in the specified size, regardless of the paper format. If you select a scaled page layout, you can
scale an axis system manually to ensure that DIAdem always prints the same number of units
per centimeter, for example, 10 °C/cm.

Inserting Report Objects
In the function groups, DIAdem REPORT provides predefined objects that you can configure.
The following objects are arranged by category in the DIAdem REPORT function groups:
•

2D axis systems

•

Polar axis systems

•

3D axis systems

•

2D tables

•

3D tables

•

Text

•

Graphics

•

Circles, rectangles, lines, and arrows

Inserting Axis Systems
Axis systems display channels as curves and as bar diagrams. Use a 2D axis system to display
velocity over time as a curve. Use a polar axis system to display the sensitivity of a microphone
in a circle diagram. Use a 3D axis system to display a characteristic diagram of engine
performance over the rpm and the compression.

2D Axis Systems
Use 2D axis systems to display channels as two-dimensional curves or as two-dimensional bar
diagrams. You usually enter an x-channel and a y-channel for a curve. The x-channel is often a
time channel. You can also use any other channel as the x-channel, for example, the frequency
of a spectral analysis or a text channel with the names of the samples. DIAdem assigns the
corresponding y-value to each x-value. If the two channels are not the same length, the curve is
as long as the shorter channel. If you specify only the y-channel, DIAdem REPORT displays a
numeric channel with its index and displays a waveform channel with its x-part.
You can combine various display types in one axis system. To edit the display, double-click the
axis system. Click the Type column to open the dialog box with the curve parameters. Select a
display mode and configure the display on the respective tabs. Use a bar diagram to display a
statistical evaluation as a histogram. Numbers above the bars show the frequencies of the
individual results. A horizontal line in the axis system represents the arithmetic mean. Use a
curve display and error deviation to illustrate the reliability of the calculated results. DIAdem
displays error bars on one side and on both sides of the curve, for the x-values and for the
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y-values. Use a filled area to highlight the surface between two curves, which represents the
norm range of the test value.
Use the Coordinate display mode to highlight conspicuous points like outliers, and to add a
comment. To mark the highest value of a curve, right-click the highlighted curve and select Add
Curve Coordinate»Absolute Maximum from the context menu. DIAdem creates a comment
with the x-value and y-value of the maximum. Double-click the text frame of the comment and
enter a descriptive text. If you move the axis system or change its size, the comment arrow
continues to point to the maximum.
You can use colored background segments, for example, to display changed test conditions in
an axis system. To do so, double-click the axis system and select Background Segments on the
Axis System tab. Select two channels from which DIAdem reads the state and the position of
the segments, and specify the background color and the direction of the segments parallel to the
x-axis or the y-axis. If you specify several segments, specify the transparency of the color in such
a way that all colors are visible if the segments overlap.
Use graphics in a report to illustrate data in and next to axis systems and tables. In 2D axis
systems, you can connect the background graphics with the value ranges in such a way that
graphics are automatically adjusted to the axis scaling and axis units. To do so, click the three
dots next to the setting Background graphic on the Axis System tab in the curve and axis
definition dialog box. Enter the start and end values of the value range of the graphic including
the unit. Use the scalable background graphics to display, for example, geo data on a map or, as
shown in the following figure, to highlight the numeric values of a color spectrum with
appropriate color values. The background graphic shows a light spectrum in the range 400 nm
to 750 nm, which is visible to the human eye. The various axis systems display the different
sections of this light spectrum and DIAdem displays the part of the background graphic which
matches the respective value range.
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Figure 5-4. Axis Systems Showing Scaled Extracts of the Visible Light Spectrum
as Background Graphics

With automatic scaling, DIAdem REPORT displays the entire channel as a curve. Use manual
scaling to zoom a section. Open the Axis Parameters with a double-click on one of the two axes.
Specify the first and the last values to be displayed and select the scaling mode for the x- and the
y-axis respectively. The x-axis scaling and the y-axis scaling can differ, as is the case in a
semi-logarithmic display.
To scale an axis interactively, position the cursor above the scale of the x-axis or of the y-axis.
The cursor appears as a double arrow next to the scale. Rotate the mouse wheel to expand or to
shrink the scale. If you position the cursor at the center of the axis, you modify the scale at both
ends of the axis. If you position the cursor at the lower end or the upper end of the axis, you scale
the axis at the selected end, while the opposite end remains fixed. Right-click the axis and select
Scale Axis Automatically to restore the original value range for this axis.
One axis system can include several curves. You can define curves with the same x-channel or
with different x-channels. Use subaxes if the axis system contains y-channels that have different
value ranges and different units. Click New Subaxis Left or New Subaxis Right on the Axis
Position tab to display channels with different measurement units in one axis system. Assign a
y-axis to each curve on the Curve List tab.
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The following figure shows a separate subaxis for each test parameter in an engine test, because
the CO emission, fuel consumption, and exhaust temperature each have different dimensions.
Select all temperature channels in the Data Portal and drag and drop the selected channels onto
the bottom left y-axis. Then select the CO emission channels and drag and drop these channels
onto the top left y-axis. Each subaxis has a separate scale. If you enlarge or reduce the size of
subaxes, DIAdem REPORT adjusts the curves.
Figure 5-5. Engine Test Evaluation with Subaxes

Use the DIAdem units catalog to compare temperature channels that have different units such as
Celsius, Fahrenheit, and Kelvin in one axis system. The units catalog defines the different units
of a quantity and describes how DIAdem converts one unit into another unit. Double-click the
axis system and open the Axis Parameters tab. Click y1 Axis»Scaling in the tree display. Enter
for Unit the symbol °C for celsius from the units catalog, which opens when you click the three
dots at the end of the input field. DIAdem converts all the temperature channels into the unit
Celsius and hides all the channels that have other quantities. If you want to show this report to
American colleagues and customers, change the unit to degrees Fahrenheit °F. In the same way
you can specify the unit for the x-axis. Refer to Using the Units Catalog in Chapter 2, Finding
and Managing Data, for further information about the units catalog.
You can use curve transformations to edit channels before DIAdem displays the curves and
without DIAdem modifying the original data. To do this, create a script with the functions you
want to use, and register the script as a user command in DIAdem. To smooth a curve with a
curve transformation, for example, double-click a 2D axis system. Click the Enable Curve
Transformation button on the Curve List tab to display the column with this name. Click the
button next to the curve definition, and enter the user command CurveSmooth. When DIAdem
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refreshes the report, DIAdem smoothes the curve with the specified user function. Refer to the
section on Defining User Commands in Chapter 6, Automating Sequences for more information
about user commands.

Polar Axis Systems
Use polar axis systems to display curves in circle diagrams. Select one or two channels in the
Data Portal for a polar axis system. In channel pairs, the x-channel contains the angle and the
y-channel contains the radius.
The following figure shows different reception ranges for two microphones. The polar axis
system shows how the sensitivity of the microphones, which are positioned at the axis origin,
depends on the direction of the microphones. You can define polar axis systems as semicircles,
quarter circles, or with any angle from 0-360°.
Figure 5-6. Comparing the Reception of Two Microphones Placed in
the Origin of the Polar Axis System

As in a 2D axis system, you can interactively scale the amplitude with the mouse wheel,
depending on the position at which you move the cursor over the axis labeling.
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3D Axis Systems
Use 3D axis systems to display, for example, characteristic diagrams of engine power or
waterfall displays of order analyses. For further diagrams of these functions, refer to the
description of the Function Libraries in DIAdem ANALYSIS in Chapter 4, Analyzing Data with
Mathematical Functions.
To edit the display, double-click the axis system. Click the Type column to select a display
mode, such as surface, isolines, bars, spikes, 2D matrix, vector, or symbol. To edit the display,
click the button with the three dots and specify the curve parameters. Use the Coordinate
display mode to highlight conspicuous points, such as plateaus or outliers, and to add a
comment. When projecting onto a plane, you can set the coordinates interactively in the
context menu as you do in a 2D axis system .
The following figure shows a combination of several displays of a spiral in a 3D axis system. To
display the spiral as a 3D curve, select three channels in the 3D axis system dialog box. The
arrows on the spiral are vectors that display the force for each point on the spiral. The xy-plane
and the xz-plane show the spiral projections. You can specify the scaling, the labels, and the grid
display for each display plane. As in a 2D axis system, you can interactively scale the axis with
the mouse wheel, depending on where you move the cursor over the axis labeling.
Figure 5-7. Vector Display of a Spiral with Projections onto the Planes
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You can rotate and move 3D axis systems in the worksheet and move the coordinate planes. To
change the view of a 3D axis system, click the 3D axis system and rotate the axis system. To
move a 3D axis system, click outside the axis system, but inside the selection frame. If the mouse
cursor does not show interlocked circles with arrows, you can move the axis system. To move a
plane outwards, click the edge of the plane. As soon as the layer displays a blue selection frame,
move the layer outwards.
The data must be in a matrix structure for a waterfall display, a bar display, and a 2D matrix
display. In the dialog box for the 3D axis system, you select an x-channel, a y-channel, and as
many z-channels as the y-channel contains values. If DIAdem displays 3D curves, the data must
be in triplets, for which you select three channels. The display types surface, spike, symbol, and
characteristic diagram can display data in triplets and in matrices. You can use the 3D analysis
functions in DIAdem ANALYSIS to convert channels into a matrix or a triple value.

Inserting Tables
2D tables list the contents of all the channel types and variables. 3D tables display numeric data
as matrices. You can align a table horizontally or vertically.

2D Tables
Use 2D tables to list numeric channels, waveform channels, time channels, and text channels.
Drag and drop channels from the Data Portal into the table. Double-click the table to open the
table definition where you change the order of the columns, specify the display parameters, and
enter the headings. For long channels, you can specify the first value, the last value, and the step
width between the values to be displayed. To change the column widths or the height of the
headings, move the separators. To change the text attributes, select the column entries or
headings and select, for example, the font in the format bar. You can display data in ascending
or descending order, and convert units, for example, temperature channels from Celsius to
Fahrenheit, with the units catalog like in a 2D axis system.
To display long channels in total, select Auto increasing as the table length on the Scaling tab
in the table definition dialog box. This defines a table that lists the channel contents on several
sheets. Use the functions of the Table Navigation on the DIAdem REPORT toolbar to scroll the
pages of the table.
You can also display scalar variables and vector variables in a 2D table. Click the Table
Columns tab, select Variable as the data type, and enter the variable name. If you enter the
CurrDate scalar variable in the dialog box, the current date appears in the top row of the table.
If you enter the CD vector variable, DIAdem displays the units of all the channels in the Data
Portal, in the table column.
Use the text lists in 2D tables to display texts and expressions separately from channels in tables.
Select the Text list data type on the Table Columns tab. Create as many rows on the Column
Properties»Text List tab as you need for entering your text. Click the button with the three dots
to insert variables and expressions. Always set double @ characters at the beginning and at the
end of each variable. DIAdem saves these text lists with the report layout.
© National Instruments Ireland Resources Limited |
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3D Tables
Use 3D tables for numeric display of the matrix structure of 3D data. Enter an x-channel, a
y-channel, and the first z-channel of the matrix structure, in the 3D table definition dialog box.
The following figure shows how a 3D table assigns the associated z-value to each xy-value pair.
Figure 5-8. 3D Tables Assign the Associated Z-Value to Each XY-Value Pair
Pressure (mbar)

Concentration (mol/l)

Temp. (°C)

0.01

0.06

0.11

0.16

0.22

0.27

0.32

0.37

0.00

0.09

0.10

0.07

0.03

0.01

0.00

0.00

0.00

0.05

0.14

0.19

0.11

0.03

0.01

0.02

0.02

0.01

0.10

0.15

0.33

0.11

0.00

0.02

0.08

0.05

0.03

0.15

0.07

0.08

0.01

0.10

0.03

0.09

0.13

0.12

0.20

0.04

0.03

0.17

0.31

0.14

0.07

0.15

0.26

0.25

0.13

0.21

0.43

0.63

0.26

0.06

0.25

0.41

0.30

0.21

0.37

0.45

0.39

0.16

0.14

0.37

0.55

0.35

0.17

0.20

0.16

0.07

0.03

0.27

0.50

0.65

The 3D table can display the entire matrix structure or a section. You specify the display
parameters such as font and display format for the x-values, the y-values, and the z-values. To
display 3D data in triplet structure, list the three channels in a 2D table, in which every column
contains one channel and every row contains one value triplet.

Adding Text, Comments, and Formulas
To create a text, you can use texts, text objects, or comments. Use text to create uniformly
formatted text such as titles, use the text object to create multiline text in different formats, and
use comments to place labels at prominent points in the worksheet. Use formula graphics to add
mathematical calculation instructions to the report.
All texts can include special characters, formula expressions and DIAdem variables, which
DIAdem refreshes with the rest of the report. For example, to display the current time, insert
@@CurrTime@@ in a text. The @@ characters indicate to DIAdem that CurrTime is a variable.
You can use user variables as well as program variables and auxiliary variables. Refer to the
section on Using Variables in Chapter 6, Automating Sequences, for more information about
variables.
Text
Use text to insert text, headings, or subtitles in a uniform format. Select Text»Text, click the text
cursor in the worksheet, and enter Ribs Left as the heading, as shown in the following figure.
If the text cursor is activated and you press <Enter>, DIAdem generates another line, where you
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enter the subtitle Dummy front left, Hybrid III 50%. To end the text entry, click
anywhere in the worksheet.
Use the format bar to format the selected text. To rotate text, click one of the squares at the
corners of the selected text and rotate the text to the right or to the left with the curved arrow.
Double-click a text to edit the contents.
Figure 5-9. Crash Test Report with a Heading and a Text Field

Text Objects
Use text objects to create a single text with different formats.
To create a text object, select Text»Text Object. DIAdem inserts a white field into the
worksheet. Double-click the text object and enter a text. The text object editor offers functions
for formatting single words and paragraphs. The functions for formatting are located on the
toolbar of the dialog box. Structure your text with list items, indentations, and paragraphs.
You cannot format text objects on the format bar; you can only format them in the text object
editor. You also define the font size differently for text objects than for text or for axis labels.
You specify the font size for the text object as absolute but the font size for the text as relative
to the worksheet. If you zoom text, you enlarge the text itself. However, if you zoom a text
object, you only change the layout, not the size of the text.

© National Instruments Ireland Resources Limited |
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Comments
Use comments to highlight key items in your worksheet. To create a comment, select Text»
Comments. Drag open a frame where you want to position the comment on the worksheet.
DIAdem creates an arrow with a text frame. Double-click the text frame and enter a text. Enter
the font size as an absolute value. Use the format bar in DIAdem REPORT to format comments.
If you anchor the end of the arrow, the arrowhead does not move when you move the comment.
To reposition the arrow, click the arrow and move the square on the arrowhead.
If you select and delete the arrow, you get a comment frame. Unlike text, a comment frame
remains the same size regardless of how much text you enter. If the text exceeds the frame size,
DIAdem wraps the text and only displays the text that fits in the frame.

Formula Graphics
Use formula graphics to add a mathematical formula to the report. To create a formula graphic
select Text»Formula Graphic and drag open a frame in the worksheet where you want to
position the formula. Double-click the formula graphic and enter the formula into the input field
on the Text tab. You can enter the formula as you do in the Calculator, for example, the square
root calculation as y=SQR(x^3). The preview shows the mathematical display of the formula
as it appears in the worksheet. You enter more complex formulas and expressions in the
Mathematical Markup Language (MathML) in which DIAdem saves the formulas in the report
file. You can frame the formula graphic and add an arrow. The size of the frame determines the
size of the formula display.

Adding Graphics, Lines, and Predefined Objects
Use graphics to include a diagram of a test stand or a company logo in your worksheet. You can
use the Graphics function group to load graphics in common formats. You can position graphics
behind axis systems and tables, because these objects generally have transparent backgrounds.
When you insert graphics, DIAdem generates a link to the graphics file. DIAdem saves the link
with the path in the layout. If you want to use a layout on another computer, embed the graphic
into the layout file. To do so, double-click the graphic and enable Embed graphic in layout
when saving.
Use frames to highlight a label text or a heading in the worksheet. To plot a frame with any page
ratio, select Circles and Rectangles»Rectangle. Drag open a frame anywhere in the worksheet.
Each worksheet has an outer frame. To hide the outer frame, select Settings»Layout Setup»
Layout Parameters and disable Display frame.
To insert a circle into the worksheet, select Circles and Rectangles»Circle. Drag open the circle
anywhere in the worksheet. To make an ellipse from a circle, disable the Force circle checkbox
in the circle dialog box. Then drag the squares at the sides of the frame to change the width and
the height.
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Use lines and arrows to partition the worksheet with lines or to indicate points in the worksheet
with arrows. The Lines and Arrows function group contains various types. For example, select
an Arrow and drag open a frame where you want the arrow to start, in the worksheet. You can
move the start point and the end point of the arrow with the mouse. To change an arrow into a
double arrow, select another arrow for the start point in the dialog box with the arrow settings.
To change an arrow into a line, select No arrow as the end point in the dialog box with the arrow
settings. To define a description field on the right side of the worksheet, click Continuous
Vertical Line, and to define a description field at the bottom of the worksheet, click Continuous
Horizontal Line.
The Predefined Objects function group contains predefined texts, for example, to add a page
number to the bottom of a report page or to add a heading. You can also add the date and the
time, the name of the report file, and the data file loaded in the Data Portal. If you created a
multipage report, click Table of Contents on New Page. DIAdem adds a new worksheet which
lists the page names of the worksheets included in the report. To add written text to the table of
contents, right-click the tabs of the individual pages and select Rename from the context menu.
As soon as you have finished the entry, DIAdem refreshes the text of the table of contents.
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Use DIAdem SCRIPT to combine steps for recurring processes, such as standard calculations
and serial evaluations in a script, in order to automate these processes. A script can use functions
from all DIAdem panels. You start a script when DIAdem launches, or with a button in a dialog
box, or with the DIAdem Scripts function group in any of the panels. You use control structures
and dialog boxes to create a flexible script for different data sets, analysis methods, and report
displays and equip the application with an individual interface.
Figure 6-1. DIAdem SCRIPT

Working with Scripts
The easiest way to create a script is in the recording mode. DIAdem records the commands for
each interactive step you execute. You can edit, test, and extend the recorded script. To record a
script, click the Enable Recording Mode button, on the DIAdem SCRIPT toolbar. Then
generate the script by interactively loading data or layouts, or executing calculations. DIAdem
SCRIPT records the actions as commands in the script editor. Use the shortcut <Ctrl-Shift-C>,
to add the settings from an open dialog box to the recorded script. To end the recording, click
Disable Recording Mode.

Editing Scripts
DIAdem displays the recorded script in a new worksheet in the script editor. Use functions such
as CodeCompletion, bookmarks, restoring, and find and replace, to make script editing easier.
The syntax coloring helps you to distinguish between comments, commands, and variables. You
can also distinguish methods and objects with their properties. If you want to change the syntax
colors or the tabulator width, select Properties from the context menu of the script editor. The
status bar of the editor displays the current cursor position, the insert or overwrite mode, changes
to the script, and a possible write protection.
If you position the cursor on a command, a variable, or the property of an object, the SmartInfo
displays the parameters of the command and the property, or the value range of the variable
followed by a short description. Click Display Help on This Subject in the SmartInfo to call
the Help for the command, the variable, or the property directly. If you enter the first letter of a
command, DIAdem completes the name or displays all commands, objects, and procedures that
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start with this letter. If you enter the name of an object and complete the entry with a dot, the
script editor offers the properties and methods that are available for this object.
The script editor contains keyboard shortcuts which make script editing easier. Use the shortcut
<Ctrl-D> to comment selected script lines and use <Ctrl-Shift-D> to convert comment lines
back to script statements. If you click next to an opening parenthesis, the script editor
automatically highlights the respective closing parenthesis. Use the shortcut <Ctrl-B> to jump
back and forth between the parentheses to check nested bracket terms.

Testing and Saving Scripts
To test the script that is visible in the script editor, click Run Script on the DIAdem SCRIPT
toolbar. That way, you can test whether the script is running without errors and is executing the
steps as expected.
If DIAdem does not execute the script correctly, use the script debugger to find errors in the
script. As soon as an error occurs, the debugger displays a green marker in front of the incorrect
script line. The error appears on the Logfile tab in the information area below the script. If you
want to view only the current error messages on this tab, you must first select Delete Logfile
View from the context menu. To monitor variables drag and drop a variable from the script into
the watch window of the information area. If you set breakpoints in the script, DIAdem displays
the contents of the variable.
Save the script for reuse. If you want to save several scripts open in the script editor, right-click
the tab and select Save All Files from the context menu. To execute a script you saved, without
loading it to the script editor, click Run Script From File. Assign frequently-used scripts to a
button in the DIAdem Scripts function group. This function group is available in all the
DIAdem panels, so you can start these scripts in each panel.
Figure 6-2. Script Function Groups Available in all Panels

You can also enter scripts in the DIAdem shortcut properties to start
sequences automatically when DIAdem launches. Refer to section Loading DIAdem
Configurations in this chapter, for information on automatically starting scripts.

Note

6-2

|

ni.com

NI DIAdem: Data Mining, Analysis, and Report Generation

You can save all files that you need for a project, as a workspace. To do so, load all files such as
the different scripts, variable definition files, and list files of the project and select File»Save
Workspace As to create a workspace. DIAdem saves workspaces with the filename extension
.wsp. To automatically load all project files, select File»Open Workspace to load a workspace,
or select Settings»DIAdem Settings»SCRIPT and specify a workspace as the default file.
You can encrypt scripts and User Dialog Boxes to use scripts on other computers without the
user being able to modify the script or the user dialog box. To encrypt scripts and user dialog
boxes, select Script»Encrypt VBS Script/SUD File and load the respective script or dialog box
file. DIAdem saves encrypted scripts with the filename extension .vbc and encrypted user
dialog boxes with the filename extension .suc. Refer to Creating User Dialog Boxes in this
chapter for further information about user dialog boxes.
By default DIAdem saves scripts in Unicode. Unicode characters include Chinese, Japanese, and
Arabic characters. Select File»Change Coding to save a script in ANSI format instead.

Creating Scripts
A script is a sequence of commands, formula calculations, and object definitions. You use loops
and branches to control the script. You can use comments, empty lines, and indentation to give
the script a clear structure.
Scripts are easier to read and to reuse if you keep to a few basic rules:
•

Write only one statement in each line of the script.

•

Use comments to describe the structure of the script and the commands you use. Start
comments with a single quotation mark (') and include them at any point in your script.

•

Insert an empty line to separate related statements.

•

Indent the statements for branches and loops, so that the beginning and the end of a
structure are in line and easier to identify. This is useful for nested structures. Use tabulators
and select Properties»Automatic Indent»Block from the context menu of the script
editor.

•

Combine recurring statements or a group of related statements, in procedures. Procedures
start and end with the keywords Sub and End Sub. To run a procedure, Call the
procedure name.

Executing Commands
You can use the commands from all the DIAdem functions in scripts. The recording mode
records the command for each function that you call in the interface, in the script editor. DIAdem
also includes commands that you only can use in scripts, such as the SQL commands for
communicating with databases.

© National Instruments Ireland Resources Limited

|

6-3

Chapter 6

Automating Sequences

You use Call to call a DIAdem command in a script. Enter the parameters, such as the channels
to be used and the selection terms for the calculation procedure, in parentheses:
Call ChnPeakFind("[1]/Time","[1]/Speed",_
"Results/PeakX","Results/"&_
"PeakY",5,"Max.Peaks","Amplitude")

The peak search command searches for the five highest amplitude peaks in the curves defined
by the channels Time and Speed and stores the results in the channels PeakX and PeakY. If
you do not specify a channel group for the result channels, DIAdem creates the two new
channels in the default group of the Data Portal.
Because channel names can occur multiple times in the Data Portal, we recommend that you
specify the group index with the channel name, for example, [2]/PeakX. If the channel group
does not always have the same number, enter the group name instead of the number, for example,
Results/PeakX. A unique channel reference that consists of the group name and the channel
name ensures that even with recurring channel names, the script returns correct results.
Note If the command parameters do not all fit into one line, use the _ sign as shown
in the first script line in order to generate a wordwrap in the parameter list of the
command. Use the string &_, if the word-wrap occurs within a multi-line text as
shown in the second script line.

To include one script in another script, use the command ScriptInclude. This command
registers all global variables, procedures, and functions of the subscript and initializes the
variables. Then you can access these variables, procedures, and functions in the main script.
The following example calls the script SubScript.vbs and accesses the procedure
GetChnName and the variable StrChannelName of the subscript. If you try to start the Call
SubScript.vbs subscript directly, an error message informs you that you cannot execute a
subscript.
Option Explicit
Call ScriptInclude("SubScript")
Call GetChnName(1)
Call MsgBoxDisp(StrChannelName)

Using Variables
Variables transfer parameters to commands, receive the results of mathematical calculations, or
control scripts. Program variables have a specific purpose in DIAdem and are usually used for
command parameters. You can name and use VBS variables in scripts as you wish. DIAdem
provides auxiliary variables and user variables for special purposes.
Unlike DIAdem, VBScript does not provide predefined variables or data types. VBS variables
are always a variant data type, which uses different data types depending on what you use the
variable for. A VBS variable reacts like a number when you use the variable in a calculation, and
a VBS variable reacts like a string when you assign text to the variable.
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Declare VBS variables with the Dim statement. The following example contains the declaration
for a numeric variable and a text variable. At the beginning of a script you can use the Option
Explicit command to force the declaration of VBS variables. This prevents the VBS from
automatically creating missing variables, which can lead to errors in the script and which are
difficult to detect, when, for example, MyVariable is spelled with a typing error
MyVariablel.
Option Explicit
Dim MyNumber, MyString
MyNumber = 12
MyString = "DIAdem"

Calculating Formulas
You can also use the formulas that you enter in the Calculator to calculate channels and single
values in scripts. DIAdem records the formulas with the complete syntax in the recording mode.
If you divide, for example, the Input1 channel by the Reference channel from the first
channel group and store the result in the new channel Result, DIAdem records the following
command line in the script editor:
Call ChnCalculate("Ch(""[1]/Result"") = _
Ch(""[1]/Input"")/Ch(""[1]/Reference"")")

DIAdem calls the Calculator function ChnCalculate with Call and calculates the formula
specified as the parameter. The individual channel assignments are set in double quotation marks
because these parameters are also text. Refer to the Calculating Formulas in the Calculator
section in Chapter 4, Analyzing Data with Mathematical Functions, for more information about
the formula syntax.

Controlling the Script Sequence
When you record a script, DIAdem works through the script line by line. Insert loops, branches,
and control commands to design a dynamic script.
Use loops to repeat statements. A loop repeats a group of statements until the loop counter
reaches a specified value. You can configure a loop with a Do While...Loop statement or a
For...Next statement. Use branches to execute different statements in relation to conditions. You
can create a branch with an If...Then...Else statement or a Case separator. If L1 is greater than
zero, the following branch smoothes the Speed channel with a channel length that depends on
the smoothing width:
If L1 <= 0 Then
Call MsgBoxDisp("No Calculation")
Else
SmoothWidth = trunc(ChnLength("[1]/Speed")/10)
Call ChnSmooth("[1]/Speed", "Results/Smooth_Speed", SmoothWidth)
End If

Use the Exit statement to abort the execution of a loop or of a procedure and use the With
statement to execute a series of statements on a singular object.
© National Instruments Ireland Resources Limited
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Use control commands to stop or to abort scripts. For example, the KeyWait command stops
the script until the user presses a key, and the Pause command stops the script for a specific
length of time.
Use the interaction mode to stop scripts and in order to work interactively with DIAdem. During
interaction, you can, for example, specify in the script a curve section for evaluation in DIAdem
VIEW. Use the InterActionOn command to enable the interaction mode in scripts. You can
add a text to the command which DIAdem displays in a dialog box. To execute the actions, move
the dialog box on the screen. To end the interaction, click the dialog box. If you do not add a text
to the command, click the End Interaction button on the toolbar of any panel to end the
interaction mode.

Creating User Interfaces
You can link scripts to dialog boxes in order to select calculation methods, to request entries, or
to load files. To configure a standard mathematical function before the calculation, call the
appropriate DIAdem program dialog box in the script. Use the DIAdem SCRIPT dialog editor
to create project-specific user dialog boxes for making entries and requests.

Calling Program Dialog Boxes
Program dialog boxes are standard DIAdem dialog boxes that you use in your script to, for
example, configure standard mathematical functions or to execute file operations. Click Help in
the dialog box and refer to the Script Call on the DIAdem Help page, for the complete name of
the program dialog box. To select the characteristic values of the descriptive statistics, use the
following script line:
Call SUDDlgShow("Main", ResourceDrv & _
"AnaChnStatisticsChannel_BlockCalc")

When the script calls the dialog box, you select the characteristic values and click OK. DIAdem
calculates the characteristic values, transfers the results to the associated program variables, and
continues to execute the script.
Use the FileDlgShow command to open the default dialog box for loading and saving files. To
load data files, add the following lines to the script:
Dim iCount
Call FileDlgShow(DataReadPath, "TDM Files (*.tdm),*.tdm | TDMS Files
(*.tdms),*.tdms", "Data selection", True)
If (DlgState = "IDOk") Then
For iCount = 0 To Ubound(FileDlgNameList)
Call DataFileLoad(FileDlgNameList(iCount))
Next
Else
Call MsgBoxDisp("Data loading was cancelled")
End If
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The FileDlgShow opens the folder that contains the data files and offers the TDM and TDMS
file formats for selection. The dialog box name is Data Selection. Because the last
parameter FileDlgMultiSelect=True enables the selection of several files, DIAdem
writes the names of all the files selected in the dialog box into the variable FileDlgNameList.
If you close the dialog box with OK, the DataFileLoad command loads the files specified in
FileDlgNameList into the Data Portal.

Creating User Dialog Boxes
You create user dialog boxes to enter values, to request settings, or to start functions. Use the
DIAdem SCRIPT dialog editor to create dialog boxes, which you save in a dialog box file with
the filename extension .sud. You call user dialog boxes in the script with the SudDlgShow
command. Include the dialog box name and the dialog box file. The call that opens the user
dialog box shown in the following figure is:
Call SudDlgShow("DlgEvalMain",ProgramDrv & _
"Examples\Documents\Crash_MMEEvaluation.sud")
Figure 6-3. User Interface for a Crash Evaluation

You can use events to connect the elements in the user dialog box with logical operations. The
figure above shows the main dialog box for a crash evaluation, in which DIAdem enables the
buttons one at a time after the appropriate steps. In the first step you load the test data and specify
whether you want to examine a frontal impact or a side impact. In the second step you evaluate
the selected data set. In the third step you select the display mode for the results.
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The dialog box file for this crash evaluation contains several dialog boxes. If you click the View
Values button, the script opens the dialog box DlgResults to display the calculated injury
criteria for the evaluated test.
Usually you close a dialog box to transfer the entries to the script and to continue the evaluation.
These are modal dialog boxes, which you open with the SudDlgShow command. DIAdem does
not continue the script until the user closes the dialog box. You can open user dialog boxes in
non-modal mode to obtain permanent user interfaces for extensive evaluations in order to control
the application. Use the SudDlgCreate command to open the dialog box in non-modal mode.

Defining User Dialog Boxes
To create user dialog boxes, call the dialog editor on the DIAdem SCRIPT toolbar or use the
templates in the Dialog Box Templates function group. If you need a user dialog box for
channel selection, click the Dialog Box Template for Channel Selection. Enter a name for the
dialog box definition, for example, MyDialog.sud. DIAdem loads the template into the dialog
editor.
Figure 6-4. Dialog Box Templates

The dialog box template for selecting channels contains two selection fields, a Cancel button,
and an OK button. In the dialog editor you can add other controls such as checkboxes, radio
buttons, selection lists, spin boxes, tables, or ActiveX objects. Use frames, text, and graphics to
design your dialog box. You can resize and reposition the controls and align them in relation to
each other. To use a dialog box in DIAdem VIEW, you must add the VIEWConnector
somewhere in the dialog box. The VIEWConnector is an invisible control with which the various
areas in DIAdem VIEW communicate.
If you want to include many input options in a dialog box, you can use the TabPageCtrl control
to create a multipage dialog box. Group the input options on several tabs according to a subject.
The dialog box for the curve and axis definition of a 2D axis system in DIAdem REPORT has
such tabs.
Use the Tree control to list elements hierarchically in a tree and to open branches with a click
on a tree node. Use the XTable control to assign controls such as buttons, checkboxes,
ComboBoxes, ListBoxes, or EditBoxes to each column of the extended table. To control the
contents of the extended table and of the tree, you use events because they make a dynamic
display possible.
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Every control has properties which you can change in the properties display of the dialog editor.
The properties are, for example, Color, Font, Title, or ToolTipText. The tabulator order specifies
the order in which controls are enabled when you use the <Tab> control to navigate the
dialog box.

Controlling User Dialog Boxes
You can control user dialog boxes with events. For example, you cannot enable the OK button
before the user enters values. The available events of a control are in the properties display on a
separate tab. You must specify appropriate commands for the procedures which the event calls.
Select an event on the Events tab in the first column of the properties display. To define this
event procedure, click the button with the three dots and open the editor which defines this event.
Click the Script View button to return to the dialog box view.
The EventClick event is linked to a button click. The Enable method activates a control. To
enable the CalculateButton by clicking the LoadButton, use the following script:
Sub LoadButton_EventClick(ByRef This)
CalculateButton.Enable = 1
End Sub

Saving and Testing User Dialog Boxes
To check the appearance of the dialog box, select View»Preview. To test the dialog box
functions, select View»Test in DIAdem. This function checks the variable definitions and the
event definitions of each control.
After designing and testing a dialog box, you save the user dialog box in a dialog box file with
the filename extension .sud. In a dialog box file, you can save several dialog boxes, so that all
the dialog boxes of a project are in the same SUD file. To add a dialog box to a dialog box file,
select Dialog Box»New. To copy and to delete dialog boxes, select Dialog Box»Dialog Box
Overview.
You can save parts of the user dialog box in the catalog window in the dialog editor. Select
View»Catalog to open the catalog. Select the dialog box controls that you want to save and
select Copy from the context menu. Then click the catalog window and select Paste from the
context menu to copy the selected controls from the clipboard to the catalog. You save the
properties and events together with the controls. You can save catalogs in a CAT file, create new
catalogs, and load catalogs.

Object Oriented Script Interfaces
DIAdem SCRIPT provides various object-oriented interfaces which you can use in scripts in
order to access DIAdem functions. Object-oriented programming interfaces define objects,
sub-objects, and collections of single objects. Use methods to create (Add) or to delete
(Remove) objects and use properties to change these objects.

© National Instruments Ireland Resources Limited
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You can only access certain objects such as VIEW and REPORT with a script if the respective
panel was already opened once before. To open a panel, use the WndOpen command with the
panel name.

DIAdem NAVIGATOR
In DIAdem NAVIGATOR you can use several objects to access external data stores, search
results, browser views, internal data, or Bus logfiles.

Finding and Loading External Data
Use the Navigator object to open external data stores, to mine data, and to load and to select
the data you find in the search results and in the file browser. Subobjects of the Navigator object
are external data stores, DataFinders, queries, search results, and browser views.
The following example executes an advanced search for channel groups with the name
Weather. The script enters the parameters for the query in the DIAdem NAVIGATOR interface

and lists the channels of the located channel groups, on the Search Results tab.
Dim oMyAdvancedQuery
Set oMyAdvancedQuery = Navigator.CreateQuery(eAdvancedQuery)
Call oMyAdvancedQuery.Conditions._
Add (eSearchChannelGroup,"name", "=", "weather")
oMyAdvancedQuery.ReturnType = eSearchChannel
Call Navigator.Display.CurrDataFinder.QueryForm._
SetCurrQuery(oMyAdvancedQuery)
Call Navigator.Display.CurrDataFinder.QueryForm.Search()
Call WndShow("NAVIGATOR","Open")

The following example searches in an ASAM data store. DIAdem opens the data store ASAM
Browse Settings Example and searches for all measurements with the name Torque. The
script enters the parameters for the query in the DIAdem NAVIGATOR interface and lists the
channels of the located measurements, on the Search Results tab.
Dim oMyStoreQuery
Call Navigator.Display.OpenDataStore("ASAM Browse Settings Example")
Set oMyStoreQuery = Navigator._
ConnectDataStore("ASAM Browse Settings Example").CreateQuery()
Call oMyStoreQuery.Conditions._
Add("MeaQuantity","Name","=","Torque")
oMyStoreQuery.Conditions.Logic = "C1"
oMyStoreQuery.ReturnType = "Measurement"
Call Navigator.Display.CurrDataStore.QueryForm._
SetCurrQuery(oMyStoreQuery)
Call Navigator.Display.CurrDataStore.QueryForm.Search()

To execute a quick search in a script, enter the search term in DIAdem NAVIGATOR in the
recording mode and press <Ctrl-Shift-C>. In the script editor you see the commands with the
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object names and the variable assignments for a search with or without the DIAdem
NAVIGATOR interface.

Changing the Data Portal View
Use the Portal object to specify the view of the Data Portal, to display channel groups, and to
select channels. The Data Portal can be fixed at the right edge or can be moved on the screen.
The structure view and the list view of the Data Portal are subobjects of the Portal object.
The following example enables the structure view of the Data Portal and downsizes the
properties window to 40 percent of the height of the Data Portal. After deleting all selections,
the script opens the first channel group and selects the third channel in this channel group.
Portal.Visible = TRUE
Call Portal.Structure.Activate
Portal.Ratio = 60
Call Portal.Structure.Selection.RemoveAll
Call Portal.Structure.Expand(Data.Root.ChannelGroups(1))
Call Portal.Structure.Selection._
Add(Data.Root.ChannelGroups(1).Channels(3))

Editing Internal Data
Use the Data object to edit, to delete, or to recreate data loaded in the Data Portal. You can
access internal data and the properties of the internal data in scripts. You can also change the
template for the custom properties or create a new template. Data sets, channel groups, channels,
data elements, properties, and the templates for custom properties are subobjects of the Data
object.
The following example first deletes all data loaded into the Data Portal and then creates the
channel group MyChnGroup with the channel MyChannel:
Dim oMyGrp, oMyChn
Call Data.Root.ChannelGroups.RemoveAll
Set oMyGrp = Data.Root.ChannelGroups.Add("MyChnGroup")
Call oMyGrp.Channels.Add("MyChannel",DataTypeFloat64)

Use the subobject CustomPropertyTemplate to access the template of the custom
properties. The following example line displays a message as to whether a template for the
custom properties has been created:
Call MsgBoxDisp(Data.Settings.CustomPropertyTemplate.Active)

Creating DataPlugins
Use the DataPlugin object to load, register, and search for additional file formats in DIAdem.
DataPlugins describe file formats so that DIAdem can read the associated data files through the
USI (Universal Storage Interface) interface. The Root object, the File object, the Store object,
and the Workbook object are subobjects of the DataPlugin object. The Root object provides the
collection of all channel groups and of all properties of a data file. The File object specifies the
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structure of text files and binary files. The Store object describes the transfer of a data model into
the TDM data model. The Workbook object supports the reading of files from table calculations.
The DataPlugin Wizard that you can open in DIAdem NAVIGATOR analyzes data files, creates
instances of the data model Root, ChannelGroups, and Channels, and fills these instances
with the information that has been read. Finally, the wizard registers this script as a DataPlugin
in DIAdem. The ni.com/dataplugins website offers DataPlugins for various file formats
created and tested by DIAdem programmers and by DIAdem users. In this user portal you can
make the DataPlugins you create accessible to other DIAdem users.
The following example reads in the values of the first page of a spreadsheet columnwise from
the second row of the first column and saves the values in channels of the first channel group:
Call Root.Properties.Add("Title",Workbook.WorkbookInfo.Title)
Call Root.Properties.Add("Author",Workbook.WorkbookInfo.Author)
Dim oCurrSheet
Set oCurrSheet = Workbook.Sheets(1)
Dim oCellBlock
Set oCellBlock = oCurrSheet.GetCellBlock(2,1)
Dim i, Name, oNewChannel
For i = 1 to oCurrSheet.MaxPosition.Column
Name = oCurrSheet.GetCellValue(1,i)
Set oNewChannel = oCellBlock.Channels.Add(Name)
Call Root.ChannelGroups(1).Channels._
AddDirectAccessChannel(oNewChannel)
Next

Converting Bus Logfiles
Use the BusLogToTDM object to convert bus log files from CAN, LIN, and FlexRay bus systems
into the TDM file format. To do so, enter the logfile you want to convert, the database file
you want to interpret, and a TCC file with the Bus Log Converter configuration. You can
also edit database files, add and delete buses, and specify clusters or XNET channels.
The following example reads in the logfile XNET_File2.tdms with the database file
XNET_TDMS.xml and saves the converted data packages in the TDM file XNET_File2.tdm.
Call BusLogToTDM.Clear()
BusLogToTDM.LogSettings.FileType = eLogFileTypeTdms
Call BusLogToTDM.LogSettings.LogFiles.Add("D:\XNET_File2.tdms")
BusLogToTDM.BusDbConfig.Name = "TDMSExample"
Call BusLogToTDM.BusDbConfig.Buses.Add("CANBus",0)
Dim oDbFile
Set oDbFile = BusLogToTDM.BusDbConfig.Buses("CANBus").DbFiles._
Add("D:\XNET_TDMS.xml")
oDbFile.IdMode = eDbFileIdModeDefault
Call oDbFile.Clusters.Add("HighBusLoad")
BusLogToTDM.ResultSettings.ResultFile = "D:\XNET_File2.tdm"
BusLogToTDM.ResultSettings.EnumSubstitution = True
BusLogToTDM.ResultSettings.SequenceChannel = False
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BusLogToTDM.ResultSettings.TimeFilter.Active = False
BusLogToTDM.ResultSettings.BusFilter.Active = False
Call BusLogToTDM.Convert()

DIAdem ANALYSIS
Use the objects CalculationSet, UnitCatalog, and LVRuntime to load and to execute a
calculation template, a unit set, or LabVIEW VI.

Calculation Templates
Use the CalculationSet object to load calculation sets, to validate individual calculation
groups, and to execute the corresponding calculations. The DIAdem calculation manager
differentiates between calculation sets, calculation groups, calculations, inputs, and outputs.
The following example loads the calculation set CalculationSet_Example.TCA, checks
the calculations in the group Noise pressure level, and starts the calculation.
Dim oCalc
Call CalculationSet.Load(sPathDocuments &
"CalculationSet_Example.TCA")
Set oCalc = CalculationSet.CalculationGroups("Noise
calculations").Calculations("Noise pressure level")
If oCalc.Validate Then
Call oCalc.Run
Else
Call MsgBoxDisp("The calculation can't be executed.")
End if

Units Catalog
Use the UnitCatalog object to load unit sets and to add, to edit, and to delete physical
quantities and symbols to a unit set. The units catalog in DIAdem consists of unit sets, physical
quantities, units, and the associated unit symbols.
If the unit set Basis is available, the following example generates the new unit Velocity,
including the symbol. If this unit set is not available in DIAdem, the script calls the input dialog
box of the units catalog.
If UnitCatalog.Sets.Exists("Basis") Then
Call UnitCatalog.Quantities.Add("Velocity",1,0,-1,0,0,0,0)
Call UnitCatalog.Quantities("Velocity").Units.Add("meter per”
“second","m*s^-1",1,0,"linear")
Call UnitCatalog.Sets("Basis").UsedQuantities.Add("Velocity")
Else
Call UnitCatalog.ShowSettingsDlg
End If
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LabVIEW VIs
Use the LVRuntime object to call LabVIEW VIs in DIAdem, to transfer values to VIs, to
execute VIs, and to call events and to display them in DIAdem REPORT.
The following script calls the LabVIEW Runtime Engine, loads the LabVIEW VI Test.vi,
and sets the input Input1. At the end, the script disconnects LabVIEW.
Dim sgRunTimeVersionT : sgRunTimeVersionT = ""
Call LVRuntime.Init(sgRunTimeVersionT)
Dim objVI
Set objVI = LVRuntime.LoadVI(AutoActPath & "Test")
Call objVI.SetControlValue("Input1","InputValue")
Call objVI.Run(true)
Set objVI = Nothing
Call LVRuntime.DeInit

To call a LabVIEW VI in DIAdem using the LVRuntime interface, LabVIEW does not need to
be installed on your computer. The DIAdem installation includes the LabVIEW runtime engine,
which you use to execute VIs. However, to create a VI you must install LabVIEW.

DIAdem VIEW
Use the View object to create, edit, or to delete worksheets, areas, axis systems, channel tables,
videos, 3D models, maps, contours, or dialog boxes in DIAdem VIEW.
The following example deletes all the worksheets in DIAdem VIEW and generates the new
worksheet MySheet. In the new worksheet, the script defines a 2D axis system for the
NewArea, and creates a curve in the axis system with Time as the x-channel and Speed as the
y-channel.
Dim oMySheet, oNewArea
Call View.Sheets.RemoveAll()
Set oMySheet = View.Sheets.Add("NewSheet")
Set oNewArea = oMySheet.ActiveArea
oNewArea.DisplayObjType = "CurveChart2D"
Call oNewArea.DisplayObj.Curves.Add("[1]/Time","[1]/Speed")
Call WndOpen("VIEW")

DIAdem REPORT
Use the Report object to create, edit, or to delete worksheets, 2D axis systems, 3D axis systems,
polar axis systems, 2D and 3D tables, text and formulas, lines and comments, circles and
rectangles, settings, and master layouts in DIAdem REPORT. You can also use the Report object
to change the general properties of DIAdem REPORT.
The following example generates a 2D axis system which displays speed over time as a curve.
Dim oMy2DAxisSystem, oMyPos, oMy2DCurve
Call Report.NewLayout()
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Set oMy2DAxisSystem = Report.ActiveSheet.Objects._
Add(eReportObject2DAxisSystem,"My2DAxisSystem")
Set oMyPos = oMy2DAxisSystem.Position.ByCoordinate
oMyPos.X1 = 20
oMyPos.X2 = 80
oMyPos.Y1 = 20
oMyPos.Y2 = 80
Set oMy2DCurve =
oMy2DAxisSystem.Curves2D.Add(e2DShapeLine,"MyNew2DCurve")
oMy2DCurve.Shape.XChannel.Reference = "[1]/Time"
oMy2DCurve.Shape.YChannel.Reference = "[1]/Speed"
Call Report.Refresh()

As in other DIAdem panels you can use the shortcut <Ctrl-Shift-C> in DIAdem REPORT to
copy the settings of an open dialog box, including the object hierarchy, to the clipboard or to add
them to the script in the recording mode. If you use this function in the Curve and Axis
Definition dialog box in an axis system, you add all objects used in the open dialog box
including their properties, methods, and current values to the script. To limit the recorded script
lines to the essential parts, select, for example, a curve in the worksheet before you press
<Ctrl-Shift-C>. When you change to DIAdem SCRIPT, you only copy the basic definition of
this curve into the script editor with <Ctrl-V>.

Assigning Properties to Documents and Graphics
Use the Document <Data> object to read, to set, or to add properties of office files in XML
format and of PDF documents or graphics in JPEG-, PNG-, and TIFF format. Every document
and every graphic contains base properties such as filename, description, title, author, and
storage date. Create a custom property such as TestSequence in the layout parameters of a
report. When you export the report, the PDF file or the graphic contains the name of the test
series.
You can read a base property and change the value. You can read a custom property and change
the value, and you can use a script to create and to delete a custom property. To do so, use the
OpenDocument command to open a PDF document or a graphic. The following example reads
the names and the values of the properties of a PDF document and displays them in a message.
Dim oMyDocument, oMyProperty, sOut
Set oMyDocument = OpenDocument(ProgramDrv &
"Manuals\DIAdem_GettingStarted.pdf", True, eDocumentTypeAuto)
For each oMyProperty in oMyDocument.Properties
sOut = sOut & "Name: " & oMyProperty.Name & ", Value: " &
oMyProperty.Value & VBCrLf
Next
Call MsgBox(sOut)
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Extended Program Interface
DIAdem provides various objects for adding functions to function groups, toolbars, menus, and
context menus, or for the configuration of user dialog boxes.

Function Groups and Toolbars
Use the BarManager object to change menus, toolbars, and function groups, or to create new
menus and function groups. You can create, copy, and delete buttons and menu entries. Use
Reset to restore the delivery status.
The following example creates the new function group My Function Bar with the button My
Function in the group bar in DIAdem SCRIPT. Then the script saves the bar definition
MyBarManager.
Call BarManager.Reset()
Dim oMyFct, oMyFctBar, oMyFctBarPopup, oMyBar
Set oMyFct = BarManager.ActionObjs.Add("MyFct","CustomButton")
oMyFct.ToolTip = "My function"
oMyFct.OnClickCode.Code = "Call MsgBoxDisp(""My new function"")"
Set oMyFctBar = BarManager.Bars.Add("MyFctBar")
Call oMyFctBar.UsedActionObjs.Add(oMyFct)
Set oMyFctBarPopup = BarManager.ActionObjs._
Add("MyFctPopup","CustomPopup")
oMyFctBarPopup.ToolTip = "My function bar"
oMyFctBarPopup.BarID = oMyFctBar.ID
BarManager.Bars("SCRGroup").UsedActionObjs.Add(oMyFctBarPopup)
Call BarManager.Save("MyBarManager.bdn")

DIAdem saves bar definitions with the filename extension .bdn in the folder that contains the
local settings, for example, in the desktop file desktop.ddd. To assign a new symbol to the
new function, create an ICO file with several pictures sized 16, 24, 32, and 48 pixels, and save
this file in the respective subfolder MyBarManager.
The following example creates the menu Testing with the submenu TestingProject DIAdem
ANALYSIS. The functions Run and Edit of the submenu are prepared in this script but not yet
defined.
Dim ProjectPath: ProjectPath = CommonDocumentsPath & "Documents\"
const ProjectFile = "CalculateTests"
const ProjectName = "Testing Project"
function CreateTestingMenu(sgID, sgCaption, oParentBar)
' Create ActionObject for menu bar --------dim oActObj
if (BarManager.ActionObjs.Exists(sgID)) then
set oActObj = BarManager.ActionObjs(sgID)
else
set oActObj = BarManager.ActionObjs.Add(sgID, "CustomPopup")
oActObj.BarID = sgID
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oActObj.Caption = sgCaption
end if
if not (oParentBar.UsedActionObjs.Exists(sgID)) then
call oParentBar.UsedActionObjs.Add(sgID)
end if
' Create menu bar --------------------dim oBar
if (BarManager.Bars.Exists(sgID)) then
set oBar = BarManager.Bars(sgID)
else
set oBar = BarManager.Bars.Add(sgID)
oBar.Style = eBarStyleIconCaption
oBar.ActionObjPictureWidth = 16
oBar.ActionObjPictureHeight = 16
end if
set CreateTestingMenu = oBar
end function
'Create menu items --------------------function CreateProjectMenuItem(sgID, sgCaption, oBar)
dim oActObj
if (BarManager.ActionObjs.Exists(sgID)) then
set oActObj = BarManager.ActionObjs(sgID)
else
set oActObj = BarManager.ActionObjs.Add(sgID, "CustomButton")
oActObj.Caption = sgCaption
end if
if (not oBar.UsedActionObjs.Exists(oActObj)) then
call oBar.UsedActionObjs.Add(oActObj)
end if
set CreateProjectMenuItem = oActObj
end function
'Main --------------------dim oMenuItem, oTestingBar, oProjectBar
set oTestingBar = CreateTestingMenu("MyTestingMenu",_
"Testing", BarManager.Bars("ANAMenuMain"))
set oProjectBar = CreateTestingMenu("MyTestingProject1Menu",_
ProjectName, oTestingBar)
set oMenuItem = CreateProjectMenuItem(ProjectName & "Run",_
"Run", oProjectBar)
oMenuItem.OnClickCode.Code = "call GetTesting._
RunTesting(""" & ProjectPath & """,""" & ProjectFile & """)"
set oMenuItem = CreateProjectMenuItem(ProjectName & "Edit",_
"Edit", oProjectBar)
oMenuItem.OnClickCode.Code = "call GetTesting._
EditTesting(""" & ProjectPath & """,""" & ProjectFile & """)"
© National Instruments Ireland Resources Limited |
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Use the Call BarManager.Reset() command to reset all menus and bar definitions to the
delivery status. This command deletes all user-defined menu entries and all buttons in the bar
definition.

Context Menus
Use the context menu object to access context menus in DIAdem NAVIGATOR, in DIAdem
VIEW, or in the SUD editor. Use the context menu object to create, delete, or to change entries
in the context menu or in submenus. Use the context menu object in a user command which
DIAdem executes when calling the context menu or when selecting a context menu entry.
The following example executes the user command MyViewOnShowingContextMenu when
opening a context menu in DIAdem VIEW. This user command adds the menu entry My Menu
Point to the context menu when you open the context menu of the channel table or of the axis
system. When you click a context menu entry, the example executes the user command
MyViewOnContextMenuPointSelected and displays the selected entry in a message.
Call AddUserCommandToEvent("View.Events.OnShowingContextMenu",_
"MyViewOnShowingContextMenu")
Call
AddUserCommandToEvent("View.Events.OnContextMenuPointSelected",_
"MyViewOnContextMenuPointSelected")
Sub MyViewOnShowingContextMenu(Area,MenuPoints)
If (Area.DisplayObjType = "CurveChart2D") Then
Call MenuPoints.Add("My CurveChart Menu Point",1)
End If
If (Area.DisplayObjType = "ChannelTable") Then
Call MenuPoints.Add("My ChannelTable Menu Point",2)
End If
End Sub
Sub MyViewOnContextMenuPointSelected(Area, MenuPoint)
Select Case MenuPoint.ID
Case 1 Call MsgBoxDisp("DIAdem-VIEW: MyMenuPoint1 selected")
Case 2 Call MsgBoxDisp("DIAdem-VIEW: MyMenuPoint2 selected")
End Select
End Sub

User Dialog Boxes
DIAdem provides an object-oriented script interface for user dialog boxes with which you access
a dialog box. You can execute every user dialog box in modal or non-modal mode. In the modal
mode, the script stops until the dialog box has closed. Therefore, you can only access the dialog
box through the script interface in non-modal mode. First, use the SudDlgCreate command,
the dialog box name, and the dialog box file to create a dialog box object. During the remainder
of the script, you must ensure that DIAdem displays the non-modal dialog box. To do so, use the
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Show method, which provides the Dialog object. Use the Hide method to hide the user dialog
box. Use the methods OK and Cancel to close the user dialog box with the script.
Dim MyDlg
Set MyDlg = SudDlgCreate("Input","Example")
Call MyDlg.Show
'further instructions
Call MyDlg.Ok

Within a script you can access the properties and methods of the non-modal user dialog box and
also the properties and methods of the controls defined in the dialog box. Use the GetControl
method to access a specific control of the dialog box through its object code. This way you can
change control properties and also, for example, trigger a mouse click on a button.
The following example changes the color of a text and clicks a button.
Dim oText, oButton
oText = MyDlg.GetControl("Text1")
oText.ForeColor = vbRed
'further instructions'
oButton = MyDlg.GetControl("Button1")
Call oButton.RunClick

Special Functions
DIAdem SCRIPT provides special functions which you can use in DIAdem:
•

Specifying user-defined functions as user commands

•

Running serial evaluations

•

Loading DIAdem Configurations

Defining User Commands
You can define user commands in scripts to increase the amount of DIAdem commands. You
can use user commands in Calculator formulas, for example, or in DIAdem REPORT and in
DIAdem SCRIPT.
If you need a special format for data display in DIAdem REPORT, write a user command with
the appropriate statements. The following figure shows in the right column a trend display with
plus and minus signs for the values in the middle column. The definition of the right column has
the user command TabTrend instead of a format definition:
@@TabTrend(CFV)@@

DIAdem recognizes user commands as variables by the leading and trailing @@ characters. The
CFV (short for CurrentFormatValue) variable stands for the current channel value.
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Figure 6-5. Table with Trend Display Created by a User Command
Date

Value

Trend

2001/01/01

0.000

Start

2001/02/01

270.000

+++

2001/03/01

–43.000

-

2001/04/01

72.000

++

2001/05/01

–43.000

-

2001/06/01

124.000

+++

2001/07/01

–92.000

--

2001/08/01

10.000

+

2001/09/01

166.000

+++

2001/10/01

–42.000

-

2001/11/01

59.000

++

2001/12/01

45.000

+

You can define user commands as procedures or functions. Specify the user command
TabTrend for a trend display as a function because TabTrend must return a result value.
TabTrend shows a maximum of three plus signs or minus signs as text.
Function TabTrend(ByVal Value)
If Value <= -100 Then
TabTrend = "---"
ElseIf (Value > -100) and (Value <= -50) Then
.......
ElseIf (Value >= 100) Then
TabTrend = "+++"
End If
End Function

For DIAdem to add the user commands to the collection of commands, you must select
Settings»Extensions»User Commands and register script files that contain user commands.
The user command TabTrend is in the UserCmdReport.vbs script in the example folder.
DIAdem saves the link to the script file in the desktop file. The user commands are then
permanent, until you delete the link or load another desktop file.

Evaluating a Series of Files
You can use DIAdem SCRIPT to automatically evaluate a series of similar files in a script,
without having to load each file separately. For example, if you run a long-term test that saves a
result file every day, you can evaluate all the files that are recorded in one week, at the beginning
of the following week. To do so, you define a statement for loading several data files and create
a loop statement with commands which you want to use for every file.
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The following script opens the file selection dialog box where you can select several TDM files,
for example, Demo1.tdm, Demo2.tdm, and Demo3.tdm. DIAdem writes the filenames into
the variable FileDlgNameList to load, save, and smooth these files one after the other, and
to then save the files under the new name Series with a running index.
Option Explicit
Dim i
If FileDlgShow(DataReadPath,"TDM Files,*.tdm",_
"DataSelection",True) = "IDOk" Then
For i = 0 to UBound(FileDlgNameList)
Call Data.Root.Clear()
Call DataFileLoad(FileDlgNameList(i),"TDM","Load")
Call ChnSmooth("[1]/[2]","/Smoothed",12,"maxNumber")
Call DataFileSave("Series_"&str(i),"TDM")
Next
End If

Loading DIAdem Configurations
You can configure DIAdem individually for different users and for different projects. Save the
settings in different desktop files with Settings»Save As. If you want to use a configuration on
a different computer, copy all configuration files (.ddd, .par, .tuc, .bdn) and the sub-folder,
which has the same name as the desktop file, to the folder with the local settings on the target
computer. To start DIAdem with a user-specific or project-specific configuration, call DIAdem
with the parameter /D and the respective desktop file MyProject.ddd:
"diadem.exe" "/DC:\diadem\myproject"

In the properties for calling DIAdem, you can also use the parameter /C in order to execute a
command or a script directly after DIAdem launches. Use the /S parameter to specify the local
system folder to the DIAdem client, in a network installation. In a request you can combine these
parameters with each other and use the /C parameter several times.

Development Environment for TDM Server
With DIAdem's development environment, configurations for the processing and evaluation of
data with TDM Server can be developed, tested, loaded, and edited. TDM Server offers the
possibility to outsource data and evaluations to a server and to organize them there centrally.
TDM Server returns result data in TDM and TDMS format as well as reports as PDF documents
and graphics. The result data and the related documents and graphics are marked with the same
custom properties, such as the name of the test series, in order to find all files of a certain test
series with DataFinder.
TDM Server contains DataFinder, Data Preprocessor, and Analysis Server. DataFinder indexes
data in the specified search areas. Data Preprocessor standardizes the data of different
measurements. Analysis Server executes calculations and creates reports.
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Figure 6-6. TDM Server with Data Preprocessor, DataFinder, and Analysis Server

In DIAdem you can create configurations for Data Preprocessor and Analysis Server, and edit
model hierarchies for DataFinder. The Analysis Server configurations contain the names of the
implemented scripts and layouts which DIAdem bundles together with the configuration to a
package. Copy the configuration packages to TDM Server and specify the automatic execution
of evaluations there. In order to view the reports promptly, a success message is sent as an email.

Creating Data Preprocessor Configurations
Use Data Preprocessor to prepare measurement data from different sources for the analysis. For
example, if you want to compare test stand results executed at different locations with the same
test but with different hardware. In DIAdem Settings»TDM Server»Data Preprocessor, you
edit and create Data Preprocessor configurations.
The dialog box displays all process chain steps available for data preparation. By default, no step
is enabled or predefined. Select each step with a click on the symbol in the process chain. Then
enable the step and configure the settings in the Edit dialog box. The selected steps in the process
chain appear dark, whereas non-selected steps are dimmed. This way you can see directly which
process steps have already been configured.
Figure 6-7. Process Chain in the Configuration Dialog Box for Data Preprocessor

Use the Replace Identifier and Replace Value steps to change the identifier and the value of a
property. The same sensor might, for example, be stored in the Detector property with the
value TC and in the probe property with the value 7241. In order to assign the data to the same
sensor, both properties are replaced by Sensor with the value TC 7241.
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Use the Convert Units step to convert measurement data into the same unit. For example, if
temperatures were measured in Fahrenheit °F but are to be evaluated in Celsius °C,
specify that temperatures are saved in Celsius °C in accordance with the units catalog.
Use the Statistics step to calculate characteristic statistical values, such as mean values, quantile,
or dispersion values. Data Preprocessor saves the results as custom properties in the data files.
Use the Validation & Verification step to check whether the processed data is plausible and
complete. The check can also include a request for limit values. If you click Edit, DIAdem
copies a script template, which you have to complete for the data check, into the script editor.
Use the Convert Data step to specify, for example, TDM as the file format for the storage of
predefined data. You also specify whether to overwrite or rename existing data.
Finally, save the Data Preprocessor configuration. DIAdem creates a package with the filename
extension DPP. The dialog box contains functions to test and to debug this configuration. Specify
a DataFinder as the data source on which DIAdem uses the configuration like in the
TDM Server. DIAdem stores the result data in the Data Portal.

Creating Analysis Server Configurations
Use Analysis Server to execute calculations with the processed data and display the results in
reports. Analysis Server saves the result data in new TDM files and exports the reports as PDF
documents or graphics. Create and edit configurations for Analysis Server in DIAdem under
Settings»TDM Server»Analysis Server.
Figure 6-8. Process Chain in the Configuration Dialog Box for Analysis Server

Use the Search Request step to define an Advanced Search. First, click Data Filter Enabled
to show the search input area and the search results list. Create several search conditions for a
search and connect the conditions with AND and OR. DIAdem automatically adds the search
condition that only indexed data is included in the search. If, for example, you search for sensor
data, select the property Sensor and enter the value TC 7241. As a second search condition,
you can select a storage date, which should not be older than three months. If you search for
channels, the search results list displays all channels the specified sensor measured during the
previous 90 days. You can save search requests and use them in other configurations just as in
DIAdem NAVIGATOR.
Use the Parameter Definition step to create exchange variables. In the exchange variables, you
enter the settings for a function such as the window used for an FFT or the smoothing width.
This way you can execute the same analysis with different parameters for similar measurement
data, like in the analysis of a 4 cylinder and a 6 cylinder engine.
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Use the Analysis Script step to combine the analysis package. The tree view in the lower part
of the dialog box displays the files already in the work folder. If, for example, you saved a search
in the Search Request step, you also see this TDQ file in the tree. Import files or whole folders
with, for example, the layouts and logos and also additional scripts. All necessary files for the
analysis procedure must be stored in the work folder and are displayed in the tree.
The tree always contains the script Main.vbsa. The filename extension VBSA shows that it is
not a DIAdem script but the central script of an analysis configuration. Select this file in the tree
and click Edit. DIAdem copies the main script to the script editor where you add evaluation
functions, loading report layouts, and the result storage as TDM files, PDF documents and
graphics to the script template.
Finally, save the Analysis Server configuration. DIAdem creates a package with the filename
extension ANP. The dialog box contains functions to test and to debug this configuration. Specify
a DataFinder as the data source like in the TDM Server. The result data is in the Data Portal and
the PDF documents and graphics are in the work folder.

Extending DataFinder Hierarchies
Use DataFinders to find data on computers and servers in the network, in order to prepare them
with Data Preprocessor and to evaluate them with Analysis Server. The data display in the file
browser is based on the TDM model (file - group - channel) or the standard ASAM model (year
- month, author - year - month). If, for example, you use data files of different models or you
want to add file levels to the browser display, edit the DataFinder hierarchy.
You edit DataFinder hierarchies and create them in DIAdem in Settings»TDM Server»
DataFinder Hierarchy. Click New to create a browser display and click Open to edit an
existing one. You can create or delete data levels or import them through a reference file
in the browser display.
Save your model hierarchy with the filename extension DFH. Copy this file to the TDM Server
so that the model hierarchies are imported into the DataFinder. Refer to the section on
DataFinder Server in Chapter 2, Finding and Managing Data, for more information about
DataFinder.
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NI Services

NI provides global services and support as part of our commitment to your success. Take
advantage of product services in addition to training and certification programs that meet your
needs during each phase of the application life cycle; from planning and development through
deployment and ongoing maintenance.
To get started, register your product at ni.com/myproducts.
As a registered NI product user, you are entitled to the following benefits:
•

Access to applicable product services.

•

Easier product management with an online account.

•

Receive critical part notifications, software updates, and service expirations.

Log in to your MyNI user profile to get personalized access to your services.

Services and Resources
•

•

Maintenance and Hardware Services—NI helps you identify your systems’ accuracy and
reliability requirements and provides warranty, sparing, and calibration services to help you
maintain accuracy and minimize downtime over the life of your system. Visit ni.com/
services for more information.
–

Warranty and Repair—All NI hardware features a one-year standard warranty that
is extendable up to five years. NI offers repair services performed in a timely manner
by highly trained factory technicians using only original parts at an NI service center.

–

Calibration—Through regular calibration, you can quantify and improve the
measurement performance of an instrument. NI provides state-of-the-art calibration
services. If your product supports calibration, you can obtain the calibration certificate
for your product at ni.com/calibration.

System Integration—If you have time constraints, limited in-house technical resources, or
other project challenges, National Instruments Alliance Partner members can help. To learn
more, call your local NI office or visit ni.com/alliance.
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•

•

•

NI Services

Training and Certification—The NI training and certification program is the most
effective way to increase application development proficiency and productivity. Visit
ni.com/training for more information.
–

The Skills Guide assists you in identifying the proficiency requirements of your
current application and gives you options for obtaining those skills consistent with
your time and budget constraints and personal learning preferences. Visit ni.com/
skills-guide to see these custom paths.

–

NI offers courses in several languages and formats including instructor-led classes at
facilities worldwide, courses on-site at your facility, and online courses to serve your
individual needs.

Technical Support—Support at ni.com/support includes the following resources:
–

Self-Help Technical Resources—Visit ni.com/support for software drivers and
updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting
wizards, thousands of example programs, tutorials, application notes, instrument
drivers, and so on. Registered users also receive access to the NI Discussion Forums
at ni.com/forums. NI Applications Engineers make sure every question submitted
online receives an answer.

–

Software Support Service Membership—The Standard Service Program (SSP) is a
renewable one-year subscription included with almost every NI software product,
including NI Developer Suite. This program entitles members to direct access to
NI Applications Engineers through phone and email for one-to-one technical support,
as well as exclusive access to online training modules at ni.com/
self-paced-training. NI also offers flexible extended contract options that
guarantee your SSP benefits are available without interruption for as long as you need
them. Visit ni.com/ssp for more information.

Declaration of Conformity (DoC)—A DoC is our claim of compliance with the Council
of the European Communities using the manufacturer’s declaration of conformity. This
system affords the user protection for electromagnetic compatibility (EMC) and product
safety. You can obtain the DoC for your product by visiting ni.com/certification.

For information about other technical support options in your area, visit ni.com/services,
or contact your local office at ni.com/contact.
You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch
office websites, which provide up-to-date contact information, support phone numbers, email
addresses, and current events.
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Numerics
2D Axis Systems
Background segments, 3-6
Constants, 3-6
3D analysis, 4-19
3D Arithmetic
Calculate extreme values, 4-20
Integrate, 4-20
Matrix-matrix operations, 4-19
Matrix-scalar operations, 4-19
Matrix-vector operations, 4-19
Normalize, 4-19
Relativize, 4-19
Summation, 4-19
3D Basic Functions
Append matrix, 4-19
Convert matrix, 4-19
Create submatrix, 4-19
Sort matrix, 4-19
Transpose matrix, 4-19
3D data, 2-11
3D Projection color display, 3-13
3D projection, 3-12
Deformation, 3-13
Grid models, 3-13

A
Analysis Server, 6-23
Arrows, 5-17
ASAM data stores, 2-7
ASAM ODS server, 2-6
Automating Sequences, 6-1
Axis Systems
2D axis system, 5-7
3D axis system, 5-12
3D curve, 5-13
Background segments, 5-8
Characteristic diagrams, 5-12
Coordinate, 5-8, 5-12
Curve transformation, 5-10
DIAdem REPORT, 5-1
Error bars, 5-7

Filled area, 5-7
Histogram, 5-7
Isoline display, 5-13
Leading curve, 3-5
Legends, 3-4
Polar axis system, 5-11
Report, 5-7
Scale, 5-9
Scale background graphic, 5-8
Subaxes, 5-9
Vector display, 5-12
Waterfall display, 5-13
Axis systems, DIAdem VIEW, 3-3

B
Basic Mathematics
Add, 4-10
Calculate differences, 4-10
Calculate reciprocal, 4-10
Divide, 4-10
Multiply, 4-10
Normalize, 4-10
Offset correction, 4-10
Relativize, 4-10
Remove Duplicates, 4-10
Rounding, 4-10
Scale, 4-10
Subtract, 4-10
Basic mathematics
Calculate RMS, 4-10
Differentiate, 4-10
Integrate, 4-10
Summation, 4-10
Bode Axis System, 3-7
Bus Log Converter
Loading bus logfiles, 2-8
Scripts, 6-12
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C
Calculation Manager, 4-7
Scripts, 6-13
Calculations
Calculate formulas, 4-2
Calculation manager, 4-7
Quantity-based, 4-6
Result storage, 4-2
Script, 4-5
Standard functions, 4-10
Calculator, 4-2
Cascade, 3-11
Channel Functions
Average channels, 4-11
Calculate peaks, 4-11
Convert channel unit, 4-11
Convert to unit set, 4-11
Event search, 4-11
Find peaks, 4-11
Generate numeric channel, 4-10
Generate time channel, 4-10
Linear mapping, 4-12
Numeric channels Assignment
channels, 4-11
Numeric channels Waveform channels,
4-10
Optimize data type, 4-11
Phase unwrap/wrap, 4-12
Process NoValues, 4-11
Quantize, 4-11
Resampling, 4-12
Sort channel values, 4-11
Synchronize Data from Different Files,
4-12
Channel Preview, 2-1
Channel reference
Name or index, 2-9
Report, 5-5
Script, 6-4
Channel Tables, 3-3
Channels, 2-9
Calculate formulas, 4-3
Channel groups, 2-9
Channel properties, 2-11
Channel reference, 2-9
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Channel table, 2-10
Creating, 2-10
Generate, 3-3
Inheriting properties, 2-12
Numeric channels, 2-10
Report, 5-1
Text channel, 5-2
Text channels, 2-10
Time channels, 2-10
Unicode, 2-10
Units catalog, 2-12
Waveform channels, 2-10
Chart Wizard, 5-2
Circles, 5-17
Classifications, 4-17
Compound classification, 4-18
Histogram classification, 4-18
Rainflow classification, 4-18
Reducing classification, 4-18
Single Classification, 4-18
Comments, 5-16
Configuration Desktop file, 6-21
Constants, 3-6
Context Menu Scripts, 6-18
Contour, 3-9
Coordinate Window, 3-5
Coordinates, 5-8
Crash analysis toolset, 4-20
Cursor, 3-4
Band cursor, 3-4
Cursor parameters, 3-4
Frame cursor, 3-4
Harmonic cursor, 3-5
Sideband cursor, 3-5
Curve Fitting
Akima subsplines, 4-12
Approximation, 4-12
Calculate Corridor, 4-13
Calculate envelope curves, 4-13
Check Corridor, 4-13
Circle approximation, 4-12
Gaussian curve fitting, 4-12
General LS linear fitting, 4-12
Non-linear curve fitting, 4-12
Non-parametrical splines, 4-12
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Parametrical splines, 4-12
Regression, 4-12
Savitzky-Golay filter, 4-12
Smooth, 4-12
Curve transformation, 5-10
Curves
Minima and maxima, 3-5
Set flags, 3-5
Custom Properties, 2-11
Documents, 2-5
Optimize, 2-5
Templates create, 2-12

D
Data
Channel groups, 2-9
Channels, 2-9
Converting bus log files, 2-8
Custom properties, 2-11
Data Portal, 2-8
Data properties, 2-11
DataFinder, 2-1
DataPlugins, 2-7
Excel data, 2-13
Find, 2-1
Finding and managing, 2-1
Format, 5-4
Indexing, 2-5
Load, 2-7
Mathematical evaluation, 4-1
Matrix/triplet, 2-11
Reducing loading, 2-8
Register, 2-8
Report, 5-1
Save, 2-13
TDM data, 2-13
TDMS data, 2-13
View and analyze, 3-1
Data Portal
Filtering, 2-9
Internal data, 2-8
List view, 2-9
Pinning, 2-9
Scripts, 6-11
Structure view, 2-9

Data Preprocessor, 6-22
Data Stores, 2-7
Adding, 2-7
ASAM, 2-7, 6-10
DataFinder
Advanced search, 2-2
Configuring, 2-4
Fragment search, 2-3
Indexing, 2-5
My DataFinder, 2-4
Operators, 2-3
Quick search, 2-1
Saving the search, 2-4
Search areas, 2-4
Search conditions connection, 2-2
Use wildcards, 2-3
Using properties, 2-4
DataFinder Server, 2-6, 6-24
ASAM ODS server, 2-6
DataPlugins
Indexing documents, 2-5
My DataFinder, 2-5
Register, 2-7
Scripts, 6-11
Date, 5-17
Default group
Data Portal, 2-9
Result storage, 4-2
DIAdem ANALYSIS, 4-1
Formulas, 4-2
NoValues, 4-8
Scripts, 6-13
Standard functions, 4-1, 4-10
DIAdem NAVIGATOR, 2-1
Data stores, 2-7
DataFinder, 2-1
Scripts, 6-10
DIAdem Panels, 1-1
Predefined settings, 1-2
DIAdem REPORT, 5-1
Axis systems, 5-1, 5-7
Scripts, 6-14
Worksheets, 5-2
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DIAdem SCRIPT
Automating sequences, 6-1
Dialog editor, 6-7
DIAdem VIEW, 3-1
3D projection, 3-12
Axis systems, 3-3
Cascade, 3-11
Channel tables, 3-3
Contour, 3-9
Graphic, 3-14
Layout transfer, 3-3
Layouts, 3-2
Maps, 3-8
Scripts, 6-14
Textboxes, 3-14
User dialog boxes, 3-13
Videos, 3-7
Dialog Boxes, 3-13, 6-18
DIAdem VIEW, 3-13
Methods and events, 6-9
Templates, 6-8
User dialog boxes, 6-7
Dialog Editor, 6-7
Digital Filters, 4-15
Documents
Indexing, 2-5
PDF export, 6-15
XML format, 6-15

E
Ellipses, 5-17
Examples, 1-3
Expansion mode, 5-6
Extending the Interface, 6-15

F
Fast Fourier Transform (FFT), 4-13
File Browser, 2-1
Channel preview, 2-1
File operations, 2-13
Format definitions, 5-4
User command, 5-4
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Formulas, 4-2
Calculating channels, 4-3
Report, 5-16
Script, 4-5, 6-5
Frequency Weighting (A-, B-, C-Filtering),
4-15
Frequency-Weighted Acceleration, 4-15
Function Groups
Global script bar, 1-2
Predefined settings, 1-2

G
Graphics, 3-14
Report, 5-16
Group bars scripts, 6-16

I
Introduction Screen, 1-3
Inverse FFT, 4-13

L
LabVIEW scripts, 6-13
Layouts
DIAdem REPORT, 5-2
DIAdem VIEW, 3-2
Layout parameters, 5-6
Report, 5-5
Transfer to REPORT, 3-3
Leading curves, 3-5
Legends, 3-4
Lines, 5-17

M
Maps Synchronize, 3-9
Master Layout, 5-6
Mathematical standard functions, 4-10
My DataFinder, 2-4
Optimizing custom properties, 2-5

N
NI License Manager, 1-3
NoValues, 4-8
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O
Orbit axis systems, 3-7
Order Analysis, 4-15
Order Lines, 3-11

P
Page formats
Report, 5-6
Scaled, 5-7
Pages, 5-17
Polar Axis Systems, 3-6, 5-11

R
Recording mode, 6-1
Rectangles, 5-16
Reports, 5-1
3D axis system, 5-12
Arrow, 5-17
Axis systems, 5-7
Chart wizard, 5-2
Circle, 5-17
Comment, 5-16
Edit, 5-3
Expansion mode, 5-6
Export, 5-2
Formula, 5-16
Frame, 5-16
Graphic, 5-16
Line, 5-17
Master layout, 5-6
Page format, 5-6
Polar axis system, 5-11
Predefined objects, 5-17
Table, 5-13
Template, 5-6
Text, 5-15
Text object, 5-15

S
Script, 6-1
Scripts
BarManager object, 6-16
Branching, 6-5
BusLogToTDM object, 6-12

CalculationSet object, 6-13
Context menu object, 6-18
Control command, 6-5
Data object, 6-11
DataPlugins, 6-11
Debug, 6-2
Dialog boxes, 6-6
Document Data object, 6-15
Encrypt, 6-3
Formula calculation, 4-5, 6-5
Global script bar, 6-2
Interaction mode, 6-6
Loops, 6-5
LVRuntime object, 6-13
Mathematical standard functions, 4-5
Navigator object, 6-10
Portal object, 6-11
Recording mode, 6-1
Report object, 6-14
Save workspace, 6-2
Script editor, 6-1
Serial evaluation, 6-20
UnitCatalog object, 6-13
User commands, 6-19
Variable, 4-5
Variables usage, 6-4
View object, 6-14
Serial Evaluation Scripts, 6-20
Set Flags, 3-5
Shaft centerline axis systems, 3-7
Signal Analysis, 4-13
AC/DC coupling, 4-16
Autocorrelation, 4-14
Characterize oscillation, 4-14
Cross correlation, 4-14
Digital filters, 4-15
FFT, 4-13
Frequency weighting (A-, B-,
C-filtering), 4-15
Frequency-weighted acceleration, 4-15
Full spectrum FFT, 4-13, 4-16
Inverse FFT, 4-13
Order analysis, 4-15
Order analysis for Bode display, 4-15
Pulse detection, 4-16
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Shaft centerline, 4-16
Shock response spectrum, 4-14
SINAD analysis, 4-14
Third/Octave Analysis, 4-13
Standard functions
3D analysis, 4-19
Basic mathematics, 4-10
Channel functions, 4-10
Classifications, 4-17
Crash analysis, 4-20
Curve fitting, 4-12
Descriptive statistics, 4-17
Signal Analysis, 4-13
Statistics
Descriptive statistics, 4-17
Process capability, 4-17
Subaxes, 5-9
Surfaces
Approximate, 4-20
Calculate contour lines, 4-20
Calculate convex hull, 4-20
Contour calculation, 4-19
Interpolate, 4-20

T
Table of contents, 5-17
Tables, 5-13
2D table, 5-13
3D table, 5-14
Formatting with user commands, 6-19
Multi-sheet table, 5-13
Text list, 5-13
TDM data, 2-13
TDM Server, 6-21
Analysis Server, 6-23
Data Preprocessor, 6-22
DataFinder hierarchy, 6-24
DataFinder server, 2-6
TDMS data, 2-13
TDR file, 5-5
Templates Report, 5-6
Text, 3-14, 5-14
Comment, 5-16
Text list, 5-13
Text object, 5-15
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Text channels Report, 5-2
The User Interface, 1-2
Third/Octave Analysis, 4-13
Tutorial, 1-3

U
Units Catalog, 2-12
Axis systems, 5-10
Calculate quantity-based, 4-6
Scripts, 6-13
URF files, 2-6
User Commands, 5-4
Register, 6-20
Scripts, 6-19

V
Variables
Calculate formulas, 4-4
Format, 5-4
Program variable, 4-6
Script, 6-4
VBS variables, 4-6, 6-4
Videos
Evaluation, 3-7
Synchronize, 3-8

W
Waterfall, 3-11
Worksheets
DIAdem REPORT, 5-2
DIAdem VIEW, 3-3
Parameters, 5-6

Z
Zoom
Band zoom, 3-4
Dynamic, 3-4
Frame zoom, 3-4

