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Calibration Executive
July 2023

This help file describes how to use NI Calibration Executive to calibrate NI hardware
devices. For detailed information on calibration, visit ni.com/calibration.

For more information about this help file, refer to the following topics:

Related Documentation

Glossary

NI Services

To comment on NI documentation, refer to the NI website.

© 2005–2023 National Instruments. All rights reserved.

Activating Your Software

How Do I Activate My Software?
Before using your product, you must activate it in accordance with its license
agreement. To activate a product, you must first purchase a license. For information
on purchasing licenses, contact your local NI sales representative or visit ni.com/
niglobal.

Complete the following steps to activate your NI products:

1. Select Start»National Instruments»NI License Manager to open NI
License Manager.

2. Select one of the following methods to launch the Activate Software window:

■ Click Activate Software on the ribbon.
■ When in the Local Licenses view, right-click the product in the License
tree and select Activate.

Note  The first time you open NI software,
the license activation window launches
automatically.
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3. If requested, log in to your NI User Account. If you do not have a User Account,
you must create one.

4. Select one of the following methods to activate your products.

■  Check my account for licenses
Licenses associated with your account are verified successfully, activation
completes. If your account lacks the appropriate licenses for a particular
product, proceed to activate the product using either a activation code or a
serial number.

■  Enter a serial number
You can find your serial numbers in the following locations:

■ On the Certificate of Ownership included in your software kit
■ On the product packing slip or shipping label
■ Visit ni.com/info and enter the Info Code SerialNumbers_en.
■ If you have installed a previous version of your application software
using your serial number, you can find the serial number by selecting
Help»About within the application.
■ Contact your local NI branch.

■  Enter activation codes
Click on Generate an activation code or visit ni.com/activate to obtain an
activation code.

■  Connect to a volume license server
Enter the name of the volume license server on which your NI products
should check for licenses.

5. Follow the prompts in the Activate Software window to complete
activation.

If you activated through your NI software, you can use the product immediately after
successful activation.

Notes  
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■ If you were using NI software before you
began the activation process, you may
need to restart the software for the
change to take effect.
■ If your NI software is licensed through a
volume license agreement, you do not
need to activate your product. Instead,
you need to point NI License Manager to a
volume license server. For more
information, refer to the Using a Volume
License Server topic of the NI License
Manager Help.

What Is Activation?
Activation is the process of obtaining an activation code to enable your software to
run on your computer. An activation code is an alphanumeric string that verifies the
software, version, and computer ID to enable features on your computer. Activation
codes are unique and are valid on only one computer.

What Information Do I Need to Activate My NI Software?
You need your NI User account log-in, the product version and serial number, and a
computer ID that uniquely identifies your computer. Certain activation methods
may require additional information for delivery. This information is used only to
activate your product. Complete disclosure of the NI software licensing information
privacy policy is available at ni.com/activate/privacy. If you optionally choose to
register your software, your information is protected under the NI privacy policy,
available at ni.com/privacy.

How Do I Find My Product Serial Number?
Your serial number uniquely identifies your purchase of NI software. You can find
your serial number on the Certificate of Ownership included in your software kit, or
you can visit ni.com/info and enter the Info Code SerialNumbers_en.

If you have installed a previous version using your serial number, you can find the
serial number by selecting Help»About within the application. You can also
contact your local NI branch at ni.com/contact.
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What Is a Computer ID?
The computer ID is a 16-character value that uniquely identifies your computer. NI
requires this information to enable your software. You can find your computer ID
through the NI Licensing Wizard or by using NI License Manager, as follows:

1. Launch the NI License Manager.

2. Click Computer Information in the ribbon.

For more information about product activation and licensing, refer to ni.com/
activate.

How Can I Evaluate NI Software?
You can evaluate most NI products, in accordance with the license agreement.
Evaluation terms vary, depending on which product you want to evaluate. Refer to
your product documentation for specific information on the product's evaluation
mode.

Moving Software after Activation
To transfer your software to another computer, uninstall the software on the first
computer, then install and activate it on the second computer. You can transfer your
software from one computer to another; you do not need to contact or inform NI of
the transfer. Because activation codes are unique to each computer, you will need a
new activation code. Refer to the How do I Activate my Software? section of this
topic to learn how to acquire a new activation code and reactivate your software.

Deactivating a Product
To deactivate a product and return it to its preactivation state, navigate to the Local
Licenses view, select the product to be deactivated, and click Deactivate from the
ribbon. Alternatively, navigate to the Local Licenses view, right-click the product in
the License tree, and click Deactivate. If the product was in evaluation mode
before you activated it, the properties of the evaluation mode may not be restored.
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Using Windows Guest Accounts
NI License Manager does not support Microsoft Windows Guest accounts. You must
log in to a non-Guest account to run licensed NI application software.

Related Documentation
Most Calibration Executive manuals also are available as PDFs. You must have
Adobe Reader installed to view the PDFs. Refer to the Adobe Systems Incorporated
website at www.adobe.com to download the latest version of Adobe Reader. Refer
to the NI Product Manuals Library at ni.com/manuals for updated documentation
resources.

The following documents contain information that you may find helpful as you use
this help file:

Calibration Executive
■ Calibration Executive Release Notes
■ Calibration Executive Readme

C Series Devices
■ Refer to the getting started guide for your C Series device.

Data Acquisition (DAQ) Devices
■ DAQ Getting Started Guide for Bus-Powered USB
■ DAQ Getting Started Guide for PCI/PCI Express
■ DAQ Getting Started Guide for PXI/PXI Express
■ DAQ Getting Started Guide for Externally Powered USB
■ E/S Series and MIO 62xx Models Calibration Hardware Adapter
Installation Guide
■ Measurement & Automation Explorer Help for NI-DAQmx
■ NI R Series Intelligent DAQ User Manual
■ Getting Started with R Series Intelligent DAQ
■ B/E/S Series and MIO 62xx/63xx Models hardware documentation
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■ NI CompactDAQ hardware documentation

NI-DAQ and NI-DAQmx
■ NI-DAQmx C Reference Help
■ NI-DAQmx Help

Dynamic Signal Acquisition (DSA) Devices
■ National Instruments Dynamic Signal Acquisition Help
■ NI Dynamic Signal Acquisition User Manual

Modular Instruments Devices
■ Read Me First: Safety and Radio-Frequency Interference
■ Maintain Forced-Air Cooling Note to Users

Digital Multimeters
■ NI Digital Multimeters Getting Started Guide
■ NI Digital Multimeters Help

Digital Waveform Generator/Analyzers
■ NI Digital Waveform Generator/Analyzer Getting Started Guide
■ NI Digital Waveform Generator/Analyzer Help

High-Speed Digitizers
■ NI High-Speed Digitizers Getting Started Guide
■ NI High-Speed Digitizers Help

RF Devices
■ NI RF Signal Analyzers Getting Started Guide
■ NI RF Signal Generators Getting Started Guide
■ NI RF Signal Analyzers Help
■ NI RF Signal Generators Help
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Power Supplies
■ NI DC Power Supplies and SMUs Getting Started Guide
■ NI DC Power Supplies and SMUs Help

Signal Generators
■ NI Signal Generators Getting Started Guide
■ NI Signal Generators Help

Specifications
To find the specifications of the device you are calibrating, select one of the
following methods:

■ Visit ni.com/calibration to find the manual calibration procedure for the
device.
■ Refer to the hardware documentation for the device. You can download the
latest product documentation from ni.com/manuals.
■ Visit ni.com/products to find the product data sheet for the device.

Note  Data sheets for some products
contain detailed specs.

Calibration Executive Device and Module Compatibility
The following table provides compatibility information about NI devices and
modules that are not supported in this version of Calibration Executive but may be
supported in a previous version. If a model is no longer supported, information in
this table indicates which version of Calibration Executive is the last to support the
device or module.

Note  Using hardware with unsupported
versions of Calibration Executive may result in
in errors, the inability for your operating system
to recognize or detect and then find a driver for
your device, or missing devices in Calibration
Executive.
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Device or Module Last Supported in
Calibration Executive

AT-5102 3.5.2
AT-AI-16XE-10 3.5.2
AT-MIO-16DE-10 3.5.2
AT-MIO-16E-1 3.5.2
AT-MIO-16E-10 3.5.2
AT-MIO-16E-2 3.5.2
AT-MIO-16XE-10 3.5.2
AT-MIO-16XE-50 3.5.2
AT-MIO-64E-3 3.5.2
DAQCard-4050 3.5.2
DAQCard-4350 3.5.2
DAQCard-5102 3.5.2
DAQCard-AI-16E-4 3.5.2
DAQCard-AI-16XE-50 3.5.2
DAQPad-4350 3.5.2
DAQPad-6020E 3.5.2
DAQPad-6020E (BNC) 3.5.2
DAQPad-6052E 3.5.2
DAQPad-6070E 3.5.2
DAQPad-6070E (BNC) 3.5.2
PC-4350 3.5.2
PCI-4060 3.5.2
PCI-4351 3.5.2
PCI-4451 3.5.2
PCI-4452 3.5.2
PCI-4551 3.5.2
PCI-4552 3.5.2
PCI-5102 3.5.2
PCI-5112 3.5.2
PCI-5911 3.5.2
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PCI-6601 3.5.2
PCI-6602 3.5.2
PCMCIA-4050 3.5.2
PCMCIA-4350 3.5.2
PCMCIA-5102 3.5.2
PXI-4060 3.5.2
PXI-4351 3.5.2
PXI-5102 3.5.2
PXI-5112 3.5.2
PXI-5600 3.5.2
PXI-5620 3.5.2
PXI-6602 3.5.2
PXI-6608 3.5.2
SCXI-1100 3.5.2
SCXI-1120 3.5.2
SCXI-1120D 3.5.2
SCXI-1121 3.5.2
SCXI-1124 3.5.2
USB-5102 3.5.2
WSN-3202 3.6.6
WSN-3212 3.6.6
WSN-3226 3.6.6
NI cDAQ-9172 (USB Chassis) 4.5
DAQCard-6024E 5.2
DAQCard-6036E 5.2
DAQCard-6062E 5.2
DAQCard-6715 5.2
DAQPad-6015 (BNC) 5.2
DAQPad-6015 (Mass Termination) 5.2
DAQPad-6015 (Screw Termination) 5.2
DAQPad-6016 5.2
FP-AI-100 5.2

© National Instruments 11

Calibration Executive



FP-AI-102 5.2
FP-AI-110 5.2
FP-AI-111 5.2
FP-AI-112 5.2
FP-AIO-600 5.2
FP-AIO-610 5.2
FP-AO-200 5.2
FP-AO-210 5.2
FP-RTD-122 5.2
FP-RTD-124 5.2
FP-TC-120 5.2
PCI-6010 5.2
PCI-6011E 5.2
PCI-6013 5.2
PCI-6014 5.2
PCI-6023E 5.2
PCI-6024E 5.2
PCI-6025E 5.2
PCI-6030E 5.2
PCI-6031E 5.2
PCI-6032E 5.2
PCI-6033E 5.2
PCI-6034E 5.2
PCI-6035E 5.2
PCI-6036E 5.2
PCI-6040E 5.2
PCI-6052E 5.2
PCI-6070E 5.2
PCI-6071E 5.2
PCI-6551 5.2
PCI-6552 5.2
PCI-7830R 5.2
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PCI-7831R 5.2
PCI-7833R 5.2
PCI-AI-16XE-10 5.2
PCI-AI-64XE-10 5.2
PCI-MIO-16E-1 5.2
PCI-MIO-16E-4 5.2
PCI-MIO-16XE-10 5.2
PCI-MIO-16XE-50 5.2
PCI-MIO-64E-1 5.2
PCI-MIO-64XE-10 5.2
PCMCIA-6715 5.2
PXI-4220 5.2
PXI-5610 5.2
PXI-5900 5.2
PXI-6025E 5.2
PXI-6030E 5.2
PXI-6031E 5.2
PXI-6040E 5.2
PXI-6052E 5.2
PXI-6070E 5.2
PXI-6071E 5.2
PXI-6551 5.2
PXI-6552 5.2
PXI-7830R 5.2
PXI-7831R 5.2
PXI-7833R 5.2
PXIe-6555_6556 Switch Fixture 5.2
SCXI-1102 5.2
SCXI-1102B 5.2
SCXI-1102C 5.2
SCXI-1104 5.2
SCXI-1104C 5.2
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SCXI-1125 5.2
SCXI-1503 5.2
SCXI-1520 5.2
SCXI-1600 5.2
FP-AI-100 5.2
FP-AI-102 5.2
FP-AI-110 5.2
FP-AI-111 5.2
FP-AI-112 5.2
FP-AI-118 5.2
FP-AIO-600 5.2
FP-AIO-610 5.2
FP-AO-200 5.2
FP-AO-210 5.2
FP-RTD-122 5.2
FP-RTD-124 5.2
FP-TC-120 5.2
PXI-5691 6.9.0
PXIe-5632 6.9.0
VB-8012 6.9.0
VB-8034 6.9.0
VB-8054 6.9.0

The Calibration Executive Readme contains the most up-to-date information for
device and module compatibility for each version of the software. The readme and
other documentation is available at ni.com/manuals.

Calibration Executive Overview
Calibration Executive, intended primarily for metrology labs, provides an integrated
software environment in which to verify and adjust NI measurement devices.

Features

Calibration Executive has the following capabilities:
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■ Externally calibrates many NI measurement devices
■ Operates in automated or manual mode
■ Configures and controls calibration instruments automatically
■ Stores calibration reports in a central database
■ Expands as new hardware calibration procedures are added

The Calibration Executive engine provides the core calibration, control, and
reporting functionality. Each device calibration procedure provides the calibration
routines and automation for a specific measurement device family.

Major Components of Calibration Executive

Calibration Executive is designed using NI LabVIEW, IVI, TestStand, and NI-VISA. A
core component of Calibration Executive is the calibration engine. This engine,
which includes the user interface, communicates with the following drivers and
databases to control the calibration process:

■ Interchangeable virtual Instruments (IVI)—A software standard for creating a
common interface (API) to common test and measurement instruments. The
IVI driver communicates with your standards during calibration, typically
using GPIB.
■ Report Database—A Microsoft Access database that stores the calibration
results about assets you have calibrated, such as verification readings taken
before and after calibration.
■ TestStand—A test executive framework that manages the calibration
procedures used to calibrate the asset.

Download the Calibration Executive installer from ni.com/downloads. Refer to
Installing, Updating, Repairing, and Removing NI Software using Package
Manager on ni.com/docs.

New Features and Changes
Learn about updates—including new features and behavior changes—introduced in
each version of Calibration Executive.
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Calibration Executive 2023 Q3
■ Added support for the following products

■ PXIe-4147
■ PXIe-5655

■ Removed support for the following procedures

■ NI VB-8012
■ NI VB-8034
■ NI VB-8054
■ PXIe-5632
■ PXI-5691

Calibration Executive 6.9
■ Added driver support for Rohde & Schwarz NRP33S Power Sensor
■ Added product support for NI 9262

Calibration Executive 6.8
■ Added support for the following products

■ PXIe-5163
■ PXIe-5698

■ Updated the following procedures

■ PXIe-5160 (2CH)
■ PXIe-5160 (4CH)
■ PXIe-5162 (2CH)
■ PXIe-5162 (4CH)
■ PXIe-5164
■ PXIe-5650
■ PXIe-5651
■ PXIe-5652
■ PXIe-5663E
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■ PXIe-5673E 3.3GHz
■ PXIe-5673E 6.6GHz

■ Removed NI USB-5681 calibration procedure support
■ Removed NI USB-5684 power meter standard support

Calibration Executive 6.7
■ Added support for the following products

■ FD-11613
■ FD-11614
■ NI 9210
■ NI TB-9212 with mini-TC
■ PXIe-4135 (40W)
■ PXIe-4137 (40W)

■ Updated the following procedures

■ NI 9219
■ PXIe-4081 (90 day)
■ PXIe-4081 (2 yr)
■ PXIe-4137
■ RM-26999

Calibration Executive 6.6
■ Added driver support for Rohde & Schwarz SMA100B signal generator for
procedures that previously supported the Rohde & Schwarz SMA100A
■ Updated the following procedures

■ PXIe-5160
■ PXIe-5162
■ PXIe-5644R
■ PXIe-5645R
■ PXIe-5646R
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Calibration Executive 6.5
■  Added product support for the PXIe-4139 (40W)
■ Updated the following procedures

■ PXIe-4081 (90 day)
■ PXIe-4081 (2 yr)
■ PXIe-4135
■ PXIe-4139
■ PXIe-5840
■ PXIe-5841
■ NI 9212

Calibration Executive 6.4
■ Revised the reporting of guard band values with dB and dBv units on the
calibration report
■ Import uncertainties from an Open XML spreadsheet using formulas that
result in text values
■ Added support for the following products

■ PXIe-5841
■ PXIe-5841 (2 yr)
■ RM-26999

■ Updated the guard band calculation for uncertainties with dB and dBv units
■ Updated the following procedures

■ PCI-4461
■ PXI-4461
■ PXIe-5654 (10 GHz)
■ PXIe-5654 (20 GHz)
■ PXIe-5654 with PXIe-5696 (10 GHz) Adjust Only
■ PXIe-5654 with PXIe-5696 (20 GHz)
■ PXIe-5668 (14 GHz), all bandwidth options
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■ PXIe-5840
■ PXIe-5840 (2 yr)
■ NI 9220
■ NI 9263

Calibration Executive 6.3
■ Revised formulas for determining measurement uncertainty related to TURs
and nominal values
■ Updated the TUR calculation for uncertainties with dB and dBv units
■ Updated the following procedures

■ PXIe-4135
■ PXI-5422

Calibration Executive 6.2
■ Added support for the following products

■ PXIe-5624
■ PXIe-5606 Adjust Only
■ PXIe-5668 Adjust Only
■ USB-6346 (Screw Terminal)
■ STS-DIO-01

■ Updated the following procedures

■ PXI-4110
■ PCI-5412
■ PXI-5412
■ PCI-5421
■ PXI-5421
■ PXI-5441
■ PXIe-5442
■ PXIe-5653
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■ PXIe-5665 (3.6 GHz)
■ PXIe-5665 (3.6 GHz), no pre-amp
■ PXIe-5665 (14 GHz)
■ PXIe-5668 (14 GHz), all bandwidth options
■ PXIe-5668 (26.5 GHz), all bandwidth options

Calibration Executive 6.1
■ Added support for the following products

■ NI 9224
■ NI 9228

Calibration Executive 6.01
■  A critical bug in the Verify ALC Limits Table test was fixed, enabling the
following devices to be verified and adjusted

■ PXI-5650
■ PXIe-5650
■ PXI-5651
■ PXIe-5651
■ PXI-5652
■ PXIe-5652
■ PXIe-5663
■ PXIe-5663E
■ PXIe-5673
■ PXIe-5673E

Calibration Executive 6.0
■ Uncertainty and guard band options in custom report configurations
■ Added support for the following products

■ PXIe-6349
■ USB-6349
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■ NI 9202
■ NI 9252

■ Added adjustment support for NI 9203
■ Modified audio notifications can only be enabled or disabled; there are no
additional options to be configured
■ Removed support for 32-bit OS calibration procedures

System Requirements
For proper operation of the Calibration Executive software, your computer must
meet the following minimum requirements:

■ Pentium 4/M processor or equivalent
■ 4 GB of RAM
■ 1024 x 768 pixels screen resolution
■ The user must have administrator privileges
■ Windows 10 (64-bit version only)

Notes Calibration Executive is not
compatible with operating
systems that use wide
characters (for example,
Japanese or Chinese).

Calibration Executive only
supports using periods (.) for
decimal places. If your
computer is configured to use
commas as decimal places, you
must change this setting.

Additional Software Requirements

To view calibration reports in all available formats, you must have the following
components installed on your system:

■ Java Runtime Environment, Java SE 8 Update 51 or greater
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■ Adobe Acrobat Reader
■ Microsoft Word
■ Microsoft Excel (64-bit is recommended)

The following instruments require specific drivers that are not installed by
Calibration Executive. To install these drivers, you must download them directly
from the manufacturer's website; you can find links to third party instrument drivers
at ni.com/idnet.

Driver versions listed are those tested during development; later versions might be
available and should be compatible.

Instrument Required Drivers
Rohde & Schwarz NRP-Z power meter

■ NRP-Toolkit 4.16
■ NRP-NI-VISA Passport 2.7.1
■ NRP-Z VXI Plug & Play x64 Driver 3.6.0.0

Rohde & Schwarz SMA100A signal generator VXIplug&play x64 driver rssma version 2.21.0

Note  This release does not include an NI-VNA
driver. To run the PXI-5691 and PXIe-5632
procedures, download NI-VNA 18.0 and install
the driver manually after you install Calibration
Executive.

Automated Mode Versus Manual Mode
For most devices, Calibration Executive calibrates in either automated or manual
mode.

Automated Mode

If the IVI driver supports the calibration standard(s) you are using or if Calibration
Executive provides a custom driver and you have a GPIB card, Calibration Executive
automates verification and adjustment by communicating directly with the
calibration standards.
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Manual Mode

If you do not have supported standards, you must run the procedure in manual
mode. In manual mode, Calibration Executive prompts you to manually control the
standards. Calibration Executive then makes the necessary verification and/or
adjustment to the device. To enter manual mode, select Enter Unsupported
Instrument on the Required Standards page when launching a calibration
procedure.

Note  Not all devices are supported in manual
mode. Refer to the specific device calibration
procedure to check if your device supports
manual mode.

Upgrade Considerations
Refer to Installing, Updating, Repairing, and Removing NI Software using
Package Manager on ni.com/docs.

Calibration Executive versions 6.0 and later have a new installation path, and the
program no longer launches as an administrator application. These changes can
render some application database paths invalid after the upgrade. After an upgrade,
you might need to manually move some files.

Upgrading Calibration Executive 5.x to 6.0 and later

If your Report and Uncertainty databases are in their default locations, the setup
program will automatically move the databases to the new default location and no
action is required.

If databases were moved from their default locations in Calibration Executive 5.x,
then Calibration Executive 6.x attempts to reference the current location. If
Calibration Executive cannot write to the files in this location, a warning message
will be displayed when you first launch Calibration Executive. In this case, you will
need to move the files manually to a writeable location. After you move the
database files, follow the instructions in Selecting Database Locations to configure
the paths for Calibration Executive 6.0 and later.
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Upgrading Calibration Executive 4.x to 6.0 and later

The setup program for Calibration Executive 6.x does not automatically move your
Report and Uncertainty databases, even if they are in their default locations.
Instead, you will need to move the databases manually to a writeable location. After
you move the database files, follow the instructions in Selecting Database Locations
to configure the paths for Calibration Executive 6.0 and later.

Selecting Database Locations

To select the location of your Report database:

1. In the menu bar, select Configure » Database options.
2. Click the folder icon in the Calibration Executive Configure Report Database

dialog, and browse to find the database file.

3. Select the file and click OK.

4. Click OK to close the dialog box.

To select the location of your Uncertainty database:

1. In the menu bar, select Configure » Calibration Reports.

2. In the Calibration Reports window, click Manage Uncertainty. The
Uncertainty Export/Import window opens.

3. Select Database Options » Select Database Location.
4. Use controls in the Select Uncertainty Database File explorer window to locate

your uncertainty database file.

5. Select the file, and click OK.

6. In the Uncertainty Export/Import window, click Done.

7. Click Close to close the Calibration Reports window.

Uninstalling Calibration Executive
Each NI software product has its own uninstall information. To remove any of these
products from your system, use the Add/Remove Programs utility in your system
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control panel. Many of these programs update your Windows registry and place files
in your system directory.

For Windows systems, perform the following procedure to uninstall Calibration
Executive:

1. Open the Control Panel from Start»Settings»Control Panel and choose
Add or Remove Programs.

2. Select National Instruments Software.

3. Click Remove.

4. Select NI Calibration Executive from the list of installed NI software.

5. Click Uninstall.
Notice  Do not attempt to uninstall by deleting
files, as some files may be shared with other
programs.

Refer to Calibration Reports Database for information on saving a report database
file (calibration reports.mdb) that is compatible with version 3.2 or prior.

Launching Calibration Executive and Logging In
To log in to Calibration Executive, complete the following steps:

1. Launch Calibration Executive by selecting Start»Programs»National
Instruments»Calibration Executive.

2. In the Login dialog box, select either administrator or another user name
from the User Name control.
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3. If you select a user name other than administrator, enter a valid password. If
you select administrator, no password is necessary.

Note  You should change the default
administrator password after the initial
login. Refer to Editing a User Profile for
instructions on how to change the default
password.

4. Click OK to launch the user interface.

Calibration Executive User Interface
The following figure shows the main components of the Calibration Executive user
interface. This interface provides access to run calibration procedures; configure
users, databases, and calibration reports; and to view the documentation.

■ Menu bar—Menu items control the main processes of Calibration
Executive.
■ Device Types selector—Select the device name for the calibration
procedure to run.
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■ Calibrate button—Starts the calibration procedure.
■ Terminate button—Ends the calibration procedure before it completes.
■ Step Message—Displays status messages from the step that is currently
executing.
■ Tests tab—Displays the step name that is currently running and the status
of each step.
■ Step—Displays which values are currently being verified or adjusted.
■ Status—Indicates whether a step in the procedure passed or failed.
The following figure shows the Step and Status window during a calibration
procedure. The yellow arrow to the left of the step indicates which step is
currently executing.

■ Step Message Log tab—Displays a log of the history of verify test points
and their results.
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■  Save to file button—Saves the Step Message Log results in a text file.

Menu Bar

The Calibration Executive menu bar contains the following four menus:

File

The File menu contains the following options:

■ Logout—Logs out the current user and enables the Login selection under
the File menu.
■  Exit—Closes Calibration Executive.

Note  If a calibration procedure is currently
running, closing Calibration Executive may
cause errors. Make sure you click the
Terminate button before you exit
Calibration Executive.

■ Login—Allows a new user to log in to the application.

View

The view menu contains the following option:

■ Calibration Reports—Opens the Calibration Reports window. Use this
window to view or delete a stored calibration report.

Configure

The Configure menu contains the following options:

■ Audio Notifications—Enables or disables audio notifications in
Calibration Executive.
■  Report Options—Configures how Calibration Executive displays
calibration reports.
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■ Database Options—Determines the database that stores calibration
reports.
■ Report Database Backup Copy—Saves a secondary copy of the current
calibration reports database.
■ Users—Allows you to add new users, edit current user profiles, or delete
users.

Help

The Help menu contains the following options:

■ Calibration Executive Help—Launches this help file.
■ Calibration Procedure Help—Provides procedure help for the device
type selected.
■ About Procedure—Provides specific information about the procedure
used to calibrate the device selected.
■ About Calibration Executive—Displays the version of Calibration
Executive you are using.

Configuring Audio Notifications

Select Configure»Audio Notifications to configure your system to notify you
when a test needs attention.
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1. Select or deselect OFF/ON under Enable Audio Notifications? to enable or
disable notifications.

2. Click Test Notification to test your audio notification.

3. Click OK to save your settings.

Configuring Report Options

Select Configure»Report Options to specify the format of the calibration report,
the location in which to store calibration reports, and customize the report name.
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1. Select a format from the Report Type pull-down menu: Text, HTML, PDF, or MS
Word.

2. Click the folder icon to the right of the Report Generator Output File Directory
field to browse for the directory in which to store your calibration reports.

3. Highlight the name of the directory.

4. Click Select Cur Dir.

5. Click OK.
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Tips  Enable
View calibration report at the end of the
calibration  if
you want the report to display automatically
when the calibration completes.

Enable
Allow editing of DUT notes when reports
are merged
to edit the DUT notes when merging reports.

Flexible Report Names

Click the Report File Names tab to customize the report name.
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1. Select an item for the report name using the Items pull-down menu.

2. Click Add to add the selected item to the report name. Use the Remove and
Remove All buttons to remove any selected items from the report name.

3. Repeat steps 1 and 2 for each item you want to add to the report name.
4. Select a separating character for the report name using the Item Separator

pull-down menu.

5. Click Move Up and Move Down to arrange the items in the Item Order text
box. The preview text box displays the customized report name.
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Tip  Click Restore Defaults to restore the
default report name.

Configuring Database Options

Select Configure»Database options to specify the database that stores
calibration reports. The Configure Report Database window contains the path to the
location where the database is stored.

To modify this path, complete the following steps:

1. Click the folder icon to the right of the path.
2. Search for the new file location.
3. Highlight the name of the file.

4. Click Open.

5. Click OK.

Configuring Users

Select Configure»Users to open the Configure Users window, from which you can
add new users and edit or delete current users.

Adding a New User

1. Click Add.
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2. Enter the User Name, Full Name, Comment, and Password in the appropriate
fields.

3. Re-enter the Password in the Confirm Password field.
4. Select a profile in the User Profile control to define an initial set of privileges

for a new user. The following table shows specific user privileges.

Feature Non-Administrator
Privilege

Administrator
Privilege

Create/edit/delete users No Yes
Configure file locations No Yes
Delete calibration reports No Yes

5. Click OK to save your changes.

Deleting a User

To delete a user name, complete the following steps:

1. Highlight the name of the user you want to remove.

2. Click Delete.

3. Click OK to save your changes.
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Note  You cannot delete your own login
information.

Editing a User Profile

To modify the login name, comments, or password associated with the selected
user, complete the following steps:

1. Click Edit.
2. Modify the information you want to change.

3. Click OK to save your changes.

Note  The Advanced button displays the Edit
Flags dialog box, which contains TestStand
property flags you can modify. You need to
configure these property flags only when you
are developing a relatively sophisticated
custom type in TestStand. The Advanced
button has no function in Calibration Executive.

Viewing a Calibration Report

You can view calibration reports in one of the following formats: text, HTML, PDF, or
Microsoft Word.

1. Select View»Calibration Reports to display the Calibration Reports
window, shown in the following figure.

ni.com36

Calibration Executive



2. Highlight the report you want to view from the displayed list.

3. Use the Report Type field to select Text, PDF, HTML, or MS Word report type.

4. Click View to display the report or click Delete to remove the report from the
database.

5. Click Close to close the Calibration Reports window and return to the main
Calibration Executive user interface.

Tip  The brackets around a column header
indicate that the reports are sorted on this field.
To sort on a different field, click on another
column header.

Launching a Calibration Procedure
This tutorial teaches you how to launch a calibration procedure in NI Calibration
Executive. In this tutorial, you will launch a calibration procedure by completing the
following tasks:

1. Launching the Setup Wizard
2. Entering the Customer Information
3. Selecting the Required Standards
4. Entering Environmental Information and Selecting Options
5. Selecting a DUT
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6. Run-time Dialog Boxes

Next Step
1. Launching the Setup Wizard

1. Launching the Setup Wizard
Complete the following steps to launch the setup wizard.

1. Select the device to calibrate from the Device Types control in the upper left
corner of the user interface.
Devices connected to your system that have calibration procedure support are
listed at the top of the drop-down list. Devices that appear in the list below
the break line are selectable, but they reflect devices that are not
automatically detected at the launch of Calibration Executive.

2. Click the Calibrate button to launch the setup wizard.

Previous Step
Launching a
Calibration Procedure

Next Step
2. Entering the
Customer Information

2. Entering the Customer Information
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1. Enter the customer name and address. Calibration Executive stores this
information and retrieves it the next time you begin to enter the customer
name.

Note  To delete a customer entry, begin
typing the name in the Customer Name
field. When a list of matching names
appears, use the up/down arrow keys to
highlight the name, as shown in the figure
below, and press the Delete key. Click
Delete to delete the customer entry from
the database.

2. (Optional) Enter information in the Work Order Number field.

3. Enter any additional relevant information in the Notes field.
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4. Click Next.

Previous Step
1. Launching the Setup
Wizard

Next Step
3. Selecting the
Required Standards

3. Selecting the Required Standards

Note  Each calibration instrument required for
your selected calibration procedure has its own
page. You must complete the required
information for each instrument before
proceeding to the next page.

1. Select a supported instrument from the supplied list.

Note  The drop-down list contains several
models for each category of instrument;
however, only a model specified or
recommended in the DUT's procedure has
been validated to work for that procedure.
Unvalidated models may not be supported
in software for the DUT's procedure and may
error out during operation.

ni.com40

Calibration Executive



Note  If you select
Enter Unsupported Instrument, you are
prompted to enter additional information
about the instrument in the Description
field.

2. Enter a tracking number for the instrument in the Tracking No. field.

3. Select a calibration interval for the instrument from the Calibration Interval
list box.

4. Select the calibration due date for the selected instrument in the Calibration
Due Date field. You can either enter the date from the keyboard or click the
calendar icon  to launch the time and date dialog box, shown in the
following figure.

5. Enter any additional comments in the Notes field.

6. Select the correct address of the instrument from the Address list.

Note  The Address list displays all detected
instruments that are connected to your
computer. If the address of your instrument
is not displayed in the list, ensure that the
instrument is connected and click Refresh.
To run a calibration procedure in automated
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mode, you must select the instrument and
its address.

7. Click Next to proceed to the next Required Standards page.

8. When you complete all required standards information, click Next.

Previous Step
2. Entering the
Customer Information

Next Step
4. Entering
Environmental
Information and
Selecting Options

Configuring and Using Tracking Numbers

Tracking Numbers
Calibration Executive version 4.1 or later enables you to maintain and view
customer-specific tracking numbers using the calibration setup wizard. Two
configuration files are created upon the initial launch of Calibration Executive:

■ TrackingNumberFilePath.ini - Contains path information for the tracking
number configuration file. The user can modify the key under the
[TrackingNumberFilePath] section to set the path of the TrackingNumbers.ini
file.
■ TrackingNumbers.ini - Contains hardware serial numbers paired with
associated tracking numbers, if entered, in the format SerialNumber =
TrackingNumber.

When you add or edit a tracking number for a device in the DUT Selection page,
Calibration Executive stores the number in the TrackingNumbers.ini configuration
file. Tracking numbers created or edited in the wizard are committed to the
configuration file when the user clicks Finish and the calibration session is
initiated.

Setting Up and Configuring the Tracking Number File
The TrackingNumberPath.ini configuration file holds a single key under the section
[TrackingNumberFilePath], which allows the user to set the path of the tracking
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number configuration file. The default location as created is Path = C:\<Program
Files>\National Instruments\Calibration Executive\Config\TrackingNumbers.ini.

The tracking number configuration file can be renamed and relocated as the user
chooses, including network locations accessible to multiple computers, and will
function as long as the correct path is defined in the TrackingNumberFilePath.ini
file. The file must remain a configuration file with the .ini file extension.

The tracking number configuration file organizes tracking numbers through pairs of
SerialNumber = TrackingNumber, where the serial number is as detected in NI-MAX
by the system API without leading zeroes.

Note  Although the serial number detected by
NI-MAX typically matches the serial number
printed on the board, it is possible for
discrepancies to occur. If you experience issues
with tracking numbers that are out of sync, or if
serial numbers displayed in Calibration
Executive do not match those recorded, you
might need to modify the serial number in the
tracking number configuration file.

You can manually enter device serial numbers in to the tracking number
configuration file in one of two ways by editing the TrackingNumberPath.ini
configuration file directly:

■ Enter the serial number/tracking number pair under the [UserDefined]
section. The setup wizard in Calibration Executive processes tracking numbers
associated with detected serial numbers from this section first.
■ Enter or modify the associated entry under the section labeled with the
product name (for example, [NI PXIe-4464]).

Once a calibration setup is completed, entries in the [UserDefined] section are
automatically moved into sections organized by product name. The following
example shows serial number/tracking number pairs for two devices in the
[UserDefined] section:
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[UserDefined]
18D771D = "8888"
1A3215A = "1111"

After these devices are configured through the setup wizard, the tracking numbers
are moved to a product section, and the information is deleted from the
[UserDefined] section:

[NI PXIe-4464]
18D771D = "8888"
1A3215A = "1111"

[UserDefined]

In addition, you can create and edit tracking numbers on the DUT Selection page of
the calibration setup wizard. Tracking numbers created or edited in the setup wizard
are only committed to the tracking number configuration file once the calibration
session is initiated after the user clicks Finish. Tracking numbers created in the
wizard are written directly to the specific product name section of the tracking
number configuration file.

4. Entering Environmental Information and Selecting Options
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Calibration Conditions

1. Enter the ambient temperature.
2. Select the temperature unit (Celsius or Fahrenheit).
3. Enter the % Humidity.

Note  The information you enter in the
Calibration Conditions section is included
on the calibration report.

Procedure Options

1. Select the Run Mode. The modes available vary depending on the device you
are calibrating. Refer to the calibration procedure for your device for details
on available run modes.

a. Verify Only - This run mode verifies the device against the
specifications. This mode does not adjust the performance of the
device.

b. Verify & Adjust - This run mode verifies the device against the
As Found specifications. The procedure then executes a series of steps
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to adjust the performance of the device. The device will then be re-
verified against the As Left specifications.

Devices that support this run mode may also support the Optional
Adjust feature. Optional Adjust is a feature that allows you to terminate
a procedure being executed in Verify & Adjust run mode after the initial
verify. After the initial verify, test results are displayed in a pop-up
window, allowing you to terminate the procedure without running
adjust and generating a report with the initial verify results.

If supported, Verify & Adjust also enables you to choose when the device
gets adjusted, based on the pass/fail status of the initial As Found pass
status. Options include the following:

■ Default (Dialog) - After the As Found verification, a dialog appears
that lets you choose whether or not to adjust based on the results of
the As Found results.
■ Force Adjust on Pass - Adjustment will be performed regardless of
the pass/fail status of the As Found verification.
■ Skip Adjust on Pass - If the As Found verification passes the As
Left limits, the device will not be adjusted. A failure automatically
forces an adjustment.

c. Adjust Only - This run mode adjusts only the device performance and
does not generate any report. This run mode can be used if a Verify Only
has already been performed.

Note  NI recommends performing
adjustment every calibration cycle to ensure
that the device is operating within
specification. Devices must be adjusted prior
to re-verification in order to reset the
calibration cycle.

Note  The run mode and adjust options
selected for the procedure are stored and
retrieved the next time the procedure is run
until the mode is changed.
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2. Complete any additional fields as needed.

Note  Not all device procedures present the
same Procedure Options. Make sure you
complete all required information before
proceeding to the next step.

3. Click Next.

Previous Step
3. Selecting the
Required Standards

Next Step
5. Selecting a DUT

5. Selecting a DUT

The DUT Selection page displays DUTs detected on the system in an array format,
which enables back-to-back calibration of multiple instances of the same model
DUTs. Note that the array displays a maximum of four rows of devices at a time; use
the scroll bar to view any additional DUTs detected on the system.

The array contains a row for each instance of the DUT detected on the system, and
each row contains the following fields:
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■ DUT - Row identifier for an instance of the device under test (DUT). Select
this box to enable calibration. Deselect this box to exclude the device from
calibration.
■ Device ID - Unique identifier of the DUT in this device row.
■ Name - Model name of the DUT in this device row.
■ Location - Discernable location (if available) of the DUT in this device row.
■ Serial No - Hardware serial number of the DUT in this device row.
■ Tracking No - Customer-specific tracking number. Values entered into this
field will be cached and recorded for future use.

In the DUT Selection page, do the following:

1. Select the DUT row for each device instance to be calibrated, or select
Calibrate? to toggle the selection of all instances.

2. Unless autopopulated, enter the serial number of each device to be calibrated
in the appropriate Serial No fields.

3. (Optional) Enter a tracking number for each device to be calibrated in the
appropriate Tracking No fields.

4. Click Finish to launch the calibration procedure.

Device Identifiers

After you launch the procedure, a dialog box appears in which you must enter a
device identifier such as a device number, device name, or resource name. This
dialog box varies depending on which device you are calibrating.

Note  In some device procedures, the device
identifier is required in the DUT Selection page,
rather than in a separate dialog box.

This device identifier is assigned by Measurement & Automation Explorer (MAX)
when you configure the hardware in MAX. To find this information, launch MAX,
expand Devices and Interfaces, and locate the device in the list.
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Previous Step
4. Entering
Environmental
Information and
Selecting Options

Next Step
6. Run-Time Dialog
Boxes

6. Run-Time Dialog Boxes
Run-Time dialog boxes are shown and described below.

Test Failed Dialog Box

During the initial verify, the dialog boxes shown below will appear for As Found and
As Left limit failures, respectively, and will describe the details of each failure. As Left
limit failures will not result in an overall test failure during the initial verify, but will
allow the user to retry the test point if failures are a result of setup issues.
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Retry the existing test point or continue to the next test point by selecting one of the
available buttons.

■ Retry Test: Retries the current test point. Allows you to check your
connections if you believe the failure to be a connection issue.
■ Display Last Dialog: Displays the last dialog box to aid in checking your
connections.
■ Terminate Procedure: Terminates the procedure.

All of the Continue options will accept the current failure and continue to the next
test point.

■ Alert on Failure: Do not suppress future failures.
■ Suppress Alerts for the Present Test: Suppress all failure only for the
current test. The next tests will display this dialog box for any failures.
■ Suppress Alerts for All Tests: This option will suppress all alerts.
■ Suppress Alerts for "As Left" Failures for Present Test: This option
will suppress alerts only for As Left test limit failures for the present test, but
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will continue to display failures for As Found test limits. This option is not
available during re-verify.
■ Suppress Alerts for "As Left" Failures for All Tests: This option will
suppress only alerts for As Left test limit failures for all tests, but will continue
to display failures for As Found test limits. This option is not available during
re-verify.

Execute Adjust Steps? Dialog Box

The Execute Adjust Steps? dialog box will appear after verification and detail
whether or not there were test point failures.
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Either dialog box provides the following options:

■ Adjust and Re-verify
■ Generate Report

Previous Step
5. Selecting a DUT

Calibration Reports
Calibration reports are stored in a central database. Calibration Executive retrieves
the data from this database and displays the report in the format you have selected
(text, HTML, PDF, Microsoft Word, or Microsoft Excel). Each report includes the
customer name and address, the purchase order number, calibration date, and DUT
type (model) for the calibrated device, as well as similar information about the
calibration standards used.

It is recommended that you use a 64-bit version of Microsoft Excel to generate
calibration reports in Excel format.

Calibration Executive requires a 64-bit Java Runtime Environment (JRE) to generate
reports in RTF (Microsoft Word) and PDF formats. The most recent version of the JRE
is available at https://java.com. You must use a 64-bit browser to access the 64-bit
download.
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Note  Refer to the Calibration Executive
Readme for details about supported versions of
the JRE. Note that some uses of Java may
require a separate license.

Reading the Calibration Report

The following terms are common to all of the calibration report tables.

■ Low Limit is the lower limit of the reading allowable to meet
specifications.
■ High Limit is the upper limit allowable to meet specifications.
■ Reading is the actual reading taken during the calibration procedure. For
an ideal calibration, the reading value always lies between the upper and
lower limits. If the reading is outside this range, the calibration fails.
■ As Found Status details the response of the DUT prior to any adjustment,
or as received at the calibration lab. Therefore, if the DUT is out of calibration,
the As Found tests can fail.
■ As Left Status represents the DUT performance after calibration, or as the
DUT left the calibration lab. The DUT should pass the As Left tests.

Note  The calibration report includes an error
message if an error or a termination occurred
that may have invalidated the calibration data.

Calibration Reports Database
The calibration reports database, a Microsoft Access database, contains all of the
results for each calibration. By default, the database is named Calibration Rep
orts.mdb and is stored in the Databases folder of Calibration Executive. If you
installed Calibration Executive in the default location, this database is located in C:
\Program Files\National Instruments\Calibration Executive\
DataBases. The calibration reports database responds to standard structured
query language (SQL) commands. Therefore, you can write your own report-
handling routine to retrieve data from the database. You could write such a routine
in LabVIEW, C, visual Basic, or any other language that supports SQL
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communication. The calibration reports database consists of the following seven
tables:

■ ASSET contains all of the information about the calibrated DUT.
■ CALIBRATION_DATA contains all the data acquired during the calibration, as
well as the uncertainty data, if applicable.
■ CUSTOMER contains all of the customer information associated with the
DUT.
■ ENGINE contains information about the operator and the calibration date.
■ ENVIRONMENT contains information about the environmental conditions
during the calibration.
■ STANDARD contains information about the standards, such as calibrators
and DMMs, that were used during the calibration.
■ REPORT keeps track of all of the relationships between the six other tables.

The REPORT table contains a search value for each of the other tables. The search
value is a unique number that represents all of the data associated with a specific
calibration report—all the customer information, calibration condition information,
and so on. To locate data associated with a given calibration, you must first find the
search value for that data in the REPORT table. When you know the search value
number for a specific report, you can search for a match to that number in the other
search value fields of the table.

Example: Using the Calibration Reports Database

Suppose you want to find out all of the calibration-related information—the
calibration conditions, DUT specifics, calibration data, and so on—about the devices
you have calibrated for a customer. To find that information, start by opening the
CUSTOMER table and locating the name of your client. In the same row that the
customer name appears, there is a numeric search value. With that search value,
you can open the REPORT table and use that value to search the other tables for
that customer’s asset information, calibration data, and so on. You could also use
that search value to write your own asset-handling routine.
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Saving a Calibration Reports Database Backup

This feature allows you to save a secondary copy of the current calibration reports
database.

1. Select Configure»Report Database Backup Copy.
2. Click the folder icon to the right of the Path to Report Database Backup field to

browse for the directory in which to store your calibration reports database
backup.

Note  Do not select the same directory
where the original report database is saved.

3. Highlight the name of the directory.

4. Click Open.
5. Select the desired Calibration Executive version from the Select Version pull-

down menu.

Note  If you select Calibration Executive 3.2
or prior, the report files do not support the
Driver Information section. So this
information will not be in the source report
database.

6. Click Save As.

Merge Reports

1. Select View»Calibration Reports to display the Calibration Reports
window.

2. Highlight the two reports you want to merge. If the two reports appear to be
compatible, the Merge Report button enables as shown in the following figure.

Note  The Merge Reports button enabling is
only a pre-checking function and does not
mean that two reports can be merged.
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3. Select the report format using the Report Type pull-down menu.

4. Click Merge Reports to merge the two highlighted reports.

5. Edit the DUT notes if you enabled Allow Editing of the DUT notes when
reports are merged on the Configuring Report Options window.

6. If the two reports are compatible, the merged report appears at the top of the
report list, as shown in the following figure. If the reports are not compatible
an error appears.

Edit Report Attributes
Calibration Executive allows you to edit the following report attributes:
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■ DUT Notes
■ Recommended Calibration Due Dates

Edit DUT Notes

1. Select View»Calibration Reports to display the Calibration Reports
window.

2. Select a calibration report from the list.

3. Click the Edit menu and select DUT Notes.

Note  Edit menu options are disabled if
more than one report is selected.

4. In the Edit DUT Notes dialog, modify the DUT notes as needed, and click OK.

Note  Content in the DUT Notes text box must
not exceed 255 characters.

Notice  If you overwrite existing content in the
DUT Notes field and click OK, the content will
be lost. Be sure to review any current note
before you modify or delete it, as it may include
important information about the procedure.

Edit Recommended Calibration Due Dates

1. Select View»Calibration Reports to display the Calibration Reports
window.

2. Select a calibration report from the list.

3. Click the Edit menu and select Recommended Calibration Due Date.

Note  Edit menu options are disabled if
more than one report is selected.

4. In the Edit Cal Due Date dialog box, enter a new date in the New
Recommended Calibration Due Date field or click the calendar icon to
select a new date and time.

5. Click OK when the correct date is set in the Edit Cal Due Date dialog box.
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Note  The Recommended Calibration Due Date
is displayed only on certificates generated from
a report configuration in which this feature is
enabled. For more information, see "Show the
Recommended Calibration Due Date" in
Custom Report Configurator.

Notice  When you click OK in the Edit Cal Due
Date dialog box, the previous Recommended
Calibration Due Date is permanently
overwritten and therefore lost. Be sure to review
the date before modify the
New Recommended Calibration Due Date
field.

Custom Report Configurator
Calibration Executive provides Custom Report Configurator tools that enable you to
create custom report types for calibration certificates in PDF format, in addition to
the default calibration report types.

Note  Java SE Runtime Environment and a PDF
reader application (Adobe Acrobat Reader is
recommended) must be installed on your
system to generate custom reports.

To display the Custom Report Configurator dialog:

1. Select View»Calibration Reports to display the Calibration Reports
window.
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2. In the lower right corner of the Calibration Reports window, click Config
Reports.

Note  The Custom Report Configurator is only
available when you run Calibration Executive in
administrator mode. Refer to Frequently Asked
Questions for more information.
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From the Custom Report Configurator window, you can do the following:

■ Create a new report configuration
■ Import a report configuration
■ Rename or Delete a report configuration
■ Preview a report configuration
■ Customize report configuration design
■ Configure supported uncertainty formats and uncertainty and guard band
display options

Create a New Report Configuration
To create a new report configuration:

1. In the Custom Report Configurator window, click Create New.
2. In the Generate New Report Configuration dialog, provide a name for the new

report configuration and click Create.
The report configuration name must meet the following criteria:

■ Cannot be longer than 60 characters.
■ Characters \, /, :, *, ?, ", <, >, and | are not allowed.
■ Cannot end with a period (.).
■ Cannot be an empty string.

3. At the confirmation message, click OK.

Set Report Configurations to Active/Inactive

New and imported report configurations are automatically set to Active, making
the configurations available in the Report Type list on the Calibration Reports
window. To keep a report configuration but remove it from the Report Type list in
Calibration Reports, select the configuration in the Custom Report Types list, and
deselect the Active checkbox.
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Select a Calibration Certificate Title

When you create or import a report configuration, you can select one of the
following certificate titles, or specify your own title:

■ Traceable Calibration Certificate
■ Compliant Calibration Certificate
■ Accredited Calibration Certificate

Note  The Custom Report Configurator does not
retain custom titles that you manually enter in
the Calibration Certificate Title field as
selectable options.

Show the Recommended Calibration Due Date

To show the recommended calibration due date on a custom report configuration,
select the Show on Certificates option in the Recommended Calibration Due
Date section. For more information about specifying the calibration due date, refer
to Edit Report Attributes in this document.

Import an Existing Report Configuration
Imported configuration(s) are copied into the Report Configuration Location folder
and are set to Active.

1. In the Custom Report Configurator window, click Import.
2. Browse to the folder that contains the report configuration you want to

import.

Note  To import multiple report
configurations, select the folder that
contains all of the report configurations that
you want to import into the Custom Report
Configurator.

3. Select the folder, and click Select Folder.

4. At the confirmation message, select OK.
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Note  Refer to Frequently Asked Questions for
more information.

Rename or Delete Report Configurations

Rename a Report Configuration

To rename a report configuration:

1. Select the report you want to rename in the Custom Report Types field.

2. Click Rename. The Rename Report Configuration dialog box opens.

3. Enter a new name in the field, and click Rename.

The new name cannot be the same as the previous name, and it is subject to the
same criteria as when you created the report configuration.

Delete a Report Configuration

To delete a report configuration:

1. Select the report configuration you want to delete in the Custom Report
Types list.

2. Click Delete.

3. At the confirmation message, click Yes to delete the report configuration.

Note  Deleting a report configuration removes
the configuration from the Custom Report
Configurator, but it does not delete the files. A
deleted report configuration can be imported
back into the Custom Report Configurator.

Customize Report Configuration Design
You can customize the following elements of a report configuration by modifying
the corresponding images or text files.

■ Lab Logo (LogoImage.jpg)
■ Miscellaneous Accreditation Images (TopRightImage.jpg)
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■ Certificate Text Body (BodyText.txt)
■ Lab Manager and Lab Info (LabInfo.txt)
■ Lab Manager Signature (Labsign.jpg)
■ Miscellaneous Affiliation Images (BottomRightImage.jpg)

Configure Uncertainty and Guard Band Options

Select Supported Uncertainty Formats

Select one or more of the following Supported Uncertainty Formats options to
specify which types of uncertainties are enabled for the selected custom report:

■ None: Custom report supports formats that do not include any uncertainty
or guard banding details.
■ Legacy: Custom report supports uncertainty format used prior to
Calibration Executive 6.0, which does not include any guard banding details
■ 2.0: Custom report supports uncertainty format used in Calibration
Executive 6.0 and later, which includes uncertainty and guard banding details.

By default, a custom report supports all uncertainty formats. Uncertainty format
options can be useful when you configure the display options for different types of
reports in the Calibration Reports window.

To determine the uncertainty format used with each report, look for the value in the
Unc Format column in the Calibration Reports window.

Configure Uncertainty and Guard Band Display Options

When you select a custom report that was generated with a supported uncertainty
format, the Reading Display Options, Uncertainty Display Options, and
Guardband Display Options tabs appear at the lower left corner of the
Calibration Reports window.

Uncertainty and Guard band settings are only available with Custom Reports, and
the settings are cached separately for each custom report type. These options can
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be modified only when you are logged into Calibration Executive as an
administrator.

Reading Display Options
Reading display options enable you to toggle whether the As Found and As Left
verify limits are displayed on the custom report. Leave the limits selected to display
them on the report; deselect the limits to hide them. Reading display options are
supported for all uncertainty formats.

Uncertainty Display Options
Uncertainty display options enable you to toggle whether uncertainty values and
uncertainty notes for As Found and As Left appear in the custom report. Leave the
options selected to display them on the report, deselect the options to hide them.
Uncertainty display options are supported for all uncertainty formats.

Guard Band Display Options
Guard band display options are only supported for 2.0 format uncertainties. Guard
band display options include the following:

■ Guardband: Displays the guard band value.
■ Accept Limits: Displays the guard banded accept limits.
■ TUR: Displays the calculated test uncertainty ratio (TUR), formatted as
TUR:1 in the report.
■ Conditional P/F?: Displays the passed/failed conditional character for
each test point and for the overall results when a reading is determined to be
either a conditional pass or a conditional fail.
■ Guardband Notes: Displays the description for the guard band methods
used in the report, which appears in the report header. If displayed, this also
includes the related callout for each method next to the passed/failed result
of each test point that was guard banded.
■ Max TUR: A value of 0 indicates that all TURs are displayed. Otherwise, any
TURs greater than the value specified in this field are hidden.
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■ Hide Zero Guardband: When selected, if a guard band calculation results
in a value of 0.0, the guard band is displayed as "-" in the report, and the
related guard band method callout is not displayed next to the Passed/Failed
result.

Additional Options

Preview a Report Configuration

To preview a report configuration, select the report in the Custom Report Types
list, and click Preview. A temporary PDF file is generated, displaying the selected
report configuration.

Configure Page Size

You can specify the page size for your custom reports. Available page sizes are
Letter (8.5 in. x 11 in.) and A4 (210 mm x 297 mm). The default page size is Letter.

To configure the page size for your custom reports:

1. Press Ctrl + P or click the Options menu, and select Set Page Size to open
the Configure Page Size dialog.

2. Select one of the options, and then click OK.

Change the Location of the Report Configuration

By default, the report configuration location is C:\Users\<username>\Docume
nts\CalibrationExecutive\CustomReports.

To change the location of the report configuration files:

1. Press Ctrl + L or click the Options menu and select Change Report
Configuration Location.

2. Browse to the location where you want to save report configurations, and
then select Select Folder.

Frequently Asked Questions
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Q:  What happens if I try to edit a report configuration in a location that is currently
opened by another user on a shared network?

A:  When you click Config Reports, a Locked Report Configuration Location
message is displayed. In this dialog box, you can select one of the following actions:

■ Cancel — Close the Custom Report Configurator to avoid corruption of
configuration files. The Report Configuration Location remains the
configured path, and you can use the available report formats from the
Calibration Reports window.
■ Change Location — Select a different Report Configuration Location to
edit.
■ Force Unlock — Unlock the current Report Configuration Location. This
permits two or more users to edit the configurations at the same time;
however, files may become corrupted. Choose this option only if you are sure
that no one else is editing configurations at this location.

Q:  What happens if I try to import a configuration folder that has the same name as
a configuration folder that already exists in my specified location?

A:  During import, a pop-up informs you that there is a conflict with the imported
configuration. Do one of the following:

■ Click Yes to overwrite the existing configuration with the configuration you
are importing.
■ Click No to import the new configuration with _Import# appended to the
end of the configuration name.
The number at the end indicates the instance of the imported configuration (_
Import1, _Import2, and so on). After import, you can rename the
configuration (select the configuration and click Rename).

Q:  Why is there a Migrate Reports button instead of the Config Reports button?

A:  Calibration Executive 6.0 uses a new custom reports stylesheet which is required
to utilize guard banding features for 2.0 uncertainty formats.
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Calibration Executive attempts to migrate stylesheets from your existing custom
reports automatically, but if any of the stylesheets have been modified manually,
they cannot be migrated without losing information. You may continue to use your
reports without migrating, but you will be unable to use any of the new custom
report functionality.

When you click Migrate, Calibration Executive prompts you to overwrite your
modified stylesheets. If you continue, you will lose these modifications and will
need to recreate any customizations you wish to retain. Calibration Executive does
save a backup of your stylesheet, which you can use for reference.

Uncertainty Reporting
Measurement uncertainty is an estimate of the range of values about the measured
value within which the accepted value is believed to lie. A total uncertainty value
represents the combination of a measure of the random error and estimated
bounds of the systematic error and considers all factors that contribute to the
measurement uncertainty. For detailed information about measurement
uncertainty, refer to ANSI/NCSL Z540-2-1997, U.S. Guide to the Expression of
Uncertainty in Measurement.

Calibration Executive provides tools that enable a laboratory to manage the
uncertainties for each test point of a procedure based on their lab capabilities, and
to capture uncertainties in reports.

Uncertainties can also be used to calculate guard banding that can be applied to
each test point at runtime and in the report. Refer to Measurement Guard Banding
for more details on guard banding.

Displaying Measurement Uncertainty in Calibration Executive Reports

In Calibration Executive, use the Uncertainty Management utility to display
uncertainties associated with procedures and to include uncertainties and guard
banding in reports. Users with Administrator privileges can access this utility from
the Calibration Reports window.

Complete the following steps to launch the Uncertainty Management utility.
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1. Select View»Calibration Reports.

2. On the Calibration Reports window, click Manage Uncertainty.

Use the Uncertainty Export/Import window to export a template that you can use to
edit uncertainties and guard bands for each test point in the procedure. Import the
edited values to an uncertainties database, which appends the uncertainties to
future runs of the procedure.
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Exporting and Editing Uncertainty Templates

Export an uncertainty template from an existing report for a procedure that has
completed without terminating. You cannot export an uncertainty template if a
procedure does not have a completed run with a report.

There are two types of uncertainty templates.

■ Legacy: Templates exported prior to Calibration Executive v. 6.0, or for any
procedures without reports generated in Calibration Executive 6.0 or later.
Legacy (1.0) templates do not include any guard banding details.
■ 2.0: Templates exported for procedures with reports generated in
Calibration Executive v. 6.0 or later. The 2.0 templates include all uncertainty
and guard band fields.

Complete the following steps to export an uncertainty template.

1. In the Calibration Reports window, click Manage Uncertainty.

2. From the Uncertainty List in the Uncertainty Export/Import window, select
the device you want to use for export.

3. Select Operate»Export to File or right-click the device name and select
Export Template.

4. In the Select Export Folder dialog box, select the location to save the exported
file, and use the File Type to Export drop-down to specify the file type.
Calibration Executive supports the following template formats:

■ .xlsx (Single Workbook) is the recommended format. This format
(Office Open XML Spreadsheet) is compatible with many spreadsheet
editors, such as Microsoft Excel 2007 SP3 or later, Apache OpenOffice, and
Google Sheets.

Note  For procedures with more than 1000
test points, uncertainties are exported to a
CSV file; refer to the XLSX file for
instructions to copy the data manually into
the XLSX file. The Open XML parser that
Calibration Executive uses is limited to
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procedures with fewer than 1000 test
points.

■ .csv (comma-delimited) format generates a single CSV file with all test
points listed as comma-separated values, which can then be edited with a
variety of text and spreadsheet editors.
■ .txt (tab-delimited) format generates a single TXT file with all test points
listed as tab-separated values, which can then be edited with a variety of
text and spreadsheet editors.
■ .xlsx (Legacy Workbook / Device) is a deprecated format that was
used prior to Calibration Executive version 6.0. This file format is not
supported for exporting 2.0 version uncertainty templates.

The exported files include instructions for how to add uncertainties.

5. Click Done to return to the Calibration Reports window.

Complete the following steps to edit an uncertainty template.

1. Locate the folder where you saved the uncertainty template. The default path
begins with C:\Program Files\National Instruments\Calibra
tion Executive\Uncertainty\.

2. Open the template, and edit the appropriate fields to add uncertainties.
Refer to Legacy and 2.0 Fields and 2.0-Only Fields for information about
template fields that can be edited.

3. Save the updated uncertainty template.

Legacy and 2.0 Fields
The following uncertainty data fields from the Legacy and 2.0 templates are
editable:

■ Uncertainty Version: This field is populated with 1.0 by default for new
uncertainty exports You can change this to any string up to 40 characters in
length. Use this field for traceability and to store multiple unique uncertainties
in your database. This field is displayed in the Uncertainty Version section of
your report.
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■ Uncertainty (dbl): Enter a numeric value that represents the uncertainty
to display on your report. Enter 0 or leave the field blank if you want only to
display the notes field. The uncertainty value is displayed in scientific format
using two digits of precision. The digits of precision for the reading and limits
fields will be scaled to match the least significant digit of the uncertainty for
each new run of the procedure.
For example, if the uncertainty value for a test point is 0.0012 V, the
uncertainty value will be displayed on the report as 1.2E-3 V. The readings
and limits will subsequently display with 4 digits of precision, for example, 1.
1234 V.

■ Uncertainty Units: If left blank, the units are assumed to be base
International System of Units (SI). For example, if the limits units are mV, then
these units will be populated as V when imported. If you manually enter units,
and they are not entered as base units, then the uncertainty value and the
units will be converted to base units on import. If the manual base SI units do
not match the base SI units of the reading, then the digits of precision will not
be scaled automatically, and the default from the procedure will be used.
■ As Found Uncertainty Notes: Free text field; the notes are appended to
the as found uncertainty value before being displayed on the report.
■ As Left Uncertainty Notes: Free text field; the notes are appended to the
as left uncertainty value before being displayed on the report.

2.0-Only Fields
The following uncertainty data fields from the 2.0 templates are editable:

■ As Found/As Left Guardband Type:

■ none
■ method 5
■ method 6
■ method 6 linear
■ method 6 db
■ method 6 dbv
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■ custom_<name>

■ As Found/As Left Modifiers: See Measurement Guard Banding for details
about how Calibration Executive uses the values in this field. Use a semicolon
(;) to separate multiple modifiers contained in this field. For example, custom
val=1.23E-2;UL.

■ customval = <value>, where <value> is a floating point numeric (e.g., 1.2
34) or an exponential (e.g., 1.23E-6)
■ UL (Only the upper limit is valid)
■ LL (Only the lower limit is valid)
■ nominal = <value> is a floating point numeric (e.g., 1.234) or an
exponential (e.g., 1.23E-6)

■ nominal=1.0E-1 — If you do not specify units, they are assumed to
be equivalent to the limits unit without an SI prefix. That is, if the limits
unit column contains mV, then the nominal value is assumed to be
1.0E-1 V and will be applied to the TUR formulas with this magnitude.
■ nominal=1.0E-1 mV — If you specify units as in this example, then
you may also specify an SI prefix. This can make it easier to compare
the nominal value to the limits or values with the same prefix. At
runtime, the prefix is taken into account and the value is converted to
match the magnitude of the limits unit.

■ CMC (dbl): CMC defines the Scope of Accreditation. If this value is larger
than the Uncertainty, it is logged as the uncertainty with the report. This value
is not used in guard band calculations.

Note  The maximum number of combined
characters for Uncertainty,
Uncertainty Units, and Notes is 50
characters. Uncertainty data is truncated upon
import if it exceeds 50 characters. You must
enter at least two characters; fewer than two
characters will not be displayed and may affect
the formatting of the report.
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Importing Uncertainties from a Template File

After you have edited the template file, import the values to the uncertainties
database. Calibration Executive imports only the values in uncertainty data fields,
but many of the other fields are used as reference and should not be modified.
When you import uncertainties from an Open XML spreadsheet and use a formula to
calculate your uncertainty, only the resulting value is imported into the database.
Calibration Executive supports only formulas resulting in numeric or text values.

Complete the following steps to import uncertainties.

1. From the Calibration Reports window, click Manage Uncertainty.

2. In the Uncertainty Export/Import window, select Operate»Import from
File, and browse to the location of the uncertainty template you want to
import.

3. Select the template and click OK.

4. In the Uncertainty Export/Import window, click Done.

Once the uncertainties have been imported to the database, the template file is no
longer needed, but could be useful later for tracking purposes.

Updating Guard Band Notes

Use guard band notes are used to describe the guard band method in the
calibration certificate. Calibration Executive adds the notes to the calibration
certificate when you run the procedure. You can edit guard band note descriptions
and report text for both built-in and custom guard band methods.

To view the Guardband Notes table, select Operate»Edit Guardband Notes
from the menu bar on the Uncertainty Export/Import window.

To edit a Description or Report Text field, right-click the text and select Edit
Guardband Description or Edit Guardband Notes.

To add a custom guard band, right-click a line of text and select Insert New
Custom Guardband. After you enter the Tag Name, you can edit the description
and the report text.
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To delete a custom guard band, right-click the guard band and select Delete
Custom Guardband. You cannot delete built-in guard band methods.

Updating Uncertainty Version and Notes

Update uncertainty versions and uncertainty notes directly from the Uncertainty
Export/Import window. Right-click the version or note you want to update, and then
follow the instructions. These fields are also available in the exported template; you
can modify the fields in the template before importing it.

Multiple Uncertainties

Import multiple versions of uncertainties for each procedure so you can use
different values under different circumstances. After importing the first version of
uncertainties, you can import additional uncertainty versions by adding a unique
version to the template worksheet each time you import the file. Calibration
Executive adds the values to the database and the new version appears in the list of
uncertainties on the Uncertainty Export/Import window.

Adding Uncertainties to a Report

After you add the uncertainties for a procedure, use the Options and Environmental
Information page in the setup wizard to select the version of uncertainties to display
on the report. The Uncertainty Version selection box lists all active versions,
along with an option to not report the uncertainty.
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If your station does not require uncertainties, disable the Uncertainty Version
control by toggling the global uncertainties option under Configure»Report
Options.

Modifying Uncertainties for a Procedure

If you need to modify the uncertainties for a procedure, change and re-import the
previous template or create a new template that is pre-loaded with the current
uncertainties. For Legacy uncertainties, you can create a new template only if a valid
report exists on the station, similar to the requirement for creating the original
template. You do not need a report to export 2.0 uncertainties. To export a 2.0
format uncertainty, select Operate»Export to File, or right-click the uncertainty
and select Export.

Deleting Uncertainties

To delete uncertainties, select Operate»Delete Items. Calibration Executive
displays all uncertainties stored in the database. Select the uncertainties you want
to delete and click Delete. Alternatively, you can right-click an uncertainty you want
to delete and select Delete Uncertainty from DB.
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Notice  Calibration Executive does not create a
backup of the deleted files.

Updating Uncertainties on Existing Reports

NI recommends that you add uncertainties by selecting the appropriate uncertainty
before running a procedure. However, you can generate a report with a different set
of uncertainties from the Calibration Reports window.

In the Calibration Reports window, use the Uncertainty Version control to select
which uncertainty version should be displayed on the report. The default is the
version with which the report was originally generated.

Notice  If you choose to display an uncertainty
that is different from the original, beware of
these potential issues:

■ The digits of precision of the readings
and limits will not be changed from the
original report. This may result in an
undesired discrepancy.
■ You will not be able to display guard
band information on your report because
guard band details are determined at
runtime and they will not be re-
calculated.

Importing Uncertainties for New Procedure Versions

When upgrading Calibration Executive, procedure versions may change if the
procedure has been modified. If this happens, the uncertainties for the previous
versions of the procedure will not be compatible with the new versions, and you will
need to import a new version of the uncertainties. To do this, each new version of a
procedure requires that you generate a new report first, to generate an accurate
template.

If you need to add uncertainties for multiple versions of a procedure, then you must
create and import a separate template for each version.
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You can determine the procedure version of your stored uncertainty by viewing this
information in the Uncertainty Management utility. To check the current procedure
version, select the device from the Device Types control, and then select
Help»About Procedure. The About Procedure dialog box displays the procedure
name, version of the procedure, and a change list.

Uncertainty Database Options

Use the Uncertainty Management Export/Import window to specify or change the
location of the uncertainty database. YOu can set the location to a networked
location that multiple systems can share.

Uncertainties developed on other systems can also be imported into the local
system using menu options in the Uncertainty Management Export/Import window.

Related Topics
Measurement Guard Banding and TUR Support

Custom Report Configurator

Example: Calculating the Uncertainty for a Test Point

Example: Calculating the Uncertainty for a Test Point
The following example is the uncertainty calculation for the PCI-MIO-16XE-10 at the
9.98 V analog input Test Point, 20 V range, bipolar mode (±10 V), using a Fluke 5720A
calibrator that was calibrated one year ago.

■

Calibrator uncertainty
The specification for the Fluke 5720A calibrator at 1 year, 95% confidence level
(k = 1.96 for normal distribution) is 3.5 ppm + 2.5 µV.

■
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Resolution of device

■

Noise and other Type A uncertainty
Standard deviation from 10,000 measurements was 207 µV.

■

Combined standard uncertainty
Use the square root of sum of squares method.

■
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Final expanded uncertainty
To convert into 95% confidence level, multiply the standard uncertainty by the
coverage factor.

±177 µV is the value printed on the calibration report.

Measurement Guard Banding and TUR Support
The guard band value can be calculated at runtime using different methods, and
then applied at runtime to the upper and lower limits to determine if a reading
should be represented as Pass, Fail, or Conditional. The figures below illustrate how
guard banding is applied to the limits to determine how the results of the reading
should be represented.

Statement of Conformity

When a statement of conformity to a specification is provided, NI uses decision rules
and considers the level of risk to determine conformance with the agreed
specification.

By default, the decision rule for test points is ILAC-G8:09/2019 section 4.2.1, Binary
Statement for Simple Acceptance Rule (w=0).
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For test points with double-sided limits, a guard band is applied if the TUR is less
than 4:1. For test points with a single-sided limit, a guard band is always applied. For
test points where a guard band is applied (as noted in the status column), the
decision rule is ILACG8:09/2019 4.2.3, Non-binary Statement with Guard Band.

Guard Band and TUR Calculations Supported by Calibration Executive

For all guard band methods, see the formulas below for the Acceptance Limits and
Conditional Pass/Fail Limits calculations.

On the uncertainty worksheet, you can specify whether to apply guard band to only
the upper or only the lower limit by adding the modifier "UL" or "LL" to the As-
Found or As-Left Modifiers columns. By default, the guard band is applied to both
upper and lower limits.

Built-in Guard Band and TUR Calculations
ANSI/NCSL Z540.3-2006 is the American national standard for the calibration of
measurement and test equipment. The ANSI/NCSL Z540.3 standard recommends six
methods to calculate and apply guard band to ensure a probability of false accepts
(PFA) of ≤2%. ANSI/NCSL Z540.3-2006 Method 5 and Method 6 described in the
standard Appendix A are built into Calibration Executive.
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In Calibration Executive, the lookup name method5 uses a formula that complies
with ANSI/NCSL Z540.3-2006 Method 5 to calculate guard bands. This method sets
the guard band to be equal to the measurement uncertainty for each test point.

The method6 lookup names in Calibration Executive apply to formulas that comply
with Z540.3-2006 Method 6. For method6, calculations vary depending on the
uncertainty units.

For test points that have valid upper and lower limits, and uncertainty values that
are > 0, the Test Uncertainty Ratio (TUR) will be calculated automatically and will be
available on custom reports when using the 2.0 uncertainty template. Use the "UL"
and "LL" modifiers on the uncertainty worksheet to configure valid limits. The TUR
calculation depends on the uncertainty units (Linear, dB, or dBv). The following
table describes the Method 6 calculations and TUR calculations according to the
uncertainty units.

Uncertainty Unit Lookup Name Formulas
dB method6_db Pass/Acceptance Limit Formula

s:

Fail Limit Formulas:
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dBv method6_dbv Pass/Acceptance Limit Formula
s:

Fail Limit Formulas:

Units other than
dB and dBv

method6_linear
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A- = Lower Pass/Acceptance Limit
A+ = Upper Pass/Acceptance Limit
Nom = Nominal Value
F- = Lower Fail Limit
F+ = Upper Fail Limit
Spec- = Lower Specification Limit
Spec+ = Upper Specification Limit
U- = Lower Uncertainty
U+ = Upper Uncertainty
LL = Lower Limit
UL = Upper Limit
TUR = Test Uncertainty Ratio

When using the value method6, the uncertainty worksheet automatically selects
the correct formula based on the uncertainty units. The method 6 formulas in the
table are only applied when both the upper limit and lower limit are valid, and when
the calculated Test Uncertainty Ratio (TUR) is determined to be ≤ 4. For values
greater that 4, the calculated guard band is determined to be 0.

If a nominal value (Nom) is not specified, Calibration Executive uses a default
nominal value:

Custom Guard Band Calculations
In addition to the built-in guard bands, you can add user-defined custom guard
bands, which modify the limits by a fixed value that is specified for each test point.

When a custom guard band is added, the prefix Custom_ is added to the user-
provided tag name to form the Lookup ID for the custom guard band. For example, if
you insert a new custom guard band and enter the tag name NewCalc, the Lookup
ID for the guard band becomes Custom_NewCalc.

In this way, you can define a custom description for the guard band to display on the
report. You must configure the guard band notes from within the Calibration
Executive application.
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Conditional Pass Runtime and Reporting Behavior

Many runtime and reporting behaviors in Calibration Executive are evaluated as
simply "Passed" or "Failed" as long as the result falls within the specified range.
However, you can configure runtime options to specify whether a conditional pass
should evaluate to "Passed" or "Failed" for these specific behaviors.

To configure the execution and reporting behavior for a Conditional Pass:

1. From the toolbar in the main Calibration Executive window, select
Configure»Runtime Options.

2. Select an option to specify whether a Conditional Pass is a Runtime Pass or a
Runtime Fail.

By default, Calibration Executive evaluates a conditional pass as a runtime fail. This
is equivalent to using the Accept Limits that are calculated from the guard band to
dictate the passed failed behavior.

The following tables show the result type for specific behaviors when guard banding
is taking into consideration. A Binary type means that the result will be either
"Passed" or "Failed." Conditional means that a double dagger symbol (‡) will be
appended to the "Passed" or "Failed" result.

Runtime Status and Behavior
Behavior Result Type (Binary or Conditional)
Failed Test Point Dialog Display Condition Binary
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Step message log pass/fail status Conditional
Test step pass/fail result in execution dialog Binary
Overall test result dialog Binary

Printed Report Status
Behavior Result Type (Binary or Conditional)
Overall As Found Result Conditional
Overall As Left Result Binary
Individual Test Point Result (as found and as left
)

Conditional

Device Calibration Procedures
The following links provide more information about running specific calibration
procedures.

C Series Devices
■ NI 9201
■ NI 9202
■ NI 9203
■ NI 9205
■ NI 9206
■ NI 9207
■ NI 9208
■ NI 9209
■ NI 9210
■ NI 9211
■ NI 9212
■ TB-9212
■ NI 9213
■ NI 9214
■ TB-9214
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9201_9221.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9202.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9203.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9205_9206.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9205_9206.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9207.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9208.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9209.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9210.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9211.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9212.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_tb-9212.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9213.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9214.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_tb9214.html


■ NI 9215
■ NI 9216/9226
■ NI 9217
■ NI 9218
■ NI 9219
■ NI 9220
■ NI 9221
■ NI 9222
■ NI 9223
■ NI 9224
■ NI 9225
■ NI 9227
■ NI 9228
■ NI 9229
■ NI 9230
■ NI 9231
■ NI 9232
■ NI 9234
■ NI 9235
■ NI 9236
■ NI 9237
■ NI 9238
■ NI 9239
■ NI 9242/9244
■ NI 9246/9247
■ NI 9250/9251
■ NI 9252
■ NI 9260
■ NI 9262/9263/9264/9265
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9215.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9216_9226.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9217.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9218.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9219.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9220.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9201_9221.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9222_9223.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9222_9223.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9224_9228.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9225_9229_9239.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9227.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9224_9228.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9225_9229_9239.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9230_9232.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9231.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9230_9232.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9234.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9235_9236.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9235_9236.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9237.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9238.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9225_9229_9239.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9242_9244.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9246_9247.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9250_9251.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9252.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9260.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9263_9264_9265.html


■ NI 9266
■ NI 9269
■ NI 9361

Counter/Timer Devices
■ PXIe-6614
■ NI 6624
■ NI 6652/6653/6672
■ PXIe-6674T
■ PXI-6683/6683H

Data Acquisition (DAQ) Devices

Analog Output
■ NI 6703/6704
■ NI 6711/6713
■ NI 6722/6723
■ NI 6731/6733
■ PCIe-6738
■ PXIe-6738/6739

CompactDAQ
■ cDAQ-9171
■ cDAQ-9174
■ cDAQ-9178
■ cDAQ-9179
■ cDAQ-9181
■ cDAQ-9184
■ cDAQ-9185
■ cDAQ-9188
■ cDAQ-9189
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9266.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9269.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_9361.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6614.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6624.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_665x-6672.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6674t.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6683_6683h.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_670x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_671x_673x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_671x_673x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_671x_673x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6738_6739.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6738_6739.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html


■ cDAQ-9191

DSA
■ USB-4431/4432
■ NI 4461/4462/4465
■ PXIe-4463
■ PXIe-4464
■ NI 4472/4474/4472B
■ PXIe-4480/4481
■ NI 4492/4495/4496/4497/4498/4499
■ PXIe-4610

FieldDAQ
■ FD-11613/11614

MIO 62xx Models (formerly M Series)
■ USB-6210/6211/6212/6215/6216/6218
■ NI 6220/6221/6224/6225/6229
■ NI 6230/6232/6233/6236/6238/6239
■ NI 6250/6251/6254/6255/6259
■ NI 6280/6281/6284/6289

R Series
■ NI 7841R/7842R
■ NI 7845R/7846R/7855R/7856R
■ NI 7851R/7852R/7853R/7854R
■ PXIe-7847R
■ PXIe-7857R
■ PXIe-7858R

S Series
■ NI 6110/6111/6115
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_cdaq.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_443x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4461_4462.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4463.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4464.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_447x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4480_4481.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_449x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4610.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_11613_11614.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_isolated_mseries.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_78xxr.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html


■ NI 6120/6122/6123
■ PXIe-6124
■ NI 6132/6133
■ NI 6143
■ PCI-6154

SC Express
■ PXIe-4300
■ PXIe-4302/4303
■ TB-4302C
■ PXIe-4304/4305
■ PXIe-4309
■ PXIe-4310
■ PXIe-4322
■ PXIe-4330/4331
■ PXIe-4339
■ RM-4339
■ PXIe-4353
■ TC-4353
■ PXIe-4357

MIO 63xx Models (formerly X Series)
■ NI 6320
■ NI 6321
■ NI 6323
■ NI 6341
■ NI 6343
■ PXIe-6345
■ PCIe-6346
■ USB-6346
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4300.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4302_4303.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_tb-4302c.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4302_4303.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4309.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4310.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4322.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_433x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4339.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_rm-4339.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4353.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_tc4353.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4357.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html


■ NI 6349
■ NI 6351
■ NI 6353
■ PXIe-6355
■ NI 6356
■ PXIe-6358
■ NI 6361
■ NI 6363
■ PXIe-6365
■ NI 6366
■ PXIe-6368
■ PCIe-6374
■ PXIe-6375
■ PCIe-6376
■ PXIe-6376
■ PXIe-6378
■ PXIe-6386
■ PXIe-6396

Modular Instruments

DMMs
■ NI 4065
■ NI 4070
■ PXI-4071
■ NI 4072
■ PXIe-4080/4082
■ PXIe-4081

Digitizers
■ NI 5105
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6349.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_bems_series.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4065.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_407x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4071.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_407x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4080_4082.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4081.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5105.html


■ PXIe-5110/5111/5113
■ NI 5114
■ NI 5122
■ NI 5124
■ USB-5132
■ USB-5133
■ NI 5142
■ NI 5152
■ NI 5153
■ NI 5154
■ PXIe-5160
■ PXIe-5162
■ PXIe-5163
■ PXIe-5164
■ PXIe-5170R/5171R
■ PXIe-5172
■ PXIe-5185 (50 Ω)
■ PXIe-5185 (1 MΩ)
■ PXIe-5186 (50 Ω)
■ PXIe-5186 (1 MΩ)
■ PXIe-5622
■ PXIe-5624
■ NI 5922

High-Speed Digital I/O
■ PXIe-6555/6556
■ PXIe-6570/6571

Power Measurement Conditioners
■ RM-26999
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_511x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5114.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_512x5142.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_512x5142.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5132_5133.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5132_5133.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_512x5142.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5152.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5152.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5152.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5160_5162.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5160_5162.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5163.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5164.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5170_5171.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5172.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_518x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_518x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_518x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_518x.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5622.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5624.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_5922.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6555_6556.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_6570.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_26999.html


Power Supplies and SMUs
■ PXI-4110
■ PXIe-4112/4113
■ PXI-4130
■ PXI-4132
■ PXIe-4135 and PXIe-4135 (40W)
■ PXIe-4136/4137 and PXIe-4137 (40W)
■ PXIe-4138/4139 and PXIe-4139 (40W)
■ PXIe-4140/4141/4142/4143
■ PXIe-4144/4145
■ PXIe-4147
■ PXIe-4154
■ RMX-4124/4125

RF
■ PXIe-5601
■ PXIe-5606
■ PXIe-5611
■ PXIe-5644R/5646R
■ PXIe-5645R
■ NI 5650
■ NI 5651
■ NI 5652
■ PXIe-5653
■ PXIe-5654
■ PXIe-5654 (with PXIe-5696)
■ PXIe-5655
■ PXIe-5663
■ PXIe-5663E
■ PXIe-5665 (3.6 GHz)
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https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4110.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4112_4113.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4130.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4132.html
https://www.ni.com/docs/bundle/calibration-executive/page/calexec/procedure_4135.html
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■ PXIe-5665 (14 GHz)
■ PXIe-5667
■ PXIe-5668R
■ PXIe-5673
■ PXIe-5673E
■ PXIe-5693
■ PXIe-5698
■ PXIe-5840
■ PXIe-5841
■ Wireless Test System (WTS)

Signal Generators
■ NI 5402
■ PXI-5404
■ NI 5406
■ NI 5412
■ PXIe-5413
■ NI 5421
■ PXI-5422
■ PXIe-5423
■ PXIe-5433
■ NI 5441
■ PXIe-5442
■ PXIe-5450
■ PXIe-5451

PXI Chassis
■ PXIe-1092
■ PXIe-1095
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Semiconductor Test System
■ STS-DIO-01 Timing CLB

STS-DIO-01 Timing CLB Calibration Procedure
This topic contains information for calibrating the STS-DIO-01 Timing Calibration
Load Board (CLB) using Calibration Executive.

Calibration Executive Procedure Features:
Adjustment Manual Mode Selectable Test Points

Approximate Test Time:
Verify Only
35 minutes

Verify & Adjust
70 minutes

Test
Equipment

| Test
Conditions

| Device Setup | Test Limit
Equations

Test Equipment
The following table lists the test equipment required to calibrate the STS-DIO-01
Timing CLB.

Instrument Recommended Model Where Used Requirements
Oscilloscope with TDR
Module

Tektronix DSA8300 and
Tektronix 80E04

Cable Characterization
Relative Signal Path Sk
ew Verification

Relative Signal Path Sk
ew Adjustment

Bandwidth: >20 MHz
Absolute Accuracy: <17.
5 ps

Relative Accuracy: <3 p
s

External reference time
base

PXIe-6674T or Rubidiu
m Symmetricom 8400

Cable Characterization
Relative Signal Path Sk
ew Verification

Relative Signal Path Sk
ew Adjustment

10 MHz Reference: <0.1 
µHz/Hz
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2.92 mm cable Maury Microwave Stabi
lity Plus Cable SP-292-
MM-24

Cable Characterization
Relative Signal Path Sk
ew Verification

Relative Signal Path Sk
ew Adjustment

Length: <24 in
Velocity of Prop: >70%

Attenuation: <0.15 dB
@ 1 GHz

STS T1 M2 NI P/N 866286-01 Relative Signal Path Sk
ew Verification
Relative Signal Path Sk
ew Adjustment

—

BNC-to-2.92 mm adapt
er

— Cable Characterization
Relative Signal Path Sk
ew Verification

Relative Signal Path Sk
ew Adjustment

—

Air source — Relative Signal Path Sk
ew Verification
Relative Signal Path Sk
ew Adjustment

90–100 psi

5/16-inch torque wrenc
h for 2.92 mm connecti
ons

— Cable Characterization
Relative Signal Path Sk
ew Verification

Relative Signal Path Sk
ew Adjustment

8 in-lbs ± 0.5 in-lbs

Calibration Executive c
ontroller

— — Dedicated Ethernet por
t
Configured as describe
d

Test Conditions
The following setup and environmental conditions are required to ensure the STS-
DIO-01 Timing CLB meets published specifications.
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■ Keep cabling as short as possible. Long cables and wires act as antennas,
picking up extra noise that can affect measurements.
■ Use shielded copper wire for all cable connections to the DUT. Use twisted-
pair wire to eliminate noise and thermal offsets.
■ Verify that all connections, including front panel connections and screws,
are secure.
■ Maintain an ambient temperature of 23 °C ±5 °C.
■ Keep relative humidity below 80%, non-condensing.
■ Allow a warm-up time of at least 30 minutes after the DUT is connected to
the STS T1M2 frame and powered on. The warm-up time ensures that
measurement circuitry is at a stable operating temperature.
■ Ensure that the PXI chassis fan speed is set to HIGH, that the fan filters are
clean, and that the empty slots contain filler panels. For more information,
refer to the Maintain Forced-Air Cooling Note to Users document available
at ni.com/manuals.

First Time Setup
The STS and the Calibration Executive controller must be configured to
communicate directly over an Ethernet connection.

STS System
Follow the instructions to configure the system for autologin and static IP.

1. Disconnect the Ethernet connection between the STS and the Calibration
Executive controller.

2. Use a USB flash drive to copy the following to the STS:
C:\Program Files\National Instruments\Calibration Exec
utive\UserResources\STS Timing CLB\Test Fixture

3. On the STS, right-click TimingCLBFixture.bat and select Run as
administrator.

4. Accept UAC Permissions to launch as administrator.
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5. When prompted, enter the user name and password for the current login. This
will configure autologin.

6. When prompted, connect the Ethernet cable between the CalExec controller
and the STS, and press a key.

7. Once the new connection is detected, the connection will be displayed.
8. Once the IP address is set, close the command window. The batch file sets the

STS IP address to 10.0.20.30.
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Calibration Executive Controller
Follow the instructions to set the Ethernet port to static IP.

1. Disconnect the Ethernet connection between the STS and the Calibration
Executive controller.

2. On the CalExec system, execute the following script, accepting elevated
permissions:
C:\Program Files\National Instruments\Calibration Exec
utive\UserResources\STS Timing CLB\CalExec System\CalE
xecSystemOneTimeSetup.bat

3. When prompted, connect the STS to the CalExec Ethernet port and press a key
to continue.

4. When prompted, press any key to accept static IP, and then close the
command window. The script sets the return IP address for the Calibration
Executive controller to 10 10.0.20.5.
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Device Setup
1. Connect the 10 MHz clk reference from the timebase to the back of the

oscilloscope.
2. Connect the TDR module to the first block on the front of the oscilloscope.
3. Power on the STS system.
4. Check that air is connected to the STS. Follow "Air Setup Requirements" in the

STS Site Preparation and Bring Up Manual. If necessary, contact NI support
to obtain a copy of the STS Site Preparation and Bring Up Manual (P/N
377702x-01).

a. Install STS-DIO-01 Timing CLB on the top of the STS, respecting proper
orientation.

b. There are two buttons on either side of the front of the STS,
approximately two arm-lengths apart, and located towards the top.

Press the two buttons simultaneously. You should hear and see the STS-
DIO-01 device interface board (DIB) lock with air.

5. Connect the STS-DIO-01 Timing CLB to your system using an Ethernet cable.
6. Launch the Calibration Executive procedure and complete the setup wizard.
7. Connect CH 0 of the TDR module to the channel on the STS Timing CLB that is

prompted by Calibration Executive.

Figure 1 STS-DIO-01 Timing CLB Initial Test Connections
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1 External reference timebase
2 BNC-to-BNC cable
3 Oscilloscope (Tektronix DSA8300)
4 TDR Module (Tektronix 80E04)
5 GPIB cable
6 Calibration Executive controller
7 2.92 mm cable
8 BNC-to-2.92 mm adapter
9 Ethernet cable
10 Air source
11 Semiconductor Test System (STS)
12 Airhose cable
13 DUT

Test Limit Equations
Absolute Signal Path Delay Functional Test: Test Limits = Nominal ±500 ps

Relative Signal Path Skew: Test Limits = 0 ps to 30 ps

Reference Path Repeatability: Test Limits = ±3 ps

DMM Instrument Standard Considerations
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The PXI-4070/4071/4072 digital multimeter (DMM) is a recommended instrument
standard for the following devices. Do not substitute the PXIe-4080/4081/4082 as
DMM to calibrate these devices; doing so can cause the Calibration Executive
procedure to produce errors or terminate.

■ USB-5132/5133
■ NI 5402/5406
■ NI 5412/5421/5441
■ PXIe-5645R
■ NI 6731/6733
■ NI 6711/6713
■ NI 6722/6723
■ NI 9218
■ NI 9219
■ NI 9260
■ NI 9269

Glossary
            

  

Prefixes
Symbol Prefix Value
p pico 10
n nano 10
µ micro 10
m milli 10
k kilo 10
M mega 10
G giga 10
T tera 10
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Numbers/Symbols
nV nanovolts 10 volts
µV microvolts 10 volts
µΩ microohms 10 ohms
mΩ milliohms 10 ohms
MΩ megaohms 10 ohms
pA picoamps 10 amperes
nA nanoamps 10 amperes
µA microamps 10 amperes
mA milliamps 10 amperes

A
adjust To correct the measurement error of a device by

adjusting the calibration constants and storing
the new calibration constants in the EEPROM.
The host computer reads the calibration
constants and the software uses them to
compensate for errors in the data and to
present calibrated data to the user.

C
calibration A set of operations that compares the values

indicated by a measuring instrument or
measuring system to the corresponding values
realized by external standards. The result of a
calibration can be used to determine the
measurement error and can correct for it in the
adjustment process.

combined standard uncertainty The standard uncertainty of the result of a
measurement when that result is obtained from
the values of a number of other quantities,
equal to the positive square root of a sum of
terms, the terms being the variances or
covariances of these other quantities weighted
according to how the measurement result varies
with changes in these quantities.
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confidence The probability that a predicted result will
occur.

confidence level Confidence, expressed either as a fraction
(between 0 and 1) or a percentage.

coverage factor A numerical factor used as a multiplier of the
standard uncertainty to obtain an expanded
uncertainty.

D
degrees of freedom Any of the unrestricted, statistically

independent values of a sample that are used to
determine a property of the sample.

DLL Dynamic-Link Library for Windows—libraries
that link to a program and load at run time
instead of being compiled into the program.

driver Software that controls specific hardware device
such as a DAQ device or a GPIB interface board.

DUT Device Under Test—the device you are
calibrating.

E
expanded uncertainty A quantity defining an interval about the result

of a measurement that may be expected to
encompass a large fraction of the distribution of
values that could reasonably be attributed to
the quantity being measured.

G
GPIB General Purpose Interface Bus—the standard

bus used for controlling electronic instruments
with a computer.

H
HTML Hyper Text Markup Language—a hypertext

document format used on the Web.
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I
IVI Interchangeable virtual Instrumentation—an

advanced architecture for instrument drivers
that includes features such as simulation and
state caching.

M
MB Megabytes of memory.
MHz Megahertz

N
NI-VISA The National Instruments implementation of

the VISA standard—an interface-independent
software that provides a unified programming
interface for vXI, GPIB, and serial instruments.

R
resolution The smallest signal increment that can be

detected by a measurement system. Resolution
can be expressed in bits, proportions, digits, or
percent of full scale.

S
SCXI Signal Conditioning eXtensions for

Instrumentation—the National Instruments
product line for conditioning low-level signals
within an external chassis near sensors.

standard An instrument used in calibration such as a
calibrator, DMM, or counter.

standard uncertainty The uncertainty of the result of a measurement
expressed as a standard deviation.

structured query language (SQL) An industry-standard language for retrieving,
updating, and managing data.
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T
TestStand A test executive program that allows you to

organize and execute sequences of reusable test
modules. In Calibration Executive, TestStand
manages the calibration procedures used to
calibrate a device.

Type A evaluation (of uncertainty) A method of evaluation of uncertainty by the
statistical analysis of a series of observations.

Type B evaluation (of uncertainty) A method of evaluation of uncertainty by means
other than the statistical analysis of a series of
observations.

U
uncertainty An estimate of the range of values about the

measured value in which the accepted value is
believed to lie.

uncertainty of measurement A parameter, associated with the result of a
measurement, that characterizes the dispersion
of the values that could reasonably be
attributed to the quantity being measured.

V
verify To compare the measured performance of a

device to an external standard of known
measurement uncertainty to confirm that the
device meets or exceeds its specifications.

NI Services
NI provides global services and support as part of our commitment to your success.
Take advantage of product services in addition to training and certification
programs that meet your needs during each phase of the application life cycle; from
planning and development through deployment and ongoing maintenance.

To get started, create an account or log in to your MyNI user profile at ni.com/
myproducts and register your product.
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As a registered NI product user, you are entitled to the following benefits:

■ Access to applicable product services.
■ Easier product management with an online account.
■ Receive critical part notifications, software updates, and service expirations.

Services and Resources

■ Maintenance and Hardware Services—NI helps you identify your
systems' accuracy and reliability requirements and provides warranty,
sparing, and calibration services to help you maintain accuracy and minimize
downtime over the life of your system. Visit ni.com/services for more
information.

■ Warranty and Repair—All NI hardware features a one-year standard
warranty that is extendable up to five years. NI offers repair services
performed in a timely manner by highly trained factory technicians using
only original parts at a NI service center.
■ Calibration—Through regular calibration, you can quantify and improve
the measurement performance of an instrument. NI provides state-of-the-
art calibration services. If your product supports calibration, you can obtain
the calibration certificate for your product at ni.com/calibration.

■ System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, National Instruments Alliance
Partner members can help. To learn more, call your local NI office or visit
ni.com/alliance.
■ Training and Certification—The NI training and certification program is
the most effective way to increase application development proficiency and
productivity. Visit ni.com/training for more information.

■ The Skills Guide assists you in identifying the proficiency requirements of
your current application and gives you options for obtaining those skills
consistent with your time and budget constraints and personal learning
preferences. Visit ni.com/skills-guide to see these custom paths.
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■ NI offers courses in several languages and formats including instructor-led
classes at facilities worldwide, courses on-site at your facility, and online
courses to serve your individual needs.

■ Technical Support—Support at ni.com/support includes the following
resources:

■ Self-Help Technical Resources—Visit ni.com/support for software
drivers and updates, a searchable KnowledgeBase, product manuals, step-
by-step troubleshooting wizards, thousands of example programs, tutorials,
application notes, instrument drivers, and so on. Registered users also
receive access to the NI Discussion Forums at ni.com/forums. NI
Applications Engineers make sure every question submitted online receives
an answer.
■ Software Support Service Membership—The Standard Service
Program (SSP) is a renewable one-year subscription included with almost
every NI software product, including NI Developer Suite. This program
entitles members to direct access to NI Applications Engineers through
phone and email for one-to-one technical support, as well as exclusive
access to online training modules at ni.com/self-paced-training. NI also
offers flexible extended contract options that guarantee your SSP benefits
are available without interruption for as long as you need them. Visit
ni.com/ssp for more information.

■ Declaration of Conformity (DoC)—A DoC is our claim of compliance with
the Council of the European Communities using the manufacturer's
declaration of conformity. This system affords the user protection for
electromagnetic compatibility (EMC) and product safety. You can obtain the
DoC for your product by visiting ni.com/certification.

For information about other technical support options in your area, visit ni.com/
services or contact your local office at ni.com/contact.

You can also visit the Worldwide Offices section of ni.com/niglobal to access the
branch office websites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.
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